Голосовая связь : Digital CCS

Настройка и устранение неполадок Transparent CCS

5 апреля 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Содержание


Введение

Этот документ описывает, как настроить и устранить неполадки Протокола T-CCS.

Предварительные условия

Требования

Для использования данного документа требуется знание следующих тем:

  • Как настроить Cisco программное обеспечение IOS� для Голосовой функциональности.

Используемые компоненты

Сведения, содержащиеся в данном документе, касаются следующих версий программного и аппаратного обеспечения:

  • Cisco IOS Software Release 12.2.7a.

  • Маршрутизатор Cisco 3640.

Сведения, представленные в этом документе, были получены от устройств в специфической лабораторной среде. Все устройства, используемые в этом документе, были запущены с чистой конфигурацией (конфигурацией по умолчанию). При работе с реальной сетью необходимо полностью осознавать возможные результаты использования всех команд.

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Технические рекомендации Cisco. Условные обозначения.

Общие сведения

T-CCS позволяет установить подключение двух устройств PBX с цифровыми интерфейсами, которые используют протокол пользователя CCS или не поддерживаемый протокол CCS без необходимости интерпретации передачи сигналов CCS для обработки вызовов.

С T-CCS голосовые каналы УАТС могут быть заколочены (сделанный постоянным) и сжаты между сайтами. Сопроводительный канал сигнализации или каналы могут быть туннелированы (переданный прозрачно) по магистрали IP/FR/ATM между PBXs. Таким образом вызовы от PBXs не направлены Cisco на основе в порядке поступления вызовов, но придерживаются предварительно сконфигурированного маршрута назначению.

Существует три способа настройки для применения этой функции:

  • Пересылка кадров T-CCS

  • Clear-Channel T-CCS

  • Перекрестно подключите T-CCS

Кроссоверное подключение T-CCS возможно только для Cisco 3810 и не обсуждается в данном документе.

Матрица совместимости T-CCS

Эта таблица показывает функции T-CCS, которые могут быть настроены на различных платформах.

VoX1 Cisco 3810 Cisco 26XX/36xx/72xx
VoIP2 Clear-Channel:
  • Любой тип сигнализации CCS.
  • Любой номер каналов передачи служебных сигналов.
Clear-Channel:
  • Любой тип сигнализации CCS.
  • Любой номер каналов передачи служебных сигналов.
VoFR3 Clear-Channel:
  • Любой тип сигнализации CCS.
  • Любой номер каналов передачи служебных сигналов.
Пересылка кадров:
  • Сигнализация с помощью кадров HDLC.4
  • Только 1 канал сигнализации: E1.
  • E1 = TS16.
  • T1 = TS 24.
Перекрестная коммутация TDM5:
  • Любой тип сигнализации CCS.
  • Любой номер каналов передачи служебных сигналов.
Clear-Channel:
  • Любой тип сигнализации CCS.
  • Любой номер каналов передачи служебных сигналов.
Пересылка кадров:
  • Сигнализация с использованием кадров HDLC.
  • Каналы сигнализации = настраиваемые группы каналов для отдельных контроллеров.
VoATM6 Clear-Channel:
  • Любой тип сигнализации CCS.
  • Любой номер каналов передачи служебных сигналов.
Пересылка кадров:
  • Сигнализация с использованием кадров HDLC.
  • Только 1 канал сигнализации.
Clear-Channel:
  • Любой тип сигнализации CCS.
  • Любой номер каналов передачи служебных сигналов.
Пересылка кадров:
  • Сигнализация с использованием кадров HDLC.
  • Каналы сигнализации = настраиваемые группы каналов для отдельных контроллеров.

1. VoX = голос более чем X

2. VoIP = передача голоса по IP

3. VoFR = голос по Frame Relay

4. HDLC = High-Level Data Link Control

5. TDM = мультиплексирование с временным разделением

6. VoATM = передача голоса по ATM

Пересылка кадров T-CCS

T-CCS пересылки кадров может только использоваться для поддержки частных протоколов УАТС, где канал сигнализации или каналы с рамкой HDLC, и требуемая технология VoX является VoFR или VoATM. В этом решении кадры сигнализации HDLC инкапсулируются и передаются через группу каналов, которая настроена для сигнализации на контроллере, и таким образом обработана как последовательный интерфейс. Формирование кадров HDLC интерпретировано и понято, невзирая на то, что сообщения о передаче сигнала не. Холостые кадры пропускаются, и только фактические данные распространяются по каналу сигнализации.

T-CCS пересылки кадров внедрения

Предупреждение: ограничение CSCdt55871

Существует текущий лимит на количество используемых голосовых каналов, когда конфигурируется пересылка кадров TCCS на E1. Ограничение происходит из-за конфликта между ds0-group и диапазонами channnel-номера-группы, как объяснен в CSCdt55871 (только зарегистрированные клиенты).

Попытка настроить группу ds0, которая является +1 из ранее результаты группы входного канала в сбое, как показано ниже.

!
 controller t1 2/1 
 channel-group 0 timeslot 24 speed 64 
 ds0-group 1 timeslots 1 type ext-sig

Вышеупомянутая конфигурация приводит к сообщению об ошибках, когда группа ds0 определена, утверждая, что канал 0 уже используется, как показано здесь:

%Channel 0 already used by other group

Обходной путь должен скучать по конфликтной группе и продолжить следующий номер группы в диапазоне. Это сокращает количество конфигурируемых групп одной.

Знайте об этих точках прежде, чем внедрить T-CCS пересылки кадров:

  • T-CCS пересылки кадров должен только быть настроен, когда протокол CCS, который будет транспортироваться, использует тип HDLC формирования кадров.

  • Команда mode ccs-frame-forwarding определяет пересылку кадров CCS.

  • Dso-группа и команды ext sig определяют, какие голосовые порты должны создаваться и использоваться для транка с сигнализацией внешнего источника.

  • Команда connection trunk устанавливает постоянные голосовые каналы.

  • Команда channel-group определяет временной интервал пересылки кадров или временные интервалы.

  • T-CCS пересылки кадров не поддерживается для VoIP.

  • TS16 на E1 всегда зарезервирован для Сигнализации по выделенному каналу (CAS). При настройке другого временного интервала для CAS (как в вышеупомянутом примере), у вас тогда есть тот меньше временного интервала для голоса.

Пример конфигурации для T-CCS VoFR с переадресацией кадров

Конфигурация и тестирование сообщаемого в этом разделе были выполнены на маршрутизаторе Cisco 3640 рабочий Cisco IOS Software Release 12.2.7a. Когда сигнализация не применена на обычный временной интервал (слот 16), пример, показанный здесь, представляет ситуацию. Другой временной интервал используется здесь (слот 6) для показа универсальности функции (не применимый на Маршрутизаторе Cisco 3810).

/image/gif/paws/19087/trans_channel_signal1.gif

Действия по настройке на стороне голоса

Для настройки Стороны передачи голоса выполните эти шаги:

  1. На контроллере Т1 или Е1:

    1. Добавьте команду mode ccs frame-forwarding.

    2. Определите channel-group для каждого канала сигнализации (для Cisco 26XX и 36xx серия только; маршрутизатор Cisco 3810 автоматически создает D-канал).

    3. Определите группы ds0 для каждого голосового канала, используя тип ext-sig.

      GTP1
      controller E1 3/0
       mode ccs frame-forwarding
       channel-group 0 timeslots 6
       ds0-group 2 timeslots 2 type ext-sig
       ds0-group 3 timeslots 3 type ext-sig
      .
       ds0-group 30 timeslots 30 type ext-sig

      GTP2
      controller E1 3/0
       mode ccs frame-forwarding
       channel-group 0 timeslots 6
       ds0-group 2 timeslots 2 type ext-sig
       ds0-group 3 timeslots 3 type ext-sig
      .
       ds0-group 30 timeslots 30 type ext-sig

  2. На интерфейсе D-канала (этот последовательный интерфейс создается после настройки команды channel-group, как описано выше):

    1. Добавьте команду ccs encap frf11.

    2. Укажите канал D к идентификатору канала на Интерфейсе WAN FR при помощи команды ccs connect Serial x/y DLCI CID.

      Примечание: Для каждого D-канала должен использоваться отдельный ID, если требуется несколько сигнальных каналов. Запустите с идентификатора канала 254 и работайте назад.

      GTP1
      interface Serial3/0:0
       no ip address
       ccs encap frf11
       ccs connect Serial0/0 105 254

      GTP2
      interface Serial3/0:0
       no ip address
       ccs encap frf11
       ccs connect Serial0/0 105 254

  3. На голосовых портах:

    Добавляет связь с магистралью xxx для каждого голосового порта. Число должно соотноситься с назначением порта голосового терминала на другой стороне. Только одна сторона соединения должна задать "режим ответа".

    GTP1
    !
    voice-port 3/0:2
     timeouts wait-release 3
     connection trunk 6002
    !
    voice-port 3/0:3
     timeouts wait-release 3
     connection trunk 6003
    !
    ... [channels 4-30 the same] ...
    !
    voice-port 3/0:30
     timeouts wait-release 3
     connection trunk 6030
    !

    GTP2
    voice-port 3/0:2
     timeouts wait-release 3
     connection trunk 8002 answer-mode
    !
    voice-port 3/0:3
     timeouts wait-release 3
     connection trunk 8003 answer-mode
    !
    ... [channels 4-30 the same] ...
    !
    voice-port 3/0:30
     timeouts wait-release 3
     connection trunk 8030 answer-mode

  4. На узлах обычной телефонной сети:

    1. Добавьте Узел VoFR, который совпадает с набранным номером магистрали, и укажите его к Идентификатору Соединения канала передачи данных Frame Relay (DLCI).

    2. Добавьте одноранговое телефонное соединение к каждому голосовому порту, который соотносится с номером, набранным операторами connection trunk xxx с другой стороны.

      GTP1
      !
      dial-peer voice 8002 pots
       destination-pattern 8002
       port 3/0:2
      !
      dial-peer voice 8003 pots
       destination-pattern 8003
       port 3/0:3
      ! 
      ... [channels 4-30 the same] ...
      
      dial-peer voice 6000 vofr
       destination-pattern 6...
       session target Serial0/0 105
      !

      GTP2
      !
      dial-peer voice 6002 pots
       destination-pattern 6002
       port 3/0:2
      !
      dial-peer voice 6003 pots
       destination-pattern 6003
       port 3/0:3
      
      ... [channels 4-30 the same] ... 
      !
       dial-peer voice 8000 vofr
       destination-pattern 8...
       session target Serial1/0 105
      !

Действия по настройке с внешней стороны (WAN Side)

Для настройки Стороны WAN выполните эти шаги:

  1. Определите последовательный интерфейс Frame Relay и подчиненного интерфейс типа точка-точка с обычным VoFR.

  2. Вставьте пропускную способность для речевых данных на основе количества каналов и кодеков, используемых для голоса.

  3. Позвольте дополнительную пропускную способность в Committedinformation rate (CIR) (гарантированная скорость передачи) для канала сигнализации и других данных, которые совместно используют этот DLCI.

    GTP1
    interface Serial0/0
     no ip address
     encapsulation frame-relay
     frame-relay traffic-shaping
    !
    interface Serial0/0.1 point-to-point
     ip address 10.10.105.2 255.255.255.0
     frame-relay class voice-class
     frame-relay interface-dlci 105   
      vofr cisco
    !
    map-class frame-relay voice-class
     no frame-relay adaptive-shaping
     frame-relay cir 512000
     frame-relay bc 5120
     frame-relay be 0
     frame-relay fair-queue
     frame-relay voice bandwidth 512000
     frame-relay fragment 640
    !

    GTP2
    !
    interface Serial1/0
     no ip address
     encapsulation frame-relay
     clock rate 768000
     frame-relay traffic-shaping
     frame-relay intf-type dce
    !
    interface Serial1/0.1 point-to-point
     ip address 10.10.105.1 255.255.255.0
     frame-relay class voice-class
     frame-relay interface-dlci 105   
      vofr cisco
    !
    !
    map-class frame-relay voice-class
     no frame-relay adaptive-shaping
     frame-relay cir 512000
     frame-relay BC 5120
     frame-relay be 0
     frame-relay fair-queue
     frame-relay voice bandwidth 512000
     frame-relay fragment 640
    !

Bandwidth

Пропускная способность, обеспеченная в магистрали, должна обеспечить весь настроенный голос и каналы сигнализации. Поскольку эти настройки используют транк подключения, все результирующие голосовые и сигнальные каналы постоянно включены. Речевое обнаружение активации (VAD) предоставляет сохранения на каналах Active Voice (невзирая на то, что не при сигнализации), но VAD не становится активным, пока не установлены голосовые каналы. Таким образом, при определении исходной пропускной способности для каждого телефонного канала необходимо учитывать используемый кодек и служебную информацию заголовка. Для VoFR только пропускная способность голосовых каналов должна составляться в командах LLQ и пропускной способности для речевых данных. Пропускная способность голоса и каналов сигнализации должна составляться на FR К ИНТЕРФЕЙСУ WAN.

Устраните неполадки и проверьте T-CCS пересылки кадров

Следующие шаги помогут проверить, правильно ли работает пересылка кадров T-CSS.

  1. Контроллер E1 должен быть включен для объединения голосовых портов и их перехода в состояние ответа.

  2. Проверьте, существует ли вызов, и выделены ли корректные Цифровые процессоры сигналов (DSP) на временных интервалах.

  3. Если вызовы не в состоянии соединяться, проверьте статус настройки Постоянной виртуальной цепи (PVC) или подключение и условие точки вызова.

  4. Если команда show voice port показывает "простаивающий" и "с отключенной линией" для какого-либо временного интервала, проверьте, назначили ли связанному временному интервалу корректную версию DSP и работает правильно с командой show voice dsp.

  5. Отладка с командой debug TCCS signaling в режиме logging buffered (это - очень с интенсивной загрузкой ЦПУ).

    gtp2#show controllers e1 3/0
    E1 3/0 is up. 
      Applique type is Channelized E1 - balanced
      No alarms detected.
      alarm-trigger is not set
      Version info Firmware: 20011015, FPGA: 15
      Framing is CRC4, Line Code is HDB3, Clock Source is Line.
      Data in current interval (276 seconds elapsed):
         0 Line Code Violations, 0 Path Code Violations
         0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins
         0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs
    
    gtp2#show voice dsp
     
    DSP  DSP            DSPWARE CURR  BOOT         VOICE       PAK     TX/RX
    TYPE NUM CH CODEC   VERSION STATE STATE RST AI PORT   TS ABORT  PACK COUNT
    ==== === == ======= ======= ===== ===== === == ====== == ===== ============
    C549 000 01 g729ar8  3.4.49 busy  idle       0 3/0:18 18     0 119229/70248
    C549 000 00 g729ar8  3.4.49 busy  idle    0  0 3/0:2  02     0  41913/45414
    C549 001 01 g729ar8  3.4.49 busy  idle       0 3/0:19 19     0 119963/70535
    C549 001 00 g729ar8  3.4.49 busy  idle    0  0 3/0:3  03     0  42865/47341
    C549 002 01 g729ar8  3.4.49 busy  idle       0 3/0:20 20     0  77746/69876
    
    
    !--- This shows DSPs are being used.
    
    
    
    gtp2#show voice call summary
    
    PORT         CODEC    VAD VTSP STATE            VPM STATE
    =========   ======== === ============        ==============
    3/0:2.2       g729ar8  y  S_CONNECT             S_TRUNKED                
    3/0:3.3       g729ar8  y  S_CONNECT             S_TRUNKED                
    3/0:4.4       g729ar8  y  S_CONNECT             S_TRUNKED                
    3/0:5.5       g729ar8  y  S_CONNECT             S_TRUNKED                
    3/0:6.31      g729ar8  y  S_CONNECT             S_TRUNKED
    
    
    !--- This shows call connected.
    
    
    gtp2#show frame-relay pvc
    
    PVC Statistics for interface Serial1/0 (Frame Relay DCE)
    
                  Active     Inactive      Deleted       Static
      Local          1            0            0            0
      Switched       0            0            0            0
      Unused         0            0            0            0
    
    DLCI = 105, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, 
    INTERFACE = Serial1/0.1
    
      input pkts 1201908       output pkts 2177352      in bytes 37341051  
      out bytes 71856239       dropped pkts 0           in FECN pkts 0         
      in BECN pkts 0           out FECN pkts 0          out BECN pkts 0         
      in DE pkts 0             out DE pkts 0         
      out bcast pkts 167       out bcast bytes 48597     
      PVC create time 08:37:30, last time PVC status changed 02:47:05
      Service type VoFR-cisco
    
    
    !--- This shows Frame Relay is active.
    
    
    
    gtp2#show frame-relay fragment 
    interface   dlci  frag-type   frag-size  in-frag  out-frag   dropped-frag
    Serial1/0.1 105   VoFR-cisco  640        172      169        0    
    
    
    debug tccs signaling
    
    Log Buffer (8096 bytes):
    
    08:55:47:  282 tccs packets received from the port.
    08:55:47:  282 tccs packets received from the nework.
    08:55:47: RX from Serial3/0:0:
    08:55:47: tccs_db->vcd = 105, tccs_db->cid = 254
    08:55:47: pak->datagramsize=20
    BE C0 C0 00 FF 03 C0 21 09 48 00 0C 01 49 F3 69 00 0C 42 00 
    08:55:47:  282 tccs packets received from the port.
    08:55:47:  283 tccs packets received from the nework.
    08:55:47: RX from Serial1/0: dlci=105, cid=254, payld-type =0,
                    payld-length=188, cid_type=424
    08:55:47: datagramsize=20
    BE C0 C0 00 FF 03 C0 21 0A 48 00 0C 03 EA DF 0D 00 0C 42 00 
    08:55:50:  282 tccs packets received from the port.
    08:55:50:  284 tccs packets received from the nework.
    08:55:50: RX from Serial1/0: dlci=105, cid=254, payld-type =0,
                    payld-length=188, cid_type=424
    08:55:50: datagramsize=20
    BE C0 C0 00 FF 03 C0 21 09 48 00 0C 03 EA DF 0D 00 62 05 00 
    08:55:50:  283 tccs packets received from the port.
    08:55:50:  284 tccs packets received from the nework.
              08:55:50: RX from Serial3/0:0:
    08:55:50: tccs_db->vcd = 105, tccs_db->cid = 254
    08:55:50: pak->datagramsize=20
    BE C0 C0 00 FF 03 C0 21 0A 48 00 0C 01 49 F3 69 00 62 05 00 
    gtp2# wr t
    
    
    !--- This shows packet forwarding and receiving.
    
    

Clear-Channel Codec T-CCS

Clear-channel T-CCS применяется для поддержки частных протоколов PBX, в которых сигнальные каналы основываются на бите ABCD или протокол HDLC, или в которых в качестве технологии передачи голосовых сообщений используется VoIP. В данном решении канал сигнализации и голосовые каналы настроены как группы ds0groups и обрабатываются как голосовые вызовы.

Действительные голосовые вызовы являются постоянно подключенными магистральными соединениями и используют выбранные вами голосовые кодеки. Сигнальные каналы – это также постоянно связанные магистрали, использующие кодек свободного канала, который идентичен G.711 по размерам образца и пакета, но автоматически исключает отмену эха и VAD. Нет никакого интеллекта в программном обеспечении для знания, какие каналы являются голосовыми каналами, и которые являются каналами сигнализации. Необходимо настроить временные интервалы, передающие сигнальный трафик, для согласования с точкой вызова, которая назначает кодек очистки канала, тогда как голосовые каналы должны согласовываться с точкой вызова, шифрующей голос (G.729 и другие).

T-CCS кодека очистки канала внедрения

Знайте об этих точках перед осуществлением T-CCS clear-channel:

  • T-CCS clear-channel использоваться для любого типа цифровой сигнализации E1 или T1 (включая Формирование кадров на основе HDLC).

  • Поддерживается любое количество каналов сигнализации.

  • T-CCS clear-channel может использоваться в VoIP, VoFR или средах VoATM

  • Кодек очистки канала используется для канала сигнализации или каналов в T-CCS clear-channel.

  • VoIP — Сигнализация и пропускная способность для речевых данных должны составляться в IP RTP Priority или Организации очереди с малой задержкой (LLQ).

  • VoIPovFR/VoFR — Сигнализация и голос может быть на тот же или разделить DLCI.

  • VoFR — пропускная способность сигнализации посчитана как часть VoFR "пропускная способность для речевых данных".

  • С T-CCS clear-channel сигнализация берет 64K выделенной полосы пропускания (не включая служебную информацию пакета).

  • Команда DSO-group настраивает голос и каналы сигнализации.

  • Программное обеспечение Cisco IOS не может определить, какой именно канал сигнализации используется.

  • Тридцать один DSP требуется для использования УАТС, сигнализирующего на временном интервале 16 с 30 голосовыми портами, таким образом, два транка на E1 2MFT исчерпали бы количество DSP на NMV2 (62, требуются).

При использовании кодеков очистки канала для транспортировки трафика данных важно, чтобы синхронизировалось хронометрирование сети. Это вызвано тем, что алгоритмы DSP теряет пакеты, когда переполнение буфера происходит и использует его алгоритм автозаливки, когда недостаточные наполнения буфера происходят (прекрасный для голосового трафика, но не хорошие для трафика данных). Обе эти ситуации могут привести к отказу D-канала и перезагрузке.

Пример конфигурации Clear-Channel VoIP T-CCS

Конфигурация и тестирование T-CCS VoIP clear-channel были выполнены на Маршрутизаторе Cisco 3640 рабочий Cisco IOS Software Release 12.2.7a. В примере, показанном здесь, сигнализация не применена на обычный временной интервал (16). Другой временной интервал используется здесь (временной интервал 6) для показа универсальности функции.

/image/gif/paws/19087/trans_channel_signal2.gif

  1. На контроллере Т1 или Е1:

    Задайте группы ds0 для каждого голосового канала и оповещательного канала.

    GTP1
    controller E1 3/0
     ds0-group 0 timeslots 6 type ext-sig
     ds0-group 1 timeslots 1 type ext-sig
     ds0-group 2 timeslots 2 type ext-sig
     ds0-group 3 timeslots 3 type ext-sig
     ds0-group 4 timeslots 4 type ext-sig
     ds0-group 5 timeslots 5 type ext-sig
     ds0-group 6 timeslots 31 type ext-sig
     ds0-group 7 timeslots 7 type ext-sig
     ....
     ds0-group 30 timeslots 30 type ext-sig

    GTP2
    controller E1 3/0
     ds0-group 0 timeslots 6 type ext-sig
    
     ds0-group 1 timeslots 1 type ext-sig
     ds0-group 2 timeslots 2 type ext-sig
     ds0-group 3 timeslots 3 type ext-sig
     ds0-group 4 timeslots 4 type ext-sig
     ds0-group 5 timeslots 5 type ext-sig
     ds0-group 6 timeslots 31 type ext-sig
     ds0-group 7 timeslots 7 type ext-sig
     ....
     ds0-group 30 timeslots 30 type ext-sig

  2. На голосовых портах:

    1. Добавьте команду connection trunk xxx в конфигурацию каждого голосового порта. Число должно соотноситься с назначением порта голосового терминала на другой стороне.

    2. Добавьте команду connection trunk xxx к каждой сигнальной настройке голосового порта — количество должно совпасть с шаблоном назначения завершающегося голосового порта (узел обычной телефонной сети) с другой стороны.

    3. Только одна сторона соединения должна задать режим ответа.

      GTP1
      voice-port 3/0:0
       timeouts wait-release 3
       connection trunk 3001
      !
      voice-port 3/0:1
       timeouts wait-release 3
       connection trunk 6001
      ! 
      ... [channels 2-30 the same] ...
      !
      voice-port 3/0:30
       timeouts wait-release 3
       connection trunk 6030

      GTP2
      !
       voice-port 3/0:0
       timeouts wait-release 3
       connection trunk 5001 answer-mode
      !
       voice-port 3/0:1
       timeouts wait-release 3
       connection trunk 8001 answer-mode
      !
      ... [channels 2-30 the same] ...
      
      voice-port 3/0:30
       timeouts wait-release 3
       connection trunk 8030 answer-mode

  3. На адресуемых точках вызова:

    1. Добавьте VoIP одноранговый соединение, который совпадает с набранным номером магистрали голосовых каналов. Укажите его к IP-адресу удаленной стороны; назначьте требуемое (или по умолчанию) голосовой кодек на этой точке вызова.

    2. Добавьте VoIP одноранговый соединение, который совпадает с набранным номером магистрали каналов сигнализации. Укажите его к IP-адресу удаленной стороны; назначьте кодек очистки канала на этой точке вызова.

    3. Добавьте узлы обычной телефонной сети в каждый голосовой порт, который соответствует номеру, набранному инструкциями голосового канала с другой стороны.

      GTP1
      dial-peer voice 8001 pots
       destination-pattern 8001
       port 3/0:1
      !
      
      
      !--- Pots dial peers 8001 --- 8030 are 
      !--- configured similarly with exclusive POTS,
      !--- destination patterns and ports. These are 
      !--- associated with the voice channels.
      
      
      dial-peer voice 8030 pots
       destination-pattern 8030
       port 3/0:30
      !
      dial-peer voice 5001 pots
       destination-pattern 5001
       port 3/0:0
      
      
      !--- This is the POTS dial peer associated with 
      !--- the port connected to the local PBX 
      !--- signaling channel.
      
      
      ! 
      dial-peer voice 6000 voip
       destination-pattern 6...
       session target ipv4:10.10.105.1
      !
      dial-peer voice 3001 voip
       answer-address 5001
       destination-pattern 3001
       session target ipv4:10.10.105.1
       codec clear-channel
      
      
      !--- This is the VoIP dial peer associated 
      !--- with the destination pattern that 
      !--- connects to the remote PBX signaling 
      !--- channel port.
      
      

      GTP2
      !
      dial-peer voice 6001 pots
       destination-pattern 6001
       port 3/0:1
      !
      
      
      !--- POTS dial peers 6001 --- 6030 are 
      !--- configured similarly with exclusive POTS,
      !--- destination patterns, and ports. 
      !--- These are associated with the 
      !--- voice channels.
      
      
      dial-peer voice 6030 pots
       destination-pattern 6030
       port 3/0:30
      ! 
      dial-peer voice 3001 pots
       destination-pattern 3001
       port 3/0:0
      
      
      !--- This is the POTS dial peer associated 
      !--- with the port connected to the local PBX 
      !--- signaling channel.
      
      
      !
      dial-peer voice 8000 voip
       destination-pattern 8...
       session target ipv4:10.10.105.2
      !
      dial-peer voice 5001 voip
       answer-address 3001
       destination-pattern 5001
       session target ipv4:10.10.105.2
       codec clear-channel
      
      
      !--- This is the VoIP dial peer associated with 
      !--- the destination pattern that connects 
      !--- to the remote PBX signaling channel port.
      
      

Действия по настройке с внешней стороны (WAN Side)

Для настройки Стороны WAN выполните эти шаги:

Добавьте команду IP RTP Priority или полосу пропускания LLQ в зависимости от следующих условий:

  • Количество голосовых каналов и кодеки используются для голосовых сигналов.

  • Количество каналов сигнализации, умноженных на 80K (обработанный, поскольку вы обработали бы G.711).

GTP1
interface Multilink1
 bandwidth 512
 ip address 10.10.105.2 255.255.255.0
 ip tcp header-compression iphc-format
 no cdp enable
 ppp multilink
 ppp multilink fragment-delay 20
 ppp multilink interleave
 multilink-group 1
 ip rtp header-compression iphc-format
 ip rtp priority 16384 16383 384
!
interface Serial0/0
 no ip address
 encapsulation ppp
 no fair-queue
 ppp multilink
 multilink-group 1

GTP2
interface Multilink1
 bandwidth 512
 ip address 10.10.105.1 255.255.255.0
 ip tcp header-compression iphc-format
 no cdp enable
 ppp multilink
 ppp multilink fragment-delay 20
 ppp multilink interleave
 multilink-group 1
 ip rtp header-compression iphc-format
 ip rtp priority 16384 16383 384
!!
interface Serial1/0
 no ip address
 encapsulation ppp
 no fair-queue
 clock rate 512000
 ppp multilink
 multilink-group 1

Устраните неполадки и проверьте T-CCS Clear-Channel

Эти шаги помогают проверять, что T-CSS clear-channel работает, как он должен:

  1. Контроллер E1 должен быть включен, чтобы голосовые порты перешли в состояние "off-hook" и к ним было применено группирование магистралей.

  2. Гарантируйте, что проверки вызова существуют, и корректные DSP выделены на временных интервалах.

  3. В случае сбоя вызова проверьте конфигурацию и соединение IP, а также работу точек вызова.

  4. Если IP восстановлен после сбоя в интерфейсе или канале, то на интерфейсе контроллера нужно выполнить команду shut/no shut либо перезагрузить маршрутизатор, чтобы вновь создать магистральные подключения.

  5. Если команда show voice port показывает idle и on hook для какого-либо временного интервала, проверьте, что связанному временному интервалу назначили корректную версию DSP, и что это работает правильно с командой show voice dsp, как показано ниже.

gtp#show voice dsp

DSP  DSP            DSPWARE CURR  BOOT         VOICE      PAK       TX/RX
TYPE NUM CH CODEC   VERSION STATE STATE RST AI PORT   TS ABORT    PACK COUNT
==== === == ======= ======= ===== ===== === == ====== == =====   ============
C549 000 02 g729r8   3.4.49 busy  idle       0 3/0:25    25      0     264/2771
C549 000 01 g729r8   3.4.49 busy  idle       0 3/0:12    12      0     264/2825
C549 000 00 clear-ch 3.4.49 busy  idle    0  0 3/0:0     06      0 158036/16069


!--- The above identifies that the clear codec is used for timeslot 6.
!--- Ensure that clear codec is applied correctly against the correct timeslot.
                                                                     


gtp1#show voice port sum

PORT   CH SIG-TYPE   ADMIN OPER STATUS   STATUS   EC
====== == ========== ===== ==== ======== ======== ==
3/0:0  6     ext     up    up   trunked  trunked  y
3/0:1  1     ext     up    up   trunked  trunked  y
3/0:2  2     ext     up    up   trunked  trunked  y
3/0:3  3     ext     up    up   trunked  trunked  y


!--- This shows that the voice port used for signaling is off-hook and trunked.
 


gtp1#show voice call sum
PORT         CODEC    VAD VTSP STATE            VPM STATE
============ ======== === ============        =============
3/0:0.6       clear-ch y  S_CONNECT             S_TRUNKED
3/0:1.1       g729r8   y  S_CONNECT             S_TRUNKED
3/0:2.2       g729r8   y  S_CONNECT             S_TRUNKED
3/0:3.3       g729r8   y  S_CONNECT             S_TRUNKED
3/0:4.4       g729r8   y  S_CONNECT             S_TRUNKED
3/0:5.5       g729r8   y  S_CONNECT             S_TRUNKED
3/0:6.31      g729r8   y  S_CONNECT             S_TRUNKED
3/0:7.7       g729r8   y  S_CONNECT             S_TRUNKED


!--- This shows a signaling call in progress.

Включите RTP, сигнализирующий на AS5350 и AS5400

Для предотвращения ошибок, вызванных пакетами RTP типа полезных данных “123” на Cisco AS5350 и платформах серии AS5400, обработка сигналов RTP отключена по умолчанию. При некоторых обстоятельствах пакеты этого типа могут вызвать недопустимую ошибку адреса памяти в AS5350 и платформах серии AS5400, потенциально завершаясь катастрофическим отказом устройства.

На этих моделях можно включить обработку сигналов RTP с помощью речевой сигнализации rtp речевого fastpath, включают скрытую команду настройки. Однако, прежде чем вы включаете обработку сигналов RTP, готовите платформу для обработки пакетов RTP типа полезных данных “123” путем включения T-CCS.

После подготовки платформы можно использовать эти команды, чтобы включить или отключить обработку сигналов RTP.

  • Для включения обработки сигналов RTP используйте эту команду:

    Router(config)#voice-fastpath voice-rtp-signalling enable
    
  • Для отключения обработки сигналов RTP используйте эту команду:

    Router(config)#no voice-fastpath voice-rtp-signalling enable
    

Тестирование T-CCS (пересылка кадров и очистка канала) без PBX

В определенных ситуациях это может быть непрактично для подтверждения конфигурации T-CCS с PBXs. В этом разделе описываются метод, который включает замену PBXs с маршрутизаторами, протестировать ту сигнализацию может быть транспортировано. Поскольку используемая в PPP структура кадра схожа со структурой, используемой сигнализацией, основанной на сообщениях (например, CCS), можно использовать маршрутизаторы, настроенные для PPP, для проверки, что канал сигнализации работает. Это может быть полезно в ситуациях, где развертывания T-CCS отказали, и дополнительное доказательство необходимо, что работает канал сигнализации. (В T-CCS пересылки кадров существует отладочная информация доступный показ передачи и приема кадров. В clear-channel T-CCS нет доступных в реальном времени сведений отладки.).)

Настройте Контроллер e1 маршрутизаторов для предпочтительного канала сигнализации. Данный пример использует временной интервал 6 к принудительному ассортименту с вышеупомянутыми тестами. Настройте PPP на результирующем последовательном интерфейсе для представления трафика сигнализации.

trans_channel_signal3.gif

Маршрутизатор 1
controller E1 0
 clock source internal
 channel-group 0 timeslots 6
!
interface Serial0:0
 ip address 1.1.1.2 255.255.255.0
 encapsulation ppp

Маршрутизатор 2
controller E1 0
 clock source internal
 channel-group 0 timeslots 6
!
interface Serial0:0
 ip address 1.1.1.1 255.255.255.0
 encapsulation ppp

Типичные выходные данные с пакетами debug ppp
1d00h: Se0:0 LCP: Received id 1, sent id 1, line up
1d00h: Se0:0 PPP: I pkt type 0xC021, datagramsize 16
1d00h: Se0:0 LCP: I ECHOREQ [Open] id 2 len 12 magic 0x0676C553
1d00h: Se0:0 LCP: O ECHOREP [Open] id 2 len 12 magic 0x0917B6ED
1d00h: Se0:0 PPP: I pkt type 0x0207, datagramsize 305
1d00h: Se0:0 LCP: O ECHOREQ [Open] id 2 len 12 magic 0x0917B6ED
1d00h: Se0:0 PPP: I pkt type 0xC021, datagramsize 16
1d00h: Se0:0 LCP: I ECHOREP [Open] id 2 len 12 magic 0x0676C553
1d00h: Se0:0 LCP: Received id 2, sent id 2, line up

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения


Document ID: 19087