Качество обслуживания (QoS) : Политики QoS

Настройка параметров маркировки пакетов для постоянных виртуальных каналов, организованных по протоколу ретрансляции кадров (Frame Relay)

5 апреля 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 апреля 2015) | Отзыв


Содержание


Введение

Этот документ рассматривает поддерживаемые команды для настройки пакетной маркировки через Интерфейсы Frame Relay.

Предварительные условия

Требования

Для этого документа отсутствуют особые требования.

Используемые компоненты

Данный документ не ограничен отдельными версиями программного или аппаратного обеспечения.

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в этом документе, были запущены с чистой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд до их использования.

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Условные обозначения технических терминов Cisco.

Маркировка пакета на основе классов

Пакет на основе классов, отмечающий использование , заставил команды и другие команды Модульного качества сервиса (QoS) Интерфейс командной строки (CLI) изменять значение поля в заголовке пакета.

Текущий Cisco выпуски ПО IOS� позволяет вам делать эти действия:

  • Установите Двоичные значения приоритета IP-трафика или кодовую точку дифференцированных сервисов (DSCP) IP в IP-типе сервисов (ToS) байт.

  • Установите значение класса обслуживания (CoS) Уровня 2.

  • Привяжите локальное групповое значение QoS к пакету.

  • Изменитесь Приоритет потери ячеек (CLP) укусил установку в заголовке ATM пакета от 0 до 1.

Поддерживаются обе политики ввода и вывода. При настройке маркировки на основе классов обратите внимание на эти ограничения:

  • Политика вывода требует Frame Relay Traffic Shaping (FRTS).

  • Только Cisco IPCC Express коммутируемые по технологии переадресации пакеты поддерживается.

  • Карта политик, которая содержит команду set atm-clp , может быть подключена как политика вывода только.

Это - пример того, как установлено DSCP-значение:

Пример конфигурации - маркировка на основе классов
class-map user1
  match access-group 101
!
class-map user2
  match access-group 102
!
policy-map dscp
  class user1
    set ip dscp AF11
  class user2
    set ip dscp AF12
!
map-class frame set-dscp
  service-policy input dscp
!
int s0/0/0:0
 no ip address
 encapsulation frame-relay
 frame-relay traffic-shaping
!
int s0/0/0:0.125
 frame-relay interface-dlci 125
  class set-dscp

Настройка бита разрешения сброса

Modular QoS CLI поддерживает две команды для изменения, значение разрешения сброса (DE) укусило во Фрейме Frame Relay. Те команды являются set fr-de с формированием на основе классов и set-frde-transmit с основанным на классе применением политик.

Примечание: Команда set-frde-transmit не применяется к Трафику Frame Relay, транспортируемому через Любой транспорт по MPLS (AToM).

Поддержки Frame Relay двухуровневая схема назначения приоритета пакетов с помощью DE укусили. Первоначально, только сетевые устройства, такие как Коммутаторы Frame Relay, заставляют бит DE указывать на относительную важность кадра. В недавних Cisco IOS Software Release маршрутизаторы теперь могут установить бит DE.

Следующая схема иллюстрирует формат Фрейма Frame Relay. DE укусил, один из трех битов, которые управляют механизмами Уведомления о перегрузке Frame Relay.

/image/gif/paws/18662/config_fr_pvc.gif

Выполните эти команды для мониторинга маркировки на основе классов:

  • show policy-map interface interface-name — Отображает конфигурацию и статистику всех классов, настроенных для всей политики обслуживания на заданном интерфейсе.

  • show frame-relay pvc [количество dlci] — Отображает статистику для всех компонентов постоянной виртуальной цепи (PVC). Это включает эти статистические данные:

    • FRTS и информация о политике обслуживания

    • фрагментация

    • количество пакетов в и

    • номер кадров с Уведомлением о явной обратной перегрузке (BECN), Уведомлением о явной прямой перегрузке (FECN) и битами DE определен

Пример конфигурации - совпадающий на DE укусил
class-map match-fr-de
  match fr-de

!--- Define a class-map named “match-fr-de” to match packets with the FR DE bit set.

!
policy-map set-de
  class match-fr-de
   set ip precedence 1

!--- All packets that match the class have IP precedence set to 1.

!
map-class frame-relay pvc150
   service-policy input set-DE

!--- Apply the policy map to the map class.

!
interface Serial0.1 point-to-point
   frame-relay class pvc150
   frame-relay interface-dlci 150

!--- Associate a map class to the Frame Relay data-link connection identifier (DLCI).

Router# show policy-map interface s0.1

Serial0.1

 Service-policy input: set-prec

   Class-map: match-fr-de (match-all)
     358 packets, 103820 bytes
     30 second offered rate 18000 bps, drop rate 0 BPS  Match: fr-de
     QoS Set
       ip precedence  1
         Packets marked 359

   Class-map: class-default (match-any)
     643 packets, 186470 bytes
     30 second offered rate 32000 BPS, drop rate 0 BPS
     Match: any  (1201)

Программное обеспечение Cisco IOS версии 12.2(2)T представило поддержку для установки бита DE с опцией set-frde-transmit как часть команды политики. (Для получения дополнительной информации обратитесь к Мониторингу трафика.) Может также быть полезно установить бит DE, когда используется с механизмами ограничения скорости, как основанное на классе применение политик. Цель такой политики QoS состоит в том, чтобы передать несоответствующие пакеты с Frame Relay и установленным битом DE, так, чтобы нисходящие коммутаторы могли потенциально отбросить весь несоответствующий требованиям трафик во время условий перегрузки.

Примечание: Несмотря на то, что основанное на классе применение политик поддерживает пакетную маркировку, рекомендуется использовать эту функцию, только если необходимо отметить пакеты, чтобы избежать выполнять их через механизм алгоритма Token bucket ограничителя.

Следующий пример конфигурации использует команду политики для ограничения совокупного трафика 800 кбит/с. Весь трафик, который соответствует, передан с IP precedence 7, и весь несоответствующий требованиям трафик имеет установленный бит DE.

Пример конфигурации - установка DE укусила
policy-map set-DE
  class class-default
   police 800000 1000 1000 conform-action
   set-prec-transmit 7 exceed-action set-frde-transmit
   violate-action set-frde-transmit
!
map-class frame-relay pvc100
  frame-relay traffic-rate 1000000
  frame-relay mincir 1000000
  service-policy input set-DE
!
interface S0/0
 no ip address
 encapsulation frame-relay
 frame-relay traffic-shaping
!
interface Serial0/0.1 point-to-point
  ip address 10.1.1.1 255.255.255.252
  no ip directed-broadcast
  frame-relay class pvc100
  frame-relay interface-dlci 100

router# show policy-map set-DE

 Policy Map set-DE
    Class class-default
      police 800000 1000 1000 conform-action
      set-prec-transmit 7 exceed-action
      set-frde-transmit violate-action
      set-frde-transmit

router# show frame-relay PVC 100

PVC Statistics for interface Serial0 (Frame Relay DTE)

DLCI = 100, DLCI USAGE = LOCAL, PVC STATUS = STATIC, INTERFACE = Serial0/0.1

input pkts 0       output pkts 13000    in bytes 0
out bytes 3770000  dropped pkts 0       in FECN pkts 0
in BECN pkts 0     out FECN pkts 0      out BECN pkts 0
in DE pkts 0       out DE pkts 4447
out bcast pkts 0   out bcast bytes 0
PVC create time 00:51:50, last time PVC status changed 00:51:50

service policy set-DE

  Service-policy output: set-DE (1069)

   Class-map: class-default (match-any) (1071/2)
     11519 packets, 3340510 bytes
     30 second offered rate 1140000 BPS, drop rate 0bps
      Match: ip precedence 1  (1075)
      police:
        800000 BPS, 1000 limit, 1000 extended limit
        conformed 4448 packets, 1289920 bytes; action:
        set-prec-transmit 7
        exceeded 11 packets, 3190 bytes; action:
        set-frde-transmit
        violated 8475 packets, 2457750 bytes; action:
        set-frde-transmit
        conformed 394000 BPS, exceed 1000 BPS violate
        749000 BPS
   Output queue size 20/max total 600/drops 1451

При тестировании конфигурации обратите внимание на эту информацию:

  • Маркировка на основе классов требует скоростной маршрутизации Cisco. Выполните команду ip cef в режиме глобальной конфигурации, для включения скоростной маршрутизации Cisco, если это уже не включено.

  • Первоначально, маркировка на основе классов применилась только к пакетам, которые были коммутируемым по технологии переадресации Cisco IPCC Express. Таким образом вы не видели бы инкрементно увеличивающиеся соответствующие счетчики пакетов при использовании эхо-запроса для генерирования трафика на том же маршрутизатор, потому что такие пакеты являются процессной коммутацией.

  • Поддержка маркировки на основе классов пакетов созданный маршрутизатором представлена в программном обеспечении Cisco IOS версии 12.2 (6.8) T.

Выбор места применения политики службы

На Серии Cisco 7200, серии Cisco 2600/3600 и другом Процессоре non-Route/Switch (RSP) платформы, политика обслуживания должна быть применена в классе сопоставления; это не может быть применено непосредственно к Постоянной виртуальной сети Frame Relay PVC. Политика вывода требует FRTS, который вы включаете с командой frame-relay traffic-shaping . Эта команда настраивает очереди PVC. Таким образом политика обслуживания обычно должна быть настроена в Режиме конфигурации DLCI или в PVC.

В текущих Cisco IOS Software Release Интерфейсы Frame Relay поддерживают приложение карты политик (с командой service-policy ) к интерфейсам, подинтерфейсам и VC. Эта таблица приводит поддерживаемые комбинации политики:

Входящая политика Политика вывода
Поддерживаемый на одном логическом интерфейсе. Поддерживаемый на множественных логических интерфейсах, которые должны быть узлами, такими как множественный PVCs.

Примечание: Основной интерфейс и подинтерфейс не являются интерфейсами между равноправными узлами и не могут поддержать политику обслуживания в то же время.

Поддерживаемый на одном или двух логических интерфейсах одновременно. Допустимые сочетания:
  • PVC и основной интерфейс
  • Подинтерфейс и основной интерфейс
Недопустимые комбинации:
  • PVC и подинтерфейс
  • PVC, подинтерфейс и основной интерфейс

Первоначально, конфигурация политики обслуживания с командой набора непосредственно на основном интерфейсе не отмечала трафик подинтерфейса. Это иллюстрирует признаки этой проблемы:

Interface Serial5/1:1
no ip address
 encapsulation frame-relay
 no keepalive
 service-policy output set

!--- Avoid the placement of a service policy on a main interface.

 no fair-queue
 frame-relay class data-map
 frame-relay traffic-shaping
!
interface Serial5/1:1.1 point-to-point
 ip address 23.0.0.2 255.0.0.0
 frame-relay interface-dlci 300

giulia# show policy-map interface

 Serial5/1:1

  Service-policy output: set

    Class-map: prec-0 (match-all)
      100 packets, 10400 bytes

!--- Packets are classified correctly.

      5 minute offered rate 0 BPS, drop rate 0 BPS
      Match: ip precedence 0
      QoS Set
        ip precedence 1
          Packets marked 0

!--- No packets are marked.


    Class-map: class-default (match-any)
      0 packets, 0 bytes
      5 minute offered rate 0 BPS, drop rate 0 BPS
      Match: any

Как обходной путь, примените политику обслуживания к подинтерфейсу.

Традиционный синтаксис – перечень DE

В Cisco IOS Software Release, которые не поддерживают новый синтаксис Modular QoS CLI Cisco, можно использовать синтаксис маркировки DE традиционного синтаксиса Cisco для установки бита DE. Традиционный синтаксис использует списки DE, которые определяют характеристики пакетов для имения право на сброс, и можно также задать группы DE для определения DLCI, на который влияют.

Router(config)# frame-relay de-list list-number 
              {protocol protocol | interface typenumber} characteristic


!--- Issue this command on one line.

Можно создать списки DE на основе протокола или на интерфейсе, и на основе различных характеристик, таких как фрагментация пакета, определенный протокол управления передачей (TPC) или порт протокола пользовательских датаграмм (UDP), номер списка доступа или размер пакета. Обратитесь к команде frame-relay de-list в Справочнике по командам Глобальной сети Cisco IOS для получения дополнительной информации.

Для определения группы DE, которая задает список DE и DLCI, на который влияют выполните group-number frame-relay de-group команда dlci в режиме конфигурации интерфейса.

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения


Document ID: 18662