Cервисы организации сетевого доступа к приложениям : Cisco LocalDirector серии 400

Настройка LocalDirector и SCA 11000 для одностороннего режима прокси

5 апреля 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Cisco объявил о конце продажи для Cisco LocalDirector. "Для получения дополнительной информации см. касающиеся LocalDirector 400 Series ""Уведомления об окончании срока эксплуатации и продаж"" и ""Информационные бюллетени по продуктам (End-of-Life and End-of-Sale Notices and Product Bulletins).".


Содержание


Введение

Этот документ предоставляет пример конфигурации для Cisco LocalDirector и Акселератора контента Cisco Secure (SCA) 11000 в одностороннем режиме proxy. Односторонний режим proxy позволяет SCA завершать все сеансы Протокола SSL и инициировать запросы открытого текста на Web-сервер. Это выгодно по этим причинам:

  • Разгрузка сеансов SSL помогает уменьшать работу, которую делают Web-серверы.

  • Позволяя SCA инициировать соединение открытого текста с Web-серверами, балансировщики загрузки могут больше равномерно распределить загрузку и поддержать устойчивость на Web-сервер сервера. Это ограничивает возможность, что клиент теряет их корзину покупок во время сеанса.

Перед началом работы

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Технические рекомендации Cisco. Условные обозначения.

Предварительные условия

Для данного документа отсутствуют предварительные условия.

Используемые компоненты

Сведения в этом документе основываются на LocalDirector 430, работающем 4.2.3 и SCA 11000, работающем 3.0.5.

Сведения, представленные в этом документе, были получены от устройств в специфической лабораторной среде. Все устройства, используемые в этом документе, были запущены с чистой конфигурацией (конфигурацией по умолчанию). При работе с реальной сетью необходимо полностью осознавать возможные результаты использования всех команд.

Настройка

В этом разделе содержатся сведения о настройке функций, описанных в этом документе.

Примечание: Дополнительные сведения о командах, используемых в данном документе, можно получить с помощью средства поиска команд (только для зарегистрированных клиентов).

Схема сети

В данном документе используется сеть, изображенная на следующей схеме.

/image/gif/paws/18658/ld_sca_oap_18658.jpg

Конфигурации

Эти конфигурации используются в данном документе:

  • LocalDirector 430

  • SCA 11000

LocalDirector 430
Building configuration...
: Saved
: LocalDirector 430 Version 4.2.3
: Uptime is 0 weeks, 0 days, 1 hours, 3 minutes, 35 seconds
syslog output 20.3
no syslog console
enable password 000000000000000000000000000000 encrypted
hostname localdirector
no shutdown ethernet 0
no shutdown ethernet 1
no shutdown ethernet 2
no shutdown ethernet 3
interface ethernet 0 auto
interface ethernet 1 auto
interface ethernet 2 auto
interface ethernet 3 auto
mtu 0 1500
mtu 1 1500
mtu 2 1500
mtu 3 1500
multiring all
no secure  0
no secure  1
no secure  2
no secure  3
no ping-allow 0
no ping-allow 1
no ping-allow 2
no ping-allow 3
ip address 172.16.1.213 255.255.255.192
route 0.0.0.0 0.0.0.0 172.16.1.193 1
arp timeout 30
no rip passive
rip version 1
failover ip address 0.0.0.0
no failover
failover hellotime 30
password dfeaf10390e560aea745ccba53e044ed encrypted
snmp-server enable traps
snmp-server community public
no snmp-server contact
no snmp-server location

virtual 172.16.1.195:443:0:tcp is


!--- Virtual for the secure connection from the client
!--- to the SCA.


virtual 172.16.1.195:81:0:tcp is


!--- Virtual for the clear text communication from the
!--- SCA to the backend web server.


virtual 172.16.1.195:80:0:tcp is


!--- Virtual for regular port 80 traffic to 
!--- the web site (optional).


real 172.16.1.201:443:0:tcp is


!--- SCA.


real 172.16.1.25:80:0:tcp is


!--- Web server.


bind 172.16.1.195:443:0:tcp 172.16.1.201:443:0:tcp


!--- Binds the secure virtual to the SCA.


bind 172.16.1.195:81:0:tcp 172.16.1.25:80:0:tcp


!--- Binds the non-secure virtual to the web server.


bind 172.16.1.195:80:0:tcp 172.16.1.25:80:0:tcp


!--- Binds the regular port 80 virtual to 
!--- the web server (optional).


: end         
[OK]

SCA 11000
SCA-1# sho run
#
# Cisco CSCA Device Configuration File
#
# Written:      Sat Dec 15 07:24:13 2001
# Inxcfg:       version 2.3 build 200108071342
# Device Type:  CSS-SCA
# Device Id:    S/N 118032
# Device OS:    MaxOS version 2.5.1 build 200108071341 by Dan L. Reading

### Device ###

mode one-port


!--- Allows one-armed configuration.


ip address 172.16.1.201 netmask 255.255.255.192
hostname SCA-1
password enable "243124676824697552563169414659636C7644757033644E514B632E"
no ip domain-name
no rdate-server
timezone ""
rip
ip route 0.0.0.0 0.0.0.0 172.16.1.193 metric 1

### Interfaces ###

interface network
  auto  
end
interface server
  auto
end

### Remote Management ###

no remote-management access-list
remote-management enable

### SNMP Subsystem ###

no snmp
telnet enable
no telnet access-list
web-mgmt enable
no web-mgmt access-list

### SSL Subsystem ###

ssl
  server chiptest1 create
    ip address 172.16.1.195
    sslport 443


!--- Secure connection port.

    remoteport 81


!--- Non-secure connection port.

    key default
    cert default
    secpolicy default
    cachesize 20
    no transparent


!--- Enables proxy or non-transparent behavior.

  end
end

Проверка.

В настоящее время для этой конфигурации нет процедуры проверки.

Устранение неполадок

Для этой конфигурации в настоящее время нет сведений об устранении проблем.

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения


Document ID: 18658