Технологии коммутируемого доступа в сеть : "Технология ISDN, CAS"

Соединение BRI с PRI с использованием передачи данных вместе с голосом

20 октября 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Содержание


Введение

Этот документ предоставляет пример конфигурации для TData по Голосу (DOV), который позволяет данным передаваться по голосовому вызову с линией ISDN.

Предварительные условия

Требования

Убедитесь, что вы обеспечили выполнение следующих требований, прежде чем попробовать эту конфигурацию:

  • Версия программного обеспечения Cisco IOS 12.0

  • Cisco 5300 с четырьмя Интерфейсами первого уровня (PRI)

  • Cisco 2503 с интерфейсом (BRI)

  • Имя хоста каждой стороны

  • Пароль для проверки подлинности PPP

  • Номера телефона линий ISDN

  • IP-адреса Интерфейсов Ethernet с обеих сторон

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Условные обозначения технических терминов Cisco.

Общие сведения

DOV позволяет данным передаваться по голосовому вызову с линией ISDN. Линия ISDN может поддерживать передачу как данных, так и голоса. Два маршрутизатора, которые соединяют с линиями ISDN, как правило, используют вызовы данных (64 кбит/сек или 56 кбит/с). Предполагается, что голосовые вызовы будут создаваться телефоном или факсом. Голосовые вызовы могут также генерироваться устройством, связанным с аналоговым модемом, например, ПК, который набирает с линией PlainOld Telephone Service (POTS) (обычная телефонная сеть).

Когда разницу в стоимости между вызовом данных и голосовым вызовом рассматривают, при некоторых обстоятельствах пользователь может подключить два маршрутизатора с голосовыми вызовами с линиями ISDN, особенно. Линии ISDN обычно оплачиваются по числу звонков с учетом всех звонков (местных, междугородних и международных). В некоторых случаях стоимость голосовых вызовов ниже, чем стоимость вызовов данных.

Для маршрутизаторов для передачи с голосовыми вызовами между двумя линиями ISDN тщательная настройка необходима для создания маршрутизаторов знающими, что вызовы должны инициироваться как голосовые вызовы и что входящие голосовые вызовы должны быть обработаны как вызовы данных. С исходящей (звонящей) стороны используйте параметр "map-class" для определения вызовов как голосовых:

map-class dialer name

dialer voice-call

Этот класс схемы задает поведение и должен применяться к интерфейсам ISDN, где необходимо такое поведение. Вот пример поведения класса сопоставления на cхеме набора номеров и командах dialer string:

класс сопоставления класса адресов протокола cхемы набора номеров имя хоста названия [передавало] номер телефона

класс карты классов номера телефона строки номеронабирателя

См. Cisco Документация к программному обеспечению IOS� для полного синтаксиса этих двух команд.

На входящей (вызванной) стороне добавьте команду для данных isdn incoming-voice под Сериалом <n>:23 интерфейса. Помните, что все входящие голосовые вызовы рассматриваются как вызовы данных. Если вы также хотите поддержать модемные вызовы на той же линии ISDN, используйте функцию Менеджера пула ресурсов (RPM); иначе, можно разделить те два сервиса на две других линии ISDN с другими номерами телефона. Если эти две линии имеют тот же номер, проблемы происходят; они - часть группы последовательного поиска. Определенный интерфейс может или обработать голосовые вызовы как модемные вызовы или голосовые вызовы, как передача данных вместе с голосом звонит, но не оба.

Необходимо помнить, что метод передачи данных вместе с голосом (DOV) недостаточно надежен. Для поддержания цифрового сквозного пути необходим вызов между двумя линиями ISDN. Оборудование, линии и другие ресурсы, что использование телефонной компании для устанавливания вызовов данных и голосовой вызов обычно является тем же, но они могут быть другими. Передача оцифрованного голоса протекает более гибко, чем передача данных. В случае вызовов для передачи данных по линии ISDN телефонная сеть гарантирует транспортировку битов по цифровому пути со скоростью 64 или 56 Кбит/с. Для голосовых вызовов телефонная сеть может направить и манипулировать битовым потоком по-разному все же не, влияют на качество голосовой связи. Так как все данные повреждены, когда передается этот путь, DOV не работает с некоторыми линиями ISDN.

Настройка

Эта конфигурация использует Cisco 5300 с четырьмя Интерфейсами первого уровня (PRI) для завершения вызовов и Cisco 2503 с Интерфейсом (BRI) для инициирования вызовов. Cisco 5300 оказывает поддержку для 48 вызовов DOV, 48 модемных вызовов и 96 вызовов данных. Первые два PRI настроены для обработки голосовых вызовов как данных, и последние два настроены для обработки голосовых вызовов как модемных вызовов. Имя пользователя и пароль должно быть настроено для каждого пользователя, который набирает в. Эта конфигурация не использует Terminal Access Controller Access Control System (TACACS) (TACACS +) или Cервис RADIUS.

В этом разделе содержатся сведения о настройке функций, описанных в этом документе.

Примечание: Чтобы получить подробные сведения о командах в данном документе, используйте Средство поиска команд (только для зарегистрированных клиентов).

Схема сети

В настоящем документе используется следующая схема сети:

/image/gif/paws/14962/britopri_dov.gif

Конфигурации

Эти конфигурации используются в данном документе:

  • Маршрутизатор 1

  • Router-2

Маршрутизатор 1
!
version 12.0
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname Router1
!
aaa new-model
AAA authentication login default local
aaa authentication login CONSOLE none
aaa authentication ppp default if-needed local
enable password somethingSecret
!
username santiago password 0 letmein
username Router2 password 0 open4me2
ip subnet-zero
no ip domain-lookup
!
isdn switch-type primary-5ess
!
controller T1 0
 framing esf
 clock source line primary
 linecode b8zs
 pri-group timeslots 1-24
!
controller T1 1
 framing esf
 clock source line secondary
 linecode b8zs
 pri-group timeslots 1-24
!
controller T1 2
 framing esf
 linecode b8zs
 pri-group timeslots 1-24
!
controller T1 3
 framing esf
 linecode b8zs
 pri-group timeslots 1-24
!
interface Ethernet0
 ip address 10.10.1.1 255.255.255.0
 no ip directed-broadcast
!
interface Serial0:23
 ip unnumbered Ethernet0
 no ip directed-broadcast
 encapsulation ppp
 ip tcp header-compression passive
 dialer rotary-group 1
 dialer-group 1
 isdn switch-type primary-5ess
 isdn incoming-voice data
!
interface Serial1:23
 ip unnumbered Ethernet0
 no ip directed-broadcast
 encapsulation ppp
 ip tcp header-compression passive
 dialer rotary-group 1
 dialer-group 1
 isdn switch-type primary-5ess
 isdn incoming-voice data
!
interface Serial2:23
 ip unnumbered Ethernet0
 no ip directed-broadcast
 encapsulation ppp
 ip tcp header-compression passive
 dialer rotary-group 2
 dialer-group 1
 isdn switch-type primary-5ess
 isdn incoming-voice modem
!
interface Serial3:23
 ip unnumbered Ethernet0
 no ip directed-broadcast
 encapsulation ppp
 ip tcp header-compression passive
 dialer rotary-group 2
 dialer-group 1
 isdn switch-type primary-5ess
 isdn incoming-voice modem
!
interface FastEthernet0
 ip address 10.10.2.1 255.255.255.0
 no ip directed-broadcast
!
interface Group-Async1
 ip unnumbered Ethernet0
 no ip directed-broadcast
 encapsulation ppp
 async mode interactive
 ip tcp header-compression passive
 peer default ip address pool IPaddressPool
 no cdp enable
 ppp authentication chap
 group-range 1 48
 !
interface Dialer1
 ip unnumbered Ethernet0
 no ip directed-broadcast
 encapsulation ppp
 ip tcp header-compression passive
 dialer-group 1
 ppp authentication chap
!
interface Dialer2
 ip unnumbered Ethernet0
 no ip directed-broadcast
 encapsulation ppp
 ip tcp header-compression passive
 dialer-group 1
 peer default ip address pool IPaddressPool
 ppp authentication chap
!
ip local pool IPaddressPool 10.10.10.1 10.10.10.254
ip classless
ip route 10.8.186.128 255.255.255.240
no ip http server
!
line con 0
 login authentication CONSOLE
 transport input none
line 1 48
 autoselect during-login
 autoselect ppp
 modem Dialin
line aux 0
line vty 0 4
!
end

Router-2
!
version 12.0
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname Router2
!
aaa new-model
aaa authentication login default local
aaa authentication login CONSOLE none
aaa authentication ppp default local
enable password somethingSecret
!
username Router1 password 0 open4me2
ip subnet-zero
no ip domain-lookup
!
isdn switch-type basic-5ess
!
interface Ethernet0
 ip address 10.8.186.134 255.255.255.240
 no ip directed-broadcast
!
interface Serial0
 no ip address
 no ip directed-broadcast
 shutdown
!
interface Serial1
 no ip address
 no ip directed-broadcast
 shutdown
!
interface BRI0
 ip unnumbered Ethernet0
 no ip directed-broadcast
 encapsulation ppp
 dialer string 5555700 class DOV
 dialer load-threshold 5 outbound
 dialer-group 1
 isdn switch-type basic-5ess
 ppp authentication chap
!
ip classless
ip route 0.0.0.0 0.0.0.0 BRI0
no ip http server
!
!
map-class dialer DOV
 dialer voice-call
dialer-list 1 protocol ip permit
!
line con 0
 login authentication CONSOLE
 transport input none
line aux 0
line vty 0 4
!
end

Проверка

В настоящее время для этой конфигурации нет процедуры проверки.

Устранение неполадок

Используйте этот раздел для устранения неполадок своей конфигурации.

Команды для устранения неполадок

Средство Output Interpreter (OIT) (только для зарегистрированных клиентов) поддерживает определенные команды show. Посредством OIT можно анализировать выходные данные команд show.

Примечание: Обратитесь к документу Важная информация о командах отладки, прежде чем использовать команды debug.

  • debug dialer — Отображает информацию, который касается причины любого вызова

  • debug isdn q931 ISDN - подключения, поскольку пользователи набирают в видеть то, что происходит с вызовом ISDN, например, если отброшено соединение

  • debug ppp nego — Видит подробные данные согласования PPP

  • debug ppp chap Аутентификация Проверок

  • show isdn status Статус должен быть этим:

    layer 1 = active 
        layer 2 = MULTIPLE_FRAMES_ESTABLISHED 

    Если Уровень 1 не активен, адаптер проводного соединения или порт могут быть плохими или не включенные. Если Уровень 2 в состоянии TEI_Assign, маршрутизатор не говорит с коммутатором.

  • show user — Асинкс/синхронизированные пользователи Показов в настоящее время соединялся

  • show dialer map — После того, как ISDN - подключение сделан, он видит, была ли создана динамическая схема набора номеров. Без схемы набора номеров передача пакетов невозможна.

Устранение проблем модема

  • debug modem –, получает ли маршрутизатор правильные сигналы от внутреннего модема

  • debug modem csm — Включает управлению модемом режим отладки Модуля коммутации вызова (CSM)


Дополнительные сведения


Document ID: 14962