Технологии коммутируемого доступа в сеть : Технология DDR

Внешние соединения сервера AS5300 с использованием ISDN/Async (исходящие DDR-соединения)

20 октября 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Содержание


Введение

Эта конфигурация имеет AS5300 с четырьмя Интерфейсами первого уровня (PRI) и поддержка 96 модемных вызовов или большого числа вызовов ISDN. Это настроено с четырьмя PRI для разрешения Асинкса и Исходящих соединений ISDN. Статические cхемы набора номеров настроены на стороне набора для каждой ISDN/АСИНХРОННОГО ПОДКЛЮЧЕНИЯ. Статические IP - маршруты используются в обоих концах соединения для предотвращения необязательных служебных данных протокола динамической маршрутизации. Добавление удаленного местоположения потребовало бы добавления cхемы набора номеров, имени пользователя и статического маршрута для нового назначения на стороне набора. Все удаленные узлы имеют фиксированные IP - адреса.

Перед началом работы

Условные обозначения

Дополнительные сведения об условных обозначениях в документах см. Cisco Technical Tips Conventions.

Предварительные условия

Шаг 1 - Настраивает и проверяет, что клиенты установления внешнего телефонного соединения являются настройкой правильно.

Настройки внешнего телефонного соединения - Устройство, к которому этот AS5300 набирает:

  • PRI: Настройка Сервер доступа с PRI для исходящего Асинкса и вызовов ISDN - Использование центральный узел маршрутизатор серии AS5300 (AS5300 имени хоста) конфигурация предоставлена в документе.

  • BRI для приема входящего вызова от AS5300: Технология DDR ISDN Настройки с Профилями DDR - Использование маршрутизатор Cisco 2503 узла клиента (имя хоста remoteISDN01) конфигурация предоставлена в документе.

  • Асинкс для приема входящего вызова от AS5300: Group-Async Интерфейса Настройки с Профилями DDR - Использование маршрутизатор Cisco 2511 узла клиента (remoteAsync01 имени хоста) конфигурация предоставлен в документе

Шаг 2. Проверьте правильность функционирования каналов Telco. Можно использовать команду show isdn status, чтобы проверить, что канал BRI или PRI функционирует правильно. Дополнительную информацию см. в документе "Использование команды show isdn status для устранения неполадок BRI". Вы также должны разрешить исходящие вызовы на канале первичного интерфейса обмена (PRI) T1/E1. Обратитесь в свою телекоммуникационную компанию для проверки этой информации.

Используемые компоненты

Сведения в этом документе основаны на версиях оборудования и программного обеспечения, указанных ниже.

  • Cisco AS5300, Cisco 2511 и Cisco 2503

  • Cisco выпуск ПО IOS� 12.2 (10b)

  • Внешний асинхронный модем

Сведения, содержащиеся в данном документе, были получены с устройств в специальной лабораторной среде. Все устройства, описанные в данном документе, были запущены с конфигурацией по умолчанию. При работе с реальной сетью необходимо полностью осознавать возможные результаты использования всех команд.

Теоретические сведения

В некоторых ситуациях может быть необходимо использовать канал PRI для исходящих соединений T1/E1. Это помогает гарантировать клиенту или филиалу компании, к которому диски канала PRI T1/E1 защищенная идентификация, вместо неизвестного пользователя, набирающего в с двойным именем пользователя и паролем к сети.

Родственные продукты

Эту конфигурацию можно применять на любых маршрутизаторах с платами T1 или PRI. Следовательно, любой маршрутизатор серии AS5xxx с платами T1 или PRI может использовать эту конфигурацию. Cisco 2600 и маршрутизаторы серии "3600" могут также быть настроены для набора номера вызовов ISDN с Интерфейсной картой WAN (WIC) T1/PRI или Сетевым модулем.

Данную конфигурацию также можно использовать с портами E1 или PRI. Установите для контроллера E1 параметры линейного кодирования, формирования кадров и другие технические характеристики, предоставленные телефонной компанией. Конфигурация канала D (интерфейс Serial x: 15 для E1s) похожа на показанную ниже конфигурацию.

Настройка

В этом разделе содержатся сведения о настройке функций, описанных в этом документе. Для этой сети вам нужно придерживающееся:

  • Тип коммутатора PRI, кадрирование и кодирование передачи.

  • Имена пользователя и пароли всех удаленных узлов вы будете набирать в. Даже если вы переходите, добавляют TACACS + или RADIUS позже, добавляют несколько названий к маршрутизатору для тестирования линий.

  • Схема IP-адресации.

Примечание: Поиск дополнительной информации о командах в данном документе можно выполнить с помощью средства "Command Lookup" (Поиск команд) (только для зарегистрированных клиентов).

Схема сети

В данном документе используется сетевая установка, показанная на следующей схеме.

/image/gif/paws/14960/1a.gif

Конфигурации

В данном документе используются следующие конфигурации.

AS5300
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname AS5300
!

!
username remoteISDN01 password 0 xxxx
username remoteAsync01 password 0 xxxx

!--- Usernames for local authentication of the call.
!--- The client presents the username/password 
!--- and the AS5300 authenticates the peer.
!--- This local database of usernames and passwords are 
!--- compared when chap PPP authentication is negotiated 
!--- between the AS5300 and remoteISDN01, remoteAsync01 routers.

!
isdn switch-type primary-5ess

!--- Switch-type for this AS5300. Obtain this information from the Telco.

chat-script kelly "" "atdt\T" TIMEOUT 60 CONNECT \c

!--- A chat script is a string of text that defines the handshaking 
!--- that occurs between the router and the  modem to sucessfully 
!--- handshake with the destination. 
!--- In this chat-script, "kelly" is the chat-script name.
!--- The expect string "" is the null from the destination. 
!--- And the send string "ATDT\T" is to instruct the modem 
!--- to dial the telephone number in the dialer string command, 
!--- which is 9996200 in the Interface dialer 1
!--- TIMEOUT 60 CONNECT \C - waits up to 60 seconds for the input string "CONNECT", 
!--- and \C is an escape sequence to end the chat-script.
!--- Refer to the Modem-Router Connection Guide and Chat-script for more information.

!
controller T1 0

!--- T1 PRI physical controller configuration.

 framing esf

!--- Framing for this T1 is Extended Super Frame (ESF). 
!--- Obtain this information from the Telco.

 clock source line primary

!--- T1 0 is the primary clock source for this AS5300. 
!--- Clock source must be specified for the timing 
!--- and synchronization of the T1 carrier.

 linecode b8zs

!--- Linecoding for this T1. Obtain this information from the Telco.

 pri-group timeslots 1-24

!--- For T1 PRI scenarios, all 24 T1 timeslots are assigned 
!--- as ISDN PRI channels. The router will now automatically create the 
!--- corresponding D-channel: interface Serial 0:23.

!
controller T1 1
 framing esf
 clock source line secondary 1
 linecode b8zs
 pri-group timeslots 1-24
!
controller T1 2
 framing esf
 clock source line secondary
 linecode b8zs
 pri-group timeslots 1-24
!
controller T1 3
 framing esf
 clock source line secondary
 linecode b8zs
 pri-group timeslots 1-24
!
interface Ethernet0
 ip address 171.68.186.54 255.255.255.240
 no ip directed-broadcast
!
interface Serial0:23

!--- D-channel configuration for T1 0.

 no ip address
 no ip directed-broadcast
 encapsulation ppp
 dialer rotary-group 2


!--- T1 0 is a member of rotary group 2.
!--- The rotary group configuration is in interface Dialer2.
!--- This rotary group command enables the Dialin and Dialout for ISDN calls.



 isdn switch-type primary-5ess

 isdn incoming-voice modem

!--- All incoming ISDN analog modem calls that come in 
!--- on an ISDN PRI receive signaling information 
!--- from the ISDN D channel. The D channel is used for 
!--- circuit-switched data calls and analog modem calls. 
!--- This enables all incoming ISDN voice calls to access the call 
!--- switch module and integrated modems.
!--- Calls are passed to the modem and the call negotiates the 
!--- appropriate connection with the far-end modem. 

 no cdp enable
!
interface Serial1:23
 no ip address
 no ip directed-broadcast
 encapsulation ppp
 dialer rotary-group 2
 isdn switch-type primary-5ess
 isdn incoming-voice modem
 no cdp enable
!
interface Serial2:23
 no ip address
 no ip directed-broadcast
 encapsulation ppp
 dialer rotary-group 2
 isdn switch-type primary-5ess
 isdn incoming-voice modem
 no cdp enable
!
interface Serial3:23
 no ip address
 no ip directed-broadcast
 encapsulation ppp
 dialer rotary-group 2
 isdn switch-type primary-5ess
 isdn incoming-voice modem
 no cdp enable
!
interface FastEthernet0
 no ip address
 no ip directed-broadcast
 shutdown
!
interface Group-Async1

!--- This interface is configured for Async Dialin and Dialout in the T1 PRI.
!--- Without this interface, Async calls cannot be made.

 no ip address
 no ip directed-broadcast
 async mode interactive

 dialer in-band
 
dialer rotary-group 1

!--- Group-Async 1 is a member of the rotary group.
!--- The rotary group configuration is in interface Dialer 1.

 no cdp enable

 group-range 1 96

!--- Group-range indicates the asynchronous interfaces 
!--- which come under the Group-Async interface.

!
interface Dialer1
 ip address 10.1.1.1 255.255.255.192
 no ip directed-broadcast
 encapsulation ppp
 dialer in-band

 dialer idle-timeout 600

!--- Set an idle-timeout to hold the ISDN line.
!--- Idle timeout for outgoing calls is 600 seconds (10 minutes).
!--- If the ISDN link is idle for more than 600 seconds, it will be dropped.

 dialer map ip 10.1.1.2 name remoteAsync01 modem-script kelly broadcast 9996200

!--- Dialer map statements for the remote router remoteAsync01.
!--- The name must match the one used by the remote router to identify itself.
!--- Use the modem chat script "kelly" for this connection.

 dialer-group 1

!--- Apply interesting traffic definition from the dialer-list 1.

ppp authentication chap
!
interface Dialer2

!--- The  dialer rotary-group 2 command in Int s0:23 activates the interface
!--- Dialer2 for inbound and outbound ISDN calls.

 ip address 10.1.1.65 255.255.255.192
 no ip directed-broadcast
 encapsulation ppp
 dialer in-band
 dialer idle-timeout 600
 dialer map ip 10.1.1.66 name remoteISDN01 broadcast 9996100
 dialer-group 1
 ppp authentication chap
!
no ip http server
ip classless

ip route 10.1.200.0 255.255.255.0 10.1.1.2

!--- Static route for the 10.1.200.0/24 network. 
!--- Interesting Traffic for that network
!--- will be sent to interface Dialer1 and the router 
!--- will initiate the outbound call for Asynchronous connectivity.

ip route 10.1.201.0 255.255.255.0 10.1.1.66

!--- Static route for the 10.1.201.0/24 network. 
!--- Interesting traffic for that network
!--- will be sent to interface Dialer2 and the router 
!--- will initiate the outbound call for ISDN BRI connectivity.

!
dialer-list 1 protocol ip permit

!--- Interesting traffic is defined by the Protocol IP.
!--- This is applied to interface Dialer1 and Dialer2 using the dialer-group 1 command.
!--- The specified dialer-list number must be the same 
!--- as the dialer-group number; in this example, defined to be "1."

!
line con 0
 transport input none
line 1 96
 
script dialer kelly

!--- Enables the chat script kelly configured globally.

 modem InOut
 transport preferred none
 transport output none
line aux 0
line vty 0 4
 login
!
end

remoteAsync01
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname remoteAsync01
!

!
username AS5300 password 0 xxxx

!
modemcap entry default

!--- A modemcap named "default" will be applied 
!--- to lines one through eight of Async interfaces.

!
interface Ethernet0
 ip address 10.1.200.1 255.255.255.0
 no ip directed-broadcast
!
interface Serial0
 no ip address
 no ip directed-broadcast
 shutdown
!
interface Serial1
 no ip address
 no ip directed-broadcast
 shutdown
!
interface Async1
 ip address 10.1.1.2 255.255.255.192
 no ip directed-broadcast
 encapsulation ppp
 dialer idle-timeout 600
 async mode interactive

!--- Enables the slip and ppp EXEC commands.

 ppp authentication chap
!
no ip http server
ip classless

ip route 0.0.0.0 0.0.0.0 10.1.1.1

!--- Default static route for the outgoing packets.

!
line con 0
 transport input none
line 1 8
  login local
  modem InOut
  modem autoconfigure type default

!--- Apply the modemcap "default" (configured globally) to initialize the modem.
!--- Refer to the Modem-Router Connection Guide for more information.

  transport input all
  autoselect during-login  autoselect ppp
  speed 38400
  flowcontrol hardware
line aux 0
line vty 0 4
!
end

remoteISDN01
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname remoteISDN01
!

!
username AS5300 password 0 xxxx

!--- Usernames for local authentication of the call.
!--- The client presents the username/password 
!--- and the AS5300 authenticates the peer.
!--- This local database of usernames and passwords are 
!--- compared when chap PPP authentication is negotiated 
!--- between the AS5300 and remoteISDN01 routers.

!
isdn switch-type basic-5ess

!--- Switch-type for this 2503. Obtain this information from the Telco.
.
!
interface Ethernet0
 ip address 10.1.201.1 255.255.255.0
 no ip directed-broadcast
!
interface Serial0
 no ip address
 no ip directed-broadcast
 shutdown
!
interface Serial1
 no ip address
 no ip directed-broadcast
 shutdown
!
interface BRI0
 ip address 10.1.1.66 255.255.255.192
 no ip directed-broadcast
 encapsulation ppp
 dialer idle-timeout 600
 dialer-group 1
 isdn switch-type basic-5ess
 ppp authentication chap
!
no ip http server
ip classless

ip route 0.0.0.0 0.0.0.0 10.1.1.65

!--- Default static route for the outgoing packets.

!
dialer-list 1 protocol ip permit
!
line con 0
 transport input none
line aux 0
line vty 0 4
!
end

Проверка

В этом разделе содержатся сведения, которые помогают убедиться в надлежащей работе конфигурации.

Некоторые команды show поддерживаются Средством интерпретации выходных данных(только зарегистрированные клиенты), которое позволяет просматривать аналитику выходных данных команды show.

  • команда show isdn status позволяет удостовериться, что маршрутизатор обменивается данными с ISDN-коммуникатором должным образом. В выходных данных команды проверьте наличие сообщений: Layer 1 Status is ACTIVE (Уровень 1 активен) и Layer 2 Status state = MULTIPLE_FRAME_ESTABLISHED (Состояние уровня 2 = MULTIPLE_FRAME_ESTABLISHED). Эта команда показывает также число активных вызовов.

  • show ppp multilink - отображение сведений об активных многоканальных пакетах. Эта команда служит для проверки многоканальных соединений.

  • show dialer [номер типа интерфейса] – отображается общая диагностическая информация для интерфейсов, настроенных для DDR. Если соединение прошло успешно, должно появиться сообщение Dialer state is data link layer up (Установлен канальный уровень для интерфейса номеронабирателя). Появление сообщения physical layer up (Установлен физический уровень) означает, что протокол линии успешно инициализирован, но протокол управления сетью (NСP) не готов к работе. Исходный и конечный адреса пакета, инициировавшего вызов номера, показаны в строке причины вызова. Эта команда show также отображает конфигурацию таймера и время, оставшееся до прекращения соединения.

  • show caller user username detail - показываются параметры для конкретного пользователя, такие как назначенный IP-адрес, параметры протокола PPP и связки PPP и т. д. Если данная команда не поддерживается в вашей версии программного обеспечения Cisco IOS, используйте команду "show user command".

  • команда show dialer map отображает настроенные статические и динамические карты номеронабирателей. Данная команда используется для проверки создания динамической схемы набора номеров. Без схемы набора номеров передача пакетов невозможна.

  • show isdn service - Проверять статус каналов B. (Эта команда является только для серверов доступа тем PRI/T1 поддержки контроллеры.)

  • show user - Отображать асинкс/синхронизированных пользователей в настоящее время соединялось.

Ниже приведены результаты выполнения команды show для успешных вызовов. Обратите внимание на разделы, выделенные жирным шрифтом, и комментарии в выходных данных. Сравните полученные выходные данные со следующим результатом.

Следующий результат получен прежде, чем установить соединение с маршрутизаторами remoteAsync01 и remoteISDN01.

AS5300#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     171.68.0.0/28 is subnetted, 1 subnets
C       171.68.186.48 is directly connected, Ethernet0
     10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
C       10.1.1.0/26 is directly connected, Dialer1
C       10.1.1.64/26 is directly connected, Dialer2
S       10.1.201.0/24 [1/0] via 10.1.1.66
S       10.1.200.0/24 [1/0] via 10.1.1.2

Следующий результат получен после установления соединения с маршрутизаторами remoteAsync01 и remoteISDN01.

AS5300#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     171.68.0.0/28 is subnetted, 1 subnets
C       171.68.186.48 is directly connected, Ethernet0
     10.0.0.0/8 is variably subnetted, 6 subnets, 3 masks
C       10.1.1.2/32 is directly connected, Dialer1
C       10.1.1.0/26 is directly connected, Dialer1
C       10.1.1.66/32 is directly connected, Dialer2
C       10.1.1.64/26 is directly connected, Dialer2
S       10.1.201.0/24 [1/0] via 10.1.1.66
S       10.1.200.0/24 [1/0] via 10.1.1.2


AS5300#show ip route connected
     171.68.0.0/28 is subnetted, 1 subnets
C       171.68.186.48 is directly connected, Ethernet0
     10.0.0.0/8 is variably subnetted, 6 subnets, 3 masks
C       10.1.1.2/32 is directly connected, Dialer1
C       10.1.1.0/26 is directly connected, Dialer1
C       10.1.1.66/32 is directly connected, Dialer2
C       10.1.1.64/26 is directly connected, Dialer2


AS5300#show controllers t1 0
T1 0 is up.
  Applique type is Channelized T1
  Cablelength is long gain36 0db
  No alarms detected.
  alarm-trigger is not set
  Version info of slot 0:  HW: 4, PLD Rev: 0

Manufacture Cookie Info:
   EEPROM Type 0x0001, EEPROM Version 0x01, Board ID 0x42,
   Board Hardware Version 1.32, Item Number 800-2540-02,
   Board Revision A0, Serial Number 11493161,
   PLD/ISP Version 0.0, Manufacture Date 12-Dec-1998.
 
Framing is ESF, Line Code is B8ZS, Clock Source is Line Primary.
   Data in current interval (197 seconds elapsed):
   0 Line Code Violations, 0 Path Code Violations
   0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins
   0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs

!--- Output suppressed.

AS5300#show int s0:23
Serial0:23 is up, line protocol is up (spoofing)
  Hardware is DSX1
  MTU 1500 bytes, BW 64 Kbit, DLY 20000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation PPP, loopback not set
  DTR is pulsed for 1 seconds on reset
  Last input 00:00:06, output 00:00:06, output hang never
  Last clearing of "show interface" counters 11:43:21
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: weighted fair
  Output queue: 0/1000/64/0 (size/max total/threshold/drops)
     Conversations  0/1/16 (active/max active/max total)
     Reserved Conversations 0/0 (allocated/max allocated)
     Available Bandwidth 48 kilobits/sec
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     5075 packets input, 25767 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     2 input errors, 0 CRC, 1 frame, 0 overrun, 0 ignored, 1 abort
     5073 packets output, 25904 bytes, 0 underruns
     0 output errors, 0 collisions, 13 interface resets
     0 output buffer failures, 0 output buffers swapped out
     2 carrier transitions
  Timeslot(s) Used:24, Transmitter delay is 0 flags


AS5300#show users
    Line       User       	Host(s)              Idle       Location
*  0 con 0                	idle                 00:00:00
  11 tty 11    remoteAsyn   Async interface      00:05:40   PPP: 10.1.1.2

Interface      User        Mode                     Idle     Peer Address
Se0:21       remoteISDN    Sync PPP             00:06:12   PPP: 10.1.1.66

remoteAsync01#show users
    Line       User       Host(s)              Idle       Location
*  0 con 0                idle                 00:00:00
   1 tty 1     AS5300     Async interface      00:07:27   PPP: 10.1.1.1
   2 tty 2                Modem Autoconfigure  00:00:00
   3 tty 3                Modem Autoconfigure  00:00:00
   4 tty 4                Modem Autoconfigure  00:00:01
   5 tty 5                Modem Autoconfigure  00:00:00
   6 tty 6                Modem Autoconfigure  00:00:00
   7 tty 7                Modem Autoconfigure  00:00:00
  Interface      User        Mode                     Idle     Peer Address

remoteISDN01#show users
    Line       User       Host(s)              Idle       Location
*  0 con 0                idle                 00:00:00
  Interface     User        Mode               Idle      Peer Address
  BR0:1        AS5300     Sync PPP             00:09:09   PPP: 10.1.1.65


AS5300#show isdn history
--------------------------------------------------------------------------------
                                ISDN CALL HISTORY
--------------------------------------------------------------------------------
Call History contains all active calls, and a maximum of 100 inactive calls.
Inactive call data will be retained for a maximum of 15 minutes.

--------------------------------------------------------------------------------
Call    Calling      Called       Remote  Seconds Seconds Seconds Charges
Type    Number       Number       Name    Used    Left    Idle    Units/Currency
--------------------------------------------------------------------------------

Out   ---N/A---     9996200  +oteAsync01      187                      0
Out   ---N/A---     9996200  +oteAsync01       56                      0
Out   ---N/A---     9996200  +oteAsync01      469     305     294      0
Out   ---N/A---     9996100  +moteISDN01      105     509      90      0
--------------------------------------------------------------------------------

AS5300#show isdn active
--------------------------------------------------------------------------------
                                ISDN ACTIVE CALLS
--------------------------------------------------------------------------------
Call    Calling      Called       Remote  Seconds Seconds Seconds Charges
Type    Number       Number       Name    Used    Left    Idle    Units/Currency
--------------------------------------------------------------------------------
Out   ---N/A---     9996100  +moteISDN01      152     449     150      0
Out   ---N/A---     9996200  +oteAsync01      133     491     108      0
--------------------------------------------------------------------------------


AS5300#show isdn status
Global ISDN Switchtype = primary-5ess
ISDN Serial0:23 interface
        dsl 0, interface ISDN Switchtype = primary-5ess
    Layer 1 Status:
        ACTIVE
    Layer 2 Status:
        TEI = 0, Ces = 1, SAPI = 0, State = MULTIPLE_FRAME_ESTABLISHED
    Layer 3 Status:
        2 Active Layer 3 Call(s)
        CCB:callid=809E, sapi=0, ces=0, B-chan=23, calltype=VOICE
        CCB:callid=809F, sapi=0, ces=0, B-chan=22, calltype=DATA
    Active dsl 0 CCBs = 2
    The Free Channel Mask:  0x801FFFFF
    Number of L2 Discards = 1, L2 Session ID = 10

!--- Output suppressed.


AS5300#Ping 10.1.201.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.201.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 32/33/36 ms

AS5300#Ping 10.1.200.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.200.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 128/141/148 ms

AS5300#show isdn service
PRI Channel Statistics:
ISDN Se0:23, Channel [1-24]
  Configured Isdn Interface (dsl) 0
   Channel State (0=Idle 1=Proposed 2=Busy 3=Reserved 4=Restart 5=Maint_Pend)
    Channel :  1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4
    State   :  0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 2 2 3
   Service State (0=Inservice 1=Maint 2=Outofservice)
    Channel :  1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4
    State   :  0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 2

!--- Output suppressed.


AS5300#show modem
 Codes:
   * - Modem has an active call
   C - Call in setup
   T - Back-to-Back test in progress
   R - Modem is being Reset
   p - Download request is pending and modem cannot be used for taking calls
   D - Download in progress
   B - Modem is marked bad and cannot be used for taking calls
   b - Modem is either busied out or shut-down
   d - DSP software download is required for achieving K56flex connections
   ! - Upgrade request is pending

        Avg Hold     Inc calls     Out calls    Busied   Failed    No     Succ
  Mdm     Time      Succ   Fail   Succ   Fail    Out      Dial   Answer   Pct.
  1/0   00:00:00       0      0      0      0       0        0       0      0%
  1/1   00:00:00       0      0      0      0       0        0       0      0%
  1/2   00:00:00       0      0      0      0       0        0       0      0%
  1/3   00:00:00       0      0      0      0       0        0       0      0%
  1/4   00:00:00       0      0      0      0       0        0       0      0%
  1/5   00:00:00       0      0      0      0       0        0       0      0%
  1/6   00:00:00       0      0      0      0       0        0       0      0%
  1/7   00:00:00       0      0      0      0       0        0       0      0%
  1/8   00:00:00       0      0      0      0       0        0       0      0%
  1/9   00:00:00       0      0      0      0       0        0       0      0%
* 1/10  00:02:21       0      0      5      5       0        0       0     50%
  1/11  00:03:11       0      0     23      6       0        0       0     79%
  1/12  00:00:00       0      0      0      0       0        0       0      0%
  1/13  00:00:00       0      0      0      0       0        0       0      0%
  1/14  00:00:00       0      0      0      0       0        0       0      0%

!--- Output suppressed.

Устранение неполадок

В этом разделе описывается процесс устранения неполадок конфигурации.

Ресурсы для устранения неполадок

Команды для устранения неполадок

Некоторые команды show поддерживаются Средством интерпретации выходных данных(только зарегистрированные клиенты), которое позволяет просматривать аналитику выходных данных команды show.

Примечание: Прежде чем применять команды отладки, ознакомьтесь с разделом "Важные сведения о командах отладки".

  • debug dialer - Когда DDR включен на интерфейсе, эта команда, отображает информацию относительно причины любого вызова (названный Причиной внешнего доступа по телефонной линии).

  • debug isdn q931- Для проверки ISDN - подключений как, исходящих вызовов инициируются.

  • debug ppp negotiation - Чтобы видеть, передает ли клиент согласование PPP. Большое число параллельных согласований PPP может сокрушить процессор маршрутизатора.

  • debug ppp authentication - Получение сведений о том, проходит ли клиент аутентификацию. При использовании версии до Cisco IOS Release 11.2 используйте команду debug ppp chap вместо этого.

  • команда debug ppp error —– Отображает ошибки протокола и статистику ошибок, связанную с работой и согласованием соединения PPP.

Команды устранения проблем модема

  • debug chat –- Видеть выполнение сценария диалогового взаимодействия, когда инициируется вызов.

  • debug modem – чтобы узнать, получает ли маршрутизатор правильные сигналы от модема.

  • debug modem csm - Включить модуль коммутации вызовов для управления модемом (CSM) режим отладки.

Поиск неполадок на выходе

Ниже приведены выходные данные команды debug для успешного исходящего вызова. Обратите внимание на разделы, выделенные жирным шрифтом, и комментарии в выходных данных. Сравните полученные выходные данные со следующим результатом.

Отладка Внешнего подключения от T1 PRI AS5300 до маршрутизатора remoteAsync01

AS5300#debug isdn q931
ISDN Q931 packets debugging is on
AS5300#debug chat
Chat scripts activity debugging is on
AS5300#debug dialer events
Dial on demand events debugging is on
AS5300#show debug
Dial on demand:  
  Dial on demand events debugging is on
PPP:  
  PPP protocol negotiation debugging is on
ISDN:  
  ISDN Q931 packets debugging is on  
  ISDN Q931 packets debug DSLs. (On/Off/No DSL:1/0/-)
  DSL  0 --> 7
  1 1 1 1 - - - -


Chat Scripts:
Chat scripts activity debugging is on


AS5300#ping 10.1.200.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.200.1, timeout is 2 seconds:


Dec 30 17:59:16.675: As12 DDR: rotor dialout [priority]
Dec 30 17:59:16.675: As12 DDR: Dialing cause ip (s=10.1.1.1, d=10.1.200.1)

!--- The dialing cause is a ping for 10.1.200.1.
!--- ICMP is tagged as interesting.

Dec 30 17:59:16.675: As12 DDR: Attempting to dial 9996200
Dec 30 17:59:16.675: CHAT12: Attempting async line dialer script
Dec 30 17:59:16.675: CHAT12: Dialing using Modem script: kelly 
 & System script: none

!--- Uses the Chat script kelly to Dialout.

Dec 30 17:59:16.675: CHAT12: process started
Dec 30 17:59:16.675: CHAT12: Asserting DTR
Dec 30 17:59:16.675: CHAT12: Chat script kelly started
Dec 30 17:59:16.675: CHAT12: Sending string: atdt\T<9996200>

!--- The Chat script kelly uses the Telephone no in Interface Dialer 1 to Dialout.

Dec 30 17:59:16.675: CHAT12: Expecting string: CONNECT
Dec 30 17:59:16.755: ISDN Se0:23: TX -> SETUP pd = 8  callref = 0x00B1

!--- Outgoing ISDN Q.931 SETUP message.

Dec 30 17:59:16.755:         Bearer Capability i = 0x8090A2
Dec 30 17:59:16.755:         Channel ID i = 0xA98397
Dec 30 17:59:16.759:         Called Party Number i = 0xA1, '9996200', Plan:ISDN,
 Type:National
Dec 30 17:59:16.823: ISDN Se0:23: RX <- CALL_PROC pd = 8  callref = 0x80B1
Dec 30 17:59:16.823:         Channel ID i = 0xA98397
Dec 30 17:59:17.023: ISDN Se0:23: RX <- ALERTING pd = 8  callref = 0x80B1.....
Success rate is 0 percent (0/5)
AS5300#
Dec 30 17:59:26.115: ISDN Se0:23: RX <- CONNECT pd = 8  callref = 0x80B1

!--- Received Q.931 CONNECT message.

Dec 30 17:59:26.119: ISDN Se0:23: TX -> CONNECT_ACK pd = 8  callref = 0x00B1
Dec 30 17:59:32.119: %ISDN-6-CONNECT: Interface Serial0:22 is now connected to 
 9996200
Dec 30 17:59:49.347: CHAT12: Completed match for expect: CONNECT
Dec 30 17:59:49.347: CHAT12: Sending string: \c
Dec 30 17:59:49.347: CHAT12: Chat script kelly finished, status = Success
Dec 30 17:59:49.351: Di1 IPCP: Install route to 10.1.1.2

!--- A route to the peer is installed.

Dec 30 17:59:51.351: %LINK-3-UPDOWN: Interface Async12, changed state to up
Dec 30 17:59:51.351: As12 DDR: Dialer statechange to up
Dec 30 17:59:51.351: As12 DDR: Dialer call has been placed
Dec 30 17:59:51.351: As12 PPP: Treating connection as a callout
Dec 30 17:59:51.351: As12 PPP: Phase is ESTABLISHING, Active Open [0 sess, 1 load]
Dec 30 17:59:51.351: As12 LCP: O CONFREQ [Closed] id 149 len 25
Dec 30 17:59:51.351: As12 LCP:    ACCM 0x000A0000 (0x0206000A0000)
Dec 30 17:59:51.351: As12 LCP:    AuthProto CHAP (0x0305C22305)
Dec 30 17:59:51.351: As12 LCP:    MagicNumber 0x4A997A3A (0x05064A997A3A)
Dec 30 17:59:51.351: As12 LCP:    PFC (0x0702)
Dec 30 17:59:51.351: As12 LCP:    ACFC (0x0802)
Dec 30 17:59:53.351: As12 LCP: TIMEout: State REQsent
Dec 30 17:59:53.351: As12 LCP: O CONFREQ [REQsent] id 150 len 25
Dec 30 17:59:53.351: As12 LCP:    ACCM 0x000A0000 (0x0206000A0000)
Dec 30 17:59:53.351: As12 LCP:    AuthProto CHAP (0x0305C22305)
Dec 30 17:59:53.351: As12 LCP:    MagicNumber 0x4A997A3A (0x05064A997A3A)
Dec 30 17:59:53.351: As12 LCP:    PFC (0x0702)
Dec 30 17:59:53.351: As12 LCP:    ACFC (0x0802)
Dec 30 17:59:53.511: As12 LCP: I CONFREQ [REQsent] id 53 len 25
Dec 30 17:59:53.511: As12 LCP:    ACCM 0x000A0000 (0x0206000A0000)
Dec 30 17:59:53.511: As12 LCP:    AuthProto CHAP (0x0305C22305)
Dec 30 17:59:53.511: As12 LCP:    MagicNumber 0x67B12AE8 (0x050667B12AE8)
Dec 30 17:59:53.511: As12 LCP:    PFC (0x0702)
Dec 30 17:59:53.511: As12 LCP:    ACFC (0x0802)
Dec 30 17:59:53.511: As12 LCP: O CONFACK [REQsent] id 53 len 25
Dec 30 17:59:53.511: As12 LCP:    ACCM 0x000A0000 (0x0206000A0000)
Dec 30 17:59:53.511: As12 LCP:    AuthProto CHAP (0x0305C22305)
Dec 30 17:59:53.511: As12 LCP:    MagicNumber 0x67B12AE8 (0x050667B12AE8)
Dec 30 17:59:53.511: As12 LCP:    PFC (0x0702)
Dec 30 17:59:53.511: As12 LCP:    ACFC (0x0802)
Dec 30 17:59:53.543: As12 LCP: I CONFACK [ACKsent] id 150 len 25
Dec 30 17:59:53.543: As12 LCP:    ACCM 0x000A0000 (0x0206000A0000)
Dec 30 17:59:53.543: As12 LCP:    AuthProto CHAP (0x0305C22305)
Dec 30 17:59:53.543: As12 LCP:    MagicNumber 0x4A997A3A (0x05064A997A3A)
Dec 30 17:59:53.543: As12 LCP:    PFC (0x0702)
Dec 30 17:59:53.543: As12 LCP:    ACFC (0x0802)
Dec 30 17:59:53.543: As12 LCP: State is Open

!--- LCP negotation is complete.

Dec 30 17:59:53.543: As12 PPP: Phase is AUTHENTICATING, by both [0 sess, 1 load]
Dec 30 17:59:53.543: As12 CHAP: O CHALLENGE id 25 len 27 from "AS5300"
Dec 30 17:59:53.655: As12 CHAP: I CHALLENGE id 27 len 34 from "remoteAsync01"
Dec 30 17:59:53.655: As12 CHAP: O RESPONSE id 27 len 27 from "AS5300"
Dec 30 17:59:53.671: As12 CHAP: I RESPONSE id 25 len 34 from "remoteAsync01"
Dec 30 17:59:53.671: As12 CHAP: O SUCCESS id 25 len 4
Dec 30 17:59:53.783: As12 CHAP: I SUCCESS id 27 len 4

!--- Two-way CHAP authentication is successful.

Dec 30 17:59:53.783: As12 PPP: Phase is UP [0 sess, 1 load]
Dec 30 17:59:53.783: As12 IPCP: O CONFREQ [Closed] id 25 len 10
Dec 30 17:59:53.783: As12 IPCP:    Address 10.1.1.1 (0x03060A010101)
Dec 30 17:59:53.783: As12 CDPCP: O CONFREQ [Closed] id 25 len 4
Dec 30 17:59:53.783: As12 IPCP: I CONFREQ [REQsent] id 27 len 10
Dec 30 17:59:53.783: As12 IPCP:    Address 10.1.1.2 (0x03060A010102)
Dec 30 17:59:53.783: As12 IPCP: O CONFACK [REQsent] id 27 len 10
Dec 30 17:59:53.783: As12 IPCP:    Address 10.1.1.2 (0x03060A010102)
Dec 30 17:59:53.911: As12 IPCP: I CONFACK [ACKsent] id 25 len 10
Dec 30 17:59:53.911: As12 IPCP:    Address 10.1.1.1 (0x03060A010101)
Dec 30 17:59:53.911: As12 IPCP: State is Open
Dec 30 17:59:53.911: As12 DDR: dialer protocol up
Dec 30 17:59:53.927: As12 LCP: I PROTREJ [Open] id 54 len 10 protocol CDPCP 
 (0x820701190004)
Dec 30 17:59:53.927: As12 CDPCP: State is Closed
Dec 30 17:59:54.783: %LINEPROTO-5-UPDOWN: Line protocol on Interface Async12, 
 changed state to up
Dec 30 17:59:54.783: As12 PPP: Outbound cdp packet dropped, CDPCP is Closed 
 [starting negotiations]
Dec 30 17:59:54.783: As12 CDPCP: State is Closed
Dec 30 17:59:54.783: As12 PPP: Outbound cdp packet dropped, CDPCP is Closed 
 [starting negotiations]
Dec 30 17:59:54.783: As12 CDPCP: State is Closed
Dec 30 17:59:54.783: As12 PPP: Outbound cdp packet dropped, CDPCP is Closed 
 [starting negotiations]
Dec 30 17:59:54.783: As12 CDPCP: State is Closed
Dec 30 17:59:54.787: As12 CDPCP: TIMEout: State Closed
Dec 30 17:59:54.787: As12 CDPCP: State is Listen


remoteAsync01#debug ppp negotiation
PPP protocol negotiation debugging is on
remoteAsync01#
Dec 30 17:58:54: As1 LCP: I CONFREQ [Closed] id 150 len 25
Dec 30 17:58:54: As1 LCP:    ACCM 0x000A0000 (0x0206000A0000)
Dec 30 17:58:54: As1 LCP:    AuthProto CHAP (0x0305C22305)
Dec 30 17:58:54: As1 LCP:    MagicNumber 0x4A997A3A (0x05064A997A3A)
Dec 30 17:58:54: As1 LCP:    PFC (0x0702)
Dec 30 17:58:54: As1 LCP:    ACFC (0x0802)
Dec 30 17:58:54: As1 LCP: Lower layer not up, Fast Starting
Dec 30 17:58:54: As1 PPP: Treating connection as a dedicated line
Dec 30 17:58:54: As1 PPP: Phase is ESTABLISHING, Active Open [0 sess, 0 load]
Dec 30 17:58:54: As1 LCP: O CONFREQ [Closed] id 53 len 25
Dec 30 17:58:54: As1 LCP:    ACCM 0x000A0000 (0x0206000A0000)
Dec 30 17:58:54: As1 LCP:    AuthProto CHAP (0x0305C22305)
Dec 30 17:58:54: As1 LCP:    MagicNumber 0x67B12AE8 (0x050667B12AE8)
Dec 30 17:58:54: As1 LCP:    PFC (0x0702)
Dec 30 17:58:54: As1 LCP:    ACFC (0x0802)
Dec 30 17:58:54: As1 LCP: O CONFACK [REQsent] id 150 len 25
Dec 30 17:58:54: As1 LCP:    ACCM 0x000A0000 (0x0206000A0000)
Dec 30 17:58:54: As1 LCP:    AuthProto CHAP (0x0305C22305)
Dec 30 17:58:54: As1 LCP:    MagicNumber 0x4A997A3A (0x05064A997A3A)
Dec 30 17:58:54: As1 LCP:    PFC (0x0702)
Dec 30 17:58:54: As1 LCP:    ACFC (0x0802)
Dec 30 17:58:54: %LINK-3-UPDOWN: Interface Async1, changed state to up
Dec 30 17:58:55: As1 LCP: I CONFACK [ACKsent] id 53 len 25
Dec 30 17:58:55: As1 LCP:    ACCM 0x000A0000 (0x0206000A0000)
Dec 30 17:58:55: As1 LCP:    AuthProto CHAP (0x0305C22305)
Dec 30 17:58:55: As1 LCP:    MagicNumber 0x67B12AE8 (0x050667B12AE8)
Dec 30 17:58:55: As1 LCP:    PFC (0x0702)
Dec 30 17:58:55: As1 LCP:    ACFC (0x0802)
Dec 30 17:58:55: As1 LCP: State is Open


!--- LCP negotation is complete.


Dec 30 17:58:55: As1 PPP: Phase is AUTHENTICATING, by both [0 sess, 0 load]
Dec 30 17:58:55: As1 CHAP: O CHALLENGE id 27 len 34 from "remoteAsync01"
Dec 30 17:58:55: As1 CHAP: I CHALLENGE id 25 len 27 from "AS5300"
Dec 30 17:58:55: As1 CHAP: O RESPONSE id 25 len 34 from "remoteAsync01"
Dec 30 17:58:55: As1 CHAP: I RESPONSE id 27 len 27 from "AS5300"
Dec 30 17:58:55: As1 CHAP: I SUCCESS id 25 len 4
Dec 30 17:58:55: As1 CHAP: O SUCCESS id 27 len 4


!--- Two-way CHAP authentication is successful.


Dec 30 17:58:55: As1 PPP: Phase is UP [0 sess, 1 load]
Dec 30 17:58:55: As1 IPCP: O CONFREQ [Closed] id 27 len 10
Dec 30 17:58:55: As1 IPCP:    Address 10.1.1.2 (0x03060A010102)
Dec 30 17:58:55: As1 IPCP: I CONFREQ [REQsent] id 25 len 10
Dec 30 17:58:55: As1 IPCP:    Address 10.1.1.1 (0x03060A010101)
Dec 30 17:58:55: As1 IPCP: O CONFACK [REQsent] id 25 len 10
Dec 30 17:58:55: As1 IPCP:    Address 10.1.1.1 (0x03060A010101)
Dec 30 17:58:55: As1 CDPCP: I CONFREQ [Not negotiated] id 25 len 4
Dec 30 17:58:55: As1 LCP: O PROTREJ [Open] id 54 len 10 protocol CDPCP 
 (0x820701190004)
Dec 30 17:58:55: As1 IPCP: I CONFACK [ACKsent] id 27 len 10
Dec 30 17:58:55: As1 IPCP:    Address 10.1.1.2 (0x03060A010102)
Dec 30 17:58:55: As1 IPCP: State is Open
Dec 30 17:58:55: As1 IPCP: Install route to 10.1.1.1


!--- A route to the peer is installed.

Dec 30 17:58:56: %LINEPROTO-5-UPDOWN: Line protocol on Interface Async1, 
  changedstate to up

Отладка Подключения к внешней службе от AS5300 до remoteISDN01 маршрутизатора

AS5300#show debug
Dial on demand:
  Dial on demand events debugging is on
PPP:
  PPP protocol negotiation debugging is on
ISDN:
  ISDN Q931 packets debugging is on
  ISDN Q931 packets debug DSLs. (On/Off/No DSL:1/0/-)
  DSL  0 --> 7
  1 1 1 1 - - - -
Chat Scripts:
  Chat scripts activity debugging is on
AS5300#ping 10.1.201.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.201.1, timeout is 2 seconds:

Dec 30 18:12:42.811: Se0:23 DDR: rotor dialout [priority]
Dec 30 18:12:42.815: Se0:23 DDR: Dialing cause ip (s=10.1.1.65, d=10.1.201.1)

!--- The dialing cause is a ping for 10.1.201.1.
!--- ICMP is tagged as interesting.

Dec 30 18:12:42.815: Se0:23 DDR: Attempting to dial 9996100
Dec 30 18:12:42.815: ISDN Se0:23: TX ->SETUP pd = 8  callref = 0x00B2

!--- Outgoing ISDN Q.931 SETUP message.

Dec 30 18:12:42.815:         Bearer Capability i = 0x8890
Dec 30 18:12:42.815:         Channel ID i = 0xA98396
Dec 30 18:12:42.819:         Called Party Number i = 0xA1, '9996100', Plan:ISDN,
 Type:National
Dec 30 18:12:42.867: ISDN Se0:23: RX <- CALL_PROC pd = 8  callref = 0x80B2
Dec 30 18:12:42.867:         Channel ID i = 0xA98396
Dec 30 18:12:43.127: ISDN Se0:23: RX <- CONNECT pd = 8  callref = 0x80B2

!--- Received Q.931 CONNECT message.

Dec 30 18:12:43.135: %LINK-3-UPDOWN: Interface Serial0:21, changed state to up
Dec 30 18:12:43.135: Se0:21 PPP: Treating connection as a callout
Dec 30 18:12:43.135: Se0:21 PPP: Phase is ESTABLISHING, Active Open [0 sess, 1 load]
Dec 30 18:12:43.135: Se0:21 LCP: O CONFREQ [Closed] id 25 len 15
Dec 30 18:12:43.139: Se0:21 LCP:    AuthProto CHAP (0x0305C22305)
Dec 30 18:12:43.139: Se0:21 LCP:    MagicNumber 0x4AA54104 (0x05064AA54104)
Dec 30 18:12:43.139: ISDN Se0:23: TX -> CONNECT_ACK pd = 8  callref = 0x00B2
Dec 30 18:12:43.167: Se0:21 LCP: I CONFREQ [REQsent] id 55 len 15
Dec 30 18:12:43.167: Se0:21 LCP:    AuthProto CHAP (0x0305C22305)
Dec 30 18:12:43.167: Se0:21 LCP:    MagicNumber 0x575DC27D (0x0506575DC27D)
Dec 30 18:12:43.167: Se0:21 LCP: O CONFACK [REQsent] id 55 len 15
Dec 30 18:12:43.167: Se0:21 LCP:    AuthProto CHAP (0x0305C22305)
Dec 30 18:12:43.167: Se0:21 LCP:    MagicNumber 0x575DC27D (0x0506575DC27D)
Dec 30 18:12:43.175: Se0:21 LCP: I CONFACK [ACKsent] id 25 len 15
Dec 30 18:12:43.175: Se0:21 LCP:    AuthProto CHAP (0x0305C22305)
Dec 30 18:12:43.175: Se0:21 LCP:    MagicNumber 0x4AA54104 (0x05064AA54104)
Dec 30 18:12:43.179: Se0:21 LCP: State is Open

!--- LCP negotation is complete.

Dec 30 18:12:43.179: Se0:21 PPP: Phase is AUTHENTICATING, by both [0 sess, 1.!!!!
Success rate is 80 percent (4/5), round-trip min/avg/max = 32/33/36 msAS5300# load]
Dec 30 18:12:43.179: Se0:21 CHAP: O CHALLENGE id 13 len 27 from "AS5300"
Dec 30 18:12:43.227: Se0:21 CHAP: I CHALLENGE id 36 len 33 from "remoteISDN01"
Dec 30 18:12:43.227: Se0:21 CHAP: O RESPONSE id 36 len 27 from "AS5300"
Dec 30 18:12:43.251: Se0:21 CHAP: I SUCCESS id 36 len 4
Dec 30 18:12:43.263: Se0:21 CHAP: I RESPONSE id 13 len 33 from "remoteISDN01"
Dec 30 18:12:43.263: Se0:21 CHAP: O SUCCESS id 13 len 4

!--- Two-way CHAP authentication is successful.

Dec 30 18:12:43.263: Se0:21 PPP: Phase is UP [0 sess, 1 load]
Dec 30 18:12:43.263: Se0:21 IPCP: O CONFREQ [Closed] id 13 len 10
Dec 30 18:12:43.267: Se0:21 IPCP:    Address 10.1.1.65 (0x03060A010141)
Dec 30 18:12:43.287: Se0:21 IPCP: I CONFREQ [REQsent] id 36 len 10
Dec 30 18:12:43.287: Se0:21 IPCP:    Address 10.1.1.66 (0x03060A010142)
Dec 30 18:12:43.287: Se0:21 IPCP: O CONFACK [REQsent] id 36 len 10
Dec 30 18:12:43.287: Se0:21 IPCP:    Address 10.1.1.66 (0x03060A010142)
Dec 30 18:12:43.287: Se0:21 CDPCP: I CONFREQ [Not negotiated] id 36 len 4
Dec 30 18:12:43.291: Se0:21 LCP: O PROTREJ [Open] id 26 len 10 protocol CDPCP 
 (0x820701240004)
Dec 30 18:12:43.307: Se0:21 IPCP: I CONFACK [ACKsent] id 13 len 10
Dec 30 18:12:43.307: Se0:21 IPCP:    Address 10.1.1.65 (0x03060A010141)
Dec 30 18:12:43.307: Se0:21 IPCP: State is Open
Dec 30 18:12:43.307: Se0:21 DDR: dialer protocol up
Dec 30 18:12:43.307: Di2 IPCP: Install route to 10.1.1.66

!--- A route to the peer is installed.

Dec 30 18:12:44.263: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0:21,
 changed state to up
Dec 30 18:12:49.135: %ISDN-6-CONNECT: Interface Serial0:21 is now connected to
 9996100 remoteISDN01

remoteISDN01#debug ppp negotiation
PPP protocol negotiation debugging is on
remoteISDN01#debug isdn q931
ISDN Q931 packets debugging is on
remoteISDN01#show debug
PPP:
  PPP protocol negotiation debugging is on
ISDN:
  ISDN Q931 packets debugging is on
remoteISDN01#
Dec 30 18:13:04: ISDN BR0: RX <- SETUP pd = 8  callref = 0x1B
Dec 30 18:13:04:         Bearer Capability i = 0x8890
Dec 30 18:13:04:         Channel ID i = 0x89
Dec 30 18:13:04:         Signal i = 0x40 - Alerting on - pattern 0
Dec 30 18:13:04:         Called Party Number i = 0xA1, '2019996100', Plan:ISDN,
 Type:National
Dec 30 18:13:04: ISDN BR0: Event: Received a DATA call from <unknown> on B1 at 
 64 Kb/s
Dec 30 18:13:04: ISDN BR0: Event: Accepting the call id 0x2D
Dec 30 18:13:04: %LINK-3-UPDOWN: Interface BRI0:1, changed state to up
Dec 30 18:13:04: BR0:1 PPP: Treating connection as a callin
Dec 30 18:13:04: BR0:1 PPP: Phase is ESTABLISHING, Passive Open [0 sess, 1 load]
Dec 30 18:13:04: BR0:1 LCP: State is Listen
Dec 30 18:13:04: ISDN BR0: TX -> CALL_PROC pd = 8  callref = 0x9B

!--- Outgoing ISDN Q.931 SETUP message.

Dec 30 18:13:04:         Channel ID i = 0x89
Dec 30 18:13:04: ISDN BR0: TX -> CONNECT pd = 8  callref = 0x9B
Dec 30 18:13:05: BR0:1 LCP: I CONFREQ [Listen] id 25 len 15
Dec 30 18:13:05: BR0:1 LCP:    AuthProto CHAP (0x0305C22305)
Dec 30 18:13:05: BR0:1 LCP:    MagicNumber 0x4AA54104 (0x05064AA54104)
Dec 30 18:13:05: BR0:1 LCP: O CONFREQ [Listen] id 55 len 15
Dec 30 18:13:05: BR0:1 LCP:    AuthProto CHAP (0x0305C22305)
Dec 30 18:13:05: BR0:1 LCP:    MagicNumber 0x575DC27D (0x0506575DC27D)
Dec 30 18:13:05: BR0:1 LCP: O CONFACK [Listen] id 25 len 15
Dec 30 18:13:05: BR0:1 LCP:    AuthProto CHAP (0x0305C22305)
Dec 30 18:13:05: BR0:1 LCP:    MagicNumber 0x4AA54104 (0x05064AA54104)
Dec 30 18:13:05: ISDN BR0: RX <- CONNECT_ACK pd = 8  callref = 0x1B

!--- Received Q.931 CONNECT message.

Dec 30 18:13:05:         Signal i = 0x4F - Alerting off
Dec 30 18:13:05: BR0:1 LCP: I CONFACK [ACKsent] id 55 len 15
Dec 30 18:13:05: BR0:1 LCP:    AuthProto CHAP (0x0305C22305)
Dec 30 18:13:05: BR0:1 LCP:    MagicNumber 0x575DC27D (0x0506575DC27D)
Dec 30 18:13:05: BR0:1 LCP: State is Open
Dec 30 18:13:05: BR0:1 PPP: Phase is AUTHENTICATING, by both [0 sess, 1 load]
Dec 30 18:13:05: BR0:1 CHAP: O CHALLENGE id 36 len 33 from "remoteISDN01"
Dec 30 18:13:05: BR0:1 CHAP: I CHALLENGE id 13 len 27 from "AS5300"
Dec 30 18:13:05: BR0:1 CHAP: Waiting for peer to authenticate first
Dec 30 18:13:05: BR0:1 CHAP: I RESPONSE id 36 len 27 from "AS5300"
Dec 30 18:13:05: BR0:1 CHAP: O SUCCESS id 36 len 4
Dec 30 18:13:05: BR0:1 CHAP: Processing saved Challenge, id 13
Dec 30 18:13:05: BR0:1 CHAP: O RESPONSE id 13 len 33 from "remoteISDN01"
Dec 30 18:13:05: BR0:1 CHAP: I SUCCESS id 13 len 4

!--- Two-way CHAP authentication is successful.

Dec 30 18:13:05: BR0:1 PPP: Phase is UP [0 sess, 0 load]
Dec 30 18:13:05: BR0:1 IPCP: O CONFREQ [Closed] id 36 len 10
Dec 30 18:13:05: BR0:1 IPCP:    Address 10.1.1.66 (0x03060A010142)
Dec 30 18:13:05: BR0:1 CDPCP: O CONFREQ [Closed] id 36 len 4
Dec 30 18:13:05: BR0:1 IPCP: I CONFREQ [REQsent] id 13 len 10
Dec 30 18:13:05: BR0:1 IPCP:    Address 10.1.1.65 (0x03060A010141)
Dec 30 18:13:05: BR0:1 IPCP: O CONFACK [REQsent] id 13 len 10
Dec 30 18:13:05: BR0:1 IPCP:    Address 10.1.1.65 (0x03060A010141)
Dec 30 18:13:05: BR0:1 IPCP: I CONFACK [ACKsent] id 36 len 10
Dec 30 18:13:05: BR0:1 IPCP:    Address 10.1.1.66 (0x03060A010142)
Dec 30 18:13:05: BR0:1 IPCP: State is Open
Dec 30 18:13:05: BR0:1 LCP: I PROTREJ [Open] id 26 len 10 protocol CDPCP 
 (0x8207 01240004)
Dec 30 18:13:05: BR0:1 CDPCP: State is Closed
Dec 30 18:13:05: BR0 IPCP: Install route to 10.1.1.65

!--- A route to the peer is installed.

Dec 30 18:13:06: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI0:1,
 changed state to up
Dec 30 18:13:06: BR0:1 PPP: Outbound cdp packet dropped, CDPCP is Closed
 [starting negotiations]
Dec 30 18:13:06: BR0:1 CDPCP: State is Closed
Dec 30 18:13:06: BR0:1 PPP: Outbound cdp packet dropped, CDPCP is Closed
 [starting negotiations]
Dec 30 18:13:06: BR0:1 CDPCP: State is Closed
Dec 30 18:13:06: BR0:1 PPP: Outbound cdp packet dropped, CDPCP is Closed
 [starting negotiations]
Dec 30 18:13:06: BR0:1 CDPCP: State is Closed
Dec 30 18:13:06: BR0:1 CDPCP: TIMEout: State Closed
Dec 30 18:13:06: BR0:1 CDPCP: State is Listen
Dec 30 18:13:10: %ISDN-6-CONNECT: Interface BRI0:1 is now connected to AS5300

Дополнительные сведения


Document ID: 14960