Глобальная сеть (WAN) : Протоколы X.25

Настройка маршрутизатора как PAD для XOT асинхронного хоста

5 апреля 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Содержание


Введение

Этот документ представляет пример конфигурации, в котором удаленный хост соединяется с X.25 по сети Протокола TCP на линии коммутируемого доступа Открытой коммутируемой телефонной сети (PSTN). Хост не передает или получает любые пакеты X.25. Однако удаленный маршрутизатор это соединяется с действиями как компоновщик/декомпоновщик пакетов (PAD) X.25 и инкапсулирует и декапсулирует пакетов X.25 для хоста.

Примечание: Это упоминается как "обратная подушка", поскольку вызов X25 может только быть установлен от устройства X25 (сервер) к асинхронному хосту, не наоборот. Прямая подушка требует другой конфигурации.

Предварительные условия

Требования

Для этого документа отсутствуют особые требования.

Используемые компоненты

Усовершенствования к СВЯЗАННОЙ С ПОДУШКОЙ функциональности, которую мы можем использовать в сервисах трансляции протоколов, были представлены в Cisco Выпуск ПО IOS� 11.2.

Придерживающиеся платформы поддерживают усовершенствования ПОДУШКИ:

  • Маршрутизаторы Cisco серии 2500

  • Cisco 26XX Series Router

  • Маршрутизаторы серии Cisco 36XX

  • Маршрутизаторы Cisco 4000

  • Маршрутизаторы Cisco 4500

  • Маршрутизаторы Cisco 4700

  • Series маршрутизаторы Cisco AS5200

  • Cisco 7000 Series Routers

  • Маршрутизаторы Cisco серии 7200

  • Cisco 7500 Series Routers

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в этом документе, были запущены с чистой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд до их использования.

Условные обозначения

Дополнительные сведения об условных обозначениях в документах см. в Условные обозначения технических терминов Cisco.

Общие сведения

ПОДУШКА по X.25 по TCP (XOT) включает Вызовы с клавиатуры назначениям, которые не достижимы по физическим интерфейсам X.25, но по туннелям TCP. Эта функция позволяет Вызовам с клавиатуры, происходящим из маршрутизатора на IP - соединении достигнуть устройства X.25. PAD over XOT также позволяет входящим соединениям XOT от IP - соединения быть принятыми как ПОДУШКА или соединения трансляции протоколов на локальном маршрутизаторе.

Настройка

В этом разделе содержатся сведения о настройке функций, описанных в этом документе.

Примечание: Дополнительные сведения о командах, используемых в данном документе, можно получить с помощью средства поиска команд (только для зарегистрированных клиентов).

Схема сети

В этом документе использованы параметры данной сети:

/image/gif/paws/14188/netdiag1.jpg

Конфигурации

Эти конфигурации используются в данном документе:

Удаленный маршрутизатор
Current configuration:
!
version 12.0
 service pad from-xot                   

!---used for allowing incoming xot to pad connection

 service timestamps debug uptime
 service timestamps log uptime
 no service password-encryption
!
!OPTIONAL
x29 profile default 2:0, 4:1, 15:0, 7:21 

!---apply customized x29 profile as default to all incoming connections

!
hostname Remote
!
memory-size iomem 25
 ip subnet-zero
 no ip domain-lookup
!
x25 routing
!
interface Serial0
 ip address 10.10.100.2 255.255.255.0
 no ip directed-broadcast
!
interface Serial1
 ip address 10.10.175.1 255.255.255.0
 no ip directed-broadcast
!
interface FastEthernet0
 ip address 10.10.10.42 255.255.255.0
 no ip directed-broadcast
 half-duplex
!
ip classless
 no ip http server
!
x25 route ^100 xot 10.10.100.1
 x25 host remote 250                 
!---map the x25 address of 25099 to the router's
hostname
!
line con 0
 no exec
 exec-timeout 0 0
 transport input none
line aux 0                     

!---to async host

 no exec
 modem InOut
 rotary 99                   

!---enable reverse PAD

 transport input pad
 flowcontrol hardware
line vty 0 4
 login local
!

Магистральный маршрутизатор
Current configuration:
!
version 12.0
 service timestamps debug uptime
 service timestamps log uptime
 no service password-encryption
!
hostname Main
!
!
memory-size iomem 25
 ip subnet-zero
 no ip domain-lookup
!
x25 routing
!
!
!
interface Serial0
 ip address 10.10.100.1 255.255.255.0
 no ip directed-broadcast
 clockrate 800000
!
interface Serial1
 no ip directed-broadcast
 encapsulation x25 dce
 x25 address 150
 clockrate 56000
!
interface FastEthernet0
 no ip address
 no ip directed-broadcast
 half-duplex
!
ip classless
 no ip http server
!
x25 route ^250 xot 10.10.100.2
 x25 route ^100 interface Serial1
!
line con 0
 transport input none
 line aux 0
 line vty 0 4
 login local
!
no scheduler allocate
end

Проверка.

В настоящее время для этой конфигурации нет процедуры проверки.

Устранение неполадок

В этом разделе описывается процесс устранения неполадок конфигурации.

Команды для устранения неполадок

Некоторые команды show поддерживаются Средством интерпретации выходных данных(только зарегистрированные клиенты), которое позволяет просматривать аналитику выходных данных команды show.

Примечание: Прежде чем вызывать команды debug, обратитесь к разделу Важные сведения о командах отладки.

  • debug x25 events обо всем трафике X.25 или определенном классе сервиса X.25.

  • debug pad — Отображает сообщения отладки для всех соединений ПОДУШКИ.

Следующие выходные данные отладки отображены для успешного вызова X.25 от сервера до хоста. Мы выполнили эти команды отладки на на Удаленном маршрутизаторе.

Remote#debug x25 events
Remote#debug pad
WORKING CALL
2d01h: pad_ctxt_up: id 808D6F18, reason 80742B9C (event 0, impetus 10)
2d01h: [10.10.100.1,11042/10.10.100.2,1998]: XOT I P/Inactive Call (20) 8
lci 1
2d01h:   From (5): 10006 To (5): 25099
2d01h:   Facilities: (6)
2d01h:     Packet sizes: 128 128
2d01h:     Window sizes: 2 2
2d01h:   Call User Data (4): 0x01000000 (pad)
2d01h: PAD: incoming call to 25099 on line 5 CUD length 4
2d01h: PAD: Creating TTY daemon on tty5 for vc 1
2d01h: [10.10.100.1,11042/10.10.100.2,1998]: XOT O P3 Call Confirm (5) 8
lci 1
2d01h:   From (0):  To (0):
2d01h:   Facilities: (0)
2d01h: PAD5: Call completed
2d01h: PAD5: Output X29 packet type 4 (Read X.3 param) len 1
2d01h: PAD5: Control packet received.
2d01h: PAD5: Input X29 packet type 0 (Parameter indication) len 45
1:1, 2:1, 3:2, 4:0, 5:0, 6:5, 7:2,
8:0, 9:0, 10:0, 11:14, 12:1, 13:4, 14:0, 15:1,
16:8, 17:24, 18:18, 19:2, 20:255, 21:7, 22:0,
2d01h: PAD5: Setting ParamsIn, length 44
2d01h: PAD5: Output X29 packet type 6 (Set and Read) len 9 2:0, 4:1,
15:0,7:21,
2d01h: PAD5: Control packet received.
2d01h: PAD5: Input X29 packet type 0 (Parameter indication) len 9 2:0,
4:1, 15:0, 7:21,

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения


Document ID: 14188