Голосовая связь : H.323

"Понимание, настройка и устранение неполадок индикации выделения ресурсов"

20 октября 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Содержание


Введение

Этот документ кратко описывает потребность в Контроле распределения ресурсов, как это работает, как настроить его и устранить неполадки его, и некоторая Cisco дефекты IOS� (дефекты) для наблюдения за.

Предварительные условия

Требования

Для этого документа отсутствуют особые требования.

Используемые компоненты

Сведения, содержащиеся в данном документе, касаются следующих версий программного обеспечения и оборудования:

  • Cisco IOS Software Release 12.2(1)

  • Cisco AS5300, 3660, 2611, 3640

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в этом документе, были запущены с чистой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд до их использования.

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Технические рекомендации Cisco. Условные обозначения.

Общее представление о RAI

Чтобы позволить привратникам принимать "продуманные" решения о маршрутизации вызовов, шлюз сообщает состояние своей ресурсной доступности привратнику. Ресурсы, которые проверены, являются каналами DS0 и каналами DSP.

Шлюз сообщает о своем состоянии ресурса сторожевому устройству с использованием Resource Availability Indication (RAI) RAS. Когда отслеживаемый ресурс падает ниже настраиваемого порогового значения, шлюз передает RAI к сторожевому устройству, которое указывает, что шлюз почти вне ресурсов. Когда доступные ресурсы тогда пересекаются выше другого настраиваемого порогового значения, шлюз передает RAI, который указывает, что больше не существует условие истощения ресурса.

Эта функция была включена в программное обеспечение Cisco IOS версии 12.0(5)T на шлюзе Cisco AS5300 и программное обеспечение Cisco IOS версии 12.1(1)T для других шлюзов в версии 2 H.323.

Определение RAI согласно H.225

RAI является уведомлением от шлюза до сторожевого устройства его емкости текущего вызова для каждого протокола серии H и скорости передачи данных для того протокола. Сторожевое устройство отвечает Resource Availability Confirmation (RAC) после получения RAI для подтверждения его приема.

Сообщение RAI включает в себя:

  • requestSeqNum

  • идентификатор протокола

  • nonStandardData

  • endpointIdentifier

  • протоколы

  • almostOutOfResources (TRUE, FALSE)

  • маркеры, cryptoTokens

  • integrityCheckValue

Сообщение RAC содержит:

  • requestSeqNum

  • идентификатор протокола

  • nonStandardData

  • маркеры

  • cryptoTokens

  • integrityCheckValue

Примечание: Это определение из протокола H.225. В версии 3 версии 2 и H.323 H.323 RAI используется, чтобы сообщить, что шлюз имеет или не имеет ресурсов для обработки входящих вызовов VoIP. Емкость вызовов прибывает в версию 4 H.323.

Принципы использования указателя доступности ресурса (RAI) на шлюзах и привратниках Cisco

  • Пороговые значения генерирования отчетов о ресурсах настраиваются с помощью команды под CLI шлюза. Верхний и нижний пороги можно настроить отдельно, чтобы предотвратить нерегулярное функционирование шлюза вследствие доступности или недостатка ресурсов.

    resource threshold [all] [high percentage-value] [low percentage-value]

    По умолчанию для "высокого" и значений "low" равняется 90.

    Использование вычислено, как замечено здесь:

    • Доступные каналы = используемые + свободные

    • Загрузка = Используемые ресурсы / Доступные ресурсы

    Когда вы вычисляете использование, принимаете во внимание доступные каналы. Отключенные каналы не посчитаны. Команда show call resource voice stat отображает количество доступных для адресации каналов. Адресуемые каналы являются каналами, которые привязаны к допустимым узлам обычной телефонной сети (например, узел обычной телефонной сети, который является завершением, не считают допустимым). Адресуемые каналы не обязательно равняются Доступным каналам, так как можно было отключить Адресуемые каналы (контроллер не работает, или вы busyout некоторые Ds0 как пример).

    Например, предположите, что у вас есть четыре T1s: два T1s для входящих вызовов, два для выхода. Вы заняли 46 из исходящих временных интервалов, и у вас есть один вызов на одном из исходящих временных интервалов. Вы будете иметь:

    • Всего = 96

    • Addressable = 48

    • Отключенный = 46

    • Используемый = 1

    • Свободно 1

    Использование = 1/(1+1)= 50 %. Таким образом, если настроенное высокое пороговое значение составляет 90%, шлюз все еще принимает вызовы.

    Если у вас есть "0" Используемых и "0" Свободные каналы, то вы сразу поражаете высокое пороговое значение. Это один из способов прекратить отправку вызовов шлюзу, если необходимо произвести его обслуживание. Эти два способа сделать это - к занятому все временные интервалы в шагах или закрыло узлы обычной телефонной сети. Существует риск при использовании метода узлов обычной телефонной сети. Привратник мог маршрутизировать несколько вызовов шлюзу еще до завершения работы точки вызова POTS. Эти вызовы разъединены с "no circuit available" кодом причины разъединения. Это происходит, потому что закрытие точки вызова влияет на все каналы, настроенные под ним. Лучший способ – разгрузить определённое число таймслотов до тех пор пока не будет достигнут верхний порог. Как только вы достигаете той точки, быть уверенными, что сторожевое устройство не передает вызовов в то время как вы занятый другие временные интервалы.

  • Вышеупомянутые вычисления только приняли ресурсы DS0 ВО ВНИМАНИЕ. Однако ресурсы DSP проверены и вычислены таким же образом. Кроме того, в зависимости от которого ресурс (DSP или DS0) достигает нижнего уровня или высокого порогового значения сначала, шлюз передает сообщения RAI.

  • Никакая конфигурация не необходима на сторожевом устройстве для активации RAI.

  • Сообщение RAI, как любое другое сообщение RAS, является UDP. Как только шлюз передает сообщение RAI к сторожевому устройству, он запускает три вторых таймера. Если таймер истекает, прежде чем он получит RAC, шлюз пытается передать RAI снова еще девять раз. Затем это дает вплоть до изменений статуса доступности ресурсов снова.

  • Если вы хотите уделить первостепенное значение определенному шлюзу, RAI полезен. Кроме того, как только порог достигнут, тогда вы направляете трафик к другим шлюзам.

  • Сторожевое устройство выбирает шлюз на основе приоритета и порога ресурса. Если все шлюзы имеют тот же приоритет и ресурсы, сторожевое устройство делает распределение нагрузки. Как только шлюз отмечен как "из ресурсов", сторожевое устройство помещает шлюз в нижнюю часть приоритетного списка (это изменяет приоритет шлюза на "1"). Если нет никакого другого шлюза с более высоким приоритетом или если все шлюзы в той зоне имеют приоритет "1", то сторожевое устройство все еще передает вызовы к шлюзу, который передал сообщение RAI, объявив, что это почти вне ресурсов.

  • Если все шлюзы в той зоне отмечены как almost-out-of-resources, с командой lrq reject-resource-low сторожевое устройство отклоняет вызов внутри зоны. Эта команда введена в Cisco IOS Software Release 12.1(3a)XI6. Если вы не используете эту команду, сторожевое устройство не отклоняет требований от других зон, когда все шлюзы в той зоне отмечены как из ресурсов.

  • Приоритет шлюза по умолчанию равняется 5. Это значение по умолчанию можно изменить с помощью команды с префиксом зоны <gatekeeper name> <E.164 prefix> gw-default-priority <priority 0-10>. Эта команда также полезна в случае, если вы хотите направить вызовы к определенным шлюзам для того префикса. Однако дело обстоит не так для других. Кроме того, вы не хотите настраивать любой шлюз с приоритетом "0" использование команды zone prefix <name> сторожевого устройства <префикс E.164> gw-приоритет.

Примеры практического применения

/image/gif/paws/14075/ram.gif

Вызовы происходят из УАТС на T1s, связанном с 5300-4. Вызов совпадает с узлом коммутации VoIP с session target RAS. В 2611 конфигурациях сторожевого устройства этот вызов обрабатывается Зоной B. LRQ передач с 2611 сторожевыми устройствами к 3660-2 сторожевым устройствам в Зоне B и RIP назад к 5300-4.

3660-2 сторожевых устройства настроены для маршрутизации того вызова с приоритетом 10 к 5300-3. Следующий приоритет – 3640-3 (задан как приоритет 9). Целых 5300-3 имеют ресурсы, все вызовы направлены к нему.

3660-2 сторожевых устройства передают LCF с 5300-3 как шлюз назначения. Когда 5300-3 получает сообщение SETUP, оно передает ARQ к своему сторожевому устройству. После ACF это устанавливает ответный матч, который является Участком FGB-телефонии к УАТС B.

Однажды 5300-3 отмечен как "нехватка ресурсов", 3660-2 сторожевых устройства в Зоне B понижают приоритет 5300-3 к "1" и начинают направлять трафик к 3640-3 шлюзам, так как это имеет более высокий приоритет "9".

В этой настройке эти 5300-3 имеют 48 адресуемых DS0 и настроены с 70-процентным высоким пороговым значением.

Первые 34 вызова от УАТС причина 34 DS0, которая будет использоваться на 5300-3. Тридцать пятый вызов заставляет 5300-3 передавать сообщение RAI к сторожевому устройству, сообщающему ему, что это становится нехваткой ресурсов. Тридцать шестой вызов и что придерживается, направлен к 3640-3 целый, эти 5300-3 являются все еще "нехваткой ресурсов".

Конфигурация 5300-3

!
controller T1 0
 framing esf
 clock source line primary
 linecode b8zs
 ds0-group 1 timeslots 1-24 type e&m-fgb dtmf dnis
!
controller T1 2
 framing esf
 clock source line secondary 1
 linecode b8zs
 ds0-group 1 timeslots 1-24 type e&m-fgb dtmf dnis
!
interface Ethernet0
 ip address 172.16.13.45 255.255.255.224
 load-interval 30
 h323-gateway voip interface
 h323-gateway voip id cisco_2 ipaddr 172.16.13.42 1718
 h323-gateway voip h323-id 5300-3
 h323-gateway voip tech-prefix 2#
!
voice-port 0:1
!
voice-port 2:1
!
dial-peer voice 11 pots
 incoming called-number .
 destination-pattern 2#987654
 direct-inward-dial
 port 0:1
 prefix 987654
!
dial-peer voice 12 pots
 destination-pattern 2#987654
 port 2:1
 prefix 987654
!
gateway 
 resource threshold high 70 low 60

!--- The gateway is configured for a high resource threshold 
!--- of 70% and low resource threshold of 60%.

!

Конфигурация 3640-3

!
controller T1 2/0
 framing esf
 linecode b8zs
 ds0-group 0 timeslots 1-24 type e&m-wink-start
!
interface Ethernet0/0
 ip address 172.16.13.40 255.255.255.224
 half-duplex
 h323-gateway voip interface
 h323-gateway voip id cisco ipaddr 172.16.13.50 1718
 h323-gateway voip id cisco_2 ipaddr 172.16.13.42 1718
 h323-gateway voip h323-id 3640-3
 h323-gateway voip tech-prefix 2#
!
voice-port 2/0:0
! 
dial-peer voice 987654 pots
 destination-pattern 2#987654
 port 2/0:0
 prefix 987654
!
gateway 

!--- No resource monitor is configured on this gateway in this lab setup.

!

Конфигурация привратника 3660-2

!
interface FastEthernet0/0
 ip address 172.16.13.42 255.255.255.224
 duplex auto
 speed auto
!
gatekeeper
 zone local cisco_2 cisco.com 172.16.13.42
 zone remote cisco cisco.com 172.16.13.50 1719
 zone prefix cisco 1*
 zone prefix cisco_2 9* gw-priority 10 5300-3
 
!--- 5300-3 is configured for priority 10 for this prefix.

 zone prefix cisco_2 9* gw-priority 9 3640-3
 gw-type-prefix 2#* default-technology
 no shutdown
!

Конфигурация 5300-4

!
controller E1 0
 clock source line primary
 ds0-group 0 timeslots 1-15,17-31 type r2-digital r2-compelled 
 cas-custom 0
!
controller E1 1
 clock source line secondary 1
 ds0-group 1 timeslots 1-15,17-31 type r2-digital r2-compelled 
 cas-custom 1
!
controller E1 2
 clock source line secondary 2
 ds0-group 2 timeslots 1-15,17-31 type r2-digital r2-compelled 
!
controller E1 3
 clock source line secondary 3
 ds0-group 3 timeslots 1-15,17-31 type r2-digital r2-compelled 
!
interface Ethernet0
 ip address 172.16.13.46 255.255.255.224
 no ip mroute-cache
 load-interval 30
 h323-gateway voip interface
 h323-gateway voip id cisco ipaddr 172.16.13.50 1718
 h323-gateway voip h323-id 5300-4
 h323-gateway voip tech-prefix 1#
!
voice-port 0:0
 compand-type a-law
!
voice-port 1:1
 compand-type a-law
!
voice-port 2:2
 compand-type a-law
!
voice-port 3:3
 compand-type a-law
!
dial-peer voice 1234 voip
 incoming called-number .
 destination-pattern 987654
 session target ras
 tech-prefix 2#
!
dial-peer voice 9876 pots
 incoming called-number .
 direct-inward-dial
!
gateway 
!

Конфигурация привратника 2611

!
interface Ethernet0/0
 ip address 172.16.13.50 255.255.255.224
 half-duplex
!
!
gatekeeper
 zone local cisco cisco.com 172.16.13.50
 zone remote cisco_2 cisco.com 172.16.13.42 1719
 zone prefix cisco 1* gw-priority 10 5300-4
 zone prefix cisco_2 9*
 gw-type-prefix 1#* default-technology
 no shutdown
!

Состояние 5300-3 при поступлении одновременно 34 вызовов

Используйте команду show pool от режима "тестового dsprm" для показа, сколько DSP используется.

dsprm 4> show pool
VFC-voice-pool      Total=120: free=86/86, in_use=34/34, pending=0/0, disabled=0/0

Используйте команду show call resource voice stat от режима включения для показа статистики всех ресурсов (DSP и Ds0).

В этих выходных данных коэффициент использования DSP является 34/120 = 28%, и использование DS0 является 34/48 = 70%. Высокое пороговое значение, настроенное на обоих случаях (DSP и DS0 utitlization), не превышено.

5300-3#show call resource voice stat

Resource Monitor -  Dial-up Resource Statistics Information:

DSP Statistics:

Utilization: 0 percent
Total channels: 120
Inuse channels: 34   

!--- Number of DSP channels used.

Disabled channels: 0
Pending channels: 0
Free channels: 86

DS0 Statistics:

Utilization: 0 percent
Total channels: 96
Addressable channels: 48
Inuse channels: 34 

!--- Number of DS0 channels used.
    
Disabled channels: 24
Free channels: 14

Используйте команду show call resource voice threshold от режима включения для проверки порогового состояния на шлюзе как показано здесь.

5300-3#show call resource voice threshold

Resource Monitor -  Dial-up Resource Threshold Information:

DS0 Threshold:

Client Type: h323
High Water Mark: 70
Low Water Mark: 60
Threshold State: low_threshold_hit

!--- DS0 threshold is still below the low value.


DSP Threshold:

Client Type: h323
High Water Mark: 70
Low Water Mark: 60
Threshold State: low_threshold_hit

!--- DSP threshold is still below the low value.

Используйте команду show gateway для проверки статуса порога ресурса H.323, если это включено и активно. Это также дает вам настроенный нижний уровень и высокие пороговые значения.

В этих выходных данных вы видите, что порог ресурса включен и активен. "Включенный" означает настроенный, и "Активный" означает, что H.323 процессы RAS в IOS зарегистрирован в Контроле ресурсов. Как пример, если шлюз не зарегистрирован в сторожевом устройстве, H.323, не инициализируется процесс RAS, и порог ресурса включен, но не активный. Выходные данные команды показаны здесь.

5300-3#show gateway
 Gateway  5300-3  is registered to Gatekeeper cisco_2

Alias list (CLI configured) 
 H323-ID 5300-3
Alias list (last RCF) 
 H323-ID 5300-3

 H323 resource thresholding is Enabled and Active
 H323 resource threshold values:
  DSP: Low threshold 60, High threshold 70
  DS0: Low threshold 60, High threshold 70
5300-3#show gateway
 Gateway  5300-3  is not registered to any gatekeeper

Alias list (CLI configured) 
 H323-ID 5300-3
Alias list (last RCF) 
 H323-ID 5300-3

 H323 resource thresholding is Enabled but NOT Active
 H323 resource threshold values:
  DSP: Low threshold 60, High threshold 70
  DS0: Low threshold 60, High threshold 70

Состояние привратника 3660-2, когда 34 вызова происходят одновременно

Используйте команду show gatekeeper gw-type-prefix для проверки приоритета шлюзов, зарегистрированных в сторожевом устройстве. Посмотрите, отмечен ли кто-либо как "нехватка ресурсов".

В этих выходных данных все шлюзы имеют ресурсы и нет никакой" (нехватка ресурсов)", отображенная, что означает, что 5300-3 все еще имеют ресурсы.

3660-2#show gatekeeper gw-type-prefix 
GATEWAY TYPE PREFIX TABLE
=========================
Prefix: 2#*    (Default gateway-technology)
  Zone cisco_2 master gateway list:
    172.16.13.40:1720 6789 
    172.16.13.45:1720 5300-3
  Zone cisco_2 prefix 9* priority gateway list(s):
   Priority 10:
    172.16.13.45:1720 5300-3
   Priority 9:
    172.16.13.40:1720 6789 

Кроме того, можно использовать команду show gatekeeper endpoint, чтобы видеть, отмечен ли какой-либо из шлюзов как из ресурсов. Если поле "F" имеет букву "O" под ним для шлюза, то то сторожевое устройство получило RAI "из ресурса" от того шлюза.

3660-2#show gatekeeper endpoint
                    GATEKEEPER ENDPOINT REGISTRATION
                    ================================
CallSignalAddr       Port    RASSignalAddr    Port  Zone Name   Type  F 
-------------------- -----  ----------------  ------ ---------- -------    --
172.16.13.40         1720    172.16.13.40     52975   cisco_2   VOIP-GW  
    E164-ID: 6789
    E164-ID: 11
    E164-ID: 336699
    H323-ID: 3640-3
172.16.13.45         1720   172.16.13.45    58131   cisco_2     VOIP-GW  
    H323-ID: 5300-3
Total number of active registrations = 2

Статус 5300-3 при одновременном поступлении 35 вызовов

В этих выходных данных коэффициент использования DSP является 35/120 = 29%, и использование DS0 является 35/48 = 73%. Значение высокого порогового значения, настроенного для каналов DS0, превышено. Кроме того, сообщение RAI с "ИСТИННЫМ" полем "out-of-resource" передается сторожевому устройству. Это указывает, что шлюз не может больше принимать вызовы.

dsprm 4>show pool
VFC-voice-pool      Total=120: free=85/85, in_use=35/35, pending=0/0, disabled=0/0

5300-3#show call resource voice stat

Resource Monitor -  Dial-up Resource Statistics Information:

DSP Statistics:

Utilization: 0 percent
Total channels: 120
Inuse channels: 35
Disabled channels: 0
Pending channels: 0
Free channels: 85

!--- Number of used DSPs is 35.


DS0 Statistics:

Utilization: 0 percent
Total channels: 96
Addressable channels: 48
Inuse channels: 35
Disabled channels: 24
Free channels: 13

!--- Number of used DS0s is 35.

Как вы можете видеть здесь, шлюз поразил высокое пороговое значение для каналов DS0.

В этих выходных данных буква "O" под полем "F" указывает, что шлюз 5300-3 является нехваткой ресурсов.

5300-3#show call resource voice threshold

Resource Monitor -  Dial-up Resource Threshold Information:

DS0 Threshold:

Client Type: h323
High Water Mark: 70
Low Water Mark: 60
Threshold State: high_threshold_hit

!--- The DS0 resources reached the high threshold value.


DSP Threshold:

Client Type: h323
High Water Mark: 70
Low Water Mark: 60
Threshold State: low_threshold_hit

И на сторожевом устройстве, вы видите, что шлюз 5300-3 отмечен как "нехватка ресурсов".

3660-2#show gatekeeper gw-type-prefix 
GATEWAY TYPE PREFIX TABLE
=========================
Prefix: 2#*    (Default gateway-technology)
  Zone cisco_2 master gateway list:
    172.16.13.40:1720 6789 
    172.16.13.45:1720 5300-3 (out-of-resources)
  Zone cisco_2 prefix 9* priority gateway list(s):
   Priority 10:
    172.16.13.45:1720 5300-3 (out-of-resources)
   Priority 9:
    172.16.13.40:1720 6789

!--- 5300-3 is out-of-resources.

3660-2#show gatekeeper endpoint
                    GATEKEEPER ENDPOINT REGISTRATION
                    ================================
CallSignalAddr     Port  RASSignalAddr  Port   Zone Name  Type    F 
-----------------  ----- -------------- ------ ---------- ------- --
172.16.13.40       1720  172.16.13.40   52975   cisco_2   VOIP-GW  
  E164-ID: 6789
  E164-ID: 11
  E164-ID: 336699
  H323-ID: 3640-3
172.16.13.45       1720  172.16.13.45   58131  cisco_2   VOIP-GW O
  H323-ID: 5300-3
Total number of active registrations = 2

Отладка

Включите функции debug ras и debug h225 asn1, если полагаете, что шлюз не отправляет правильное сообщение RAI или что привратник не отправляет сообщение RAC.

Примечание:  debug h225 asn1 многословен. Поэтому необходимо быть осторожными при включении его, особенно когда сторожевое устройство или шлюз работают, и они обрабатывают много вызовов. Debug h225 asn1 показывает все сообщения H.225 (не только RAS). Это - выходные данные этих отладок на 3660-2 сторожевых устройствах после того, как тридцать пять вызовов будут подключены:

В этих выходных данных поле "almostoutofresources" "ИСТИННО". Это означает отчёты о шлюзе сторожевому устройству, которое это вне ресурсов. Когда шлюз поражает значение нижнего предела, он передает другое сообщение RAI. Однако с этим полем "FALSE", это говорит сторожевому устройству начинать передавать вызовы снова. Все сообщения RAS как порядковый номер и любой ответ на эти сообщения несут тот же порядковый номер.

RAW_BUFFER::=
81 340000A1 06000891 
*Mar  5 11:26:02.961: PDU DATA = 60E28808

value RasMessage ::= resourcesAvailableIndicate : 
                     
!--- RAI message.

    {
      requestSeqNum 162
      
!--- Sequence number of the H.225 message.

      protocolIdentifier { 0 0 8 2250 0 2 }
      endpointIdentifier {"6165B9D400000006"}
      protocols 
      {
        voice : 
        {
          supportedPrefixes 
          {

            {
              prefix e164 : "2#"
            }
          }
        }
      }
      almostOutOfResources TRUE
      
!--The value of  almostOutOfResources.

    }
*Mar  5 11:26:02.965: RAI (seq# 162) rcvd

Это - сообщение RAC, передаваемое от сторожевого устройства до шлюза, подтверждая его прием сообщения RAI.

PDU DATA = 60E28808

value RasMessage ::= resourcesAvailableConfirm : 
                     
!--- RAC message.

    {
      requestSeqNum 162
      
!--- Sequence number of the H.225 message.

      protocolIdentifier { 0 0 8 2250 0 2 }
    }


RAW_BUFFER::=
82 0A0000A1 06000891 4A0002
*Mar  5 11:26:02.965: 
*Mar  5 11:26:02.965:       RASLib::RASSendRAC: RAC (seq# 162) sent to 172.16.13.45

Ошибки, которые могут произойти

Это некоторые идентификаторы ошибок Cisco, которые были на других платформах. Почти все из них разрешены, но это может помочь в том случае, если произойдет ошибка с RAI, уже описанная здесь.

Примечание: Можно обратиться к этим идентификаторам ошибок Cisco через Bug Toolkit (только зарегистрированные клиенты).

  • CSCds41207

  • CSCds79319

  • CSCds90317

  • CSCdt00087

  • CSCdt68781

  • CSCdt77870

  • CSCdt93779

  • CSCdu55874

  • CSCdu76312

  • CSCdu79860


Дополнительные сведения


Document ID: 14075