Управление сетью и автоматизация : Cisco Network Registrar

Установка кабельного модема в базовой конфигурации с помощью сетевого регистратора Cisco Network Registrar

20 октября 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Содержание


Введение

Цель этих Технических примечаний состоит в том, чтобы предоставить завершенное руководство по установке для сети кабельного модема (CM) в лабораторной среде. Данную установку можно использовать в качестве первого этапа перед развертыванием в сети заказчика. Следует отметить, что безаварийная настройка в лабораторной работе не обязательно означает безаварийную настройку в сети клиента. В управляемой лабораторной среде шум может не быть проблемой; в то время как в реальной жизни, это может быть как раз наоборот. Однако эта процедура может использоваться для исключения проблем, которые являются результатом Cisco Выпуск ПО IOS�, конфигурация, аппаратные средства и Радиочастоты (RF).

Предварительные условия

Требования

Для этого документа отсутствуют особые требования.

Используемые компоненты

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в этом документе, были запущены с чистой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд до их использования.

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Технические рекомендации Cisco. Условные обозначения.

Топология лаборатории

Рисунок 1 – настройка лабораторной сети

basic_bridged_setup_01.gif

В этой схеме существует Система терминирования кабельных модемов (CMTS), которая состоит из этих компонентов:

  • uBR7246, который выполняет программное обеспечение Cisco IOS версии 12.1(2)T с Модемными картами MC16C

  • CM uBR904, который выполняет версию 12.0 (7) T Cisco IOS Software Release

  • Преобразователь с повышением частоты

  • Диплексный Фильтр для разделения высокой частоты от низких частот

  • Версия 3.5 (3) Cisco Network Registrar (CNR)

  • Сплиттер с тремя путями

  • Customer Premises Equipment (CPE), который, в этом случае, является портативным ПК

Примечание: Настройка RF в той схеме может использоваться в качестве стартовой контрольной точки; однако, это могло бы измениться, как только вы развертываете его в клиентском узле сети. Измерения RF выходят за рамки этого документа; обратитесь к Соединению Маршрутизатора серии Cisco uBR7200 к Головной станции кабельной сети для надлежащей настройки RF и измерений.

Предположения

  • Преобразователь уже установлен и должным образом настроен. См. документацию поставщика для настройки. Помните, что при использовании повышающего преобразователя GI это должно быть установлено в на 1.75 МГц ниже, чем средняя частота рассматриваемого канала NTSC.

  • Существует должным образом настроенный CPE, который находится позади CM, в частности для получения IP-адреса через сервер DHCP.

  • CNR используется в качестве DHCP и серверов TFTP с тем же IP-адресом: 172.17.110.136.

  • Программное обеспечение сервера Времени дня (ToD) работает на том же NT - сервере как CNR.

Разделы в этом документе объясняют шаги, которые необходимы для настройки этих компонентов:

  • Сетевой регистратор Cisco (CNR)

  • Файл конфигурации Data-Over-Cable Service Interface Specification (DOCSIS)

  • Система терминирования кабельных модемов (CMTS)

  • Кабельный модем (CM)

Схема сети

Рисунок 2 – Диаграмма сети с IP-адресами и Названиями, Используемыми в этих Технических примечаниях

/image/gif/paws/12547/basic_bridged_setup_02.gif

Конфигурация сетевого регистратора Cisco Network Registrar

Выполните эту процедуру для настройки CNR:

  1. CNR запуска от Меню Пуск.

  2. На строке меню нажмите вкладку Add для добавления нового кластера.

    1. Введите имя кластера.

      В этом случае IP-адрес используется в качестве названия.

    2. Проверьте, что Подключение к этому кластеру однажды добавило флажок.

    3. Нажмите кнопку OK.

    Рисунок 3 – имя кластера или окно IP Address в CNR

    /image/gif/paws/12547/basic_bridged_setup_03.gif

  3. Когда вам предложат для Имени пользователя и пароля, используйте admin и changeme.

    Рисунок 4 – окно имени пользователя и пароля в CNR

    /image/gif/paws/12547/basic_bridged_setup_04.gif

  4. Нажмите кнопку OK.

    Окно появляется, который подобен рисунку 5, который содержит названия или IP-адреса настроенных кластеров.

    Рисунок 5 – окно менеджера сервера в CNR

    basic_bridged_setup_05.gif

  5. Дважды нажмите DHCP@172.17.110.136, для внедрения Окна свойств DHCP@172.17.110.136.

  6. Нажмите вкладку Policies и затем нажмите New, для создания новой политики.

    Рисунок 6 – добавление политики под названием “кабельные модемы” и копирование атрибутов от политики “по умолчанию”

    basic_bridged_setup_06.gif

  7. Введите название политики.

    В данном примере названием являются Кабельные модемы.

  8. Если это - новая политика, заставьте поле "From" Копии принимать значение по умолчанию.

  9. Нажмите кнопку OK.

  10. Нажмите опции Edit, для определения параметров DHCP.

    Для политики под названием Кабельные модемы добавьте следующие опции (см. рисунок 7):

    • Dhcp-lease-time активен по умолчанию и набор к 604800 секундам, который является кол-вом секунд за одну неделю.

    • routers - IP-адрес кабельного интерфейса CMTS, в данном случае 10.1.1.10. Посмотрите Настройку головной узел (CMTS).

    • смещение времени CM с Universal Coordinated Time (UTC; Параметр смещения времени 2). Это используется CM для вычисления местного времени для добавления метку времени к журналам ошибок.

    • IP-адрес серверов синхронизации для сервера ToD, который является 172.17.110.136.

    • пакетным siaddr является IP-адрес сервера TFTP, который является 172.17.110.136.

    • packet-file-name является файлом конфигурации DOCSIS, настроенным с Конфигуратором DOCSIS CPE (только зарегистрированные клиенты). Этот файл должен находиться в каталоге tftpboot сервера TFTP.

    Рисунок 7 – окно свойств Edit с атрибутами, данными политике для кабельного модема

    basic_bridged_setup_07.gif

    Примечание: Гарантируйте проверку Передачи к флажку Клиентов BOOTP если у вас есть Клиенты BOOTP. Это также настоятельно рекомендовано это, вы проверяете, Всегда передают к флажку клиентов DHCP.

  11. Создайте другую политику, привязанную к CPE позади CM, как портативные ПК, и т.д.

    В данном примере название политики является Клиентами кабельного модема.

    Выполните ту же процедуру, как использовался для политики Кабельных модемов кроме, на этот раз, набор поле "From" Копии к политике Кабельных модемов вместо к политике по умолчанию.

    Рисунок 8 – добавление политики под названием “клиенты кабельного модема” и копирование атрибутов от существующей политики под названием “кабельные модемы”

    /image/gif/paws/12547/basic_bridged_setup_08.gif

  12. Нажмите кнопку OK.

  13. Нажмите переключатель Edit, для выбора активных параметров.

  14. Для политики CPE удалите все опции из Списка активных пользователей кроме Dhcp-lease-time и параметров маршрутизатора.

    Для этого выберите свойство, чтобы удалить в Списке активных пользователей и нажать кнопку Remove.

  15. Измените IP-адрес для параметра маршрутизатора к 192.168.1.1, который является вторичным IP - адресом, настроенным на маршрутизаторе CMTS.

    Посмотрите Настройку головной узел (CMTS).

    Рисунок 9 – Добавление IP-адреса для Атрибута маршрутизаторов, который является Вторичным IP - адресом, Настроенным в Кабельном сопряжении, к которому эта Политика Применяется в CMTS

    basic_bridged_setup_09.gif

    Примечание: Данный пример использует закрытый IP - адрес в качестве вторичного адреса на CMTS и в Клиентской политике Кабельных модемов. В производственной среде устройства CPE должны использовать открытый IP - адрес, чтобы быть в состоянии обратиться к Интернету (пока Трансляция сетевых адресов [NAT] не используется).

  16. Создайте области для соединения с политикой Клиентов кабельного модема и Кабельными модемами.

    1. Для создания новой области щелкните по DHCP@172.17.110.136 в главном меню, и затем нажмите вкладку Add.

      Это позволит вам добавить новый диапазон.

    2. Введите имя новой области и затем выберите соответствующую политику.

      В данном примере область для Кабельных модемов собирается использовать диапазон IP-адресов от 10.1.1.20 до 10.1.1.30.

      Рисунок 10 – Область для Кабельных модемов под названием “Кабельные модемы”

      /image/gif/paws/12547/basic_bridged_setup_10.gif

    3. Повторите Шаги 16a и 16b для области Клиентов кабельного модема.

      В этом случае диапазон закрытого IP - адреса от 192.168.1.20 до 192.168.1.30 используется.

      Рисунок 11 – Область для Абонентского оборудования CPE Позади Кабельных модемов под названием “Клиенты кабельного модема”

      /image/gif/paws/12547/basic_bridged_setup_11.gif

    4. Область, используемая для устройств CPE, требует дополнительной настройки.

      1. После создания область Клиентов кабельного модема, необходимо дважды нажать область для открытия диалогового окна, которое показывают на рисунке 12.

        Рисунок 12 – окно scope клиентов кабельного модема

        /image/gif/paws/12547/basic_bridged_setup_11.gif

      2. Нажмите Вкладку Дополнительно для связи вторичной области к первичной области.

      3. Проверьте Делать эту область дополнительный флажок.

      4. Как только выпадающий список показывает пустое значение, выберите соответствующую первичную область.

        В данном примере выбрана область Кабельных модемов.

        Рисунок 13 – создание вторичной области “клиентов кабельного модема” и связь его к первичной области

        basic_bridged_setup_12.gif

  17. Наконец, необходимо перезапустить сервер DHCP так, чтобы изменения могли иметь место.

    В главном меню выберите DHCP@172.17.110.136 и нажмите вкладку Control наверху, для показывания диалогового окна на рисунке 14. Это диалоговое окно позволяет вам повторно загружать сервер DHCP.

    Рисунок 14 – повторно загружает окно для фиксации изменений в CNR

    /image/gif/paws/12547/basic_bridged_setup_13.gif

Файл конфигурации DOCSIS

Следующий шаг, который требуется, чтобы устанавливать Кабельную сеть, должен составить файл конфигурации. Для кабельного модема, чтобы подключиться к сети, это должно загрузить свой файл конфигурации через TFTP от сервера DHCP. В примере этого документа CNR используется для обеспечения и TFTP и серверов DHCP. См. DHCP и Файл конфигурации DOCSIS для Кабельных модемов (DOCSIS 1.0) для получения дополнительной информации о минимальных требованиях для устанавливания файла конфигурации. Файл является настройкой или с вебом - инструментом, Конфигуратор DOCSIS CPE (только зарегистрированные клиенты), или с загрузкой автономной версии. В На CM (uBR904) раздел этого документа, файл конфигурации DOCSIS, который используется, называют platinum.cm.

Примечание: Как только файл конфигурации создан, гарантируйте, что он скопирован к серверу TFTP. В случае сервера TFTP CNR также необходимо гарантировать, что запущен сервер TFTP:

  1. Выберите TFTP@172.17.110.136 и затем нажмите вкладку Control.

    Это переводит диалоговое окно TFTP@172.17.110.136 Control в рабочее состояние, где может быть запущен сервер.

  2. Функциональные возможности TFTP-сервера прочь по умолчанию. Чтобы заставить сервер TFTP запуститься автоматически в загрузке, запустите NRCMD (интерфейс командной строки для CNR) и выполните эти команды:

    server tftp set start-on-reboot=enabled
    
    save
    

Настройка головной станции (CMTS)

Это - базовая конфигурация для CMTS (uBR7246):

Current configuration:
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Sydney
!
boot system flash ubr7200-ik1s-mz_121-2_T.bin
no logging buffered
enable password <deleted>
!
no cable qos permission create

!--- Default.

no cable qos permission update

!--- Default.

cable qos permission modems

!--- Default.

!
!
!
ip subnet-zero
no ip domain-lookup
!
!
interface FastEthernet0/0
 no ip address
 shutdown
 half-duplex
!
interface Ethernet1/0
 ip address 172.17.110.139 255.255.255.224

!--- The IP address of the interface in the same LAN segment as CNR.

!
interface Ethernet1/1
 no ip address
 shutdown
!
interface Ethernet1/2
 no ip address
 shutdown
!
interface Ethernet1/3
 no ip address
 shutdown
!
interface Ethernet1/4
 no ip address
 shutdown
!
interface Ethernet1/5
 no ip address
 shutdown
!
interface Ethernet1/6
 no ip address
 shutdown
!
interface Ethernet1/7
 no ip address
 shutdown
!
 interface Cable2/0
 ip address 192.168.1.1 255.255.255.0 secondary

!--- The secondary IP address is used for the CPE’s scope in CNR.

 ip address 10.1.1.10 255.255.255.0

!--- The primary IP address is used for the CM’s scope in CNR.

 no keepalive
 cable downstream annex B

!--- Default for DOCSIS-compliant cable plants. For EuroDOCSIS, use annex A.

 cable downstream modulation 64qam

!--- Default.

 cable downstream interleave-depth 32

!--- Default.

 cable downstream frequency 451250000

!--- Cosmetic except for the uBR7100. This line has no effect
!--- on Upconverter Frequency. Used as a reminder of the frequency
!--- that is used in the Unconverter.

 cable upstream 0 frequency 28000000

!--- Upstream Frequency configuration. This is chosen after a careful
!--- analysis on the noise levels of the return path.

 cable upstream 0 power-level 0
 no cable upstream 0 shutdown

!--- Enables the upstream 0 port.

 cable upstream 1 shutdown
 cable upstream 2 shutdown
 cable upstream 3 shutdown
 cable upstream 4 shutdown
 cable upstream 5 shutdown
 cable dhcp-giaddr policy

!--- Modifies the GIADDR field of DHCPDISCOVER and DHCPREQUEST packets.

 cable helper-address 172.17.110.136

!--- Specifies a destination IP address for UDP-broadcast DHCP packets.

!
interface Cable3/0
 no ip address
 no keepalive
 shutdown
 cable downstream annex B
 cable downstream modulation 64qam
 cable downstream interleave-depth 32
 cable upstream 0 shutdown
 cable upstream 1 shutdown
 cable upstream 2 shutdown
 cable upstream 3 shutdown
 cable upstream 4 shutdown
 cable upstream 5 shutdown
!
ip classless
ip route 0.0.0.0 0.0.0.0 172.17.110.129
no ip http server
!
line con 0
 exec-timeout 0 0
 transport input none
line aux 0
line vty 0
 exec-timeout 0 0
  transport input none
line aux 0
line vty 0
 exec-timeout 0 0
 password cisco
 login
line vty 1 4
 password cisco
 login
!
end

Конфигурация CM

Как правило, кабельный модем не требует, чтобы любая пользовательская конфигурация для него подключилась к сети (кроме заводских настроек). Это применяется, только если CM должен использоваться в качестве моста. Это - пример настройки кабельного модема uBR, которая получается автоматически, после того, как CM подключается к сети:

version 12.0
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Router
!
clock timezone - 0
ip subnet-zero
no ip routing
!
!
interface Ethernet0
 ip address 10.1.1.25 255.255.255.0
 no ip directed-broadcast
 no ip route-cache
 bridge-group 59
 bridge-group 59 spanning-disabled
!
interface cable-modem0
 ip address negotiated
 no ip directed-broadcast
 no ip route-cache
 cable-modem downstream saved channel 453000000 20 1
 cable-modem mac-timer t2 40000
 bridge-group 59
 bridge-group 59 spanning-disabled
!
ip default-gateway 10.1.1.10
ip classless
no ip http server
!
!
line con 0
 transport input none
line vty 0 4
!
end

Проверка и устранение неполадок

В этом разделе описываются команды, которые могут использоваться для проверки нормальной работы Кабельной сети.

На CMTS (uBR7246)

Гарантируйте, что кабельные модемы являются онлайновыми:

Sydney# show cable modem

Interface   Prim Online     Timing Rec    QoS CPE IP address      MAC address
            Sid  State      Offset Power
Cable2/0/U0 2    online     2290   -0.25  6   1   10.1.1.25       0050.7366.2223

Если кабельные модемы застревают в состоянии init(d), то нет никакого подключения между интерфейсом кабеля CMTS и Сервером DHCP.

Гарантируйте, что можно выполнить команду extended ping от кабельного сопряжения CMTS:

Sydney# ping ip

Target IP address: 172.17.110.136
Repeat count [5]: 
Datagram size [100]: 
Timeout in seconds [2]: 
Extended commands [n]: y
Source address or interface: 10.1.1.10
Type of service [0]: 
Set DF bit in IP header? [no]: 
Validate reply data? [no]: 
Data pattern [0xABCD]: 
Loose, Strict, Record, Timestamp, Verbose[none]: 
Sweep range of sizes [n]: 
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.17.110.136, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/12/24 ms

Если эхо-тест не проходит, проверьте IP-маршрутизацию. Кроме того, гарантируйте, что NT - сервер, который выполняет CNR, имеет правильный шлюз по умолчанию или маршрут назад к CMTS. Можно также выполнить эхо-запрос от CNR.

Другая команда, которая может использоваться на CMTS для проверки кабельного модема и подключения CPE, является show interface cable 2/0 modem 0:

Sydney# show interfaces cable 2/0 modem 0

SID   Priv bits  Type      State     IP address    method    MAC address
2     00         host      unknown   192.168.1.20  dhcp      0010.a4e6.d04d

!--- A laptop that is obtaining an IP address.

2     00         modem     up        10.1.1.25     dhcp      0050.7366.2223

!--- The cable modem.

На CM (uBR904)

Можно также проверить подключение на стороне кабельного модема. Выполните команду show ip interface brief и проверьте, что интерфейсами является up/up:

Router# show ip interface brief

Interface                  IP-Address      OK? Method Status         Protocol
Ethernet0                  10.1.1.25       YES unset  up             up
cable-modem0               10.1.1.25       YES unset  up             up

Router# show controllers cable-modem 0

BCM Cable interface 0:
CM unit 0, idb 0x2010AC, ds 0x86213E0, regaddr = 0x800000, reset_mask 0x80
station address 0050.7366.2223  default station address 0050.7366.2223
PLD VERSION: 32
MAC State is maintenance_state, Prev States = 15
MAC mcfilter 01E02F00  data mcfilter 01000000
MAC extended header ON
DS: BCM 3116 Receiver: Chip id = 2
US: BCM 3037 Transmitter: Chip id = 30AC
Tuner: status=0x00
Rx: tuner_freq 453000000, symbol_rate 5055880, local_freq 11520000
    snr_estimate 35210, ber_estimate 0, lock_threshold 26000
    QAM in lock, FEC in lock, qam_mode QAM_64
Tx: TX_freq 27984000, power_level 0x30 (24.0 dBmV), symbol_rate 8
    (1280000 sym/sec)
DHCP: TFTP server = 172.17.110.136, TOD server = 172.17.110.136
      Security server = 0.0.0.0, Timezone Offest = 0
      Config filename = platinum.cm
buffer size 1600

RX data PDU ring with 32 entries at 0x202130
   rx_head = 0x202168 (7), rx_p = 0x8621418 (7)

RX MAC message ring with 8 entries at 0x202270
  rx_head_mac = 0x2022A0 (6), rx_p_Mac = 0x86214BC (6)

TX BD ring with 8 entries at 0x2023A8, TX_count = 0
  TX_head = 0x2023C8 (4), head_txp = 0x8621548 (4)
  TX_tail = 0x2023C8 (4), tail_txp = 0x8621548 (4)

TX PD ring with 8 entries at 0x202428, TX_count = 0
  TX_head_pd = 0x202C28 (4)
  TX_tail_pd = 0x202C28 (4)

Global control and status:
  global_ctrl_status=0x00
interrupts:
  irq_pend=0x0008, irq_mask=0x00F7

Можно также протестировать возможность подключения с помощью IP-адреса. Пропингуйте сервер DHCP от CM:

Router# ping 172.17.110.136

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.17.110.136, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/12/24 ms

uBR7246

Sydney# show version

Cisco Internetwork Operating System Software
IOS (tm) 7200 Software (UBR7200-IK1S-M),
     Version 12.1(2)T, RELEASE SOFTWARE (fc1)
Copyright (c) 1986-2000 by cisco Systems, Inc.
Compiled Tue 16-May-00 13:36 by ccai
Image text-base: 0x60008900, data-base: 0x613E8000
ROM: System Bootstrap,
     Version 11.1(10) [dschwart 10], RELEASE SOFTWARE (fc1)
BOOTFLASH: 7200 Software (UBR7200-BOOT-M),
     Version 12.0(10)SC, EARLY DEPLOYMENT RELEASE SOFTWARE (fc1)
Sydney uptime is 4 days, 40 minutes
System returned to ROM by reload
System image file is "slot0:ubr7200-ik1s-mz_121-2_T.bin"
cisco uBR7223 (NPE150) processor (revision B) with 57344K/8192K bytes of memory.
Processor board ID SAB0249006T
R4700 CPU at 150Mhz, Implementation 33, Rev 1.0, 512KB L2 Cache
3 slot midplane, Version 1.0
Last reset from power-on
Bridging software.
X.25 software, Version 3.0.0.
8 Ethernet/IEEE 802.3 interface(s)
1 FastEthernet/IEEE 802.3 interface(s)
2 Cable Modem network interface(s)
125K bytes of non-volatile configuration memory.
1024K bytes of packet SRAM memory.
20480K bytes of Flash PCMCIA card at slot 0 (Sector size 128K).
4096K bytes of Flash internal SIMM (Sector size 256K).
Configuration register is 0x2102

uBR904

Router# show version

Cisco Internetwork Operating System Software
IOS (TM) 900 Software (UBR900-K1OY556I-M),
     Version 12.0(7)T,  RELEASE SOFTWARE (fc2)
Copyright (c) 1986-1999 by cisco Systems, Inc.
Compiled Tue 07-Dec-99 02:01 by phanguye
Image text-base: 0x08004000, database: 0x0852E888


ROM: System Bootstrap,
     Version 11.2(19980518:195057), RELEASED SOFTWARE
ROM: 900 Software (UBR900-RBOOT-M),
     Version 11.3(7)NA, EARLY DEPLOYMENT RELEASE SOFTWARE (fc1) 


Router uptime is 1 hour, 6 minutes
System returned to ROM by reload at 11:20:43 - Thu Oct 12 2001
System restarted at 11:21:53 - Thu Oct 12 2001
System image file is "flash:ubr900-k1oy556i-mz.120-7.T.bin"

cisco uBR900 CM (68360) processor (revision D) with 8192K bytes of memory.
Processor board ID FAA0315Q07M
Bridging software.
1 Ethernet/IEEE 802.3 interface(s)
1 Cable Modem network interface(s)
4096K bytes of processor board System flash (Read/Write)
2048K bytes of processor board Boot flash (Read/Write)
        

Configuration register is 0x2102

Для подробного объяснения об использовании отладок CNR — в случае, если необходимо решить проблемы CNR — обращаются к Устранению проблем Проблем DHCP в Кабельных сетях с помощью Cisco Network Registrar Debugs. Для конфигурации класса клиентов обратитесь к классам клиентов Настройки.


Дополнительные сведения


Document ID: 12547