Технологии коммутируемого доступа в сеть : Технология DDR

Настройка конфигурации резервирования DDR для ISDN с профилями номеронабирателя

20 октября 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Содержание


Введение

Этот пример конфигурации показывает, как можно использовать канал ISDN BRI для выполнения резервное копирование выделенной линии, глобальной сети (WAN) или последовательного подключения.

В этом документе используются профили программы набора номера и функция резервного интерфейса. Команда backup interface переводит настраиваемый физический или логический интерфейс в режим ожидания до тех пор, пока не прекратит работу основной интерфейс.

Предварительные условия

Требования

Для этого документа отсутствуют особые требования.

Используемые компоненты

В этой конфигурации для резервирования последовательного канала используется линия BRI. Ramses маршрутизатора выполняет внешнее телефонное соединение, если строка номеронабирателя настроена на этом маршрутизаторе. В данной конфигурации:

  • Маршрутизатор Cisco 2500 (ramses) используется, связывается с маршрутизатором Cisco 2520 (сфинкс). Оба маршрутизатора оснащены также интерфейсами BRI, которые используются для резервной связи.

  • На обоих маршрутизаторах работает Cisco IOS Software Release 12.0.7T.

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в этом документе, были запущены с чистой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд до их использования.

Условные обозначения

Дополнительные сведения об условных обозначениях в документах см. Cisco Technical Tips Conventions.

Настройка

В этом разделе содержатся сведения о настройке функций, описанных в этом документе. Эти три шага завершают эту конфигурацию:

  1. Настройте технологию DDR с Унаследованным профилем DDR или профилями DDR. Пример конфигурации, показанный в этом документе, использует профили DDR.

  2. Используйте команду backup interface, чтобы вызвать исходящий звонок при сбое главного канала.

  3. Определение представляющего интерес трафика.

Примечание: Рекомендуется, чтобы вы настроили подключение DDR (номеронабиратель 1 с BRI0) и проверили, что это работает должным образом перед настройкой резервного интерфейса и команд backup delay. Это позволяет вам эффективно управлять и устранять неполадки профилей DDR, ISDN, PPP и проблем аутентификации перед настройкой резервной копии.

Примечание: Поиск дополнительной информации о командах в данном документе можно выполнить с помощью средства "Command Lookup" (Поиск команд) (только для зарегистрированных клиентов).

Схема сети

В настоящем документе используется следующая схема сети:

/image/gif/paws/12481/ddr_serial_12481.gif

Конфигурации

Эти конфигурации используются в данном документе:

ramses (маршрутизатор Cisco 2500)
ramses#show running-config
Building configuration...

Current configuration:
!
version 12.0
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname ramses
!
username sphinx password <password>

!-- password is case sensitive and should be the same on both sides

!
isdn switch-type basic-net3
!
!
interface Loopback1
ip address 1.1.1.1 255.255.255.255
!
interface Ethernet0
ip address 10.48.74.45 255.255.254.0
!
interface Serial0
backup delay 10 30
backup interface Dialer1
ip address 3.3.3.1 255.255.255.0
no ip directed-broadcast
clockrate 125000
!
interface BRI0
no ip address
no ip directed-broadcast
encapsulation ppp
dialer pool-member 2
isdn switch-type basic-net3
no cdp enable
ppp authentication chap callin
!
interface Dialer1
ip unnumbered Loopback1
no ip directed-broadcast
encapsulation ppp
dialer remote-name sphinx
dialer pool 2
dialer string 5551000
dialer-group 1
ppp authentication chap callin
!
ip classless
ip route 2.2.2.1 255.255.255.255 Dialer1
ip route 2.2.2.1 255.255.255.255 Serial0
no ip http server
!
dialer-list 1 protocol ip permit
!
line con 0
exec-timeout 0 0
transport input none
line aux 0
line vty 0 4
exec-timeout 0 0
password <password>
login
!
ntp server 10.200.20.134
end

sphinx (маршрутизатор Cisco 2520)
sphinx#show running-config

Building configuration...
Current configuration:
!
version 12.0
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname sphinx
!
!
username ramses password <password>

!-- password is case sensitive and should be the same on both sides

!
isdn switch-type basic-net3
interface Loopback1
ip address 2.2.2.1 255.255.255.255
!
interface Serial0
ip address 3.3.3.2 255.255.255.0
!
interface BRI0
no ip address
no ip directed-broadcast
encapsulation ppp
dialer pool-member 2
isdn switch-type basic-net3
no cdp enable
ppp authentication chap callin
!
interface Dialer1
ip unnumbered Loopback1
no ip directed-broadcast
encapsulation ppp
dialer remote-name ramses
dialer pool 2
dialer-group 1
ppp authentication chap
!
ip classless
ip route 1.1.1.1 255.255.255.255 Serial0
ip route 1.1.1.1 255.255.255.255 Dialer1 2
dialer-list 1 protocol ip permit
!
line con 0
exec-timeout 0 0
transport input none
line aux 0
line vty 0 4
!
end

Проверка

В этом разделе содержатся сведения, которые помогают убедиться в надлежащей работе конфигурации.

Некоторые команды show поддерживаются Средством интерпретации выходных данных(только зарегистрированные клиенты), которое позволяет просматривать аналитику выходных данных команды show.

  • show isdn status??? Отображает статус всех интерфейсов ISDN или определенного интерфейса ISDN.

  • show interfaces serial – отображает сведения о последовательном интерфейсе.

  • show interface dialer??? Отображает информацию об интерфейсе номеронабирателя.

  • debug dialer - вывод сведений DDR о пакетах, полученных в интерфейсе номеронабирателя.

  • debug isdn q931 – Показывает установление и разрыв соединений сети ISDN (3-й уровень) между маршрутизатором и коммутатором ISDN.

  • команда debug ppp negotiation отображает сведения об объеме трафика и обмене по протоколу PPP в процессе согласования компонентов PPP, включая протокол управления каналом (LCP), аутентификацию и протокол NCP. В успешных переговорах PPP сначала выясняется состояние LCP, затем проводится аутентификация и наконец выполняется согласование NCP.

  • debug ppp authentication – отображает сообщения протокола аутентификации PPP, включая обмен пакетами протокола аутентификации с предварительным согласованием вызова (CHAP) и обмена протоколами аутентификации по паролю (PAP). Если произошел сбой, проверьте правильность настройки имени пользователя и пароля CHAP.

Устранение неполадок

В этом разделе описывается процесс устранения неполадок конфигурации.

Шаги по устранению неполадок

Для устранения неполадок конфигурации выполните следующие действия:

Используйте команду show isdn status, чтобы удостовериться в том, что маршрутизатор обменивается данными с ISDN-коммуникатором должным образом. Для входных данных проверьте следующее:

  • Состояние уровня 1 - ACTIVE

  • "Layer 2 Status state = MULTIPLE_FRAME_ESTABLISHED" (состояние 2-го уровня = установлено многокадровое)

Эта команда показывает также число активных вызовов. Рассмотрим пример:

   ramses#show isdn status
   Global ISDN Switchtype = basic-net3
   ISDN BRI0 interface
   dsl 0, interface ISDN Switchtype = basic-net3
   Layer 1 Status:
   ACTIVE
   Layer 2 Status:
   TEI = 97, Ces = 1, SAPI = 0, State = MULTIPLE_FRAME_ESTABLISHED
   Layer 3 Status:
   0 Active Layer 3 Call(s)
   Activated dsl 0 CCBs = 0
   The Free Channel Mask: 0x80000003
   Total Allocated ISDN CCBs = 0

   ramses#show interface serial 0
   Serial0 is up, line protocol is up
   Hardware is HD64570
   Internet address is 3.3.3.1/24
   Backup interface Dialer1, failure delay 10 sec, secondary disable
   delay 30 sec

   ramses#show interface dialer 1
   Dialer1 is standby mode, line protocol is down 
   ! --- In standby mode.
   Hardware is Unknown

Так как резервный интерфейс находится в режиме ожидания, вы не видите эту информацию в выходных данных команды show ip route.

Давайте рассмотрим различия в выходных данных при использовании административного расстояния (AD) и без него.

Если не используется административное расстояние

Если не с помощью AD, вы видите следующий результат:

   sphinx#show interface dialer 1
   Dialer1 is up (spoofing), line protocol is up (spoofing)
   Hardware is Unknown

Если вы не используете AD для номеронабирателя на маршрутизаторе Sphinx, вы видите следующий результат от команды show ip route:

   sphinx(config)#ip route 1.1.1.1 255.255.255.255 dialer1
   
   ! --- No AD used here.


   sphinx#show ip route 1.1.1.1
   Routing entry for 1.1.1.1/32
   Known via "static", distance 1, metric 0 (connected)
   Routing Descriptor Blocks:
   * directly connected, via Dialer1
   Route metric is 0, traffic share count is 1
   directly connected, via Serial0
   Route metric is 0, traffic share count is 1

Выходные данные, отображаемые для команды ping, похожи на следующие данные тем, что в них отсутствует одна из проверок доступности адресата:

   sphinx#ping 1.1.1.1
   Type escape sequence to abort.
   Sending 5, 100-byte ICMP Echos to 1.1.1.1, timeout is 2 seconds:
   .!.!.

При использовании административного расстояния

При использовании AD вы видите следующий результат:

   sphinx(config)#ip route 1.1.1.1 255.255.255.255 dialer1 2
 
   ! --- The AD used here is two.


   sphinx#show ip route 1.1.1.1
   Routing entry for 1.1.1.1/32
   Known via "static", distance 1, metric 0 (connected)
   Routing Descriptor Blocks:
   * directly connected, via Serial0
   Route metric is 0, traffic share count is 1

   sphinx#ping 1.1.1.1
   Type escape sequence to abort.
   Sending 5, 100-byte ICMP Echos to 1.1.1.1, timeout is 2 seconds:
   !!!!! 

Перед настройкой команд backup interface и backup delay выполните настройку и убедитесь, что соединение DDR (между номеронабирателем 1 и BRI0) работает правильно. Это позволяет вам проверять, что профиль DDR, ISDN, PPP и аутентификация функционируют правильно прежде, чем настроить резервную копию.

Проверив, что подключение DDR работает надлежащим образом, можно перейти к следующим шагам поиска неполадок резервных средств, намеченным ниже:

  1. Снимите основную связь.

    Примечание: Не используйте команду shutdown на маршрутизаторе с настроенной командой резервного интерфейса. Это не заставляет Cisco IOS установить связь по резервному каналу. На маршрутизаторах, не поддерживающих команду backup interface, для активизации резервирования достаточно завершить работу основного интерфейса.

    Примечание: В нашем сценарии команда backup interface сконфигурирована на ramses (маршрутизатор Cisco 2500). Поэтому выполнение команды shutdown на основном интерфейсе сфинкса (маршрутизатор Cisco 2520) активирует резервное соединение.

    Примечание: Можно физически устранить основное подключение, отсоединив кабели или используя другой эквивалентный способ, чтобы вызвать интерфейс резервного копирования.

  2. При этом на консоли должно появиться сообщение о подключении резервного интерфейса (интерфейс дозвона 1). Это сообщение появляется только после того, как истечет интервал времени, заданный командой отсрочки резервного копирования. В этой конфигурации задержка запуска резервного копирования – 10 секунд.

    Если на консоли не отображается это сообщение, проверьте таймер задержки резервирования.

       *Mar 1 03:54:00.451: %LINEPROTO-5-UPDOWN: Line protocol on Interface
       Serial0, changed state to down
       *Mar 1 03:54:11.467: %LINK-3-UPDOWN: Interface Dialer1, changed state to up
  3. Для просмотра таблицы маршрутизации с неработоспособным основным каналом используйте команду show ip route. Необходимо отслеживать прямой путь к номеронабирателю 1.

  4. Проверка доступности IP-адреса интерфейса обратной связи удаленного маршрутизатора. Если ссылка не набирает, проверяет, что ваше определение содержательного трафика разрешает трафик ICMP (эхо-запросы).

    Примечание: В нашем примере AD два используется для маршрута в маршрутизаторе Sphinx (это может быть любым номером кроме одного).

    ip route 1.1.1.1 255.255.255.255 Dialer1 2

    Примечание: Причина для этого состоит в том, что, если основное соединение подключено, потеряна половина эхо-запросов. Поскольку интерфейс номеронабирателя 1 и последовательный интерфейс 0 находятся в рабочем режиме, маршрут установлен для обоих интерфейсов. Однако интерфейс номеронабирателя не может отправить пакет, так кА не включен интерфейс BRI.

Команды для устранения неполадок

Используйте команды, которые, как показывают в этом разделе, устраняли неполадки вашей конфигурации.

Некоторые команды show поддерживаются Средством интерпретации выходных данных(только зарегистрированные клиенты), которое позволяет просматривать аналитику выходных данных команды show.

Примечание: Прежде чем вызывать команды debug, обратитесь к разделу Важные сведения о командах отладки.

Попытайтесь для прозванивания 2.2.2.1 для создания представляющего интерес трафика:

ramses#ping 2.2.2.1
   *Mar 1 04:53:26.574: %LINK-3-UPDOWN: Interface Serial0, changed state
   to down
   *Mar 1 04:53:27.574: %LINEPROTO-5-UPDOWN: Line protocol on Interface
   Serial0, changed state to down
   *Mar 1 04:53:38.590: %LINK-3-UPDOWN: Interface Dialer1, changed state
   to up
   *Mar 1 04:53:38.606: Di1 LCP: Not allowed on a Dialer Profile.
   *Mar 1 04:53:40.058: BRI0 DDR: rotor dialout [priority]
   *Mar 1 04:53:40.062: BRI0 DDR: Dialing cause ip (s=1.1.1.1, d=2.2.2.1)
   *Mar 1 04:53:40.066: BRI0 DDR: Attempting to dial 5551000
   *Mar 1 04:53:40.078: ISDN BR0: TX -> SETUP pd = 8 callref = 0x0A
   *Mar 1 04:53:40.078: Bearer Capability i = 0x8890
   *Mar 1 04:53:40.082: Channel ID i = 0x83
   *Mar 1 04:53:40.086: Called Party Number i = 0x80, '5551000'
   *Mar 1 04:53:40.342: ISDN BR0: RX <- CALL_PROC pd = 8 callref = 0x8A
   *Mar 1 04:53:40.346: Channel ID i = 0x89
   *Mar 1 04:53:40.834: ISDN BR0: RX <- CONNECT pd = 8 callref = 0x8A
   *Mar 1 04:53:40.846: ISDN BR0: TX -> CONNECT_ACK pd = 8 callref =
   0x0A
   *Mar 1 04:53:40.854: %LINK-3-UPDOWN: Interface BRI0:1, changed state to
   up
   *Mar 1 04:53:40.870: BRI0:1: interface must be fifo queue, force fifo
   *Mar 1 04:53:40.874: %DIALER-6-BIND: Interface BRI0:1 bound to profile
   Dialer1
   *Mar 1 04:53:40.882: %ISDN-6-CONNECT: Interface BRI0:1 is now connected
   to 5551000
   *Mar 1 04:53:40.890: BR0:1 PPP: Treating connection as a callout
   *Mar 1 04:53:40.890: BR0:1 PPP: Phase is ESTABLISHING, Active Open
   *Mar 1 04:53:40.894: BR0:1 PPP: No remote authentication for call-out
   *Mar 1 04:53:40.898: BR0:1 LCP: O CONFREQ [Closed] id 18 len 10
   *Mar 1 04:53:40.902: BR0:1 LCP: MagicNumber 0xE1BD38B8
   (0x0506E1BD38B8)
   *Mar 1 04:53:40.930: BR0:1 LCP: I CONFREQ [REQsent] id 22 len 15
   *Mar 1 04:53:40.934: BR0:1 LCP: AuthProto CHAP (0x0305C22305)
   *Mar 1 04:53:40.938: BR0:1 LCP: MagicNumber 0xEEBCFA2D
   (0x0506EEBCFA2D)
   *Mar 1 04:53:40.942: BR0:1 LCP: O CONFACK [REQsent] id 22 len 15
   *Mar 1 04:53:40.946: BR0:1 LCP: AuthProto CHAP (0x0305C22305)
   *Mar 1 04:53:40.950: BR0:1 LCP: MagicNumber 0xEEBCFA2D
   (0x0506EEBCFA2D)
   *Mar 1 04:53:40.954: BR0:1 LCP: I CONFACK [ACKsent] id 18 len 10
   *Mar 1 04:53:40.954: BR0:1 LCP: MagicNumber 0xE1BD38B8
   (0x0506E1BD38B8)
   *Mar 1 04:53:40.958: BR0:1 LCP: State is Open
   *Mar 1 04:53:40.962: BR0:1 PPP: Phase is AUTHENTICATING, by the peer
   *Mar 1 04:53:40.982: BR0:1 CHAP: I CHALLENGE id 9 len 27 from "sphinx"
   *Mar 1 04:53:40.986: BR0:1 CHAP: O RESPONSE id 9 len 27 from "ramses"
   *Mar 1 04:53:41.046: BR0:1 CHAP: I SUCCESS id 9 len 4
   *Mar 1 04:53:41.050: BR0:1 PPP: Phase is UP
   *Mar 1 04:53:41.054: BR0:1 IPCP: O CONFREQ [Not negotiated] id 9 len 10
   *Mar 1 04:53:41.058: BR0:1 IPCP: Address 1.1.1.1 (0x030601010101)
   *Mar 1 04:53:41.062: BR0:1 CDPCP: O CONFREQ [Not negotiated] id 9 len 4
   *Mar 1 04:53:41.066: BR0:1 IPCP: I CONFREQ [REQsent] id 6 len 10
   *Mar 1 04:53:41.070: BR0:1 IPCP: Address 2.2.2.1 (0x030602020201)
   *Mar 1 04:53:41.074: BR0:1 IPCP: O CONFACK [REQsent] id 6 len 10
   *Mar 1 04:53:41.078: BR0:1 IPCP: Address 2.2.2.1 (0x030602020201)
   *Mar 1 04:53:41.082: BR0:1 CDPCP: I CONFREQ [REQsent] id 9 len 4
   *Mar 1 04:53:41.086: BR0:1 CDPCP: O CONFACK [REQsent] id 9 len 4
   *Mar 1 04:53:41.110: BR0:1 IPCP: I CONFACK [ACKsent] id 9 len 10
   *Mar 1 04:53:41.110: BR0:1 IPCP: Address 1.1.1.1 (0x030601010101)
   *Mar 1 04:53:41.114: BR0:1 IPCP: State is Open
   *Mar 1 04:53:41.122: BR0:1 CDPCP: I CONFACK [ACKsent] id 9 len 4
   *Mar 1 04:53:41.126: BR0:1 CDPCP: State is Open
   *Mar 1 04:53:41.126: BRI0:1 DDR: dialer protocol up
   *Mar 1 04:53:41.134: Di1 IPCP: Install route to 2.2.2.1
   *Mar 1 04:53:42.086: %LINEPROTO-5-UPDOWN: Line protocol on Interface
   BRI0:1, changed state to up
   *Mar 1 04:53:46.886: %ISDN-6-CONNECT: Interface BRI0:1 is now connected
   to 5551000 5551000

   ramses#show dialer

   BRI0 - dialer type = ISDN

   Dial String Successes Failures Last DNIS Last status
   0 incoming call(s) have been screened.
   0 incoming call(s) rejected for callback.

   BRI0:1 - dialer type = ISDN
   Idle timer (120 secs), Fast idle timer (20 secs)
   Wait for carrier (30 secs), Re-enable (15 secs)
   Dialer state is data link layer up
   Dial reason: ip (s=1.1.1.1, d=2.2.2.1)
   ! --- we see dial reason, this is the calling router
   Interface bound to profile Dialer1
   Time until disconnect 105 secs
   Current call connected 00:00:16
   Connected to 5551000 (5551000)

   BRI0:2 - dialer type = ISDN
   Idle timer (120 secs), Fast idle timer (20 secs)
   Wait for carrier (30 secs), Re-enable (15 secs)
   Dialer state is idle

   Dialer1 - dialer type = DIALER PROFILE
   Idle timer (120 secs), Fast idle timer (20 secs)
   Wait for carrier (30 secs), Re-enable (15 secs)
   Dialer state is data link layer up
   Number of active calls = 1
   Number of active circuit switched calls = 0

   Dial String Successes Failures Last DNIS Last status
   5551000 5 0 00:00:19 successful
   Default

   Dialer2 - dialer type = NONE
   Idle timer (120 secs), Fast idle timer (20 secs)
   Wait for carrier (30 secs), Re-enable (15 secs)
   Number of active calls = 0

   Dial String Successes Failures Last DNIS Last status

   ramses#show ip route
   Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP

   D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
   N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
   E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
   i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS
   inter area
   * - candidate default, U - per-user static route, o - ODR
   P - periodic downloaded static route

   Gateway of last resort is not set

   1.0.0.0/32 is subnetted, 1 subnets
   C 1.1.1.1 is directly connected, Loopback1
   2.0.0.0/32 is subnetted, 1 subnets
   C 2.2.2.1 is directly connected, Dialer1
   10.0.0.0/23 is subnetted, 1 subnets
   C 10.48.74.0 is directly connected, Ethernet0

   sphinx(config)#interface serial 0
   sphinx(config-if)#shutdown
   sphinx(config-if)#
   *Mar 3 20:07:40.603: %LINK-5-CHANGED: Interface Serial0, changed state
   to administratively down
   *Mar 3 20:07:41.603: %LINEPROTO-5-UPDOWN: Line protocol on Interface
   Serial0, changed state to down
   *Mar 3 20:07:54.331: ISDN BR0: RX <- SETUP pd = 8 callref = 0x14
   *Mar 3 20:07:54.335: Bearer Capability i = 0x8890
   *Mar 3 20:07:54.339: Channel ID i = 0x89
   *Mar 3 20:07:54.343: Called Party Number i = 0xC1, '5551000'
   *Mar 3 20:07:54.355: ISDN BR0: Event: Received a DATA call from
   <unknown> on B1 at 64 Kb/s
   *Mar 3 20:07:54.355: BRI0:1: interface must be fifo queue, force fifo
   *Mar 3 20:07:54.363: %DIALER-6-BIND: Interface BRI0:1 bound to profile
   Dialer1
   *Mar 3 20:07:54.383: %LINK-3-UPDOWN: Interface BRI0:1, changed state to
   up
   *Mar 3 20:07:54.403: %ISDN-6-CONNECT: Interface BRI0:1 is now connected
   to <unknown phone number>
   *Mar 3 20:07:54.411: BR0:1 PPP: Treating connection as a callin
   *Mar 3 20:07:54.415: BR0:1 PPP: Phase is ESTABLISHING, Passive Open
   *Mar 3 20:07:54.415: BR0:1 LCP: State is Listen
   *Mar 3 20:07:54.471: %ISDN-6-LAYER2UP: Layer 2 for Interface BR0, TEI
   99 changed to up
   *Mar 3 20:07:54.479: ISDN BR0: TX -> CALL_PROC pd = 8 callref = 0x94
   *Mar 3 20:07:54.687: ISDN BR0: TX -> CONNECT pd = 8 callref = 0x94
   *Mar 3 20:07:54.851: ISDN BR0: RX <- CONNECT_ACK pd = 8 callref =
   0x14
   *Mar 3 20:07:54.939: BR0:1 LCP: I CONFREQ [Listen] id 18 len 10
   *Mar 3 20:07:54.939: BR0:1 LCP: MagicNumber 0xE1BD38B8
   (0x0506E1BD38B8)
   *Mar 3 20:07:54.943: BR0:1 LCP: O CONFREQ [Listen] id 22 len 15
   *Mar 3 20:07:54.947: BR0:1 LCP: AuthProto CHAP (0x0305C22305)
   *Mar 3 20:07:54.951: BR0:1 LCP: MagicNumber 0xEEBCFA2D
   (0x0506EEBCFA2D)
   *Mar 3 20:07:54.955: BR0:1 LCP: O CONFACK [Listen] id 18 len 10
   *Mar 3 20:07:54.959: BR0:1 LCP: MagicNumber 0xE1BD38B8
   (0x0506E1BD38B8)
   *Mar 3 20:07:54.987: BR0:1 LCP: I CONFACK [ACKsent] id 22 len 15
   *Mar 3 20:07:54.987: BR0:1 LCP: AuthProto CHAP (0x0305C22305)
   *Mar 3 20:07:54.991: BR0:1 LCP: MagicNumber 0xEEBCFA2D
   (0x0506EEBCFA2D)
   *Mar 3 20:07:54.995: BR0:1 LCP: State is Open
   *Mar 3 20:07:54.995: BR0:1 PPP: Phase is AUTHENTICATING, by this end
   *Mar 3 20:07:54.999: BR0:1 CHAP: O CHALLENGE id 9 len 27 from "sphinx"
   *Mar 3 20:07:55.027: BR0:1 CHAP: I RESPONSE id 9 len 27 from "ramses"
   *Mar 3 20:07:55.035: BR0:1 CHAP: O SUCCESS id 9 len 4
   *Mar 3 20:07:55.039: BR0:1 PPP: Phase is UP
   *Mar 3 20:07:55.043: BR0:1 IPCP: O CONFREQ [Not negotiated] id 6 len 10

   *Mar 3 20:07:55.047: BR0:1 IPCP: Address 2.2.2.1 (0x030602020201)
   *Mar 3 20:07:55.051: BR0:1 CDPCP: O CONFREQ [Not negotiated] id 9 len 4

   *Mar 3 20:07:55.115: BR0:1 IPCP: I CONFREQ [REQsent] id 9 len 10
   *Mar 3 20:07:55.119: BR0:1 IPCP: Address 1.1.1.1 (0x030601010101)
   *Mar 3 20:07:55.123: BR0:1 IPCP: O CONFACK [REQsent] id 9 len 10
   *Mar 3 20:07:55.127: BR0:1 IPCP: Address 1.1.1.1 (0x030601010101)
   *Mar 3 20:07:55.131: BR0:1 CDPCP: I CONFREQ [REQsent] id 9 len 4
   *Mar 3 20:07:55.135: BR0:1 CDPCP: O CONFACK [REQsent] id 9 len 4
   *Mar 3 20:07:55.139: BR0:1 IPCP: I CONFACK [ACKsent] id 6 len 10
   *Mar 3 20:07:55.143: BR0:1 IPCP: Address 2.2.2.1 (0x030602020201)
   *Mar 3 20:07:55.147: BR0:1 IPCP: State is Open
   *Mar 3 20:07:55.151: BR0:1 CDPCP: I CONFACK [ACKsent] id 9 len 4
   *Mar 3 20:07:55.155: BR0:1 CDPCP: State is Open
   *Mar 3 20:07:55.159: BRI0:1 DDR: dialer protocol up
   *Mar 3 20:07:55.167: Di1 IPCP: Install route to 1.1.1.1
   *Mar 3 20:07:56.039: %LINEPROTO-5-UPDOWN: Line protocol on Interface
   BRI0:1, changed state to up
   *Mar 3 20:08:00.411: %ISDN-6-CONNECT: Interface BRI0:1 is now connected
   to <unknown phone number> ramses

   sphinx#show dialer

   BRI0 - dialer type = ISDN

   Dial String Successes Failures Last DNIS Last status
   0 incoming call(s) have been screened.
   0 incoming call(s) rejected for callback.

   BRI0:1 - dialer type = ISDN
   Idle timer (120 secs), Fast idle timer (20 secs)
   Wait for carrier (30 secs), Re-enable (15 secs)
   Dialer state is data link layer up
   Interface bound to profile Dialer1
   Time until disconnect 95 secs
   Connected to <unknown phone number> (ramses)
   
! --- We see ramses.

			BRI0:2 - dialer type = ISDN
   Idle timer (120 secs), Fast idle timer (20 secs)
   Wait for carrier (30 secs), Re-enable (15 secs)
   Dialer state is idle

   Dialer1 - dialer type = DIALER PROFILE
   Idle timer (120 secs), Fast idle timer (20 secs)
   Wait for carrier (30 secs), Re-enable (15 secs)
   Dialer state is data link layer up
   Number of active calls = 1
   Number of active circuit switched calls = 0

   Dial String Successes Failures Last DNIS Last status

   sphinx#show ip route
   Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP

   D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
   N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
   E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
   i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS
   inter area
   * - candidate default, U - per-user static route, o - ODR
   P - periodic downloaded static route

   Gateway of last resort is not set

   1.0.0.0/32 is subnetted, 1 subnets
   C 1.1.1.1 is directly connected, Dialer1
   2.0.0.0/32 is subnetted, 1 subnets
   C 2.2.2.1 is directly connected, Loopback1
   sphinx#

Дополнительные сведения


Document ID: 12481