Асинхронный режим передачи (ATM) : IP over ATM

Вопросы и ответы о мостовой передаче в ATM-интерфейсах

5 апреля 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Содержание


Введение

Этот документ содержит ответы на часто задаваемые вопросы, касающиеся использования мостов для интерфейсов маршрутизатора ATM.

Вопрос. Поддерживает ли GSR использование моста?

О. Нет. GSR выполняет Cisco Выпуски ПО IOS� 12.0S и 11.2GS, которые разработаны для обеспечения устойчивого IP routing и сервисов улучшенного IP для сообщества интернет-провайдера (ISP). Они не поддерживают протоколы мостовой передачи, например прозрачный режим моста или мост от источника, а также интегрированную маршрутизацию и мостовую передачу (IRB). Однако можно использовать мостовые постоянные виртуальные каналы (BPVC), чтобы позволить картам линии ATM соединяться с Коммутатором Catalyst или с другим удаленным устройством, которое поддерживает мостовой RFC Request For Comments 1483 leavingcisco.com PDU только.

В. Поддерживает ли Catalyst 6000 FlexWAN модуль данных мостового протокола RFC 1483 (PDU)?

Ответ. Да. Производительность этой функции меняется в зависимости от Cisco IOS Software Release, который определяет, поддерживаются ли такие PVCs в пути пересылки программного или аппаратного обеспечения.

Cisco IOS 12.1 (13) E представляет протокольные информационные единицы моста RFC 1483 аппаратной поддержки на Серии Cisco 7600 с адаптером для порта ATM PA-A3 и FlexWAN. Cisco рекомендует обновить к этому выпуску для обеспечения максимальной скорости переадресации. В предыдущих версиях протокольная информационная единица моста RFC 1483 значительно уменьшает скорость переадресации Catalyst 6000 при использовании "IRB" и не рекомендуется.

Если не удается выполнить обновление до Cisco IOS 12.1(13)E, альтернативным решением будет использование модуля OC-12 ATM (WS-X6101) для Catalyst 6000 для поддержки приложений второго уровня, таких как PDU в формате моста или эмуляция LAN (LANE). Если вы не можете использовать OC-12, интерфейсное и приложение является агрегацией цифровой абонентской линии (DSL), используйте Cisco 7200 или 7400 Series Router рабочая инкапсуляция маршрутизированного моста (RBE).

Cisco IOS 12.1 (5a) E1 представила поддержку протокольных информационных единиц моста RFC 1483 на FlexWAN с PA-A3. В этом выпуске требуется скрытая команда cwan atm bridge. Мы рекомендуем рабочую Cisco IOS 12.1 (11a) E1 или выше избегать CSCdw22284 и CSCdw44684. Команда cwan atm bridge не необходима при использовании Cisco IOS 12.1 (13) E или более новая.

Протокольные информационные единицы моста RFC 1483 поддерживаются в обеих Cisco IOS (Собственный IOS) и Гибридный режим (MSFC) начиная с Cisco IOS 12.1 (13) E или более новое программное обеспечение. В следующей таблице приводится пример конфигурации для модулей данных протокола RFC 1483 на FlexWAN и PA-A3. Убедитесь, что правильная VLAN сопоставлена с правильной PVC. Эта конфигурация реализована в распределенном пути FlexWAN.

Пример конфигурации для протокольных информационных единиц моста RFC 1483 12.1 (13) E1 или позже
vlan 30 
! 
interface FastEthernet7/1 
 no ip address 
 duplex full 
 speed 100 
 switchport 
 switchport access vlan 30 
! 
interface ATM9/1/0 
 no ip address  
 mtu 4096
 atm bridge-enable 
  bandwidth 2000 
  pvc 0/39  
  bridge-vlan 30 
 encapsulation aal5snap 
! 
router rip 
 network 10.0.0.0 
 network 30.0.0.0 
! 

Оптический сервисный модуль (OSM) OC-12 ATM для Серии Cisco 7600 также поддерживает RFC 1483, соединяя. Для получения дополнительной информации и пример конфигурации, посмотрите Настройку Сервисные модули Оптических сетей ATM OC-12.

Вопрос. . Почему модули ATM Catalyst 5000/6000 не устанавливают мост между двумя субинтерфейсами в той же самой виртуальной локальной сети (VLAN)?

О. Руководства по конфигурации для модулей ATM обращают внимание на придерживающееся ограничение: Если два PVCs настроены на той же VLAN и модуле ATM, пакеты, полученные от одного PVC, не переданы к другому PVC. Причина этого связана с архитектурой модулей. Серия WS-X515x и WS-X5166 используют однонаправленную микросхему интерфейса объединительной платы, которая препятствует тому, чтобы модуль передал пакеты это, это получает. В серии WS-X516x используются две микросхемы интерфейса однонаправленной объединительной платы. Однако он не может посылать те же пакеты, что и принимает из-за функции автоматического подавления эхо, которая включена по умолчанию и помогает предотвратить появление петель, поскольку логика покрывающего дерева на Catalyst 5000 действует только для отдельных портов или VLAN, но не для отдельных PVC.

Способы разрешения проблемы таковы:

  • Вместо топологии звезды следует использовать схему ATM PVC full-mesh.

  • Используйте маршрутизатор, сконфигурированный со стандартным мостовым соединением Cisco IOS. Необходимо настроить два разных интерфейса в одной группе мостов, чтобы разрешить широковещанию и другому трафику проходить между двумя удаленными хостами.

  • Используйте модуль коммутации маршрутов (RSM), плату коммутации маршрутов (RSFC) или плату многоуровневой коммутации (MSFC). Разъедините PVC на маршрутизаторе, а затем установите между ними маршрут или мостовое соединение.

Вопрос. . Поддерживают ли маршрутизаторы Cisco мостовой формат инкапсуляции RFC 1483 aal5mux?

О. Нет. Виртуальный канал (VC) - базирующееся мультиплексирование требует, чтобы инкапсулированный или перенесенный протокол был вручную настроен на ATM-интерфейсе. Cisco поддерживает следующие протоколы с инкапсуляцией aal5mux:

7500-1(config-subif)#atm pvc 1 0 200 aal5mux ? 
     apollo     Apollo Domain 
     appletalk  AppleTalk 
     decnet     DECnet 
     ip         IP 
     ipx        Novell IPX 
     vines      Banyan VINES 
     xns        Xerox Network Services

С мультиплексированием на основе VC сетевой протокол, используемый в сети ATM, явно определяется VC, соединяющем две станции ATM. Т.е. каждый протокол нужно перенести по отдельному VC. Это не доступно на Cisco 7600 с OSM ATM.

Вопрос. . Будет ли маршрутизатор передавать заголовок 802.1Q через интерфейс ATM?

О. Нет. В придерживающейся топологии маршрутизатор не сохранит метку 802.1Q при мостовом соединении по соединению ATM. Метка 802.1Q удалена в Интерфейсе Ethernet.

/image/gif/paws/10405/atm_bridging_faq.gif

Однако есть другой способ построения сквозных VLAN. Настройте оба маршрутизатора с одним и тем же набором мостовых групп и субинтерфейсов 802.1Q. Другими словами, два конца маршрутизатора имеют взаимно однозначное сопоставление между группой моста и подчиненным интерфейсом 802.1Q. Это не применимо к Cisco 7600.

Конфигурация маршрутизатора для сквозных виртуальных локальных сетей (VLAN)
interface FastEthernet4/0 
no ip address 
! 
interface FastEthernet4/0.100 
 encapsulation dot1Q 100 
 bridge-group 1 
! 
interface atm 5/0.100 
 bridge-group 1

Кроме того, Cisco IOS теперь поддерживает виртуальные частные сети уровня 2 (VPN) для прозрачного переноса архитектуры Уровня 2 по облаку ATM. Any Transport over Multiprotocol Label Switching (AToM) является решением Cisco для транспортировки пакетов Уровня 2 по Протоколу Интернета / Многопротокольная коммутация по меткам (IP/MPLS) магистраль. Атом расширяет удобство пользования IP - сетей путем включения транспорта кадров Уровня 2 по магистрали MPLS. AToM требуется для поддержки традиционных служб по инфраструктурам MPLS и для поддержки нескольких новых параметров подключения, включая Virtual Leased Line Уровня 2 и Сети VPN второго уровня. Для получения дополнительной информации о AToM см. Обзор - Cisco Любой Транспорт по MPLS.

ST/12.0 Cisco IOS Software Release 12.0 (10) (21) Ст и 12.0 (22) S представляет поддержку Атома ATM (AAL5 по MPLS) на линейных картах ATM серии Cisco 12000. Посмотрите ATM AToM MPLS AAL5 по MPLS для получения дополнительной информации. Программное обеспечение Cisco IOS версии 12.0 (22) SY представляет Ретрансляцию клеток ATM по MPLS на серии 7200 и серии 7500.

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения


Document ID: 10405