Технологии коммутируемого доступа в сеть : "Технология ISDN, CAS"

Настройка NFAS для четырех каналов T1

20 октября 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Содержание


Введение

Non-facility Associated Signaling (NFAS) ISDN позволяет одиночному каналу D управлять множественными Интерфейсами первого уровня (PRI). Когда основной D-канал NFAS отказывает, можно настроить резервный канал D. При настройке контроллеров T1 с разделением каналов для PRI ISDN только необходимо настроить канал D основного канала NFAS; его конфигурация распределена всем участникам cвязанной группы NFAS.

При помощи одиночного канала D к управлению множественными интерфейсами PRI один дополнительный канал на каждом интерфейсе свободен нести трафик данных. Любой серьезный отказ основного D-канала-сигнализации приводит к мгновенному переключению к резервному каналу D, не разъединяя в настоящее время подключенных пользователей.

Примечание: При настройке резервного канала D только 23 канала B могут использоваться на резервном контроллере T1, потому что канал D на резервной копии недоступен. Поэтому только те T1s, которые не являются ни основными, ни резервные, могут иметь 24 канала B в наличии. В этой конфигурации контроллер T1 4/0 является основным и имеет 23 доступных канала B, и контроллер T1 4/1 является резервной копией и имеет 23 доступных канала B. Контроллеры T1 5/0 и 5/1 у каждого есть 24 доступных канала B.

Предварительные условия

Требования

Предварительные условия для NFAS следующие:

  • NFAS поддерживается только с контроллером T1 с разделением каналов, и, в результате контроллеры T1 должны также быть настроены для PRI ISDN прежде, чем внедрить NFAS. Для получения дополнительной информации о настройке ISDN обратитесь к Странице Поддержки цифровых линий ISDN.

  • Маршрутизатор, настроенный для NFAS, должен соединиться или с 4ess, dms250, dms100 или с Тип коммутатора национальной ISDN.

    Примечание: NFAS не поддерживается на коммутаторах типа primary-5ess. Консультируйтесь со своим Поставщиком услуг или Telco (телефонная компания), чтобы определить, может ли NFAS быть настроен для вашей линии T1.

  • NFAS должен быть настроен на коммутаторе ISDN вашего Telco (телефонная компания).

  • Необходимо использовать Cisco Выпуск ПО IOS� 11.3T или позже.

Используемые компоненты

Сведения, содержащиеся в данном документе, касаются следующих версий программного обеспечения и оборудования:

  • Следующая конфигурация была протестирована с маршрутизатором Cisco 7507 рабочее программное обеспечение Cisco IOS версии 12.0(5).

  • Эта конфигурация иллюстрирует, как установить четырех Членов NFAS в той же группе. Основным Интерфейсом NFAS является T1 4/0, и резервной копией является T1 4/1. Контроллеры T1 5/0 и 5/1 имеют 24 канала B в наличии для них

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в этом документе, были запущены с чистой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд до их использования.

Условные обозначения

Дополнительные сведения об условных обозначениях в документах см. Cisco Technical Tips Conventions.

Общие сведения

Терминология NFAS

Обычно используемые термины NFAS следующие:

  • NFAS - Сервис ISDN, который позволяет одиночный канал D управлению множественными интерфейсами PRI. Использование одиночного канала D к управлению множественными интерфейсами PRI позволяет одному каналу B на каждом интерфейсе нести другой трафик.

  • 24 интерфейса канала B - группа каналов PRI, настроенная, чтобы не иметь никакого канала D NFAS; все эти 24 канала являются каналами B. Этот определенный T1 использует канал D, настроенный в главном контроллере для сигнализации.

  • Группа NFAS - группировка канала PRI (группа интерфейсов) под контролем одиночного канала D. Группа каналов может включать все каналы ISDN на множественных контроллерах T1.

    Примечание: NFAS может быть настроен с участниками в других слотах на маршрутизаторе (например, Члены NFAS не ограничены тем, чтобы быть на том же слоте или модуле). Кроме того, в отдельном шасси поддерживаются пять групп NFAS. В случаях, где T1s от нескольк поставщиков используются, они часто группируются поставщиком.

  • Член NFAS - PRI в группе NFAS. Например, если контроллеры T1 1/0, 1/1, и 2/0 настроены в одной группе NFAS, группа NFAS могла бы включать последовательные интерфейсы 1/0:23, 1/1:23, и 2/0:23. Для отображения участников всей группы NFAS используйте команду EXEC show isdn nfas group, которой дают привилегию.

Требуемая команда

Примечание: Обычные команды конфигурации PRI ISDN не появляются в этом документе. Посмотрите Раздел связанных сведений для получения дополнительной информации о настройке PRI ISDN.

pri-group timeslots 1-24 nfas_d функционирует nfas_interface int_number nfas_group group_number

Эта команда конфигурации контроллера назначает контроллер T1 на группу NFAS и определяет ее функцию в группе. Задайте следующие значения как соответствующие:

  • функция - функция, которая будет выполнена к временному интервалу 24, или основной, резервный, или ни один. У каждой группы NFAS должен быть один основной. Маршрутизатор не требует резервной копии, однако большинство реализаций NFAS действительно имеет резервный канал D. Свяжитесь со своим telco (телефонная компания), чтобы определить, необходимо ли настроить резервный канал D для группы NFAS. Остаток контроллеров не может быть настроен ни с одним, который определяет 24-й временной интервал как канал B.

    Примечание: Настройте основные и резервные каналы D точно, как задано вашим Telco (телефонная компания). Распространенная ошибка с конфигурацией NFAS неправильно определяет, какой T1 является основным и который является резервной копией.

  • int_number - Значение, назначенное поставщиком услуг и используемое для однозначного определения PRI. Значения возможный диапазон от 0 до самого высокого t1, доступного на маршрутизаторе, минус один. Например, если маршрутизатор имеет 10 T1s, номер Интерфейса NFAS может расположиться между 0 и 9. Эти 0 интерфейсов должны быть назначены на основной канал D и этот 1 интерфейс к резервному каналу D.

    Примечание: В определенных сценариях, где настройка NFAS не использует резервный канал D, не используйте ключевое слово nfas_interface 1, поскольку это зарезервировано для резервного канала D. Настройте только nfas_interfaces 0, 2, 3, 4 и так далее.

    Примечание: При настройке множественных групп NFAS эти 0 интерфейсов должны быть назначены на каждый основной канал D и этот 1 интерфейс к каждому резервному каналу D, если они находятся в другом nfas_group.

  • group Number- Идентификатор группы, уникальный на маршрутизаторе. Множественные группы NFAS могут существовать на маршрутизаторе. Каждая группа должна быть настроена с основным и дополнительным контроллером.

Настройка

В этом разделе содержатся сведения о настройке функций, описанных в этом документе.

Примечание: Поиск дополнительной информации о командах в данном документе можно выполнить с помощью средства "Command Lookup" (Поиск команд) (только для зарегистрированных клиентов).

Схема сети

В настоящем документе используется следующая схема сети:

/image/gif/paws/9584/quadt1_nfas.gif

Конфигурации

Эти конфигурации используются в данном документе:

Cisco 7507
! 
! 
Last configuration change at 13:07:00 cst Mon Jan 31 2000 
!
version 12.0 
no service pad 
service timestamps debug uptime 
service timestamps log datetime localtime show-timezone 
no service password-encryption 
! 
hostname Router 
! 
enable secret 
! 
ip subnet-zero 
no ip domain-lookup 
ip host west 172.22.173.21
isdn switch-type primary-dms100 

!--- Switchtype must be configured. 
!--- Contact your Telco for more information.
!--- Primary T1 controller.

controller T1 4/0 
framing esf 
linecode b8zs 
pri-group timeslots 1-24 nfas_d primary nfas_int 0 nfas_group 1 

!--- Primary D channel, nfas interface 0 and member of group 1.

controller T1 4/1 
framing esf 
linecode b8zs 
pri-group timeslots 1-24 nfas_d backup nfas_int 1 nfas_group 1 


!--- Backup D channel, nfas interface 1 and member of group 1. 


controller T1 5/0 
framing esf 
linecode b8zs 
pri-group timeslots 1-24 nfas_d none nfas_int 2 nfas_group 1 

!--- 24th timeslot used as B channel, nfas interface 2 and member of group 1.


controller T1 5/1 
framing esf 
linecode b8zs 
pri-group timeslots 1-24 nfas_d none nfas_int 3 nfas_group 1 

!--- 24th timeslot used as B channel, nfas interface 3 and member of group 1.

process-max-time 200 
! 
interface FastEthernet1/0/0   
 ip address 10.1.1.1 255.255.255.0 
 no ip directed-broadcast 
 no ip route-cache distributed 
 no ip mroute-cache 
 full-duplex 
! 
interface FastEthernet1/1/0 
 no ip address 
 no ip directed-broadcast 
 no ip route-cache distributed 
 no ip mroute-cache 
 shutdown 

!--- D channel for primary controller.
!--- Note: Other D channels in the group are not seen.
!--- All configuration changes made to the primary D channel propagate 
to all the NFAS group members.


interface Serial4/0:23 
 description primary d channel 
 no ip address 
 no ip directed-broadcast 
 encapsulation ppp 
 dialer pool-member 1 
 isdn switch-type primary-dms100 
 isdn tei-negotiation first-call 
 ppp authentication chap 
 ppp multilink 
! 
interface Dialer0 
 ip address 192.168.10.1 255.255.255.0 
 no ip directed-broadcast 
 encapsulation ppp 
 dialer remote-name C3620-EA-BCO 
 dialer pool 1 
 dialer-group 1 
 ppp authentication chap 
 ppp multilink 
!
router eigrp 200 
 redistribute static 
 network 10.0.0.0 
 network 192.168.10.0 

! 
no ip classless 
ip route 0.0.0.0 0.0.0.0 10.1.1.2 
! 
dialer-list 1 protocol ip permit 
! 
line con 0 
 transport input none 
line aux 0 
 password
   login
  modem InOut
  stopbits 1
 line vty 0 4
  exec-timeout 60 0
  password 
 login 
! 
end

Проверка

В этом разделе содержатся сведения, которые помогают убедиться в надлежащей работе конфигурации.

Некоторые команды show поддерживаются Средством интерпретации выходных данных(только зарегистрированные клиенты), которое позволяет просматривать аналитику выходных данных команды show.

  • show isdn status- Удостоверьтесь, что маршрутизатор должным образом связывается с коммутатором ISDN. В выходных данных команды проверьте наличие сообщений: Layer 1 Status is ACTIVE (Уровень 1 активен) и Layer 2 Status state = MULTIPLE_FRAME_ESTABLISHED (Состояние уровня 2 = MULTIPLE_FRAME_ESTABLISHED).

  • show isdn nfas group - Привилегированная команда EXEC для отображения участников указанной группы NFAS или всех групп NFAS.

  • show isdn service - Привилегированная команда EXEC для показа и сервисного статуса состояния каждого канала ISDN. Каналы D обозначены, как зарезервировано. Эта команда может использоваться, чтобы проверить, заняты ли отдельные каналы или неисправны.

  • show controller t1 – отображает состояние контроллера, типичное для оборудования контроллера. Это также отображает информацию для устранения проблем проблем физического уровня и канального уровня. На нормальной работе выходные данные должны указать, что контроллер подключен и что нет никаких сигналов тревоги.

Примечание: Удостоверьтесь, что соединение T1, определяемое как основное Telco (телефонная компания) и в вашей конфигурации маршрутизатора, связано с правильным портом. Распространенная ошибка имеет неправильную линию T1 (кабели), связанные с основным портом T1 на вашем маршрутизаторе.

Образец команды show output

Придерживающееся является некоторыми выходными данными команды show от маршрутизатора, настроенного с NFAS.

Вот пример выходных данных команды show isdn status:

Router#show isdn status 
Global ISDN Switchtype = primary-dms100 
ISDN Serial4/0:23 interface
         dsl 0, interface ISDN Switchtype = primary-dms100 : 
Primary D channel of nfas group 1
     Layer 1 Status:
         ACTIVE

!--- Primary D channel is active

    Layer 2 Status: 
        TEI = 0, Ces = 1, SAPI = 0, State = MULTIPLE_FRAME_ESTABLISHED 

!--- Layer 2 is established correctly

    Layer 3 Status: 
        23 Active Layer 3 Call(s) 
    Activated dsl 0 CCBs = 23 
        CCB:callid=0xA0B, sapi=0x0, ces=0x0, B-chan=1 
        CCB:callid=0xA0C, sapi=0x0, ces=0x0, B-chan=3 
        CCB:callid=0xA0D, sapi=0x0, ces=0x0, B-chan=4 
        CCB:callid=0xA0E, sapi=0x0, ces=0x0, B-chan=2 
        CCB:callid=0xA0F, sapi=0x0, ces=0x0, B-chan=5 
        CCB:callid=0xA10, sapi=0x0, ces=0x0, B-chan=6 
        CCB:callid=0xA11, sapi=0x0, ces=0x0, B-chan=7 
        CCB:callid=0xA12, sapi=0x0, ces=0x0, B-chan=8 
        CCB:callid=0xA13, sapi=0x0, ces=0x0, B-chan=9 
        CCB:callid=0xA14, sapi=0x0, ces=0x0, B-chan=10 
        CCB:callid=0xA15, sapi=0x0, ces=0x0, B-chan=11 
        CCB:callid=0xA16, sapi=0x0, ces=0x0, B-chan=12 
        CCB:callid=0xA17, sapi=0x0, ces=0x0, B-chan=13 
        CCB:callid=0xA18, sapi=0x0, ces=0x0, B-chan=14 
        CCB:callid=0xA1B, sapi=0x0, ces=0x0, B-chan=15 
        CCB:callid=0xA1C, sapi=0x0, ces=0x0, B-chan=16 
        CCB:callid=0xA1D, sapi=0x0, ces=0x0, B-chan=17 
        CCB:callid=0xA1E, sapi=0x0, ces=0x0, B-chan=18 
        CCB:callid=0xA1F, sapi=0x0, ces=0x0, B-chan=19 
        CCB:callid=0xA20, sapi=0x0, ces=0x0, B-chan=20 
        CCB:callid=0xA21, sapi=0x0, ces=0x0, B-chan=21 
        CCB:callid=0xA22, sapi=0x0, ces=0x0, B-chan=22 
        CCB:callid=0xA23, sapi=0x0, ces=0x0, B-chan=23 
    The Free Channel Mask:  0x80000000 
ISDN Serial4/1:23 interface
         dsl 1, interface ISDN Switchtype = primary-dms100 :
 Backup D channel of nfas group 1
     Layer 1 Status:
         DEACTIVATED
     Layer 2 Status:
         TEI = 0, Ces = 1, SAPI = 0, State = TEI_ASSIGNED 
    Layer 3 Status: 
        0 Active Layer 3 Call(s) 
    Activated dsl 1 CCBs = 0 
    The Free Channel Mask:  0x7E7FFB 
ISDN Serial5/0:23 interface
         dsl 2, interface ISDN Switchtype = primary-dms100 :
 Group member of nfas group 1
     Layer 1 & 2 Status Not Applicable
 
!--- NFAS member: D channel is used as B channel.

    Layer 3 Status: 
        0 Active Layer 3 Call(s) 
    Activated dsl 2 CCBs = 0 
    The Free Channel Mask:  0x0 
ISDN Serial5/1:23 interface
         dsl 3, interface ISDN Switchtype = primary-dms100 :
 Group member of nfas group 1 
    Layer 1 & 2 Status Not Applicable

!--- NFAS member-channel is used as B channel.

    Layer 3 Status: 
        0 Active Layer 3 Call(s) 
    Activated dsl 3 CCBs = 0 
    The Free Channel Mask:  0x80000000 
    Total Allocated ISDN CCBs = 23

Примечание: Выходные данные show isdn status только отображают информацию относительно канал D для основного и резервных контроллеров. Кроме того, только основной канал D (Serial4/0:23) показывает АКТИВНЫЙ и УСТАНОВЛЕННЫЙ СОСТАВНОЙ ФРЕЙМ. Резервный статус канала D (Serial4/1:23) появляется, как ДЕАКТИВИРОВАНО и TEI_ASSIGNED.

Выходные данные show isdn status для Уровня 1 и Уровень 2 для T1 5/0 и 5/1 названы НЕ ПРИМЕНИМЫМИ, потому что 24-й канал (Serial5/0:23 и Последовательный 5/1:23) используется в качестве канала B.

Вот выходные данные команды show isdn nfas group:

Router#show isdn nfas group 1 
ISDN NFAS GROUP 1 ENTRIES:The primary D is Serial4/0:23.    
The backup D is Serial4/1:23.    
The NFAS member is Serial5/0:23.    
The NFAS member is Serial5/1:23. 
There are 4 total nfas members.    
There are 68 total available B channels. 
The primary D-channel is DSL 0 in state IN SERVICE. 
The backup D-channel is DSL 1 in state OUT OF SERVICE. 
The current active layer 2 DSL is 0.

Примечание: Выходные данные show isdn nfas group показывают участникам группы. Выходные данные показывают, что контроллер 4/0 является основным, и 4/1 является резервной копией. Контроллеры 5/0 и 5/1 являются участниками группы и имеют 24 канала B в наличии для них.

Выходные данные также показывают общее число Членов NFAS и количество доступных каналов. Это показывает, что основной канал D работает, в то время как резервная копия Out Of Service.

Вот пример выходных данных команды show isdn service:

Router# show isdn service 
PRI Channel Statistics:
 ISDN Se4/0:23, Channel [1-24]
      Configured Isdn Interface (dsl) 0
      Channel State (0=Idle 1=Propose 2=Busy 3=Reserved 4=Restart 5=Maint_Pend)
      0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 3
      Service State (0=Inservice 1=Maint 2=Outofservice)
      0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 
 ISDN Se4/1:23, Channel [1-24]
     Configured Isdn Interface (dsl) 1
     Channel State (0=Idle 1=Propose 2=Busy 3=Reserved 4=Restart 5=Maint_Pend)
     2 2 0 2 2 2 2 2 2 2 2 2 2 2 2 0 0 2 2 2 2 2 0 3  
     Service State (0=Inservice 1=Maint 2=Outofservice) 
     0 0 2 0 0 0 0 0 0 0 0 0 0 0 0 2 2 0 0 0 0 0 0 0  
ISDN Se5/0:23, Channel [1-24] 
     Configured Isdn Interface (dsl) 2 
     Channel State (0=Idle 1=Propose 2=Busy 3=Reserved 4=Restart 5=Maint_Pend)    
     2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2  
     Service State (0=Inservice 1=Maint 2=Outofservice) 
     0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0  
ISDN Se5/1:23, Channel [1-24] 
     Configured Isdn Interface (dsl) 3 
     Channel State (0=Idle 1=Propose 2=Busy 3=Reserved 4=Restart 5=Maint_Pend)    
     2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2  
     Service State (0=Inservice 1=Maint 2=Outofservice) 
     0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0  
Router#

Выходные данные show isdn service показывают, что каналы D для основного и вторичного устройства находятся в состоянии 3, который соответствует Зарезервированный. Каналы D для других участников находятся в состоянии 2, которое указывает, что они Заняты и в использовании в качестве каналов B. Состояние канала 0 указывает, что канал доступен для использования.

Примечание: Во многих устройствах (обычно Серверы доступа) Состояние сервиса для канала D равняется 2, указывая, что канал Out Of Service. Это - косметическая проблема и не должно влиять на ваше соединение. Чтобы определить, функционирует ли канал D фактически, используют команду show isdn status, как ранее описано

Для контроллеров, которые не определяются как основные или резервные (5/0 и 5/1), гарантируйте, что 24-й канал находится в Состоянии бездействия или Состоянии занятости. Это не должно быть в Зарезервированном состоянии.

Устранение неполадок

В этом разделе описывается процесс устранения неполадок конфигурации.

Команды для устранения неполадок

Некоторые команды show поддерживаются Средством интерпретации выходных данных(только зарегистрированные клиенты), которое позволяет просматривать аналитику выходных данных команды show.

Примечание: Прежде чем вызывать команды debug, обратитесь к разделу Важные сведения о командах отладки:

  • debug isdn q931- Покажите настройку вызова и разъедините сетевого подключения ISDN (Уровень 3).

  • debug isdn q921- Покажите сообщения уровня соединения данных (Уровень 2) на канале D между маршрутизатором и коммутатором ISDN. Используйте эту команду отладки, если команда show isdn status не показывает, что уровни 1 и 2 активны.

Если Закрыт Контроллер

Когда контроллер, принадлежащий группе NFAS, закрыт, что происходит? Все активные вызовы на том закрытом контроллере будут очищены, и одно из придерживающегося применится:

  • Если закрытый контроллер является основным, и никакая резервная копия не настроена, все активные вызовы на всей группе очищены.

  • Если закрытый контроллер является основным, активное (В ОБСЛУЖИВАНИИ) канал D находится на основном, и резервная копия настроена, активный канал D переключается на резервный контроллер.

  • Если закрытый контроллер является основным и активным (В ОБСЛУЖИВАНИИ), канал D находится на резервной копии, активный канал D остается на резервном контроллере.

  • Если закрытый контроллер является резервной копией, и активный канал D находится на резервной копии, активный канал D изменяется на главный контроллер.

Примечание: Активное переключение канала D между основным и резервными контроллерами происходит только, когда любая из ссылок отказывает и не, когда подходит ссылка.


Дополнительные сведения


Document ID: 9584