Технологии коммутируемого доступа в сеть : "Технология ISDN, CAS"

Настройка обратного вызова PPP через ISDN

20 октября 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Содержание


Введение

Этот документ предоставляет пример конфигурации для обратного вызова Протокола PPP по Цифровой сети с интеграцией услуг (ISDN). Можно использовать Обратный вызов для:

  • Консолидация и централизация выставления телефонных счетов.

  • Снижение затрат на междугородных телефонных разговорах.

  • Контроль доступа.

Предварительные условия

Требования

Для этого документа отсутствуют особые требования.

Используемые компоненты

Сведения, содержащиеся в данном документе, касаются следующих версий программного обеспечения и оборудования:

  • Cisco Выпуск ПО IOS� 11.0 (3) или позже.

  • Cisco 3640 (maui-nas-04) с Cisco IOS Software Release 12.0 (5) XK1.

  • Cisco 1604 (maui-soho-01) с программным обеспечением Cisco IOS версии 12.0(4)T.

Сведения, содержащиеся в данном документе, были получены с устройств в специальной лабораторной среде. Все устройства, описанные в данном документе, были запущены с конфигурацией по умолчанию. При работе с реальной сетью необходимо полностью осознавать возможные результаты использования всех команд.

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Условные обозначения технических терминов Cisco.

Общие сведения

В этом примере конфигурации обратный вызов использует PPP и средства, которые leavingcisco.comзадает RFC 1570. Завершение Обратного вызова PPP ISDN происходит в этом заказе:

  1. Маршрутизатор А создает коммутируемое соединение с маршрутизатором Б.

  2. Маршрутизаторы A и B выполняют согласование о Протоколе управления Канала "PPP" (LCP). Маршрутизатор A может запросить обратный вызов либо маршрутизатор B может инициировать обратный вызов.

  3. Маршрутизатор A аутентифицирует себя на маршрутизаторе B через Протокол аутентификации Пароля PPP (PAP) или Протокол аутентификации по квитированию вызова (CHAP). Маршрутизатор B может дополнительно аутентифицироваться на маршрутизаторе A.

  4. Оба маршрутизатора отбрасывают подключение с коммутацией каналов.

  5. Маршрутизатор Б создает коммутируемое соединение с маршрутизатором А.

Настройка

В этом разделе содержатся сведения о настройке функций, описанных в этом документе.

Примечание: Для получения дополнительной информации о командах, встречающихся в этом документе, используйте средство поиска команд

Схема сети

В настоящем документе используется следующая схема сети:

/image/gif/paws/9575/isdn-ppp-callback.gif

Конфигурации

Эти конфигурации используются в данном документе:

maui-soho-01: обратный вызов клиента
version 12.0
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname maui-soho-01
!
aaa new-model
aaa authentication login default local
aaa authentication ppp default local

!--- Basic AAA configuration for PPP calls.

!
username maui-nas-04 password 0 happy

!--- Username for remote router (maui-nas-04) and shared secret password.
!--- Shared secret (for CHAP authentication) must be the same on both sides.

username admin password 0 <deleted>
!
ip subnet-zero
!
isdn switch-type basic-ni
!
interface Ethernet0
 ip address 172.22.85.1 255.255.255.0
 no ip directed-broadcast
!
interface BRI0
 ip address 172.22.82.2 255.255.255.0
 no ip directed-broadcast
 encapsulation ppp
 dialer map ip 172.22.82.1 name maui-nas-04 20007

!--- Dialer map statements for the remote router.
!--- The name must match the name that the remote router uses to identify itself.

 dialer-group 1

!--- Apply interesting traffic definition from dialer-list 1.

 isdn switch-type basic-ni
 isdn spid1 20009
 ppp callback request

!--- Request PPP callback from the server.

 ppp authentication chap

!--- Use CHAP authentication.

!
no ip http server
ip classless
ip route 172.22.80.0 255.255.255.0 172.22.82.1
!
dialer-list 1 protocol ip permit

!--- Interesting traffic definition.
!--- Apply this to BRI0 with dialer-group 1.

line con 0
 transport input none
 stopbits 1
line vty 0 4
!
end

maui-nas-04: сервер обратного вызова
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname maui-nas-04
!
aaa new-model
aaa authentication login default local
aaa authentication ppp default local
!
username admin password <deleted>
username maui-soho-01 password happy

!--- Username for remote router (maui-soho-01) and shared secret password.
!--- Shared secret(for CHAP authentication) must be the same on both sides.

!
ip subnet-zero
no ip domain-lookup
!
isdn switch-type basic-ni
!
process-max-time 200
!
interface Ethernet0/0
 ip address 172.22.80.4 255.255.255.0
 no ip directed-broadcast
!
interface BRI1/1
 no ip address
 no ip directed-broadcast
 encapsulation ppp
 dialer rotary-group 10

!--- Assign BRI 1/1 to the rotary-group 10.
!--- Rotary-group properties are defined in interface Dialer 10.

 isdn switch-type basic-ni
 isdn spid1 20007
!
interface dialer10

!--- Interface for the dialer rotary-group 10 configuration.

 ip address 172.22.82.1 255.255.255.0
 no ip directed-broadcast
 encapsulation ppp
 dialer in-band
 dialer callback-secure 

!--- Disconnect calls that are not properly configured for callback.
!--- Disconnects any unconfigured dial-in users. 

dialer map ip 172.22.82.2 name maui-soho-01 class dial1 20009

!--- Dialer map statements for the callback.
!--- The name must match the name that the remote router uses to identify itself.
!--- Use map-class dialer dial1 for this connection.

 dialer-group 1
 ppp callback accept

!--- Allows the interface to accept a callback request to a remote host.

 ppp authentication chap
!
ip classless
ip route 172.22.85.0 255.255.255.0 172.22.82.2
no ip http server
!
map-class dialer dial1

!--- The dialer map statement uses this map class for the callback.

 dialer callback-server username

!--- Use authenticated username to identify return call dial string.

dialer-list 1 protocol ip permit
!
line con 0
 transport input none
line 65 70
line aux 0
line vty 0 4
!
end

Проверка

В этом разделе содержатся сведения, которые помогают убедиться в надлежащей работе конфигурации.

Некоторые команды show поддерживаются Интерпретатором выходных данных; это позволяет выполнять анализ выходных данных команды show.

  • interface type number show dialer — отображает общую диагностическую информацию для интерфейсов, которые вы настраиваете для технологии DDR. Исходный и конечный адреса пакета, инициировавшего вызов номера, показаны в строке причины вызова. Эта команда также отображает таймеры подключения.

  • show isdn status, что маршрутизатор должным образом связывается с коммутатором ISDN. In the output, verify that Layer 1 Status is ACTIVE, and that the Layer 2 Status state = MULTIPLE_FRAME_ESTABLISHED appears. This command also displays the number of active calls.

  • dialer enable-timeout seconds — включает таймаут сервера обратного вызова и определяет время между разъединением вызова вызова и инициализацией обратного вызова.

  • dialer hold-queue — позволяет клиенту обратного вызова и серверу считать пакеты предназначенными удаленному назначению, пока не сделано соединение.

Устранение неполадок

В этом разделе описывается процесс устранения неполадок конфигурации.

Команды для устранения неполадок

Некоторые команды show поддерживаются Интерпретатором выходных данных; это позволяет выполнять анализ выходных данных команды show.

Примечание: Прежде чем применять команды отладки, ознакомьтесь с разделом "Важные сведения о командах отладки".

  • debug ppp [пакет | согласование | ошибка | аутентификация] — отображает информацию на трафике и обменах в объединении нескольких локальных сетей, которое внедряет PPP.

    • пакет — отображает пакеты PPP, передаваемые и полученные. (Данная команда отображает низкоуровневые пакетные дампы.).)

    • negotiation — пакеты PPP показов передали во время запуска PPP, где об опциях PPP выполняют согласование.

    • ошибка — отображает ошибки протокола и статистику ошибок, привязанную к согласованию PPP - подключения и операции.

    • аутентификация — отображает сообщения протокола аутентификации и включает обмены пакетами Протокола аутентификации по квитированию вызова (CHAP) и обмены Протокола аутентификации пароля (PAP).

  • debug isdn q931 – отображает параметры настройки вызова и разрыва сетевого подключения ISDN (3-й уровень).

  • debug isdn q921 – отображает сообщения канального (2-го) уровня на канале D между маршрутизатором и коммутатором ISDN. Используйте эту команду отладки, если команда show isdn status не показывает, что уровни 1 и 2 активны.

  • debug dialer [events | packets] – отображает отладочные сведения DDR о пакетах, принимаемых через интерфейс номеронабирателя.

Пример результата отладки


!--- maui-soho-01 (callback client:172.22.82.2) pings maui-nas-04. 
!--- (Callback server:172.22.80.4 - Ethernet interface).
!--- and starts the callback process.
!--- Debugs are collected on maui-soho-01.



maui-soho-01#debug dialer events 
maui-soho-01#show debugging 
Dial on demand: 
  Dial on demand events debugging is on
maui-soho-01#ping 172.22.80.4 
   Type escape sequence to abort. 
   Sending 5, 100-byte ICMP Echos to 172.22.80.4, timeout is 2 seconds: 
   *Mar 8 23:13:02.117: BRI0 DDR: Dialing cause ip (s=172.22.82.2, d=172.22.80.4)    
   *Mar 8 23:13:02.117: BRI0 DDR: Attempting to dial 20007 
   *Mar 8 23:13:02.333: %LINK-3-UPDOWN: Interface BRI0:1, changed state to up 
   *Mar 8 23:13:02.353: isdn_call_connect: Calling lineaction of BRI0:1 
   *Mar 8 23:13:02.417: BRI0:1 DDR: Callback negotiated - waiting for
    server disconnect 
   *Mar 8 23:13:02.493: %LINK-3-UPDOWN: Interface BRI0:1, changed state to down.    
   *Mar 8 23:13:02.509: DDR: Callback client for maui-nas-04 20007 created 
   *Mar 8 23:13:02.509: isdn_call_disconnect: Calling lineaction of BRI0:1 
   *Mar 8 23:13:02.513: BRI0:1 DDR: disconnecting call.... 
   Success rate is 0 percent (0/5) 

   
!--- A few seconds later, maui-soho-01 receives the callback from maui-nas-04. 

   
   maui-soho-01# 
   *Mar 8 23:13:17.537: %LINK-3-UPDOWN: Interface BRI0:1, changed state to up 
   *Mar 8 23:13:17.553: isdn_call_connect: Calling lineaction of BRI0:1 
   *Mar 8 23:13:19.697: BRI0:1 DDR: No callback negotiated 
   *Mar 8 23:13:19.717: BRI0:1 DDR: dialer protocol up 
   *Mar 8 23:13:19.717: BRI0:1 DDR: Callback received from maui-nas-04 20007 
   *Mar 8 23:13:19.721: DDR: Freeing callback to maui-nas-04 20007 
   *Mar 8 23:13:20.697: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI0:1, 
       changed state to up 
   *Mar 8 23:13:23.553: %ISDN-6-CONNECT: Interface BRI0:1 is now connected to 
       20007 maui-nas-04 
   
!--- Verifies that the connection was successful


maui-soho-01#ping 172.22.80.4 
   Type escape sequence to abort. 
   Sending 5, 100-byte ICMP Echos to 172.22.80.4, timeout is 2 seconds: 
   !!!!! 
   Success rate is 100 percent (5/5), round-trip min/avg/max = 36/36/36 ms

Дополнительные сведения


Document ID: 9575