Cервисы организации сетевого доступа к приложениям : Модули контента Cisco серии 500

Конфигурация прозрачного и прокси- перенаправления данных с помощью программного обеспечения ACNS версии 4.x

5 апреля 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Содержание


Введение

Этот документ описывает, как настроить Cisco Cache/Content Engine для прозрачного и кэширования средств прокси с помощью версии 2 Протокола координации веб-кэша (WCCP). Выпуск 4.x ACNS Cisco, включает, как опция, RealProxy от RealNetworks, Inc. leavingcisco.com для поддержки обоих потоковых разделений (распределяющий оперативную подачу) и кэширование потоковых мультимедиа (по требованию содержание) и в Протоколе RTSP - основанная потоковая передача и в другом Реальном PNM (метафайл RealNetworks) форматы.

Модуль контента может быть настроен для прозрачного принятия запросов RTSP, перенаправленных от маршрутизатора WCCP, а также традиционных запросов RTSP стиля прокси от клиентского программного обеспечения RealPlayer. Потоковое медиа-данные кэширование предоставляет содержание по требованию расширению этого, если пользователь уже просмотрел кэшируемый потоковый медиа-данные файл, это может быть подано следующим пользователям без требования для соединения с исходным сервером. Знайте, что не могут кэшироваться прямые трансляции.

Для настройки Модуля контента для принятия трафика RTSP выполните эти шаги:

  1. Выполните команду RTSP - прокси в режиме глобальной конфигурации для ввода IP-адреса, порта и лицензии, используемой в RealProxy Модуля контента.

  2. Выполните команду глобальной кофигурации кэша сред wccp для регистрации Модуля контента в любых поддерживающих WCCP маршрутизаторах.

В то время как Программное обеспечение RealProxy скопировано к системе файла программного обеспечения (swfs) разделение как часть процедуры установки, потоковые медиа-данные объекты кэшируются в системе медиа-файла (mediafs) разделы диска. Выполните дисковую команду для создания отделений mediafs; выйдите команда mediafs для поддержания этих отделений (обратитесь к Поддержанию Хранилища Жесткого диска для получения дополнительной информации о разделах диска). Программное обеспечение RealProxy может быть администрируемо с RealAdministrator GUI� (для доступа к этой странице, имя пользователя по умолчанию / пароль является admin/ромбом).

Для настройки поддерживающих WCCP маршрутизаторов необходимо выполнить команду wccp service-group 80. Выходные данные Command показывают в разделе Конфигураций.

Перед началом работы

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Технические рекомендации Cisco. Условные обозначения.

Предварительные условия

Для данного документа отсутствуют предварительные условия.

Требования

Для использования данного документа требуется знание следующих тем:

  • Модуль контента, выполняющий Выпуск 4.x Программного обеспечения ACNS или позже

  • Программное обеспечение RealProxy, установленное с отделениями mediafs, повысилось

Примечание: Необходимо купить лицензионный ключ для активирования опций RealProxy в программном обеспечении Кэша. Для заказа на Cisco.com обратитесь к Заказу.

Используемые компоненты

Сведения, содержащиеся в данном документе, касаются следующих версий программного и аппаратного обеспечения:

  • Модуль контента Cisco 590 рабочих Выпусков 4.x программного обеспечения Cisco ACNS или позже в лабораторной среде с очищенными конфигурациями

  • Маршрутизатор Cisco 7513 рабочий Cisco IOS Software Release 12.0.18 (S)

Настройка

Примечание: Дополнительные сведения о командах, используемых в данном документе, можно получить с помощью средства поиска команд (только для зарегистрированных клиентов).

Схема сети

/image/gif/paws/4717/media_redir.jpg

Конфигурации

Cisco Cache Engine 560 (выпуск 4 программного обеспечения ACNS Cisco�. x
hostname disaster

!

ip domain-name cisco.com

!

interface FastEthernet 0/0

ip address 172.17.241.108 255.255.255.0

exit

interface FastEthernet 0/1

shutdown

exit

!

ip default-gateway 172.17.241.45

!

ip name-server 144.254.6.77

!

!

wccp router-list 1 172.17.241.29 172.17.241.31 172.17.241.45

wccp web-cache router-list-num 1

wccp media-cache router-list-num 1

wccp version 2

!

!

rtsp proxy media-real license-key <removed>

rtsp proxy media-real ip-address 172.17.241.108

rtsp proxy media-real enable�

rtsp proxy incoming 554�

rtsp proxy l4-switch enable

!

!

username admin password 1 Gn1nQzm/arxcI

username admin privilege 15

username cisco password 1 714DWnzYTRHC.

username cisco privilege 15

!

!
Building configuration...

Current configuration : 3071 bytes

!

version 12.0

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

no service single-slot-reload-enable

!

hostname lsd

!

ip subnet-zero

ip wccp web-cache

ip wccp 80

ip cef

no ip domain-lookup

ip domain-name cisco.com.

ip name-server 144.254.6.77

!

interface Ethernet5/0

�ip address 172.17.241.45 255.255.255.0

�no ip directed-broadcast

�ip wccp 80 redirect out

!

interface Ethernet5/1

�ip address 10.10.10.1 255.255.255.0

�no ip directed-broadcast

!

ip classless

ip route 0.0.0.0 0.0.0.0 172.17.241.1

!

line con 0

�exec-timeout 0 0

line aux 0

line vty 0 4

�password <removed>

�login

!

end

команды "debug" и "show"

Прежде чем вызывать команды debug, обратитесь к разделу Важные сведения о командах отладки.

Некоторые команды show поддерживаются Средством интерпретации выходных данных(только зарегистрированные клиенты), которое позволяет просматривать аналитику выходных данных команды show.

disaster#show mediafs volumes

disk00/03 :    mounted  size: 10669934

disk01/00 :    mounted  size: 14226579

disk01/02 :   formatted  size: 7113289
disaster#show statistics mediacache real requests

                  Media Cache Statistics - Requests

                                                Total             % of Requests

                            ---------------------------------------------------

     Total Received Requests:                       5                         -

            Demand Cache Hit:                       3                      60.0

           Demand Cache Miss:                       2                      40.0

         Demand Pass-Through:                       0                       0.0

                  Live Split:                       0                       0.0

           Live Pass-Through:                       0                       0.0

disaster#show statistics mediacache real savings

             Media Cache Statistics - Savings

                        Requests                          Bytes

         -----------------------------------------------------------

  Total:                       5                       14617438

   Hits:                       3                        6458830

   Miss:                       2                        8158608

Savings:                    60.0 %                         44.2 %

disaster#show rtsp all

Media Types:

  Servicing Real Media

Real Proxy License Key:

  Installed

Media Specific Info:

  Real Proxy IP address: 172.17.241.108

Incoming Proxy-Mode:

  Servicing Proxy mode RTSP connections on port: 554

RTSP Transparent Proxy (WCCP):

  Configured for port: 554

RTSP Transparent Proxy (L4 Switch):

  Configured for port: 554
disaster#show wccp 80 detail



Service Details for Media Cache Service

        Service Enabled                    : Yes

        Service Priority                   : 200

        Service Protocol                   : 6

        Application                        : Streaming

        Service Flags (in Hex)             : 512

        Service Ports                      :    554     0     0     0

                                           :      0     0     0     0

        Security Enabled for Service       : No

        Multicast Enabled for Service      : No

        Weight for this Web-CE: 0
lsd#show ip wccp 80 detail

WCCP Cache-Engine information:

        IP Address:            172.17.241.108

        Protocol Version:      2.0

        State:                 Usable

        Redirection:           GRE

        Initial Hash Info:     00000000000000000000000000000000

                               00000000000000000000000000000000

        Assigned Hash Info:    FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF

                               FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF

        Hash Allotment:        256 (100.00%)

        Packets Redirected:    35

        Connect Time:          23:41:34
lsd#show ip wccp

Global WCCP information:

    Router information:

        Router Identifier:                   172.17.241.45

        Protocol Version:                    2.0



    Service Identifier: web-cache

        Number of Cache Engines:             1

        Number of routers:                   1

        Total Packets Redirected:            0

        Total Packets Fast Redirected:       0

        Total Packets CEF Redirected:        0

        Total Packets DCEF Redirected:       0

        Redirect access-list:                -none-

        Packets Denied Redirect (ACL):       0

        Packets Denied Redirect (Policy):    0

        Total Packets Unassigned:            0

        Group access-list:                   -none-

        Total Messages Denied to Group:      0

        Total Authentication failures:       0

        Policy Tag:                          0

        Policy Type:                         none



    Service Identifier: 80

        Number of Cache Engines:             1

        Number of routers:                   1

        Total Packets Redirected:            35

        Total Packets Fast Redirected:       0

        Total Packets CEF Redirected:        35

        Total Packets DCEF Redirected:       0

        Redirect access-list:                -none-

        Packets Denied Redirect (ACL):       0

        Packets Denied Redirect (Policy):    0

        Total Packets Unassigned:            0

        Group access-list:                   -none-

        Total Messages Denied to Group:      0

        Total Authentication failures:       0

        Policy Tag:                          0

        Policy Type:                         none

Команды show модуля кэширования

команда "show" Описание
show wccp content-engines Информация о Модуле контента WCCP показов.
show wccp flows media-cache Потоки пакетов сервиса кэширования сред показов.
show wccp routers Список маршрутизатора WCCP показов.
show wccp services Сервисы WCCP показов настроены.
show wccp slowstart Медленный пуск WCCP показов.
show wccp status Отображает состояние выполнения WCCP.
show statistics mediacache real savings Статистика сохранений показов.
show statistics mediacache real requests Отображает статистику запросов.
show rtsp all Отображает всю конфигурацию RTSP.
show rtsp proxy Настройка режима прокси показов.
show mediafs volumes Отображает громкости mediafs.

Команды отладки Cache Engine

команда debug Описание
debug wccp all Позволяет WCCP включить всю отладку.
debug wccp events Включения события WCCP.
debug wccp packets Включает сведения, относящиеся к пакету WCCP.

Команды show маршрутизатора

команда "show" Описание
show ip wccp 80 detail Cache Engine показов и статистика маршрутизатора WCCP для конкретной сервисной группы.
show ip wccp 80 view Группа сервисов показов просматривает информацию

Команды отладки маршрутизатора

команда debug Описание
debug ip wccp events События WCCP показов.
debug ip wccp packets Сведения, относящиеся к пакету WCCP показов.

Перечень команд

Эти команды Cache Engine использовались в этой конфигурации:

  • версия wccp {1 | 2}

  • wccp router-list number ip-address

  • номер router-list-num кэша сред wccp

  • ключ лицензионного ключа real сред RTSP - прокси

  • rtsp proxy media-real ip-address ip-address

  • real сред RTSP - прокси включает

  • входящий порт RTSP - прокси

Это команды маршрутизатора, которые использовались в этой конфигурации:

  • ip wccp {веб - кэширование | служебное число}

  • ip wccp {веб - кэширование | служебное число} перенаправляет

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения


Document ID: 4717