Асинхронный режим передачи (ATM) : "Класс обслуживания (IP, ATM и т. п.)"

Формирование очередей рer-VC CBWFQ на маршрутизаторах Cisco 7200, 3600 и 2600

21 октября 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Содержание


Введение

Взвешенная справедливая организация очереди (WFQ) была внедрена для медленных каналов (таких как последовательные) для обеспечения справедливой обработки каждого типа трафика. Чтобы сделать его задание, WFQ классифицирует трафик в другие потоки на основе cвязанных сведений об уровнях 3 и 4 (IP-адреса, порты TCP, и так далее). Для работы этой функции не требуется задавать списки доступа. С WFQ трафик низкой пропускной способности имеет действительный приоритет по трафику высокой пропускной способности. При высокой скорости передачи трафика средства связи используются пропорционально присвоенным весовым коэффициентам.

WFQ имеет следующие ограничения:

  • Если трафик значительно увеличивается, то WFQ не удается приспособиться, так как он не масштабируемый.

  • WFQ не доступен на высокоскоростных интерфейсах, таков как ATM.

Чтобы обеспечить соответствие ограничениям WFQ, разработана новая функция взвешенной организации очередей на основе классов (CBWFQ). В отличие от WFQ, CBWFQ позволяет вам определять классы трафика. Как только классы были определены, параметры могут тогда быть применены. Эти параметры включают пропускную способность и queue-limit.

При использовании CBWFQ вес, заданный для класса, становится весом каждого пакета, который совпадает с критериями класса. Этот вес получен исходя из пропускной способности, назначенной классу. WFQ тогда применен к этим классам вместо того, чтобы быть примененным к самим потокам. Классы могут включать несколько потоков.

Ниже сводка доступности CBWFQ на-VC на 7200, 3600, и 2600 маршрутизаторов:

  • 7200: Cisco версии IOS� 12.0 (5) T, 12.0 (5) XE, 12.1 (1), 12.1 (1) T, 12.1 (1) E и более позднее использование PA-A3.

  • 7200 с NSE: Версия Cisco IOS 12.1 (7) E и позже.

  • 7200 с Акселератором Сервисов NSE-1: Версия Cisco IOS 12.2 (4) B1.

  • 2600/3600 с модулями NM-1A-T3/E3 поддерживают LLQ / CBWFQ на версии Cisco IOS 12.1 (5) T и позже.

  • 2600/3600 с сетевыми модулями DS3/E3: Версия Cisco IOS 12.1 (2) T.

Примечание: Функциональность метода коммутации CEF должна использоваться, потому что CBWFQ контролирует только CEF-коммутируемые пакеты.

Предварительные условия

Требования

Для этого документа отсутствуют особые требования.

Используемые компоненты

Сведения, содержащиеся в данном документе, относятся к следующим версиям оборудования:

  • Series маршрутизаторы Cisco 7200, 3600 и 2600

Условные обозначения

Дополнительные сведения об условных обозначениях в документах см. Cisco Technical Tips Conventions.

Настройка

В этом разделе содержатся сведения о настройке функций, описанных в этом документе.

Примечание: Поиск дополнительной информации о командах в данном документе можно выполнить с помощью средства "Command Lookup" (Поиск команд) (только для зарегистрированных клиентов).

Схема сети

В настоящем документе используется следующая схема сети:

/image/gif/paws/10395/7200-1.gif

  • 1/130 является значением VPI/VCI, назначенным на обоих концах PVC между 7200 и маршрутизатором A.

  • Генератор трафика связан с интерфейсным Fast-Ethernet 3/0.

  • Эти 7200 выполняют версию Cisco IOS 12.0 (5) T.

  • Маршрутизатор A используется в качестве устройства приемника для тестов.

  • Конфигурация выполнена на 7200, но это подобно на 2600/3600.

Пример конфигурации

Ниже 7200 конфигураций, необходимых для реализации CBWFQ:

7200
    class-map ixia
      match input-interface FastEthernet3/0
    class-map loopbacks
      match access-group 102
    !
    policy-map mypol
      class ixia
       bandwidth 40000
       queue-limit 40
      class loopbacks
       bandwidth 10000
      class class-default
       fair-queue
    !
    interface ATM2/0.130 point-to-point
     ip address 14.0.0.2 255.0.0.0
     no ip directed-broadcast
     pvc 1/130
      service-policy output mypol
      vbr-nrt 100000 75000
      broadcast
      encapsulation aal5mux ip
    !
    access-list 102 permit ip host 10.0.0.1 host 11.0.0.1

Ниже некоторые комментарии к конфигурации:

  • Карты классов классифицируют и назначают веса на трафик. Параметры классификации и схемы классов определяются в одном месте. В этом случае один класс применен ко всему входящему трафику на Fast-Ethernet 3/0 (трафик от генератора трафика). Другой класс отнесен к трафику между loopback (определенный на 7200 и маршрутизаторе A).

  • После определения параметров классификации можно использовать карту политик для применения параметров трафика к этим классифицированным потокам. В этом случае поток от генератора трафика "выделен" пропускная способность 40 Мбит/с и глубина очереди 40 пакетов. Трафик между loopback выделен пропускная способность 10 Мбит/с.

  • Глубина очереди является количеством пакетов, которые могут быть сохранены для отдельного класса, прежде чем произойдут отбрасывания. Значение по умолчанию равняется 64 (который является также Maximum Queue Depth).

  • После того, как параметры трафика были определены для каждого класса, CBWFQ применен на основании VC с помощью следующей команды: стратегия обслуживания [input|output] Policy-map-name.

  • Трафику, не совпадающему с одной из карт определенного класса, назначат карта класса по умолчанию (по умолчанию класса), который определен в карте политик. Весь неклассифицируемый трафик будет применен параметры, определенные под этим классом по умолчанию. В этом случае обычное Обслуживание очередей на основе равнодоступности настроено.

  • Для этого примера конфигурации CBWFQ применен на VC, но это может использоваться на пакете ПВК также. Кроме того, CBWFQ может быть привязан к Weighted Random Early Discard (WRED) как механизм сброса (когда queue-limit достигнут).

Важно:

Прежде, чем выполнить задачи конфигурации в этом разделе, необходимо сначала создать классы, которые будут использоваться для дифференциации трафика на VC, затем определят карту политик для включения их. Политики класса можно настроить для такого числа классов, которое определено на маршрутизаторе (не более 64). Однако общий объем распределенной пропускной способности ВК (для всех классов, включенных в карту политик) не должен превышать 75 процентов от доступной пропускной способности ВК.

Поскольку CBWFQ предоставляет минимальную пропускную способность, можно только применить CBWFQ к VC с классами обслуживания кроме UBR и UBR +.

Вы не можете применить поканальный WFQ и CBWFQ к UBR и UBR + VC, потому что оба из этих классов сервиса являются наилучшим образом классами, которые не гарантируют минимальную пропускную способность. Когда CBWFQ включен для VC, все классы, настроенные, поскольку часть политики обслуживания установлена в Системе организации очереди с весами.

Если вы примените политику обслуживания к VC ATM, и политика включает функцию, которая не является Parallel Express Forwarding поддерживающий (PXF), то пакеты будут плыться на плоскодонке к следующему коммутируемому пути более низкого уровня. Выполните команду show pxf acc summ и ищите инкрементно увеличивающееся значение для избыточных направлений из-за "функции обработки исходящих данных".

router#show pxf acc sum      
            Pkts             Dropped   RP Processed             Ignored 
           Total                 242      328395045                   0 
10 second averages: PXF complex busy:       28%  PXF read pipeline full:   0% 
PXF Statistic: 
     Packets RP -> PXF: 
         switch ip:                       0 
         switch raw:              556612940 
         qos fastsend:                    0 
         qos enqueue:                     0 
     Total:                       556612940 
Packets PXF -> RP: 
         qos pkts:                        0 
         fast pkts:               228217649 
         drops: total                   242 
           "    no route               :         242 
         punts: total             328395045 
           "    not IP                 :         597 
           "    IP options             :         676 
           "    CEF no adjacency       :      186770 
           "    CEF receive            :      265306 
           "    output feature         :   327916956 

Расширенная конфигурация CBWFQ на маршрутизаторах 7200

На Маршрутизаторах Cisco 7200 рабочая версия Cisco IOS 12.1 (5) E, 12.1 (5) T и позже, мы можем сгруппировать классы сопоставления для формирования более сложных карт классов. Кроме того, мы можем привязать логические операции к параметрам карты классов (чтобы определить, совпадает ли трафик с классом).

Давайте посмотрим на следующие карты классов для разъяснения этого понятия:

Расширенная настройка cbwfq
class-map match-all ixia
  description traffic from Ixia 
  match input-interface FastEthernet1/0 
class-map match-all ftp1 
  description ftp traffic initiated by the traffic generator 
  match class-map ixia 
  match class-map ftp2 
class-map match-all ftp2 
  match access-group 103 
class-map match-any test 
  match access-group 102    
  match input-interface Ethernet0/0 
! 
access-list 103 permit tcp any any eq ftp    
! 
access-list 102 permit ip host 10.1.1.1 any

Разница между match-all и match-any заключается в следующем:

  • match-all: если ALL cвязанных условий проверен, поток привязан к карте классов.

  • средства match-any: если ANY cвязанных условий проверен (не обязательно все условия), поток привязан к class-map.

Мы видим здесь, что карта классов может включать тесты против других карт настроенного класса. В этом случае поток привязан к ftp1, если это совпадает со всеми условиями, определенными под ixia карты классов и картой классов ftp2.

Проверка

В этом разделе содержатся сведения, которые помогают убедиться в надлежащей работе конфигурации.

Некоторые команды show поддерживаются Средством интерпретации выходных данных(только зарегистрированные клиенты), которое позволяет просматривать аналитику выходных данных команды show.

  • show policy-map interface atm x/y [.z] — Эта команда позволяет вам видеть статистику на очередь, такую как отбрасывания. Это полезно для мониторинга результатов стратегии обслуживания, созданной с модульным качеством сервиса Cisco (QoS) интерфейс командной строки (CLI) (MQC). Для более подробной информации о том, как интерпретировать выходные данные этой команды, обратитесь к Пониманию Счетчиков пакетов в Выходных данных show policy-map interface.

            7200#show policy-map interface atm 2/0.130 
             ATM2/0.130: VC 1/130 - output : mypol 
              Weighted Fair Queueing 
                Class ixia 
                  Output Queue: Conversation 264 
                    Bandwidth 40000 (kbps) Packets Matched 0 Max Threshold 40(packets) 
                    (discards/tail drops) 0/0 
                Class loopbacks 
                  Output Queue: Conversation 265 
                    Bandwidth 10000 (kbps) Packets Matched 0 Max Threshold 64(packets) 
                    (discards/tail drops) 0/0 
                Class class-default 
                  Output Queue: Conversation 266 
                    Bandwidth 0 (kbps) Packets Matched 0 Max Threshold 64 (packets) 
                    (discards/tail drops) 0/0

    Примечание: См., что следующие пояснения расценивают два типа отбрасываний:

    • Сброс: общее количество понижается от этой очереди.

    • Tail drops: отбрасывания от этой очереди только, когда у другой очереди есть входящий пакет с "более низким" порядковым номером WFQ и системой WFQ, достигают количества max-queue-limit пакетов.

  • vc show policy-map interface atm x/y [.z] [vcd | vpi/vci] — Эта команда дает больше глубины детализации для определенных VC.

            7200#show policy-map interface atm 2/0.130 vc 1/130 
             ATM2/0.130: VC 1/130 - output : mypol 
              Weighted Fair Queueing 
                Class ixia 
                  Output Queue: Conversation 264 
                    Bandwidth 40000 (kbps) Packets Matched 0 Max Threshold 40(packets) 
                    (discards/tail drops) 0/0 
                Class loopbacks 
                  Output Queue: Conversation 265 
                    Bandwidth 10000 (kbps) Packets Matched 0 Max Threshold 64(packets) 
                    (discards/tail drops) 0/0 
                Class class-default 
                  Output Queue: Conversation 266 
                    Bandwidth 0 (kbps) Packets Matched 0 Max Threshold 64 (packets) 
                    (discards/tail drops) 0/0
    

Можно также использовать другие команды как show class-map или show policy-map class для получения более подробной информации о классах сопоставления.

Устранение неполадок

Для этой конфигурации в настоящее время нет сведений об устранении проблем.


Дополнительные сведения


Document ID: 10395