Глобальная сеть (WAN) : Протокол PPP

Многоканальный PPP на сдвоенных маршрутизаторах с несколькими последовательными интерфейсами

5 апреля 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Содержание


Введение

В некоторых средах может быть необходимо связать последовательные соединения для действия как одиночная совокупная пропускная способность. Этот документ описывает, как настроить Сервер доступа Cisco 2503 для связывания двух последовательных интерфейсов с двумя другими методами:

Эти конфигурации можно использовать для маршрутизаторов, подключенных по выделенным линиям связи, или маршрутизаторов, имеющих модуль обслуживания канала или модуль обслуживания данных (CSU/DSU) или адаптер терминала (TA) ISDN, настроенный для набора номера. (Маршрутизаторы Cisco не были настроены к количеству телефона с дисковым номеронабирателем.) Можно добавить дополнительные опции к этой конфигурации для удовлетворения потребностям.

Предварительные условия

Требования

Для этого документа отсутствуют особые требования.

Используемые компоненты

Сведения, содержащиеся в данном документе, касаются следующих версий программного и аппаратного обеспечения:

  • Маршрутизаторы Cisco 2503

  • Cisco выпуск ПО IOS� 12.2 (7b)

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в этом документе, были запущены с чистой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд до их использования.

Родственные продукты

Эта конфигурация может использоваться с любыми двумя маршрутизаторами с двумя последовательными интерфейсами глобальной сети (WAN) каждый. Можно использовать WIC-1T, WIC-2T или исправленные последовательные интерфейсы глобальной сети (WAN).

Условные обозначения

Дополнительные сведения об условных обозначениях в документах см. в Условные обозначения технических терминов Cisco.

Настройка

В этом разделе содержатся сведения о настройке функций, описанных в этом документе.

Примечание: Дополнительные сведения о командах, используемых в данном документе, можно получить с помощью средства поиска команд (только для зарегистрированных клиентов).

Схема сети

В этом документе использованы параметры данной сети:

/image/gif/paws/10382/pppmultilink.gif

Конфигурации

Эта конфигурация была протестирована с программным обеспечением Cisco IOS версии 12.2(7b) на маршрутизаторах Cisco серии 2500. Понятия одинаковой конфигурации применились бы к топологии аналогичного маршрутизатора или другим Cisco IOS Software Release.

Пример 1 : Interface Dialer

Пример 2: Virtual template

Пример 1 : Interface Dialer

Router1 - Cisco 2503
Current configuration:
version 12.2
 
hostname Router1
!
username Router2 password 0 abc

!--- This local username and password pair is used for PPP Challenge
!--- Handshake Authentication Protocol (CHAP) authentication.

ip subnet-zero
no ip domain-lookup
!
!
interface Loopback0
 ip address 192.168.10.2 255.255.255.0

!--- The loopback address is used by interface dialer 1.

!
!
interface Serial0
 no ip address
 encapsulation ppp
 dialer in-band
 dialer rotary-group 1

 !--- Interface Serial0 is a member of rotary-group 1.
 !--- The rotary group configuration is in interface dialer 1. 

 no fair-queue
 pulse-time 1
!
interface Serial1
 no ip address
 encapsulation ppp
 dialer in-band
 dialer rotary-group 1
 no fair-queue
 pulse-time 1
!
interface Dialer1

!--- This is the configuration for rotary-group 1.
!--- The dialer interface number must exactly match the rotary group number.

 ip unnumbered Loopback0
 encapsulation ppp
 dialer in-band
 dialer idle-timeout 300
 dialer map ip 192.168.20.1 name Router2 broadcast
 dialer load-threshold 2 either
 dialer-group 1

 !--- Apply interesting traffic definition from dialer-list 1.

 no fair-queue
 ppp authentication chap
 ppp direction callout  

 !--- This is a hidden command; see the Notes section for more information.

 ppp multilink

 !--- Allow multilink for the dialer profile.
 !--- Without this command, multilink is NOT negotiated.

!
ip classless
ip route 192.168.20.1 255.255.255.255 Dialer1
dialer-list 1 protocol ip permit

!--- The dialer-list defines the interesting traffic.

!
line con 0
line aux 0
 transport input all
line vty 0 4
 login
!
end

Router2 - Cisco 2503
Current configuration:
version 12.2
hostname Router2
!
!
username Router1 password 0 abc
ip subnet-zero
no ip domain-lookup
!
!
interface Loopback0
 ip address 192.168.20.1 255.255.255.0
!
!
interface Serial0
 no ip address
 encapsulation ppp
 dialer in-band
 dialer rotary-group 1
 no fair-queue
 clockrate 56000
 pulse-time 1
!
interface Serial1
 no ip address
 encapsulation ppp
 dialer in-band
 dialer rotary-group 1
 no fair-queue
 clockrate 56000
 pulse-time 1
!
!
interface Dialer1
 ip unnumbered Loopback0
 encapsulation ppp
 dialer in-band
 dialer idle-timeout 999
 dialer map ip 192.168.10.2 name Router1 broadcast
 dialer load-threshold 2 either
 dialer-group 1
 no fair-queue
 no cdp enable
 ppp authentication chap
 ppp multilink
!
ip classless
ip route 192.168.10.2 255.255.255.255 Dialer1
!
dialer-list 1 protocol ip permit
!
line con 0
line aux 0
line vty 0 4
!
end

Пример 1 примечание

Команда ppp direction callout является скрытой командой, используемой в случае, если маршрутизатор не может определить, кто был вызывающей стороной, а кто – вызываемой (при встречно-параллельном соединении или соединении через арендованные каналы, при этом CSU/DSU или ISDN TA настроены на установку телефонного соединения). Команда ppp direction callin может также использоваться. Используйте любую из этих команд.

  • Для локального маршрутизатора используйте выноску направления PPP.

  • Для удаленного маршрутизатора используйте вызов ppp direction.

Если вы не используете эту команду, подключения маршрутизатора на мгновение, и затем разъединяет.

Вышеупомянутая конфигурация описывает два маршрутизатора, Router1 и Router2, которые имеют два последовательных интерфейса, которые будут связаны для действия как одиночная совокупная пропускная способность. На обоих маршрутизаторах обратная связь интерфейса настроена и интегрирована с interface dialer с помощью IP ненумерованного loopback0. Оба последовательных интерфейса настроены для no IP address. Serial0 физических интерфейсов и Serial1 настроены с командой "dialer rotary-group" и привязаны к одиночному номеронабирателю логического интерфейса.

Dialer-list 1 определяет представляющий интерес трафик, который в свою очередь вызывает команду dialer-group 1 на interface dialer 1 для внедрения ссылки. Инструкция схемы набора номеров, определенная на обоих маршрутизаторах, сопоставляет interface dialer 1 с IP-адресом равного маршрутизатора, и имя хоста определило подачи в Аутентификации CHAP. Определенные маршруты статического маршрута трафик назначению.

Команда аутентификации ppp chap включает согласование PPP. Наборы команд dialer load-threshold загрузка, которая вызывает для обеспечения второй последовательной линии. Команды ppp multilink и dialer rotary-group были настроены так, чтобы оба последовательных интерфейса могли быть связаны вместе как один Интерфейс виртуального доступа для совокупной пропускной способности. Команда выноски направления PPP определяет, какая сторона должна сделать выноску во время согласования PPP и Аутентификации CHAP.

Проверьте пример 1

В данном разделе содержатся сведения о проверке работы конфигурации.

Некоторые команды show поддерживаются Средством интерпретации выходных данных(только зарегистрированные клиенты), которое позволяет просматривать аналитику выходных данных команды show.

Router1# show ppp multilink 
Virtual-Access1, bundle name is Router2 
  Bundle up for 00:01:05 
  Dialer interface is Dialer1 
  0 lost fragments, 0 reordered, 0 unassigned 
  0 discarded, 0 lost received, 1/255 load 
  0x0 received sequence, 0x0 sent sequence 
  Member links: 2 (max not set, min not set) 
    Serial0, since 00:01:05, no frags rcvd 
    Serial1, since 00:01:05, no frags rcvd   

 Router2# show ppp multilink  

 Virtual-Access1, bundle name is Router1
  Bundle up for 00:03:25
  Dialer interface is Dialer1
  0 lost fragments, 0 reordered, 0 unassigned
  0 discarded, 0 lost received, 1/255 load
  0x0 received sequence, 0x0 sent sequence
  Member links: 2 (max not set, min not set)
    Serial1, since 00:03:25, no frags rcvd
    Serial0, since 00:03:25, no frags rcvd

Пример устранения неполадок 1

В этом разделе описывается процесс устранения неполадок конфигурации.

Некоторые команды show поддерживаются Средством интерпретации выходных данных(только зарегистрированные клиенты), которое позволяет просматривать аналитику выходных данных команды show.

Примечание: Прежде чем вызывать команды debug, обратитесь к разделу Важные сведения о командах отладки.

команды "debug"

На Router1 команда debug ppp authenticaion показывает успех CHAP.

May  8 17:52:19: Se1 PPP: Using configured call direction
May  8 17:52:19: Se1 PPP: Treating connection as a callout
May  8 17:52:19: Se0 CHAP: O CHALLENGE id 135 len 28 from "Router1"
May  8 17:52:19: Se1 CHAP: O CHALLENGE id 135 len 28 from "Router1"
May  8 17:52:19: Se0 CHAP: I CHALLENGE id 134 len 28 from "Router2"
May  8 17:52:19: Se0 CHAP: O RESPONSE id 134 len 28 from "Router1"
May  8 17:52:19: Se1 CHAP: I CHALLENGE id 134 len 28 from "Router2"
May  8 17:52:19: Se1 CHAP: O RESPONSE id 134 len 28 from "Router1"
May  8 17:52:19: Se0 CHAP: I SUCCESS id 134 len 4
May  8 17:52:19: Se0 CHAP: I RESPONSE id 135 len 28 from "Router2"
May  8 17:52:19: Se0 CHAP: O SUCCESS id 135 len 4
May  8 17:52:19: Se1 CHAP: I SUCCESS id 134 len 4
May  8 17:52:19: Se1 CHAP: I RESPONSE id 135 len 28 from "Router2"
May  8 17:52:19: Se1 CHAP: O SUCCESS id 135 len 4
5d05h: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to up
May  8 17:52:19: Vi1 PPP: Using configured call direction
May  8 17:52:19: Vi1 PPP: Treating connection as a callout
5d05h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0, changed state to up
5d05h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial1, changed state to up

На Router2 команда debug ppp authenticaion показывает "Ожидание узла...."

5d02h: %LINK-3-UPDOWN: Interface Serial0, changed state to up
5d02h: Se0 PPP: Treating connection as a callin
5d02h: Se0 CHAP: O CHALLENGE id 132 len 28 from "Router2"
5d02h: Se0 CHAP: I CHALLENGE id 133 len 28 from "Router1"
5d02h: Se0 CHAP: Waiting for peer to authenticate first
5d02h: Se0 CHAP: I RESPONSE id 132 len 28 from "Router1"
5d02h: Se0 CHAP: O SUCCESS id 132 len 4
5d02h: Se0 CHAP: Processing saved Challenge, id 133
5d02h: Se0 CHAP: O RESPONSE id 133 len 28 from "Router2"
5d02h: Se0 CHAP: I SUCCESS id 133 len 4
5d02h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0, changed state to up

Пример 2: Virtual template

Router1 - Cisco 2503
Current configuration
!
version 12.2
!
hostname Router1
!
!
username Router2 password 0 abc
 
ip subnet-zero
no ip domain-lookup
!
 
multilink virtual-template 1

!--- Applies the virtual interface template to the multilink bundle.

 
interface Loopback0
 ip address 192.168.10.2 255.255.255.0

 !--- The loopback address is used by virtual-template 1.

 
 
interface Virtual-Template1

!--- Interface virtual-template is a logical interface that creates
!--- virtual access interfaces dynamically and applies them to 
!--- physical serial interfaces.

 ip unnumbered Loopback0

!--- Always unnumber the virtual-template to an UP interface.
!--- Do not assign a static IP.

 ppp authentication chap
 ppp multilink 

 !--- Enables multilink PPP on the virtual-template interface.

 
interface Serial0
 no ip address
 encapsulation ppp
 pulse-time 1
 ppp multilink
!
interface Serial1
 no ip address
 encapsulation ppp
 pulse-time 1
 ppp multilink
!
!
ip classless
!
line con 0
line aux 0
 transport input all
line vty 0 4
 login
!
end

Router2 - Cisco 2503
Current configuration :
!
version 12.2
!
hostname Router2
!
!
username Router1 password 0 abc
 
ip subnet-zero
no ip domain-lookup
!
multilink virtual-template 1
!
!
!
interface Loopback0
 ip address 192.168.20.1 255.255.255.0
!
!
interface Virtual-Template1
 ip unnumbered Loopback0
 ppp authentication chap
 ppp multilink
!
interface Serial0
 no ip address
 encapsulation ppp
 no fair-queue
 clockrate 56000
 pulse-time 1
 ppp multilink
!
interface Serial1
 no ip address
 encapsulation ppp
 no fair-queue
 clockrate 56000
 pulse-time 1
 ppp multilink
!
!
ip classless
!
!
line con 0
line aux 0
line vty 0 4
!
end

Конфигурация выше описывает виртуальный шаблон, настроенный на Router1 и Router2. В этом примере оба маршрутизатора настроены с помощью виртуальных шаблонов. Маршрутизаторы соединяются с помощью встречно-параллельного соединения. Многоканальный сеанс при этом находится в состоянии ожидания. Статические маршруты не требуются: маршрут хоста будет установлен после PPP-согласований.

Используйте Cisco IOS Software Release 11.3 или более позднюю версию для применения виртуального шаблона для многоканального подключения PPP.

Команда виртуального шаблона динамично создает интерфейс виртуального доступа и применяет их к интерфейсам физического серийного номера с командой многоканального виртуального шаблона. Параметры (такие как аутентификация ppp chap) настроенный в интерфейсном виртуальном шаблоне применены для обоих последовательных интерфейсов. Команда ppp multilink в interface virtual-template связывает интерфейсы физического серийного номера для формирования виртуального доступа для соединения пропускной способности.

Проверьте пример 2

В данном разделе содержатся сведения о проверке работы конфигурации.

Некоторые команды show поддерживаются Средством интерпретации выходных данных(только зарегистрированные клиенты), которое позволяет просматривать аналитику выходных данных команды show.

Router2# show ppp multilink
 
Virtual-Access1, bundle name is Router1

!--- Virtual Access interface used for the bundle

  Bundle up for 00:20:38
  0 lost fragments, 0 reordered, 0 unassigned
  0 discarded, 0 lost received, 1/255 load
  0x0 received sequence, 0x0 sent sequence
  Member links: 2 (max not set, min not set)
    Serial1, since 00:20:39, no frags rcvd
    Serial0, since 00:20:39, no frags rcvd

!--- Note that there are two links (Se 0 and Se1) in the bundle

Эти команды могут также помочь:

  • show ip route connected — Чтобы видеть, установлен ли IP route для виртуального доступа.

  • show interface virtual-access x — Для проверки статуса отдельного интерфейса виртуального доступа. В приведенном выше примере количество интерфейса виртуального доступа равняется 1.

Пример устранения неполадок 2

В этом разделе описывается процесс устранения неполадок конфигурации.

Некоторые команды show поддерживаются Средством интерпретации выходных данных(только зарегистрированные клиенты), которое позволяет просматривать аналитику выходных данных команды show.

Примечание: Прежде чем вызывать команды debug, обратитесь к разделу Важные сведения о командах отладки.

Настройте метки времени в глобальной конфигурации следующим образом:

service timestamps debug datetime msec
service timestamps log datetime msec

Используйте эти команды для устранения проблем:

  • debug ppp negotiation — Чтобы видеть, передает ли клиент согласование PPP. Также можно проверить, какие параметры (обратный вызов, многоканальный PPP [MLP] и т.д.) и какие протоколы (IP, IPX и т.д.) согласованы.

  • debug ppp authenticaion — Чтобы видеть, передает ли клиент аутентификацию.

  • debug vtemplate — Видеть, какие конфигурации virtual-template используются.

  • отладка vprofile — Для наблюдения, какие параметры конфигурации применены к интерфейсу виртуального доступа.

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения


Document ID: 10382