Технологии коммутируемого доступа в сеть : Асинхронные подключения

Подключение двух маршрутизаторов через дополнительны порты

5 апреля 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Содержание


Введение

Этот пример конфигурации показывает, как непосредственно соединить два маршрутизатора без модема или других устройств коммуникационного оборудования (DCE). Для получения дополнительной информации по тому, как настроить модемы на вспомогательном (AUX) или консольном портах, см. раздел Поддержка технологии Access-Dial или Руководство по подключению модема с маршрутизатором.

Предварительные условия

Требования

Для этого документа отсутствуют особые требования.

Используемые компоненты

Настоящий документ не имеет жесткой привязки к каким-либо конкретным версиям программного обеспечения и оборудования.

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Технические рекомендации Cisco. Условные обозначения.

Общие сведения

В этой конфигурации два маршрутизатора Cisco подключаются встречно-параллельно через асинхронные порты AUX при помощи нуль-модемного кабеля ("перевернутого" кабеля). Порты AUX этих двух маршрутизаторов напрямую подключаются при помощи перевернутого кабеля с использованием протокола "точка-точка" (PPP), работающего на данном соединении. Порты AUX представляют собой оконечные устройства (DTE). Вам нужно, чтобы нуль-модемный кабель (перевернутый кабель) подключил DTE к устройствам DTE.

Плоский полуматовый перевернутый (нуль-модемный) кабель (CAB-500RJ=) обычно поставляется с каждым маршрутизатором Cisco для обеспечения подключения консоли RJ-45. Если порт AUX — DB-25, используйте переходник RJ-45-DB-25 с обозначением "terminal" для подключения нуль-модемного кабеля (перевернутого кабеля).

Примечание: Убедитесь, что длина кабеля составляет менее 50 футов, вследствие ограничений EIA/TIA-232 к EIA/TIA-232 (ранее называвшегося RS-232) .

Для получения дополнительной информации по кабельному подключению обратитесь к Руководству по разводке кабелей для консоли RJ-45, портов AUX и кабелей RJ-45.

Маршрутизаторы с портами DB-25 AUX

Для маршрутизаторов с портом AUX DB-25 (например, Cisco 4500, 7200 и 7500), вам потребуется нуль-модемный кабель DB-25-DB-25. Этот кабель можно купить в большинстве розничных магазинов электротоваров.

Примечание: Вследствие неверных пар сигналов вы не сможете использовать катаный плоский блестящий кабель RJ-45-RJ-45 с адаптерами RJ-45-DB-25 (номер изделияCAB-25AS-MMOD ) на обоих концах.

Проверьте, есть ли у вашего нуль-модемного кабеля DB-25-DB-25 штырьковые разъемы, перечисленные в таблице 1.

Таблица 1 – Штырьковые разъемы нуль-модемного кабеля DB-25-DB-25

DB-25 DB-25
RxD – 2 3 TxD
TxD 3 2 RxD –
CTS 4 5 RTS –
RTS – 5 4 CTS
DTR – 6 20 CD
DSR 8
CD 20 6 DTR –
8 DSR
GND 7 7 GND

Настройка

В этом разделе содержатся сведения о настройке функций, описанных в этом документе.

Примечание: Дополнительные сведения о командах, используемых в данном документе, можно получить с помощью средства поиска команд (только для зарегистрированных клиентов).

Схема сети

В этом документе использованы параметры данной сети:

/image/gif/paws/10365/auxback.gif

Конфигурации

Эти конфигурации используются в данном документе:

  • Маршрутизатор 1

  • Маршрутизатор 2

Примечание: Это подключение было настроено с IP-адресами на портах AUX для постоянного ("забитого") подключения.

Маршрутизатор 1
version 11.1
 service udp-small-servers
 service tcp-small-servers
 !
 hostname Router1
 !
 interface Ethernet0
  no ip address
  shutdown
 !
 interface Serial0
  no ip address
  shutdown
 !
 interface Serial1
  no ip address
  shutdown
 !         
 interface Async1

 !--- The async interface that corresponds to the AUX port.
 !--- Use the show line command to determine which async interface corresponds
 !--- to the AUX port.

  ip address 192.168.10.1 255.255.255.0

 !--- The IP address on the AUX ports of both routers are in the same subnet.

  encapsulation ppp

 !--- Set PPP as the encapsulation.

  async default routing 

 !--- This allows routing protocols on the link. 

  async mode dedicated
 !
 no ip classless
 ip route 0.0.0.0 0.0.0.0 Async1

 !--- The default route points to the Async1 (AUX port) interface.

 logging buffered
 !
 line con 0
  exec-timeout 0 0
 line aux 0

 !--- Line configuration for the AUX port.

  modem InOut
  transport input all

  !--- This allows all protocols to use the line.

  rxspeed 38400

  !--- Set the Rx speed (identical to the TX speed of the other router).

  txspeed 38400

  !--- Set the Tx speed (identical to the RX speed of the other router).

  flowcontrol hardware
 line vty 0 4
  login
 !
 end

Маршрутизатор 2
version 11.1

 service udp-small-servers
 service tcp-small-servers
 !
 hostname Router2
 !
 interface Ethernet0
  ip address 10.1.1.1 255.255.255.0
 !
 interface Serial0
  no ip address
  shutdown
 !
 interface Serial1
  no ip address
  shutdown
 !         
 interface Async1

 !--- The async interface that corresponds to the AUX port.
 !--- Use the show line command to determine which async interface corresponds
 !--- to the AUX Port.

  ip address 192.168.10.2 255.255.255.0

  !--- The IP address on the AUX ports of both routers are in the same subnet.

  encapsulation ppp

  !--- Set PPP as encapsulation.

  async default routing 
  
!--- This allows routing protocols on the link.
 
  async mode dedicated
 !
 no ip classless
 ip route 0.0.0.0 0.0.0.0 Ethernet0
 
!--- This default route points to interface Ethernet0.

 logging buffered
 !
 line con 0
  exec-timeout 0 0
 line aux 0

 !--- Line configuration for the AUX port.

  modem InOut
  transport input all

 !--- This allows all protocols to use the line.

  rxspeed 38400

 !--- set the Rx speed (identical to the TX speed of the other router).

  txspeed 38400

 !--- set the Tx speed (identical to the RX speed of the other router).

  flowcontrol hardware
 line vty 0 4
  login
 !
 end

Проверка.

В настоящее время для этой конфигурации нет процедуры проверки.

Устранение неполадок

В этом разделе описывается процесс устранения неполадок конфигурации.

Процедура устранения неполадок

Прежде чем применять команды отладки, ознакомьтесь с разделом "Важные сведения о командах отладки".

Выполните следующие действия:

  1. Используйте команду show line для определения вида асинхронного интерфейса портов AUX.

    Хотя у большинства маршрутизаторов имеется порт AUX в качестве интерфейса async 1, у серверов доступа имеется интерфейс порта AUX вслед за линиями TTY. Например, если ваш маршрутизатор имеет 16 асинхронных модемных линий, то порт AUX является линией 17. В таком случае порт AUX должен быть настроен на interface async 17. Настройте порт AUX на основании выходных данных команды show line. Вот пример проверки того, что конфигурация AUX-порта на ваших маршрутизаторах находится на интерфейсе Async1:

    Router1#show line
     Tty Typ     Tx/Rx    A Modem Roty AccO AccI Uses  Noise  Overruns
    *  0 CTY              -    -     -    -    -    0      0       0/0
    A  1 AUX  38400/38400 - inout    -    -    -    0      0       0/0
       2 VTY              -    -     -    -    -    0      0       0/0
       3 VTY              -    -     -    -    -    0      0       0/0
       4 VTY              -    -     -    -    -    0      0       0/0
       5 VTY              -    -     -    -    -    0      0       0/0
       6 VTY              -    -     -    -    -    0      0       0/0
  2. Выполните команду show line aux 0.

  3. Убедитесь, что все сигналы работают (например, готовность к отправке (CTS), запрос на отправку (RTS), готовность терминала данных (DTR) и определение несущей (CD)).

    Если рядом ничего не появляется, они включены. Если рядом с ними появляется No (Нет) (например, No-CTS), это означает, что они отключены. Если они не работают, проверьте конфигурацию на каждой стороне. Проверьте, что у вас имеются асинхронный интерфейс и линия настроенного порта AUX (как показано выше).

    Примечание: Если выходные данные команды show line указывают, что DSR не включен (noDSR), необходимо убедиться, что каждый конец нуль-модемного кабеля DB-25-DB-25 имеет контакты 6 и 8, физически соединенные проводом с выводом 20 на другом конце. Обратитесь к таблице 1, где приведены правильные схемы расположения выводов.

    Router1#show line aux 0
     Tty Typ    Tx/Rx     A Modem Roty AccO AccI Uses  Noise  Overruns
    A  1 AUX 38400/38400  - inout    -    -    -    0      0       0/0
    
    Line 1, Location: "", Type: ""
    Length: 24 lines, Width: 80 columns
    Baud rate (TX/RX) is 38400/38400, no parity, 2 stopbits, 8 databits
    Status: Ready, Active, Async Interface Active
    Capabilities: Hardware Flowcontrol In, Hardware Flowcontrol Out
      Modem Callout, Modem RI is CD, Line is permanent async interface
    Modem state: Ready
    Special Chars: Escape  Hold  Stop  Start  Disconnect  Activation
                    ^^x    none   -     -       none         
    Timeouts:  Idle EXEC  Idle Session  Modem Answer  Session  Dispatch
               00:10:00      never                       none   not set
    Modem type is unknown.
    Session limit is not set.
    Time since activation: 00:00:30
    Editing is enabled.
    History is enabled, history size is 10.
    Full user help is disabled
    Allowed transports are pad v120 telnet.  Preferred is telnet.
    No output characters are padded
    No special data dispatching characters
    Line is running PPP for address 192.168.10.2.
    0 output packets queued, 1 input packets.
     Async Escape map is 00000000000000000101000000000000
    Modem hardware state: CTS* DSR*  DTR RTS 
    
  4. Если конфигурация не содержит ошибок, замените перекрученный кабель маршрутизатора.

  5. Для сброса подключения используйте команды shutdown и no shutdown асинхронного интерфейса.

Команды для устранения неполадок

Некоторые команды show поддерживаются Средством интерпретации выходных данных(только зарегистрированные клиенты), которое позволяет просматривать аналитику выходных данных команды show.

Используйте эти команды debug, чтобы убедиться в том, что соединение выполняется правильно.

Примечание: Прежде чем вызывать команды debug, обратитесь к разделу Важные сведения о командах отладки.

  • debug ppp negotiation — отображает информацию о трафике PPP и обмене информацией в процессе согласования протокола управления каналом (LCP), аутентификации и протокола управления сетью (NCP). В успешных переговорах PPP сначала выясняется состояние LCP, затем проводится аутентификация и наконец выполняется согласование NCP. Если CONFREQ отосланы, но CONFACK не получены, проверьте, правильно ли кабельное подключение и настроена ли верная линия (для этого выполните команду interface async x).

  • debug ppp authenticaion — отображает сообщения протокола проверки подлинности PPP (если аутентификация настроена) и включает обмен пакетами протокола аутентификации по квитированию вызова (CHAP) и обмен данными протокола проверки пароля (PAP). В этой конфигурации аутентификация не настроена. Поэтому эта команда отладки не требуется.

  • debug ppp error – отображает ошибки протокола и статистику ошибок, связанных с согласованием и функционированием PPP-соединения.

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения


Document ID: 10365