Технологии коммутируемого доступа в сеть : "Технология ISDN, CAS"

Настройка ISDN BRI и PRI в Австралии

5 апреля 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Содержание


Введение

Этот документ покрывает Проблемы ISDN, определенные для Австралии. Это включает примеры конфигурации и информацию о различном BRI и сервисах PRI, которые могут быть получены из Telco (телефонная компания).

Предварительные условия

Требования

Для этого документа отсутствуют особые требования.

Используемые компоненты

Данный документ не ограничен отдельными версиями программного или аппаратного обеспечения.

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в этом документе, были запущены с чистой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд до их использования.

Родственные продукты

Эта конфигурация может использоваться на любом маршрутизаторе с интерфейсом PRI или BRI.

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Условные обозначения технических терминов Cisco.

Настройка

В этом разделе содержатся сведения о настройке функций, описанных в этом документе.

Примечание: Чтобы получить подробные сведения о командах в данном документе, используйте Средство поиска команд (только для зарегистрированных клиентов).

Сведения о типе коммутации BRI

BRIs в Австралии требуют идентификаторов профиля no service (SPID).

Существует два switch-type ISDN, которые могут использоваться:

  • basic-net3 — В настоящее время обычно используемый.

  • basic-ts013 — Для более старых коммутаторов ISDN, таких как MicroLink.

Тип коммутатора PRI и служебная информация

В Австралии существует два switch-type, которые могут использоваться:

  • primary-net5 — В настоящее время обычно используемый (“Onramp”).

  • primary-ts015 — Для более старых коммутаторов ISDN, таких как MacroLink.

С PRI существует также много типов предоставленных сервисов:

  • 10 B-каналов (10 64 кбит/с �) — Обычно известный как ONRAMP 10 с primary-net5.

    !
    controller E1 0
    pri-group timeslots 1-10,16
    !
    interface Serial0:15
    isdn switch-type primary-net5
    !
  • 20 B-каналов (20 64 кбит/с �) — Обычно известный как ONRAMP 20 с primary-net5.

    !
    controller E1 0
    pri-group timeslots 1-21
    !
    interface Serial0:15
    isdn switch-type primary-net5
    !
  • 30 B-каналов (30 64 кбит/с �) — Обычно известный как ONRAMP 30 с primary-net5.

    !
    controller E1 0
    pri-group timeslots 1-31
    !
    interface Serial0:15
    isdn switch-type primary-net5
    !

Схема сети

В этом документе использованы параметры данной сети:

/image/gif/paws/10227/isdn_australia.gif

Конфигурации

Этот документ показывает конфигурацию для ISDN в Австралии. В то время как следующие два для PRI, первая конфигурация является BRI.

BRI с основным-net3 switch-type

!--- Configuration uses BRI0 linked to a dialer profile 1
!--- via dialer pool to dial out.

!
!
ip routing
!
isdn switch-type basic-net3 
! 
interface loopback0
ip address 10.10.10.1 255.255.255.0
!
interface BRI0 
 ip unnumbered loopback0
 encapsulation ppp 
 dialer pool-member 1    
 isdn switch-type basic-net3 
 ppp authentication chap pap
! 
interface Dialer1 
 ip address 192.168.12.1 255.255.255.0 
 encapsulation ppp 
 dialer remote-name AROP
 dialer string 0291191111 
 dialer pool 1 
 dialer-group 1 
 ppp authentication chap pap callin    
!
ip classless 
ip route 0.0.0.0 0.0.0.0 Dialer1    
! 
dialer-list 1 protocol ip permit 
!

PRI с switch-type primary-net5

!--- Configuration uses PRI 30 x B-channels linked to a
!--- dialer profile 1 via dialer pool to dial out.

!
ip routing
! 
isdn switch-type primary-net5
! 
interface loopback0
 ip address 10.10.10.1 255.255.255.0
!
controller E1 0
 pri-group timeslots 1-31
!
interface Serial0:15
 ip unnumbered loopback0
 encapsulation ppp 
 dialer pool-member 1    
 isdn switch-type primary-net5
 ppp authentication chap pap 
! 
interface Dialer1 
 ip address 192.168.12.1 255.255.255.0 
 encapsulation ppp 
 dialer remote-name AROP
 dialer string 0291191111 
 dialer pool 1 
 dialer-group 1 
 ppp authentication chap pap callin    
!
ip classless 
ip route 0.0.0.0 0.0.0.0 Dialer1    
! 
dialer-list 1 protocol ip permit 
!

PRI 20 B-каналов, используемых для Аналогового коммутируемого соединения к модемам Cisco MICA

!--- Configuration uses PRI 20 x B-channels 
!--- to terminate up to 20 modem calls
!--- even though we have 30 modems. We are restricted 
!--- by the amount of B-channels.

!
!
ip routing
! 
isdn switch-type primary-net5 
! 
interface loopback0 
ip address 10.10.10.1 255.255.255.0 
! 
controller E1 0  
pri-group timeslots 1-21
!    
interface Serial0:15 
ip unnumbered loopback0 
encapsulation ppp 
isdn switch-type primary-net5 
isdn incoming voice-modem
ppp authentication chap pap 
! 
interface Group-Async 1
ip unnumbered loopback0
encapsulation ppp 
ppp authentication chap pap
async mode dedicated
peer default ip pool swim
group-range 1 30
!
ip local pool swim 192.168.1.1 192.168.1.20
!
line 1 30
modem inout
transport input all

Проверка.

Этот раздел позволяет убедиться, что конфигурация работает правильно.

Средство Output Interpreter (OIT) (только для зарегистрированных клиентов) поддерживает определенные команды show. Посредством OIT можно анализировать выходные данные команд show.

  • команда show isdn status позволяет удостовериться, что маршрутизатор обменивается данными с ISDN-коммуникатором должным образом. В выходных данных команды проверьте наличие сообщений: Layer 1 Status is ACTIVE (Уровень 1 активен) и Layer 2 Status state = MULTIPLE_FRAME_ESTABLISHED (Состояние уровня 2 = MULTIPLE_FRAME_ESTABLISHED). Эта команда показывает также число активных вызовов. Обратитесь к разделу Использование команды show isdn status для устранения неисправностей BRI для получения дополнительной информации.

  • команда show dialer [номер_типа_интерфейса] отображает общие диагностические сведения для интерфейсов, настроенных на маршрутизацию DDR. Если соединение прошло успешно, должно появиться сообщение Dialer state is data link layer up (Установлен канальный уровень для интерфейса номеронабирателя). Появление сообщения physical layer up (Установлен физический уровень) означает, что протокол линии успешно инициализирован, но протокол управления сетью (NСP) не готов к работе. Исходный и конечный адреса пакета, инициировавшего вызов номера, показаны в строке причины вызова. Эта команда show также отображает конфигурацию таймера и время, оставшееся до прекращения соединения.

  • show caller user username detail - показываются параметры для конкретного пользователя, такие как назначенный IP-адрес, параметры протокола PPP и связки PPP и т. д. Версия Cisco, программное обеспечение IOS� не поддерживает эту команду, при использовании команды show user.

  • команда show dialer map отображает настроенные статические и динамические карты номеронабирателей. Данная команда используется для проверки создания динамической схемы набора номеров. Невозможно выполнить маршрутизацию пакетов без схемы набора номера.

Устранение неполадок

Используйте этот раздел для устранения неполадок своей конфигурации.

Ресурсы для устранения неполадок

Для получения информации по устранению проблем см. следующие документы:

Команды для устранения неполадок

Примечание: Прежде чем выполнять какие-либо команды отладки , ознакомьтесь с документом "Важные сведения о командах отладки".

  • "debug dialer" - отображаются данные отладки устройства прямой записи на диск о пакетах, полученных на интерфейс номеронабирателя. Данные сведения помогут убедиться в наличии существенного трафика, который может использовать интерфейс номеронабирателя.

  • debug isdn q931 – отображает параметры настройки вызова и разрыва сетевого подключения ISDN (3-й уровень).

  • debug modem - отображает активность линии модема для сервера доступа. В результатах показано, когда изменяется состояние модемной линии.

  • debug modem csm - команда EXEC для устранения неполадок модуля коммутации вызовов (CSM) на маршрутизаторах со встроенными цифровыми модемами. Используя эту команду, можно отследить последовательность всех входящих и исходящих вызовов коммутатора.

  • debug ppp negotiation — Отображает информацию на трафике PPP и обменивается в то время как согласование протокола LCP (LCP) и Аутентификация и NCP. В успешных переговорах PPP сначала выясняется состояние LCP, затем проводится аутентификация и наконец выполняется согласование NCP. Многозвенные параметры, такие как максимально восстановленный полученный блок (MRRU), устанавливаются во время согласования LCP.

  • debug ppp authenticaion — Отображает сообщения протокола аутентификации PPP, включая обмены пакетами Протокола аутентификации по квитированию вызова (CHAP) и обмены Протокола аутентификации пароля (PAP).

  • debug ppp error — - отображаются ошибки протокола и статистических данных, связанные с согласованием и функционированием PPP-соединения.

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения


Document ID: 10227