Глобальная сеть (WAN) : Frame Relay

Настройка резервного копирования ISDN для линий связи WAN с использованием плавающих статических маршрутов

5 апреля 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Содержание


Введение

Эта эталонная конфигурация показывает, как резервируется канал Frame Relay с цифровой сетью с комплексными услугами (ISDN) с помощью использования плавающих статических маршрутов и маршрутизации по требованию (DDR).

Предварительные условия

Требования

Для этого документа отсутствуют особые требования.

Используемые компоненты

При разработке и тестировании этой конфигурации использовались следующие версии программного и аппаратного обеспечения.

  • Маршрутизаторы Cisco 2503

  • Cisco Выпуск ПО IOS� 12.2 (7b) работал на обоих маршрутизаторах

Сведения, представленные в этом документе, были получены от устройств в специфической лабораторной среде. Все устройства, используемые в этом документе, были запущены с чистой конфигурацией (конфигурацией по умолчанию). При работе с реальной сетью необходимо полностью осознавать возможные результаты использования всех команд.

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Технические рекомендации Cisco. Условные обозначения.

Теоретические сведения

Одной из целей использования каналов WAN является обеспечение резервного канала на случай сбоя. ISDN часто предоставляет эту резервную копию. Cisco предлагает запасные стратегии, которые позволяют выполнять те же функции, но другими способами. Если канал Frame Relay перестает пропускать данные маршрутизации, то плавающий статический маршрут может задействовать резервный канал.

Примечание: Данный пример показывает резервную копию для Frame Relay с помощью плавающих статических маршрутов. Однако можно также использовать этот метод для создания копии любого канала WAN.

Другие решения могут использовать резервный интерфейс (См. Настройку Резервный интерфейс для Подинтерфейса), или часы Номеронабирателя. Если используется командный подход к резервному интерфейсу, субинтерфейсы "точка-точка" более выгодны, так как основной и многоточечный интерфейсы могут оставаться в рабочем состоянии, даже если постоянные виртуальные подключения (PVC) перестают работать с Frame Relay.

Для получения дополнительной информации о настройке Резервирования DDR обратитесь к настройке документа и устранение проблем при резервировании DDR. Можно также сослаться на документ Анализы резервного интерфейса, Floating Static Routes и функция Dialer Watch для Резервирования DDR для получения дополнительной информации о различных методах Резервирования DDR.

Настройка

В этом разделе содержатся сведения о настройке функций, описанных в этом документе.

Примечание: Для обнаружения дополнительных сведений о командах используемыми в этом документе используйте Средство поиска команд Command Lookup Tool для IOS.

Схема сети

В данном документе используется сеть, изображенная на следующей схеме.

/image/gif/paws/10214/fr_isdn_backup.gif

Конфигурации

В данном документе используются следующие конфигурации.

Эта конфигурация была протестирована с помощью Cisco IOS Software Release 12.2(7b) на маршрутизаторах серии 2500. Те же принципы конфигурации применимы к похожей топологии маршрутизатора или к другим выпускам Cisco IOS.

Router1 (маршрутизатор Cisco 2503)
Current configuration:

version 12.2
!
hostname Router1
!

!--- This username password pair is used for 
!--- PPP CHAP authentication

username Router2 password 0 letmein
ip subnet-zero
no ip domain-lookup
!
isdn switch-type basic-5ess
!
interface Ethernet0
 ip address 172.16.1.1 255.255.255.0
 no ip route-cache
 no ip mroute-cache
!
interface Serial0

!--- Primary Link.
!--- The bandwidth is adjusted to allow for rapid backup of the link.


!--- This adjusts the EIGRP Hello interval and 
!--- Hold time for rapid convergence.
!--- The bandwidth command does not actually change the bandwidth of the link,
!--- it only adjusts the routing protocol bandwidth parameter.

 bandwidth 2048
 ip address 172.16.2.1 255.255.255.128
 encapsulation frame-relay
 no ip route-cache
 no ip mroute-cache
 clockrate 64000
!
interface Serial1
 no ip address
 no ip route-cache
 no ip mroute-cache
 shutdown
!
interface BRI0

! -- Backup link.

 ip address 172.16.3.1 255.255.255.0

! -- The backup link is in a different subnet.
! -- The BRI interface on the peer should also be in this subnet.

 encapsulation ppp
 no ip route-cache
 no ip mroute-cache
 dialer map ip 172.16.3.2 name Router2 broadcast 5552000

! -- Dialer map for the peer. Note the IP address and name.
! -- The name must match the authenticated username of the peer.

 dialer load-threshold 5 either
 dialer-group 1

! -- Apply interesting traffic definition.
! -- Interesting traffic definition is defined in dialer-list 1.

 isdn switch-type basic-5ess
 ppp authentication chap
 ppp multilink
!
router eigrp 100

!--- This example uses eigrp. 
!--- You can use any routing protocol instead.

 network 172.16.0.0
 auto-summary
 no eigrp log-neighbor-changes
!
ip classless
ip route 172.16.4.0 255.255.255.0 172.16.3.2 200

!--- The floating static route is defined.
!--- Note the administrative distance of the route is 200.
!--- Hence it is only used when all other routes for 172.16.4.0/24 
!--- are lost. Note that the next hop for the floating static route 
!--- matches the dialer map ip. If the nexthop is not the same as 
!--- in the dialer map then the router will no dial.

!
access-list 100 deny   eigrp any any
access-list 100 permit ip any any

!--- EIGRP routing packets are denied in the dialer-list.


!--- This prevents eigrp packets from keeping the link up.
!--- Adjust the interesting traffic depending on your traffic definitions.

!
dialer-list 1 protocol ip list 100

!---  Interesting traffic defintion. Use access-list 100.
!---  The interesting traffic is applied to BRI interface 
!--- using dialer-group 1. 

!
line con 0
line aux 0
 transport input all
line vty 0 4
 login
!
end

Для маршрутизатора Router1 был настроен плавающий статический маршрут. Плавающий статический маршрут имеет назначенное административное расстояние 200. Маршрут к тождественной подсети также изучается через канал ретрансляции кадров по улучшенному протоколу маршрутизации внутреннего шлюза (EIGRP), который подчеркивает дополнительную или избыточную природу плавающего маршрута. EIGRP узнал, что маршрут будет установлен в таблице маршрутизации из-за ее меньшего административного расстояния 90, по сравнению с тем из 200 статического маршрута. В случае сбоя Соединения Frame Relay маршрут EIGRP исчезнет из таблицы маршрутизации, плавающий статический маршрут установлен. Любой содержательный трафик, подлежащий пересылке через соединение ISDN, включает канал. Когда подключение восстановлено по Frame Relay, маршрут изучен снова через EIGRP. Этот маршрут заменяет статический маршрут и направляет трафик через цепь frame relay еще раз.

Трафик протокола маршрутизации отмечен как неинтересный в списке номеронабирателя так, чтобы это не заставляло линию ISDN соединяться или оставаться связанной. Однако, как только ссылка закончилась, пакеты EIGRP могут пересечь ссылку, и эти два маршрутизатора могут обмениваться сведениями о маршрутизации. Широковещательное ключевое слово было включено в инструкцию схемы набора номеров для разрешения прохода трафика протокола маршрутизации по соединению ISDN. Если вы не хотите, чтобы EIGRP обменивался сведениями о маршрутизации, даже если соединение ISDN произошло, не включайте широковещательное ключевое слово в инструкцию схемы набора номеров.

Команда dialer load-threshold устанавливает загрузку, которая запустит параллельный вызов для его размещения во втором канале B. Множественный Point-to-Point Protocol (PPP) был настроен (ppp multilink) таким образом, что оба канала ISDN B могут быть связаны вместе как один интерфейс виртуального доступа для объединения пропускной способности.

В текущей конфигурации только маршрутизатор Router1 настроен для выполнения вызова. Маршрутизатор 2 получает вызовы от маршрутизатора 1. Если вы хотите, чтобы обе стороны перевели ссылку в рабочее состояние, добавьте cхему набора номеров и команды dialer load-threshold к конфигурации Router2.

Маршрутизатор 2 (Cisco 2503)
Current configuration:

version 12.2
!
!
hostname Router2
!
username Router1 password 0 letmein
ip subnet-zero
no ip domain-lookup
!
isdn switch-type basic-5ess
!
!
interface Ethernet0
 ip address 172.16.4.1 255.255.255.0
!
interface Serial0
 bandwidth 2048
 ip address 172.16.2.2 255.255.255.128
 encapsulation frame-relay
 clockrate 64000
!
interface Serial1
 no ip address
 shutdown
 clockrate 64000
!
interface BRI0
 ip address 172.16.3.2 255.255.255.0

! -- IP address of backup interface.
! -- This router accepts the call. Note the IP address matches both the 
! -- dialer map floating static router nexthop on the peer.

 encapsulation ppp
 dialer-group 1
 isdn switch-type basic-5ess
 ppp authentication chap
 ppp multilink

!--- The missing dialer map command disables 
!--- this router from making the call.

!
router eigrp 100
 network 172.16.0.0
 auto-summary
 no eigrp log-neighbor-changes
!
ip classless
ip route 172.16.1.0 255.255.255.0 172.16.3.1 200
!
access-list 100 deny   eigrp any any
access-list 100 permit ip any any
dialer-list 1 protocol ip list 100
!
!
line con 0
line aux 0
line vty 0 4
!
end

Проверка.

В данном разделе содержатся сведения о проверке работы конфигурации.

Изменения в таблице маршрутизации

Примечание: Некоторые команды show поддерживаются Интерпретатором выходных данных; это позволяет выполнять анализ выходных данных команды show;

См. ниже таблицы маршрутизации с Router1. Обратите внимание, что плавающий статический маршрут заменил известный маршрут EIGRP после того как маршрутизатор 2 стал недоступен по каналу Frame Relay.

Когда Соединение Frame Relay произошло, показанный ниже таблица маршрутизации Router1.

Router1#show ip route      
     Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
            D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
            N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
            E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
            i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS 
            inter area      
            * - candidate default, U - per-user static route, o - ODR 
            P - periodic downloaded static route 

     Gateway of last resort is not set 

     172.16.0.0/16 is variably subnetted, 4 subnets, 2 masks 
      [D 172.16.4.0/2490/1787392] via 172.16.2.2, 00:06:56, Serial0
     
!---  EIGRP learned route over Frame Relay link 

     C 172.16.1.0/24 is directly connected, Ethernet0 
     C 172.16.2.0/25 is directly connected, Serial0 
     C 172.16.3.0/24 is directly connected, BRI0 
     Router1# 

При потере связи по сети Frame Relay маршрутизатор 1 устанавливает плавающий статический маршрут так, как показано ниже.

Router1#show ip route 
     Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP 
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2 
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP 
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area 
       * - candidate default, U - per-user static route, o - ODR 
       P - periodic downloaded static route 

     Gateway of last resort is not set 

     172.16.0.0/16 is variably subnetted, 4 subnets, 2 masks 
     S 172.16.4.0/24 [200/0] via 172.16.3.2 
     
!--- Floating static route. Administrative distance is 200 

     C 172.16.1.0/24 is directly connected, Ethernet0 
     C 172.16.2.0/25 is directly connected, Serial0 
     C 172.16.3.0/24 is directly connected, BRI0 
     Router1# 

Любой представляющий интерес трафик к сети 172.16.4.0/24 теперь переводит ISDN - подключение в рабочее состояние. Например, от Router1, эхо-запрос к 172.16.4.1 переводит соединение ISDN в рабочее состояние как показано ниже.

Примечание: Если вы делаете протокол маршрутизации содержательным, то периодический трафик переводит ссылку в рабочее состояние автоматически. Нижняя сторона этого - то, что ссылка останется неопределенно, возможно приводя к высоким картам за услуги.

Router1#ping 172.16.4.1 
Type escape sequence to abort. 
Sending 5, 100-byte ICMP Echos to 172.16.4.1, timeout is 2 seconds: 
.!!!! 
Success rate is 80 percent (4/5), round-trip min/avg/max = 36/36/36 ms 
Router1# 
3d22h: %LINK-3-UPDOWN: Interface BRI0:1, changed state to up 
3d22h: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to up 
3d22h: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI0:1, 
changed state to up 
3d22h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access1, 
changed state to up 
3d22h: %ISDN-6-CONNECT: Interface BRI0:1 is now connected to 5552000 Router2 
Router1# 

Так как линия ISDN произошла, EIGRP теперь запускает exchaging сведения о маршрутизации по ISDN - подключению. Это заставляет Router1 устанавливать маршрут EIGRP в свою таблицу маршрутизации, указывая на следующий переход 172.16.3.2.

Router1#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP 
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2 
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP 
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area 
       * - candidate default, U - per-user static route, o - ODR 
       P - periodic downloaded static route 

Gateway of last resort is not set 

172.16.0.0/16 is variably subnetted, 5 subnets, 3 masks 
D      172.16.4.0/24 [90/40537600] via 172.16.3.2, 00:00:17, BRI0

!--- EIGRP route learnt over the ISDN link 

C      172.16.3.2/32 is directly connected, BRI0 
C      172.16.1.0/24 is directly connected, Ethernet0 
C      172.16.2.0/25 is directly connected, Serial0 
C      172.16.3.0/24 is directly connected, BRI0 
Router1# 

Представляющий интерес трафик является трафиком, который будет инициировать вызов ISDN и определен командой dialer-list. В вышеупомянутой конфигурации dialer-list указывает к access-list количество 100, которое разрешает все пакеты IP кроме пакетов EIGRP. Это означает, все пакеты IP, кроме пакетов EIGRP, могут перевести ISDN - подключение в рабочее состояние. Как только соединение сделано, любому трафику, включая трафик EIGRP, позволяют пойти по ссылке. Но если никакой представляющий интерес трафик не пересечет соединение ISDN на время таймера простоя номеронабирателя, то ссылка будет переведена в нерабочее состояние, и никакими маршрутами EIGRP не обменяются. На этом этапе плавающий статический маршрут будет снова установлен в таблице маршрутизации Router1.

Устранение неполадок

Для получения информации об устранении проблем плавающего статического маршрута обращаются к настройке документа и устранение проблем при резервировании DDR. Этот документ обращается к распространенным симптомам, таким как:

  • Когда основное соединение выключается, Резервное соединение не набрано.

  • Наборы Резервного соединения, но не соединяются с другой стороной.

  • Резервный канал не отключается при восстановлении основной линии.

  • Резервное соединение не стабильно (например, оно колеблется), когда основной интерфейс не работает.

Для Frame Relay определенное устранение проблем обращаются к Резервному копированию Frame Relay Настройки

Следующие команды могут помочь устранять неполадки резервного соединения.:

  • debug dialer events - Видеть процесс маршрутизации по требованию.

  • пакеты debug dialer - Для наблюдения сведений о содержательном трафике для программы набора номера.

  • show ppp multilink —- Для проверки многоканального статуса после, резервная копия подошла.

Перед выполнением любой команды отладки ознакомьтесь с разделом "Важные сведения о командах отладки".

Выходные данные отладки

Трафик протокола маршрутизации (EIGRP) маркируется неинтересным с помощью команды dialer list, чтобы он не смог активировать канал или удерживать его активным. Однако, когда ссылка активна, обновлениями маршрута обменяются. При помощи команды отладки пакета номеронабирателя можно проверить, может ли верный трафик привести к остановки канала. Выходные данные приводятся ниже.

Router1#debug dialer packets 
Dial on demand packets debugging is on 
Router1# 
3d22h: BR0 DDR: ip (s=172.16.3.1, d=224.0.0.10), 60 bytes, 
outgoing uninteresting (list 100)

!--- EIGRP packet 

3d22h: BR0 DDR: sending broadcast to ip 172.16.3.2 -- failed, 
not connected 

!---  EIGRP packet does not bring up the link 

3d22h: BR0 DDR: ip (s=172.16.3.1, d=224.0.0.10), 60 bytes, 
outgoing uninteresting (list 100)

!--- EIGRP packet 

3d22h: BR0 DDR: sending broadcast to ip 172.16.3.2 -- failed, 
not connected 

!---  EIGRP packet does not bring up the link 

3d22h: BR0 DDR: cdp, 273 bytes, outgoing uninteresting (no list matched) 

Представляющий интерес трафик (эхо Протокола ICMP в этом случае) перезагрузит счетчик простоя и поддержит соединение как ниже. Несодержательный трафик передается, но он не будет поддерживать канал в активном состоянии, когда срок таймера простоя истечет.

Router1#ping 172.16.4.1 
Type escape sequence to abort. 
Sending 5, 100-byte ICMP Echos to 172.16.4.1, timeout is 2 seconds: 
!!!!! 
Success rate is 100 percent (5/5), round-trip min/avg/max = 40/51/80 ms 
Router1# 
3d22h: BR0 DDR: ip (s=172.16.3.1, d=172.16.4.1), 100 bytes, 
outgoing interesting (list 100)

!--- ICMP packet (ping) 

3d22h: BR0 DDR: ip (s=172.16.3.1, d=172.16.4.1), 100 bytes, 
outgoing interesting (list 100)

!--- ICMP packet (ping)

3d22h: BR0 DDR: ip (s=172.16.3.1, d=172.16.4.1), 100 bytes, 
outgoing interesting (list 100)

!--- ICMP packet (ping)

3d22h: BR0 DDR: ip (s=172.16.3.1, d=172.16.4.1), 100 bytes, 
outgoing interesting (list 100)

!--- ICMP packet (ping)

3d22h: BR0 DDR: ip (s=172.16.3.1, d=172.16.4.1), 100 bytes, 
outgoing interesting (list 100)

!--- ICMP packet (ping)

3d22h: BR0 DDR: ip (s=172.16.3.1, d=224.0.0.10), 60 bytes, 
outgoing uninteresting (list 100)

!--- EIGRP packet 

3d22h: BR0 DDR: sending broadcast to ip 172.16.3.2 
3d22h: BR0 DDR: ip (s=172.16.3.1, d=224.0.0.10), 60 bytes, 
outgoing uninteresting (list 100)

!--- EIGRP packet 

3d22h: BR0 DDR: sending broadcast to ip 172.16.3.2 

Хотя отмечено как неинтересные, пакеты EIGRP пересекают соединение ISDN, потому что соединение уже сделано содержательным трафиком ICMP.

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения


Document ID: 10214