Качество обслуживания (QoS) : QoS - управление перегрузками сети (организация очередей)

Формирование CBWFQ и LLQ на MLPPP и интерфейсах наборного устройства

6 сентября 2014 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (12 августа 2014) | Отзыв


Содержание


Введение

Команда обслуживания обычно применяет стратегическую карту, формируемую с командами модульного QoS CLI (MQC) к главному интерфейсу, подынтерфейсу или виртуальной цепи. Можно также применить эту команду к действительному интерфейсу шаблона, многоканальному интерфейсу и интерфейсу наборного устройства, формируемому с герметизацией двухточечного протокола (PPP) и многоканальным PPP (MLPPP). Такой результат интерфейсов в интерфейсе действительного доступа, где организация очереди функционально имеет место. Этот документ обеспечивает единственную ссылку для понимания рекомендуемых конфигураций и связанных протестов применить основанную на классе взвешенную справедливую организацию очереди (CBWFQ) и низкое время ожидания, стоя в очереди (LLQ) к интерфейсам связки MLPPP и интерфейсам наборного устройства.

Предпосылки

Требования

Нет никаких определенных предпосылок для этого документа.

Используемые компоненты

Этот документ не ограничен определенными версиями программного и аппаратного обеспечения.

Соглашения

Направьте в Cisco Технические Соглашения Подсказок для получения дополнительной информации о соглашениях документа.

Примените организацию очереди к взаимодействиям со множеством полос пропускания

1990 RFC leavingcisco.com определяет многоканальный PPP, который объединяет один или несколько физических интерфейсов в действительный интерфейс "связки". Полоса пропускания интерфейса связки равна сумме полосы пропускания составляющих связей. Таким образом интерфейс связки имеет максимальную стоимость полосы пропускания, которая варьируется в мгновенный момент вовремя.

Первоначально, полоса пропускания и приоритетные команды поддержали только абсолютную стоимость kbps. Если вы применили обслуживание с CBWFQ и LLQ к интерфейсу связки, и первый активный интерфейс не поддерживал абсолютную стоимость kbps, обслуживание подвело контроль приема. Маршрутизатор удалил обслуживание и напечатал сообщения об ошибках, подобные этой продукции:

May 18 17:32:34.766 MEST: CBWFQ: Not enough available bandwidth for all 
classes Available 48 (kbps) Needed 96 (kbps) 
May 18 17:32:34.766 MEST: CBWFQ: Removing service policy on Dialer100

С Cisco IOS® Software Release 12.2T маршрутизатор теперь пытается повторно использовать политику, когда это обнаруживает, что дополнительный интерфейс (такой как второй B-канал BRI) добавлен к связке. Превосходящий подход должен формировать приоритет и команды полосы пропускания как процент доступной полосы пропускания. Использование стоимости процента формирует маршрутизатор для назначения относительной суммы полосы пропускания, которая приспосабливается, поскольку связка содержит одну или более членских связей. Выпуск 12.2 (2) T программного обеспечения Cisco IOS ввел поддержку приоритетной команды процента на Серийных маршрутизаторах Cisco 7500 и других платформах. Для получения дополнительной информации обратитесь к Низкому Времени ожидания, Стоя в очереди с Приоритетной Поддержкой Процента.

CBWFQ и LLQ в интерфейсах наборного устройства

Направление дисков по требованию (DDR) может формироваться двумя способами:

  • Наследство DDR — Применяет диски и параметры протокола непосредственно к физическому интерфейсу.

  • Профили наборного устройства — Применяют диски и параметры протокола динамично к интерфейсу наборного устройства, который в свою очередь связывает с физическими интерфейсами. Например, интерфейс наборного устройства включает одну или более последовательностей дисков для достижения отдаленного места, типа идентификации PPP и MLPPP.

Устаревший DDR первоначально поддержал метод "первым пришел - первым вышел" (FIFO), стоящий в очереди только, когда последовательный интерфейс или интерфейс ISDN формировались с MLPPP. Это ограничение применилось, даже когда два конца связи не договаривались о MLPPP и использовали физический интерфейс в качестве интерфейса несвязки, который управляет герметизацией PPP. Традиционная взвешенная справедливая организация очереди (WFQ) через команду справедливой очереди теперь поддержана.

Если вы принимаете решение формировать профили наборного устройства, и интерфейс наборного устройства и основные физические интерфейсы поддерживают команду обслуживания. Если вы применяете политику по физическому интерфейсу, выпускаете или интерфейсную последовательную команду стратегической карты шоу или выставочный интерфейс базового уровня интерфейса стратегической карты 0/0:1bri0/0:2) команда для подтверждения конфигурации. D-канал, идентифицированный в IOS как BRI0/0, передача сигналов поддержек и не поток данных. Если вы применяете политику к интерфейсу наборного устройства, выпускаете выставочные диски интерфейса организации очередей <0-255> команда для подтверждения конфигурации.

Выпуски программного обеспечения Cisco IOS 12.2 (4) и 12.2 (4) T ввели поддержку основанных на организации очереди обслуживаний в интерфейсах действительного доступа, созданных из интерфейса наборного устройства, формируемого с MLPPP. В предыдущих выпусках параметры обслуживания не скопированы к клонированному интерфейсу действительного доступа, где организация очереди фактически имеет место. Эта продукция иллюстрирует эти признаки:

Router#show policy interface dialer1
  Dialer1 
   Service-policy output: foo 

     Class-map: class-default (match-any) 
       0 packets, 0 bytes 
       5 minute offered rate 0 bps, drop rate 0 bps 
       Match: any 
       Weighted Fair Queueing 
         Flow Based Fair Queueing 
         Maximum Number of Hashed Queues 256 
         (total queued/total drops/no-buffer drops) 0/0/0 

Router#show policy interface virtual-access 2
 Router#

Примечание: Выпуску 12.2 (8) и 12.2 (8) T программного обеспечения Cisco IOS рекомендуют избежать ошибки ID CSCdu87408 Cisco, которая решает, что маршрутизатор перезагружает как редкий побочный эффект этой конфигурации.

Эта типовая конфигурация показывает, как применить CBWFQ и LLQ к интерфейсу наборного устройства. Эта конфигурация приводит к:

  • Использует интерфейс наборного устройства для применения динамично параметров протокола связи с интерфейсами BRI ISDN. Интерфейс наборного устройства, как говорят, "связан" с интерфейсами BRI ISDN.

  • Помещает два интерфейса BRI ISDN в многоканальную связку.

  • Когда маршрутизатор должен активировать дополнительные B-каналы и увеличить полосу пропускания интерфейса связки, использует груз порога груза наборного устройства [за границу | прибывающий | любой] команда для определения.

  • Создает взаимодействие действительного доступа с ppp многоканальной командой.

  • Применяет обслуживание с CBWFQ и LLQ к интерфейсу действительного доступа посредством интерфейса наборного устройства.

Типовая конфигурация
access-list 101 permit udp any any range 16384 32767
access-list 101 permit tcp any any eq 1720
!
access-list 102 permit tcp any any eq 23
! 
class-map voice
    match access-group 101

!--- Traffic that matches ACL 101 is classified as class voice.

class-map data
    match access-group 102

!--- Traffic that matches ACL 102 is classified as class data.

policy-map mlppp 
   class voice 
      priority percent 50 
   class data 
      bandwidth percent 25 
   class class-default 
     fair-queue 
!
interface BRI2/1  
  no ip address  
  encapsulation ppp  
  dialer pool-member 1  

!--- Member of dialer pool 1.

  isdn switch-type basic-net3  
  no cdp enable  
  ppp authentication chap  
! 
interface BRI2/2 
  no ip address  
  encapsulation ppp  
  dialer pool-member 1  

!--- Member of dialer pool 1.

  isdn switch-type basic-net3  
  no cdp enable  
  ppp authentication chap  
!  
interface Dialer2  
  ip unnumbered Loopback0  
  encapsulation ppp  
  dialer pool 1  
  dialer load-threshold 1 either  
  
!--- Load level (in either direction) for  
  !--- traffic at which additional connections  
  !--- are added to the MPPP bundle 
  !--- load level values that range from 1 (unloaded)  
  !--- to 255 (fully loaded).

  dialer string 6113 
  dialer string 6114  
  dialer-group 1  
  ppp authentication chap  
  ppp multilink  

!--- Allow MLPPP for the four BRI channels.

  service-policy output mlppp 
  
!--- Apply the service policy to the dialer interface.

LLQ и CBWFQ с распределенным MLPPP

Ряд Cisco 7500 использует распределенную архитектуру, которая гарантирует высокую пропускную способность пакета путем перемещения отправляющих пакет решений с Процессора выключателя маршрута (RSP) на Универсальные Интерфейсные Процессоры (VIPs). Эта архитектура также позволяет развертывание крупномасштабных улучшенных услуг IP, таких как QoS, путем распределения нагрузки обработки через многократные независимые процессоры VIPs.

Основанный на интерфейсных аппаратных средствах, ряд Cisco 7500 поддерживает две формы QoS:

QoS Как позволенный Где поддержано Где обработано
Основанный на RSP Автоматически на устаревших процессорах интерфейса. Устаревшие Процессоры Интерфейса. Больше не может позволяться на VIPs. ЦЕНТРАЛЬНЫЙ ПРОЦЕССОР RSP
ОСНОВАННЫЙ НА VIP (Распределенный) Автоматически, когда формируются эти две команды:
  • IP cef распределенная команда в глобальном способе конфигурации.
  • IP тайник маршрута распределил команду в интерфейсном способе конфигурации.
VIPs ЦЕНТРАЛЬНЫЙ ПРОЦЕССОР VIP

ОСНОВАННЫЕ НА VIP механизмы QoS, примененные через модульный QoS CLI (MQC), введены в этих трех поездах выпуска программного обеспечения Cisco IOS:

  • Выпуск 12.0 программного обеспечения Cisco IOS (XE), который стал Выпуском 12.1 (E) программного обеспечения Cisco IOS

  • Выпуск 12.0 (9) S программного обеспечения Cisco IOS

  • Выпуск 12.1 (5) T программного обеспечения Cisco IOS, который стал магистралью Выпуска 12.2 программного обеспечения Cisco IOS и Выпуском 12.2T программного обеспечения Cisco IOS

Распределенная особенность MLPPP позволяет вам объединять полосу пропускания многократных интерфейсов T1/E1 на VIP в интерфейс связки. Для получения дополнительной информации обратитесь к Распределенному Многоканальному Двухточечному Протоколу для Серийных маршрутизаторов Cisco 7500. Выпуск 12.2 (13) T программного обеспечения Cisco IOS вводит поддержку Распределенного MLPPP (dMLPPP) на ненаправленных адаптерах порта, таких как PA-4T + и PA-8T.

Выпуск 12.2 (8) T программного обеспечения Cisco IOS ввел поддержку распределенного LLQ и CBWFQ в интерфейсах связки dMLPPP на направленных адаптерах порта такой как PA-MC-xT1/E1 и PA-MC-xT3/E3. Как нераспределенная версия этой особенности, dMLPPP использует интерфейс, многоканальный для создания интерфейса действительного доступа, где организация очереди функционально имеет место. Обратитесь к Новой и Измененной информации для Выпуска 12.2T программного обеспечения Cisco IOS. Когда вы применяете распределенную организацию очереди с dMLPPP, Выпуск 12.2 (10) T программного обеспечения Cisco IOS, или позже рекомендован для ухода от ошибки ID CSCdw47678 Cisco.

Только CBWFQ и LLQ, как применено с командой обслуживания поддержаны с dMLPPP/dLFI. Наследство, стоящее в очереди особенности, такие как ярмарка, стоящая в очереди с командой справедливой очереди, приоритет, стоящий в очереди с командой приоритетной группы и обычаем, стоящим в очереди с командой списка очереди, не поддержано.

FlexWAN для ряда Cisco 7600 поддерживает dLLQ в интерфейсах несвязки. Это не поддерживает dLLQ в интерфейсах связки MLPPP. Эта поддержка доступна с Выпуском 12.2S программного обеспечения Cisco IOS.

Эта типовая конфигурация применяет dLLQ на многоканальный интерфейс:

Типовая Конфигурация dLLQ в Интерфейсе Связки MLPPP
Interface 
! 
access-list 100 permit udp any any range 16384 32000
access-list 100 permit tcp any any eq 1720
access-list 101 permit tcp any any eq 80
access-list 102 permit tcp any any eq 23
!
class-map voip 
   match access-group 100
class-map data1
    match access-group 101
class-map data2 
    match access-group 102
!
policy-map llq-policy
    class voip 
     bandwidth 40 
    class data1 
     bandwidth 15 
    class data2 
     bandwidth 15
    class class-default 
     fair-queue
!
policy-map set-policy
    class voip 
     bandwidth 40 
    class data1 
     bandwidth 15
    class data2 
     bandwidth 15 
    class class-default 
     fair-queue
!
interface Serial5/0/0:0 
   no ip address 
   encapsulation ppp 
   keepalive 10 
   ppp chap hostname G2 
   ppp multilink 
   multilink-group 2 
!  
interface Serial5/1/0:0 
  no ip address 
  encapsulation ppp 
  keepalive 10 
  ppp chap hostname G2 
  ppp multilink 
  multilink-group 2 
!  
interface Multilink2 
  ip address 106.0.0.2 255.0.0.0 
  ppp multilink 
  service-policy output llq-policy 
  service-policy input set-policy 
  multilink-group 2

Фрагментация связи и чередующий (LFI) добавляет ppp многоканальную задержку фрагмента и ppp многоканальные команды чередования к интерфейсному действительному шаблону, формируемому с MLPPP и обслуживанием. Эта конфигурация уменьшает задержку на связях более медленной скорости путем разбивания больших дейтаграмм и чередования транспортных пакетов низкой задержки с меньшими пакетами, которые следуют из фрагментированной дейтаграммы. Для получения дополнительной информации обратитесь к Формированию Фрагментации Связи и Чередованию для Виртуальных цепей ATM и Ретрансляции кадров.

Выпуск 12.2 (8) T программного обеспечения Cisco IOS ввел поддержку распределенного LFI (dLFI), сверхнаправил последовательные линии на ряду Cisco 7500 с VIPs. Эта особенность также доступна с Катализатором 6500 Серийных Выключателей и Серийные маршрутизаторы Cisco 7600. Для получения информации о выпусках, которые поддерживают dLFI, обратитесь к Инструменту Навигатора Особенности (только зарегистрированные клиенты) и Информация о версии для соответствующих продуктов. Для получения дополнительной информации об этой особенности обратитесь к Распределенной Фрагментации Связи и Чередующий по Выделенным линиям.

FlexWAN для ряда Cisco 7600 с Поездом Выпуска программного обеспечения Cisco IOS 12.1E не поддерживает dLFI.

После формирования максимальной задержки фрагмента с ppp многоканальной задержкой фрагмента <msec> команда dLFI особенность вычисляет фактический размер фрагмента на направленные последовательные взаимодействия с использованием этой формулы (где полоса пропускания находится в kbps):

fragment size = bandwidth x fragment-delay  / 8

Кроме того, размер фрагмента вычислен основанный на членской связи с самой маленькой суммой полосы пропускания. Например, в конфигурации с членскими связями 64 К и 128 К, размер фрагмента вычислен основанный на связи на 64 К.

CBWFQ и LLQ с PPPoA и MLPPPoA

Выпуск 12.2 (8) программного обеспечения Cisco IOS ввел поддержку за - VC стоящий в очереди на виртуальных цепях ATM, формируемых с универсальным PPP по ATM (PPPoA) герметизация. Эти подразделы дают вам примеры конфигурации Основанного на классе отмечания, Охраны и Организации очереди.

1. Основанное на классе отмечание

Команда обслуживания может быть присоединена к интерфейсу Действительного шаблона или ATM PVC для Основанного на классе отмечания.

В этом примере определена карта PEER2PEER класса, стратегическая карта MARK_PEER2PEER создана, и dscp неплатеж формируется для класса PEER2PEER; тогда обслуживание присоединено к действительному шаблону или ATM PVC.

Router(config)#class-map PEER2PEER
Router(config-cmap)#match access-group 100
Router(config-cmap)#exit

Router(config)#policy-map MARK_PEER2PEER
Router(config-pmap)#class PEER2PEER
Router(config-pmap-c)#set dscp default
Router(config-pmap-c)#end


Attaching Service-policy to Virtual Template


Router(config-subif)#int atm1/0.1 point-to-point
Router(config-subif)#ip address 10.10.10.1 255.255.255.0
Router(config-subif)#pvc 1/50
Router(config-if-atm-vc)#encapsulation aal5mux ppp virtual-Template 1

Router(config)#interface Virtual-Template1
Router(config-if)#ip address negotiated
Router(config-if)#service-policy output MARK_PEER2PEER 


Attaching Service-policy to ATM pvc

Router(config)#int atm1/0.1 point-to-point
Router(config-subif)#ip address 10.10.10.1 255.255.255.0
Router(config-subif)#pvc 1/50
Router(config-if-atm-vc)#service-policy output MARK_PEER2PEER

2. Основанная на классе охрана:

Команда обслуживания может быть присоединена к интерфейсу Действительного шаблона или ПВХ ATM для Основанной на классе Охраны.

Router(config)#policy-map POLICE_PEER2PEER
Router(config-pmap)#class PEER2PEERRouter(config-pmap-c)#police 8000 conform-action transmit exceed-action drop

Attaching Service-policy to Virtual Template

Router(config-subif)#int atm1/0.2 multipoint
Router(config-subif)#no ip address
Router(config-subif)#pvc 1/100
Router(config-if-atm-vc)#encapsulation aal5mux ppp virtual-Template 2

Router(config)#interface Virtual-Template2
Router(config-if)#ip address negotiated
Router(config-if)#service-policy output POLICE_PEER2PEER 



Attaching Service-policy to ATM pvc

Router(config)#int atm1/0.2 multipoint
Router(config-subif)#no ip address
Router(config-subif)#pvc 1/100
Router(config-if-atm-vc)#service-policy output POLICE_PEER2PEER

3. Основанная на классе организация очереди:

Для Основанной на классе Организации очереди, то есть, полосы пропускания, формы, приоритет, и случайный - обнаруживает, команда обслуживания может быть присоединена к Действительному Шаблону или ATM PVC.

Router(config)#policy-map QUEUE_PEER2PEER
 Router(config-pmap)#class PEER2PEER
 Router(config-pmap-c)#bandwidth 768

Attaching Service-policy to Virtual Template

Router(config-subif)#int atm1/0
Router(config-subif)#no atm ilmi-keepalive
Router(config-subif)#pvc 1/150
Router(config-if-atm-vc)#encapsulation aal5mux ppp virtual-Template 3

Router(config)#interface Virtual-Template3
Router(config-if)#ip address negotiated
Router(config-if)#service-policy output QUEUE_PEER2PEER

Attaching Service-policy to ATM pvc 

Router(config)#int atm1/0
Router(config-subif)#no atm ilmi-keepalive
Router(config-subif)#pvc 1/150
Router(config-if-atm-vc)#service-policy output QUEUE_PEER2PEER

Примечание: при использовании комбинации Основанного на классе отмечания или Основанной на классе Охраны и Основанной на классе Организации очереди заказ операций - это:

  1. Команда обслуживания формировала на отметках интерфейса Virtual-Template или полицейских пакеты.

  2. Команда обслуживания на ATM PVC стоит в очереди пакеты.

Обратитесь к этому примеру:

policy-map MARK_PEER2PEER
  class PEER2PEER
   set dscp default
! 
 interface ATM0/0
 no ip address
 no atm ilmi-keepalive
 pvc 1/100
  encapsulation aal5mux ppp Virtual-Template1
  service-policy output QUEUE_PEER2PEER
!
interface Virtual-Template1 
ip address negotiate
service-policy output MARK_PEER2PEER

При управлении более ранним выпуском программного обеспечения Cisco IOS можно формировать на ATM VC с герметизацией MLPPPoA и применить основанное на организации очереди обслуживание к интерфейсу действительного шаблона. Для получения дополнительной информации относитесь для Соединения Фрагментации и Чередующий для Ретрансляции кадров и Виртуальных цепей ATM и Обзора Механизмов Эффективности Связи.

Выпуск 12.2 (4) T3 программного обеспечения Cisco IOS вводит распределенную версию этой особенности ряда Cisco 7500. Для получения дополнительной информации об этой особенности обратитесь к Распределенной Фрагментации Связи и Чередующий для ATM и Ретрансляции кадров.

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Соответствующая информация


Document ID: 10102