Технологии коммутируемого доступа в сеть : Виртуальная частная коммутируемая сеть (VPDN)

Простая виртуальная частная сеть с модемным доступом по протоколу L2TP Virtual Private Dialup Network (VPDN) для входящих и исходящих соединений по телефонной линии

5 апреля 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Содержание


Введение

Данный документ содержит пример конфигурации для туннельного протокола уровня 2 (L2TP) для входящих и исходящих звонков.

Примечание: Эта настройка не включает аутентификацию, авторизацию и учет (AAA).

Предварительные условия

Требования

Для этого документа отсутствуют особые требования.

Используемые компоненты

Сведения в этом документе основываются на Cisco Выпуск ПО IOS� 12.1.

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в этом документе, были запущены с чистой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд до их использования.

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Технические рекомендации Cisco. Условные обозначения.

Настройка

В этом разделе содержатся сведения о настройке функций, описанных в этом документе.

Примечание: Дополнительные сведения о командах, используемых в данном документе, можно получить с помощью средства поиска команд (только для зарегистрированных клиентов).

Схема сети

В этом документе использованы параметры данной сети:

/image/gif/paws/9556/basic_vpdn.gif

Конфигурации

Эти конфигурации используются в данном документе:

  • Удаленный маршрутизатор1:

    Номер "ISDN" (BRI 0) Loopback0: 17.17.17.1/32 Username: remote1@cisco.com: 6122

  • Маршрутизатор remote2:

    Loopback: 17.17.17.2/32 Имя пользователя: Номер "ISDN" remote2@cisco.com (BRI 0): 6121

  • Маршрутизатор LAC:

    Loopback: 18.18.18.1/32 Номер "ISDN" (E1 0): 8211 Последовательных интерфейсов (S0): 18.18.18.6/30

  • Маршрутизатор LNS:

    Loopback: 18.18.18.2/32 Последовательный интерфейс (S0): 18.18.18.5/30 Интерфейс Ethernet (E0): 10.200.20.24/24

  • Маршрутизатор local1:

    Loopback: 17.17.17.3/32 Интерфейс Ethernet (E0): 10.200.20.32/24

Маршрутизаторы remote1@cisco.com и remote2@cisco.com используют ISDN для доступа к Концентратору доступа L2TP (LAC). Встречно-параллельное последовательное соединение подключает LAC и L2TP Network Server (LNS) в этой настройке. Маршрутизатор local1 и LNS совместно используют то же Соединение Ethernet

Вот процесс:

  1. Внешний доступ L2TP: remote1@cisco.com клиент хочет связаться с маршрутизатором local1. Клиент генерирует вызов ISDN к LAC, который переводит туннель L2TP в рабочее состояние к LNS и затем Сеансу l2tp. LAC использует доменное имя для внедрения туннеля с LNS. LNS выполняет аутентификацию удаленных пользователей локально.

  2. Подключение к внешней службе L2TP: маршрутизатор local1 хочет связаться с remote2@cisco.com удаленным клиентом. LNS использует существующий туннель с LAC и создает новый Сеанс l2tp.

Примечание: Эти конфигурации являются усеченными для показа связанных сведений.

LAC
hostname LAC 
! 
! 
ip subnet-zero 
no ip domain-lookup 
! 
vpdn enable 
no vpdn logging 
vpdn search-order domain 

!--- VPDN tunnel authorization is based on the domain only.

! 
vpdn-group 1 
request-dialin 

!--- Enables the LAC to make requests to the LNS for dialin.

protocol l2tp 
domain cisco.com 
accept-dialout 

!--- Enables the LAC to accept requests from the LNS for dialout.

protocol l2tp 
dialer 1 

!--- Specifies the dialer used to dial out.

terminate-from hostname LNS 
initiate-to ip 18.18.18.2 
local name LAC 
l2tp tunnel password l2tptunnel 
source-ip 18.18.18.1 
! 
isdn switch-type primary-net5 
! 
! 
controller E1 0 
clock source line primary 
pri-group timeslots 1-31 
! 
interface Loopback0 
ip address 18.18.18.1 255.255.255.255 
! 
interface Ethernet0 
ip address 10.200.20.34 255.255.255.0 
no ip route-cache 
no ip mroute-cache 
no cdp enable 
! 
! 
interface Serial0 
description -- Connection to the LNS 
ip address 18.18.18.6 255.255.255.252 
no fair-queue 
clockrate 64000 
no cdp enable 
! 
interface Serial0:15 
no ip address 
encapsulation ppp 
dialer rotary-group 1 
isdn switch-type primary-net5 
no cdp enable 
ppp authentication chap 
ppp chap hostname LAC 
! 
interface Dialer1 
ip unnumbered Loopback0 
encapsulation ppp 
dialer in-band 
dialer aaa 

!--- L2TP dialout functionality requires this command even if you do not use AAA.
  
dialer-group 1 
no cdp enable 
ppp authentication chap 
ppp chap hostname LAC 
ppp chap password 7 1511021F0725 
! 
no ip http server 
ip classless 
ip route 18.18.18.2 255.255.255.255 18.18.18.5 
! 
dialer-list 1 protocol ip permit 
no cdp run

LNS
hostname LNS
!
vpdn enable
vpdn-group 1 
accept-dialin

!--- Enables the LNS to accept request from the LAC for dialin.
 
protocol l2tp 
virtual-template 1 

!--- For each user, a virtual-access is cloned from this virtual-template.
 
request-dialout 

!--- Enables the LNS to request the LAC for dialout.
 
protocol l2tp 
pool-member 1 

!--- Specifies the dialer profile to be used to dial out.
 
terminate-from hostname LAC 
initiate-to ip 18.18.18.1 
local name LNS 
l2tp tunnel password l2tptunnel 
source-ip 18.18.18.2 
! 
! 
interface Loopback0 
ip address 18.18.18.2 255.255.255.255 
! 
interface Ethernet0 
ip address 10.200.20.24 255.255.255.0 
no ip route-cache 
no ip mroute-cache 
! 
interface Virtual-Template1 
ip unnumbered Loopback0 
no peer default ip address 
ppp chap hostname LNS 
! 
interface Serial0 
description -- Connection to the LAC 
ip address 18.18.18.5 255.255.255.252 
no ip route-cache 
no ip mroute-cache 
! 
interface Dialer1 

!--- For each user, a dialer profile is configured.
 
ip unnumbered Loopback0 
encapsulation ppp 
dialer pool 1 

!--- "dialer pool 1"  must match "pool-member 1" in the VPDN-group.
 
dialer remote-name remote1@cisco.com 
dialer string 6122 

!--- ISDN number that the LAC uses to dialout the remote client remote1@cisco.com.

dialer vpdn 

!--- Enables the dialer profile to use L2TP dialout, and so place a VPDN call.
 
dialer-group 1 
ppp authentication chap callin 
ppp chap hostname LNS 
! 
interface Dialer2 
ip unnumbered Loopback0 
encapsulation ppp 
dialer pool 1 
dialer remote-name remote2@cisco.com 
dialer string 6121 
dialer vpdn 
dialer-group 1 
no cdp enable 
ppp authentication chap callin 
ppp chap hostname LNS 
! 
no ip http server 
ip classless 
ip route 10.200.16.26 255.255.255.255 10.200.20.1 
ip route 17.17.17.1 255.255.255.255 Dialer1 
ip route 17.17.17.2 255.255.255.255 Dialer2 
ip route 17.17.17.3 255.255.255.255 10.200.20.32 
ip route 18.18.18.1 255.255.255.255 18.18.18.6 
! 
dialer-list 1 protocol ip permit 
no cdp run

Проверка.

В данном разделе содержатся сведения о проверке работы конфигурации.

Некоторые команды show поддерживаются Средством интерпретации выходных данных(только зарегистрированные клиенты), которое позволяет просматривать аналитику выходных данных команды show.

  • show vpdn – отображает информацию об активном туннеле с протоколом переадресации 2 уровня (L2F) и идентификаторы сообщений в Виртуальной Закрытой модемной Сети (VPDN).

    LAC#show debug 
    Dial on demand:   
      Dial on demand events debugging is on 
    VPN:   
      L2X protocol events debugging is on   
      VPDN events debugging is on 
    PPP:   
      PPP authentication debugging is on   
      PPP protocol negotiation debugging is on 
    ISDN:   
      ISDN events debugging is on 
      
      ISDN events debug DSLs. (On/Off/No DSL:1/0/-) 
       DSL 0 --> 1 
       1 - 
    
    LNS#show debug 
    Dial on demand:   
      Dial on demand events debugging is on 
    VPN:   
      L2X protocol events debugging is on   
      VPDN events debugging is on 
    PPP:   
      PPP authentication debugging is on   
      PPP protocol negotiation debugging is on 
    VTEMPLATE:   
      Virtual Template debugging is on

Проверка

Входящий звонок

remote1@cisco.com маршрутизатор инициирует вызов к маршрутизатору local1.

LAC# 

Вызов ISDN поступает на LAC.

Sep 29 02:25:42.923: ISDN Se0:15: Incoming call id = 0x011B, dsl 0 
Sep 29 02:25:42.927: Negotiated CCB->int_id 0 B-chan 0, req->int_id 0, B-chan 18 
Sep 29 02:25:42.931: CCPRI_ReleaseChan CCB->B_Chan zero 
Sep 29 02:25:42.939: ISDN Se0:15: received CALL_INCOMING call_id 0x11B 
Sep 29 02:25:42.939: ISDN Se0:15: CALL_INCOMING: call type is DATA , bchan = 17 
Sep 29 02:25:42.943: ISDN Se0:15: Event: Received a DATA call from 6122 on B17
 at 64 Kb/s 
Sep 29 02:25:42.947: ISDN Se0:15: RM returned call_type 0 resource type 0      
Sep 29 02:25:42.959: ISDN Se0:15: isdn_send_connect(): msg 74, call id 0x11B,
 ces 1 bchan 17, call type DATA 
Sep 29 02:25:43.031: %LINK-3-UPDOWN: Interface Serial0:17, changed state to up 
Sep 29 02:25:43.059: Se0:17 PPP: Treating connection as a callin 
Sep 29 02:25:43.063: Se0:17 PPP: Phase is ESTABLISHING, Passive Open 
Sep 29 02:25:43.067: Se0:17 LCP: State is Listen 
Sep 29 02:25:43.127: ISDN Se0:15: received CALL_PROGRESSing call_id 0x11B      
Sep 29 02:25:43.199: Se0:17 LCP: I CONFREQ [Listen] id 125 len 10 
Sep 29 02:25:43.203: Se0:17 LCP: MagicNumber 0xEB818699 (0x0506EB818699) 
Sep 29 02:25:43.207: Se0:17 LCP: O CONFREQ [Listen] id 7 len 15 
Sep 29 02:25:43.211: Se0:17 LCP: AuthProto CHAP (0x0305C22305) 
Sep 29 02:25:43.215: Se0:17 LCP: MagicNumber 0x6BDE50CC (0x05066BDE50CC) 
Sep 29 02:25:43.219: Se0:17 LCP: O CONFACK [Listen] id 125 len 10 
Sep 29 02:25:43.223: Se0:17 LCP: MagicNumber 0xEB818699 (0x0506EB818699) 
Sep 29 02:25:43.247: Se0:17 LCP: I CONFACK [ACKsent] id 7 len 15 
Sep 29 02:25:43.251: Se0:17 LCP: AuthProto CHAP (0x0305C22305) 
Sep 29 02:25:43.255: Se0:17 LCP: MagicNumber 0x6BDE50CC (0x05066BDE50CC) 
Sep 29 02:25:43.259: Se0:17 LCP: State is Open 
Sep 29 02:25:43.259: Se0:17 PPP: Phase is AUTHENTICATING, by this end 

Концентратор доступа по протоколу L2TP отправляет клиенту сообщение CHAP Сhallenge.

Sep 29 02:25:43.263: Se0:17 CHAP: Using alternate hostname LAC 
Sep 29 02:25:43.267: Se0:17 CHAP: O CHALLENGE id 7 len 24 from "LAC" 

LAC получает ответ CHAP, но не подтверждает подлинность пользователя. LNS выполняет аутентификацию.

Sep 29 02:25:43.295: Se0:17 CHAP: I RESPONSE id 7 len 38 from "remote1@cisco.com"    
Sep 29 02:25:43.303: Se0:17 PPP: Phase is FORWARDING 
Sep 29 02:25:43.303: Se0:17 VPDN: Got DNIS string 211

LAC проверяет, существует ли доменный "cisco.com", и затем собирает информацию, должен был перевести туннель в рабочее состояние с LNS.

Sep 29 02:25:43.307: Se0:17 VPDN: Looking for tunnel -- cisco.com -- 
Sep 29 02:25:43.347: Se0:17 VPDN/LAC/1: Got tunnel info for cisco.com 
Sep 29 02:25:43.351: Se0:17 VPDN/LAC/1: LAC LAC 
Sep 29 02:25:43.351: Se0:17 VPDN/LAC/1: source-ip 18.18.18.1 
Sep 29 02:25:43.355: Se0:17 VPDN/LAC/1: l2tp-busy-disconnect yes 
Sep 29 02:25:43.359: Se0:17 VPDN/LAC/1: l2tp-tunnel-password xxxxxx 
Sep 29 02:25:43.359: Se0:17 VPDN/LAC/1: IP 18.18.18.2 
Sep 29 02:25:43.371: Se0:17 VPDN/1: curlvl 1 Address 0: 18.18.18.2, priority 1 
Sep 29 02:25:43.375: Se0:17 VPDN/1: Select non-active address 18.18.18.2, priority 1 
Sep 29 02:25:43.379: Tnl 45029 L2TP: SM State idle 

LAC переводит туннель в рабочее состояние с LNS.

Sep 29 02:25:43.383: Tnl 45029 L2TP: O SCCRQ 
Sep 29 02:25:43.391: Tnl 45029 L2TP: Tunnel state change from idle to 
   wait-ctl-reply    
Sep 29 02:25:43.395: Tnl 45029 L2TP: SM State wait-ctl-reply 
Sep 29 02:25:43.399: Se0:17 VPDN: Find LNS process created 
Sep 29 02:25:43.403: Se0:17 VPDN: Forward to address 18.18.18.2 
Sep 29 02:25:43.403: Se0:17 VPDN: Pending 
Sep 29 02:25:43.411: Se0:17 VPDN: Process created 
Sep 29 02:25:43.463: Tnl 45029 L2TP: I SCCRP from LNS 
Sep 29 02:25:43.467: Tnl 45029 L2TP: Got a challenge from remote peer, LNS 
Sep 29 02:25:43.471: Tnl 45029 L2TP: Got a response from remote peer, LNS 
Sep 29 02:25:43.475: Tnl 45029 L2TP: Tunnel Authentication success 
Sep 29 02:25:43.479: Tnl 45029 L2TP: Tunnel state change from wait-ctl-reply 
   to established 
Sep 29 02:25:43.483: Tnl 45029 L2TP: O SCCCN to LNS tnlid 11407 
Sep 29 02:25:43.487: Tnl 45029 L2TP: SM State established 
Sep 29 02:25:43.495: Se0:17 VPDN: Forwarding... 
Sep 29 02:25:43.499: Se0:17 DDR: Authenticated host remote1@cisco.com with no 
   matching dialer map 
Sep 29 02:25:43.503: Se0:17 VPDN: Bind interface direction=1 
Sep 29 02:25:43.507: Tnl/Cl 45029/291 L2TP: Session FS enabled 
Sep 29 02:25:43.511: Tnl/Cl 45029/291 L2TP: Session state change from idle to 
   wait-for-tunnel 
Sep 29 02:25:43.515: Se0:17 Tnl/Cl 45029/291 L2TP: Create session 
Sep 29 02:25:43.519: Tnl 45029 L2TP: SM State established 

LAC переводит сеанс в рабочее состояние для пользователя remote1@cisco.com.

Sep 29 02:25:43.523: Se0:17 Tnl/Cl 45029/291 L2TP: O ICRQ to LNS 11407/0 
Sep 29 02:25:43.531: Se0:17 Tnl/Cl 45029/291 L2TP: Session state change from 
   wait-for-tunnel to wait-reply 
Sep 29 02:25:43.535: Se0:17 VPDN: remote1@cisco.com is forwarded 
Sep 29 02:25:43.635: Se0:17 Tnl/Cl 45029/291 L2TP: O ICCN to LNS 11407/303 
Sep 29 02:25:43.639: Se0:17 Tnl/Cl 45029/291 L2TP: Session state change from 
   wait-reply to established 
Sep 29 02:25:44.535: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0:17, 
   changed state to up 
Sep 29 02:25:49.055: %ISDN-6-CONNECT: Interface Serial0:17 is now connected to 
6122 remote1@cisco.com 
   
LAC#show vpdn 

L2TP Tunnel and Session Information Total tunnels 1 sessions 1 

LocID RemID Remote Name State Remote Address Port Sessions 
45029 11407 LNS est 18.18.18.2 1701 1 

LocID RemID TunID Intf Username State Last Chg Fastswitch 
291 303 45029 Se0:17 remote1@cisco.com est 00:00:14 enabled 

% No active L2F tunnels

Телефонное подключение к внешнему объекту

Маршрутизатор local1 инициирует вызов к remote2@cisco.com маршрутизатору.

LAC# 

LAC получает запрос от LNS на создание нового сеанса удаленного доступа.

Sep 29 02:26:19.479: Tnl 45029 L2TP: I OCRQ from LNS tnl 11407 
Sep 29 02:26:19.483: Tnl/Cl 45029/292 L2TP: Session FS enabled 
Sep 29 02:26:19.487: Tnl/Cl 45029/292 L2TP: New session created 
Sep 29 02:26:19.491: 1D4C: Same state, 0 
Sep 29 02:26:19.495: DSES 1D4C: Session create 
Sep 29 02:26:19.499: L2TP: Send OCRP 
Sep 29 02:26:19.503: Tnl/Cl 45029/292 L2TP: Session state change from 
idle to wait-cs-answer 

LAC использует ISDN для вызова количества 6121.

Sep 29 02:26:19.511: DSES 0x1D4C: Building dialer map 
Sep 29 02:26:19.511: Dialout 0x1D4C: Next hop name is 6121 
Sep 29 02:26:19.515: Se0:15 DDR: rotor dialout [priority] 
Sep 29 02:26:19.519: Se0:15 DDR: Dialing cause dialer session 0x1D4C 
Sep 29 02:26:19.523: Se0:15 DDR: Attempting to dial 6121 
Sep 29 02:26:19.523: ISDN Se0:15: Outgoing call id = 0x8055, dsl 0 
Sep 29 02:26:19.527: ISDN Se0:15: Event: Call to 6121 at 64 Kb/s 
Sep 29 02:26:19.531: ISDN Se0:15: process_pri_call(): call id 0x8055, 
   number 6121, speed 64, call type DATA 
Sep 29 02:26:19.539: building outgoing channel id for call nfas_int is 0 len is 0 
Sep 29 02:26:19.623: ISDN Se0:15: received CALL_ACCEPT call_id 0x8055 
Sep 29 02:26:19.623: ISDN Se0:15: PRI Event: CALL_ACCEPT, bchan = 30, 
   call type = DATA 
Sep 29 02:26:20.043: ISDN Se0:15: received CALL_CONNECT call_id 0x8055 
Sep 29 02:26:20.115: %LINK-3-UPDOWN: Interface Serial0:30, changed state to up 
Sep 29 02:26:20.147: Di1: Session free, 1D4C 
Sep 29 02:26:20.151: : 0 packets unqueued and discarded 
Sep 29 02:26:20.155: Se0:30 VPDN: Bind interface direction=1 
Sep 29 02:26:20.159: Se0:30 Tnl/Cl 45029/292 L2TP: Session state change 
   from wait-cs-answer to established 
Sep 29 02:26:20.163: L2TP: Send OCCN 

Концентратор LAC ограничивает сеанс ISDN se0:30 сеансом VPDN.

Sep 29 02:26:20.167: Se0:30 VPDN: bound to vpdn session 
Sep 29 02:26:20.175: ISDN Se0:15: received CALL_PROGRESSing call_id 0x8055 
Sep 29 02:26:26.143: %ISDN-6-CONNECT: Interface Serial0:30 is now connected to 6121
LAC# 
LAC#show vpdn 

L2TP Tunnel and Session Information Total tunnels 1 sessions 2 

LocID RemID Remote Name State Remote Address Port Sessions 
45029 11407 LNS est 18.18.18.2 1701 2 

LocID RemID TunID Intf Username State Last Chg Fastswitch 
291 303 45029 Se0:17 remote1@cisco.com est 00:00:57 enabled 
292 304 45029 Se0:30 est 00:00:20 enabled 

% No active L2F tunnels 
LAC#

Устранение неполадок

В этом разделе описывается процесс устранения неполадок конфигурации.

Команды для устранения неполадок

Некоторые команды show поддерживаются Средством интерпретации выходных данных(только зарегистрированные клиенты), которое позволяет просматривать аналитику выходных данных команды show.

Примечание: Прежде чем применять команды отладки, ознакомьтесь с разделом "Важные сведения о командах отладки".

  • debug dialer events — вывод отладочной информации о пакетах, полученных в интерфейсе номеронабирателя.

  • debug vpdn l2x-events – отображает сообщения о событиях, свидетельствующих о нормальном ходе установления или закрытия туннеля.

  • debug vpdn l2x-packets - вывод всех пакетов протокола, участвовавших в обмене. Эта команда может привести к большому числу сообщений отладки. Используйте эту команду только на шасси отладки с одиночным активным сеансом.

  • debug vpdn l2x-error — отображают ошибки, которые предотвращают установление туннеля или ошибок, которые заставляют установку туннеля быть закрытой.

  • "debug ppp negotiation" - вызов команды "debug ppp" для отображения передаваемых пакетов PPP при согласовании параметров во время запуска протокола PPP.

  • debug ppp authenticaion — заставляет команду debug ppp отображать сообщения протокола аутентификации. Сообщения включают обмены пакетами Протокола аутентификации по квитированию вызова (CHAP) и обмены Протокола аутентификации пароля (PAP).

  • debug isdn event — отображают события Integrated Services Digital Network (ISDN), которые происходят на стороне пользователя (на маршрутизаторе) интерфейса ISDN.

  • "debug isdn q931" - отображение сведений об установлении соединения и освобождении канала в сети ISDN (третий уровень модели OSI) между локальным маршрутизатором (на стороне пользователя) и сетью.

  • {\f3 debug vtemplate}–{\f3 выводит информацию о клонировании интерфейса виртуального доступа с момента его клонирования из виртуального шаблона до момента отключения при завершении вызова.}

Отладка на LNS

Входящий звонок

remote1@cisco.com маршрутизатор инициирует вызов к маршрутизатору local1.

LNS получает запрос от LAC для внедрения туннеля.

Sep 29 02:25:44.531: L2TP: I SCCRQ from LAC tnl 45029 
Sep 29 02:25:44.539: Tnl 11407 L2TP: Got a challenge in SCCRQ, LAC 
Sep 29 02:25:44.543: Tnl 11407 L2TP: New tunnel created for remote LAC, 
   address 18.18.18.1 
Sep 29 02:25:44.547: Tnl 11407 L2TP: O SCCRP to LAC tnlid 45029 
Sep 29 02:25:44.555: Tnl 11407 L2TP: Tunnel state change from idle to 
   wait-ctl-reply    
Sep 29 02:25:44.623: Tnl 11407 L2TP: I SCCCN from LAC tnl 45029 
Sep 29 02:25:44.627: Tnl 11407 L2TP: Got a Challenge Response in SCCCN from LAC 
Sep 29 02:25:44.631: Tnl 11407 L2TP: Tunnel Authentication success 
Sep 29 02:25:44.635: Tnl 11407 L2TP: Tunnel state change from wait-ctl-reply 
   to established 
Sep 29 02:25:44.639: Tnl 11407 L2TP: SM State established

LNS получает запрос от LAC на увеличение сессии.

Sep 29 02:25:44.667: Tnl 11407 L2TP: I ICRQ from LAC tnl 45029 
Sep 29 02:25:44.671: Tnl/Cl 11407/303 L2TP: Session FS enabled 
Sep 29 02:25:44.679: Tnl/Cl 11407/303 L2TP: Session state change from idle 
   to wait-connect 
Sep 29 02:25:44.679: Tnl/Cl 11407/303 L2TP: New session created 
Sep 29 02:25:44.683: Tnl/Cl 11407/303 L2TP: O ICRP to LAC 45029/291 
Sep 29 02:25:44.791: Tnl/Cl 11407/303 L2TP: I ICCN from LAC tnl 45029, cl 291    
Sep 29 02:25:44.799: Tnl/Cl 11407/303 L2TP: Session state change from wait-connect 
   to established 

LNS клонирует виртуальный доступ для пользователя remote1@cisco.com.

Sep 29 02:25:44.803: Vt1 VTEMPLATE: Unable to create and clone vaccess 
Sep 29 02:25:44.803: Vi2 VTEMPLATE: Reuse Vi2, recycle queue size 1 
Sep 29 02:25:44.807: Vi2 VTEMPLATE: Hardware address 0060.4780.ac23 
Sep 29 02:25:44.807: Vi2 VPDN: Virtual interface created for remote1@cisco.com    
Sep 29 02:25:44.811: Vi2 PPP: Phase is DOWN, Setup 
Sep 29 02:25:44.815: Vi2 VPDN: Clone from Vtemplate 1 filterPPP=0 blocking 
Sep 29 02:25:44.819: Vi2 VTEMPLATE: Has a new cloneblk vtemplate, 
   now it has vtemplate 
Sep 29 02:25:44.827: Vi2 VTEMPLATE: ********** CLONE VACCESS2 **************    
Sep 29 02:25:44.827: Vi2 VTEMPLATE: Clone from Virtual-Template1 interface 
Virtual-Access2    
encapsulation ppp 
ip unnumbered loopback 0 
ppp chap hostname LNS 
ppp authentication chap 
end 

Sep 29 02:25:46.975: %LINK-3-UPDOWN: Interface Virtual-Access2, 
   changed state to up
Sep 29 02:25:46.995: Vi2 PPP: Using set call direction 
Sep 29 02:25:46.999: Vi2 PPP: Treating connection as a callin 
Sep 29 02:25:46.999: Vi2 PPP: Phase is ESTABLISHING, Passive Open 
Sep 29 02:25:47.003: Vi2 LCP: State is Listen 
Sep 29 02:25:47.007: Vi2 VPDN: Bind interface direction=2 
Sep 29 02:25:47.007: Vi2 LCP: I FORCED CONFREQ len 11 
Sep 29 02:25:47.011: Vi2 LCP: AuthProto CHAP (0x0305C22305) 
Sep 29 02:25:47.015: Vi2 LCP: MagicNumber 0x6BDE50CC (0x05066BDE50CC)

LNS получает уровень LCP, о котором LAC выполнил согласование с remote1@cisco.com клиентом. Поэтому LNS не пересматривает LCP с клиентом.

Sep 29 02:25:47.019: Vi2 VPDN: PPP LCP accepted rcv CONFACK 
Sep 29 02:25:47.019: Vi2 VPDN: PPP LCP accepted sent CONFACK 
Sep 29 02:25:47.023: Vi2 PPP: Phase is AUTHENTICATING, by this end 
Sep 29 02:25:47.023: Vi2 CHAP: Using alternate hostname LNS 
Sep 29 02:25:47.027: Vi2 CHAP: O CHALLENGE id 8 len 24 from "LNS"    
Sep 29 02:25:47.039: Vi2 CHAP: I RESPONSE id 7 len 38 from "remote1@cisco.com"    
Sep 29 02:25:47.051: Vi2 CHAP: O SUCCESS id 7 len 4 
Sep 29 02:25:47.055: Vi2 PPP: Phase is UP 
Sep 29 02:25:47.059: Vi2 IPCP: O CONFREQ [Not negotiated] id 1 len 10 
Sep 29 02:25:47.063: Vi2 IPCP: Address 18.18.18.2 (0x030612121202) 
Sep 29 02:25:47.111: Vi2 IPCP: I CONFREQ [REQsent] id 110 len 10 
Sep 29 02:25:47.115: Vi2 IPCP: Address 17.17.17.1 (0x030611111101) 
Sep 29 02:25:47.119: Vi2 IPCP: O CONFACK [REQsent] id 110 len 10 
Sep 29 02:25:47.123: Vi2 IPCP: Address 17.17.17.1 (0x030611111101) 
Sep 29 02:25:47.127: Vi2 IPCP: I CONFACK [ACKsent] id 1 len 10 
Sep 29 02:25:47.131: Vi2 IPCP: Address 18.18.18.2 (0x030612121202) 
Sep 29 02:25:47.135: Vi2 IPCP: State is Open 
Sep 29 02:25:47.143: Vi2 IPCP: Install route to 17.17.17.1 
Sep 29 02:25:48.131: %LINEPROTO-5-UPDOWN: Line protocol on 
Interface Virtual-Access2, changed state to up 

LNS#show vpdn 

L2TP Tunnel and Session Information Total tunnels 1 sessions 1 

LocID RemID Remote Name State Remote Address Port Sessions 
11407 45029 LAC est 18.18.18.1 1701 1 

LocID RemID TunID Intf Username State Last Chg Fastswitch 
303 291 11407 Vi2 remote1@cisco.com est 00:00:22 enabled 

% No active L2F tunnels

Телефонное подключение к внешнему объекту

Маршрутизатор local1 инициирует вызов к remote2@cisco.com маршрутизатору.

LNS# 
Sep 29 02:26:20.531: Vi1 VTEMPLATE: Reuse Vi1, recycle queue size 0 
Sep 29 02:26:20.531: Vi1 VTEMPLATE: Hardware address 0060.4780.ac23 
Sep 29 02:26:20.535: Vi1 PPP: Phase is DOWN, Setup 
Sep 29 02:26:20.543: Vi1 VTEMPLATE: Has a new cloneblk dialer, now it has dialer    
Sep 29 02:26:20.547: Vi1 DDR: Dialing cause ip (s=10.200.20.32, d=17.17.17.2)    
Sep 29 02:26:20.551: Vi1 DDR: Attempting to dial 6121 
Sep 29 02:26:20.555: Tnl/Cl 11407/304 L2TP: Session FS enabled 
Sep 29 02:26:20.559: Tnl/Cl 11407/304 L2TP: Session state change from idle 
   to wait-for-tunnel 
Sep 29 02:26:20.563: Tnl/Cl 11407/304 L2TP: Create dialout session 
Sep 29 02:26:20.567: Tnl 11407 L2TP: SM State established 

LNS отправляет запрос к LAC для подключения к внешней службе.

Sep 29 02:26:20.571: L2TP: O OCRQ 
Sep 29 02:26:20.575: Vi1 Tnl/Cl 11407/304 L2TP: Session state change from 
   wait-for-tunnel to wait-reply 
Sep 29 02:26:20.579: Vi1 VPDN: Bind interface direction=2 
Sep 29 02:26:20.635: Vi1 Tnl/Cl 11407/304 L2TP: I OCRP from LAC tnl 45029, cl 0 
Sep 29 02:26:20.639: Vi1 Tnl/Cl 11407/304 L2TP: Session state change from 
   wait-reply to wait-connect 
Sep 29 02:26:21.299: Vi1 Tnl/Cl 11407/304 L2TP: I OCCN from LAC tnl 45029, cl 292 
Sep 29 02:26:21.303: Vi1 Tnl/Cl 11407/304 L2TP: Session state change from 
   wait-connect to established 
Sep 29 02:26:21.307: Vi1 VPDN: Connection is up, start LCP negotiation now 
Sep 29 02:26:21.315: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to up
Sep 29 02:26:21.335: Vi1 DDR: Dialer statechange to up 

Виртуальный доступ 1 связан представить номеронабирателя 2, где расположена конфигурация для remote2@cisco.com.

Sep 29 02:26:21.335: %DIALER-6-BIND: Interface Vi1 bound to profile Di2 
Sep 29 02:26:21.339: Vi1 DDR: Dialer call has been placed 

Фаза PPP запускается между LNS и remote2@cisco.com клиентом.

Sep 29 02:26:21.343: Vi1 PPP: Treating connection as a callout 
Sep 29 02:26:21.343: Vi1 PPP: Phase is ESTABLISHING, Active Open 
Sep 29 02:26:21.347: Vi1 PPP: No remote authentication for call-out 
Sep 29 02:26:21.351: Vi1 LCP: O CONFREQ [Closed] id 1 len 10 
Sep 29 02:26:21.355: Vi1 LCP: MagicNumber 0x6F87121F (0x05066F87121F) 
Sep 29 02:26:21.427: Vi1 LCP: I CONFREQ [REQsent] id 79 len 39 
Sep 29 02:26:21.431: Vi1 LCP: AuthProto CHAP (0x0305C22305) 
Sep 29 02:26:21.435: Vi1 LCP: MagicNumber 0x059935DB (0x0506059935DB) 
Sep 29 02:26:21.435: Vi1 LCP: MRRU 1524 (0x110405F4) 
Sep 29 02:26:21.439: Vi1 LCP: EndpointDisc 1 Local 
Sep 29 02:26:21.443: Vi1 LCP: (0x13140172656D6F74653240636973636F) 
Sep 29 02:26:21.447: Vi1 LCP: (0x2E636F6D) 
Sep 29 02:26:21.451: Vi1 LCP: O CONFREJ [REQsent] id 79 len 28 
Sep 29 02:26:21.455: Vi1 LCP: MRRU 1524 (0x110405F4) 
Sep 29 02:26:21.455: Vi1 LCP: EndpointDisc 1 Local 
Sep 29 02:26:21.459: Vi1 LCP: (0x13140172656D6F74653240636973636F) 
Sep 29 02:26:21.463: Vi1 LCP: (0x2E636F6D) 
Sep 29 02:26:21.467: Vi1 LCP: I CONFACK [REQsent] id 1 len 10 
Sep 29 02:26:21.471: Vi1 LCP: MagicNumber 0x6F87121F (0x05066F87121F) 
Sep 29 02:26:21.559: Vi1 LCP: I CONFREQ [ACKrcvd] id 80 len 15 
Sep 29 02:26:21.563: Vi1 LCP: AuthProto CHAP (0x0305C22305) 
Sep 29 02:26:21.567: Vi1 LCP: MagicNumber 0x059935DB (0x0506059935DB) 
Sep 29 02:26:21.571: Vi1 LCP: O CONFACK [ACKrcvd] id 80 len 15 
Sep 29 02:26:21.575: Vi1 LCP: AuthProto CHAP (0x0305C22305) 
Sep 29 02:26:21.579: Vi1 LCP: MagicNumber 0x059935DB (0x0506059935DB) 
Sep 29 02:26:21.583: Vi1 LCP: State is Open 
Sep 29 02:26:21.583: Vi1 PPP: Phase is AUTHENTICATING, by the peer 
Sep 29 02:26:21.647: Vi1 CHAP: I CHALLENGE id 8 len 38 from "remote2@cisco.com"    
Sep 29 02:26:21.651: Vi1 CHAP: Using alternate hostname LNS 
Sep 29 02:26:21.655: Vi1 CHAP: O RESPONSE id 8 len 24 from "LNS" 
Sep 29 02:26:21.699: Vi1 CHAP: I SUCCESS id 8 len 4 
Sep 29 02:26:21.703: Vi1 PPP: Phase is UP 
Sep 29 02:26:21.707: Vi1 IPCP: O CONFREQ [Closed] id 1 len 10 
Sep 29 02:26:21.711: Vi1 IPCP: Address 18.18.18.2 (0x030612121202) 
Sep 29 02:26:21.715: Vi1 IPCP: I CONFREQ [REQsent] id 40 len 10 
Sep 29 02:26:21.719: Vi1 IPCP: Address 17.17.17.2 (0x030611111102) 
Sep 29 02:26:21.723: Vi1 IPCP: O CONFACK [REQsent] id 40 len 10 
Sep 29 02:26:21.727: Vi1 IPCP: Address 17.17.17.2 (0x030611111102) 
Sep 29 02:26:21.775: Vi1 IPCP: I CONFACK [ACKsent] id 1 len 10 
Sep 29 02:26:21.779: Vi1 IPCP: Address 18.18.18.2 (0x030612121202) 
Sep 29 02:26:21.783: Vi1 IPCP: State is Open 
Sep 29 02:26:21.791: Vi1 DDR: dialer protocol up 
Sep 29 02:26:21.795: Di2 IPCP: Install route to 17.17.17.2 
Sep 29 02:26:22.703: %LINEPROTO-5-UPDOWN: Line protocol on 
Interface Virtual-Access1, changed state to up 

LNS#show vpdn 

L2TP Tunnel and Session Information Total tunnels 1 sessions 2 

LocID RemID Remote Name State Remote Address Port Sessions 
11407 45029 LAC est 18.18.18.1 1701 2 

LocID RemID TunID Intf Username State Last Chg Fastswitch 
304 292 11407 Vi1 est 00:00:16 enabled 
303 291 11407 Vi2 remote1@cisco.com est 00:00:52 enabled 

% No active L2F tunnels

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения


Document ID: 9556