Глобальная сеть (WAN) : Протокол PPP

Множественные многозвенные ветви между маршрутизаторами

5 апреля 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Содержание


Введение

Этот документ содержит пример конфигурации для создания многоканальных соединений между маршрутизаторами. Чтобы иметь несколько многоканальных линий между двумя маршрутизаторами, необходимо настроить другие проверяемые имена пользователей для каждой связки (bundle).

Предварительные условия

Требования

Для этого документа отсутствуют особые требования.

Используемые компоненты

Сведения в этом документе основываются на Cisco Выпуск ПО IOS� 12.0 (7) T.

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в этом документе, были запущены с чистой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд до их использования.

Условные обозначения

Дополнительные сведения об условных обозначениях в документах см. в Условные обозначения технических терминов Cisco.

Общие сведения

Созданная нами примерная конфигурация обладает следующими свойствами:

  • Это использует многоканальный интерфейс с одним интерфейсом физического члена под ним.

  • Это использует интерфейс BRI в качестве резервной копии для многоканального интерфейса. Данный интерфейс BRI обладает возможностями передачи по нескольким каналам и всеми остальными характеристиками основного многоканального интерфейса.

  • При коммутации от резервного интерфейса до основного интерфейса мы используем два многоканальных соединения, которые независимы друг от друга. Один из них от многоканального интерфейса, и каждый от BRI. По умолчанию многоканальное соединение было определено проверенным именем пользователя. Однако это создает проблемы при коммутации от резервной копии (BRI) к основному (многоканальному) интерфейсу. Этот пример конфигурации показывает вам, как обойти эту проблему.

Настройка

В этом разделе содержатся сведения о настройке функций, описанных в этом документе.

Примечание: Дополнительные сведения о командах, используемых в данном документе, можно получить с помощью средства поиска команд (только для зарегистрированных клиентов).

Схема сети

В этом документе использованы параметры данной сети:

/image/gif/paws/9500/multilink_bundles.gif

Конфигурации

Эти конфигурации используются в данном документе:

  • Маршрутизатор 3

  • Маршрутизатор 2

Маршрутизатор 3
Router3#show running-config 
!
version 12.0 
!
hostname Router3
!
!
username MultilinkRouter2 password 0 cisco
username Router2BRI password 0 cisco

!--- The username must match the one in the ppp chap hostname command on the remote router

! 
!
isdn switch-type basic-net3 
! 
multilink bundle-name authenticated 

!--- to differentiate bundles based on authenticated usernames

!
interface Multilink1
ip address 192.168.19.6 255.255.255.0 
no cdp enable
ppp authentication chap
ppp chap hostname MultilinkRouter3 

!--- alternate CHAP hostname

ppp chap password 7 121A0C041104
ppp multilink
multilink-group 1
! 
interface Serial1
no ip address
no ip directed-broadcast
encapsulation ppp
no fair-queue
ppp multilink
multilink-group 1
!
interface BRI0
no ip address
no ip directed-broadcast
encapsulation ppp
no ip route-cache
no ip mroute-cache
dialer rotary-group 1
isdn switch-type basic-net3
ppp authentication chap
ppp multilink
!
interface Dialer1
ip address 192.168.20.1 255.255.255.0
no ip directed-broadcast
encapsulation ppp
dialer in-band
dialer idle-timeout 30
dialer map ip 10.0.0.0 name Router2 broadcast 6084
dialer map ip 192.168.20.2 name Router2 broadcast 6084
dialer load-threshold 1 either
dialer watch-group 1
dialer-group 1
ppp authentication chap
ppp chap hostname Router3BRI 

!--- alternate CHAP hostname

ppp chap password 7 094F471A1A0A
ppp multilink
!
router eigrp 1
network 10.0.0.0
network 192.168.19.0
network 192.168.20.0
no auto-summary
eigrp log-neighbor-changes
!
ip classless
no ip http server
! 
access-list 150 deny eigrp any any
access-list 150 deny udp any any
access-list 150 permit ip any any
dialer watch-list 1 ip 10.0.0.0 255.0.0.0
dialer-list 1 protocol ip list 150

!
line con 0
exec-timeout 0 0
transport input none
line aux 0
line vty 0 4
login
!
end

Маршрутизатор 2
Router2#show running-config 
!
version 12.0 
!
hostname Router2
!
!
username MultilinkRouter3 password 0 cisco
username Router3BRI password 0 cisco

!--- The username must match the one in the ppp chap hostname command on the remote router

!
isdn switch-type basic-net3 
!

multilink bundle-name authenticated
!
interface Multilink1
ip address 192.168.19.5 255.255.255.0 
no cdp enable
ppp authentication chap
ppp chap hostname MultilinkRouter2
ppp chap password 7 104D000A0618 

!--- alternate CHAP hostname

ppp multilink
multilink-group 1
! 
interface Serial1
no ip address
no ip directed-broadcast
encapsulation ppp
no fair-queue
clockrate 2000000
ppp multilink
multilink-group 1
!
interface BRI0
no ip address
no ip directed-broadcast
encapsulation ppp
no ip route-cache
no ip mroute-cache
dialer pool-member 1
isdn switch-type basic-net3
ppp authentication chap
ppp multilink
!
interface Dialer1
ip address 192.168.20.2 255.255.255.0
no ip directed-broadcast
encapsulation ppp
dialer remote-name Router3
dialer pool 1
dialer string 6082
dialer-group 1
ppp authentication chap
ppp chap hostname Router2BRI 

!--- alternate CHAP hostname

ppp chap password 7 00071A150754
ppp multilink
!
router eigrp 1
network 10.0.0.0
network 192.168.19.0
network 192.168.20.0
no auto-summary
eigrp log-neighbor-changes
! 
access-list 150 deny eigrp any any
access-list 150 deny udp any any
access-list 150 permit ip any any
dialer-list 1 protocol ip list 150
!
!
line con 0
exec-timeout 0 0
transport input none
line aux 0
line vty 0 4
!
end

Проверка.

В данном разделе содержатся сведения о проверке работы конфигурации.

Некоторые команды show поддерживаются Средством интерпретации выходных данных(только зарегистрированные клиенты), которое позволяет просматривать аналитику выходных данных команды show.

  • show ppp multilink —, работает ли сеть должным образом.

Вывод, представленный ниже, является результатом ввода этой команды на устройствах, показанных на сетевой диаграмме выше.

Router3#show ppp multilink
Multilink1, bundle name is MultilinkRouter2
0 lost fragments, 0 reordered, 0 unassigned, sequence 0x0/0x0 rcvd/sent
0 discarded, 0 lost received, 1/255 load
Member links: 1 active, 0 inactive (max not set, min not set)
Serial1
Virtual-Access1, bundle name is Router2BRI
Dialer interface is Dialer1
0 lost fragments, 0 reordered, 0 unassigned, sequence 0x18/0x3F rcvd/sent
0 discarded, 0 lost received, 1/255 load
Member links: 2 (max not set, min not set)
BRI0:1
BRI0:2

Router2#show ppp multilink
Multilink1, bundle name is MultilinkRouter3
0 lost fragments, 0 reordered, 0 unassigned, sequence 0x0/0x0 rcvd/sent
0 discarded, 0 lost received, 1/255 load
Member links: 1 active, 0 inactive (max not set, min not set)
Serial1
Virtual-Access1, bundle name is Router3BRI
Dialer interface is Dialer1
0 lost fragments, 0 reordered, 0 unassigned, sequence 0x18/0x3F rcvd/sent
0 discarded, 0 lost received, 1/255 load
Member links: 2 (max not set, min not set)
BRI0:1
BRI0:2

Устранение неполадок

Для этой конфигурации в настоящее время нет сведений об устранении проблем.

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения


Document ID: 9500