Cервисы организации сетевого доступа к приложениям : Cisco Cache Engines серии 500

Устранение неполадок обратного прозрачного кэширования для WCCP

20 октября 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Содержание


Введение

В этом документе описывается устранение неполадок протокола подключения к веб-кэшу (WCCP) при его использовании для осуществления обратного прозрачного кэширования.

Предварительные условия

Требования

Для этого документа отсутствуют особые требования.

Используемые компоненты

Сведения, содержащиеся в данном документе, касаются следующих версий программного обеспечения и оборудования:

  • Catalyst 6500 с Supervisor 1 и MSFC 1 настроен в Режиме работы в собственной системе команд

  • Cisco выпуск ПО IOS� 12.1 (8a) EX (c6sup11-jsv-mz.121-8a. EX.bin)

  • Cache Engine 550 с версией 2.51

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в этом документе, были запущены с чистой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд до их использования.

Условные обозначения

Сведения об условных обозначениях см. в документе Условные обозначения технических терминов Cisco.

!--- конфигурацию

tshoot_wccp_9251.gif

При установке Cache Engine Cisco рекомендует настроить только команды, необходимые для реализации WCCP. Можно добавить другие опции, такие как аутентификация к маршрутизатору и спискам перенаправления клиентов, позднее.

На Cache Engine необходимо задать IP-адрес маршрутизатора и версию WCCP, который вы хотите использовать.


wccp router-list 1 192.168.15.1    
   wccp reverse-proxy router-list-num 1    
   wccp version 2

Как только IP-адрес и версия WCCP настроены, вы могли бы видеть сообщение, которое предупреждает, что сервис 99 должен быть активирован в маршрутизаторе для реализации обратного прозрачного кэширования. Сервис 99 является идентификатором сервиса WCCP для обратного прозрачного кэширования. Прозрачное кэширование идентификатора обычного прозрачного кэширования является словом "веб - кэширование" в Cisco IOS. Для активации сервиса 99 (обратное прозрачное кэширование) на маршрутизаторе и для определения порта, где перенаправление будет выполнено, добавьте эти команды в режиме глобальной конфигурации:


ip wccp 99
interface Vlan200 
    ip address 10.10.10.120 255.255.255.0 
    ip wccp 99 redirect out 

При настройке обратного прозрачного кэширования маршрутизатор, который выполняет WCCP, обрабатывает 99 запросов точек пересечения, направленных к Web-серверам. Команда ip wccp 99 redirect out применена на интерфейс, где вы хотите перехватить клиентские пакеты HTTP в их пути к вашему Web-серверу. Как правило, это - VLAN Web-сервера. Это обычно - не VLAN, где установлен Cache Engine.

Как только WCCP активен, маршрутизатор слушает на всех портах, которым настроили перенаправление WCCP. Для сигнализации его присутствия Cache Engine постоянно передает WCCP Сюда, я - пакеты к IP-адресам, которые настроены в списке маршрутизатора.

WCCP - подключение между маршрутизатором и кэшем сформирован. Для просмотра информации о соединении выполните команду show ip wccp.

Идентификатором маршрутизатора является IP-адрес маршрутизатора, как это замечено Cache Engine. Этот идентификатор является не обязательно интерфейсом маршрутизатора, используемым перенаправленным трафиком для достижения кэша. Идентификатор маршрутизатора в данном примере 192.168.15.1.

Router#show ip wccp 
   Global WCCP information: 
       Router information: 
           Router Identifier:                  192.168.15.1 
           Protocol Version:                   2.0
    Service Identifier: 99 
           Number of Cache Engines:            1 
           Number of routers:                  1 
           Total Packets Redirected:           0 
           Redirect access-list:               -none- 
           Total Packets Denied Redirect:      0 
           Total Packets Unassigned:           0 
           Group access-list:                  -none- 
           Total Messages Denied to Group:     0 
           Total Authentication failures:      0

Команда show ip wccp 99 detail предоставляет подробные сведения о кэшах.

Router#show ip wccp 99 detail 
   WCCP Cache-Engine information: 
           IP Address:               192.168.15.2 
           Protocol Version:         2.0 
           State:                    Usable 
           Redirection:              GRE 
           Initial Hash Info:        FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF 
                                     FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF    
           Assigned Hash Info:       FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF 
                                     FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF    
           Hash Allotment:           256 (100.00%) 
           Packets Redirected:       0 
           Connect Time:             00:00:39

Поле Redirection представляет метод, используемый для перенаправления пакетов от маршрутизатора до Cache Engine. Этот метод является или универсальной инкапсуляцией маршрутизации (GRE) или Уровнем 2. С GRE пакеты инкапсулируются в пакете GRE. С Уровнем 2 пакеты переданы прямо к кэшу, но Cache Engine и коммутатором или маршрутизатором должен быть Уровень 2, смежный для перенаправления Уровня 2.

Hash Allotment, представленный в шестнадцатеричном в полях Initial Hash Info и Assigned Hash Info, является количеством блоков хэша, которые назначены на этот кэш. Все интернет-адреса возможного источника разделены на 64 равных размерных диапазона, один блок на диапазон, и каждый кэш является назначенным трафиком из многих этих диапазонов адреса источника блока. Этой суммой управляет динамично WCCP согласно загрузке и заданию веса нагрузки кэша. Если у вас есть только один установленный кэш, этому кэшу можно было бы назначить все блоки.

Когда маршрутизатор начинает перенаправлять пакеты к Cache Engine, номеру в увеличениях поля Total Packets Redirected.

Поле Total Packets Unassigned является количеством пакетов, которые не были перенаправлены, потому что они не были назначены ни на какой кэш. В данном примере количество пакетов равняется 5. Когда кэш удален, пакеты могли бы быть неприсвоенными во время первоначального обнаружения кэшей или для маленького интервала.

Router#show ip wccp 
   Global WCCP information: 
       Router information: 
           Router Identifier:                      192.168.15.1 
           Protocol Version:                       2.0
    Service Identifier: 99 
           Number of Cache Engines:                1 
           Number of routers:                      1 
           Total Packets Redirected:               28 
           Redirect access-list:                   -none- 
           Total Packets Denied Redirect:          0 
           Total Packets Unassigned:               5 
           Group access-list:                      -none- 
           Total Messages Denied to Group:         0 
           Total Authentication failures:          0

Если кэш не становится полученным маршрутизатором, могло бы быть полезно отладить активность WCCP. Каждый раз, когда маршрутизатор получает Здесь, я - пакет от кэша, это отвечает со мной, видят вас пакет, и об этом сообщают в отладках. Доступные команды отладки являются debug ip wccp events и debug ip wccp packets.

Примечание: Обратитесь к документу Важная информация о командах отладки, прежде чем использовать команды debug.

Эти выходные данные предоставляют выборку обычных сообщений отладки WCCP:

Router#debug ip wccp event 
   WCCP events debugging is on 
  Router#debug ip wccp packet 
   WCCP packet info debugging is on 
   Router# 
   2d18h: WCCP-EVNT:S00: Built new router view: 0 routers,   
          0 usable web caches, change # 00000001 
   2d18h: WCCP-PKT:S00: Sending I_See_You packet to
          192.168.15.2 w/ rcv_id 00000001 
   2d18h: WCCP-EVNT:S00: Redirect_Assignment packet from
          192.168.15.2 fails source check 
   2d18h: %WCCP-5-SERVICEFOUND: Service web-cache
          acquired on Web Cache 192.168.15.2 
   2d18h: WCCP-PKT:S00: Received valid Here_I_Am packet
          from 192.168.15.2 w/rcv_id 00000001 
   2d18h: WCCP-EVNT:S00: Built new router view: 1
          routers, 1 usable web caches, change # 00000002 
   2d18h: WCCP-PKT:S00: Sending I_See_You packet to 192.168.15.2
          w/ rcv_id 00000002 
   2d18h: WCCP-EVNT:S00: Built new router view: 1 routers,
          1 usable web caches, change # 00000002 
   2d18h: WCCP-PKT:S00: Received valid Redirect_Assignment
          packet from 192.168.15.2 w/rcv_id 00000002 
   2d18h: WCCP-PKT:S00: Sending I_See_You packet to 192.168.15.2
          w/ rcv_id 00000003 
   2d18h: WCCP-EVNT:S00: Built new router view: 1 routers,
          1 usable web caches, change # 00000002 
   2d18h: WCCP-PKT:S00: Received valid Redirect_Assignment
          packet from 192.168.15.2 w/rcv_id 00000003 
   2d18h: WCCP-PKT:S00: Sending I_See_You packet to 192.168.15.2
          w/ rcv_id 00000004 
   2d18h: WCCP-PKT:S00: Sending I_See_You packet to 192.168.15.2
          w/ rcv_id 00000005 
   2d18h: WCCP-PKT:S00: Sending I_See_You packet to 192.168.15.2
          w/ rcv_id 00000006 
   2d18h: WCCP-EVNT:S00: Built new router view: 1 routers,
          1 usable web caches, change # 00000002 
   2d18h: WCCP-PKT:S00: Received valid Redirect_Assignment
          packet from 192.168.15.2 w/rcv_id 00000006

Для увеличения уровня отладки вы могли бы хотеть отследить трафик пакетов IP, чтобы проверить, получает ли маршрутизатор пакеты от Cache Engine. Во избежание перегрузки маршрутизатора в производственной среде и для показа только представляющего интерес трафика, можно использовать ACL для ограничения отладок только пакетами, которые имеют IP-адрес кэша как источник. Типовой ACL является permit ip host access-list 130 192.168.15.2 хостов 192.168.15.1.

Router#debug ip wccp event 
   WCCP events debugging is on 
  Router#debug ip wccp packet 
   WCCP packet info debugging is on 
  Router#debug ip packet 130 
   IP packet debugging is on for access list 130    
   2d19h: WCCP-EVNT:S00: Built new router view: 1 routers,  1 usable web caches, 
          change # 00000002 
   2d19h: WCCP-PKT:S00: Received valid Redirect_Assignment  packet from 192.168.15.2 
          w/rcv_id 0000001B 
   2d19h: datagramsize=174, IP 18390: s=192.168.15.2  (Vlan300), d=192.168.15.1
          (Vlan300), totlen 160, fragment 0, fo 0, rcvd 3    
   2d19h: WCCP-PKT:S00: Sending I_See_You packet to 192.168.15.2  w/ rcv_id 0000001C 
   2d19h: datagramsize=174, IP 18392: s=192.168.15.2  (Vlan300), d=192.168.15.1
          (Vlan300), totlen 160, fragment 0, fo 0, rcvd 3    
   2d19h: WCCP-PKT:S00: Sending I_See_You packet to 192.168.15.2  w/ rcv_id 0000001D 
   2d19h: datagramsize=174, IP 18394: s=192.168.15.2  (Vlan300), d=192.168.15.1
          (Vlan300), totlen 160, fragment 0, fo 0, rcvd 3    
   2d19h: WCCP-PKT:S00: Sending I_See_You packet to 192.168.15.2  w/ rcv_id 0000001E 
   2d19h: datagramsize=378, IP 18398: s=192.168.15.2  (Vlan300), d=192.168.15.1
          (Vlan300), totlen 364, fragment 0, fo 0, rcvd 3    
   2d19h: WCCP-EVNT:S00: Built new router view: 1 routers,  1 usable web caches, 
          change # 00000002 
   2d19h: WCCP-PKT:S00: Received valid Redirect_Assignment  packet from 192.168.15.2 
          w/rcv_id 0000001E 
   2d19h: datagramsize=174, IP 18402: s=192.168.15.2  (Vlan300), d=192.168.15.1
          (Vlan300), totlen 160, fragment 0, fo 0, rcvd 3    
   2d19h: WCCP-PKT:S00: Sending I_See_You packet to 192.168.15.2  w/ rcv_id 0000001F 
   2d19h: datagramsize=174, IP 18404: s=192.168.15.2  (Vlan300), d=192.168.15.1
          (Vlan300), totlen 160, fragment 0, fo 0, rcvd 3    
   2d19h: WCCP-PKT:S00: Sending I_See_You packet to 192.168.15.2  w/ rcv_id 00000020 
   2d19h: datagramsize=174, IP 18406: s=192.168.15.2  (Vlan300), d=192.168.15.1
          (Vlan300), totlen 160, fragment 0, fo 0, rcvd 3    
   2d19h: WCCP-PKT:S00: Sending I_See_You packet to 192.168.15.2  w/ rcv_id 00000021 
   2d19h: datagramsize=378, IP 18410: s=192.168.15.2  (Vlan300), d=192.168.15.1
          (Vlan300), totlen 364, fragment 0, fo 0, rcvd 3    
   2d19h: WCCP-EVNT:S00: Built new router view: 1 routers,  1 usable web caches, 
          change # 00000002 
   2d19h: WCCP-PKT:S00: Received valid Redirect_Assignment  packet from 192.168.15.2 
          w/rcv_id 00000021 
   2d19h: datagramsize=174, IP 18414: s=192.168.15.2  (Vlan300), d=192.168.15.1
          (Vlan300), totlen 160, fragment 0, fo 0, rcvd 3    
   2d19h: WCCP-PKT:S00: Sending I_See_You packet to 192.168.15.2  w/ rcv_id 00000022 
   2d19h: datagramsize=174, IP 18416: s=192.168.15.2  (Vlan300), d=192.168.15.1
          (Vlan300), totlen 160, fragment 0, fo 0, rcvd 3

Если никакие кэши не замечены маршрутизатором, и никакая активность WCCP не замечена, проверьте основное подключение. Попытайтесь пропинговать кэш от маршрутизатора или маршрутизатора от кэша. Если эхо-запрос работает, ошибка могла бы существовать в конфигурации.

Если кэш получен, но никакие пакеты не перенаправлены, проверяют, что маршрутизатор получает трафик и что трафик передан к интерфейсу, где применена команда ip wccp 99 redirect out. Помните, что трафик, который перехвачен и перенаправлен, является только трафиком, направленным к порту TCP 80.

Если трафик все еще не перенаправляется, и веб - контент прибывает прямо из серверов, проверьте, что кэш правильно передает инструкцию, что перехватить. У вас должны быть некоторые общие сведения на WCCP для завершения этого действия.

WCCP распознает два различных типа сервисов: стандартный и динамичный. Маршрутизатор неявно знает о стандартном сервисе. Т.е. маршрутизатору не должны говорить использовать порт 80, потому что это уже знает, чтобы сделать так. Обычное прозрачное кэширование (веб - кэширование - стандартный сервис 0) является стандартным сервисом.

Во всех других случаях (который включает прозрачное кэширование), маршрутизатор сказан который порт перехватить. Эту информацию передают в Здесь, я - пакет.

Можно выполнить команду debug ip packet dump для исследования самих пакетов. Используйте ACL, созданный для отладки только пакетов, переданных Cache Engine.

Router#debug ip packet 130 dump 
   2d19h: datagramsize=174, IP 19576: s=192.168.15.2 (Vlan300), d=192.168.15.1 
      (Vlan300), totlen 160, fragment 0, fo 0, 
   rcvd 3 
   072C5120:                       0004 9B294800            ...)H. 

!--- Start IP header.
 
   072C5130: 00500F0D 25360800 450000A0 4C780000  .P..%6..E.. Lx..    
   072C5140: 3F118F81 C0A80F02 C0A80F01 08000800  ?...@(..@(......    
   072C5150: 008CF09E 0000000A 0200007C 00000004  ..p........|.... 

!--- Start WCCP header.

   072C5160: 00000000 00010018 0163E606 00000515  .........cf.....    
   072C5170: 00500000 00000000 00000000 00000000  .P.............. 

!--- Port to intercept (0x50=80).

   072C5180: 0003002C C0A80F02 00000000 FFFFFFFF  ...,@(.......... 

!--- Hash allotment (FFFF...).

   072C5190: FFFFFFFF FFFFFFFF FFFFFFFF FFFFFFFF  ................ 
   072C51A0: FFFFFFFF FFFFFFFF FFFF0000 00000000  ................ 
   072C51B0: 00050018 00000002 00000001 C0A80F01  ............@(..    
   072C51C0: 0000000C 00000001 C0A80F02 00080008  ........@(......    
   072C51D0: 00010004 00000001 30                 ........0

С этой командой можно определить, объявлен ли порт без потребности просмотреть весь Запрос на комментарий (RFC). Если порт не объявлен, проблема наиболее вероятна в конфигурации кэша.

См. Протокол V2.0 Координации Веб-кэша leavingcisco.com для получения дополнительной информации.

Если кэш получен, и пакеты перенаправлены, но ваши интернет-клиенты не могут просмотреть ваши серверы, проверьте, имеет ли кэш подключение к Интернету и к вашим серверам. Эхо-запрос от кэша до различных IP-адресов в Интернете и к некоторым вашим внутренним серверам. Если вы пропинговываете полностью определенные домены (URL) вместо IP-адресов, уверены, что вы задаете сервер DNS для использования в конфигурации кэш-памяти.

Если вы не уверены, обрабатывает ли кэш запросы, можно отладить работу HTTP в кэше. Для отладки работы HTTP в кэше необходимо ограничить трафик, чтобы избежать перегружать кэш. На маршрутизаторе создайте ACL с IP - адресом источника одного клиента в Интернете, который можно использовать в качестве устройства для тестов и использовать список перенаправления опции команды global ip wccp 99.

Router(config)#access-list 50 permit 172.17.241.126
Router(config)#ip wccp 99 redirect-list 50

Как только вы создаете и применяете ACL, выполняете эти шаги:

  1. Активируйте отладку HTTP в кэше с командой debug http all all (версия 2.x Cisco Cache Engine) или отладьте http все (версия 3 Cisco Cache Engine и версия ACNS 4, 5).

  2. Активируйте мониторинг терминала (выполните команду term mon).

  3. Попытайтесь просмотреть один из своих серверов от клиента, которого вы настроили в ACL.

Вот пример выходных данных:

irq0#conf tcework_readfirstdata() Start the recv: 0xb820800 len 4096 timeout    
   0x3a98 ms ctx 0xb87d800 
   cework_recvurl() Start the request: 0xb20c800 0xb20c838 0xb20c8e0 
   Http Request headers received from client:    
   GET / HTTP/1.1 
   Host: 10.10.10.152 
   User-Agent: Links (0.92; Linux 2.2.16-22 i686) 
   Accept: */* 
   Accept-Charset: us-ascii, ISO-8859-1, ISO-8859-2, ISO-8859-4, ISO-8895-5,    
      ISO-8859-13, windows-1250, windws-1251, windows-1257, cp437, cp850, cp852,
       cp866, x-cp866-u, x-mac-ce, x-kam-cs, x-koi8-r, x-koi8-u, utf8 
   Connection: Keep-Alive

Protocol dispatch: mode=1 proto=2 
   ValidateCode() Begin: pRequest=0xb20c800 
   Proxy: CACHE_MISS: HealProcessUserRequest 
   cework_teefile() 0xb20c800: Try to connect to server: CheckProxyServerOut():    
      Outgoing proxy is not enable: 0xb20c800 (F) 
   GetServerSocket(): Forwarding to server: pHost = 10.10.10.152, Port = 80    
   HttpServerConnectCallBack : Connect call back socket = 267982944, error    = 0 
   Http request headers sent to server:    

   GET / HTTP/1.1 
   Host: 10.10.10.152 
   User-Agent: Links (0.92; Linux 2.2.16-22 i686) 
   Accept: */* 
   Accept-Charset: us-ascii, ISO-8859-1, ISO-8859-2, ISO-8859-4, ISO-8895-5,    
      ISO-8859-13, windows-1250, windws-1251, windows-1257, cp437, cp850, cp852, 
      cp866, x-cp866-u, x-mac-ce, x-kam-cs, x-koi8-r, x-koi8-u, utf8 
   Connection: keep-alive 
   Via: 1.1 irq0 
   X-Forwarded-For: 172.17.241.126

cework_sendrequest: lBytesRemote = 386, nLength = 386 (0xb20c800)    
   ReadResCharRecvCallback():  lBytesRemote = 1818, nLength = 1432 0xb20c800)    
   IsResponseCacheable() OBJECTSIZE_IS_UNLIMITED, lContentLength = 3194    
   cework_processresponse() : 0xb20c800 is cacheable 
   Http response headers received from server:    
   HTTP/1.1 200 OK 
   Date: Tue, 20 Nov 2001 10:46:14 GMT 
   Server: Apache/1.3.12 (Unix)  (Red Hat/Linux) mod_ssl/2.6.6 OpenSSL/0.9.5a 
      mod_perl/1.24 
   Last-Modified: Fri, 12 Oct 2001 12:55:23 GMT 
   ETag: "5e23-c7a-3bc6e83b" 
   Accept-Ranges: bytes 
   Content-Length: 3194 
   Keep-Alive: timeout=15, max=100 
   Connection: Keep-Alive 
   Content-Type: text/html

GetUpdateCode(): GET request from client, GET request to server. 
   GetUpdateCode(): nRequestType = -1 
   SetTChain() 0xb20c800: CACHE_OBJECT_CLIENT_OBJECT sendobj_and_cache    
   Http response headers sent to client:    
   HTTP/1.1 200 OK 
   Date: Tue, 20 Nov 2001 10:46:14 GMT 
   Server: Apache/1.3.12 (Unix)  (Red Hat/Linux) mod_ssl/2.6.6 OpenSSL/0.9.5a    
      mod_perl/1.24 
   Last-Modified: Fri, 12 Oct 2001 12:55:23 GMT 
   ETag: "5e23-c7a-3bc6e83b" 
   Content-Length: 3194 
   Keep-Alive: timeout=15, max=100 
   Content-Type: text/html 
   Connection: keep-alive

cework_tee_sendheaders() 0xb20c800: sent 323 bytes to client 
   cework_tee_send_zbuf() 0xb20c800: Send 1087 bytes to client (1087)    
   UseContentLength(): Valid Content-Length (T) 
   cework_tee_recv_zbuf() 0xb20c800: Register to recv 2107 bytes timeout 120 sec 
   HttpServerRecvCallBack(): Recv Call Back socket 267982944, err 0, length  2107 
   HttpServerRecvCallBack(): lBytesRemote = 3925, nLength = 2107 (186697728)    
   cework_tee_send_zbuf() 0xb20c800: Send 2107 bytes to client (2107)    
   UseContentLength(): Valid Content-Length (T) 
   cework_setstats(): lBytesLocal = 0, lBytesRemote = 3925 (0xb20c800)    
   cework_readfirstdata() Start the recv: 0xb84a080 len 4096 timeout 0x3a98    
      ms ctx 0xb87d800 
   cework_cleanup_final() End the request: 0xb20c800 0xb20c838 0xb20c8e0

Связанные сведения, которые вы могли бы найти в отладке, выделены полужирным.

Это другие фазы транзакции страницы веб-страницы:

  1. Заголовки запроса HTTP получены от клиента.

  2. Заголовки запроса HTTP, передаваемые серверу.

  3. Заголовки ответа HTTP получены от сервера.

  4. Заголовки ответа HTTP, передаваемые клиенту.

Если веб-страница, которую вы просматриваете, содержит множественные объекты, множественные случаи этой последовательности событий существуют. Используйте самый простой запрос уменьшить выходные данные отладки.

На Catalyst 6500 или маршрутизаторе Cisco 7600, менеджер функции обрабатывает все функции, настроенные в Cisco IOS для обеспечения добавленного слоя устранения проблем. Когда функция Уровня 3 настроена в этих устройствах, информация, которая определяет, как к с рукояткой полученные фреймы передан к контрольным функциям Уровня 2 коммутатора или маршрутизатора (менеджер функции). Для WCCP эта контрольная информация определяет, какие пакеты перехвачены IOS и WCCP и направлены к прозрачной cache - памяти.

Команда show fm features отображает опции, которые активированы в Cisco IOS. Можно использовать эту команду, чтобы проверить, объявлен ли порт для прерывания правильно Cache Engine.

Router#show fm features 
   Redundancy Status: stand-alone 
   Interface: Vlan200 IP is enabled 
     hw[EGRESS] = 1, hw[INGRESS] = 1 
     hw_force_default[EGRESS] = 0, hw_force_default[INGRESS] = 0    
     mcast = 0 
     priority = 2 
     reflexive = 0 
     vacc_map : 
     outbound label: 5 
           merge_err: 0 
           protocol: ip 
             feature #: 1    
             feature id: FM_IP_WCCP    
             Service ID: 99    
             Service Type: 1

The following are the used labels 
     label 5: 
           swidb: Vlan200 
           Vlous:

The following are the features configured 
     IP WCCP: service_id = 99, service_type = 1, state = ACTIVE 
           outbound users: 
             user_idb: Vlan200    
           WC list: 
             address: 192.168.15.2    
           Service    ports: 
             ports[0]:    80

The following is the ip ACLs port expansion information 
     FM_EXP knob configured: yes

FM mode for WCCP: GRE (flowmask: destination-only)

FM redirect index base: 0x7E00

The following are internal statistics 
     Number of pending tcam inserts: 0 
     Number of merge queue elements: 0

Команда show fm int vlan 200 отображает точное содержание Ternary Content Addressable Memory (TCAM).

Router#show fm int vlan 200 
 Interface: Vlan200 IP is enabled 
  hw[EGRESS] = 1, hw[INGRESS] = 1 
  hw_force_default[EGRESS] = 0, hw_force_default[INGRESS] = 0    
  mcast = 0 
  priority = 2 
  reflexive = 0 
  vacc_map : 
  outbound label: 5 
   merge_err: 0 
   protocol: ip 
    feature #: 1    
    feature id: FM_IP_WCCP    
    Service ID: 99    
    Service Type: 1    
     (only for IP_PROT) DestAddr SrcAddr          Dpt   Spt  L4OP TOS Est  prot  Rslt 
     vmr IP value #1:   0.0.0.0  192.168.15.2     0     0    0    0   0    6     permit 
     vmr IP mask  #1:   0.0.0.0  255.255.255.255  0     0    0    0   0    FF 
     vmr IP value #2:   0.0.0.0  0.0.0.0          80    0    0    0   0    6     bridge 
     vmr IP mask  #2:   0.0.0.0  0.0.0.0          FFFF  0    0    0   0    FF 
     vmr IP value #3:   0.0.0.0  0.0.0.0          0     0    0    0   0    0     permit 
     vmr IP mask  #3:   0.0.0.0  0.0.0.0          0     0    0    0   0    0

Линия vmr IP value # 1: определяет обход перехвата на кадрах, которые прибывают из Cache Engine. Без этого была бы петля перенаправления. Линия vmr IP value # 2: определяет перехват всех пакетов, которые имеют порт 80 как их назначение. Если порт 80 не отображен во второй линии, но WCCP активен, и кэш применим маршрутизатором, то могла бы быть проблема в конфигурации кэш-памяти. Соберите дамп Здесь, я - пакет, чтобы определить, передается ли порт кэшем.

Если вы неспособны решить проблему после того, как вы устраните неполадки, сообщите о проблеме к Центру технической поддержки Cisco (TAC).

Вот некоторые основные сведения, которые необходимо предоставить Центру технической поддержки Cisco. От маршрутизатора соберите эту информацию:

  • Выходные данные команды show tech. Если существует трудность с размером выходных данных show tech, выходными данными команд show running config и show version output можно заменить.

  • Выходные данные команды show ip wccp.

  • Выходные данные команды show ip wccp web-cache detail.

  • Если, кажется, существует проблема со связью между маршрутизатором и Веб-кэшем, предоставьте выходные данные от debug ip wccp events и команд debug ip wccp packets, в то время как происходит проблема.

На Cache Engine (только Cisco Cache Engines), соберите выходные данные команды show tech.

Когда вы связываетесь с TAC, выполняете эти шаги:

  1. Предоставьте ясное описание проблемы. Необходимо включать ответы на эти вопросы:

    • Каковы признаки?

    • Это происходит все время или нечасто?

    • Проблема запускалась после изменения в конфигурации?

    • Cisco или кэши третьей стороны используются?

  2. Предоставьте ясное описание топологии. Включайте схему, если это сделает ее более ясной.

  3. Предоставьте любую другую информацию, что вы думаете, полезно в решении проблемы.

Вот выходные данные примера конфигурации:

*********************************** Router Configuration *****************************
Router#show running 
   Building configuration...
Current configuration : 4231 bytes 
   ! 
   version 12.1 
   service timestamps debug uptime 
   service timestamps log uptime 
   no service password-encryption 
   ! 
   hostname Router 
   ! 
   boot buffersize 126968 
   boot bootldr bootflash:c6msfc-boot-mz.120-7.XE1    
   ! 
   redundancy 
    main-cpu 
     auto-sync standard 
   ip subnet-zero 
   ip wccp 99 
   ! 
   ! 
   ! 
   interface FastEthernet3/1 
    no ip address 
    switchport 
    switchport access vlan 100 
    switchport mode access 
   ! 
   interface FastEthernet3/2 
    no ip address 
    switchport 
    switchport access vlan 200 
    switchport mode access 
   ! 
   interface FastEthernet3/3 
    no ip address 
    switchport 
    switchport access vlan 300 
    switchport mode access 
   ! 
   interface FastEthernet3/4 
    no ip address 
   ! 
! 
   interface Vlan100 
    ip address 172.17.241.97 255.255.255.0    
   ! 
   interface Vlan200 
    ip address 10.10.10.120 255.255.255.0    
    ip wccp 99 redirect out 
   ! 
   interface Vlan300 
    ip address 192.168.15.1 255.255.255.0    
   ! 
   ip classless 
   ip route 0.0.0.0 0.0.0.0 172.17.241.1    
   no ip http server 
   ! 
   access-list 30 permit 192.168.15.2 
   ! 
   ! 
   line con 0 
    exec-timeout 0 0 
   line vty 0 4 
    login 
    transport input lat pad mop telnet rlogin udptn    nasi 
   ! 
   end
*********************************** Cache Configuration ******************************
Cache#show running
Building configuration... 
   Current configuration: 
   ! 
   ! 
   logging disk /local/syslog.txt debug 
   ! 
   user add admin uid 0  capability admin-access    
   ! 
   ! 
   ! 
   hostname Cache 
   ! 
   interface ethernet 0 
    ip address 192.168.15.2 255.255.255.0    
    ip broadcast-address 192.168.15.255    
    exit 
   ! 
   interface ethernet 1 
    exit 
   ! 
   ip default-gateway 192.168.15.1 
   ip name-server 172.17.247.195 
   ip domain-name cisco.com 
   ip route 0.0.0.0 0.0.0.0 192.168.15.1    
   cron file /local/etc/crontab 
   ! 
   wccp router-list 1 192.168.15.1 
   wccp reverse-proxy router-list-num 1 
   wccp version 2 
   ! 
   authentication login local enable 
   authentication configuration local enable    
   rule no-cache url-regex .*cgi-bin.* 
   rule no-cache url-regex .*aw-cgi.* 
   ! 
   ! 
   end

Дополнительные сведения


Document ID: 9251