Коммутация LAN : Протокол ISL

Настройка группообразования ISL между коммутаторами Catalyst под управлением системного программного обеспечения CatOS и Cisco IOS

5 апреля 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (7 октября 2015) | Отзыв


Содержание


Введение

Этот документ предоставляет примеры конфигурации для транкинга Протокола ISL между Cisco Catalyst 5000 коммутаторов, которые выполняют операционную систему Catalyst (CatOS) и Коммутатор Catalyst 6500, который выполняет Cisco системное программное обеспечение IOS�. Можно использовать любой из коммутаторов, упомянутых в этом сценарии. Результат будет одинаков:

  • Любой Catalyst 4500/4000, 5500/5000, или 6500/6000 коммутатор серии, который выполняет CatOS

  • Любой Catalyst 4500/4000 или Коммутатор серии Catalyst 6500/6000, который выполняет системное ПО Cisco IOS

Предварительные условия

Требования

Для этого документа отсутствуют особые требования.

Используемые компоненты

Сведения, содержащиеся в данном документе, касаются следующих версий программного и аппаратного обеспечения:

  • Коммутатор Catalyst 5000, который выполняет CatOS 6.1 (1) программное обеспечение

  • Коммутатор Catalyst 6509, который выполняет программное обеспечение Cisco IOS версии 12.1(4)E1

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Для получения дополнительной информации о лабораторной среде, посмотрите раздел Диаграммы сети этого документа. Гарантируйте понимание потенциального воздействия любой конфигурации или команды в сети перед использованием его. Конфигурации на всех устройствах были очищены с clear config all и командами write erase для обеспечения конфигурации по умолчанию.

Теоретические сведения

Транкинг является способом перенести трафик от нескольких VLAN по каналу типа точка-точка между двумя устройствами. Существуют два способа применения режима магистрального соединения Ethernet:

  • ISL (частный протокол Cisco)

  • IEEE 802.1Q (стандарт IEEE)

В данном документе рассматриваются только примеры файлов конфигурации для коммутаторов, а также выходные данных соответствующих команд show. Для получения дополнительной информации о том, как настроить магистральный канал ISL между Коммутаторами Catalyst, сошлитесь на эти документы:

Важные примечания

  • Коммутаторы 4500/4000 Series катализатора (которые включают Catalyst 2948G и Catalyst 2980G), что выполненный CatOS только поддерживает транкинг 802.1Q. Эти коммутаторы не поддерживают Транкинг ISL.

  • Коммутаторы Catalyst 4000 Switch с Supervisor Engine II + или позже выполняют программное обеспечение Cisco IOS по умолчанию. Эти коммутаторы поддерживают и ISL и магистральные режимы 802.1Q на всех интерфейсах за исключением блокирования Гигабитных портов на WS-X4418-GB и S-X4412-2GB-T модулях. В этих случаях коммутаторы поддерживают только транкинг 802.1Q. Порты 3-18 являются блокирующими портами Gigabit в модуле WS-X4418-GB. . Порты 1-12 являются блокирующими портами Gigabit в модуле WS-X4412-2GB-T. . Термин "блокирующий порт" означает, что превышено подключение порта к объединительной плате.

  • Любой Порт Ethernet на Коммутаторе серии Catalyst 6500/6000 поддерживает 802.1Q и инкапсуляцию ISL.

  • На основе модуля Catalyst 5000 с поддержкой транка портирует, поддерживают инкапсуляцию ISL только или поддерживают и ISL и 802.1Q. Лучший способ определить поддерживаемые типы инкапсуляции состоит в том, чтобы использовать команду show port capabilities. Выходные данные command явно сообщают пропускную способность транкинга, как показано в примере:

    cat5000> show port capabilities 3
    Model                    WS-X5225R
    Port                     3/1
    Type                     10/100BaseTX
    Speed                    auto,10,100
    Duplex                   half,full
    Trunk encap type         802.1Q, ISL
    
    !--- This particular port supports both 802.1Q and ISL.
    
    Trunk mode               on,off,desirable,auto,nonegotiate
    Channel                  3/1-2,3/1-4
    Broadcast suppression    percentage(0-100)
    Flow control             receive-(off,on),send-(off,on)
    Security                 yes
    Membership               static,dynamic
    Fast start               yes
    QOS scheduling           rx-(none),tx-(none)
    CoS rewrite              yes
    ToS rewrite              IP-Precedence
    Rewrite                  no
    UDLD                     yes
    AuxiliaryVlan            1..1000,1025..4094,untagged,dot1p,none
    SPAN                     source,destination
  • Убедитесь, что магистральные режимы совпадают по магистральной линии. При настройке одной стороны ссылки как магистральный канал ISL необходимо настроить другую сторону ссылки как ISL. Точно так же при настройке одной стороны ссылки как 802.1Q необходимо настроить другую сторону ссылки как 802.1Q.

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Условные обозначения технических терминов Cisco.

Настройка

В этом разделе содержатся сведения о настройке функций, описанных в этом документе.

Примечание: Чтобы получить подробные сведения о командах в данном документе, используйте Средство поиска команд (только для зарегистрированных клиентов).

Схема сети

В этом документе использованы параметры данной сети:

/image/gif/paws/8759/66a.gif

Конфигурации

Эти конфигурации используются в данном документе:

Примечание: Этот документ отображает комментарии и пояснения в синем курсиве в конфигурациях.

Catalyst 5000 Switch
#version 6.1(1)
!
set option fddi-user-pri enabled
set password $2$h/BN$i3S54iNvIXknFelh6gOve0
set enablepass $2$DpAu$/mw1ZxL5I8ymR.yn85ovB/
!
#errordetection
set errordetection portcounter enable
!
#system
set system name  cat5000
!
#frame distribution method
set port channel all distribution mac both
!
#vtp

!--- In the example, the VLAN Trunk Protocol (VTP) mode is set to be transparent.
!--- Use your network as a basis to set the VTP mode.

set vtp mode transparent

!--- For details on VTP, refer to Configuring VTP.


set vlan 1 name default type ethernet mtu 1500 said 100001 state active
set vlan 1002 name fddi-default type fddi mtu 1500 said 101002 state active
set vlan 1004 name fddinet-default type fddinet mtu 1500 said 101004 state active stp ieee
set vlan 1005 name trnet-default type trbrf mtu 1500 said 101005 state active stp ibm
set vlan 2
set vlan 1003 name token-ring-default type trcrf mtu 1500 said 101003 state acti
ve mode srb aremaxhop 7 stemaxhop 7 backupcrf off
!
#ip

!--- This is the IP address that is used for management.

set interface sc0 1 10.10.10.2/255.255.255.0 10.10.10.255
 
!
#set boot command
set boot config-register 0x10f
set boot system flash bootflash:cat5000-sup3.6-1-1.bin
!
#mls
set mls nde disable
!
# default port status is enable
!
!
#module 1 : 0-port Supervisor III
!
#module 2 empty
!
#module 3 : 9-port Gigabit Ethernet
!
#module 4 : 24-port 10/100BaseTX Ethernet
!
#module 5 : 24-port 10/100BaseTX Ethernet

!--- Ports 5/13–24 have been assigned to VLAN 2.

set vlan 2 5/13-24


!--- The ISL trunking mode is set to "on".
!--- Use your network and requirements as a basis to set the trunking mode.

set trunk 5/1 on isl 1-1005

!--- For details on different trunking modes, refer to 
!--- Configuring VLAN Trunks on Fast Ethernet and Gigabit Ethernet Ports.


!--- PortFast has been enabled on the ports that are connected to the workstations.

set spantree portfast 5/2-24 enable

!--- For details on why to enable PortFast, refer to
!--- Using PortFast and Other Commands to Fix Workstation Startup Connectivity Delays.

end

Коммутатор Catalyst 6500
Current configuration : 4207 bytes
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname cat6000
!
boot buffersize 126968
boot bootldr bootflash:c6msfc-boot-mz.121-4.E1.bin
no logging console

!--- The example uses the privileged mode password.

enable password mysecret
!
redundancy
 main-cpu
  auto-sync standard
ip subnet-zero
no ip domain-lookup
!
ip cef
cns event-service server
!
!
!
interface gigabitethernet1/1
 no ip address
 shutdown
!
interface gigabitethernet1/2
 no ip address
 shutdown
!
interface fastethernet9/1
 no ip address


!--- Issue the switchport command once, without any keywords, 
!--- in order to configure the interface as a Layer 2 (L2) port for the Catalyst 6500.
!--- For details, refer to Configuring Layer 2 Ethernet Interfaces (Catalyst 6500).
!--- On a Catalyst 4000 switch that runs Cisco IOS Software, all ports are 
!--- L2 ports by default. If there is no change to the default configuration, 
!--- you do not need to issue the switchport command.
!--- For details, refer to Configuring Layer 2 Ethernet Interfaces (Catalyst 4000).

 switchport

!--- Configure trunk encapsulation as ISL.

 switchport trunk encapsulation isl


!--- Enable trunking on the interface.

 switchport mode trunk
!

!--- Interfaces Fast Ethernet 9/2 through 9/24 are configured to be in access mode.
!--- For details, refer to the "Layer 2 Interface Modes" section of
!--- Configuring Layer 2 Ethernet Interfaces.

interface fastethernet9/2
 no ip address
 switchport
 switchport mode access
!
interface fastethernet9/3
 no ip address
 switchport
 switchport mode access
!

!--- Output suppressed.

!
interface fastethernet9/11
 no ip address
 switchport
 switchport mode access
!
interface fastethernet9/12
 no ip address
 switchport
 switchport mode access
!

!--- Interfaces Fast Ethernet 9/13 through 9/24 are placed in VLAN 2.

interface fastethernet9/13
 no ip address
 switchport
 switchport access vlan 2
 switchport mode access
!
interface fastethernet9/14
 no ip address
 switchport
 switchport access vlan 2
 switchport mode access
!

!--- Output suppressed.

!
interface fastethernet9/23
 no ip address
 switchport
 switchport access vlan 2
 switchport mode access
!
interface fastethernet9/24
 no ip address
 switchport
 switchport access vlan 2
 switchport mode access
!
interface fastethernet9/25
 no ip address
 shutdown
!

!--- Output suppressed.

!
interface fastethernet9/48
 no ip address
 shutdown
!
interface vlan1

!--- This is the IP address that is used for management.

 ip address 10.10.10.3 255.255.255.0
!
!
ip classless
no ip http server
!
!
!
line con 0
 transport input none
line vty 0 4

!--- This example uses the Telnet password.

 password mysecret
login
!
end

Примечание: Если вы назначаете интерфейс на VLAN, которая не существует, интерфейс завершает, пока вы не создаете VLAN в базе данных VLAN. Дополнительные сведения см. в разделе Создание или изменение Ethernet VLAN документа Настройка сетей VLAN.

Проверка.

команды "show"

Этот раздел позволяет убедиться, что конфигурация работает правильно.

Средство Output Interpreter (OIT) (только для зарегистрированных клиентов) поддерживает определенные команды show. Посредством OIT можно анализировать выходные данные команд show.

Catalyst 5000 или Коммутаторы Catalyst 6000, который выполненный CatOS

  • модуль/порт show port capabilities — Использование эта команда, чтобы проверить, способен ли порт к транкингу.

    cat5000> (enable) show port capabilities 5/1
    Model                    WS-X5234
    Port                     5/1
    Type                     10/100BaseTX
    Speed                    auto,10,100
    Duplex                   half,full
    Trunk encap type         802.1Q,ISL
    Trunk mode               on,off,desirable,auto,nonegotiate
    Channel                  5/1-2,5/1-4
    Broadcast suppression    percentage(0-100)
    Flow control             receive-(off,on),send-(off,on)
    Security                 yes
    Membership               static,dynamic
    Fast start               yes
    QOS scheduling           rx-(none),TX(1q4t)
    COs rewrite              yes
    ToS rewrite              IP-Precedence
    Rewrite                  yes
    UDLD                     yes
    AuxiliaryVlan            1..1000,1025..4094,untagged,dot1p,none
    SPAN                     source,destination
  • модуль/порт show port — Эта команда показывает статус определенного порта и является ли это магистральным.

    cat5000> (enable) show port 5/1
    Port  Name               Status     Vlan       Level  Duplex Speed Type
    ----- ------------------ ---------- ---------- ------ ------ ----- ------------
     5/1                     connected  trunk      normal a-full a-100 10/100BaseTX
    
    Port  AuxiliaryVlan AuxVlan-Status
    ----- ------------- --------------
     5/1  none          none          
    
    
    Port  Security Violation Shutdown-Time Age-Time Max-Addr Trap     IfIndex
    ----- -------- --------- ------------- -------- -------- -------- -------
     5/1  disabled  shutdown             0        0        1 disabled      66
    
    Port  Num-Addr Secure-Src-Addr   Age-Left Last-Src-Addr     Shutdown/Time-Left
    ----- -------- ----------------- -------- ----------------- ------------------
     5/1         0                 -        -                 -        -         -
    
    !--- Output suppressed.
    
    
  • модуль/порт show trunk — Использование эта команда для подтверждения статуса транкинга и конфигурации.

    cat5000> (enable) show trunk
    * - indicates vtp domain mismatch
    Port      Mode         Encapsulation  Status        Native vlan
    --------  -----------  -------------  ------------  -----------
     5/1      on           isl            trunking      1
     
    Port      Vlans allowed on trunk
    --------  ---------------------------------------------------------------------
     5/1      1-1005
     
    Port      Vlans allowed and active in management domain
    --------  ---------------------------------------------------------------------
     5/1      1-2
     
    Port      Vlans in spanning tree forwarding state and not pruned
    --------  ---------------------------------------------------------------------
     5/1      1-2
    
  • show vtp domain эту команду для проверки информации VTP.

    cat5000> (enable) show vtp domain
    Domain Name                      Domain Index VTP Version Local Mode  Password
    -------------------------------- ------------ ----------- ----------- ----------
                                     1            2           Transparent -
    
    Vlan-count Max-vlan-storage Config Revision Notifications
    ---------- ---------------- --------------- -------------
    6          1023             0               disabled
    
    Last Updater    V2 Mode  Pruning  PruneEligible on Vlans
    --------------- -------- -------- -------------------------
    10.10.10.2      disabled disabled 2-1000

Коммутаторы Catalyst 6500/6000 или коммутаторы Catalyst 4500/4000, Который Выполненное программное обеспечение Cisco IOS

  • interface_type show interfaces если порт является магистральным, транк модуля/порта — Эта команда говорит вам.

    cat6000#show interfaces fastethernet 9/1 trunk
     
    Port      Mode         Encapsulation  Status        Native vlan
    Fa9/1     on           isl            trunking      1
     
    Port      Vlans allowed on trunk
    Fa9/1     1-1005
     
    Port      Vlans allowed and active in management domain
    Fa9/1     1-2,1002-1005
     
    Port      Vlans in spanning tree forwarding state and not pruned
    Fa9/1     1-2,1002-1005
  • show vlan команда предоставляет сведения о VLAN и портах, которые принадлежат конкретной VLAN.

    cat6000#show vlan
     
    VLAN Name                             Status    Ports
    ---- -------------------------------- --------- -------------------------------
    1    default                          active    Fa9/2, Fa9/3, Fa9/4, Fa9/5
                                                    Fa9/6, Fa9/7, Fa9/8, Fa9/9
                                                    Fa9/10, Fa9/11, Fa9/12
    2    VLAN0002                         active    Fa9/13, Fa9/14, Fa9/15, Fa9/16
                                                    Fa9/17, Fa9/18, Fa9/19, Fa9/20
                                                    Fa9/21, Fa9/22, Fa9/23, Fa9/24
    1002 fddi-default                     active
    1003 token-ring-default               active
    1004 fddinet-default                  active
    1005 trnet-default                    active
    
    !--- Output suppressed.
    
    

Примечание: Только те порты, которые настроены как немагистральные порты L2, отображены. Более подробно см. раздел "Настройка интерфейсов Ethernet для коммутации уровня 2" в главе "Настройка уровня 2 интерфейсов Ethernet".

Устранение неполадок

Используйте этот раздел для устранения неполадок своей конфигурации.

Коммутатор не принимает изменение собственного VLAN на магистральном порту, поскольку порт является портом не802.1Q

Эта проблема происходит, потому что магистральный порт не поддерживает инкапсуляцию 802.1Q. Собственный VLAN требует поддержки 802.1Q на порту. Если порт не имеет поддержки 802.1Q, коммутатор не позволяет изменение собственного VLAN.

Поддержка 802.1Q транкинга является независимым от оборудования фактором. Выполните команду show port capabilities для проверки для поддержки 802.1Q. Параметр инкапсуляции в выходных данных состояний команды show port capabilities поддержка 802.1Q транкинга.

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения


Document ID: 8759