Маршрутизаторы : Маршрутизаторы Cisco серии 800

Настройка маршрутизатора Cisco 827 как клиента PPPoE с NAT

20 октября 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Содержание


Введение

В Cisco Выпуск ПО IOS� 12.1 (3) XG, PPP over Ethernet (PPPoE) характеристика клиента была представлена для Маршрутизатора Cisco 827. Эта возможность позволяет перенести функции PPPoE в маршрутизатор. Множество персональных компьютеров можно установить за Cisco 827. Прежде чем их трафик передается Сеансу PPPoE, он может шифроваться, фильтроваться и т.д. Кроме того, Технология NAT может работать.

В этом документе показан клиент PPPoE настроенный на интерфейсе ATM (интерфейсе DSL) маршрутизатора Cisco 827. Эта конфигурация может также использоваться на маршрутизаторе Cisco 1700 с интерфейсной платой WAN (WIC) канала ADSL.

Конфигурацию процессора маршрутизации узла (NRP) на Cisco 6400 можно также использовать на другом маршрутизаторе, который служит собирающим устройством и имеет ATM-интерфейс.

Предварительные условия

Требования

Для этого документа отсутствуют особые требования.

Используемые компоненты

Настоящий документ не имеет жесткой привязки к каким-либо конкретным версиям программного обеспечения и оборудования.

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Технические рекомендации Cisco. Условные обозначения.

Настройка

В этом разделе приводятся сведения о настройке функций, описанных в данном документе.

Примечание: Дополнительные сведения о командах, использованных в данном документе, см. в разделе Средство поиска команд (только для зарегистрированных клиентов).

Схема сети

В настоящем документе используется следующая схема сети:

/image/gif/paws/8514/827pppoe_client.gif

Конфигурации

Эти конфигурации используются в данном документе:

PPPoE настроен на Маршрутизаторе Cisco 827 с командами Virtual Private Dial Network (VPDN). Удостоверьтесь, что вы настраиваете эти команды сначала.

Примечание: Для получения информации о том, как изменить размер максимального размера передаваемого блока данных (MTU), обратитесь к Устранению проблем Максимального размера передаваемого блока данных в Возможности внешнего подключения по телефонной линии PPPoE.

Маршрутизатор Cisco 827
! 
vpdn enable 
no vpdn logging

!--- This is the default.

! 
vpdn-group pppoe 
 request-dialin     
 
!--- This is the PPPoE client that requests to establish a session  
 !--- with the aggregation unit (6400 NRP). 
 
  protocol pppoe 
! 


!--- This is the Internal Ethernet network.
 
! 
interface Ethernet0 
 ip address 10.92.1.182 255.255.255.0 
 ip nat inside 
  


!--- The DSL interface.
 
! 
interface ATM0 
 no ip address 
 no atm ilmi-keepalive
 bundle-enable
 dsl operating-mode auto
 hold-queue 224 in
 
!--- All defaults.

  


!--- PPPoE runs on top of AAL5SNAP. However, the 
!--- encap aal5snap command is not used.
  
! 
interface ATM0.1 point-to-point 
 pvc 1/1 
  pppoe-client dial-pool-number 1 
  
!--- pvc 1/1 is an example value that must be changed 
  !--- in order to match the value used by the ISP. 

 ! 



!--- The PPPoE client code ties into a dialer interface upon  
!--- which a virtual-access interface is cloned.  

! 
interface Dialer1 
 ip address negotiated 
 ip mtu 1492
 
!--- Ethernet MTU is 1500 by default -- 1492 + PPPoE headers = 1500

 ip nat outside 
 encapsulation ppp 
 dialer pool 1
 
!--- Ties to ATM interface.
  
 ppp authentication chap callin 
 ppp chap hostname <username> 
 ppp chap password <password> 
! 

!--- Note: The ISP  instructs you  about the 
!--- type of authentication to use. 
!--- In order to change from PPP CHAP to PPP PAP, replace
!--- ppp authentication chap callin 
!--- ppp chap hostname <username> 
!--- ppp chap password <password>   
!--- with ppp authentication pap callin
!--- ppp pap sent-username <username> password <password>




!--- For NAT, overload on the Dialer1 interface 
!--- and add a default route out since dialer IP address can change. 
  
ip nat inside source list 1 interface Dialer1 overload 
ip classless 
ip route 0.0.0.0 0.0.0.0 dialer1 
no ip http server 
! 
access-list 1 permit 10.92.1.0 0.0.0.255

!--- For NAT.

! 

Cisco 6400 NRP
*** local ppp user 

!--- Or,  use AAA.


username <username> password <password>



!--- Begin with the VPDN commands. 
!--- Notice that the PPPoE is bound here to 
!--- a virtual-template instead of on the ATM interface. 
!--- You cannot (at this time) use more than one 
!--- virtual-template (or VPDN group) for PPPoE that begins  
!--- with the VPDN commands. 

vpdn enable 
no vpdn logging 
! 
vpdn-group pppoe 
 accept-dialin
 
!--- PPPoE server mode.
 
  protocol pppoe 
  virtual-template 1 
! 
! 
interface ATM0/0/0 
 no ip address 
 no atm ilmi-keepalive 
 hold-queue 500 in 



!--- The binding to the virtual-template 
!--- interface is configured in the VPDN group.
  
! 
interface ATM0/0/0.182 point-to-point 
 pvc 1/82 
  encapsulation aal5snap
  
!--- Needs the command on the server side. 

  protocol pppoe 
 ! 
! 



!--- Virtual-template is used instead of dialer interface.
 
! 
interface Virtual-Template1 
 ip unnumbered Loopback10 
 ip mtu 1492 
 peer default ip address pool ippool 
 ppp authentication chap 
! 
! 
interface Loopback10 
 ip address 8.8.8.1 255.255.255.0 
! 
ip local pool ippool 9.9.9.1 9.9.9.5 

Проверка

В настоящее время для этой конфигурации нет процедуры проверки.

Устранение неполадок

В этом разделе описывается процесс устранения неполадок конфигурации.

Некоторые команды show поддерживаются Средством интерпретации выходных данных(только зарегистрированные клиенты), которое позволяет просматривать аналитику выходных данных команды show.

Примечание: Прежде чем применять команды отладки, ознакомьтесь с разделом "Важные сведения о командах отладки".

Отладьте PPPoE-клиент

Для отладки PPPoE-клиента на Маршрутизаторе Cisco 827 или Cisco NRP серии 6400, необходимо рассмотреть стек протоколов. Можно начать устранять неполадки в нижней части.

1. Физический уровень DSL

Убедитесь что линия функционирует и подготовлена.

show interface atm0 

ATM0 is up, line protocol is up 
  Hardware is PQUICC_SAR (with Alcatel ADSL Module) 
 
show dsl interface atm0 

!--- Look for "Showtime" in the first few lines.


                ATU-R (DS)                      ATU-C (US) 
Modem Status:    Showtime (DMTDSL_SHOWTIME) 

2. Уровень ATM

Если ATM-интерфейс подключен, используйте команду debug atm packets, чтобы видеть, входит ли что-нибудь от интернет-провайдера.

Примечание: При использовании этой команды исходящие пакеты не видны из-за способа их обработки.

Выходные данные должны быть аналогичны следующим данным: в полях типа, SAP, CTL и OUI должен отображаться входящий пакет ATM AAL5SNAP.

debug atm packet 
03:21:32: ATM0(I): 
VCD:0x2 VPI:0x1 VCI:0x1 Type:0x0 SAP:AAAA CTL:03 OUI:0080C2 
TYPE:0007 Length:0x30 
03:21:32: 0000 0050 7359 35B7 0001 96A4 84AC 8864 1100 0001 
000E C021 09AB 000C 0235 
03:21:32: 279F 0000 0000 
03:21:32: 

3. Уровень Ethernet

Завершенные Фреймы Ethernet находятся в пакетах AAL5SNAP. Отсутствует команда debug Ethernet packet. Однако необходимо выполнить некоторые отладки VPDN для наблюдения кадров PPPoE.

Для ссылки Фрейм Ethernet, который является кадром PPPoE, содержит один из двух Ethertype:

  • 0x8863 Ethertype = пакет управления PPPoE (обрабатывает сеанс PPPoE)

  • 0x8864 Ethertype = пакет данных PPPoE (содержит пакеты PPP)

Важное замечание: в PPPoE используются два сеанса. Сеанс PPPoE, являющийся VPDN L2TP типом сеанса, и PPP сеанс. Поэтому для установления PPPoE, у вас есть Фаза установления сеанса PPPoE и этап установления сеанса PPP.

Завершение обычно включает фазу завершения PPP и фазу завершения PPPoE.

Установка фазы PPPoE состоит из идентификации PPPoE-клиента и сервера (MAC-адреса), и присвоение идентификатора сеанса. После того, как это завершено, нормальное установление ppp происходит точно так же, как любой другой PPP - подключение.

Для отладки используйте отладки PPPoE VPDN, чтобы помочь вам определять, успешен ли этап установки связи PPPoE.

#debug vpdn pppoe-events 

06:17:58: Sending PADI: vc=1/1

!--- A broadcast Ethernet frame (in  this case encapsulated in ATM) 
!--- that requests  a PPPoE server, "Are there any PPPoE servers out there?" 


06:18:00:  PPPOE: we've got our pado and the pado timer went off 

!--- This is a unicast reply from a PPPoE server 
!--- (very similar to a DHCP offer).


06:18:00: OUT PADR from PPPoE tunnel

!--- This is a unicast reply that accepts the offer.


06:18:00: IN PADS from PPPoE tunnel

!--- This is a confirmation and the establishment completes.

Установление соединения PPP начинается как в любой другой инициации PPP. После того, как Сеанс PPPoE установлен, используйте команды show vpdn для получения статуса.

#show vpdn
%No active L2TP tunnels 
%No active L2F tunnels 

PPPoE Tunnel and Session Information Total tunnels 1 sessions 1

PPPoE Tunnel Information

Session count: 1

PPPoE Session Information
SID  RemMAC           LocMAC      Intf  VASt  OIntf   VC 
1  0050.7359.35b7  0001.96a4.84ac  Vi1  UP     AT0    1   1

Можно получить сведения о количестве пакетов с помощью команды show vpdn session all.

show vpdn session all
%No active L2TP tunnels
%No active L2F tunnels

PPPoE Session Information Total tunnels 1 sessions 1

session id: 1
local MAC address: 0001.96a4.84ac, remote MAC address: 0050.7359.35b7 
virtual access interface: Vi1, outgoing interface: AT0, vc: 1/1 
    1656 packets sent, 1655 received, 24516 bytes sent, 24486 received

Другие команды отладки:

  • debug vpdn pppoe-data

  • debug pppoe-errors

  • debug pppoe-packets

Уровень PPP

После того, как Сеанс PPPoE был установлен, отладки PPP совпадают с для любого другого установления соединения PPP.

Применяются те же команды "debug ppp negotiation" и "debug ppp authentication". Вот пример выходных данных.

Примечание: В этой выборке имя хоста является "client1", и название удаленного Cisco NRP серии 6400 является "Nrp-b".

06:36:03: Vi1 PPP: Treating connection as a callout
06:36:03: Vi1 PPP: Phase is ESTABLISHING, Active Open [0 sess, 1 load]
06:36:03: Vi1 PPP: No remote authentication for call-out
06:36:03: Vi1 LCP: O CONFREQ [Closed] id 1 len 10
06:36:03: Vi1 LCP:    MagicNumber 0x03013D43 (0x050603013D43) 
06:36:03: Vi1 LCP: I CONFACK [REQsent] id 1 len 10
06:36:03: Vi1 LCP:    MagicNumber 0x03013D43 (0x050603013D43) 
06:36:05: Vi1 LCP: I CONFREQ [ACKrcvd] id 2 len 15
06:36:05: Vi1 LCP:    AuthProto CHAP (0x0305C22305)
06:36:05: Vi1 LCP:    MagicNumber 0x65E315E5 (0x050665E315E5) 
06:36:05: Vi1 LCP: O CONFACK [ACKrcvd] id 2 len 15
06:36:05: Vi1 LCP:    AuthProto CHAP (0x0305C22305)
06:36:05: Vi1 LCP:    MagicNumber 0x65E315E5 (0x050665E315E5) 
06:36:05: Vi1 LCP: State is Open
06:36:05: Vi1 PPP: Phase is AUTHENTICATING, by the peer [0 sess, 1 load]
06:36:05: Vi1 CHAP: I CHALLENGE id 9 len 26 from "nrp-b" 
06:36:05: Vi1 CHAP: Using alternate hostname client1
06:36:05: Vi1 CHAP: Username nrp-b not found
06:36:05: Vi1 CHAP: Using default password
06:36:05: Vi1 CHAP: O RESPONSE id 9 len 28 from "client1"
06:36:05: Vi1 CHAP: I SUCCESS id 9 len 4
06:36:05: Vi1 PPP: Phase is FORWARDING [0 sess, 1 load]
06:36:05: Vi1 PPP: Phase is AUTHENTICATING [0 sess, 1 load]
06:36:05: Vi1 PPP: Phase is UP [0 sess, 1 load]
06:36:05: Vi1 IPCP: O CONFREQ [Closed] id 1 len 10
06:36:05: Vi1 IPCP:    Address 0.0.0.0 (0x030600000000)
06:36:05: Vi1 CDPCP: O CONFREQ [Closed] id 1 len 4
06:36:05: Vi1 IPCP: I CONFREQ [REQsent] id 1 len 10
06:36:05: Vi1 IPCP:    Address 8.8.8.1 (0x030608080801)
06:36:05: Vi1 IPCP:    Address 8.8.8.1 (0x030608080801)
06:36:05: Vi1 IPCP:    Address 9.9.9.2 (0x030609090902)
06:36:05: Vi1 IPCP: O CONFREQ [ACKsent] id 2 len 10
06:36:05: Vi1 IPCP:    Address 9.9.9.2 (0x030609090902)
06:36:05: Vi1 LCP: I PROTREJ [Open] id 3 len 10 protocol CDPCP (0x820701010004) 
06:36:05: Vi1 CDPCP: State is Closed
06:36:05: Vi1 IPCP: I CONFACK [ACKsent] id 2 len 10
06:36:05: Vi1 IPCP:    Address 9.9.9.2 (0x030609090902)
06:36:05: Vi1 IPCP: State is Open
06:36:05: Di1 IPCP: Install negotiated IP interface address 9.9.9.2
06:36:05: Di1 IPCP: Install route to 8.8.8.1
06:36:06: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access1, 
changed state to up

Отладьте сервер PPPoE

Для отладки Cisco 6400 (сервер PPPoE), используйте ту же восходящую процедуру, используемую для Маршрутизатора Cisco 827 (клиент). Различие находится на физическом уровне DSL, где необходимо проверить Мультиплексор доступа DSL (DSLAM).

1. Физический уровень DSL

Для проверки физического уровня DSL необходимо видеть статистику DSL по DSLAM. Для Cisco DSLAMs используйте команду show dsl interface.

2. Уровень ATM

На стороне Cisco 6400 можно также использовать команду debug atm packet и включить Cisco 6400 для определенной постоянной виртуальной цепи (PVC).

debug atm packet interface atm 0/0/0.182 vc 1/82

Выходные данные должны быть аналогичны следующим данным: в полях типа, SAP, CTL и OUI должен отображаться входящий пакет ATM AAL5SNAP.

4d04h: ATM0/0/0.182(I):
VCD:0x3 VPI:0x1 VCI:0x52 Type:0x900 SAP:AAAA CTL:03 OUI:0080C2 TYPE:0007 Length:0x30
4d04h: 0000 0001 96A4 84AC 0050 7359 35B7 8864 1100 0001 000E C021 0A2E 000C 65E3
4d04h: 15E5 0000 0000

Примечание: При использовании этой команды исходящие пакеты не видны из-за способа их обработки.

3. Уровень Ethernet

Те же команды показа VPDN и отладки, используемые на Маршрутизаторе Cisco 827, могут использоваться на Cisco NRP серии 6400 для рассмотрения установления соединения PPPoE.

#debug vpdn pppoe-events

4d04h: IN PADI from PPPoE tunnel

4d04h: OUT PADO from PPPoE tunnel

4d04h: IN PADR from PPPoE tunnel

4d04h: PPPoE: Create session
4d04h: PPPoE: VPN session created.

4d04h: OUT PADS from PPPoE tunnel
#show vpdn
%No active L2TP tunnels
%No active L2F tunnels

PPPoE Tunnel and Session Information Total tunnels 1 sessions 1

PPPoE Tunnel Information

Session count: 1
PPPoE Session Information
SID        RemMAC          LocMAC       Intf    VASt   OIntf    VC
1       0001.96a4.84ac  0050.7359.35b7  Vi4     UP     AT0/0/0 1    82
nrp-b#show vpdn session all
%No active L2TP tunnels
%No active L2F tunnels

PPPoE Session Information Total tunnels 1 sessions 1
 
session id: 1
local MAC address: 0050.7359.35b7, remote MAC address: 0001.96a4.84ac
virtual access interface: Vi4, outgoing interface: AT0/0/0, vc: 1/82
    30 packets sent, 28 received, 422 bytes sent, 395 received

Другие команды отладки:

  • debug vpdn pppoe-data

  • debug pppoe-errors

  • debug pppoe-packets

4. Уровень PPP

Это - выходные данные отладки PPP от Cisco NRP серии 6400, который соответствует более ранней отладке от Маршрутизатора Cisco 827.

debug ppp negotiation and debug ppp authentication
4d04h: Vi2 PPP: Treating connection as a dedicated line 
4d04h: Vi2 PPP: Phase is ESTABLISHING, Active Open [0 sess, 1 load] 
4d04h: Vi2 LCP: O CONFREQ [Closed] id 1 len 15 
4d04h: Vi2 LCP:    AuthProto CHAP (0x0305C22305) 
4d04h: Vi2 LCP:    MagicNumber 0x65F62814 (0x050665F62814) 
4d04h: Vi2 LCP: I CONFREQ [REQsent] id 1 len 10 
4d04h: Vi2 LCP:    MagicNumber 0x03144FF9 (0x050603144FF9) 
4d04h: Vi2 LCP: O CONFACK [REQsent] id 1 len 10 
4d04h: Vi2 LCP:    MagicNumber 0x03144FF9 (0x050603144FF9) 
4d04h: Vi3 LCP: I ECHOREQ [Open] id 60 len 8 magic 0xA60C0000 
4d04h: Vi3 LCP: O ECHOREP [Open] id 60 len 8 magic 0x51A0BEF6 
4d04h: Vi2 LCP: TIMEout: State ACKsent 
4d04h: Vi2 LCP: O CONFREQ [ACKsent] id 2 len 15 
4d04h: Vi2 LCP:    AuthProto CHAP (0x0305C22305) 
4d04h: Vi2 LCP:    MagicNumber 0x65F62814 (0x050665F62814) 
4d04h: Vi2 LCP: I CONFACK [ACKsent] id 2 len 15 
4d04h: Vi2 LCP:    AuthProto CHAP (0x0305C22305) 
4d04h: Vi2 LCP:    MagicNumber 0x65F62814 (0x050665F62814) 
4d04h: Vi2 LCP: State is Open 
4d04h: Vi2 PPP: Phase is AUTHENTICATING, by this end [0 sess, 1 load] 
4d04h: Vi2 CHAP: O CHALLENGE id 10 len 26 from "nrp-b" 
4d04h: Vi2 CHAP: I RESPONSE id 10 len 28 from "client1" 
4d04h: Vi2 PPP: Phase is FORWARDING [0 sess, 1 load] 
4d04h: Vi2 PPP: Phase is AUTHENTICATING [0 sess, 1 load] 
4d04h: Vi2 CHAP: O SUCCESS id 10 len 4 
4d04h: Vi2 PPP: Phase is UP [0 sess, 1 load] 
4d04h: Vi2 IPCP: O CONFREQ [Closed] id 1 len 10 
4d04h: Vi2 IPCP:    Address 8.8.8.1 (0x030608080801) 
4d04h: Vi2 IPCP: I CONFREQ [REQsent] id 1 len 10 
4d04h: Vi2 IPCP:    Address 0.0.0.0 (0x030600000000) 
4d04h: Vi2 IPCP: Pool returned 9.9.9.2 
4d04h: Vi2 IPCP: O CONFNAK [REQsent] id 1 len 10 
4d04h: Vi2 IPCP:    Address 9.9.9.2 (0x030609090902) 
4d04h: Vi2 CDPCP: I CONFREQ [Not negotiated] id 1 len 4 
4d04h: Vi2 LCP: O PROTREJ [Open] id 3 len 10 protocol CDPCP (0x820701010004) 
4d04h: Vi2 IPCP: I CONFACK [REQsent] id 1 len 10 
4d04h: Vi2 IPCP:    Address 8.8.8.1 (0x030608080801) 
4d04h: Vi2 IPCP: I CONFREQ [ACKrcvd] id 2 len 10 
4d04h: Vi2 IPCP:    Address 9.9.9.2 (0x030609090902) 
4d04h: Vi2 IPCP: O CONFACK [ACKrcvd] id 2 len 10 
4d04h: Vi2 IPCP:    Address 9.9.9.2 (0x030609090902) 
4d04h: Vi2 IPCP: State is Open 
4d04h: Vi2 IPCP: Install route to 9.9.9.2 
4d04h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access2, 
changed state to up 

Дополнительные сведения


Document ID: 8514