5 апреля 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Интерактивно этот документ предлагает анализ конкретного устройства Cisco.


Содержание


Введение

Типичной проблемой при использовании OSPF является отсутствие маршрутов из базы данных в таблице маршрутизации. Чаще всего OSPF обнаруживает противоречие в базе данных и не устанавливает маршрут в таблице. При возникновении этой проблемы в базе данных часто можно видеть сообщение Adv Router is not reachable (означающее, что маршрутизатор, объявляющий LSA, недоступен через OSPF) над описанием локального состояния соединений (LSA). Например:

Adv Router is not-reachable
LS age: 418
Options: (No TOS-capability, DC)
LS Type: Router Links
Link State ID: 172.16.32.2
Advertising Router: 172.16.32.2
LS Seq Number: 80000002
Checksum: 0xFA63
Length: 60
 Number of Links: 3

Существует несколько причин для этой проблемы, большинство которых имеет дело с неверной конфигурацией или сломанной топологией. Когда конфигурация исправлена, несоответствие базы данных OSPF уходит, и маршруты появляются в таблице маршрутизации. Этот документ объясняет некоторые из большего количества обычных причин, которые могут вызвать несоответствие в базе данных.

Некоторые команды, используемые всюду по этому документу для проверки поведения OSPF, включают show ip ospf interface, IP маршрутизатор базы данных ospf, show ip ospf neighbor и внешнего show ip ospf database. Если у вас есть выходные данные какой-либо из этих команд от устройства Сisco, можно использовать для получения наглядной информации о возможных проблемах и способах их устранения. Для работы с необходимо быть зарегистрированным пользователем, войти в систему и включить поддержку JavaScript.

Предварительные условия

Требования

Для использования данного документа требуется знание следующих тем

Используемые компоненты

Сведения, содержащиеся в данном документе, касаются следующих версий программного и аппаратного обеспечения:

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в этом документе, были запущены с чистой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд до их использования.

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Технические рекомендации Cisco. Условные обозначения.

Причина 1: Несоответствие типа сети

Давайте использовать следующую схему сети в качестве примера:

/image/gif/paws/7112/26a.gif

R4-4K R1-7010
interface Loopback0
 ip address 172.16.33.1 255.255.255.255

interface Serial2
 ip address 172.16.32.1 255.255.255.0
 ip ospf network broadcast

router ospf 20
 network 172.16.0.0 0.0.255.255 area 0
interface Loopback0
 ip address 172.16.30.1 255.255.255.255
!
interface Serial1/0
 ip address 172.16.32.2 255.255.255.0
 clockrate 64000

router ospf 20
 network 172.16.0.0 0.0.255.255 area 0

R4-4K(4)# show ip ospf interface serial 2
Serial2 is up, line protocol is up 
  Internet Address 172.16.32.1/24, Area 0 
  Process ID 20, Router ID 172.16.33.1, Network Type BROADCAST, Cost: 64
  Transmit Delay is 1 sec, State DR, Priority 1 
  Designated Router (ID) 172.16.33.1, Interface address 172.16.32.1
  Backup Designated router (ID) 172.16.32.2, Interface address 172.16.32.2
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    Hello due in 00:00:08
  Neighbor Count is 1, Adjacent neighbor count is 1 
    Adjacent with neighbor 172.16.32.2  (Backup Designated Router)
  Suppress hello for 0 neighbor(s)

R1-7010(5)# show ip ospf interface serial 1/0
Serial1/0 is up, line protocol is up 
  Internet Address 172.16.32.2/24, Area 0 
  Process ID 20, Router ID 172.16.32.2, Network Type POINT_TO_POINT, Cost: 64
  Transmit Delay is 1 sec, State POINT_TO_POINT,
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    Hello due in 00:00:02
  Neighbor Count is 1, Adjacent neighbor count is 1 
    Adjacent with neighbor 172.16.33.1
  Suppress hello for 0 neighbor(s)

Как вы можете видеть выше, Маршрутизатор R4-4K настроен для широковещания, и Маршрутизатор R1-7010 настроен для точка-точка. Этот вид несоответствия типа сети делает объявляющий маршрутизатор недостижимым.

R4-4K(4)# show ip ospf database router 172.16.32.2

  Adv Router is not-reachable
  LS age: 418
  Options: (No TOS-capability, DC)
  LS Type: Router Links
  Link State ID: 172.16.32.2
  Advertising Router: 172.16.32.2
  LS Seq Number: 80000002
  Checksum: 0xFA63
  Length: 60
   Number of Links: 3

    Link connected to: another Router (point-to-point)
    (Link ID) Neighboring Router ID: 172.16.33.1
    (Link Data) Router Interface address: 172.16.32.2
    Number of TOS metrics: 0
    TOS 0 Metrics: 64

    Link connected to: a Stub Network
    (Link ID) Network/subnet number: 172.16.32.0
    (Link Data) Network Mask: 255.255.255.0
    Number of TOS metrics: 0
    TOS 0 Metrics: 64

R1-7010(5)# show ip ospf database router 172.16.33.1

  Adv Router is not-reachable
  LS age: 357
  Options: (No TOS-capability, DC)
  LS Type: Router Links
  Link State ID: 172.16.33.1
  Advertising Router: 172.16.33.1
  LS Seq Number: 8000000A
  Checksum: 0xD4AA
  Length: 48
   Number of Links: 2

     Link connected to: a Transit Network
     (Link ID) Designated Router address: 172.16.32.1
     (Link Data) Router Interface address: 172.16.32.1
     Number of TOS metrics: 0
     TOS 0 Metrics: 64

Вы видите, что для подсети 172.16.32.0/24, Маршрутизатор R1-7010 генерирует канал типа точка-точка, и Маршрутизатор R4-4K генерирует транзитное соединение. Это создает несоответствие в базе данных состояний соединениий, что означает, что никакие маршруты не установлены в таблице маршрутизации.

R1-7010(5)# show ip route
172.16.0.0/16 is variably subnetted, 3 subnets, 2 masks
C       172.16.32.0/24 is directly connected, Serial1/0
C       172.16.30.1/32 is directly connected, Loopback0

Решение

Для решения этой проблемы настройте оба маршрутизатора для того же типа сети. Можно или изменить тип сети Маршрутизатора R1-7010, чтобы передать, или изменить последовательный интерфейс R4-4K's Маршрутизатора на точка-точка.

Примечание: Если у вас есть ситуация, где одна сторона является многоточечным интерфейсом, и другая сторона является подчиненным интерфейсом, тогда изменяют тип сети для радиовещания с обеих сторон.

В данном примере мы удалили "широковещательный оператор" network-type на R4-4K, потому что обе стороны являются инкапсулированными интерфейсами High-Level Data Link Control (HDLC) "точка-точка".

R4-4K(4)# configure terminal 
R4-4K(4)(config)# interface serial 2 
R4-4K(4)(config-if)# no ip ospf network broadcast 
R4-4K(4)(config-if)# end

R4-4K(4)# show ip ospf interface serial 2
 Serial2 is up, line protocol is up 
  Internet Address 172.16.32.1/24, Area 0 
  Process ID 20, Router ID 172.16.33.1, Network Type POINT_TO_POINT, Cost: 64
  Transmit Delay is 1 sec, State POINT_TO_POINT,
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
   Hello due in 00:00:04
  Neighbor Count is 1, Adjacent neighbor count is 1 
  Adjacent with neighbor 172.16.32.2
  Suppress hello for 0 neighbor(s)

Причина 2: неверное назначение адреса в настройке сдвоенного последовательного канала

Рассмотрите эту схему сети как пример:

/image/gif/paws/7112/26b.gif

R4-4K R1-7010
interface loopback 0
 ip address 172.16.35.1 255.255.255.255

interface Serial2
 ip address 172.16.29.1 255.255.255.0
!
interface Serial3
 ip address 172.16.32.1 255.255.255.0

router ospf 20
 network 172.16.0.0 0.0.255.255 area 0
interface loopback 0
 ip address 172.16.30.1 255.255.255.255

interface Serial1/0
 ip address 172.16.32.2 255.255.255.0
 clockrate 64000
!
interface Serial1/1
 ip address 172.16.29.2 255.255.255.0
 clockrate 38400

router ospf 20
 network 172.16.0.0 0.0.255.255 area 0

Вы видите, что IP-адреса зеркально отражены в вышеупомянутых конфигурациях, который вызывает несоответствие в базе данных OSPF. Однако маршрутизаторы все еще формируют соседние узлы в версии Cisco IOS ранее, чем 12.1, потому что на канале типа точка-точка, маршрутизаторы OSPF не проверяют, что соседний маршрутизатор находится в той же подсети.

R4-4K(4)# show ip ospf neighbor

Neighbor ID     Pri   State           Dead Time   Address         Interface
172.16.32.2       1   FULL/  -        00:00:37    172.16.32.2     Serial2
172.16.32.2       1   FULL/  -        00:00:31    172.16.29.2     Serial3

От вышеупомянутых выходных данных вы видите, что Serial2 формирует соседние узлы с IP-адресом 172.16.32.2, который не находится в той же подсети. Несмотря на то, что соседние узлы сформированы, никакие маршруты не установлены в таблице маршрутизации:

R1-7010(5)# show ip route
172.16.0.0/16 is variably subnetted, 3 subnets, 2 masks
C       172.16.32.0/24 is directly connected, Serial1/0
C       172.16.29.0/24 is directly connected, Serial1/1
C       172.16.30.1/32 is directly connected, Loopback0

Решение

Для решения этой проблемы, или правильно назначают IP-адреса или коммутируют кабели последовательного порта. Здесь мы исправили IP-адреса:

R4-4K R1-7010
interface loopback 0
 ip address 172.16.35.1 255.255.255.255

interface Serial2
 ip address 172.16.32.1 255.255.255.0
!
interface Serial3
 ip address 172.16.29.1 255.255.255.0

router ospf 20
 network 172.16.0.0 0.0.255.255 area 0
interface loopback 0
 ip address 172.16.30.1 255.255.255.255

interface Serial1/0
 ip address 172.16.32.2 255.255.255.0
 clockrate 64000
!
interface Serial1/1
 ip address 172.16.29.2 255.255.255.0
 clockrate 38400

router ospf 20
 network 172.16.0.0 0.0.255.255 area 0

R4-4K(4)# show ip ospf neighbor

Neighbor ID     Pri   State           Dead Time   Address         Interface
172.16.32.2       1   FULL/  -        00:00:36    172.16.32.2     Serial2
172.16.32.2       1   FULL/  -        00:00:39    172.16.29.2     Serial3

Теперь это показывает корректный адрес соседа на Последовательных 2 интерфейсах. Маршруты находятся также в таблице маршрутизации:

R1-7010(5)# show ip route
172.16.0.0/16 is variably subnetted, 4 subnets, 2 masks
C       172.16.32.0/24 is directly connected, Serial1/0
O       172.16.35.1/32 [110/65] via 172.16.32.1, 00:03:12, Serial1/0
                       [110/65] via 172.16.29.1, 00:03:12, Serial1/1
C       172.16.29.0/24 is directly connected, Serial1/1
C       172.16.30.1/32 is directly connected, Loopback0

Причина 3: Одно из соединений точка–точка включено в неправильную основную сеть или подсеть

Рассмотрите эту схему сети как пример:

/image/gif/paws/7112/26c.gif

Эта ситуация создает точно то же поведение как Неверное назначение адреса в Настройке Сдвоенного последовательного канала. Для решения проблемы назначьте IP-адреса в той же подсети на обоих маршрутизаторах.

Причина 4: Одна сторона не нумерована, а другая – нумерована

Рассмотрите следующую схему сети как пример:

/image/gif/paws/7112/unnum.gif

R4-4K R1-7010
interface Loopback0
 ip address 172.16.35.1 255.255.255.255

interface Serial2
 ip unnumbered Loopback0
 router ospf 20
 network 172.16.0.0 0.0.255.255 area 0
interface Loopback0
 ip address 172.16.30.1 255.255.255.255
!
interface Serial1/0
 ip address 172.16.32.2 255.255.255.0
 clockrate 64000

router ospf 20
 network 172.16.0.0 0.0.255.255 area 0

R4-4K(4)# show interface serial 2
Serial2 is up, line protocol is up 
  Hardware is cxBus Serial
  Interface is unnumbered.  Using address of Loopback0 (172.16.35.1)

R1-7010(5)# show interface serial 1/0
Serial1/0 is up, line protocol is up 
  Hardware is cxBus Serial
  Internet address is 172.16.32.2/24

Выходные данные выше показов, что Последовательные 2 интерфейса R4-4K являются ненумерованными к Loopback0, тогда как Последовательный 1/0 R1-7010 является нумерованным интерфейсом.

R4-4K(4)# show ip ospf interface serial 2
Serial2 is up, line protocol is up 
  Internet Address 0.0.0.0/24, Area 0 
  Process ID 20, Router ID 172.16.35.1, Network Type POINT_TO_POINT, Cost: 64
  Transmit Delay is 1 sec, State POINT_TO_POINT,
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    Hello due in 00:00:02
  Neighbor Count is 1, Adjacent neighbor count is 1 
    Adjacent with neighbor 172.16.32.2
  Suppress hello for 0 neighbor(s)

R1-7010(5)# show ip ospf interface serial 1/0
Serial1/0 is up, line protocol is up 
  Internet Address 172.16.32.2/24, Area 0 
  Process ID 20, Router ID 172.16.32.2, Network Type POINT_TO_POINT, Cost: 64
  Transmit Delay is 1 sec, State POINT_TO_POINT,
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    Hello due in 00:00:02
  Neighbor Count is 1, Adjacent neighbor count is 1 
    Adjacent with neighbor 172.16.33.1
  Suppress hello for 0 neighbor(s)

Как вы можете видеть выше, network-type в обоих случаях является точка-точка. Проблема состоит в том, что одна сторона является ненумерованной, и другая сторона не, который создает несоответствие в базе данных как показано ниже.

R4-4K(4)# show ip ospf database router 172.16.30.1

  OSPF Router with ID (172.16.35.1) (Process ID 20)
 Router Link States (Area 0)
 LS age: 202
     Options: (No TOS-capability, DC)
     LS Type: Router Links
     Link State ID: 172.16.30.1
     Advertising Router: 172.16.30.1
     LS Seq Number: 80000002
     Checksum: 0xC899
     Length: 60
     Number of Links: 3
 Link connected to: another Router (point-to-point)
     (Link ID) Neighboring Router ID: 172.16.35.1
     (Link Data) Router Interface address: 172.16.32.2
     Number of TOS metrics: 0
     TOS 0 Metrics: 64
 Link connected to: a Stub Network
     (Link ID) Network/subnet number: 172.16.32.0
     (Link Data) Network Mask: 255.255.255.0
     Number of TOS metrics: 0
     TOS 0 Metrics: 64
 Link connected to: a Stub Network
     (Link ID) Network/subnet number: 172.16.30.1
     (Link Data) Network Mask: 255.255.255.255
     Number of TOS metrics: 0
     TOS 0 Metrics: 1

     R4-4k(4)#
    
R1-7010(5)# show ip ospf database router 172.16.35.1

OSPF Router with ID (172.16.30.1) (Process ID 20)
     Router Link States (Area 0)
 Adv Router is not-reachable
     LS age: 396
     Options: (No TOS-capability, DC)
     LS Type: Router Links
     Link State ID: 172.16.35.1
     Advertising Router: 172.16.35.1
     LS Seq Number: 80000003
     Checksum: 0xBEA1
     Length: 48
     Number of Links: 2
 Link connected to: another Router (point-to-point)
     (Link ID) Neighboring Router ID: 172.16.30.1
     (Link Data) Router Interface address: 0.0.0.3

          
!--- In case of an unnumbered link we use MIB 
          !--- II IfIndex value which usually starts with 0.

          
     Number of TOS metrics: 0
     TOS 0 Metrics: 64
 Link connected to: a Stub Network
     (Link ID) Network/subnet number: 172.16.35.1
     (Link Data) Network Mask: 255.255.255.255
     Number of TOS metrics: 0
     TOS 0 Metrics: 1

     R1-7010(5)#

Вы видите, что R1-7010 генерирует LSA для этого канала типа точка-точка с полем Link Data, содержащим его интерфейсный адрес, в то время как R4-4K генерирует LSA для той же ссылки с полем Link Data, содержащим значение IfIndex MIBII. Это создает несоответствие в базе данных состояний соединениий, что означает, что никакие маршруты не установлены в таблице маршрутизации.

R1-7010(5)# show ip route
172.16.0.0/16 is variably subnetted, 3 subnets, 2 masks
C       172.16.32.0/24 is directly connected, Serial1/0
C       172.16.30.1/32 is directly connected, Loopback0

Решение

Для решения этой проблемы настройте последовательные интерфейсы обоих маршрутизаторов или как пронумерованные или как ненумерованные. В данном примере мы пронумеровали последовательные 2 интерфейса маршрутизатора R4-4K.

R4-4K(4)# configure terminal 
R4-4K(4)(config)# interface serial 2
R4-4K(4)(config-if)# no ip unnumbered loopback 0 
R4-4K(4)(config-if)# ip address 172.16.32.1 255.255.255.0

R4-4K(4))# show ip ospf interface serial 2
Serial2 is up, line protocol is up 
  Internet Address 172.16.32.1/24, Area 0 
  Process ID 20, Router ID 172.16.33.1, Network Type POINT_TO_POINT, Cost: 64
  Transmit Delay is 1 sec, State POINT_TO_POINT,
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    Hello due in 00:00:02
  Neighbor Count is 1, Adjacent neighbor count is 1 
    Adjacent with neighbor 172.16.32.2
  Suppress hello for 0 neighbor(s)

R1-7010(5)# show ip route
172.16.0.0/16 is variably subnetted, 3 subnets, 2 masks
C       172.16.32.0/24 is directly connected, Serial1/0
O       172.16.33.1/32 [110/65] via 172.16.32.1, 00:03:08, Serial1/0
C       172.16.30.1/32 is directly connected, Loopback0

Причина 5: Неисправная PVC в полносетчатой среде Frame Relay

Рассмотрите эту схему сети как пример:

/image/gif/paws/7112/26d.gif

R9-2500
interface Loopback0
 ip address 50.50.50.50 255.255.255.255
 !
interface Serial0
 ip address 10.10.10.5 255.255.255.0
 encapsulation frame-relay
 ip ospf network broadcast 
 frame-relay map ip 10.10.10.6 102 broadcast
 frame-relay map ip 10.10.10.7 101 broadcast

router ospf 10
 network 10.10.10.0 0.0.0.255 area 0
 network 50.50.50.0 0.0.0.255 area 0

R4-4K
interface Loopback0
 ip address 70.70.70.70 255.255.255.255
!
interface Serial0
 ip address 10.10.10.7 255.255.255.0
 encapsulation frame-relay
 ip ospf network broadcast
 frame-relay map ip 10.10.10.5 101 broadcast
 frame-relay map ip 10.10.10.6 100 broadcast

router ospf 10
 network 10.10.10.0 0.0.0.255 area 0
 network 70.70.70.0 0.0.0.255 area 0

R3-4K
interface Loopback0
 ip address 60.60.60.60 255.255.255.255
 !
interface Serial0
 no ip address
 encapsulation frame-relay
!
interface Serial0.1 multipoint
 ip address 10.10.10.6 255.255.255.0
 ip ospf network broadcast
 frame-relay map ip 10.10.10.5 102 broadcast
 frame-relay map ip 10.10.10.7 100 broadcast
!
router ospf 10
 network 10.10.10.0 0.0.0.255 area 0
 network 60.60.60.0 0.0.0.255 area 0

Модель трансляции по Frame Relay работает должным образом, пока Облако Frame Relay полностью поймано в сети. Если какие-либо постоянные виртуальные каналы (PVCs) сломаны, он может создать проблемы в базе данных OSPF, которая в свою очередь производит сообщение Adv router not reachable.

В данном примере, PVC между R9-2500 и R4-4K сломан, и ссылка R9-2500 на выделенный маршрутизатор (DR) сломана. В результате R9-2500 объявляет все LSA от R3-4K (который не является DR), как недостижимый. Как вы можете видеть R9-2500 не генерирует транзитное соединение для последовательного интерфейса, подключенного к R3-4K; это генерирует тупиковую ссылку вместо этого, потому что, насколько R9-2500 обеспокоен, что на этой ссылке нет никакого DR.

R9-2500(3)# show ip ospf database router

       OSPF Router with ID (50.50.50.50) (Process ID 10)
                Router Link States (Area 0)
  LS age: 148
  Options: (No TOS-capability, DC)
  LS Type: Router Links
  Link State ID: 50.50.50.50
  Advertising Router: 50.50.50.50
  LS Seq Number: 8000000B
  Checksum: 0x55A
  Length: 48
   Number of Links: 2

    Link connected to: a Stub Network
    (Link ID) Network/subnet number: 10.10.10.0
    (Link Data) Network Mask: 255.255.255.0
    Number of TOS metrics: 0
    TOS 0 Metrics: 64

    Link connected to: a Stub Network
    (Link ID) Network/subnet number: 50.50.50.50
    (Link Data) Network Mask: 255.255.255.255
    Number of TOS metrics: 0
    TOS 0 Metrics: 1

  Adv Router is not-reachable
  LS age: 1081
  Options: (No TOS-capability, DC)
  LS Type: Router Links
  Link State ID: 60.60.60.60
  Advertising Router: 60.60.60.60
  LS Seq Number: 80000006
  Checksum: 0x4F72
  Length: 48
   Number of Links: 2

    Link connected to: a Stub Network
    (Link ID) Network/subnet number: 60.60.60.60
    (Link Data) Network Mask: 255.255.255.255
    Number of TOS metrics: 0
    TOS 0 Metrics: 1

    Link connected to: a Transit Network
    (Link ID) Designated Router address: 10.10.10.7
    (Link Data) Router Interface address: 10.10.10.6
    Number of TOS metrics: 0
    TOS 0 Metrics: 64

          
  Adv Router is not-reachable
  LS age: 306
  Options: (No TOS-capability, DC)
  LS Type: Router Links
  Link State ID: 70.70.70.70
  Advertising Router: 70.70.70.70
  LS Seq Number: 80000007
  Checksum: 0xC185
  Length: 48
   Number of Links: 2

    Link connected to: a Stub Network
    (Link ID) Network/subnet number: 70.70.70.70
    (Link Data) Network Mask: 255.255.255.255
    Number of TOS metrics: 0
    TOS 0 Metrics: 1

    Link connected to: a Transit Network
    (Link ID) Designated Router address: 10.10.10.7
    (Link Data) Router Interface address: 10.10.10.7
    Number of TOS metrics: 0
    TOS 0 Metrics: 64

Обратитесь к проблемам с Рабочим OSPF в РЕЖИМЕ NBMA по Frame Relay для более подробной информации об этой проблеме.

Причина 6: Адрес пересылки, полученный с помощью внешнего маршрута

Рассмотрите эту схему сети как пример:

/image/gif/paws/7112/foradd.gif

R2507
interface Serial0
ip address 1.1.1.1 255.255.255.0
         
interface Serial1
ip address 7.7.7.1 255.255.255.0
         
router ospf 1
network 1.1.1.1 0.0.0.0 area 0
default- information originate metric 20
         
ip route 0.0.0.0 0.0.0.0 Serial1

R2504
interface Serial0
ip address 1.1.1.2 255.255.255.0
         
interface TokenRing0
ip address 3.3.4.2 255.255.255.0
         
router ospf 1
network 1.1.1.0 0.0.0.255 area 0
network 3.0.0.0 0.255.255.255 area 1
area 1 range 3.0.0.0 255.0.0.0

R2515
interface Serial1
ip address 4.4.4.3 255.255.255.0
       
interface TokenRing0
ip address 3.3.4.3 255.255.255.0
       
interface ethernet 0
ip address 3.44.66.3 255.255.255.0
       
interface ethernet 1
ip address 3.22.88.3 255.255.255.0
       
router ospf 1
redistribute rip metric 20 subnets
network 0.0.0.0 255.255.255.255 area 1
       
router rip
network 3.0.0.0

R2513
interface TokenRing0
ip address 3.3.4.4 255.255.255.0
       
interface ethernet 0
ip address 200.1.1.4 255.255.255.0
       
router rip
network 3.0.0.0
network 200.1.1.0

R2507# show ip ospf data external 200.1.1.0
       OSPF Router with ID (7.7.7.1) (Process ID 1)
       Type- 5 AS External Link States
       LS age: 72
       Options: (No TOS- capability, DC)
       LS Type: AS External Link
       Link State ID: 200.1.1.0 (External Network Number )
       Advertising Router: 3.44.66.3
       LS Seq Number: 80000001
       Checksum: 0xF161
       Length: 36
       Network Mask: /24
                   Metric Type: 2 (Larger than any link state path)
                   TOS: 0
                   Metric: 20
                   Forward Address: 3.3.4.4
                   External Route Tag: 0

R2507 имеет 200.1.1.0/24 в своей базе данных, но это не установило его в таблице маршрутизации, потому что 3.3.4.4 изучен через внешний маршрут OSPF.

R2507# show ip route 3.3.4.4
       Routing entry for 3.3.4.0/ 24
       Known via "ospf 1", distance 110, metric 20,type extern 2, forward metric 70
       Redistributing via ospf 1
       Last update from 1.1.1.2 on Serial0, 00: 00: 40 ago
       Routing Descriptor Blocks:
       * 1.1.1.2, from 3.44.66.3, 00: 00: 40 ago, via Serial0
          Route metric is 20, traffic share count is 1

Примечание: С исправлением идентификатора ошибки Cisco CSCdp72526 (только зарегистрированные клиенты) OSPF не генерирует описание локального состояния соединениий (LSA) type-5 перекрытой внешней сети; поэтому, R2507 будет только иметь итоговый внутриобластной маршрут 3.0.0.0/8. Затем R2507 установит 200.1.1.0/24 как адрес пересылки, и это будет достижимо через внутриобластной маршрут 3.0.0.0/8, таким образом в соответствии с RFC 2328 leavingcisco.com.

После устранения вышеупомянутой ошибки на выходе получим следующее:

R2507# show ip route 3.3.4.4
      Routing entry for 3.0.0.0/8
      Known via "ospf 1", distance 110, metric 74, type inter area
      Last update from 1.1.1.2 on Serial0, 00:19:20 ago
      Routing Descriptor Blocks:
      * 1.1.1.2, from 3.3.4.2, 00:19:20 ago, via Serial0



R2507# show ip route  
      Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
      D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
      N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
      E1 - OSPF external type 1, E2 - OSPF external type 2
      i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
      ia - IS-IS inter area, * - candidate default, U - per-user static route
      o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

1.0.0.0/24 is subnetted, 1 subnets
    C 1.1.1.0 is directly connected, Serial0
    O IA 3.0.0.0/8 [110/74] via 1.1.1.2, 00:30:18, Serial0
    O E2 200.1.1.0/24 [110/20] via 1.1.1.2, 00:22:58, Serial0
    Route metric is 74, traffic share count is 1

R2507#

Если адрес пересылки также известен через внешний маршрут, OSPF не устанавливает тот маршрут в таблице маршрутизации. Для более подробной информации об этой проблеме посмотрите Общие проблемы маршрутизации с пересылкой адреса OSPF.

Причина 7: Список распределения блокирует маршруты

Давайте использовать следующую схему сети в качестве примера:

/image/gif/paws/7112/26a.gif

R4-4K R1-7010
interface Loopback0
 ip address 172.16.33.1 255.255.255.255

interface Serial2
 ip address 172.16.32.1 255.255.255.0

router ospf 20
 network 172.16.0.0 0.0.255.255 area 0
interface Loopback0
 ip address 172.16.30.1 255.255.255.255
!
interface Serial1/0
 ip address 172.16.32.2 255.255.255.0
 clockrate 64000

router ospf 20
 network 172.16.0.0 0.0.255.255 area 0
 distribute-list 1 in
!
access-list 1 permit 172.16.32.0. 0.0.0.255

Как вы можете видеть выше, R1-7010 настроили команду distribute-list, и это только позволяет 172.16.32.0/24 диапазону адресов быть установленным в таблице маршрутизации. В протоколах состояния соединений вы не можете действительно фильтровать LSA с командой distribute-list. LSA все еще будет в базе данных; однако, LSA не будет установлен в таблице маршрутизации.

R1-7010(5)# show ip ospf database router 172.16.33.1

  LS age: 357
  Options: (No TOS-capability, DC)
  LS Type: Router Links
  Link State ID: 172.16.33.1
  Advertising Router: 172.16.33.1
  LS Seq Number: 8000000A
  Checksum: 0xD4AA
  Length: 48
   Number of Links: 3

 Link connected to: another Router (point-to-point)
    (Link ID) Neighboring Router ID: 172.16.32.2
    (Link Data) Router Interface address: 172.16.32.1
    Number of TOS metrics: 0
    TOS 0 Metrics: 64

Команда настройки distribute-list на R1-7010 фильтрует 172.16.33.1/32 сеть от того, чтобы быть установленным в таблице маршрутизации.

R1-7010(5)# show ip route
172.16.0.0/16 is variably subnetted, 3 subnets, 2 masks
C       172.16.32.0/24 is directly connected, Serial1/0
C       172.16.30.1/32 is directly connected, Loopback0

Решение

Для решения этой проблемы настройте R1-7010 и позвольте 172.16.33.0/24 в списке контроля доступа (ACL), таким образом, эта сеть установлена в таблице маршрутизации.

R1-7010(5)# configure terminal 
R1-7010(5)(config)# access-list 1 permit 172.16.33.0 0.0.0.255 
R1-7010(5)(config)# end

R1-7010(5)# show ip access-list 1
Standard IP access list 1
    permit 172.16.32.0, wildcard bits 0.0.0.255
    permit 172.16.33.0, wildcard bits 0.0.0.255

R1-7010(5)# show ip route
172.16.0.0/16 is variably subnetted, 3 subnets, 2 masks
C       172.16.32.0/24 is directly connected, Serial1/0
O       172.16.33.1/32 [110/65] via 172.16.32.1, 00:00:08, Serial1/0
C       172.16.30.1/32 is directly connected, Loopback0

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения


Document ID: 7112