Технологии коммутируемого доступа в сеть : Технология DDR

Настройка входящих и исходящих соединений по телефонной линии по одним и тем же каналам PRI T1/E1

5 апреля 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Содержание


Введение

В данном документе описана настройка сервера доступа для входящих и исходящих вызовов на одном и том же интерфейсе T1 PRI. Входящие и исходящие звонки являются всей основанной на трафике Технологией DDR и Технологией DDR использования, но не предоставляют резервную копию ни для какого другого маршрутизатора. Если вы хотите настроить Сервер доступа для Входящих вызовов только, обратитесь к Настройке документа Сервер доступа с PRI для входящего асинхронный и Вызовов ISDN. Для адаптации этой конфигурации для включения резервной копии обратитесь к настройке документа и устранение проблем при резервировании DDR.

Предварительные условия

Требования

Шаг 1 - Настраивает и проверяет, что входящий вызов и клиенты установления внешнего телефонного соединения являются настройкой правильно. Поскольку в этой настройке основное внимание уделено конфигурации центрального узла NAS, пример конфигурации для клиентов не включен. Некоторые примеры конфигурации клиента приведены ниже:

Клиент входящих звонков - Устройство, которое набирает в NAS:

Клиент установления внешнего телефонного соединения - Устройство, к которому этот NAS набирает:

Шаг 2. Проверьте правильность функционирования каналов Telco. Можно использовать команду show isdn status, чтобы проверить, что канал BRI или PRI является functionting правильно. Дополнительную информацию см. в документе "Использование команды show isdn status для устранения неполадок BRI". Вы также должны разрешить исходящие вызовы на канале первичного интерфейса обмена (PRI) T1/E1. Обратитесь в свою телекоммуникационную компанию для проверки этой информации.

Используемые компоненты

При разработке и тестировании этой конфигурации использовались следующие версии программного и аппаратного обеспечения.

  • NAS: Cisco AS5300 с одним каналом связи T1 PRI. Данный AS5300 работает под управлением Cisco IOS Software Release 12.2(5).

  • Клиент: Cisco AS5300 с одним каналом связи T1 PRI. Данная конфигурация отсутствует.

  • Клиент: Cisco 1600 и одна цепь BRI. Данная конфигурация отсутствует.

  • Клиент: Cisco 804 с одной сетью BRI. Данная конфигурация отсутствует.

Сведения, представленные в этом документе, были получены от устройств в специфической лабораторной среде. Все устройства, используемые в этом документе, были запущены с чистой конфигурацией (конфигурацией по умолчанию). При работе с реальной сетью необходимо полностью осознавать возможные результаты использования всех команд.

Теоретические сведения

Во многих случаях может понадобиться использовать тот же канал T1/E1 для соединений Dialin и Dialout. Доступ Доступа к сети Разъединяет (NAS), поддержал бы входящие вызовы от пользователей нескольких сетей ISDN, и это могло также сделать исходящие вызовы на том же PRI к другому устройству. Исходящее соединение также можно использовать в резервном сценарии, где NAS вызывает и подключается к точке вызова, потерявшей свой основной канал WAN.

Родственные продукты

Эту конфигурацию можно применять на любых маршрутизаторах с платами T1 или PRI. Следовательно, любой маршрутизатор серии AS5xxx с платами T1 или PRI может использовать эту конфигурацию. Cisco 2600 и 3600 Series Routers можно также настроить на прием вызовов ISDN с помощью сетевого модуля или интерфейсной карты WAN (WIC) типа T1/PRI.

Данную конфигурацию также можно использовать с портами E1 или PRI. Установите для контроллера E1 параметры линейного кодирования, формирования кадров и другие технические характеристики, предоставленные телефонной компанией. Конфигурация канала D (интерфейс Serial x: 15 для E1s) похожа на показанную ниже конфигурацию.

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Технические рекомендации Cisco. Условные обозначения.

Настройка

В этом разделе содержатся сведения о настройке функций, описанных в этом документе.

Примечание: Для получения дополнительной информации о командах, встречающихся в этом документе, используйте средство поиска команд

Схема сети

В данном документе используется сеть, изображенная на следующей схеме.

/image/gif/paws/6435/pri_dialin_6435.gif

Конфигурации

Существует два основных метода для настройки Сервера доступа, чтобы быть в состоянии выполнить исходящие вызовы и принять входящие вызовы на том же PRI T1/E1. Это профили номеронабирателя и группы импульсного набора номера. Каждый обладает его преимуществами и недостатками, такими как:

  • Группы импульсного набора номера более просты настроить и управлять.

  • Профили DDR требуют отдельного интерфейса набора номера для каждого входящего и исходящего звонка.. Если имеются несколько входящих и исходящих одноранговых узлов, то создание и управление конфигурацией будет сложным.

  • Профили программы набора номера поддерживают клиентскую настройку., Например, можно указать, что определенному, некоторый клиенту назначат IP-адрес от пула адресов Некоторое время, другому клиенту назначат адрес от пула B.

  • Группы импульсного набора номера позволяют только тем же параметрам быть примененными ко всем пользователям. Настройка для каждого конкретного пользователя невозможна.

  • Ротационные группы дозвона допускают только одно определение интересующего трафика для входящих и исходящих вызовов. Следовательно, вы не можете настроить маршрутизатор для использования одного определения содержательного трафика для входящих вызовов и другого для исходящих вызовов.

  • Профили DDR обеспечивают отдельные определения содержательного трафика для каждого узла.

Этот документ предоставляет выборки с помощью Профилей DDR и Групп импульсного набора номера на NAS. Выберите метод, подходящий для конкретной ситуации.

Центральный сервер доступа с профилями набора (AS5300)
maui-nas-03#show running-config 
Building configuration...

Current configuration : 3351 bytes
!
! Last configuration change at 07:25:39 CDT Wed Oct 24 2001
! NVRAM config last updated at 16:37:00 CDT Tue Oct 23 2001
!
version 12.2
service timestamps debug datetime msec show-timezone
service timestamps log datetime msec show-timezone
service password-encryption
!
hostname maui-nas-03
!
aaa new-model
aaa authentication login default local
aaa authentication login NO_AUTHEN none
aaa authentication ppp default local
aaa authorization network default local 
enable secret 5 <deleted>
!
username admin password 7 <deleted>
username 800-isdn-client password 7 <deleted>
username 1600-isdn-client password 7 <deleted>
username 5300-client password 7 <deleted>
username lanai-nas-01 password 7 <deleted>

! -- Usernames for local authentication of the call.
! -- The client presents the username/password 
! -- and the NAS authenticates the peer.

spe 2/0 2/7
 firmware location mica-modem-pw.2.7.3.0.bin
!
resource-pool disable
!
clock timezone CST -6
clock summer-time CDT recurring
ip subnet-zero
!
isdn switch-type primary-ni

! -- Switch-type for this NAS. Obtain this information from the Telco.

isdn voice-call-failure 0
!
controller T1 0

! -- T1 PRI physical controller configuration.

 framing esf

! -- Framing for this T1 is Extended Super Frame (ESF). 
! -- Obtain this information from the telco.

 clock source line primary

! -- T1 0 is the primary clock source for this NAS. 
! -- Clock source must be specified for the timing 
! -- and synchronization of the T1 carrier.

 linecode b8zs

! -- Linecoding for this T1. Obtain this information from the telco.

 pri-group timeslots 1-24

! -- For T1 PRI scenarios, all 24 T1 timeslots are assigned 
! -- as ISDN PRI channels. The router will now automatically create the 
! -- corresponding D-channel: interface Serial 0:23
!
! -- The configurations for unused T1 controllers are omitted to save space.
! -- Unused T1s can be shutdown.


!
interface Ethernet0
 ip address 172.22.53.150 255.255.255.0
!
interface Serial0:23

! -- D-channel configuration for T1 0.

 no ip address
 encapsulation ppp
 dialer pool-member 10

! -- Assign this D-channel as member of dialer pool 10.
! -- Dialer pool 10 is used by interface Dialer 1 and Dialer 2. 
! -- All Dialer Interfaces for incoming calls should be configured 
! -- to use this pool.

 dialer pool-member 50 max-link 10

! -- The D-channel is also a member of dialer pool 50.
! -- Dialer pool 50 is used by interface Dialer 100.
! -- The pool can use a maximum of 10 links and will be used for outgoing calls.
 
 isdn switch-type primary-ni
 isdn bchan-number-order ascending

! -- B Channel Outgoing Call Order is ascending.
! -- Contact the Telco to determine whether the ISDN outbound trunk 
! -- call selection is configured for ascending or descending on the switch.

 no cdp enable
 ppp authentication chap
 ppp multilink

! -- Allow multlink ppp on this interface.

!
interface FastEthernet0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Dialer1
 description For Dialin ISDN Client - austin-soho-01
 ip unnumbered Ethernet0

! -- The interface is unnumbered to conserve IP addresses.

 encapsulation ppp
 dialer pool 10

! -- Defines the pool of physical resources from which the Dialer 
! -- interface may draw B channels as needed. Interface Dialer 2 also 
! -- uses this pool. Serial 0:23 is a member of this pool.

 dialer remote-name 1600-isdn-client

! -- Specifies remote router authenticated name and must match that used by 
! -- the remote router to authenticate itself (which can be different from
! -- the router hostname). The router uses this remote-name to bind the 
! -- incoming call to this dialer. without this command calls from 
! -- 1600-isdn-client will fail after authentication.

 dialer idle-timeout 0

! -- Set an idle-timeout of infinity. 
! -- The "zero" option for dialer idle-timeout was introduced in 12.1(3)T.

 dialer-group 1

! -- Apply interesting traffic definition from dialer-list 1.


 peer default ip address pool DIALIN

! -- Clients are assigned addresses from the ip address pool named "DIALIN".

 no fair-queue
 ppp authentication chap callin
 ppp multilink
!
interface Dialer2
 description For Dialin ISDN Client - travis-soho-01
 ip unnumbered Ethernet0
 encapsulation ppp
 dialer pool 10

! -- Defines the pool of physical resources from which the Dialer 
! -- interface may draw B channels as needed. Interface Dialer 1 
! -- also uses this pool. Serial 0:23 is a member of this pool.

 dialer remote-name 800-isdn-client

! -- Binds incoming calls from  user "800-isdn-client" to this dialer.

 dialer-group 1

! -- Apply interesting traffic definition from dialer-list 1. 

 peer default ip address pool DIALIN
 pulse-time 0
 ppp authentication chap callin
 ppp multilink
!
interface Dialer100
 description For Dialout Client - lanai-nas-01
 ip unnumbered Ethernet0
 encapsulation ppp
 dialer pool 50

! -- This dialer will draw resources from dialer pool 50 
! -- in which int serial 0:23 is the sole member.
! -- Since this dialer is used for dialout, 
! -- the outgoing call will be sent to interface se 0:23.

 dialer remote-name lanai-nas-01

! -- Specifies remote router authenticated name and must match that used by 
! -- the remote router to authenticate itself 
! -- (which can be different from the router hostname).

 dialer idle-timeout 900

! -- Idle timeout for incoming calls is 900 seconds (15 mins).
! -- Users that are idle for more than 900 seconds will be dropped.

 dialer string 81690 class 56k

!--- Dial 81690 and use the map-class named "56k" (defined below).

 dialer load-threshold 1 outbound

! -- This sets the outbound load level for traffic at which
! -- additional connections will be added to the MP bundle load level.
! -- Values range from 1 (unloaded) to 255 (fully loaded). 
! -- With a threshold of 1, additional links will be immediately 
! -- brought up and added to the bundle.

 dialer-group 3

! -- Apply interesting traffic definition from dialer-list 3.
! -- Note: the interesting traffic definition for outbound 
! -- calls is different than for incoming calls.

 ppp authentication chap
 ppp multilink

! -- Allow multlink ppp.

!         
router eigrp 69
 network 172.22.0.0
 auto-summary
 no eigrp log-neighbor-changes
!
ip local pool DIALIN 172.22.53.151 172.22.53.159

! -- IP address pools for dialin clients.

ip classless
ip route 172.16.0.0 255.255.0.0 Dialer100

! -- Static route for the 172.16.0.0/16 network. 
! -- Interesting Traffic for that network
! -- will be sent to interface Dialer100 and the router 
! -- will initiate the outbound call.

no ip http server
ip pim bidir-enable
!
!
map-class dialer 56k

!-- map-class named "56k" that was used with the dialer string in int Dialer100.

 dialer isdn speed 56

! -- Set the speed of the call to be 56k (default is 64k).
! -- This may not be neccessary for your connection. Consult your telco
! --  to find out if you need to configure the dial speed to 56k.

access-list 101 remark Interesting traffic definition for dialin clients
access-list 101 deny   eigrp any any
access-list 101 deny   udp any any eq ntp
access-list 101 permit ip any any

! -- EIGRP and  NTP traffic are tagged uninteresting for dialin clients.

access-list 103 remark Interesting traffic for link lanai-nas-01
access-list 103 deny   eigrp any any
access-list 103 deny   udp any any eq ntp
access-list 103 permit ip any any

! -- EIGRP and  NTP traffic are tagged uninteresting for the outbound dial.
! -- Eventhough the two interesting traffic definitions here are identical, 
! -- they can be changed depending on your traffic patterns.

dialer-list 1 protocol ip list 101

!--- Interesting traffic is defined by access-list 101.
!--- This is applied to interface Dialer 1 & 2 using the command dialer-group 1.
!--- Note: The specified dialer-list number must be the same 
!--- as the dialer-group number; in this example, defined to be "1".

dialer-list 3 protocol ip list 103
!
line con 0
 exec-timeout 0 0
 login authentication NO_AUTHEN
line 1 48
line aux 0
line vty 0 4
!
ntp clock-period 17180029
ntp server 172.22.53.1
end

Вышеупомянутая Конфигурация профиля DDR имеет отдельный интерфейс набора номера для каждого входящего и исходящего звонка. Для входящих вызовов используются интерфейсы программы набора номера Dialer 1 и Dialer 2, а для исходящих вызовов – Dialer 100. После того как входящий вызов пройдет аутентификацию, маршрутизатор направляет вызов на соответствующий интерфейс набора номера на основе удаленного имени номеронабирателя. Только интерфейс номеронабирателя для исходящего вызова (номеронабиратель 100) имеет строку с номером для набора. Только Dialer100 включает команду dialer load-threshold, так как это может набрать дополнительные ссылки в зависимости от входящей или исходящей загрузки (по умолчанию является исходящим).

В следующей конфигурации группы телефонной связи номеронабирателя используются для данного сценария:

Центральный сервер доступа с группами чередования
maui-nas-03#show running-config 
Building configuration...

Current configuration : 2436 bytes
!
! Last configuration change at 08:20:11 CDT Thu Oct 25 2001
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname maui-nas-03
!
aaa new-model
aaa authentication login default local
aaa authentication login NO_AUTHEN none
aaa authentication ppp default local
aaa authorization network default local 
enable secret 5 <deleted>
!
username admin password 7 <deleted>
username lanai-nas-01 password 7 <deleted>
username 800-isdn-client password 7 <deleted>
username 1600-isdn-client password 7 <deleted>
spe 2/0 2/7
 firmware location mica-modem-pw.2.7.3.0.bin
!
resource-pool disable
!
clock timezone CST -6
clock summer-time CDT recurring
ip subnet-zero
!
isdn switch-type primary-ni
!
controller T1 0
 framing esf
 clock source line primary
 linecode b8zs
 pri-group timeslots 1-24
!

! -- The configuration for unused T1 controllers are omitted to save space.
! -- Unused T1s can be shutdown.

!
interface Ethernet0
 ip address 172.22.53.150 255.255.255.0
!
interface Serial0:23

! -- D-channel configuration for T1 0.

 no ip address
 encapsulation ppp
 dialer rotary-group 1

! -- T1 0 is a member of rotary group 1.
! -- The rotary group configuration is in interface Dialer 1.
! -- Note: this command was not included in the dialer profile configuration.

 isdn switch-type primary-ni
 isdn bchan-number-order ascending
 no peer default ip address
 no cdp enable
 ppp authentication chap
 ppp multilink
!
interface FastEthernet0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Dialer1

!--- Configuration for rotary group 1.
!--- The Dialer interface number (1) must exactly match rotary group number
!--- configured on the physical interfaces(interface Serial 0:23).

 ip unnumbered Ethernet0

! -- This dialer is unnumbered to ethernet 0.

 encapsulation ppp
 dialer in-band

! -- Enable this dialer interface to be a DDR interface.

 dialer idle-timeout 900

! -- Idle timeout for incoming calls is 900 seconds (15 mins).
! -- Users that are idle for more than 900 seconds will be dropped.
! -- If dialer in-band is used and a dialer idle-timeout is not defined, then 
! -- the default idle-timeout of 120 seconds (2min) will be applied.

 dialer map ip 172.16.1.1 name lanai-nas-01 speed 56 broadcast 81690

! -- Dialer map for the outbound dial. Add a dialer map for every router 
! -- that needs to be dialed. Inbound calls do not need dialer maps. 
! -- They will be dynmamically created.

 dialer load-threshold 1 outbound

! -- This sets the outbound load level for Multlink PPP at 1/255.

 dialer-group 1

!--- Apply interesting traffic definition from dialer-list 1.
! -- Note: The specified dialer-group number must be the same as 
! -- the dialer-list number; in this example, defined to be "1". 

 peer default ip address pool DIALIN

! -- clients are assigned addresses from the ip address pool named "DIALIN".

 no cdp enable
 ppp authentication chap
 ppp multilink
 multilink max-links 5
!
router eigrp 69
 network 172.22.0.0
 auto-summary
 no eigrp log-neighbor-changes
!
ip local pool DIALIN 172.22.53.151 172.22.53.159
ip classless
ip route 172.16.0.0 255.255.0.0 172.16.1.1
ip route 172.16.1.1 255.255.255.255 Dialer1
no ip http server
ip pim bidir-enable
!
!
access-list 101 remark Interesting traffic definition
access-list 101 deny   eigrp any any
access-list 101 deny   udp any any eq ntp
access-list 101 permit ip any any
dialer-list 1 protocol ip list 101

! -- Interesting traffic is defined by dialer-list 1.
! -- This is applied to interface Dialer 1 using dialer-group 1.
! -- The interesting traffic definition for inbound and outbound calls 
! -- is the same. If you want different interesting traffic definition 
! -- for inbound and outbound calls use dialer profiles.

!
line con 0
 login authentication NO_AUTHEN
line 1 48
line aux 0
line vty 0 4
!
ntp clock-period 17179882
ntp server 172.22.53.1
end

В вышеприведенной настройке группы телефонной связи номеронабирателя интерфейс имеет одну карту коммутации, используемую для подключения к внешним ресурсам по телефонной линии. Следует настроить карту коммутации для каждого узла, к которому нужно будет обращаться.

Примечание: Входящие звонки не требуют использования схем набора номера, т. к. создаются динамически. Это можно проверить с помощью команды show dialer map. Ниже приводится пример:

maui-nas-03#show dialer map
Dynamic dialer map ip 172.22.53.152 name 1600-isdn-client () on Di1

! -- Dynamic dialer map for 1600-isdn-cliet created from Dialer1
! -- (the rotary group interface).

Dynamic dialer map ip 172.22.53.151 name 800-isdn-client () on Di1

! -- Dynamic dialer map for 800-isdn-cliet created from Dialer1
! -- (the rotary group interface).

Static dialer map ip 172.16.1.1 name lanai-nas-01 (81690) on Di1

! -- Static map configured on Dialer 1 was applied to this link 
! -- connected to lanai-nas-01.


Проверка.

В данном разделе содержатся сведения о проверке работы конфигурации.

Некоторые команды show поддерживаются Интерпретатором выходных данных; это позволяет выполнять анализ выходных данных команды show.

  • команда show isdn status позволяет удостовериться, что маршрутизатор обменивается данными с ISDN-коммуникатором должным образом. В выходных данных команды проверьте наличие сообщений: Layer 1 Status is ACTIVE (Уровень 1 активен) и Layer 2 Status state = MULTIPLE_FRAME_ESTABLISHED (Состояние уровня 2 = MULTIPLE_FRAME_ESTABLISHED). Эта команда показывает также число активных вызовов.

  • show ppp multilink - отображение сведений об активных многоканальных пакетах. Эта команда служит для проверки многоканальных соединений.

  • show dialer [interface номер типа] – отображает общие диагностические сведения о настроенных для DDR интерфейсах. Если соединение прошло успешно, должно появиться сообщение Dialer state is data link layer up (Установлен канальный уровень для интерфейса номеронабирателя). Появление сообщения physical layer up (Установлен физический уровень) означает, что протокол линии успешно инициализирован, но протокол управления сетью (NСP) не готов к работе. Исходный и конечный адреса пакета, инициировавшего вызов номера, показаны в строке причины вызова. Эта команда show также отображает конфигурацию таймера и время, оставшееся до прекращения соединения.

  • show caller user username detail - показываются параметры для конкретного пользователя, такие как назначенный IP-адрес, параметры протокола PPP и связки PPP и т. д. Если данная версия программного обеспечения Cisco IOS не поддерживает эту команду, рекомендуется использовать команду "show user".

  • команда show dialer map отображает настроенные статические и динамические карты номеронабирателей. Данная команда используется для проверки создания динамической схемы набора номеров. Без схемы набора номеров передача пакетов невозможна.

Ниже приведены результаты выполнения команды show для успешных вызовов. Обратите внимание на разделы, выделенные жирным шрифтом, и комментарии в выходных данных. Сравните полученные выходные данные со следующим результатом.

maui-nas-03#show isdn status
Global ISDN Switchtype = primary-ni
ISDN Serial0:23 interface
        dsl 0, interface ISDN Switchtype = primary-ni
    Layer 1 Status:
        ACTIVE
    Layer 2 Status:
        TEI = 0, Ces = 1, SAPI = 0, State = MULTIPLE_FRAME_ESTABLISHED

    ! -- Layer 1 is ACTIVE and Layer 2 is MULTIPLE FRAME ESTABLISHED.

    Layer 3 Status:
        0 Active Layer 3 Call(s)
    Active dsl 0 CCBs = 0
    The Free Channel Mask:  0x807FFFFF
    Number of L2 Discards = 0, L2 Session ID = 0
    Total Allocated ISDN CCBs = 0

maui-nas-03#show isdn service
PRI Channel Statistics:
ISDN Se0:23, Channel [1-24]
  Configured Isdn Interface (dsl) 0
   Channel State (0=Idle 1=Proposed 2=Busy 3=Reserved 4=Restart 5=Maint_Pend)
    Channel :  1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4
    State   :  0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 3 
   Service State (0=Inservice 1=Maint 2=Outofservice)
    Channel :  1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4
    State   :  0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 2 

! -- All channels are Inservice.


maui-nas-03#show user
    Line       User       Host(s)              Idle       Location
*  0 con 0                idle                 00:00:00   

  Interface      User        Mode                     Idle     Peer Address
  Di100        lanai-nas- PPP   Bundle        00:00:35 172.16.1.1

  ! -- Connection to lanai-nas-01 uses int Dialer 100.

  Di2          800-isdn-c PPP   Bundle        00:00:22 172.22.53.154
  
! -- Connection to 800-isdn-client uses int Dialer 2.

  Di1          1600-isdn- PPP   Bundle        00:01:29 172.22.53.153
 
 ! --  Connection to 1600-isdn-client uses int Dialer 1.

  Se0:0        lanai-nas- Sync PPP                    -   Bundle: Di100
  Se0:1        lanai-nas- Sync PPP                    -   Bundle: Di100
  Se0:2        1600-isdn- Sync PPP                    -   Bundle: Di1
  Se0:3        1600-isdn- Sync PPP                    -   Bundle: Di1
  Se0:4        lanai-nas- Sync PPP                    -   Bundle: Di100
  Se0:5        lanai-nas- Sync PPP                    -   Bundle: Di100
  Se0:6        lanai-nas- Sync PPP                    -   Bundle: Di100
  Se0:7        800-isdn-c Sync PPP                    -   Bundle: Di2
  Se0:8        800-isdn-c Sync PPP                    -   Bundle: Di2

  ! -- Two B-channels are connected to 800-isdn-client (Se0:7-Se0:8) and 
  ! -- 1600-isdn-client (Se0:2-Se0:3). Five other B-channels 
  ! -- (Se0:0-Se0:1 and Se0:4-Se0:6) are connected to lanai-nas-01.


maui-nas-03#show ppp multilink 

Dialer2, bundle name is 800-isdn-client

  ! -- int Dialer 2 controls multilink bundle to 800-isdn-client.

  Bundle up for never
  0 lost fragments, 0 reordered, 0 unassigned
  0 discarded, 0 lost received, 1/255 load
  0x8 received sequence, 0xC sent sequence
  Member links: 2 (max not set, min not set)
    Serial0:7, since 00:00:16, last rcvd seq 000006
    Serial0:8, since 00:00:15, last rcvd seq 000007

  ! -- B-channels Se0:7 and Se0:8 are connected.


Dialer100, bundle name is lanai-nas-01

! -- int Dialer 100 controls multilink bundle to lanai-nas-01.

  Bundle up for never
  0 lost fragments, 0 reordered, 0 unassigned
  0 discarded, 0 lost received, 1/255 load
  0x33 received sequence, 0x33 sent sequence
  Member links: 5 (max not set, min not set)
    Serial0:0, since 00:02:08, last rcvd seq 000032
    Serial0:1, since 00:02:05, last rcvd seq 00002E
    Serial0:4, since 00:01:35, last rcvd seq 00002F
    Serial0:5, since 00:01:05, last rcvd seq 000030
    Serial0:6, since 00:00:35, last rcvd seq 000031

  ! -- B-channels Se0:0-Se0:1 and Se0:4-Se0:6 are connected.


Dialer1, bundle name is 1600-isdn-client

! -- int Dialer 100 controls multilink bundle to 1600-isdn-client.

  Bundle up for never
  0 lost fragments, 1 reordered, 0 unassigned
  0 discarded, 0 lost received, 1/255 load
  0x28 received sequence, 0x7B sent sequence
  Member links: 2 (max not set, min not set)
    Serial0:2, since 00:06:24, last rcvd seq 000026
    Serial0:3, since 00:06:22, last rcvd seq 000027

 ! -- B-channels Se0:2 and Se0:3 are connected.


Устранение неполадок

В этом разделе описывается процесс устранения неполадок конфигурации.

Ресурсы для устранения неполадок

Для получения информации по устранению проблем см. следующие документы:

Команды для устранения неполадок

Некоторые команды show поддерживаются Интерпретатором выходных данных; это позволяет выполнять анализ выходных данных команды show.

Примечание: Прежде чем применять команды отладки, ознакомьтесь с разделом "Важные сведения о командах отладки".

  • "debug dialer" - отображаются данные отладки устройства прямой записи на диск о пакетах, полученных на интерфейс номеронабирателя. Данные сведения помогут убедиться в наличии существенного трафика, который может использовать интерфейс номеронабирателя.

  • debug isdn q931 – отображает параметры настройки вызова и разрыва сетевого подключения ISDN (3-й уровень).

  • debug ppp negotiation - вывод сведений о трафике PPP и обмене данными в процессе согласования параметров протокола управления каналом (LCP), аутентификации и протокола управления сетью (NCP). В успешных переговорах PPP сначала выясняется состояние LCP, затем проводится аутентификация и наконец выполняется согласование NCP. Многозвенные параметры, такие как максимально восстановленный полученный блок (MRRU), устанавливаются во время согласования LCP.

  • команда "debug ppp authentication" отображает сообщения протокола аутентификации PPP, включая информацию об обмене пакетами CHAP и обмене по протоколу аутентификации по паролю (PAP).

  • debug ppp error – отображает ошибки протокола и статистику ошибок, связанных с согласованием и функционированием PPP-соединения.

Ниже приведены выходные данные команды debug для успешного исходящего вызова. Обратите внимание на разделы, выделенные жирным шрифтом, и комментарии в выходных данных. Сравните полученные выходные данные со следующим результатом.

maui-nas-03#debug dialer
Dial on demand events debugging is on
maui-nas-03#debug ppp negotiation
PPP protocol negotiation debugging is on
maui-nas-03#debug ppp authentication
PPP authentication debugging is on
maui-nas-03#debug isdn q931
ISDN Q931 packets debugging is on

maui-nas-03#ping 172.16.1.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.1.1, timeout is 2 seconds:

Oct 24 12:56:16.205 UTC: Se0:23 DDR: rotor dialout [priority]
Oct 24 12:56:16.205 UTC: Se0:23 DDR: Dialing cause ip 
(s=172.22.53.150, d=172.16.1.1)

! -- The dialing cause is a ping for 172.16.1.1. 
! -- ICMP is tagged as interesting.

Oct 24 12:56:16.205 UTC: Se0:23 DDR: Attempting to dial 81690
Oct 24 12:56:16.205 UTC: ISDN Se0:23: TX -> SETUP pd = 8  callref = 0x0063

! -- Outgoing ISDN Q.931 SETUP message.

Oct 24 12:56:16.205 UTC:         Bearer Capability i = 0x8890218F
Oct 24 12:56:16.205 UTC:         Channel ID i = 0xA98381
Oct 24 12:56:16.209 UTC:         Called Party Number i = 0x80, '81690', 
Plan:Unknown, Type:Unknown
Oct 24 12:56:16.241 UTC: ISDN Se0:23: RX <- CALL_PROC pd = 8  callref = 0x8063
Oct 24 12:56:16.241 UTC:         Channel ID i = 0xA98381
Oct 24 12:56:16.285 UTC: ISDN Se0:23: RX <- CONNECT pd = 8  callref = 0x8063

! -- Received Q.931 CONNECT message.

Oct 24 12:56:16.297 UTC: %LINK-3-UPDOWN: Interface Serial0:0, changed state to up
Oct 24 12:56:16.297 UTC: Se0:0: interface must be fifo queue, force fifo
Oct 24 12:56:16.297 UTC: %DIALER-6-BIND: Interface Se0:0 bound to profile Di100
Oct 24 12:56:16.297 UTC: Se0:0 PPP: Treating connection as a callout
Oct 24 12:56:16.297 UTC: Se0:0 PPP: Phase is ESTABLISHING, 
Active Open [0 sess, 1 load]
Oct 24 12:56:16.301 UTC: Se0:0 LCP: O CONFREQ [Closed] id 12 len 33
Oct 24 12:56:16.301 UTC: Se0:0 LCP:    AuthProto CHAP (0x0305C22305)
Oct 24 12:56:16.301 UTC: Se0:0 LCP:    MagicNumber 0xE384A4CD (0x0506E384A4CD)
Oct 24 12:56:16.301 UTC: Se0:0 LCP:    MRRU 1524 (0x110405F4)
Oct 24 12:56:16.301 UTC: Se0:0 LCP:    EndpointDisc 1 maui-nas-03 
(0x130E016D6175692D6E61732D3033)
Oct 24 12:56:16.301 UTC: ISDN Se0:23: TX -> CONNECT_ACK pd = 8  callref = 0x0063
Oct 24 12:56:16.317 UTC: Se0:0 LCP: I CONFREQ [REQsent] id 10 len 34
Oct 24 12:56:16.317 UTC: Se0:0 LCP:    AuthProto CHAP (0x0305C22305)
Oct 24 12:56:16.317 UTC: Se0:0 LCP:    MagicNumber 0x54F49B93 (0x050654F49B93)
Oct 24 12:56:16.321 UTC: Se0:0 LCP:    MRRU 1524 (0x110405F4)
Oct 24 12:56:16.321 UTC: Se0:0 LCP:    EndpointDisc 1 lanai-nas-01 
(0x130F016C616E61692D6E61732D3031)
Oct 24 12:56:16.321 UTC: Se0:0 LCP: O CONFACK [REQsent] id 10 len 34
Oct 24 12:56:16.321 UTC: Se0:0 LCP:    AuthProto CHAP (0x0305C22305)
Oct 24 12:56:16.321 UTC: Se0:0 LCP:    MagicNumber 0x54F49B93 (0x050654F49B93)
Oct 24 12:56:16.321 UTC: Se0:0 LCP:    MRRU 1524 (0x110405F4)
Oct 24 12:56:16.321 UTC: Se0:0 LCP:    EndpointDisc 1 lanai-nas-01 
(0x130F016C616E61692D6E61732D3031)
Oct 24 12:56:16.325 UTC: Se0:0 LCP: I CONFACK [ACKsent] id 12 len 33
Oct 24 12:56:16.325 UTC: Se0:0 LCP:    AuthProto CHAP (0x0305C22305)
Oct 24 12:56:16.325 UTC: Se0:0 LCP:    MagicNumber 0xE384A4CD (0x0506E384A4CD)
Oct 24 12:56:16.325 UTC: Se0:0 LCP:    MRRU 1524 (0x110405F4)
Oct 24 12:56:16.325 UTC: Se0:0 LCP:    EndpointDisc 1 maui-nas-03 
(0x130E016D6175692D6E61732D3033)
Oct 24 12:56:16.325 UTC: Se0:0 LCP: State is Open

! -- LCP negotation is complete.

Oct 24 12:56:16.325 UTC: Se0:0 PPP: Phase is AUTHENTICATING, 
by both [0 sess, 1 load]
Oct 24 12:56:16.325 UTC: Se0:0 CHAP: O CHALLENGE id 8 len 32 from "maui-nas-03"
Oct 24 12:56:16.337 UTC: Se0:0 CHAP: I CHALLENGE id 10 len 33 from "lanai-nas-01"
Oct 24 12:56:16.341 UTC: Se0:0 CHAP: O RESPONSE id 10 len 32 from "maui-nas-03"
Oct 24 12:56:16.353 UTC: Se0:0 CHAP: I SUCCESS id 10 len 4
Oct 24 12:56:16.357 UTC: Se0:0 CHAP: I RESPONSE id 8 len 33 from "lanai-nas-01"
Oct 24 12:56:16.361 UTC: Se0:0 CHAP: O SUCCESS id 8 len 4

! -- Two-way CHAP authentication is successful.

Oct 24 12:56:16.361 UTC: Se0:0 PPP: Phase is VIRTUALIZED [0 sess, 1 load]
Oct 24 12:56:16.361 UTC: Di100 DDR: Authenticated host lanai-nas-01 
with no matching dialer map
Oct 24 12:56:16.361 UTC: Di100 PPP: Phase is UP [0 sess, 1 load]
Oct 24 12:56:16.361 UTC: Di100 IPCP: O CONFREQ [Closed] id 6 len 10
Oct 24 12:56:16.361 UTC: Di100 IPCP:    Address 172.22.53.150 (0x0306AC163596)
Oct 24 12:56:16.361 UTC: Di100 CDPCP: O CONFREQ [Closed] id 6 len 4
Oct 24 12:56:16.365 UTC: Di100 MLP: Added first link Se0:0 to bundle lanai-nas-01
Oct 24 12:56:16.365 UTC: Di100 PPP: Treating connection as a callout
Oct 24 12:56:16.377 UTC: Di100 IPCP: I CONFREQ [REQsent] id 1 len 10
Oct 24 12:56:16.377 UTC: Di100 IPCP:    Address 172.16.1.1 (0x0306AC100101)
Oct 24 12:56:16.377 UTC: Di100 IPCP: O CONFACK [REQsent] id 1 len 10
Oct 24 12:56:16.377 UTC: Di100 IPCP:    Address 172.16.1.1 (0x0306AC100101)
Oct 24 12:56:16.381 UTC: Di100 IPCP: I CONFACK [ACKsent] id 6 len 10
Oct 24 12:56:16.381 UTC: Di100 IPCP:    Address 172.22.53.150 (0x0306AC163596)
Oct 24 12:56:16.381 UTC: Di100 IPCP: State is Open
Oct 24 12:56:16.381 UTC: Di100 DDR: dialer protocol up
Oct 24 12:56:16.381 UTC: Di100 IPCP: Install route to 172.16.1.1

! -- A route to the peer is installed.

Oct 24 12:56:17.361 UTC: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0:0, 
changed state to up
Oct 24 12:56:19.113 UTC: Se0:23 DDR: rotor dialout [priority]

! -- Second call is being dialed.

Oct 24 12:56:19.113 UTC: Se0:23 DDR: Attempting to dial 81690
Oct 24 12:56:19.113 UTC: ISDN Se0:23: TX -> SETUP pd = 8  callref = 0x0064
Oct 24 12:56:19.113 UTC:         Bearer Capability i = 0x8890218F
Oct 24 12:56:19.113 UTC:         Channel ID i = 0xA98382
Oct 24 12:56:19.113 UTC:         Called Party Number i = 0x80, '81690', 
Plan:Unknown, Type:Unknown
Oct 24 12:56:19.141 UTC: ISDN Se0:23: RX <- CALL_PROC pd = 8  callref = 0x8064
Oct 24 12:56:19.141 UTC:         Channel ID i = 0xA98382
Oct 24 12:56:19.205 UTC: ISDN Se0:23: RX <- CONNECT pd = 8  callref = 0x8064
Oct 24 12:56:19.217 UTC: %LINK-3-UPDOWN: Interface Serial0:1, 
changed state to up
Oct 24 12:56:19.217 UTC: Se0:1: interface must be fifo queue, force fifo
Oct 24 12:56:19.217 UTC: %DIALER-6-BIND: Interface Se0:1 bound to profile Di100
Oct 24 12:56:19.217 UTC: %ISDN-6-CONNECT: 
Interface Serial0:0 is now connected to 81690 lanai-nas-01
Oct 24 12:56:19.221 UTC: Se0:1 PPP: Treating connection as a callout
Oct 24 12:56:19.221 UTC: Se0:1 PPP: Phase is ESTABLISHING, Active Open 
[0 sess, 1 load]
Oct 24 12:56:19.221 UTC: Se0:1 LCP: O CONFREQ [Closed] id 14 len 33
Oct 24 12:56:19.221 UTC: Se0:1 LCP:    AuthProto CHAP (0x0305C22305)
Oct 24 12:56:19.221 UTC: Se0:1 LCP:    MagicNumber 0xE384B037 
(0x0506E384B037)
Oct 24 12:56:19.221 UTC: Se0:1 LCP:    MRRU 1524 (0x110405F4)
Oct 24 12:56:19.221 UTC: Se0:1 LCP:    EndpointDisc 1 maui-nas-03 
(0x130E016D6175692D6E61732D3033)
Oct 24 12:56:19.221 UTC: ISDN Se0:23: TX -> CONNECT_ACK pd = 8  
callref = 0x0064
Oct 24 12:56:19.241 UTC: Se0:1 LCP: I CONFREQ [REQsent] id 11 len 34
Oct 24 12:56:19.241 UTC: Se0:1 LCP:    AuthProto CHAP (0x0305C22305)
Oct 24 12:56:19.241 UTC: Se0:1 LCP:    MagicNumber 0x54F4A700 
(0x050654F4A700)
Oct 24 12:56:19.241 UTC: Se0:1 LCP:    MRRU 1524 (0x110405F4)
Oct 24 12:56:19.241 UTC: Se0:1 LCP:    EndpointDisc 1 lanai-nas-01 
(0x130F016C616E61692D6E61732D3031)
Oct 24 12:56:19.241 UTC: Se0:1 LCP: O CONFACK [REQsent] id 11 len 34
Oct 24 12:56:19.241 UTC: Se0:1 LCP:    AuthProto CHAP (0x0305C22305)
Oct 24 12:56:19.241 UTC: Se0:1 LCP:    MagicNumber 0x54F4A700 
(0x050654F4A700)
Oct 24 12:56:19.241 UTC: Se0:1 LCP:    MRRU 1524 (0x110405F4)
Oct 24 12:56:19.241 UTC: Se0:1 LCP:    EndpointDisc 1 lanai-nas-01 
(0x130F016C616E61692D6E61732D3031)
Oct 24 12:56:19.245 UTC: Se0:1 LCP: I CONFACK [ACKsent] id 14 len 33
Oct 24 12:56:19.245 UTC: Se0:1 LCP:    AuthProto CHAP (0x0305C22305)
Oct 24 12:56:19.245 UTC: Se0:1 LCP:    MagicNumber 0xE384B037 (0x0506E384B037)
Oct 24 12:56:19.245 UTC: Se0:1 LCP:    MRRU 1524 (0x110405F4)
Oct 24 12:56:19.245 UTC: Se0:1 LCP:    EndpointDisc 1 maui-nas-03 
(0x130E016D6175692D6E61732D3033)
Oct 24 12:56:19.245 UTC: Se0:1 LCP: State is Open
Oct 24 12:56:19.245 UTC: Se0:1 PPP: Phase is AUTHENTICATING, by both 
[0 sess, 1 load]
Oct 24 12:56:19.245 UTC: Se0:1 CHAP: O CHALLENGE id 8 len 32 from "maui-nas-03"
Oct 24 12:56:19.257 UTC: Se0:1 CHAP: I CHALLENGE id 11 len 33 from "lanai-nas-01"
Oct 24 12:56:19.261 UTC: Se0:1 CHAP: O RESPONSE id 11 len 32 from "maui-nas-03"
Oct 24 12:56:19.273 UTC: Se0:1 CHAP: I SUCCESS id 11 len 4
Oct 24 12:56:19.281 UTC: Se0:1 CHAP: I RESPONSE id 8 len 33 from "lanai-nas-01"
Oct 24 12:56:19.281 UTC: Se0:1 CHAP: O SUCCESS id 8 len 4
! -- Authentication is successful.
Oct 24 12:56:19.281 UTC: Se0:1 PPP: Phase is VIRTUALIZED [0 sess, 1 load]
Oct 24 12:56:19.281 UTC: Di100 MLP: Added link Se0:1 to bundle lanai-nas-01

! -- The link is added to the Multilink bundle.

Oct 24 12:56:20.281 UTC: %LINEPROTO-5-UPDOWN: Line protocol on 
Interface Serial0:1, changed state to up
Oct 24 12:56:25.221 UTC: %ISDN-6-CONNECT: Interface Serial0:1 
is now connected to 81690 lanai-nas-01
Oct 24 12:56:49.117 UTC: Se0:23 DDR: rotor dialout [priority]

! -- Third call is being dialed.

Oct 24 12:56:49.117 UTC: Se0:23 DDR: Attempting to dial 81690
Oct 24 12:56:49.117 UTC: ISDN Se0:23: TX -> SETUP pd = 8  callref = 0x0065
Oct 24 12:56:49.117 UTC:         Bearer Capability i = 0x8890218F
Oct 24 12:56:49.117 UTC:         Channel ID i = 0xA98385
Oct 24 12:56:49.117 UTC:         Called Party Number i = 0x80, '81690', 
Plan:Unknown, Type:Unknown
...
...

! -- Output Omitted.

...
Oct 24 12:56:49.261 UTC: Se0:4 PPP: Phase is VIRTUALIZED [0 sess, 1 load]
Oct 24 12:56:49.261 UTC: Di100 MLP: Added link Se0:4 to bundle lanai-nas-01

! -- The 3rd link is added to the bundle.

Oct 24 12:56:50.261 UTC: %LINEPROTO-5-UPDOWN: Line protocol on 
Interface Serial0:4, changed state to up
Oct 24 12:56:55.198 UTC: %ISDN-6-CONNECT: Interface Serial0:4 
is now connected to 81690 lanai-nas-01  
...
...
...

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения


Document ID: 6435