Интерфейсы и модули Cisco : Сервисные адаптеры Cisco

Конфигурация и краткий обзор модуля маршрутизатора для cемейства Catalyst 4500/4000 (WS-X4232-L3)

20 октября 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (7 октября 2015) | Отзыв


Содержание


Введение

Этот документ описывает модуль маршрутизатора WS-X4232-L3 для коммутаторов Cisco Catalyst серии 4500/4000. В дополнение к описанию архитектуры и конфигурации WS-X4232-L3, этот документ также содержит пример конфигурации, в которой используются коммутаторы Catalyst серии 4500/4000 и модуль маршрутизатора.

Предварительные условия

Требования

Для этого документа отсутствуют особые требования.

Используемые компоненты

Сведения, содержащиеся в данном документе, касаются следующих версий программного обеспечения и оборудования:

  • Cisco Catalyst ОС (CatOS) выпуск 5.5 (1) или позже

  • Cisco выпуск ПО IOS� 12.0 (7) W5 (15d)

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в этом документе, были запущены с чистой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд до их использования.

Название файла образа Cisco IOS для WS-X4232-L3 начинается с "cat4232-". Можно найти файл в раздел Catalyst 4232 области загрузки ПО (только зарегистрированные клиенты) для программного обеспечения коммутации LAN.

Примечание: Существует поддержка модуля маршрутизатора при использовании его в сочетании с Supervisor Engine 1 и Supervisor Engine 2. Однако нет никакой поддержки модуля маршрутизатора при использовании его в сочетании с Supervisor Engine 2 +, 3, 4, или 5.

Примечание: См. раздел Функций Примечания по установке и конфигурации для сервисного модуля Catalyst 4000 Уровня 3 для получения дополнительной информации о программных характеристиках, которые имеют поддержку на модуле маршрутизатора (WS-X4232-L3).

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Условные обозначения технических терминов Cisco.

Обзор архитектуры

Модуль WS-X4232-L3 имеет 32 Порта Fast Ethernet и два Порта Gigabit Ethernet.

Эти два Порта Gigabit Ethernet соответствуют гигабиту интерфейсов 1 и гигабиту 2 в конфигурации маршрутизатора. Эти порты Gigabit Ethernet являются маршрутизируемыми.

Внутренне, модуль имеет два Интерфейса Gigabit Ethernet (гигабит 3 и гигабит 4), которые подключают маршрутизатор с объединительной платой коммутатора. Объединительная карта коммутатора использует первые два порта в этом слоте для подключения к маршрутизационному модулю. Когда вы вставляете модуль WS-X4232-L3 в слот 3, Интерфейсы Gigabit Ethernet 3 и 4 подключения к портам 3/1 и 3/2 объединительной платы. Порты 3/1 и 3/2 являются портами Уровня 2 с конфигурацией на Supervisor Engine коммутатора. Интерфейсы Gigabit Ethernet 3 и 4 являются портами Уровня 3 с конфигурацией на модуле маршрутизатора.

В модуле маршрутизатора есть 32 порта Fast Ethernet. Эти порты являются портами Уровня 2 и не выполняют функций Уровня 3. Несмотря на то, что порты имеют физическое размещение на модуле маршрутизатора, необходимо настроить порты на Supervisor Engine коммутатора.

Эта схема предоставляет наглядное объяснение архитектуры. Для этой настройки установите модуль маршрутизатора в слоте 2 Коммутатора Catalyst.

http://www.cisco.com/c/dam/en/us/support/docs/switches/catalyst-4000-series-switches/6198-28-a.gif

Конфигурация WS-X4232-L3

Supervisor Engine

Команда show port отображает порты на два гигабита и 32 порта на 10/100 Мбит/с с номерами 1 - 34.

Примечание: Порты на два гигабита, которые вы видите от Supervisor Engine, не являются двумя портами, которые вы видите на лицевой панели. Порты, которые вы видите от Supervisor Engine, являются двумя коммутируемыми портами, которые соединяются с механизмом маршрута. Необходимо настроить физические порты как порты коммутатора. Эта конфигурация подобна конфигурации многоуровневого коммутатора (MSM) на коммутаторах Catalyst 6500/6000 Series. Больше обычной конфигурации для этих портов должно установить их как Gigabit EtherChannel (GEC) и транкинг. Таким образом, можно направить между всеми VLAN на маршрутизаторе.

Примечание: Можно обратиться к модулю маршрутизатора от Supervisor Engine при запуске сеанса module# команда. Это действие подобно доступу Модульного коммутатора с функциями маршрутизатора (RSM) в Catalyst 5500/5000 Series Switches.

Маршрутизатор

Если вы видите командную строку маршрутизатора, ищете четыре Интерфейса Gigabit Ethernet с номерами от 1 до 4 (гигабит 1, гигабит 2, гигабит 3 и гигабит 4) и Fast Ethernet внеполосный интерфейс.

Это настройка используется по умолчанию:

Router#show run 
Building configuration...  

Current configuration:  
!  
version 12.0  
service config  
no service pad  
service timestamps debug uptime  
service timestamps log uptime  
no service password-encryption  
!  
hostname Router  
!  
!  
ip subnet-zero  
!  
!  
!  
interface FastEthernet1  
 no ip address  
 no ip directed-broadcast  
 shutdown  
!  
interface gigabitEthernet1  
 no ip address  
 no ip directed-broadcast 

!--- Output suppressed.

Примечание: В этой конфигурации гигабит 3 и гигабит 4 являются соединениями, который переходит к объединительной плате. Гигабит 1 и гигабит 2 являются портами пользователя на лицевой панели (маршрутизируемые порты). Большую часть времени, как на MSM, вы настраиваете порт 3 и порт 4, чтобы быть частью того же канала интерфейсного порта. Кроме того, вы настраиваете подинтерфейсы на том канале (с протоколом inter-switch link [ISL] или инкапсуляция IEEE 802.1Q). Как на MSM, конфигурация Gigabit 3 и гигабит 4 на модуле маршрутизатора должно быть совместимо со слотом/1 конфигурации порта и slot/2 на стороне коммутатора. Можно проверить трафик между маршрутизатором и коммутатором при запуске команд show interface port-channel или show interface gigabitethernet.

Поддержка листа доступа на WS-X4232-L3

Существует поддержка списков контроля доступа (ACL) на модуле маршрутизатора WS-X4232-L3, но пример конфигурации, который обсуждает этот документ, не поддерживает ACL. См. ACL Настройки на Модуле маршрутизатора WS-X4232-L3 для Catalyst 4000 Family для получения дополнительной информации о конфигурациях списков управления доступом (ACL) с поддержкой модуля WS-X4232-L3.

Примеры конфигураций

Пример конфигурации содержит элементы в этом списке. (См. Диаграмму сети.)

  • Удар — коммутаторы Catalyst 4500/4000 Series с модулем маршрутизатора в слоте 3.

  • Liki — Маршрутизатор, который подключает к Гигабитному Ethernet 1 на модуле маршрутизатора.

  • Donald — маршрутизатор, который подключает в VLAN 2 на порту 3/3 Банга. Порт 3/3 является одним из портов Уровня 2 модуля маршрутизатора.

  • Даниэлла — Маршрутизатор, который подключает в VLAN 3 на порту 2/3 Банга.

Эта конфигурация включает подключение GEC между модулем маршрутизатора и коммутаторами Catalyst 4500/4000 Series. Вы настраиваете транкинг на GEC, чтобы позволить несколько интерфейсов VLAN проходить к маршрутизатору для маршрутизации между виртуальными локальными сетями (IVR). Эта конфигурация GEC является стандартной конфигурацией. Все характерные для этой настройки команды перемещаются в субинтерфейсы "порт-канал".

При использовании модуля Уровня 3 помните, что весь трафик, который достигает маршрутизатора на собственном VLAN, маршрутизируется в программном обеспечении. Эта ситуация имеет негативный эффект на производительность коммутатора. Микрокод на WS-X4232-L3 не обрабатывает пакеты 802.1Q, которые входят на собственном VLAN без меток. Вместо этого пакеты переходят к ЦП и Процессам ЦПУ пакеты. Это результаты процесса в высокой загрузке ЦП, если ЦП получает пакеты без меток в высокой скорости на подинтерфейсах собственного VLAN. Поэтому создайте фиктивную VLAN (который не содержит трафика пользователя) как собственный VLAN. В этом примере конфигурации (Диаграмма сети), VLAN 99 служит собственным VLAN. Настройте только собственный VLAN на GEC между маршрутизатором и коммутатором. Не настраивайте никакие другие порты на коммутаторе в этой фиктивной VLAN.

Примечание: Создайте фиктивную VLAN как собственный VLAN на магистральных линиях между маршрутизатором и коммутатором. ЦП направляет в программном обеспечении весь трафик, который передает на собственном VLAN, который имеет негативный эффект на производительность коммутатора. Создайте дополнительную VLAN, которую вы не используете больше нигде в сети и делаете эту VLAN собственным VLAN для магистральных линий между маршрутизатором и коммутатором.

Схема сети

http://www.cisco.com/c/dam/en/us/support/docs/switches/catalyst-4000-series-switches/6198-28-b.gif

Разделы Конфигурации механизма и Конфигурации модуля маршрутизатора супервизора Коммутатора этого документа представляют конфигурации и выходные данные некоторых команд показа. Конфигурации находятся на Supervisor Engine коммутаторов Catalyst 4500/4000 Series и модуля маршрутизатора. Это позволяет направлять между этими тремя подсетями (VLAN 1, VLAN 2 и маршрутизатор, который подключает к Гигабитному Ethernet 1).

Конфигурация механизма супервизора коммутатора

Карта коммутирующего маршрутизатора показывает 34 порта в команде show module. Эти 34 порта включают 32 коммутируемых порта в лицевую панель и коммутируемые порты на 2 гигабита, которые непосредственно соединяются с двумя из портов маршрутизатора. Вот выборка:

bang> (enable) show module
Mod Slot Ports Module-Type                Model                Sub Status  
--- ---- ----- ------------------------- ------------------- ---  --------  
1   1    0     Switching  Supervisor      WS-X4012             no  ok  
2   2    34    10/100/1000  Ethernet      WS-X4232             no  ok  
3   3    34    Router Switch  Card        WS-X4232-L3          no  ok

Mod Module-Name         Serial-Num  
--- ------------------- --------------------  
1                        JAB02380AYG  
2                        JAB03210B6Y  
3                        JAB0417055S  

Mod MAC-Address(es)                         Hw     Fw          Sw  
--- -------------------------------------- ------ ---------- -----------------  
1   00-50-73-2a-f3-00 to 00-50-73-2a-f6-ff 1.0     4.5(1)     5.5(1)  
2   00-50-73-42-a9-68 to 00-50-73-42-a9-89 1.6  
3   00-01-42-06-73-a8 to 00-01-42-06-73-c9 1.0     12.0(7)W5( 12.0(7)W5(14.90

Единственная конфигурация прибавила сторону Catalyst 4000, касается магистрали GEC к модулю маршрутизатора, поскольку эта выборка показывает:

bang> (enable) show config

# ***** NON-DEFAULT CONFIGURATION *****  
!  
! 
!  
!  
!  
set port channel all distribution mac both  
!  
#ip  
set interface sl0 down  
set interface me1 down  
!  
#set boot command  
set boot config-register 0x102  
set boot system flash bootflash:cat4000.5-5-1.bin  
!  
#port channel  
set port channel 3/1-2 156  
!  
#module 1 : 0-port Switching Supervisor  
!  
#module 2 : 34-port 10/100/1000 Ethernet  

set VLAN 3    2/3

!  
#module 3 : 34-port Router Switch Card  
set VLAN 2    3/3
set VLAN 99   3/1-2

!--- This interface has a configuration for 802.1Q routing. 
!--- The interface uses VLAN 99 as the native VLAN. The native VLAN on the 
!--- router switch must match the one that you have configured on the router.
!--- VLAN 99 is a dummy native VLAN. For more information, 
!--- see the note in the Sample Configurations section.


set trunk 3/1  nonegotiate dot1q 1-1005


!--- Note: Trunk mode needs to be in no-negotiate status
!--- because the router module does not support Dynamic Trunking Protocol (DTP).


set trunk 3/2  nonegotiate dot1q 1-1005
set port channel 3/1-2 mode on


!--- Note: You need to force the channel mode to on because
!--- the router module does not support Port Aggregation Protocol (PAgP).
  
end

На коммутаторе команда show cdp neighbor отображает модуль маршрутизатора, как будто модуль был внешним маршрутизатором, который соединяется магистралью GEC на гигабитных портах 3/1 и 3/2. Вот выборка:

bang> (enable) show cdp neighbor
* - indicates vlan mismatch.  
# - indicates duplex mismatch.  
Port     Device-ID                        Port-ID                    Platform  
-------- ------------------------------- -------------------------  ------------  
 2/3     daniella                         Ethernet0                  cisco 2500  
                                         
                                         
                                          
 3/3     donald                           Ethernet0                  cisco 2500

bang> (enable) show trunk 
* - indicates vtp domain mismatch  
Port      Mode          Encapsulation  Status        Native  vlan  
--------  -----------  -------------  ------------   -----------  
 3/1      nonegotiate  dot1q           trunking      99  
 3/2      nonegotiate  dot1q           trunking      99

Port      Vlans allowed on trunk  
--------  ---------------------------------------------------------------------  
 3/1      1-1005  
 3/2      1-1005

Port      Vlans allowed and active in management  domain  
--------  ---------------------------------------------------------------------  
 3/1      1-3, 99
 3/2      1-3, 99

Port      Vlans in spanning tree forwarding  state and not pruned  
--------  ---------------------------------------------------------------------  
 3/1      1-3, 99
 3/2      1-3, 99

Если у вас есть выходные данные команды show trunk от вашего устройства Сisco, вы можете использовать Средство интерпретации выходных данных (только зарегистрированные клиенты) для отображения потенциальных проблем и исправляете.

bang> (enable) show port channel
Port  Status     Channel               Admin Ch  
                  Mode                  Group Id  
----- ---------- -------------------- ----- -----  
 3/1  connected  on                      156   833  
 3/2  connected  on                      156   833  
----- ---------- -------------------- ----- -----

Port  Device-ID                        Port-ID                    Platform  
----- ------------------------------- -------------------------  ----------------  
 3/1  bang-rp                          GigabitEthernet3           cisco Cat4232  
 3/2   Not directly connected to switch  
----- ------------------------------- -------------------------  ----------------

Выход команды show port channel устройства Cisco позволяет отобразить потенциальные проблемы и исправления с помощью средства интерпретации выхода ( только для зарегистрированных клиентов).

Конфигурация модуля маршрутизатора

bang-rp#show verify
Cisco Internetwork Operating System Software  
IOS (tm) L3 Switch/Router Software (CAT4232-IN-M), Version 12.0(7)W5(14.90)   INTERIM 
TEST SOFTWARE  
Copyright (c) 1986-2000 by cisco Systems, Inc.  
Compiled Fri 26-May-00 15:26 by integ  
Image text-base: 0x60010928, data-base: 0x605C8000  

ROM: System Bootstrap, Version 12.0(7)W5(15b) RELEASE SOFTWARE  

bang-rp uptime is 1 day, 22 hours, 7 minutes  
System restarted by power-on  
System image file is "bootflash:cat4232-in-mz.120-7.W5.14.90"  

cisco Cat4232 (R5000) processor with 57344K/8192K bytes of memory.  
R5000 processor, Implementation 35, Revision 2.1  
Last reset from power-on  
1 FastEthernet/IEEE 802.3 interface(s)  
4 Gigabit Ethernet/IEEE 802.3z interface(s)  
123K bytes of non-volatile configuration memory. 

16384K bytes of Flash internal SIMM (Sector size 256K).  
Configuration register is 0x1

bang-rp#show run
Building configuration...
Current Configuration:
!  
version 12.0  
no service pad  
service timestamps debug uptime  
service timestamps log uptime  
no service password-encryption  
!  
hostname bang-rp  
!  
!  
ip subnet-zero  
!  
!  
!  
interface Port-channel1                    
 no ip redirects  
 no ip directed-broadcast  
 hold-queue 300 in  
!  
interface Port-channel1.2 


!--- The configuration of this interface is for 802.1Q routing.
!--- The interface uses a VLAN 2 tag.


encapsulation dot1Q 2
ip address 2.2.2.2 255.255.255.0
no ip redirects
no ip directed-broadcast    
!  
interface Port-channel1.3

!--- The configuration of this interface is for 802.1Q routing.
!--- The interface uses a VLAN 3 tag.

encapsulation dot1Q 3  
ip address 1.1.1.2 255.255.255.0  
no ip redirects  
no ip directed-broadcast  
!
interface Port-channel1.99

!--- The configuration of this interface is for 802.1Q routing. 
!--- The interface uses VLAN 99 as the native VLAN. The native VLAN on the router 
!--- must match the one that you have configured on the switch. VLAN 99 is a dummy
!--- native VLAN. For more information, see the note
!--- in the Sample Configurations section.


encapsulation dot1Q 99 native
no ip address
no ip redirects
no ip directed-broadcast
!
interface FastEthernet1                  

!--- You can use this out-of-band interface for management.
  
 no ip address  
 no ip directed-broadcast  
 shutdown  
!  
interface GigabitEthernet1  
 ip address 3.3.3.2 255.255.255.0  
 no ip directed-broadcast  
!  
interface GigabitEthernet2  
 no ip address  
 no ip directed-broadcast  
 shutdown  
!  
interface GigabitEthernet3  
 no ip address  
 no ip directed-broadcast  
 no negotiation auto  
 channel-group 1                         

!--- Both  Gigabit Ethernet 3 and Gigabit Ethernet 4 
!--- are part of channel group 1.
  
!  
interface GigabitEthernet4  
 no ip address  
 no ip directed-broadcast  
 no negotiation auto  
 channel-group 1                          

!--- Both Gigabit Ethernet 3 and Gigabit Ethernet 4  
!--- are part of channel group 1.
  
!  
router eigrp 1  
 passive-interface FastEthernet1  
 network 1.0.0.0  
 network 2.0.0.0  
 network 3.0.0.0  
!  
ip classless  
!  
arp 127.0.0.2 0050.732a.f300 ARPA  
!  
line con 0  
 transport input none  
line aux 0  
line vty 0 4  
 login  
!  
end  
bang-rp#show cdp neighbor  
Capability Codes: R - Router, T - Trans Bridge, B - Source Route  Bridge  
                   S - Switch, H - Host, I - IGMP, r - Repeater

Device ID        Local Intrfce      Holdtme    Capability Platform  Port ID  
liki              Gig 1               
160         T S      
WS-C3508G-Gig 0/1                           

!--- Liki connects to gigabit 1 on the router. 
!--- You can only see Liki from the router; you cannot 
!--- see Liki from the Supervisor Engine.
  
JAB02380AYG(bang)Port-channel1      148          T S       WS-C4003  3/2  
JAB02380AYG(bang)Port-channel1      147          T S       WS-C4003  3/1

Устранение неполадок

Сеанс от супервизора до модуля с 4232 L3 не работает после того, как это выполнится некоторое время

После того, как коммутатор выполняется некоторое время, сеанс от Супервизора до сбоев модуля с 4232 L3 с этим сообщением об ошибках:

4006> (enable) session 2
Trying IntlgLineCard-2...
session: Unable to tunnel to IntlgLineCard-2 (57)

Наиболее вероятная причина для этого происходит из-за неправильной смежности, сформированной в таблице протокола разрешения адресов (ARP) Модуля супервизора для модуля с 4232 L3 внутриполосный MAC-адрес.

Этот вопрос может быть решен с обновлением системного программного обеспечения к Версии CatOS, на которую не влияет идентификатор ошибки Cisco CSCdx30617 (только зарегистрированные клиенты).

Если обновление системного программного обеспечения не возможно, можно попробовать эти обходные пути:

  • Вместо того, чтобы открыть сеанс к модулю, telnet к любому из IP-адресов настроена на нем.

  • Сброс модуля с 4232 L3 может восстановить проблему временно.

  • Перемещение интерфейса sc0 в другую VLAN может также решить этот вопрос.

Периодические запросы TFTP от с 4232 L3

Модуль с 4232 L3 непрерывно пытается загрузить конфигурацию из сети и отображает это сообщение об ошибках:

%Error opening tftp://255.255.255.255/network-config (Timed out)

Модуль L3 может быть настроен для автоматической загрузки файла конфигурации от сервера TFTP при запуске команды service config. Сохраните файлы конфигурации на сервере TFTP и загрузите их при начальной загрузке. Когда размер файла конфигурации больше, чем размер NVRAM на устройстве, это полезно.

Когда модуль L3 настроен с командой service config, он генерирует Запросы TFTP для загрузки ее конфигурации от сервера TFTP.

В сценарии, где IPS/IDS используется, вы могли бы заметить, что маршрутизатор постоянно передает широковещание tftp. Это подтверждено IP-адресом источника, и назначение 255.255.255.255, трафиком является UDP 69 (TFTP).

Чтобы мешать сообщениям журнала генерироваться, выполните эти команды:

Router#config terminal
Router(config)#no service config
Router(config)#exit
Router#copy running-config startup-config

Заключение и советы

Помните эти ключевые точки при настройке модуля маршрутизации на Catalyst 4500/4000:

  • Гигабитные интерфейсы, которые вы видите на лицевой панели, не являются тем же как гигабитными интерфейсами, которые вы видите при запуске команды show port от Supervisor Engine. Интерфейсы на лицевой панели являются интерфейсами с гигабитом названий 1 и гигабитом 2 на маршрутизаторе.

  • Удостоверьтесь, что собственный VLAN транков между коммутатором и маршрутизатором является фиктивной VLAN. ЦП направляет в программном обеспечении весь трафик, который находится на собственном VLAN. Поэтому создайте одну дополнительную VLAN, которую вы не используете в другом месте и делаете ту VLAN собственным VLAN на ссылках между коммутатором и маршрутизатором.


Дополнительные сведения


Document ID: 6198