Голосовая связь : H.323

Как настроить передачу видео по сети IP для видеомодулей Polycom

20 октября 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Содержание


Введение

В данном документе рассмотрены основные вопросы настройки Polycom ViewStation128 (устройство для проведения видеоконференций) в связке с маршрутизаторами Cisco для передачи видеосигнала в IP-сетях. Также рассматривается добавление QoS и устранение неполадок качества видео в реальном времени в средах LAN и WAN.

Polycom Viewstation взаимодействует к Телевидению для отображения видео-снимков и аудио; это также имеет соединение с LAN для передачи пакетов сжатого видео по IP. Polycom являются оконечными точками H323 так же, как любым другим шлюзом. Видео по IP использует следующие протоколы:

  • H.225 для обмена сигнальными сообщениями управления вызовом

  • H.245 для открытия и закрытия каналов потоков данных носителей

  • Стандарты H.263 и H.261 для видеокодека с форматами изображений

  • G.723 для аудио кодека в режиме 5.3kpbs или 6.3kpbs

Программное обеспечение для Polycom ViewStation128 должно быть последним, его можно загрузить с веб-узла Polycom по LAN. Последние версии микропрограммного обеспечения, доступные во время публикации этого документа, были 7.0.1. http://www.polycom.com/home/ leavingcisco.com

ViewStation может отправлять сжатые видео и аудио вызовы на скорости 128k, 256k, 384k, 512k, 576k или 768k. Эта частота сжатия не включает добавленные заголовки IP и LAN/WAN, поэтому при резервировании полосы пропускания в QoS следует учитывать эти служебные данные. Например, Аудио (64Кб/с)+ Видео (704Кб/с)+IP(25% издержек)=960Кб/с.

Оптимальная задержка видеоприложений подобна голосу: 125-150msec круговая задержка для оптимальных результатов. Добавленная задержка терпима, но сообщила относительно Polycom как ошибка когда вы telnet в него.

Предварительные условия

Требования

Для этого документа отсутствуют особые требования.

Используемые компоненты

Настройка ниже была протестирована в лабораторной работе с Cisco Выпуск ПО IOS� 12.1 (5) T и 12.2 (1a) на Маршрутизаторах Cisco 7200. Polycom ViewStation 128 с встроенным программным обеспечением версии 7.0.1.

Сведения, содержащиеся в данном документе, были получены с устройств в специальной лабораторной среде. Все устройства, описанные в данном документе, были запущены с конфигурацией по умолчанию. При работе с реальной сетью необходимо полностью осознавать возможные результаты использования всех команд.

Условные обозначения

Дополнительные сведения об условных обозначениях в документах см. Cisco Technical Tips Conventions.

Схема сети

В данном документе используется сетевая установка, показанная на следующей схеме. Polycom аппаратно запрограммирован полудуплексно и на 10 Мб/с. 2900XL в этом случае имеет все порты, жестко закодированные к автоматическому/автоматическому, таким образом, никакое изменение не было необходимо на Cisco 7200 FE (интерфейс Fast Ethernet), таким образом, это установлено в 100/полный. В случае прямого соединения модулей Polycom с маршрутизатором или коммутаторами Catalyst необходимо настроить порты в соответствии с режимом передачи и скоростью.

/image/gif/paws/6172/polycom_video_over_ip1.gif

Конфигурация и настройка Polycom ViewStation

Настройка вызовов H.323 для ViewStation

В окне System Info (Сведения о системе) > Admin Setup (Административная установка) выполните следующие действия:

  1. По локальной сети H.323 и локальной сети Intranet конфигурируйте IP адрес Polycom и шлюза по умолчанию.

  2. Для параметров LAN/H.323 и H323 установите имя H323 для данной станции видеоконференц-связи и, при необходимости, любое значение идентификатора E164.

  3. Для LAN/H.323 и H323 можно указать QoS для конкретных портов UDP или TCP (необязательно). Диапазон неподвижных портов TCP 3230-3231, и исправленные порты UDP 3230 - 3235 для видеотрафика. Можно также задать критический IP-приоритет на данных пакетах.

  4. При Общей Настройке настройте стандартные параметры, такие как имя системы, режим автоответа, автоматический набор, язык.

Выполнение вызова H.323 с ViewStation

Все вызовы здесь выполнены с помощью удаленного IP-адреса; можно также использовать номера E.164, если используется привратник для осуществления видеовызовов. Под основным экраном введите в IP-адресе для удаленного Polycom, затем выберите скорость сжатия; это должно соответствовать заданному параметру по умолчанию на удаленной стороне.

Конфигурация маршрутизаторов с QoS для видеосвязи

Один из наиболее эффективных методов QoS, применяемых для передачи видео по протоколу IP в среде WAN, состоит в использовании приоритетов очередности с низкой задержкой (LLQ). policymap может основываться на нескольких других параметрах, обсужденных ниже. Необходимый объем пропускной способности может быть выделенным, и видео, передаваемому по другим IP-приложениями, можно назначить приоритет с помощью LLQ. Кроме того, для обеспечения более высокого качества видеосигнала, линия связи ATM должна быть класса VBR-NRT или CBR.

Конфигурация 7206VXR

Cisco 7206VXR
!
class-map match-all video
  match access-group 101

!--- Class map used to associate access-list 101 to the LLQ class video.

!
policy-map video-police

!--- Definition of the policy map for the LLQ Configuration
 
  class video
    priority 900

!--- This is the priority class/queue assigned for video traffic.
!--- It reserves 900 Kbps for video traffic
  
  class class-default
   fair-queue 64

!-- All other non-video traffic uses fair-queuing policing.
 
!
interface FastEthernet0/0
 description Polycom-192.168.3.90
 ip address 192.168.3.100 255.255.255.0
 duplex half
 no cdp enable

!--- This is the LAN interface that connects to the Polycom ViewStation
!--- No QoS (LLQ) was applied here.
 

!
interface ATM6/0
 no ip address
 load-interval 30
 no atm ilmi-keepalive
!
interface ATM6/0.1 point-to-point
 ip address 10.1.105.1 255.255.255.0
 pvc 1/138

!--- atm pvc defined 

  class-vc VBR-NRT
  encapsulation aal5snap

!--- Layer 2 encapsulation type for atm packets

  service-policy out video-police

!--- Applies LLQ (defined above) to the subinterface for 
!--- layer 3 (Video over IP)traffic shaping and priotization

!
vc-class atm VBR-NRT

!--- atm traffic shaping class defined

  vbr-nrt 1500 1400 100

!--- Maximum bandwidth at 1500Kbps and nominal at 1400Kbps with 100Kbps burst

!
access-list 101 permit tcp any any range 3230 3231
access-list 101 permit udp any any range 3230 3235

!--- These access-lists are used by the LLQ class-map.
!--- These access-lists are based on the fixed UDP (3230-3235) 
!--- and TCP (3230-3231) ports for the ViewStation VideoOverIP


Также следующие конфигурации access-list, возможно, использовались.

  • На основе IP - адреса источника и IP - адреса назначения модулей ViewStation:

    permit ip host access-list 101 192.168.3.90 хоста 192.168.1.90

    permit ip host access-list 101 192.168.1.90 хоста 192.168.3.90

  • На основе приоритета IP-трафика 5:

    ip разрешения access-list 101 любые любые приоритеты 5

Проверка

В настоящее время для этой конфигурации нет процедуры проверки.

Устранение неполадок

Когда вызов установлен, Polycom отслеживает все видеопакеты. С помощью telnet можно подключиться к polycom и лично отслеживать все события. Polycom сообщает о задержке в пакетах H323, а также о потерянных пакетах видео и аудиоданных. Отладки Polycom читаемы и указывают на проблемы, когда может быть трудно заметить их на видео экране.

Некоторые из наиболее распространенных проблем с видеоданными: замораживание, получение из дуплексного Ethernet и/или несоответствие скорости. Если счетчики Ethernet укажут на большое число CRC/кадра/задержанных пакет, то качество видеосигнала ухудшится значительно, таким образом, первая контрольная точка удостоверится, что все интерфейсы LAN (локальной сети) работают безошибочный.

В этом разделе описывается процесс устранения неполадок конфигурации.

Конфигурации на Polycom можно проверить с помощью начального экрана сведений. Имеются информационные отладчики, включенные для каждого действия. Когда у вас есть видеовызов, Polycom автоматически сообщают о вычисленной задержке в пакетах: любые потерянные пакеты и повторно упорядоченные пакеты в результате потери пакетов.

MS-7206VXR-12A#telnet 192.168.3.90

!--- Action: Telnetting to the Polycom ViewStation unit to capture information 
!--- and debug output. 
!--- When a call is established, the Polycom unit keeps track of video packets. 
!--- The Polycom reports h323 packet latency and lost video and voice packets.


Trying 10.122.3.90 ... Open

Hi, my name is :     Polycom166-regnl
Here is what I know about myself:
Serial Number:       011B12
Brand:               Polycom
Software Version:    Release 7.0.1 - 16 Jun 2001
Model:               VS
Network Interface:   ISDN_UNKNOWN
MP Enabled:          No
H323 Enabled:        Yes
IP Address:          192.168.3.90
Time In Last Call:   0:08:41
Total Time In Calls: 44:20:06
Total Calls:         171
Switch Type:         Nortel DMS-100
Country Code:        1
Area Code:           919
ISDN 1 a is:         9913293
ISDN 2 a is:         9913294

Прежде чем QoS было применено, когда видео и данные были выполнены в то же время, результат telnet в Polycom сообщит о следующем; это определенно указывает на неполадки в сети, которые также должны отражаться на качестве видеосигнала.

RTP: Video Packet Lost
RTP: Reseting last_seq_num from 23397 to 23398
RTP: Send FastVideoPicture_MSG
RTP: last eBit 6 plus new sBit 0 not equal 8! (instance 0)
...VideoFastUpdatePictureHandler() time 469850
RTP: Max. video packets stored = 4
RTP: Minimum/MaximumThreshold = 4 0/256, 4 0/256
UI:UI msg from VidDec: S VD1 ReceivedFreezeRelease 0
Received a Picture Fast Update request from the other side
Audio Packet(s) lost - last_seq_num = 15147, new_seq_num = 15149
Transfer 1 duplicate packets
Received a Picture Fast Update request from the other side
RTP: Max. video packets stored = 1
RTP: Minimum/MaximumThreshold = 4 0/256, 4 255/256

Команды для устранения неполадок

Некоторые команды show поддерживаются Средством интерпретации выходных данных(только зарегистрированные клиенты), которое позволяет просматривать аналитику выходных данных команды show.

Следующие выходные данные были зафиксированы маршрутизаторами Cisco IOS; на интерфейсах ATM была применена LLQ, затем атака типа "лавина эхо-запросов" была использована для создания перегрузки во время видеовызова. Когда существует соперничество за полосу пропускания, LLQ динамично располагает по приоритетам видеотрафик.

MS-7206VXR-12A#show queue atm 6/0.1

  Interface ATM6/0.1 VC 1/138 
  Queuing strategy: weighted fair
  Total output drops per VC: 22863
  Output queue: 66/512/64/22863 (size/max total/threshold/drops)
     Conversations  3/4/64 (active/max active/max total)
     Reserved Conversations 0/0 (allocated/max allocated)
     Available Bandwidth 0 kilobits/sec

  (depth/weight/total drops/no-buffer drops/interleaves) 1/4626/0/0/0
  Conversation 1, linktype: ip, length: 54
  source: 10.122.3.100, destination: 10.1.105.2, id: 0x002B, ttl: 255,
  TOS: 192 prot: 6, source port 23, destination port 11032

  (depth/weight/total drops/no-buffer drops/interleaves) 1/5397/0/0/0
  Conversation 51, linktype: ip, length: 308
  source: 10.122.3.90, destination: 10.122.1.90, id: 0x51AB, ttl: 59,
  TOS: 160 prot: 17, source port 49206, destination port 3232

Обратите внимание, что отбрасывания пакетов видеокласса нет в следующих выходных данных.

MS-7206VXR-12A#show policy-map int atm 6/0.1
 ATM6/0.1: VC 1/138 -

  Service-policy output: video-police

    Class-map: video (match-all)
      0 packets, 0 bytes
      30 second offered rate 0 bps, drop rate 0 bps
      Match: access-group 101
      Weighted Fair Queueing
        Strict Priority
        Output Queue: Conversation 72 
       Bandwidth 900 (kbps) Burst 22500 (Bytes)
        (pkts matched/bytes matched) 0/0
        (total drops/bytes drops) 0/0

    Class-map: class-default (match-any)
      290307 packets, 252480609 bytes
      30 second offered rate 2951000 bps, drop rate 2341000 bps
      Match: any 
      Weighted Fair Queuing
        Flow Based Fair Queuing
        Maximum Number of Hashed Queues 64 
        (total queued/total drops/no-buffer drops) 67/35584/0

Дополнительные сведения


Document ID: 6172