Технологии коммутируемого доступа в сеть : "Технология ISDN, CAS"

Настройка конфигурации резервного интерфейса BRI с профилями программы набора номера

5 апреля 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Содержание


Введение

Эта конфигурация демонстрирует использование канала Интерфейса (BRI) ISDN для выполнения резервное копирование выделенной линии, глобальной сети (WAN) или последовательного подключения.

Перед началом работы

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Условные обозначения технических терминов Cisco.

Предварительные условия

Для данного документа отсутствуют предварительные условия.

Используемые компоненты

Настоящий документ не имеет жесткой привязки к каким-либо конкретным версиям программного обеспечения и оборудования.

Сведения, представленные в этом документе, были получены от устройств в специфической лабораторной среде. Все устройства, используемые в этом документе, были запущены с чистой конфигурацией (конфигурацией по умолчанию). При работе с реальной сетью необходимо полностью осознавать возможные результаты использования всех команд.

Теоретические сведения

Команда backup interface переводит интерфейс в режим ожидания до тех пор, пока первичный интерфейс не перестанет работать. Для получения дополнительной информации о характеристике резервного интерфейса обратитесь к Анализам резервного интерфейса, Floating Static Routes и функции Dialer Watch для Резервирования DDR.

Этот пример использует профили программы набора номера с функцией резервного интерфейса. Использование команды резервного интерфейса вынуждает настроенный медосмотр или логический интерфейс быть в режиме ожидания. Если используются профили устройств для набора номера (DDR),то в режим ожидания переходит только логический интерфейс (интерфейс устройства для набора номера), в то время как физический интерфейс (BRI) может все еще использоваться для других подключений, становясь членом другого пула. Дополнительные сведения о профилях номеронабирателя см. в разделе "Настройка ISDN DDR с профилями номеронабирателя".

Настройка

В этом разделе содержатся сведения о настройке функций, описанных в этом документе.

Настройка резервирования Dial-on-Demand Routing (DDR) включает в себя три процедуры:

  1. Настройте DDR. Можно использовать или унаследованные профили DDR, или программы для набора номера. Эта конфигурация использует профили DDR. Перед вводом в действие резервной конфигурации необходима проверка успешного функционирования подключения DDR. Это позволяет перед конфигурированием резервирования удостовериться, что способ дозвона, согласование протокола Point-to-Point Protocol (PPP) и проверка подлинности прошли успешно. Поскольку cхема набора номеров базировала резервное копирование конфигурации, сошлитесь на документ Резервирование DDR с помощью BRIs и Команды резервного интерфейса.

  2. Настройте один из маршрутизаторов на начало DDR-подключения при сбое основной линии. В этой конфигурации для запуска исходящего модемного соединения используется команда "backup interface".

  3. Определите содержательный трафик, который запустит резервное подключение при сбое основного канала.

Мы рекомендуем обратиться к настройке документа и устранение проблем при резервировании DDR для получения дополнительной информации.

Примечание: Дополнительные сведения о командах, используемых в данном документе, можно получить с помощью средства поиска команд (только для зарегистрированных клиентов).

Схема сети

В данном документе используется сеть, изображенная на следующей схеме.

/image/gif/paws/5721/bri-to-bri-backup.gif

Конфигурации

В этой конфигурации для резервирования последовательного канала используется линия BRI. Она также использует протокол маршрутизации OSPF между двумя маршрутизаторами. Как только резервное подключение активировано, необходимо гарантировать, что таблица маршрутизации обновлена для использования нового резервного соединения. Только одна сторона (maui-soho-01) настроена для вызова номера. Другая сторона (maui-nas-05) настроена только на прием вызова.

В этой конфигурации нам подключили маршрутизатор Cisco 1604 с Маршрутизатором Cisco 3640 с помощью последовательного подключения. Оба маршрутизатора оснащены также интерфейсами BRI, которые используются для резервной связи. Cisco 1604 выполняет Cisco Выпуск ПО IOS� 12.1 (5), T и Cisco 3640 используют Cisco IOS 12.1 (2).

Примечание: Настройте подключение DDR (номеронабиратель 1 с BRI0) и проверьте, что это работает должным образом перед настройкой резервного интерфейса и команд backup delay. Это позволит эффективно управлять устранением неполадок профилей программы дозвона, проблем с ISDN, PPP и аутентификацией перед настройкой резервного копирования.

maui-soho-01 (1600)
maui-soho-01#show running-config 
Building configuration...

Current configuration : 1687 bytes
!
version 12.1
no service single-slot-reload-enable
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname maui-soho-01
!
logging rate-limit console 10 except errors
aaa new-model
aaa authentication login default local
aaa authentication login NO_AUTHEN none
aaa authentication ppp default local

!--- Basic AAA configuration for ppp calls.

enable secret 5 <deleted>
!
username maui-nas-05 password 0 cisco

!--- Username for remote router (maui-nas-05) and shared secret(used for
!--- CHAP authentication).
!--- Shared secret must be the same on both sides.

ip subnet-zero
no ip finger
!
isdn switch-type basic-ni
!
interface Loopback0
 ip address 172.17.1.1 255.255.255.0

!--- The loopback address will be used by OSPF for the router ID.

!
interface Ethernet0
 ip address 172.16.1.1 255.255.255.0
!
interface Serial0

!--- Primary Interface

 backup delay 10 30

!--- Backup link will be activated 10 seconds after primary link goes down.
!--- Backup link will be deactivated 30 seconds after primary link is restored.

 backup interface Dialer1

!--- Interface Dialer 1 will provide backup. Dialer 1 will be placed in Standby
!--- until the primary link goes down.

 ip address 192.168.10.2 255.255.255.252
 encapsulation ppp
 no fair-queue
 clockrate 64000
 ppp authentication chap
!
interface BRI0
 no ip address
 encapsulation ppp
 dialer pool-member 10

!--- Assign BRI0 as member of dialer pool 10.
!--- Dialer pool 10 is specified in interface Dialer 1.

 isdn switch-type basic-ni
 isdn spid1 51255511110101 5551111
 isdn spid2 51255511120101 5551112
 ppp authentication chap

!--- Use PPP CHAP authentication.

 ppp multilink
!
interface Dialer1

!--- Dialer 1 provides backup for the serial link.
!--- This interface will be in standby until the primary link is down.

 ip address 172.20.10.2 255.255.255.0

!--- Address for the dialer interface. 
!--- The remote side dialer interface is in the same subnet.

 encapsulation ppp
 dialer pool 10

!--- Defines Dialer pool 10.
!--- BRI 0 is a member of this pool.

 dialer remote-name maui-nas-05

!--- Specifies remote router name. 
!--- This name must match that used by the remote router to authenticate itself.

 dialer idle-timeout 900

!--- Idle timeout is set to 900 seconds (15 minutes).
!--- The link will be disconnected if there is no interesting traffic for 900 secs.
!--- Since OSPF hellos are interesting traffic, this will reset the idle timeout
!--- and cause the link to stay up until the primary link is restored and the dialer
!--- returns to standby mode.

 dialer string 5552222

!--- Defines the destination routers phone number.

 dialer load-threshold 80 outbound

!--- This sets the outbound load level for traffic at which 
!--- additional connections will be added to the MP bundle load level.
!--- Values range from 1 (unloaded) to 255 (fully loaded). The threshold
!--- in this case is 80/255=32%.

 dialer-group 1

!--- Apply interesting traffic definition from dialer-list 1.

 ppp authentication chap

!--- Use PPP CHAP authentication.

 ppp multilink
!
router ospf 5

!--- OSPF configuration. You can use any routing protocol here without any other
!--- changes to the configuration.

 log-adjacency-changes
 network 172.16.1.0 0.0.0.255 area 0
 network 172.17.1.0 0.0.0.255 area 0
 network 172.20.10.0 0.0.0.255 area 0
 network 192.168.10.0 0.0.0.3 area 0
!
ip classless
no ip http server
!
dialer-list 1 protocol ip permit

!--- All IP traffic is designated as interesting.
!--- This is applied to Interface Dialer 1 using dialer-group 1.
!--- OSPF hello packets will trigger the dial.

!
line con 0
 exec-timeout 0 0
 login authentication NO_AUTHEN
 transport input none
line vty 0 4
!
end

Примечание следующие моменты в конфигурации maui-soho-01:

  • Резервная ссылка использует профили дозвона. Это позволяет резервному интерфейсу (номеронабиратель 1) находиться в режиме ожидания во время активности физического интерфейса (BRI 0). Это позволяет использовать физический интерфейс (путем создания его участником другого пула программ для набора номера), в то время как основное соединение активно. Для получения дополнительной информации о профилях DDR обратитесь к Настройке документа и Профилям DDR Устранения проблем.

  • Маршрутизатор использует OSPF в качестве протокола маршрутизации. Можно использовать любой другой протокол маршрутизации (например, RIP, EIGRP) здесь также. Обратитесь к соответствующему IPC руководства конфигурации протокола маршрутизации: Часть 2: Протоколы маршрутизации IP. Убедитесь, что сети основного и резервного интерфейса включены в конфигурацию протокола маршрутизации, чтобы сведения могли передаваться протоколом. если вы хотите использовать статические маршруты вместо протокола маршрутизации, создать статический маршрут со следующим переходом, являющимся удаленным интерфейсом BRI (вам, вероятно, придется сделать его плавающим статическим маршрутом в зависимости от сценария).

  • Любой IP-трафик запустит набор (на основании списка-номеронабирателя 1 и группы-номеронабирателя 1). Это работает хорошо в среде Резервирования DDR резервного интерфейса, так как резервное соединение будет в режиме ожидания и неспособно набрать, когда основной произойдет так или иначе. Поскольку для резервного соединения необходим содержательный трафик, подтвердите наличие источника такого трафика. В этом примере пакеты приветствия OSPF инициируют дозвон. Если протокол маршрутизации не используется, для перехода на резервный канал можно применять эхо-запросы ICMP. Скорректируйте содержательный трафик в зависимости от ваших потребностей.

maui-nas-05 (3640)
maui-nas-05#show running-config 
Building configuration...

Current configuration:
!
version 12.1
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname maui-nas-05
!
aaa new-model
aaa authentication login default local
aaa authentication login NO_AUTHEN none
aaa authentication ppp default local

!--- Basic AAA configuration for ppp calls.

enable secret 5 <deleted>
!
username maui-soho-01 password 0 cisco

!--- Username for remote router (maui-soho-01) and shared secret
!---(used for CHAP authentication).
!--- Shared secret must be the same on both sides.

ip subnet-zero
!         
isdn switch-type basic-ni
!
interface Loopback0
 ip address 172.22.1.1 255.255.255.0

!--- The loopback address will be used by OSPF for the router ID.

!
interface Ethernet0/0
 ip address 172.22.53.105 255.255.255.0
!
interface Ethernet0/1
 no ip address
 shutdown
!
interface BRI1/0
 ip unnumbered Loopback0

!--- Unnumbered to the Loopback 0 address.

 encapsulation ppp
 dialer pool-member 20

!--- Assign BRI0 as member of dialer pool 20.
!--- Dialer pool 20 is specified in interface Dialer 1.

 isdn switch-type basic-ni
 isdn spid1 51255522220101 5552222
 isdn spid2 51255522230101 5552223
 ppp authentication chap

!--- Use ppp chap authentication.

 ppp multilink
!

! <<-- Unused interface configurations have been removed.

!
interface Serial2/0

!--- Primary interface.

 ip address 192.168.10.1 255.255.255.252
 encapsulation ppp
 no fair-queue
 ppp authentication chap
!

! <<--Unused interface configurations have been removed.

!
interface Dialer1

!--- Dialer 1 provides backup for the serial link.
!--- Notice that there is no dialer string on this router. This prevents the NAS
!--- from attempting to dialout using the backup circuit when the primary is up.

 ip address 172.20.10.1 255.255.255.0

!--- Address for the dialer interface. 
!--- The remote side dialer interface is in the same subnet.

 encapsulation ppp
 dialer remote-name maui-soho-01

!--- Specifies remote router name. 
!--- This name must match that used by the remote router to authenticate itself.

 dialer pool 20

!--- Defines dialer pool 20.

 dialer idle-timeout 900

!--- Idle timeout is set to 900 seconds (15 minutes).
!--- This is equal to the idle timeout set on maui-soho-01.

 dialer max-call 4096
 dialer-group 1

!--- Apply interesting traffic definition from dialer-list 1.

 ppp authentication chap

!--- Use ppp chap authentication.

 ppp multilink
!
router ospf 5
 network 172.20.10.0 0.0.0.255 area 0
 network 172.22.1.0 0.0.0.255 area 0
 network 172.22.53.0 0.0.0.255 area 0
 network 192.168.10.0 0.0.0.3 area 0
 default-information originate

!--- Transmit ospf default information. 
!--- This may be required for remote router to use the BRI DDR link.

!
ip classless
ip route 0.0.0.0 0.0.0.0 Ethernet0/0
no ip http server
!
dialer-list 1 protocol ip permit

!--- All IP traffic is designated as interesting.
!--- This is applied to Interface Dialer 1 using dialer-group 1.

!
line con 0
 login authentication NO_AUTHEN
 transport input none
line 97 102
line aux 0
line vty 0 4
!
end

Проверка.

В данном разделе содержатся сведения о проверке работы конфигурации.

Проверьте следующие пункты в конфигурации сервера maui-nas-05 (3640):

  • Конфигурация подобна любой конфигурации внутреннего подключения. Насколько NAS обеспокоен, что резервное соединение является просто другим входящим вызовом.

  • В интерфейсе номеронабирателя отсутствует строка набора, и поэтому он не может устанавливать внешнее телефонное соединение.

  • Весь трафик содержательный. Поскольку резервный канал не имеет возможности подключения к внешним службам (см. предыдущий пункт), это возможно. При создании представляющего интерес трафика более строгим (например, протокол маршрутизации является неинтересным), то существует возможность, что NAS мог разъединить вызов если никакой представляющий интерес трафик по ссылке. В резервных сценариях лучше всего позволить одной стороне (исходящей или входящей) управлять резервным каналом, чтобы избежать нестабильности канала.

Тестирование вспомогательного канала

Резервный интерфейс требует, чтобы протокол основного интерфейса не работал, прежде чем резервный интерфейс даже принесен из режима ожидания. Поэтому невозможно тестировать резервный канал без физического отключения основного канала. Имеются следующие варианты:

  • Используйте команду shutdown для выключения основного интерфейса. Однако не используйте команду shutdown на маршрутизаторе с настроенной командой резервного интерфейса. Это не заставит программное обеспечение Cisco IOS набирать резервное соединение. На маршрутизаторах, не поддерживающих команду backup interface, для активизации резервирования достаточно завершить работу основного интерфейса. В нашем сценарии команда резервного интерфейса backup interface сконфигурирована на maui-soho-01 (1600). Поэтому выполнение команды shutdown на основном интерфейсе maui-nas-05 (3640) активирует резервное соединение.

  • Физически переведите первичное соединение в нерабочее состояние путем отключения кабелей или некоторого аналогичного метода для внедрения резервного интерфейса.

Команды "show"

Некоторые команды show поддерживаются Интерпретатором выходных данных; это позволяет выполнять анализ выходных данных команды show.

  • show isdn status — позволяет убедиться в том, что маршрутизатор правильно взаимодействует с ISDN-коммутатором. В выходных данных команды проверьте наличие сообщений: Layer 1 Status is ACTIVE (Уровень 1 активен) и Layer 2 Status state = MULTIPLE_FRAME_ESTABLISHED (Состояние уровня 2 = MULTIPLE_FRAME_ESTABLISHED). Эта команда показывает также число активных вызовов.

  • show ip interface brief- Этот будет show dialer 1 (на maui-soho-01) в режиме ожидания. Использование номеронабирателя 1 в качестве интерфейса резервного копирования означает, что физический интерфейс (BRI0) не предназначен для резервного копирования. В то время как основное соединение произошло, Поэтому BRI 0 может использоваться для обычного DDR.

Образец команды show output

Следующие результаты показывают таблицу маршрутизации на клиентской стороне. Выходные данные ниже показов таблица маршрутизации с активным основным соединением.

maui-soho-01#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is 192.168.10.1 to network 0.0.0.0

     192.168.10.0/24 is variably subnetted, 2 subnets, 2 masks
C       192.168.10.0/30 is directly connected, Serial0
C       192.168.10.1/32 is directly connected, Serial0
     172.17.0.0/24 is subnetted, 1 subnets
C       172.17.1.0 is directly connected, Loopback0
     172.16.0.0/24 is subnetted, 1 subnets
C       172.16.1.0 is directly connected, Ethernet0
     172.20.0.0/24 is subnetted, 1 subnets
O       172.20.10.0 [110/1849] via 192.168.10.1, 00:00:10, Serial0
     172.22.0.0/16 is variably subnetted, 2 subnets, 2 masks
O       172.22.53.0/24 [110/74] via 192.168.10.1, 00:00:11, Serial0
O       172.22.1.1/32 [110/65] via 192.168.10.1, 00:00:11, Serial0
O*E2 0.0.0.0/0 [110/1] via 192.168.10.1, 00:00:11, Serial0

Выходные данные show ip route (показанный выше) отображают маршруты OSPF, изученные из узла с помощью основного соединения (Serial 0). Теперь давайте переведем основное соединение в нерабочее состояние и давайте активируем резервное соединение.

После того, как резервное соединение активировано, Таблицей ospf обмениваются, и новые маршруты с помощью резервного соединения установлен. Трафик теперь течет по резервному соединению.

maui-soho-01#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is 172.20.10.1 to network 0.0.0.0

     172.17.0.0/24 is subnetted, 1 subnets
C       172.17.1.0 is directly connected, Loopback0
     172.16.0.0/24 is subnetted, 1 subnets
C       172.16.1.0 is directly connected, Ethernet0
     172.20.0.0/16 is variably subnetted, 2 subnets, 2 masks
C       172.20.10.0/24 is directly connected, Dialer1
C       172.20.10.1/32 is directly connected, Dialer1
     172.22.0.0/16 is variably subnetted, 2 subnets, 2 masks
O       172.22.53.0/24 [110/1572] via 172.20.10.1, 00:00:01, Dialer1
O       172.22.1.1/32 [110/1563] via 172.20.10.1, 00:00:02, Dialer1
O*E2 0.0.0.0/0 [110/1] via 172.20.10.1, 00:00:02, Dialer1

Устранение неполадок

В этом разделе описывается процесс устранения неполадок конфигурации.

Команды "debug"

Прежде чем применять команды отладки, ознакомьтесь с разделом "Важные сведения о командах отладки".

  • debug dialer - вывод сведений DDR о пакетах, полученных в интерфейсе номеронабирателя.

  • debug isdn events – эта команда используется, чтобы увидеть действия ISDN, происходящие на стороне пользователя интерфейса ISDN.

  • debug isdn q931 – Показывает установление и разрыв соединений сети ISDN (3-й уровень) между маршрутизатором и коммутатором ISDN.

  • команда debug ppp negotiation отображает сведения об объеме трафика и обмене данными по протоколу PPP в процессе согласования компонентов PPP, включая протокол управления каналом (LCP), аутентификацию и протокол NCP. В успешных переговорах PPP сначала выясняется состояние LCP, затем проводится аутентификация и наконец выполняется согласование NCP.

  • debug ppp authentication – отображает сообщения протокола аутентификации PPP, включая обмен пакетами протокола аутентификации с предварительным согласованием вызова (CHAP) и обмена протоколами аутентификации по паролю (PAP). В случае сбоя проверьте правильность имени пользователя и пароля в протоколе CHAP.

  • debug ppp error —используется для отображения ошибок протокола и статистики ошибок, связанных с согласованием и функционированием соединения PPP.

Неполадки при резервном копировании DDR

Настройте и проверьте, что подключение DDR (Номеронабиратель 1 и BRI0) работает должным образом перед настройкой резервного интерфейса и команд backup delay. Это позволяет проверить правильность функционирования профиля программы набора номера, ISDN, PPP и аутентификации до настройки резервирования. Для устранения проблем соединения DDR обратитесь к Dialup-технологии: Методика поиска и устранения неисправностей.

Теперь, когда вы проверили, что подключение DDR работает должным образом, можно продолжиться к придерживающимся резервным действиям по устранению проблем, выделенным ниже:

  • Снимите основную связь. Не используйте команду shutdown на маршрутизаторе с настроенной командой резервного интерфейса. Это не приводит к вызову резервного канала программным обеспечением Cisco IOS. На маршрутизаторах, не поддерживающих команду backup interface, для активизации резервирования достаточно завершить работу основного интерфейса. В нашем сценарии команда резервного интерфейса backup interface сконфигурирована на maui-soho-01 (1600). Поэтому выполнение команды shutdown на основном интерфейсе maui-nas-05 (3640) активирует резервное соединение. Кроме того, можно физически перевести первичное соединение в нерабочее состояние путем отключения кабелей или некоторого аналогичного метода для внедрения резервного интерфейса.

  • При этом на консоли должно появиться сообщение о подключении резервного интерфейса (интерфейс дозвона 1). Это сообщение появляется только после того, как истечет интервал времени, заданный командой отсрочки резервного копирования. В этой конфигурации задержка запуска резервного копирования – 10 секунд. Если на консоли не отображается это сообщение, проверьте таймер задержки резервирования.

    *Mar  1 03:37:31.788: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0, changed state to down
    *Mar  1 03:37:42.719: %LINK-3-UPDOWN: Interface Dialer1, changed state to up
    
  • Для просмотра таблицы маршрутизации с неработоспособным основным каналом используйте команду show ip route. Необходимо отслеживать прямой путь к номеронабирателю 1. Пропингуйте IP-адрес интерфейса номеронабирателя удаленного маршрутизатора (который находится в той же подсети как interface dialer 1). Вы должны увидеть подключение удаленного доступа и подключиться.

    • Если ссылка не набирает, проверяет, что определение содержательного трафика разрешает ICMP (эхо-запросы).

    • При включении канала можно сделать вывод, что проблема была вызвана отсутствием трафика, предназначенного для этой подсети. Однако, нереально добиться принудительного соединения резервного канала на основе проверки доступности определенного хоста. Чтобы разобраться с этой проблемой, нужно настроить плавающий статический маршрут для трафика по умолчанию.

      maui-soho-01(config)#ip route 0.0.0.0 0.0.0.0 172.20.10.1 200 
      

      Вышеупомянутый маршрут по умолчанию имеет адрес следующего маршрутизатора интерфейса номеронабирателя удаленного маршрутизатора и административное расстояние 200. Если лучший маршрут по умолчанию (т.е. с меньшим административным расстоянием) не существует, этот плавающий маршрут позволяет маршрутизатор маршрутизированным пакетам к интерфейсу номеронабирателя. Помните, что мы ранее проверили, что пакеты, маршрутизировавшие к интерфейсу номеронабирателя, заставляют ссылку набирать.

  • Если маршрутизатор набирает ссылку, но не в состоянии соединяться, то это больше не проблема Резервирования DDR, и необходимо обратиться к Dialup-технологии: Методики поиска и устранения проблем при последующем обслуживании.

Обратитесь к Резервному интерфейсу Устранения проблем раздела в настройке документа и устранение проблем при резервировании DDR для большего количества сведений об устранении проблем.

Пример отладочных выходных данных

Следующие выходные данные отладки (от клиента) показывают сбой основного соединения и активацию резервного соединения:

Примечание: Некоторые линии выходных данных отладки разделены на составные строки для печатей.

maui-soho-01#show debug

maui-soho-01#debug dialer
Dial on demand events debugging is on
maui-soho-01#debug isdn q931
ISDN Q931 packets debugging is on
maui-soho-01#debug ppp negotiation
PPP protocol negotiation debugging is on
maui-soho-01#debug ppp authentication 
PPP authentication debugging is on
maui-soho-01#
*Mar  1 01:09:24.872: %LINK-3-UPDOWN: Interface Serial0, changed state to down

!--- Primary link is unplugged.
!--- Refer to the section Testing the Backup Link for the appropriate procedure.

*Mar  1 01:09:24.880: Se0 IPCP: State is Closed
*Mar  1 01:09:24.884: Se0 CDPCP: State is Closed
*Mar  1 01:09:24.888: Se0 PPP: Phase is TERMINATING [0 sess, 0 load]
*Mar  1 01:09:24.892: Se0 LCP: State is Closed
*Mar  1 01:09:24.892: Se0 PPP: Phase is DOWN [0 sess, 0 load]
*Mar  1 01:09:24.908: Se0 IPCP: Remove route to 192.168.10.1
*Mar  1 01:09:24.916: %OSPF-5-ADJCHG: Process 5, Nbr 172.22.1.1 on Serial0
 from FULL to DOWN, Neighbor Down: Interface down or detached
*Mar  1 01:09:25.864: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0,
 changed state to down

!--- Primary interface line protocol is down. This must happen before the backup
!--- interface is brought out of standby.

*Mar  1 01:09:34.824: Di1 DDR is shutdown, could not clear interface.
*Mar  1 01:09:34.840: BR0 DDR: rotor dialout [priority]

!--- Note: The backup interface was activated 10 seconds after the primary
!--- link went down. This interval was defined with the backup delay command
!--- in maui-soho-01 (1600).

*Mar  1 01:09:34.848: BR0 DDR: Dialing cause ip (s=172.20.10.2, d=224.0.0.5)

!--- OSPF hellos cause the router to dial.

*Mar  1 01:09:34.852: BR0 DDR: Attempting to dial 5552222

!--- Phone number of the remote router that is dialed.

*Mar  1 01:09:34.876: ISDN BR0: TX ->  SETUP pd = 8  callref = 0x0A
*Mar  1 01:09:34.888:         Bearer Capability i = 0x8890
*Mar  1 01:09:34.895:         Channel ID i = 0x83
*Mar  1 01:09:34.903:         Keypad Facility i = '5552222'
*Mar  1 01:09:35.169: ISDN BR0: RX <-  CALL_PROC pd = 8  callref = 0x8A
*Mar  1 01:09:35.177:         Channel ID i = 0x89
*Mar  1 01:09:35.415: ISDN BR0: RX <-  CONNECT pd = 8  callref = 0x8A

!--- Call is connected.

*Mar  1 01:09:35.439: %LINK-3-UPDOWN: Interface BRI0:1, changed state to up
*Mar  1 01:09:35.447: %DIALER-6-BIND: Interface BR0:1 bound to profile Di1
*Mar  1 01:09:35.463: BR0:1 PPP: Treating connection as a callout

!--- PPP negotiation begins.

*Mar  1 01:09:35.467: BR0:1 PPP: Phase is ESTABLISHING, Active Open
 [0 sess, 0 load]
*Mar  1 01:09:35.479: BR0:1 LCP: O CONFREQ [Closed] id 14 len 34
*Mar  1 01:09:35.483: BR0:1 LCP:    AuthProto CHAP (0x0305C22305)
*Mar  1 01:09:35.487: BR0:1 LCP:    MagicNumber 0x10BC0680 (0x050610BC0680)
*Mar  1 01:09:35.491: BR0:1 LCP:    MRRU 1524 (0x110405F4)
*Mar  1 01:09:35.495: BR0:1 LCP:    EndpointDisc 1 Local
 (0x130F016D6175692D736F686F2D3031)
*Mar  1 01:09:35.511: ISDN BR0: TX ->  CONNECT_ACK pd = 8  callref = 0x0A
*Mar  1 01:09:35.566: BR0:1 LCP: I CONFREQ [REQsent] id 6 Len 33
*Mar  1 01:09:35.570: BR0:1 LCP:    AuthProto CHAP (0x0305C22305)
*Mar  1 01:09:35.574: BR0:1 LCP:    MagicNumber 0x30D37ABB (0x050630D37ABB)
*Mar  1 01:09:35.578: BR0:1 LCP:    MRRU 1524 (0x110405F4)
*Mar  1 01:09:35.582: BR0:1 LCP:    EndpointDisc 1 Local
 (0x130E016D6175692D6E61732D3035)
*Mar  1 01:09:35.590: BR0:1 LCP: O CONFACK [REQsent] id 6 Len 33
*Mar  1 01:09:35.598: BR0:1 LCP:    AuthProto CHAP (0x0305C22305)
*Mar  1 01:09:35.602: BR0:1 LCP:    MagicNumber 0x30D37ABB (0x050630D37ABB)
*Mar  1 01:09:35.606: BR0:1 LCP:    MRRU 1524 (0x110405F4)
*Mar  1 01:09:35.610: BR0:1 LCP:    EndpointDisc 1 Local
 (0x130E016D6175692D6E61732D3035)
*Mar  1 01:09:35.618: BR0:1 LCP: I CONFACK [ACKsent] id 14 Len 34
*Mar  1 01:09:35.622: BR0:1 LCP:    AuthProto CHAP (0x0305C22305)
*Mar  1 01:09:35.626: BR0:1 LCP:    MagicNumber 0x10BC0680 (0x050610BC0680)
*Mar  1 01:09:35.630: BR0:1 LCP:    MRRU 1524 (0x110405F4)
*Mar  1 01:09:35.637: BR0:1 LCP:    EndpointDisc 1 Local
 (0x130F016D6175692D736F686F2D3031)
*Mar  1 01:09:35.641: BR0:1 LCP: State is Open
*Mar  1 01:09:35.645: BR0:1 PPP: Phase is AUTHENTICATING, by both
 [0 sess, 1 load]

!--- PPP authentication begins.

*Mar  1 01:09:35.649: BR0:1 CHAP: O CHALLENGE id 6 Len 33 from "maui-soho-01"

!--- This is the username used for outgoing CHAP challenge. The remote router
!--- must have this username configured along with shared secret.

*Mar  1 01:09:35.657: BR0:1 CHAP: I CHALLENGE id 6 Len 32 from "maui-nas-05"

!--- This is the username for incoming CHAP challenge.
!--- This username must be locally configured.

*Mar  1 01:09:35.760: BR0:1 CHAP: O RESPONSE id 6 Len 33 from "maui-soho-01"
*Mar  1 01:09:35.804: BR0:1 CHAP: I SUCCESS id 6 Len 4
*Mar  1 01:09:35.808: BR0:1 CHAP: I RESPONSE id 6 Len 32 from "maui-nas-05"
*Mar  1 01:09:35.820: BR0:1 CHAP: O SUCCESS id 6 Len 4

!--- CHAP authentication is successful.

*Mar  1 01:09:35.828: BR0:1 PPP: Phase is VIRTUALIZED [0 sess, 1 load]
*Mar  1 01:09:35.844: Di1 DDR: Authenticated host maui-nas-05 with no matching
 dialer map
*Mar  1 01:09:35.848: Di1 PPP: Phase is UP [0 sess, 1 load]
*Mar  1 01:09:35.856: Di1 IPCP: O CONFREQ [Closed] id 6 Len 10
*Mar  1 01:09:35.860: Di1 IPCP:    Address 172.20.10.2 (0x0306AC140A02)
*Mar  1 01:09:35.872: Di1 CDPCP: O CONFREQ [Closed] id 6 Len 4
*Mar  1 01:09:35.876: BR0:1 MLP: maui-nas-05, multilink up, first link
*Mar  1 01:09:35.884: BR0:1 IPCP: MLP bundle interface is built,
 process packets now 
*Mar  1 01:09:35.887: BR0:1 IPCP: Redirect packet to Di1
*Mar  1 01:09:35.891: Di1 IPCP: I CONFREQ [REQsent] id 6 Len 10
*Mar  1 01:09:35.895: Di1 IPCP:    Address 172.20.10.1 (0x0306AC140A01)
*Mar  1 01:09:35.903: Di1 IPCP: O CONFACK [REQsent] id 6 Len 10
*Mar  1 01:09:35.907: Di1 IPCP:    Address 172.20.10.1 (0x0306AC140A01)
*Mar  1 01:09:35.911: BR0:1 CDPCP: MLP bundle interface is built,
 process packets now 
*Mar  1 01:09:35.915: BR0:1 CDPCP: Redirect packet to Di1
*Mar  1 01:09:35.919: Di1 CDPCP: I CONFREQ [REQsent] id 6 Len 4
*Mar  1 01:09:35.927: Di1 CDPCP: O CONFACK [REQsent] id 6 Len 4
*Mar  1 01:09:35.931: Di1 IPCP: I CONFACK [ACKsent] id 6 Len 10
*Mar  1 01:09:35.935: Di1 IPCP:    Address 172.20.10.2 (0x0306AC140A02)
*Mar  1 01:09:35.939: Di1 IPCP: State is Open

!--- IPCP state is open and route will be installed.

*Mar  1 01:09:35.951: Di1 CDPCP: I CONFACK [ACKsent] id 6 Len 4
*Mar  1 01:09:35.955: Di1 CDPCP: State is Open
*Mar  1 01:09:35.959: Di1 DDR: dialer protocol up
*Mar  1 01:09:35.971: Di1 IPCP: Install route to 172.20.10.1

!--- Route to remote side is installed.

*Mar  1 01:09:36.840: %LINK-3-UPDOWN: Interface Dialer1, changed state to up
*Mar  1 01:09:36.844: Di1 LCP: Not allowed on a Dialer Profile
*Mar  1 01:09:36.848: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI0:1,
 changed state to up
*Mar  1 01:09:41.411: %ISDN-6-CONNECT: Interface BRI0:1 is now connected to 5552222
 maui-nas-05

!--- Connection is up.

*Mar  1 01:09:44.931: %OSPF-5-ADJCHG: Process 5, Nbr 172.22.1.1 on
 Dialer1 from LOADING to FULL, Loading Done

!--- OSPF database exchange is complete.

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения


Document ID: 5721