Технологии коммутируемого доступа в сеть : "Технология ISDN, CAS"

Настройка конфигурации для резервирования через устройства DDR с использованием интерфейсов BRI и функции Dialer Watch

5 апреля 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Содержание


Введение

В данном документе описывается использование канала с интерфейсом передачи данных с номинальной скоростью (BRI) ISDN для создания резерва для выделенного канала, WAN или последовательной связи с использованием средства наблюдения номеронабирателя. Для получения дополнительных сведений о функциях средства наблюдения номеронабирателя обратитесь к разделам "Оценка резервных интерфейсов", "Плавающие статические маршруты", а также "Dialer Watch для резервирования DDR".

Перед началом работы

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Технические рекомендации Cisco. Условные обозначения.

Предварительные условия

Для данного документа отсутствуют предварительные условия.

Используемые компоненты

Сведения, содержащиеся в данном документе, относятся к следующим версиям программного и аппаратного обеспечения.

  • Cisco 1604 с 1 U-интерфейсом BRI рабочий Cisco Выпуск ПО IOS� 12.1 (5) T.

Сведения, представленные в этом документе, были получены от устройств в специфической лабораторной среде. Все устройства, используемые в этом документе, были запущены с чистой конфигурацией (конфигурацией по умолчанию). При работе с реальной сетью необходимо полностью осознавать возможные результаты использования всех команд.

Теоретические сведения

Данный пример использует устаревшую технологию DDR, которая использует команду cхемы набора номеров для подключения BRI. Можно также использовать профили программы набора номера вместо наследуемых DDR (схемы набора номера). Дополнительные сведения о профилях номеронабирателя см. в разделе "Настройка ISDN DDR с профилями номеронабирателя".

Для настройки резервирования DDR выполните следующие действия:

  1. Выполните настройку маршрутизации вызовов по запросу (DDR) с использованием унаследованных профилей DDR или программы для набора номера. Перед вводом в действие резервной конфигурации необходима проверка успешного функционирования подключения DDR. Это позволит проверить используемый метод телефонного соединения, согласование протокола двухточечного соединения Point-to-Point Protocol (PPP) и аутентификация прошли успешно до резервирования конфигурации.

  2. Настройте маршрутизатор на начало архивации DDR-подключения при сбое основной линии. Эта конфигурация использует средство наблюдения номеронабирателя для запуска подключения к внешней службе.

Для получения дополнительных сведений о шагах, необходимых для настройки резерва, обратитесь к документу "Настройка и устранение неисправностей резервирования DDR"

Функция Dialer Watch

С помощью средства Dialer watch маршрутизатор проверяет наличие указанного маршрута и при его отсутствии инициирует набор по резервному каналу. В отличие от других методов резервирования (например, создания резервного интерфейса или плавающих статических маршрутов), при использовании функции Dialer watch инициирование дозвона не требует наличия содержательного трафика. Процесс, используемый функцией dialer watch, описан ниже:

  • При удалении наблюдаемого маршрута средство контроля за номеронабирателем выполняет поиск хотя бы одного допустимого маршрута к любым наблюдаемым IP-адресам или сетям.

    • Если допустимого маршрута нет, основная линия считается отключенной и непригодной к использованию.

      • Затем механизм просмотра устройства набора номера запускает вызов, а маршрутизаторы соединяются и обмениваются данными маршрутизации. Весь трафик для удаленной сети теперь будет использовать дублирующий канал связи.

    • Если хотя бы для одной наблюдаемой IP-сети определен допустимый маршрут, который указывает на интерфейс, отличный от резервного (заданного для средства контроля за номеронабирателем), основной канал считается рабочим, и резервный канал не инициируется.

  • После начала работы резервного канала выполняется повторная проверка основного канала по истечении времени ожидания простоя. Если основной канал остается отключенным, происходит сброс таймера простоя. Так как маршрутизатор должен периодически проверять, было ли основное соединение восстановлено, настройте маленькое значение для idle-timeout номеронабирателя. После восстановления основного канала протокол маршрутизации обновит маршрутную таблицу, и весь трафик снова проследует на основной канал. Поскольку трафик больше не будет проходить по резервному каналу, таймаут простоя будет завершен и маршрутизатор отключит этот канал.

    Примечание: При определении представляющего интерес трафика запретите, что трафик протокола маршрутизации препятствует тому, чтобы периодический hellos перезагрузил время простоя.

  • Если основной канал активирован заново, вторичный резервный канал отключается. Тем не менее, можно использовать таймер отключения, чтобы создать задержку перед отключением резервного канала после восстановления основного канала. Этот таймер задержки запускается, когда найден основной маршрут для передачи, а срок таймера простоя истекает. Этот таймер задержки может обеспечить стабильность, особенно для интерфейсов с переброской состояния или с регулярно изменяющимися маршрутами.

Для получения дополнительных сведений о функциях средства наблюдения номеронабирателя обратитесь к разделам "Оценка резервных интерфейсов", "Плавающие статические маршруты", а также "Dialer Watch для резервирования DDR".

Настройка

В этом разделе содержатся сведения о настройке функций, описанных в этом документе.

Схема сети

В данном документе используется сеть, изображенная на следующей схеме.

/image/gif/paws/5600/bri-backup-map-watch.gif

Конфигурации

В этой конфигурации для резервирования последовательного канала используется линия BRI. В этой конфигурации также используется протокол предпочтения кратчайшего пути (OSPF) для соединения двух маршрутизаторов. Как только резервное соединение будет активизировано, необходимо проверить, что таблица маршрутизации обновлена для использования нового резервного маршрута.

Дополнительные сведения об условных обозначениях команд см. "Условные обозначения технических терминов Cisco".

maui-soho-01 (1600)
maui-soho-01#show running-config 
Building configuration...

Current configuration : 1546 bytes
!
version 12.1
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname maui-soho-01
!
logging rate-limit console 10 except errors
aaa new-model
aaa authentication login default local
aaa authentication login NO_AUTHEN none
aaa authentication ppp default local

!--- This is the basic AAA configuration for ppp calls.

enable secret 5 <deleted>!
username maui-nas-05 password 0 cisco

!--- Username for remote router (maui-nas-05) and shared secret.
!--- Shared secret (used for CHAP) must be the same on both sides.

ip subnet-zero
no ip finger
!
isdn switch-type basic-ni
!
interface Loopback0
 ip address 172.17.1.1 255.255.255.0
!
interface Ethernet0
 ip address 172.16.1.1 255.255.255.0
!
interface Serial0

!--- Primary link

 ip address 192.168.10.2 255.255.255.252
 encapsulation ppp
 ppp authentication chap
!
interface BRI0
 ip address 172.20.10.2 255.255.255.0

!--- IP address for the BRI interface (backup link)

 encapsulation ppp
 dialer idle-timeout 30

!--- Idle timeout (in seconds) for this backup link.
!--- Dialer watch checks the status of the primary link every time the
!--- idle-timeout expires.

 dialer watch-disable 15

!--- Delays disconnecting the backup interface for 15 seconds after the
!--- primary interface is found to be up, that is 15 seconds after the idle 
!--- timeout expired after the primary link came UP.

 dialer load-threshold 1 outbound

!--- This sets the load level for traffic at which additional connections
!--- will be added to the Multilink PPP bundle.
!--- Load level values range from 1 (unloaded) to 255 (fully loaded).

 dialer map ip 172.20.10.1 name maui-nas-05 broadcast 5551111

!--- Dialer map for the BRI interface of the remote router.

 dialer map ip 172.22.53.0 name maui-nas-05 broadcast 5551111

!--- Map statement for the route/network being watched by the
!--- dialer watch-list command
!--- This address must exactly match the network configured with the
!--- dialer watch-list command.
!--- When the watched route disappears, this dials the specified
!--- phone number.  

 dialer watch-group 8

!--- Enable dialer watch on this backup interface.
!--- Watch the route specified with dialer watch-list 8.

 dialer-group 1

!--- Apply interesting traffic defined in dialer-list 1.

 isdn switch-type basic-ni
 isdn spid1 51255522220101 5552222
 isdn spid2 51255522230101 5552223

!--- SPID information. Contact your telco for the SPID format.
!--- In many parts of the world, SPIDs are not required. 
!--- In such cases, omit the above two commands.

 ppp authentication chap

!--- Use CHAP authentication.

 ppp multilink

!--- Enable Multilink.

!
router ospf 5
 log-adjacency-changes
 network 172.16.1.0 0.0.0.255 area 0
 network 172.17.1.0 0.0.0.255 area 0
 network 172.20.10.0 0.0.0.255 area 0
 network 192.168.10.0 0.0.0.3 area 0
!
ip classless
no ip http server
!
dialer watch-list 8 ip 172.22.53.0 255.255.255.0

!--- This defines the route(s) to be watched.
!--- This exact route (including subnet mask) must exist in the 
!--- routing table. Use the dialer watch-group 8 command to apply this
!--- list to the backup interface.

access-list 101 remark Define Interesting Traffic
access-list 101 deny   ospf any any

!--- Mark OSPF as uninteresting.
!--- This will prevent OSPF hellos from keeping the link up.

access-list 101 permit ip any any
dialer-list 1 protocol ip list 101

!--- Interesting traffic is defined by access-list 101.
!--- This is applied to BRI0 using dialer-group 1.

!
line con 0
 login authentication NO_AUTHEN
 transport input none
line vty 0 4
!         
end

maui-nas-05 (3640)
maui-nas-05#show running-config 
Building configuration...

Current configuration:
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname maui-nas-05
!
aaa new-model
aaa authentication login default local
aaa authentication login NO_AUTHEN none
aaa authentication ppp default local

!--- This is the basic AAA configuration for PPP calls.

enable secret 5 <deleted> !
username maui-soho-01 password 0 cisco

!--- Username for remote router (maui-soho-01) and shared secret.
!--- Shared secret(used for CHAP authentication) must be the same on
!--- both sides.

!
ip subnet-zero
!         
isdn switch-type basic-ni
!
interface Loopback0
 ip address 172.22.1.1 255.255.255.0
!
interface Ethernet0/0
 ip address 172.22.53.105 255.255.255.0
!
interface Ethernet0/1
 no ip address
 shutdown
!
interface BRI1/0

!--- Interface for backup link.

 ip address 172.20.10.1 255.255.255.0
 encapsulation ppp
 dialer map ip 172.20.10.2 name maui-soho-01 broadcast

!--- This is the dialer map with IP address and authenticated username
!--- for the remote destination. The name should match the authentication
!--- username provided by the remote side. The dialer map statement is
!--- used even though this router is not dialing out
!--- (that is, the phone number is not specified).

 dialer-group 1

!--- Apply interesting traffic defined in dialer-list 1.

 isdn switch-type basic-ni
 isdn spid1 51255511110101 5551111
 isdn spid2 51255511120101 5551112

!--- SPID information. Contact your telco for the SPID format.
!--- In many parts of the world, SPIDs are not required.
!--- In such cases, omit the above two commands.

 ppp authentication chap
 ppp multilink
!

!--- Output removed.

!
interface Serial2/0

!--- Primary link.

 ip address 192.168.10.1 255.255.255.252
 encapsulation ppp
 clockrate 64000
 ppp authentication chap
!

!--- Output removed.

!
router ospf 5
 network 172.20.10.0 0.0.0.255 area 0
 network 172.22.1.0 0.0.0.255 area 0
 network 172.22.53.0 0.0.0.255 area 0
 network 192.168.10.0 0.0.0.3 area 0
 default-information originate
!
ip classless
ip route 0.0.0.0 0.0.0.0 Ethernet0/0
no ip http server
!
dialer-list 1 protocol ip permit

!--- This defines all IP traffic as interesting. OSPF does not need 
!--- to be marked uninteresting since this link does not dial out.
!--- Adjust the interesting traffic definition depending on your needs.

!
line con 0
 login authentication NO_AUTHEN
 transport input none
line 97 102
line aux 0
line vty 0 4
!
end

Примечание: Конфигурация maui-nas-05 не включает резервных связанных команд. С точки зрения maui-nas-05 резервное соединение является просто другим клиентом входящих звонков. Это может упростить конфигурацию центрального узла в ситуациях, когда много устройств устанавливают резервное соединение на одном и том же центральном узле. В идеальном сценарии резервирования только одна сторона инициирует вызовы, тогда как другая их принимает.

Команды функции Dialer Watch

Ниже следует список команд, доступных механизму dialer watch. Некоторые из этих команд включены в приведенную выше конфигурацию; другие предоставлены для справок.

  • address-mask ip ip-address group-number dialer watch-list : Определяет IP-адреса или сети, которые будут наблюдаться. Настроенный адрес или сеть (с правильной маской) должны существовать в таблице маршрутизации., можно также наблюдать несколька маршрутов с командой dialer watch-list. Пример:

    dialer watch-list 1 ip 10.1.1.0 255.255.255.0
    dialer watch-list 1 ip 10.1.2.0 255.255.255.0
    dialer watch-list 1 ip 10.1.3.0 255.255.255.0       
    
    
  • dialer watch-group group-number : Включите часы номеронабирателя на резервном интерфейсе. Номер группы, использованный здесь, соответствует номеру группы команды watch-list номеронабирателя, определяя маршруты, подлежащие наблюдению . Команда dialer watch-group с количеством конкретной группы может только быть настроена на одном интерфейсе. Это значит, что маршрутизатор не может использовать несколько интерфейсов для предоставления резерва для отдельного маршрута. Однако один интерфейс может иметь несколько команд dialer watch-group с разными номерами групп. Таким образом, один интерфейс может использоваться для резервирования нескольких маршрутизаторов.

  • dialer watch-disable seconds : Примените запрещать время задержки к интерфейсу. После восстановления основного интерфейса эта задержка препятствует отключению резервного интерфейса в течение определенного периода времени. Этот таймер задержки запущен, когда счетчик простоя истекает, и статус основного маршрута проверен и, как находят, возрос. Эта задержка может обеспечить стабильность, особенно для интерфейсов автоматического возобновления или интерфейсов, испытывающих частые изменения маршрутизаторов.

  • секунды delay route-check initial group-number dialer watch-list: Эта команда инициирует проверку основного маршрута после первоначального запуска маршрутизатора и по истечении времени ожидания (в секундах). Без этой команды dialer watch вызывается только в том случае, когда главный маршрут удаляется из таблицы маршрутизации. Если первичный канал связи не инициализируется во время начального запуска маршрутизатора, маршрут никогда не добавляется к таблице маршрутизации и следовательно не может отслеживаться. Поэтому с этой командой, часы номеронабирателя наберут резервное соединение в случае сбоя основного соединения во время начального запуска маршрутизатора.

Проверка.

Для получения дополнительной информации обратитесь к Использованию Команды show isdn status для Устранения проблем BRI.

В данном разделе содержатся сведения о проверке работы конфигурации.

Некоторые команды show поддерживаются Интерпретатором выходных данных, взял, который позволяет вам просматривать аналитику выходных данных команды show.

  • show dialer [interface type number] - Отображает общую диагностическую информацию для интерфейсов, настроенных для DDR, и отображает конфигурацию таймера и время перед временами соединения. Следует проверить следующие сообщения:

    • "Dialer state is data link layer up" (Состояние номеронабирателя: канальный уровень установлен) - Номеронабиратель запущен правильно.

      • "Physical layer up" (физический уровень функционирует) – протокол линии работает, но протокол управления сетью (NСP) нет.

    • Dial reason (Причина вызова): отображает исходный и конечный адреса пакета, инициировавшего вызов номера.

  • show isdn status — позволяет убедиться в том, что маршрутизатор правильно взаимодействует с ISDN-коммутатором. Эта команда показывает также число активных вызовов. Следует изучить такие сообщения:

    • Состояние уровня 1 - ACTIVE,

    • "Layer 2 Status state = MULTIPLE_FRAME_ESTABLISHED" (состояние 2-го уровня = установлено многокадровое)

Образец команды show output

Таблицу маршрутизации клиента, maui-soho-01 (1600), с функционированием основного соединения показывают ниже:

maui-soho-01#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - ISIS level-1, L2 - ISIS level-2, ia - ISIS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is 192.168.10.1 to network 0.0.0.0

     192.168.10.0/24 is variably subnetted, 2 subnets, 2 masks
C       192.168.10.0/30 is directly connected, Serial0
C       192.168.10.1/32 is directly connected, Serial0
     172.17.0.0/24 is subnetted, 1 subnets
C       172.17.1.0 is directly connected, Loopback0
     172.16.0.0/24 is subnetted, 1 subnets
C       172.16.1.0 is directly connected, Ethernet0
     172.20.0.0/24 is subnetted, 1 subnets
C       172.20.10.0 is directly connected, BRI0
     172.22.0.0/16 is variably subnetted, 2 subnets, 2 masks
O       172.22.53.0/24 [110/74] via 192.168.10.1, 02:48:10, Serial0
O       172.22.1.1/32 [110/65] via 192.168.10.1, 02:48:10, Serial0
O*E2 0.0.0.0/0 [110/1] via 192.168.10.1, 02:48:10, Serial0

Выходные данные show ip route, показанного выше, отображают маршруты OSPF, изученные из узлов с помощью основного соединения (последовательный 0). Заметьте, что наблюдаемый маршрут (172.22.53.0 с маской 255.255.255.0) существует в таблице маршрутизации. Это должно быть проверено для часов номеронабирателя для функционирования правильно.

Теперь мы переводим основное соединение в нерабочее состояние и активируем резервное соединение. После того, как резервное соединение активировано, Таблицей ospf обмениваются, и новые маршруты с помощью резервного соединения установлен. Трафик теперь проходит по резервному соединению.

Пример этой ситуации приведен ниже:

maui-soho-01#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - ISIS, L1 - ISIS level-1, L2 - ISIS level-2, IA - ISIS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is 172.20.10.1 to network 0.0.0.0

     172.17.0.0/24 is subnetted, 1 subnets
C       172.17.1.0 is directly connected, Loopback0
     172.16.0.0/24 is subnetted, 1 subnets
C       172.16.1.0 is directly connected, Ethernet0
     172.20.0.0/16 is variably subnetted, 2 subnets, 2 masks
C       172.20.10.0/24 is directly connected, BRI0
C       172.20.10.1/32 is directly connected, BRI0
     172.22.0.0/16 is variably subnetted, 2 subnets, 2 masks
O       172.22.53.0/24 [110/1572] via 172.20.10.1, 00:01:26, BRI0
O       172.22.1.1/32 [110/1563] via 172.20.10.1, 00:01:27, BRI0
O*E2 0.0.0.0/0 [110/1] via 172.20.10.1, 00:01:27, BRI0

Выходные данные выше показов, что таблица маршрутизации была обновлена и весь трафик, будут использовать резервное соединение (BRI0)

Команда show dialer может использоваться, чтобы проверить, что интерфейс DDR подошел должным образом. Заметьте, что интерфейс BRI был набран, потому что маршрутизатор обнаружил, что был потерян наблюдаемый маршрут.

maui-soho-01#  show dialer

BRI0 - dialer type = ISDN

Dial String      Successes   Failures    Last DNIS   Last status
5551111                 10          0    00:01:49       successful
0 incoming call(s) have been screened.
0 incoming call(s) rejected for callback.

BRI0:1 - dialer type = ISDN
Idle timer (30 secs), Fast idle timer (20 secs)
Wait for carrier (30 secs), Re-enable (15 secs)
Dialer state is data link layer up
Dial reason: Dialing on watched route loss
Time until disconnect 11 secs
Connected to 5551111 (maui-nas-05)

BRI0:2 - dialer type = ISDN
Idle timer (30 secs), Fast idle timer (20 secs)
Wait for carrier (30 secs), Re-enable (15 secs)
Dialer state is idle

Устранение неполадок

Устранение неполадок для функции Dialer Watch

Настройте и проверьте, что подключение DDR работает должным образом перед настройкой часов номеронабирателя. Это поможет вам изолировать и решать проблемы DDR перед занятием резервными связанными проблемами. При настройке функции Dialer Watch это возобновлено, что вы используете Cisco Выпуск ПО IOS� 12.1 (7) или выше. Теперь будут рассмотрены некоторые проблемы и их возможные решения:

Проблема: Когда основное соединение выключается, маршрутизатор не набирает резервное соединение.

Возможное решение #1: Используйте команду show ip route, чтобы проверить, что маршрут, который вы смотрите, существует в таблице маршрутизации. Маршрут, настроенный для механизма Dialer Watch, должен полностью соответствовать маршруту в таблице маршрутизации. Это включает в себя проверку того, что маски подсети идентичны. Например, если в таблице маршрутизации содержится значение 10.0.0.0/8, и выполняется команда dialer watch-list 1 ip 10.0.0.0 255.255.255.0 (адрес 10.0.0.0/24), функция Dialer Watch не сможет определить, что адрес 10.0.0.0/8 больше не содержится в таблице маршрутизации.

Возможное решение #2: Проверьте, что есть два оператора схемы набора номеров на резервном интерфейсе.

  • Для маршрута/сети должна быть одна инструкция сопоставления, заданная командой dialer watch-list

  • Должен быть один оператор отображения для IP-адреса интерфейса удаленного маршрутизатора.

Возможное решение #3: Настройте секунды delay route-check initial group-number команды dialer watch-list . Обратитесь к Командам Dialer Watch раздела для получения дополнительной информации.

Проблема: Резервное соединение установлено, но никакие сведения о маршрутизации не переданы по резервному соединению.

Возможное решение: Проверьте, что IP - сеть резервного интерфейса включен в конфигурацию протокола маршрутизации

Проблема: Резервный канал не отключается при восстановлении основной линии.

Примечание: Благодаря средству Dialer watch содержательный трафик используется только для управления временем ожидания простоя, которое, в свою очередь, управляет интервалом, используемым для опроса состояния главного маршрута.

Возможное решение #1: Понизьте idle-timeout номеронабирателя. По умолчанию составляет 120 секунд, но можно хотеть понизить это значение в зависимости от потребностей.

Возможное решение #2: Используйте команду show dialer, чтобы проверить, что не перезагружается время простоя.

Измените определение содержательного трафика (настроенный с командой dialer-list), чтобы быть более строгими. Трафик протокола маршрутизации нужно отметить как бесполезный.

Как последнее прибежище можно настроить весь IP - трафик как неинтересное использование команды dialer-list 1 protocol ip deny. При таком определении интересного трафика время ожидания простоя не будет сбрасываться и маршрутизатор будет проверять статус первичного канала с заданным интервалом.

Возможное решение #3: Проверьте, чтобы удостовериться, что резервное соединение менее выбираемо, чем основное соединение с точки зрения протокола маршрутизации в использовании. Это - то, так, чтобы, когда основное соединение восстанавливается, протокол динамической маршрутизации предпочел основного по резервному соединению и не сбалансировал нагрузку по двум ссылкам. Сбой, чтобы сделать это может заставить резервное соединение постоянно не ложиться спать. С помощью команды show ip route можно определить, используются ли маршрутизатором первичные и резервные каналы для распределения трафика между маршрутизаторами. В таком случае маршрутизатор поддержит одинаковые дублированные маршруты; один для основного и один для резервного соединения можно использовать любой из следующих методов, чтобы гарантировать, что резервное соединение менее выбираемо с точки зрения протокола маршрутизации: пропускная способность, задержка или расстояние. Обратитесь к Ссылке Программной команды Cisco IOS для получения дополнительной информации.

Для общих Уровней ISDN 1,2 и 3 Устранения проблем обращаются к документу Использование Команды show isdn status для Устранения проблем BRI.

Команды для устранения неполадок

Некоторые команды show поддерживаются Интерпретатором выходных данных; это позволяет выполнять анализ выходных данных команды show.

Примечание: Прежде чем применять команды отладки, ознакомьтесь с разделом "Важные сведения о командах отладки".

  • debug dialer - Это используется для показа сведений DDR о пакетах, полученных на интерфейсе номеронабирателя.

  • debug isdn q931 – показывает настройку вызова и разрывает сетевое соединение ISDN (уровень 3) между маршрутизатором и коммутатором ISDN.

  • debug ppp negotiation - Это отображает информацию на трафике PPP и обменивается при согласовании о компонентах PPP включая протокол управления каналом (LCP), аутентификацию и NCP. В случае успешного согласования PPP сначала открывается состояние LCP, затем выполняется аутентификация и согласование NCP.

  • debug ppp authenticaion - Это отображает сообщения протокола аутентификации PPP, включая обмены пакетами Протокола аутентификации по квитированию вызова (CHAP) и обмены Протокола аутентификации пароля (PAP). В случае сбоя проверьте правильность имени пользователя и пароля в протоколе CHAP.

  • debug ppp error - Это отображает ошибки протокола и статистику ошибок, привязанную к согласованию PPP - подключения и операции.

Пример отладочных выходных данных

Выходные данные debug dialer ниже показов сбой основного соединения и часы номеронабирателя, распознающие потерянный маршрут. Маршрутизатор тогда инициирует резервное соединение. После каждого раза idle-timeout истекает, проверки маршрутизатора, не работает ли основное соединение. Если основное соединение, как находят, произошло, часы номеронабирателя разъединяют резервное соединение после того, как истекает запрещать таймер. В отладках обратите внимание на метку времени в каждом сообщении, поскольку они могут предоставить сведения о различных таймерах и временах простоя, которые активны.

maui-soho-01#debug dialer
Dial on demand events debugging is on
maui-soho-01#
03:47:07: %LINK-3-UPDOWN: Interface Serial0, changed state to down

!--- Primary Link is brought down

03:47:07: %OSPF-5-ADJCHG: Process 5, Nbr 192.168.10.1 on Serial0 from FULL to DOWN,
 Neighbor Down: Interface down or detached
03:47:07: DDR: Dialer Watch: watch-group = 8

!--- Use dialer watch-group 8. 

03:47:07: DDR:    network 172.22.53.0/255.255.255.0 DOWN,
03:47:07: DDR:    primary DOWN

!--- The primary network is down.

03:47:07: DDR: Dialer Watch: Dial Reason: Primary of group 8 DOWN

!--- Dialing Reason is that the primary route is down.

03:47:07: DDR: Dialer Watch: watch-group = 8, 
03:47:07: DDR:    dialing secondary by dialer map 172.22.53.0 on BR0

!--- Indicates which dialer map statement is used for the dialout.

03:47:07: BR0 DDR: Attempting to dial 5551111
03:47:08: %LINK-3-UPDOWN: Interface BRI0:1, changed state to up
03:47:08: BR0:1 DDR: Dialer Watch: resetting call in progress
03:47:08: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0, changed state
 to down
03:47:08: BR0:1 DDR: dialer protocol up
03:47:09: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI0:1, changed state
 to up
03:47:14: %ISDN-6-CONNECT: Interface BRI0:1 is now connected to 5551111 maui-nas-05

!--- BRI link is connected.

03:47:17: %OSPF-5-ADJCHG: Process 5, Nbr 192.168.10.1 on BRI0 from LOADING to FULL,
 Loading Done
03:47:38: BR0:1 DDR: idle timeout

!--- Idle Timeout (30 seconds) expires.
!--- The router will check to see if the primary link has come up.

03:47:38: DDR: Dialer Watch: watch-group = 8
03:47:38: DDR:    network 172.22.53.0/255.255.255.0 UP,

!--- A route for the watched network exists (due to the active backup link).

03:47:38: DDR:    primary DOWN

!--- The primary network is still down.

03:48:08: BR0:1 DDR: idle timeout

!--- Next Idle Timeout (30 seconds) expires.
!--- The router will check to see if the primary link has come up.

03:48:08: DDR: Dialer Watch: watch-group = 8
03:48:08: DDR:    network 172.22.53.0/255.255.255.0 UP,
03:48:08: DDR:    primary DOWN

!--- The primary network is still down.

...
...
...
03:50:38: BR0:1 DDR: idle timeout

!--- Next Idle Timeout (30 seconds) expires.
!--- The router will check to see if the primary link has come up.

03:50:38: DDR: Dialer Watch: watch-group = 8
03:50:38: DDR:    network 172.22.53.0/255.255.255.0 UP,

!--- A route for the watched network exists (due to the active backup link).

03:50:38: DDR:    primary DOWN

!--- The primary network is still down.

03:50:44: %LINK-3-UPDOWN: Interface Serial0, changed state to up

!--- Primary link is re-established.

03:50:45: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0, changed state
 to up
03:50:54: %OSPF-5-ADJCHG: Process 5, Nbr 192.168.10.1 on Serial0 from LOADING
 to FULL, Loading Done
03:51:08: BR0:1 DDR: idle timeout

!--- Next Idle Timeout (30 seconds) expires.


!--- The router will check to see if the primary link has come up.

03:51:08: DDR: Dialer Watch: watch-group = 8
03:51:08: DDR:    network 172.22.53.0/255.255.255.0 UP,

!--- A route for the watched network exists. 

03:51:08: DDR:    primary UP

!--- The primary network is UP. Dialer watch will initiate a disconnect of


!--- the backup link.

03:51:08: BR0:1 DDR: starting watch disable timer

!--- Delays disconnecting the backup interface after the primary interface recovers.
!--- This timer is 15 seconds as configured with the dialer watch-disable 15 command

03:51:23: BR0:1 DDR: watch disable timeout

!--- 15 second disconnect delay expires. The link will be brought down.

03:51:23: BR0:1 DDR: disconnecting call

!--- Backup link is disconnected.

03:51:23: BR0:1 DDR: Dialer Watch: resetting call in progress
03:51:23: DDR: Dialer Watch: watch-group = 8
03:51:23: DDR:    network 172.22.53.0/255.255.255.0 UP,
03:51:23: DDR:    primary UP

!--- The primary network is UP.

03:51:23: %ISDN-6-DISCONNECT: Interface BRI0:1  disconnected from 5551111
 maui-nas-05, call lasted 255 seconds
03:51:23: %LINK-3-UPDOWN: Interface BRI0:1, changed state to down
03:51:23: BR0:1 DDR: disconnecting call
03:51:23: DDR: Dialer Watch: watch-group = 8
03:51:23: DDR:    network 172.22.53.0/255.255.255.0 UP,
03:51:23: DDR:    primary UP
03:51:24: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI0:1,
  changed state to down
maui-soho-01#

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения


Document ID: 5600