Технологии коммутируемого доступа в сеть : Асинхронные подключения

Настройка внешнего телефонного соединения с использованием модема в порте AUX

20 октября 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Содержание


Введение

Этот документ показывает, как использовать модем на порту AUX для настройки подключения к внешней службе. В этом сценарии маршрутизатор с модемом на порту AUX набирает Primary Rate Interface (PRI) маршрутизатора центрального узла.

Примечание: Мы не показываем сценарий резервирования, а лишьдемонстрируем коммутируемый доступ маршрутизации по требованию (DDR) между маршрутизаторами с модемом на порту AUX.

Предварительные условия

Требования

Прежде чем делать попытку создания этой конфигурации, изучите общие сведения о различных проблемах, связанных с модемами на портах AUX. Для получения дополнительной информации по этим проблемам см. Руководство по подключению модема к маршрутизатору.

Используемые компоненты

Сведения, содержащиеся в данном документе, касаются следующих версий программного обеспечения и оборудования:

  • Маршрутизатор серии Cisco 2600, который выполняет Cisco IOS?? Software Release 12.1 (2).

  • Маршрутизатор Cisco AS5300, который выполняет Cisco IOS Software Release 12.0 (7) T.

Примечание: Эта конфигурация может быть применена к любому маршрутизатору с портом AUX или даже консольным портом. Однако вследствие проблем управления по модему RS232 и некоторых родственных проблем безопасности не рекомендуется подключать модем к консольному порту. См. Руководство по подключению модема у маршрутизатору для получения дополнительной информации.

Сведения, содержащиеся в данном документе, были получены с устройств в специальной лабораторной среде. Все устройства, описанные в данном документе, были запущены с конфигурацией по умолчанию. При работе с реальной сетью необходимо полностью осознавать возможные результаты использования всех команд.

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Технические рекомендации Cisco. Условные обозначения.

Настройка

В этом разделе содержатся сведения о настройке функций, описанных в этом документе.

Примечание: Поиск дополнительной информации о командах в данном документе можно выполнить с помощью средства "Command Lookup" (Поиск команд) (только для зарегистрированных клиентов).

Схема сети

В данном документе используется сетевая установка, показанная на следующей схеме.

/image/gif/paws/5465/mod-aux-dialout.gif

Конфигурации

Эти конфигурации используются в данном документе:

  • maui-slt-01 (2600)

  • maui-nas-03 (5300)

В этой конфигурации, maui-slt-01 (2600), модем на порту AUX используется для вызова номера PRI maui-nas-03 (AS5300). NAS (maui-nas-03) настроен для отправки вызовов на внутренний цифровой модем.

maui-slt-01 (2600)
maui-slt-01#show running-config 
Building configuration...

Current configuration:
!
version 12.1
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname maui-slt-01
!
aaa new-model
aaa authentication login default local
aaa authentication login NO_AUTHEN none
aaa authentication ppp default local

!--- This is the basic AAA configuration for PPP calls.

enable secret 5 <deleted>
!
username admin password 0 <deleted>
username maui-nas-03 password 0 cisco

!--- Defines username for remote router (maui-nas-03), and shared secret 
!--- password. Shared secret (used for CHAP authentication)
!--- must be the same on both sides.

!
memory-size iomem 30
ip subnet-zero
!
chat-script Dialout ABORT ERROR ABORT BUSY "" 
"AT" OK "ATDT \T" TIMEOUT 45 CONNECT \c

!--- Sets up chat script "Dialout" used for the dialout connection on aux 0.

modemcap entry MY_USR_MODEM:MSC=&F1S0=1

!--- Modemcap (MY_USR_MODEM) is applied to the AUX port line interface.
!--- This modemcap was created through the command:
!--- modemcap edit MY_USR_MODEM miscellaneous &F1S0=1
!--- See the Modem-Router Connection Guide for more information.

!
interface Loopback0
 ip address 172.17.1.1 255.255.255.0
!
interface FastEthernet0/0
 ip address 172.16.1.1 255.255.255.0
 no keepalive
 duplex auto
 speed auto
!

!--- Irrelevant output has been removed.

!
interface Async65

!--- Async interface that corresponds to the AUX Port. 
!--- This was determined through the show line command.
!--- See External Modem Setup and Troubleshooting Tasks for more information.

 no ip address
 encapsulation ppp

!--- Use PPP encapsulation over this link.

 dialer in-band
 dialer pool-member 20

!--- Designate Async65 as member of dialer pool 20.
!--- The dialer pool 20 command is specified in interface Dialer 10.

 async default routing

!--- This permits routing over the async interface.
!--- This is required for a routing protocol to run accross the async link.

 ppp authentication chap callin
!
interface Dialer10

!---Dialer 10 is the logical interface for Dialer Pool 20.

 ip unnumbered Loopback0

!--- This uses the Loopback 0 IP address.

 encapsulation ppp
 ip ospf demand-circuit
 dialer remote-name maui-nas-03

!--- This specifies the remote router name. 
!--- This name must match the name that the remote router uses for 
!--- authentication.

 dialer pool 20

!--- Async 65 is a member of this pool.

 dialer idle-timeout 900
 dialer string 81690

!--- This defines the phone number of the destination router.

 dialer max-call 4096
 dialer-group 1

!--- Apply the definition of interesting traffic from dialer-list 1.


 ppp authentication chap callin

!--- Use CHAP authentication for incoming calls.

!
router ospf 5
 network 172.16.1.0 0.0.0.255 area 0
 network 172.17.1.0 0.0.0.255 area 0
 network 172.22.1.0 0.0.0.255 area 0

!---OSPF is used between the routers.
!---A routing protocol is unnecessary if you configure appropriate static routes.

!
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer10

!--- Default route points to int dialer 10. 
!--- This is necessary because OSPF is not configured to send default routes.

no ip http server
!
access-list 101 remark Define Interesting Traffic
access-list 101 deny   ospf any any
access-list 101 permit ip any any
dialer-list 1 protocol ip list 101

!--- Use access list 101 for interesting traffic definition.
!--- This is applied to interface Dialer 10 through dialer-group 1.

!
line con 0
 login authentication NO_AUTHEN
 transport input none
!
line aux 0

!--- Line interface for the AUX port.

 exec-timeout 0 0

!--- This disables exec timeout on the interface.

 script dialer Dialout

!--- Use chat script "Dialout".

 modem InOut

!--- This enables incoming and outgoing calls.

 modem autoconfigure type MY_USR_MODEM

!--- Now apply the modemcap MY_USR_MODEM that you configured previously.

 transport input all
 stopbits 1

!--- Reduce async framing overhead to improve throughput. 

 speed 115200

!--- The AUX port on the 2600 supports a speed of 115200.
!--- Note: If you route through the AUX port, each character generates a 
!--- processor interrupt. This is an abnormally high load on the CPU, 
!--- which can be resolved if you use a lower AUX port speed.

 flowcontrol hardware

!--- This configures RTS/CTS flow control.

line vty 0 4
!
no scheduler allocate
end

maui-nas-03 (5300)
maui-nas-03#show running-config 
Building configuration...

Current configuration:
!
version 12.0
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname maui-nas-03
!
aaa new-model
aaa authentication login default local
aaa authentication login NO_AUTHEN none
aaa authentication ppp default local

!--- This is the basic AAA configuration for PPP calls.

enable secret 5 <deleted>
!
username admin password 0 <deleted>
username maui-slt-01 password 0 cisco

!--- Defines username for remote router (maui-slt-01) and shared secret password.
!--- Shared secret(used for CHAP authentication) must be the same on both sides.

spe 1/0 1/7
 firmware location system:/ucode/mica_port_firmware
!
ip subnet-zero
!
isdn switch-type primary-ni
mta receive maximum-recipients 0
!
controller T1 0

!--- Primary T1.

 framing esf
 clock source line primary
 linecode b8zs
 pri-group timeslots 1-24
!

!--- Irrelevant output has been removed.

!
interface Loopback0
 ip address 172.22.1.1 255.255.255.0
 no ip directed-broadcast
!
interface Ethernet0
 ip address 172.22.53.105 255.255.255.0
 no ip directed-broadcast
 no keepalive
!

!--- Irrelevant output has been removed.

!
interface Serial0:23

!--- D-channel for T1 0.

 no ip address
 no ip directed-broadcast
 encapsulation ppp
 isdn switch-type primary-ni
 isdn incoming-voice modem

!--- This sends incoming async calls to the modems.

 fair-queue 64 256 0
 ppp authentication chap
!         

!--- Irrelevant output has been removed.

!
interface Group-Async0

!--- Group-Async interface is used to aggregate the modems.

 ip unnumbered Loopback0
 no ip directed-broadcast
 encapsulation ppp
 ip ospf network point-to-point

!--- This identifies the type of OSPF network. 

 async default routing

!--- This permits routing over the async interface.
!--- It is required for a routing protocol to run on the async link.

 async mode interactive
 peer default ip address pool clientpool

!--- This assigns an IP address from the pool named "clientpool" for the
!--- incoming call.

 ppp authentication chap
 group-range 1 96
!
router ospf 5
 network 172.22.1.0 0.0.0.255 area 0
 network 172.22.53.0 0.0.0.255 area 0
!
ip local pool clientpool 172.22.1.2 172.22.1.30

!--- IP addresses for dialin calls are given from this pool.

ip classless
no ip http server
!
line con 0
 login authentication NO_AUTHEN
 transport input none
line 1 96
 autoselect ppp
 modem InOut
 transport preferred lat pad telnet rlogin udptn v120 lapb-ta
 transport output lat pad telnet rlogin udptn v120 lapb-ta
line aux 0
line vty 0 4
!
end

Примечание: maui-nas-03 специально не настраивается для приема вызовов только от maui-slt-01 (клиента). С точки зрения NAS (maui-nas-03) входящий вызов является просто другим клиентом входящих звонков. Эта конфигурация может использоваться для многих удаленных клиентов, чтобы набрать PRI NAS центрального узла и соединиться с корпоративной сетью.

Проверка

В этом разделе содержатся сведения, которые помогают убедиться в надлежащей работе конфигурации.

Некоторые команды show поддерживаются Средством интерпретации выходных данных(только зарегистрированные клиенты), которое позволяет просматривать аналитику выходных данных команды show.

Образец команды show output

Используйте команду show ip route для проверки, существует ли маршрут к номеронабирателю или асинхронному интерфейсу. Если нет маршрута к асинхронному интерфейсу или интерфейсу номеронабирателя,, то вызов номера не может произойти. Поэтому настройте статические маршруты нужным образом.

maui-slt-01#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is 0.0.0.0 to network 0.0.0.0

     172.17.0.0/24 is subnetted, 1 subnets
C       172.17.1.0 is directly connected, Loopback0
     172.16.0.0/24 is subnetted, 1 subnets
C       172.16.1.0 is directly connected, FastEthernet0/0
S*   0.0.0.0/0 is directly connected, Dialer10

Примечание: Существует маршрут по умолчанию к интерфейсу номеронабирателя.

Маршрутизатор затем инициирует набор, подключается, выполняет согласование с PPP и обменивается базой данных OSPF. Для получения дополнительной информации по этому процессу просмотрите отладочную информацию, которая показана ниже:

Используйте команду show ip route после того, как соединение успешно установлено. В этом сценарии используется маршрут OSPF протокола маршрутизации. Наблюдайте маршруты OSPF, добавленные к таблице маршрутизации.

maui-slt-01#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is 0.0.0.0 to network 0.0.0.0

     172.17.0.0/24 is subnetted, 1 subnets
C       172.17.1.0 is directly connected, Loopback0
     172.16.0.0/24 is subnetted, 1 subnets
C       172.16.1.0 is directly connected, FastEthernet0/0
     172.22.0.0/16 is variably subnetted, 2 subnets, 2 masks
O       172.22.53.0/24 [110/1795] via 172.22.1.1, 00:00:03, Dialer10
C       172.22.1.1/32 is directly connected, Dialer10
S*   0.0.0.0/0 is directly connected, Dialer10

Устранение неполадок

В этом разделе описывается процесс устранения неполадок конфигурации.

Задачи по настройке и устранению неполадок во внешних модемах

Выполните эти шаги по настройке внешнего модема и убедитесь, что модем функционирует правильно. Когда вы проверяете способность маршрутизатора набрать номер и соединиться при помощи этого модема, необходимые конфигурации DDR, а также конфигурации PPP и другие высокоуровневые конфигурации протокола могут быть настроенына маршрутизаторе набора номера. В этом разделе предполагается, что маршрутизатор, который принимает вызов, настроен правильно, как показано выше.

  1. Соедините порт AUX с модемом соответствующим кабелем. Для получения дополнительной информации по вариантам разводки кабеля см. Руководство по подключению модема к маршрутизатору.

  2. Используйте команду демонстрации канала связи для определения асинхронного интерфейса вспомогательного порта. Хотя у большинства маршрутизаторов имеется порт AUX в качестве интерфейса async 1, у серверов доступа имеется интерфейс порта AUX вслед за линиями TTY. Например, если ваш маршрутизатор имеет 16 асинхронных или модемных линий, топорт AUX является линией 17. В таком случае порт AUX должен быть настроен на interface async 17. Настройте порт AUX на основании выходных данных команды show line. Данный пример проверяет, что на maui-slt-01 в конфигурации AUX-порта указано interface Async65.

    maui-slt-01#show line
       Tty Typ   Tx/Rx    A Modem  Roty AccO AccI  Uses  Noise  Overruns  Int
    *    0 CTY            -    -      -    -    -     0      0     0/0      -
        65 AUX 9600/9600  -    -      -    -    -     0      1     0/0      -
        66 VTY            -    -      -    -    -     0      0     0/0      -
        67 VTY            -    -      -    -    -     0      0     0/0      -
        68 VTY            -    -      -    -    -     0      0     0/0      -
        69 VTY            -    -      -    -    -     0      0     0/0      -
        70 VTY            -    -      -    -    -     0      0     0/0      -
    
    Line(s) not in async mode -or- with no hardware support: 
    1-64
  3. Настройте modemcap для модема, подключенного к порту AUX. См. Руководство по подключению модема с маршрутизатором. Создайте новый modemcap, который включает данную строку инициализации (Init). Вот пример для нового modemcap (названного MY_USR_MODEM):

    maui-slt-01(config)#modemcap edit MY_USR_MODEM miscellaneous &F1S0=1

    В приведенной выше конфигурации modemcap &F1S0=1 является строкой инициализации. Обратитесь к разделуСоздание modemcap для получения информации о строке init, соответствующей вашему модему.

  4. Примените modemcap к порту AUX. Мы ранее проверили, что порт AUX находится на линии 65.

    maui-slt-01(config)#line 65
    maui-slt-01(config-line)#modem autoconfigure type MY_USR_MODEM

    Для обеспечения соединения между модемами необходимо также настроить линию вспомогательного (AUX) порта. Дополнительные сведения о конфигурации линии см. разделе "Руководство по подключению модема с маршрутизатором". Приведенный выше пример конфигурации для maui-slt-01 содержит также все необходимые команды.

    Используйте команду debug confmodem для проверки, правильно ли применен modemcap. После выполнения цикла включения и выключения питания маршрутизатор автоматически настраивает модем.

    maui-slt-01#debug confmodem
    Modem Configuration Database debugging is on
    maui-slt-01#
    
    !--- Power cycle the modem.
    
    *Mar  1 06:58:10.118: TTY65: detection speed (115200) response ---OK---
    *Mar  1 06:58:10.122: TTY65: Modem command:  --AT&F1S0=1--
    
    !--- Apply the init string specified in the modemcap.
    
    *Mar  1 06:58:10.758: TTY65: Modem configuration succeeded
    
    !--- Modem configuration is successful.
    
    *Mar  1 06:58:10.758: TTY65: Detected modem speed 115200
    *Mar  1 06:58:10.758: TTY65: Done with modem configuration
    maui-slt-01#
  5. Выполните команду show line aux 0 или show line aux-line. Убедитесь, что прошли все сигналы. Например, CTS, RTS, DTR, CD. Если рядом ничего не появляется, они включены. Если рядом с ними появляется сообщение "No" (нет), (например, No CTS), это означает, что они не работают. Если они не работают, проверьте кабель и конфигурацию на маршрутизаторе. Также проверьте, правильно ли настроены асинхронный интерфейс и линия порта AUX. Для получения дополнительных сведений по разводке кабелей см. "Руководство по подключению модема с маршрутизатором. Используйте документ об устранении неисправностей подключений по входящему звонку для информации о том, как устранить неполадки . Например:

    maui-slt-01#show line 65
       Tty Typ     Tx/Rx    A Modem  Roty AccO AccI   Uses   Noise  Overruns   Int
    A   65 AUX 115200/115200- inout     -    -    -      8       1     1/0       -
      Ready
    
    Line 65, Location: "PPP: 172.22.1.1", Type: ""
    Length: 24 lines, Width: 80 columns
    Baud rate (TX/RX) is 115200/115200, no parity, 1 stopbits, 8 databits
    Status: Ready, Active, No Exit Banner, Async Interface Active
      Modem Detected, CTS Raised, Modem Signals Polled
    Capabilities: Hardware Flowcontrol In, Hardware Flowcontrol Out
      Modem Callout, Modem RI is CD, Modem Autoconfigure
    Modem state: Ready
    Group codes:    0
    Line is running PPP routing for address 172.22.1.1.
    0 output packets queued, 1 input packets.
     Async Escape map is 00000000000000000101000000000000
    Modem hardware state: CTS* DSR*  DTR RTS
    
    !--- All signals are up.
    
     TTY NUMBER 65
    Parity Error = 0 Framing Error = 536 Receive Error = 536 Overrun = 1
    Outcount = 0 totalout = 40615 incount = 0 totalin = 49805
    , Modem Configured
    Special Chars: Escape  Hold  Stop  Start  Disconnect  Activation
                    ^^x    none   -     -       none                   
    Timeouts:    Idle EXEC    Idle Session   Modem Answer  Session   Dispatch
                 00:10:00        never                        none    not set
                              Idle Session Disconnect Warning
                                never 
                              Login-sequence User Response
                               00:00:30
                              Autoselect Initial Wait
                                not set 
    Modem type is MY_USR_MODEM.
    
    !--- Modemcap is MY_USR_MODEM.
    
    Session limit is not set.
    Time since activation: never
    Editing is enabled.
    History is enabled, history size is 10.
    DNS resolution in show commands is enabled
    Full user help is disabled
    Allowed transports are lat pad v120 mop telnet rlogin nasi. 
    Preferred is lat.
    No output characters are padded
    No special data dispatching characters
    maui-slt-01# 
  6. Выполните

    обратный сеанс Telnet от порта AUX к модему и используйте набор AT-команд, чтобы вручную набрать номер и соединиться с удаленным устройством. Это можно использовать, чтобы убедиться в том, что функции аппаратного обеспечения модема и телефонной линии работают должным образом. В данном примере, поскольку порт AUX находится на линии 65, вы должны получить обратный доступ по протоколу Telnet к порту 2065 маршрутизатора. Дополнительную информацию об обратных сеансах Telnet см. в разделе "Установка обратного сеанса Telnet с модемом".

    maui-slt-01#telnet 172.17.1.1 2065 
    Trying 172.17.1.1, 2065 ...Open
    
    User Access Verification
    
    Username: admin Password:
    
    !--- Authentication performed by local router for the reverse Telnet.
    
    at
    OK
    atdt 81690 
    
    !--- The modem dials (81690), and connects. 
    !--- This process takes approximately 30 to 45 seconds.
    
    CONNECT 31200/ARQ/V34/LAPM/V42BIS
    
    !--- Connection speed and protocols that were negotiated.
    
    User Access Verification
     
    Username: maui-slt-01
    Password:
    
    !--- Authentication performed by the remote router for the incoming call.
    
    
    
    maui-nas-03>
    
    !--- Prompt on the remote router.
    
    

    Как показано выше, мы выполняем обратный сеанс по протоколу Telnet к модему и используем команду at для подтверждения, отвечает ли модем. Получив сообщение ОК, наберите удаленный номер при помощи команды atdt number. При этом выполняется вызов, и происходит соединение с удаленным устройством. Затем удаленный маршрутизатор выполняет аутентификацию входящего вызова. Если вы замечаете, что внешний модем не набирает номер, убедитесь, что кабельное подключение корректно, что внешний модем не неисправен и что телефонная линия активна. Обратитесь к документам "Настройка поддержки модема и других асинхронных возможностей" и "Устранение неполадок с подключениями по входящему звонку" для получения дополнительных сведений.

    При завершении вышеупомянутых задач и процедур можно продолжить проверку того, может ли маршрутизатор перевести подключение удаленного доступа в рабочее состояние автоматически. Для получения дополнительной информации обратитесь к разделам Примеры вывода команды show и Примеры отладочных выходных данных документа Настройкаподключения к внешней службе с использованием модема напорту AUX .

Команды для устранения неполадок

Некоторые команды show поддерживаются Средством интерпретации выходных данных(только зарегистрированные клиенты), которое позволяет просматривать аналитику выходных данных команды show.

Примечание: Прежде чем применять команды отладки, ознакомьтесь с разделом "Важные сведения о командах отладки".

  • debug dialer –??? отображает данные отладки о пакетах, полученных на интерфейсе номеронабирателя. Когда DDR включен в интерфейсе, информация, которая касается причины любого вызова ( причины внешнего доступа по телефонной линии) также отображается. Для получения дополнительной информации см. вывод команды debug dialer в debug clns - debug fras.

  • debug modem –??? отображает операции модемной линии, управление по модему и сообщения об активации процесса на маршрутизаторе.

  • debug chat –??? контролирует выполнение сценария диалогового взаимодействия при инициировании вызова номера асинхронной линии/POTS. Обратитесь к разделуАсинхронные исходящие вызовы - проверкаопераций сценария диалогового взаимодействиядокумента "Технологии удаленного доступа: Методика поиска и устранения неисправностей для получения дополнительных сведений.

  • debug ppp negotiation –??? отображает информацию о трафике PPP и обменивается ей, по мере согласования компонентов PPP, таких как, протокол управления каналом (LCP), аутентификация и протокол управления сетью (NCP). Процесс успешного согласования PPP состоит в том, что сначала выясняется состояние LCP, затем проводится аутентификация и, наконец, согласовывается NCP.

  • debug ppp authenticaion –??? отображает сообщения протокола проверки подлинности PPP, которые включают обмен пакетами протокола CHAP и обмен пакетами протокола PAP.

Пример результата отладки

Используйте эти команды отладки для устранения неисправностей соединения:

maui-slt-01#debug dialer
Dial on demand events debugging is on
maui-slt-01#debug chat
Chat scripts activity debugging is on
maui-slt-01#debug modem
Modem control/process activation debugging is on
maui-slt-01#debug ppp negotiation
PPP protocol negotiation debugging is on
maui-slt-01#debug ppp authentication
PPP authentication debugging is on       
maui-slt-01#
maui-slt-01#show debug
General OS:
  Modem control/process activation debugging is on
Dial on demand:
  Dial on demand events debugging is on
PPP:
  PPP authentication debugging is on
  PPP protocol negotiation debugging is on
Chat Scripts:
  Chat scripts activity debugging is on
maui-slt-01#
maui-slt-01#ping 172.22.53.105

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.22.53.105, timeout is 2 seconds:

*Mar  1 05:37:44.858: As65 DDR: rotor dialout [priority]
*Mar  1 05:37:44.858: As65 DDR: Dialing cause ip (s=172.17.1.1, d=172.22.53.105)

!--- Dialing reason.

*Mar  1 05:37:44.858: As65 DDR: Attempting to dial 81690

!--- Phone number that is dialed.

*Mar  1 05:37:44.858: CHAT65: Attempting async line dialer script
*Mar  1 05:37:44.858: CHAT65: Dialing using Modem script: Dialout
 & System script: none

!--- Use the chat-script "Dialout".

*Mar  1 05:37:44.862: CHAT65: process started
*Mar  1 05:37:44.862: CHAT65: Asserting DTR
*Mar  1 05:37:44.862: TTY65: Set DTR to 1
*Mar  1 05:37:44.862: CHAT65: Chat script Dialout started

!--- Chat-script "Dialout" has started.

*Mar  1 05:37:44.862: CHAT65: Sending string: AT
*Mar  1 05:37:44.862: CHAT65: Expecting string: OK
*Mar  1 05:37:44.990: CHAT65: Completed match for expect: OK
*Mar  1 05:37:44.990: CHAT65: Sending string: ATDT \T<81690>
*Mar  1 05:37:44.990: CHAT65: Expecting string: CONNECT
*Mar  1 05:38:02.774: CHAT65: Completed match for expect: CONNECT
*Mar  1 05:38:02.774: CHAT65: Sending string: \c
*Mar  1 05:38:02.774: CHAT65: Chat script Dialout finished, status = Success

!--- Chat script is successful. 
!--- Notice the Expect/Send Attributes and the time elapsed.

*Mar  1 05:38:02.774: TTY65: destroy timer type 1
*Mar  1 05:38:02.778: TTY65: destroy timer type 0
*Mar  1 05:38:04.778: %LINK-3-UPDOWN: Interface Async65, changed state to up
*Mar  1 05:38:04.778: Async65 DDR: Dialer statechange to up
*Mar  1 05:38:04.778: %DIALER-6-BIND: Interface As65 bound to profile Di10
*Mar  1 05:38:04.782: Async65 DDR: Dialer call has been placed
*Mar  1 05:38:04.782: As65 PPP: Treating connection as a callout

!--- PPP LCP negotiation begins.

*Mar  1 05:38:04.782: As65 PPP: Phase is ESTABLISHING, Active Open
*Mar  1 05:38:04.782: As65 PPP: No remote authentication for call-out
*Mar  1 05:38:04.782: As65 LCP: O CONFREQ [Closed] id 43 len 20
*Mar  1 05:38:04.782: As65 LCP:    ACCM 0x000A0000 (0x0206000A0000)
*Mar  1 05:38:04.782: As65 LCP:    MagicNumber 0x314EFEBB (0x0506314EFEBB)
*Mar  1 05:38:04.786: As65 LCP:    PFC (0x0702)
*Mar  1 05:38:04.786: As65 LCP:    ACFC (0x0802)
*Mar  1 05:38:06.782: As65 LCP: TIMEout: State REQsent
*Mar  1 05:38:06.782: As65 LCP: O CONFREQ [REQsent] id 44 len 20
*Mar  1 05:38:06.782: As65 LCP:    ACCM 0x000A0000 (0x0206000A0000)
*Mar  1 05:38:06.782: As65 LCP:    MagicNumber 0x314EFEBB (0x0506314EFEBB)
*Mar  1 05:38:06.782: As65 LCP:    PFC (0x0702)
*Mar  1 05:38:06.782: As65 LCP:    ACFC (0x0802)
*Mar  1 05:38:08.782: As65 LCP: TIMEout: State REQsent
*Mar  1 05:38:08.782: As65 LCP: O CONFREQ [REQsent] id 45 len 20
*Mar  1 05:38:08.782: As65 LCP:    ACCM 0x000A0000 (0x0206000A0000)
*Mar  1 05:38:08.782: As65 LCP:    MagicNumber 0x314EFEBB (0x0506314EFEBB)
*Mar  1 05:38:08.782: As65 LCP:    PFC (0x0702)
*Mar  1 05:38:08.782: As65 LCP:    ACFC (0x0802)

!--- Observe that two outgoing CONFREQs timed out.
!--- If you observe such a situation with no incoming CONFREQs, verify that the 
!--- autoselect ppp or async mode dedicated commands are configured
!--- on the router that receives the call.

*Mar  1 05:38:08.934: As65 LCP: I CONFREQ [REQsent] id 2 len 25
*Mar  1 05:38:08.934: As65 LCP:    ACCM 0x000A0000 (0x0206000A0000)
*Mar  1 05:38:08.934: As65 LCP:    AuthProto CHAP (0x0305C22305)
*Mar  1 05:38:08.934: As65 LCP:    MagicNumber 0x515A1AC7 (0x0506515A1AC7)
*Mar  1 05:38:08.938: As65 LCP:    PFC (0x0702)
*Mar  1 05:38:08.938: As65 LCP:    ACFC (0x0802)
*Mar  1 05:38:08.938: As65 LCP: O CONFACK [REQsent] id 2 len 25
*Mar  1 05:38:08.938: As65 LCP:    ACCM 0x000A0000 (0x0206000A0000)
*Mar  1 05:38:08.938: As65 LCP:    AuthProto CHAP (0x0305C22305)
*Mar  1 05:38:08.938: As65 LCP:    MagicNumber 0x515A1AC7 (0x0506515A1AC7)
*Mar  1 05:38:08.938: As65 LCP:    PFC (0x0702)
*Mar  1 05:38:08.938: As65 LCP:    ACFC (0x0802)
*Mar  1 05:38:08.942: As65 LCP: I CONFACK [ACKsent] id 45 len 20
*Mar  1 05:38:08.946: As65 LCP:    ACCM 0x000A0000 (0x0206000A0000)
*Mar  1 05:38:08.946: As65 LCP:    MagicNumber 0x314EFEBB (0x0506314EFEBB)
*Mar  1 05:38:08.946: As65 LCP:    PFC (0x0702)
*Mar  1 05:38:08.946: As65 LCP:    ACFC (0x0802)
*Mar  1 05:38:08.946: As65 LCP: State is Open
*Mar  1 05:38:08.946: As65 PPP: Phase is AUTHENTICATING, by the peer
*Mar  1 05:38:09.066: As65 CHAP: I CHALLENGE id 1 len 32 from "maui-nas-03"
*Mar  1 05:38:09.066: As65 CHAP: O RESPONSE id 1 len 32 from "maui-slt-01"
*Mar  1 05:38:09.206: As65 CHAP: I SUCCESS id 1 len 4

!--- CHAP authentication is successful.

*Mar  1 05:38:09.206: As65 PPP: Phase is UP
*Mar  1 05:38:09.210: As65 IPCP: O CONFREQ [Not negotiated] id 13 len 10
*Mar  1 05:38:09.210: As65 IPCP:    Address 172.17.1.1 (0x0306AC110101)
*Mar  1 05:38:09.218: As65 IPCP: I CONFREQ [REQsent] id 1 len 10
*Mar  1 05:38:09.218: As65 IPCP:    Address 172.22.1.1 (0x0306AC160101)
*Mar  1 05:38:09.218: As65 IPCP: O CONFACK [REQsent] id 1 len 10
*Mar  1 05:38:09.218: As65 IPCP:    Address 172.22.1.1 (0x0306AC160101)
*Mar  1 05:38:09.350: As65 IPCP: I CONFNAK [ACKsent] id 13 len 10
*Mar  1 05:38:09.350: As65 IPCP:    Address 172.22.1.9 (0x0306AC160109)
*Mar  1 05:38:09.350: As65 IPCP: O CONFREQ [ACKsent] id 14 len 4
*Mar  1 05:38:09.478: As65 IPCP: I CONFACK [ACKsent] id 14 len 4
*Mar  1 05:38:09.478: As65 IPCP: State is Open

!--- IPCP negotiation is complete.

*Mar  1 05:38:09.482: As65 DDR: dialer protocol up
*Mar  1 05:38:09.482: Di10 IPCP: Install route to 172.22.1.1
*Mar  1 05:38:10.206: %LINEPROTO-5-UPDOWN: Line protocol on Interface Async65,
 changed state to up

!--- Interface is up.


Дополнительные сведения


Document ID: 5465