Интерфейсы и модули Cisco : Модуль коммутации контента Cisco

Настройка безопасного режима (маршрутизатора) на модуле коммутации контента

20 октября 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Содержание


Введение

Модуль коммутации контента обеспечивает высокопроизводительные подключения между пользователями сети и серверными фермами на основе данных уровней 4-7. Можно представить группу реальных серверов (серверная ферма) в виде одного сервера (виртуальный сервер), выполнить балансировку трафика к серверной ферме, выбрать один из методов балансировки загрузки сервера, и ограничить трафик к отдельным серверам (фиксированные соединения) и серверным фермам (политики). Этот пример конфигурации описывает, как настроить Распределение нагрузки сервера (SLB) на CSM Семейства Catalyst 6000.

Вы не можете выполнить Cisco программное обеспечение SLB IOS� на том же коммутаторе как CSM. Необходимо настроить режим CSM путем запуска команды ip slb mode [csm | rp] перед любой конфигурацией. В команде ip slb mode аргумент армированного пластика является по умолчанию.

Перед началом работы

Условные обозначения

Дополнительные сведения об условных обозначениях в документах см. Cisco Technical Tips Conventions.

Предварительные условия

Для данного документа отсутствуют предварительные условия.

Используемые компоненты

Сведения в этом документе основаны на версиях оборудования и программного обеспечения, указанных ниже.

  • Supervisor IOS версии 12.1(8)EX для семейства Catalyst 6000 для Supervisor Engine 1 с MSFC1 (c6sup11-jsv-mz.121-8.EX)

  • Выпуск 2.1 (0) (c6slb-apc.2-1-1.bin) Па CSM семейства Catalyst 6000

Модуль CSM работает под управлением Cisco IOS Release 12.1(6)E или более поздней. При использовании Supervisor Engine 2 необходимо использовать Cisco IOS Release 12.1 (8a) E или позже.

Рабочий режим

Соединения клиента и сервера через CSM могут использовать или Уровень 2 или Коммутацию уровня 3. Клиенты подключаются к VLAN на стороне клиента, а серверы — к VLAN на стороне сервера. Серверы и клиенты могут находиться в разных подсетях. Серверы также могут быть расположены на расстоянии более одного перехода и подключаться к серверной VLAN через маршрутизаторы. В этом случае шлюз по умолчанию серверов и маршрутизация через сеть от серверов до VLAN стороны сервера CSM должны направить весь трафик с балансировкой нагрузки от серверов до CSM или клиента группы серверов, NAT должен быть настроен в CSM для всего трафика, предназначенного к серверам в ферме серверов. Клиент отправляет запрос к адресу VIP, � и CSM пересылают запрос на сервер, который может удовлетворить запрос. Сервер вперед ответ на CSM и CSM вперед ответ клиенту.

Когда клиентская сторона и VLAN стороны сервера находятся в других подсетях, можно настроить CSM в безопасном (маршрутизатор) режим. Этот пример конфигурации фокусирует на безопасном (маршрутизатор) конфигурацию режима. Когда клиентская сторона и VLAN стороны сервера находятся в той же подсети, можно настроить CSM для работы в одиночной подсети (мост) режимом. См. примеры конфигурации ниже для получения дополнительной информации.

Схема сети

Клиентская сторона и VLAN стороны сервера находятся на других подсетях в безопасном (маршрутизатор) режим. На схеме показано, как устанавливать конфигурацию режима безопасности (маршрутизатора).

csm_router.gif

Конфигурации

Выполните эти шаги для настройки CSM для безопасного (несколько подсетей) режим:

  1. Выберите режим CSM.

    cat(config)# ip slb mode csm
    
  2. Создайте VLAN клиента и сервера в базе данных. При выходе из режима базы данных сети VLAN будут применены изменения конфигурации.

    cat# vlan database 
    cat(vlan)# vlan 100 
    VLAN 100 added: Name: VLAN0100 
    cat(vlan)# vlan 200 
    VLAN 200 added: Name: VLAN0200 
    cat(vlan)# exit 
    APPLY completed. 
    Exiting....
  3. Настройте физические интерфейсы, подключающие клиента (каскадное подключение) к соответствующей виртуальной локальной сети.

    cat(config)# inter fastEthernet 2/1 
    cat(config-if)# switchport 
    cat(config-if)# switchport access vlan 100 
    cat(config-if)# no shut
    
  4. Настройте физические интерфейсы, которые подключают серверы с соответствующей VLAN.

    cat(config)# inter fastEthernet 2/3 
    cat(config-if)# switchport 
    cat(config-if)# switchport access vlan 200 
    cat(config-if)# no shutdown 
    cat(config)# inter fastEthernet 2/4 
    cat(config-if)# switchport 
    cat(config-if)# switchport access vlan 200 
    cat(config-if)# no shutdown
    
  5. Создайте VLAN клиентской стороны и шлюз.

    cat(config)# ip slb vlan 100 client 
    cat(config-slb-vlan-client)# ip address 172.17.63.217 255.255.255.192 
    cat(config-slb-vlan-client)# gateway 172.17.63.210
    
  6. Создайте VLAN стороны сервера.

    cat(config)# ip slb vlan 200 server 
    cat(config-slb-vlan-server)# ip address 10.1.1.251 255.255.255.0 
    cat(config-slb-vlan-server)# alias 10.1.1.250 255.255.255.0
    
  7. Создайте serverfarm.

    cat(config)# ip slb serverfarm WWWFARM 
    cat(config-slb-sfarm)# real 10.1.1.3 
    cat(config-slb-real)# inservice 
    cat(config-slb-real)# real 10.1.1.5 
    cat(config-slb-real)# inservice
    
  8. Создайте vserver и объединенный serverfarm.

    cat(config)# ip slb vserver SERVER 
    cat(config-slb-vserver)# virtual 172.17.63.241 tcp www 
    cat(config-slb-vserver)# serverfarm WWWFARM 
    cat(config-slb-vserver)# inservice
    

Ниже приводится пример конфигурации распределения нагрузки сервера, которое использует Cisco Catalyst 6500 и CSM.

CSM (WS-X6066-SLB-APC) рабочая конфигурация
Current configuration : 3791 bytes 
! 
version 12.1 
service timestamps debug uptime 
service timestamps log uptime 
no service password-encryption 
! 
hostname cat 
! 
boot buffersize 126968 
boot system flash slot0:c6sup11-jsv-mz.121-8.EX.bin 
! 
redundancy 
�main-cpu 
� auto-sync standard 
ip subnet-zero 
! 


!--- SLB mode. 

ip slb mode csm 
! 


!--- Client side VLAN configuration.� 
!--- Important: Gateway address pointing to interface VLAN 100.
 
ip slb vlan 100 client 
�ip address 172.17.63.217 255.255.255.192 
�gateway 172.17.63.210 
! 


!--- Server side VLAN configuration.�
 
ip slb vlan 200 server 
�ip address 10.1.1.251 255.255.255.0 
�alias 10.1.1.250 255.255.255.0 
! 


!--- Serverfarm configuration.
 
ip slb serverfarm WWWFARM 
�nat server� 
�no nat client 
real 10.1.1.3 
� inservice 
�real 10.1.1.5 
� inservice 
! 


!--- Vserver configuration.�
 
ip slb vserver SERVER 
�virtual 172.17.63.241 tcp www 
�serverfarm WWWFARM 
�inservice 
! 
interface GigabitEthernet1/1 
�no ip address 
�shutdown 
! 
interface GigabitEthernet1/2 
�no ip address 
�shutdown 
! 


!--- Client (uplink) connected to FastEthernet 2/1. 

interface FastEthernet2/1 
�no ip address 
�switchport 
�switchport access vlan 100 
�switchport mode access 
! 
interface FastEthernet2/2 
�no ip address 
�shutdown 
! 


!--- Servers connected to FastEthernet 2/3 and 2/4.
� 
interface FastEthernet2/3 
�no ip address 
�switchport 
�switchport access vlan 200 
�switchport mode access 
! 
interface FastEthernet2/4 
�no ip address 
�switchport 
�switchport access vlan 200 
�switchport mode access ... 
interface FastEthernet2/48 
�no ip address 
�shutdown 
! 
interface Vlan1 
�no ip address 
�shutdown 
! 
interface Vlan100 
�ip address 172.17.63.210 255.255.255.192 
! 
ip default-gateway 172.17.63.193 
ip classless 
ip route 0.0.0.0 0.0.0.0 172.17.63.193 
no ip http server 
! 
line con 0 
line vty 0 4 
�login 
! 
end

команды "show"

Примечание: Некоторые команды show поддерживаются Средством интерпретации выходных данных(только зарегистрированные клиенты), которое позволяет просматривать аналитику выходных данных команды show.

команда show ip slb status

Команда show ip slb status отображает состояние модуля SLB. Модуль должен быть онлайновым.

cat6#show ip slb status�
SLB Module is online in slot 3.�
Configuration Download state: COMPLETE, SUCCESS

команда "show ip slb vserver"

Команда show ip slb vserver отображает данные виртуального сервера. Вы также видите состояние виртуального сервера и сколько соединений, там:

cat6#show ip slb vserver
slb vserver�� prot��� virtual������������� vlan�� state�������� conns����������
---------------------------------------------------------------------------
SERVER������� TCP���� 172.17.63.241/32:80� ALL��� OPERATIONAL�� 0

команда "show ip slb reals"

Команда show ip slb reals отображает информацию для каждого реального сервера, такого как ферма серверов, где каждый сервер находится, состояния сервера, пороги и соединения.

cat6#show ip slb reals
real����������������� server farm����� weight� state��������� conns
-------------------------------------------------------------------
10.1.1.5������������� WWWFARM��������� 8������ OPERATIONAL��� 0��������
10.1.1.3������������� WWWFARM��������� 8������ OPERATIONAL��� 0

команда "show ip slb serverfarms"

Команда show ip slb serverfarms показывает сведения о серверных фермах. Эта команда показывает предиктор, используемый для распределения нагрузки. Данный пример использует по умолчанию, циклический выбор.

cat6#show ip slb serverfarm
server farm��� predictor��� nat�� reals�� redirect� bind id
-------------------------------------------------------------
WWWFARM������� RoundRobin�� S���� 2������ 0�������� 0

команда show ip slb vlan

Команда show ip slb vlan отображает сведения о виртуальной локальной сети (VLAN) для клиента и сервера.

cat6# show ip slb vlan
vlan�� IP address������ IP mask����������� type��
---------------------------------------------------
100��� 172.17.63.217��� 255.255.255.192��� CLIENT
200��� 10.1.1.251������ 255.255.255.0����� SERVER

Устранение неполадок

Можно только пропинговать реальный сервер от Catalyst 6500 при помощи команды ping slb, как показано ниже.

cat6#ping slb 10.1.1.3�
IP address������ Reachable�
--------------------------�
10.1.1.3�������� Yes

Дополнительные сведения


Document ID: 5448