Интерфейсы и модули Cisco : Модуль коммутации контента Cisco

Настройка режима одиночной подсети (моста) на CSM

20 октября 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Содержание


Введение

Модуль коммутации содержимого (CSM) обеспечивает высокопроизводительное выравнивание нагрузки на серверы (SLB) между сетевыми устройствами и фермами серверов на основе информационных пакетов уровней 4-7. Фермы серверов, которые представлены как виртуальные серверы, могут улучшить масштабируемость и доступность сервисов для вашей сети. Можно добавлять новые серверы и удалять отказавшие или существующие серверы в любой момент времени без влияния на работоспособность виртуального сервера.

Клиенты подключаются к CSM, сообщая виртуальный IP-адрес виртуального сервера. Когда клиент инициирует подключение к виртуальному серверу, CSM выбирает реальный сервер (физическое устройство, назначенное в серверную ферму) для подключения на основе настроенных алгоритмов балансировки нагрузки и политик (правил доступа). Политика управляет трафиком путем определения, куда передать запросы клиента за информацией.

Перед началом работы

Условные обозначения

Дополнительные сведения об условных обозначениях в документах см. Cisco Technical Tips Conventions.

Предварительные условия

Для данного документа отсутствуют предварительные условия.

Используемые компоненты

Эта конфигурация может использоваться с любыми версиями программного и аппаратного обеспечения, которые поддерживают CSM.

Теоретические сведения

Клиенты и серверы связываются через CSM с помощью или технологии Уровня 2 или Уровня 3₩½ в определенной конфигурации VLAN. Клиенты подключаются к VLAN на стороне клиента, а серверы — к VLAN на стороне сервера. Серверы и клиенты могут находиться в разных подсетях. Серверы также могут быть расположены на расстоянии более одного перехода и подключаться к серверной VLAN через маршрутизаторы. Клиент отсылает запрос на один из VIP-адресов модуля. CSM передает этот запрос к серверу, который может ответить на запрос. Сервер затем отправляет ответы на CSM, а CSM отправляет ответ пользователю.

Если клиентская и серверная стороны виртуальных локальных сетей находятся в одинаковых подсетях, можно настроить CSM в режиме одиночной подсети (моста). Этот документ описывает одиночную подсеть (мост) режим.

Когда клиентская сторона и VLAN серверной части находятся на других подсетях, можно настроить CSM для работы в безопасном (маршрутизатор) режимом. Для получения дополнительной информации обратитесь к Настройке, Безопасной (маршрутизатор) Режим на CSM.

Настройка

Схема сети

На следующей схеме показаны разные VLAN и разные подсети.

csm-bridge.gif

Конфигурации

Выполните следующие действия:

  1. Создайте клиента и сервер VLAN на MSFC.

    cat#conf t 
    cat(config)#vlan 100 
    cat(config-vlan)#exit 
    cat(config)#vlan 200 
    cat(config-vlan)#
  2. Настройте физический интерфейс подключения клиента (uplink) к соответствующей виртуальной локальной сети.

    cat(config)#inter fastEthernet 2/1 
    cat(config-if)#switchport 
    cat(config-if)#switchport access vlan 100 
    cat(config-if)#no shut
    
  3. Настройте физические интерфейсы, который подключает серверы с соответствующей VLAN.

    cat(config)#inter fastEthernet 2/3 
    cat(config-if)#switchport
    cat(config-if)#switchport access vlan 200 
    cat(config-if)#no shutdown 
    cat(config)#inter fastEthernet 2/4 
    cat(config-if)#switchport 
    cat(config-if)#switchport access vlan 200 
    cat(config-if)#no shutdown
    
  4. Настройте CSM.

    cat(config)#module csm 3 
    cat(config-module-csm)#
  5. Создайте VLAN на стороне клиента и шлюз.

    cat(config-module-csm)#vlan 100 client 
    cat(config-slb-vlan-client)#ip address 172.17.63.217 255.255.255.192 
    cat(config-slb-vlan-client)#gateway 172.17.63.214  
    cat(config-slb-vlan-client)#
  6. Создайте VLAN серверной части.

    cat(config-module-csm)#vlan 200 server 
    cat(config-slb-vlan-server)#ip address 172.17.63.217 255.255.255.192
    
  7. Создайте ферму серверов.

    cat(config-module-csm)#serverfarm wwwfarm
    cat(config-slb-sfarm)#real 172.17.63.215 
    cat(config-slb-real)#inservice 
    cat(config-slb-real)#real 172.17.63.216 
    cat(config-slb-real)#inservice
    
  8. Создайте Vserver и объединенную ферму серверов.

    cat(config-module-csm)#vserver server 
    cat(config-slb-vserver)#virtual 172.17.63.241 tcp www 
    cat(config-slb-vserver)#serverfarm wwwfarm 
    cat(config-slb-vserver)#inservice
    

Это - пример конфигурации SLB с помощью Cisco Catalyst 6500 и CSM.

CSM (WS-X6066-SLB-APC) Config выполнения
Building configuration... 

Current configuration : 3863 bytes 
! 
version 12.1 
service timestamps debug uptime 
service timestamps log uptime 
no service password-encryption 
! 
hostname cat 
! 
boot system flash sup-bootflash:c6sup11-jsv-mz.121-11b.E 
! 
redundancy 
�main-cpu 
� auto-sync standard 
ip subnet-zero 
! 
mls qos statistics-export interval 300 
mls qos statistics-export delimiter | 
! 

!--- CSM located in slot 3. Module running as Active.�
 
! 
module ContentSwitchingModule 3� 
! 


!--- Client side CSM VLAN 100 
!--- Gateway pointing to the MSFC.

! 
�vlan 100 client 
� ip address 172.17.63.217 255.255.255.192 
� gateway 172.17.63.214 
! 

!--- Server side CSM VLAN 200.

! 
�vlan 200 server 
� ip address 172.17.63.217 255.255.255.192 
! 

!--- Server farm configuration.
 
! 
�serverfarm WWWFARM 
� nat server� 
� no nat client 
� real 172.17.63.215 
�� inservice 
� real 172.17.63.216 
�� inservice 
! 

!--- VServer configuration. 

! 
�vserver SERVER 
� virtual 172.17.63.241 tcp www 
� serverfarm WWWFARM 
� persistent rebalance 
� inservice 
! 
interface GigabitEthernet1/1 
�no ip address 
�shutdown 
! 
interface GigabitEthernet1/2 
�no ip address 
�shutdown 
! 

!--- Connection to upstream device.

! 
interface FastEthernet2/1 
�switchport 
�switchport access vlan 100 
�switchport mode access 
�no ip address 
! 
interface FastEthernet2/2 
�no ip address 
�shutdown 
! 

!--- Connection to Web servers.

! 
interface FastEthernet2/3 
�switchport 
�switchport access vlan 200 
�switchport mode access 
�no ip address 
! 
interface FastEthernet2/4 
�switchport 
�switchport access vlan 200 
�switchport mode access 
�no ip address 
! 
interface FastEthernet2/5 
�no ip address 
�shutdown 
! 

!--- MSFC VLAN 100.

! 
interface Vlan100 
�ip address 172.17.63.214 255.255.255.192 
! 
ip classless 
ip route 0.0.0.0 0.0.0.0 172.17.63.193 
no ip http server 
! 
! 
line con 0 
line vty 0 4 
�login 
! 
end

Проверка (команды show)

команда show module csm # status

Show module csm # команда статуса отображает статус модуля SLB. Модуль должен быть подключен к сети.

cat#show module csm 3 status
SLB Module is online in slot 3.
Configuration Download state: COMPLETE, SUCCESS

команда show module csm # vserver name word detail

Show module csm # подробная команда vservers name word отображает подробную информацию о виртуальном сервере. Вы также видите состояние виртуального сервера и сколько соединений, там. Это - лучшая команда для использования для того, чтобы получить информацию виртуального сервера.

cat#show module csm 3 vservers name server detail�
SERVER, state = OPERATIONAL, v_index = 10
� virtual = 172.17.63.241/32:80, TCP, service = NONE, advertise = FALSE
� idle = 3600, replicate csrp = none, vlan = ALL, pending = 30
� max parse len = 600, persist rebalance = TRUE
� conns = 0, total conns = 4
� Default policy:
��� server farm = WWWFARM
��� sticky: timer = 0, subnet = 0.0.0.0, group id = 0
� Policy���������� Tot Conn���� Client pkts� Server pkts
� ------------------------------------------------------
� (default)������� 4����������� 56���������� 56

команда show module csm # real detail

Команда show module csm # real detail отображает сведения о каждом реальном сервере, например на какой серверной ферме находится каждый сервер, состояния серверов, пороги и подключения.

cat#show module csm 3 real detail
172.17.63.215, WWWFARM, state = OPERATIONAL
� conns = 0, maxconns = 4294967295, minconns = 0
� weight = 8, weight(admin) = 8, metric = 0, remainder = 0
� total conns established = 2, total conn failures = 2
172.17.63.216, WWWFARM, state = OPERATIONAL
� conns = 0, maxconns = 4294967295, minconns = 0
� weight = 8, weight(admin) = 8, metric = 0, remainder = 0
� total conns established = 2, total conn failures = 2
cat#show module csm 3 real detail

показать детальную команду слова-имени модуля csm # serverfarm

Команда show module csm # serverfarms name word detail отображает информацию фермы сервера. Эта команда показывает предиктор, используемый для распределения нагрузки. В этом примере используется циклический алгоритм, заданный по умолчанию.

cat#show module csm 3 serverfarms name wwwfarm detail�
WWWFARM, predictor = RoundRobin, nat = SERVER
� virtuals inservice: 1, reals = 2, bind id = 0, fail action = none
� inband health config: <none>
� retcode map = <none>
� Real servers:
��� 172.17.63.215, weight = 8, OPERATIONAL, conns = 0
��� 172.17.63.216, weight = 8, OPERATIONAL, conns = 0
� Total connections = 0

команда "show module csm #vlan"

С помощью команды show module csm # vlan detail отображается информация о сети VLAN для клиента и сервера.

cat#show module csm 3 vlan detail�
vlan�� IP address������ IP mask��������� type������
---------------------------------------------------
100��� 172.17.63.217��� 255.255.255.192� CLIENT
� GATEWAYS
� 172.17.63.214����
200��� 172.17.63.217��� 255.255.255.192� SERVER
cat#

Устранение неполадок

Должна существовать возможность пропинговать реальный сервер и шлюз CSM от Catalyst 6500 путем запуска эхо-запроса или модуля CSM эхо-запроса # команды реальных сервера и приложений.

cat#ping module csm 3 reals
IP address������ Reachable
--------------------------
172.17.63.215��� Yes
172.17.63.216��� Yes
cat#ping module csm 3 gateway�������������������������
IP address������ Reachable
--------------------------
172.17.63.214��� Yes

Другая хорошая команда устранения проблем является show module csm # arp. CSM изучит адреса. Удостоверьтесь, что обнаруживаются шлюз и реальные сервера и приложения.

cat#show module csm 3 arp�
Internet Address� Physical Interface� VLAN����� Type������ Status
--------------------------------------------------------------------
�172.17.63.210��� 00-E0-B6-01-FA-49�� 100������ LEARNED��� up(0 misses)
�172.17.63.214��� 00-04-C0-C0-68-00�� 100������ GATEWAY��� up(0 misses)
�172.17.63.215��� 00-60-B0-87-DC-1A�� 200������ REAL������ up(0 misses)
�172.17.63.216��� 00-50-DA-BF-A1-7F�� 200������ REAL������ up(0 misses)
�172.17.63.217��� 00-30-F2-71-5D-2E�� 100/200�� --SLB--��� local
�172.17.63.222��� 00-02-B9-45-A2-91�� 100������ LEARNED��� up(0 misses)
�172.17.63.241��� 00-30-F2-71-5D-2D�� 0�������� VSERVER��� local

Дополнительные сведения


Document ID: 5217