Коммутаторы : ??????????? Cisco Catalyst ????? 3750

Настройка и анализ кластеризации на коммутаторах с фиксированной конфигурацией Catalyst

20 октября 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (20 октября 2015) | Отзыв


Содержание


Введение

В этом документе описаны основные шаги настройки для создания кластера на основе Catalyst 1900/2820 и коммутаторов Catalyst различной конфигурации с помощью Cluster Management Suite (CMS). Коммутаторы Catalyst с фиксированной конфигурацией, которые охватывает этот документ, включают серии 2900/3500XL, 2940, 2950, 2955, 2970, 3550, 3560 и 3750. Цель этого документа - дать базовые знания о том, как работает кластеризация, и предоставить основные процедуры анализа и устранение неполадок с командами show и выходными данными отладки debug. Документ содержит простой пример кластера, построенного с помощью веб-интерфейса. Он также показывает автоматические изменения конфигурации, отмечаемые во время процесса кластерной сборки (cluster build process).

Предварительные условия

Требования

Отдельный документ Управления web предоставляет сведения о том, как обратиться к коммутатору с Cisco Visual Switch Manager (VSM) или CMS. Документ, Устраняя неполадки Cisco Visual Switch Manager или Доступа к набору управления кластерами на Catalyst 2900 XL/3500 XL/2950/3550 Коммутатор, решает эти проблемы:

  • Не удается подключиться к главной веб-странице коммутатора

  • 404 Не Найденные ошибки

  • Пустой экран, когда вы обращаетесь к VSM или CMS

  • Java не является включенным экраном

  • Веб-интерфейс непрерывно спрашивает имя пользователя и пароль

  • Никакой ответ из сообщений от устройства во время ссылки или создания графиков пропускной способности

В случае проблем доступа с веб-интерфейсом управления (VSM or CMS) или если замечены какие-либо из этих признаков, см. "Устранение проблем Cisco Visual Switch Manager" или "Доступ к пакету управления кластерами на коммутаторе Catalyst 2900 XL/3500 XL/2950/3550".

Используемые компоненты

Настоящий документ не имеет жесткой привязки к каким-либо конкретным версиям программного обеспечения и оборудования.

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Технические рекомендации Cisco. Условные обозначения.

Важные примечания

Технология кластеризации коммутаторов Cisco является рядом программных характеристик, доступных всему 2900/3500XL, 2940, 2950, 2955, 2970, 3550, 3560, и коммутаторы серии 3750 и Стандарт Catalyst 1900/2820 и Коммутаторы для предприятий. Технология кластеризации включает максимум до 16 взаимосвязанных коммутаторов для формирования управляемой сети одного IP-адреса. Это - по существу метод для управления группой коммутаторов без потребности назначить IP-адрес на каждый коммутатор.

Коммутаторы в пределах кластера играют одну из таких ролей:

  • Командный маршрутизатор

  • Рядовые коммутаторы

  • Коммутаторы-кандидаты

В каждом кластере имеется главный, или командный, коммутатор. Остаток коммутаторов служит коммутаторами - участниками. Коммутатор команд предоставляет основной интерфейс управления для всего кластера. Коммутатор команд обычно является единственным коммутатором в кластере коммутаторов с настроенным IP-адресом. Каждый запрос управления переходит к командному коммутатору перед перенаправлением к соответствующему коммутатору - участнику. Для резервирования можно настроить коммутатор для команды ожидания. Коммутатор для команды режима ожидания должен быть той же модели, что и командный коммутатор. Коммутатор - участник, как правило, не настраивается с IP-адресом и получает команды управления, которые перенаправил командный коммутатор. Кандидат в коммутаторы является коммутатором, который можно добавить к кластеру коммутаторов как коммутатор - участник.

Характеристики командного коммутатора

Командный коммутатор Catalyst должен удовлетворить эти требования:

  • У маршрутизатора имеется IP-адрес.

  • Для коммутатора включен протокол обнаружения Cisco версии 2 (CDPv2) (по умолчанию).

  • Коммутатор не является управляющим или рядовым коммутатором другого кластера.

  • Коммутатор подключается к резервным управляющим коммутаторам через VLAN управления, а к рядовым коммутаторам - через обычную сеть VLAN.

Как указано ниже, командным коммутатором должен быть самый современный коммутатор в данном кластере, способный выполнять наибольшее количество команд:

  • Если ваш кластер коммутаторов имеет 3750 коммутаторов, тот коммутатор должен быть командным коммутатором.

  • Если ваш кластер коммутаторов имеет 2900XL, 2940, 2950, 2955, 3550, 3560 и 3500XL, коммутаторы, 3550 или эти 3560 должны быть командным коммутатором.

  • Если ваш кластер коммутаторов имеет 2900XL, 2940, 2950, 2955, и 3500XL, коммутаторы, 2950 или эти 2955 должны быть командным коммутатором.

  • Если ваш кластер коммутаторов имеет 1900, 2820, 2900XL, и 3500XL, коммутаторы, или 2900XL или 3500XL должны быть командным коммутатором.

Характеристики коммутаторов для команд режима ожидания

Коммутатор для команды ожидания Catalyst должен удовлетворить эти требования:

  • У маршрутизатора имеется IP-адрес.

  • В коммутаторе включена поддержка CDPv2.

  • Коммутатор подключен к другим резервным коммутаторам через VLAN управления и ко всем рядовым коммутаторам через обычную VLAN.

  • Коммутатор имеет резервное подключение к кластеру для поддержания устойчивой связи с рядовыми коммутаторами.

  • Коммутатор не является управляющим или рядовым коммутатором другого кластера.

Коммутаторы для команды ожидания также должны удовлетворить эти требования:

  • Когда командный коммутатор является коммутатором a�3750, все коммутаторы для команды ожидания должны коммутаторы be�3750.

  • Когда командный коммутатор является коммутатором a�3550, все коммутаторы для команды ожидания должны коммутаторы be�3550.

  • Когда командный коммутатор является коммутатором a�2955, все коммутаторы для команды ожидания должны коммутаторы be�2955.

  • Когда командный коммутатор является a�2950 коммутатором Long-Reach Ethernet (LRE), все коммутаторы для команды ожидания должны коммутаторы be�2950 LRE.

  • Когда командный коммутатор является коммутатором non-LRE₩½2950, который выполняет Cisco программное обеспечение IOS� Release�12.1 (9) EA1 или позже, все коммутаторы для команды ожидания должны быть коммутаторами non-LRE₩½2950, которые выполняют программное обеспечение Cisco IOS Release�12.1 (9) EA1 или позже.

  • Когда командный коммутатор является коммутатором non-LRE₩½2950, который выполняет программное обеспечение Cisco IOS Release�12.1 (6) EA2 или позже, все коммутаторы для команды ожидания должны быть коммутаторами non-LRE₩½2950, которые выполняют программное обеспечение Cisco IOS Release�12.1 (6) EA2 или позже.

  • Когда программное обеспечение Cisco IOS выполнений командного коммутатора Release�12.0 (5) WC2 или ранее, коммутаторы для команды ожидания могут be�2900XL, non-LRE�2950, and�3500XL коммутаторы.

Командный коммутатор и коммутаторы для команды ожидания должны иметь ту же платформу коммутатора.

  • С a�3550 командным коммутатором коммутаторы для команды ожидания должны коммутаторы be�3550.

  • С a�2955 командным коммутатором коммутаторы для команды ожидания должны коммутаторы be�2955.

  • С командным коммутатором a₩½2950 LRE коммутаторы для команды ожидания должны коммутаторы be�2950 LRE.

  • С non-LRE₩½2950 командным коммутатором коммутаторы для команды ожидания должны быть коммутаторами non-LRE₩½2950.

  • С командным коммутатором a₩½2900XL or₩½3500XL коммутаторы для команды ожидания должны коммутаторы be�2900XL and�3500XL.

Кандидат в коммутаторы и Характеристики коммутатора - участника

Кандидаты в коммутаторы являются коммутаторами с поддержкой кластеров, которые еще не были добавлены к кластеру. Коммутаторы - участники являются коммутаторами, которые были фактически добавлены к кластеру коммутаторов. Хотя это и не требуется у кандидата или коммутатора - участника могут быть IP-адрес и пароль. (Для похожих рассуждений обратитесь к разделу IP-адресов и разделу Паролей документа Кластеризации коммутаторов.)

Для присоединения к кластеру коммутатор-кандидат должен соответствовать следующим требованиям:

  • На коммутаторе в данный момент запущено ПО, поддерживающее кластеры.

  • В коммутаторе включена поддержка CDPv2.

  • Коммутатор не является управляющим или рядовым коммутатором другого кластера.

  • Для соединения коммутатора с командным коммутатором используется как минимум одна сеть VLAN.

  • Если кластерная резервная группа существует, подключения коммутатора к каждому коммутатору для команды ожидания по крайней мере через одну общую VLAN. VLAN каждого резервного командного коммутатора могут различаться.

Примечание: Они кандидат и коммутаторы - участники должны соединиться с командным коммутатором и коммутаторами для команды ожидания через VLAN управления:

  • 1900 коммутаторов

  • 2820 коммутаторов

  • коммутаторы 2900XL

  • коммутаторы non-LRE₩½2950, которые в настоящее время выполняют выпуск ранее, чем программное обеспечение Cisco IOS Release�12.1 (9) EA1

  • 3500XL коммутаторы

Примечание: Это требование не применяется, если у вас есть не-LRE 2950 командных коммутаторов, которые в настоящее время выполняют программное обеспечение Cisco IOS Release�12.1 (9) EA1 или позже, 2950 командных коммутаторов LRE, 2955 командных коммутаторов или a�3550 командный коммутатор. Кандидат и коммутаторы - участники могут соединиться через любую VLAN вместе с командным коммутатором.

При помощи CDPv2 все коммутаторы, включая командные, обнаруживают соседние узлы CDP и хранят эту информацию в соответствующем кэше соседнего узла CDP. Коммутаторы, которые выполняют с поддержкой кластеров программное обеспечение, передают информацию о коммутаторах и соответствующих соседях к командному коммутатору. Для этого коммутаторы используют механизм внутрикластерной связи (ICC), который выполняется поверх протокола UDP. На командном коммутаторе осуществляется фильтрация данных, и создается список коммутаторов-кандидатов.

Для отображения списка кандидатов введите команду show cluster candidates на командном коммутаторе.

Примечание: Список может не отразить таблицу окружения CDP командного коммутатора. Таблица соседних узлов протокола обнаружения Cisco (CDP) отображает сведения только о непосредственных соседях. Любой коммутатор, который находится в списке, является кандидатом, чтобы быть коммутатором - участником или коммутатором, которым может управлять командный коммутатор. Кандидат в коммутаторы должен удовлетворить эти требования для присоединения к кластеру:

Примечание: Кандидат в коммутаторы может иметь IP-адрес, но IP-адрес не необходим.

Примечание: При помощи команды "switch IP address" можно получить доступ ко всем возможностям администрирования кластера. IP-адрес управляющего коммутатора всегда принадлежит к VLAN управления (по умолчанию VLAN1). Все коммутаторы в кластере коммутаторов должны иметь ту же VLAN управления как командный коммутатор. С программного обеспечения Cisco IOS версии 12.0(5)XP для 2900XL и 3500XL коммутаторы, можно изменить VLAN управления от по умолчанию VLAN1. Кроме того, программное обеспечение Cisco IOS версии 12.0(5)XU или позже позволяет вам изменять VLAN управления для кластера целостного коммутатора. Изменение требует одной команды, которую необходимо выполнить через веб-интерфейс CMS. Для получения дополнительной информации о том, как изменить VLAN управления, обратитесь к этим документам:

Обнаружение через маршрутизируемые порты

Если кластерному командному коммутатору настроили маршрутизируемый порт, коммутатор обнаруживает только кандидата и коммутаторы члена кластера в той же VLAN как маршрутизируемый порт. Для получения дополнительной информации о маршрутизируемых портах, обратитесь к разделу Маршрутизируемых портов 3750 Характеристик Интерфейса Настройки руководства по конфигурации программного обеспечения.

Обнаружение через другие VLAN

Если командный коммутатор является a�3550, 3560, или 3750 коммутаторов, кластер может иметь коммутаторы - участников в других VLAN. Коммутаторы - участники, которые являются 3550, должны соединиться по крайней мере через одну VLAN, которую коммутатор имеет вместе с командным коммутатором. Коммутаторы - участники, что are�2900XL, �are 2950 и выполняют выпуск ранее, чем программное обеспечение Cisco IOS Release�12.1 (9) EA1 или are�3500XL, должны соединиться с командным коммутатором через VLAN управления. Для получения информации об обнаружении через VLAN управления обратитесь к Обнаружению через Тот же Раздел VLAN управления и Обнаружению через Другой раздел VLAN управления документа Кластеризации коммутаторов. Для получения дополнительной информации о VLAN, обратитесь к VLAN Настройки документа.

Модели коммутаторов Catalyst с функциями кластера

Установка с поддержкой кластеров версии Программного обеспечения Catalyst достигает кластерной функциональности. Весь Catalyst совместимые с кластером коммутаторы может быть командными коммутаторами. Можно обновить коммутаторы серии 8 MB 2900XL для работы в качестве командных коммутаторов. Невозможно обновить коммутаторы 2900XL 4 Мбайт для их обслуживания в качестве управляющих коммутаторов. Кроме того, эти коммутаторы могут только действовать как члены кластера, если коммутаторы в настоящее время выполняют Cisco IOS Software Release 11.2 (8.x) SA6.

Перед созданием кластеров необходимо определить, который коммутаторы с поддержкой кластеров. Также понадобится определить, какие коммутаторы могут быть командными. С помощью этой таблицы можно определить, является ли коммутатор членом кластера или командным коммутатором:

Catalyst 2900XL, 2950, 2955, 2970, 2940, 3550, 3560, и 3750 Наименьших версий ПО Моделей и Возможности кластера

Тип коммутатора Catalyst Программное обеспечение Cisco IOS Release� Возможности кластера
3750 Программное обеспечение Cisco IOS версии 12.2(11)AX или позже Коммутатор-участник или командный коммутатор
3560 Программное обеспечение Cisco IOS версии 12.1(19)EA1 или позже Коммутатор-участник или командный коммутатор
3550 Cisco IOS Software Release 12.1 (4) EA1 или позже Коммутатор-участник или командный коммутатор
2970 Программное обеспечение Cisco IOS версии 12.2(11)AX или позже Коммутатор-участник или командный коммутатор
2950 Cisco IOS Software Release 12.0 (5.2) WX (1) или позже Коммутатор-участник или командный коммутатор
2955 Программное обеспечение Cisco IOS версии 12.1 (12c) EA1 или позже Коммутатор-участник или командный коммутатор
2950 LRE Программное обеспечение Cisco IOS версии 12.1(11)YJ или поздно Коммутатор-участник или командный коммутатор
2940 Программное обеспечение Cisco IOS версии 12.1(13)AY или позже Коммутатор-участник или командный коммутатор
3500XL Программное обеспечение Cisco IOS версии 12.0 (5.1) XU или позже Коммутатор-участник или командный коммутатор
2900 LRE XL (коммутаторы на 16 МБ) Программное обеспечение Cisco IOS версии 12.0 (5.1) WC1 или позже Коммутатор-участник или командный коммутатор
2900XL (коммутаторы с ОЗУ 8 Мб) Программное обеспечение Cisco IOS версии 12.0 (5.1) XU или позже Коммутатор-участник или командный коммутатор
2900XL (коммутаторы на 4 МБ) Cisco IOS Software Release 11.2 (8.5) SA6 (рекомендован) Коммутатор - участник only1
1900 и 2820 Программное обеспечение Cisco IOS Release 9.0 (-A или - EN) Коммутатор - участник только

1The 2900XL коммутаторы (на 4 МБ) появляются в лицевой панели и просмотрах топологии CMS. Однако CMS не поддерживает конфигурацию или монитор этих коммутаторов. �To определяют, имеет ли ваш 2900XL коммутатор 4 МБ или 8 МБ DRAM, и если коммутатору нужно обновление программного обеспечения, выполните команду Show version пользовательского уровня. Для получения дополнительной информации об этой команде обратитесь к , Как Определить Количество памяти на Коммутаторе Использование раздела Интерфейса командной строки Обновления программного обеспечения в Catalyst 2900XL и 3500XL Коммутаторы Использование Интерфейса командной строки.

Примечание: В настоящее время для поддержки коммутаторов 1900 и 2820 как коммутаторов-участников на командных коммутаторах (3600XL или 8 MB 2900XL) должно выполняться Cisco IOS Software Release 12.0(5) XP или более поздней. 2950 командных коммутаторов должны выполнить программное обеспечение Cisco IOS версии 12.0(5) WC (1) или позже.

Коммутаторы 1900 и 2820 должны работать на микропрограмме версии 9.00 (стандартная или корпоративная версии) и не могут выступать в качестве управляющих коммутаторов. Для получения дальнейшей информации обратитесь к Комментариям к выпуску для Коммутаторов Серии Catalyst 1900 и Catalyst 2820, Версии 9.00.

Протокол управления кластером

Когда включена кластеризация коммутаторов, командному коммутатору присвоен виртуальный IP-адрес, который называется протоколом управления кластером (Cluster Management Protocol - CMP). Когда коммутатор становится участником, командный коммутатор генерирует другой адрес CMP для нового коммутатора - участника. Этот адрес применяется для любого ICC. Командный коммутатор использует этот адрес CMP для отправки и добавления сообщения на кандидат в коммутаторы. Кандидат в коммутаторы проверяет, что это не часть другого кластера, перед тем как коммутатор извлекает адрес CMP и сведения о кластере из сообщения добавления. Кандидат в коммутаторы затем отвечает управляющему коммутатору.

Примечание: Адреса CMP, которые являются для ICC, отличаются от IP-адреса, который является для коммутатора или управления кластером. Адреса CMP не отвечают на эхо-запросы. Это отсутствие ответа происходит из-за статических записей Протокола Разрешения Адреса (ARP), которые существуют для всех адресов CMP в кластере коммутаторов, но очевидны для окружения за пределами кластер.

CMP является набором основных технологий, которые упрощают управление 16 коммутаторов с использованием одного IP-адреса. CMP состоит из трех ключевых частей технологии:

  • Механизм назначения адреса CMP

  • Механизм переноса CMP/IP

  • Механизм определения адресов CMP/протокола RARP

Механизм назначения адреса CMP позволяет динамически распределять адреса CMP для членов кластера и обеспечивать отсутствие конфликтов с другими CMP- и IP-адресами кластера. Механизм назначения адреса CMP также позволяет решать конфликты адресов. CMP/IP – это механизм переноса, который выполняет обмен пакетами управления между командным коммутатором и коммутаторами-членами. Пакеты CMP/IP являются обычными пакетами IP, которые инкапсулированы в заголовке Протокола Доступа к Подсети (SNAP) совместно с протоколами типа Cisco Organizational Unique Identifier (OUI) (Уникальным идентификатором организации) и Протоколом CMP. Идентификация отделяет эти пакеты от обычных пакетов Ethernet TCP/IP. Формат позволяет текущим IP-приложениям работать на CMP/IP без любого изменения и позволяет HTTP и перенаправлению Протокола SNMP происходить. CMP/RARP является изменением RARP. Он добавляет и удаляет коммутаторы из кластера, устанавливает кластерные параметры, и уведомляет командный коммутатор о конфликтах адресов CMP.

В разделе "debug cluster ip" этого документа далее объясняется CMP с помощью команд отладки.

Связь в Коммутаторном кластере ICC

Связь в кластере использует адреса CMP; ICC транспортирует его. Любая связь, внешняя к кластеру, использует IP-адреса и механизм переноса TCP/IP. Для связи от обращенного к CMP устройства до устройства с внешним IP-адресом командный коммутатор действует как прокси и выполняет трансляцию между протоколами TCP/IP и CMP.

Как Раздел протокола Управления кластером упоминает, командный коммутатор назначает IP-адреса, названные адресами CMP ко всем коммутаторам в кластере. Любое время ПК управления использует IP-адрес командного коммутатора для доступа к коммутаторам - участникам, командный коммутатор, использует адреса CMP для перенаправления трафика.

Например, при создании кластера, командный коммутатор управляет обменом сообщениями между коммутаторами - участниками и приложением SNMP. ПО управления кластером присоединяет номер рядового коммутатора (@esN, где N – номер коммутатора) к первым настроенным строкам сообщества для чтения и записи (RW) и только для чтения (RO) на управляющем коммутаторе. Это тогда распространяется их к коммутатору - участнику. Командный коммутатор использует строки имени и пароля для управления форвардом get-request, set-request и сообщений get-next-request между станцией управления SNMP и коммутаторами - участниками.

При управлении коммутатором - участником в кластере с использованием CMS или SNMP станция управления передает запросы управления к IP-адресу командного коммутатора. Запросы поступают на управляющий коммутатор, поскольку рядовой коммутатор обычно не имеет IP-адреса. Запрос содержит классификатор (esN, где N – номер коммутатора). Классификатор информирует командный коммутатор о члене, которому запрос предназначается. Командный коммутатор изменяет запрос таким образом, что создается впечатление, что запрос исходит от командного коммутатора. Это тогда пересылает запрос на соответствующий коммутатор - участника. Коммутатор-участник получает запрос управления и выполняет команду локально. Поскольку рядовой коммутатор "полагает", что управляющие пакеты пришли с командного коммутатора, подтверждение приёма направляется прямо на командный коммутатор. Наконец, командный коммутатор модифицирует подтверждения и повторно передает их станции управления.

На этой блок-схеме показано, как работает перенаправление SNMP:

/image/gif/paws/4085/61-a.gif

Для получения дальнейшей информации на SNMP - управлении на коммутаторах серии XL, обратитесь к документам, перечисленным здесь:

Настройте кластеризацию

В этом разделе описываются пошаговые процедуры для настройки объединения в кластеры на Catalyst 2900XL, 2940, 2950, 2955, 2970, 3550, 3560, и 3750 коммутаторов с использованием CMS. Разработка и тест конфигураций в этом разделе произошли с этими версиями программного и аппаратного обеспечения:

Версии ПО

  • 3500XL (3500XL-C3H2S-M), Cisco IOS Software Release 12.0(5.2)XU, внутреннее программное обеспечение сопровождения

  • 2900XL (2900XL-C3H2S-M) программное обеспечение Cisco IOS версии 12.0 (5.2) XU, внутреннее программное обеспечение сопровождения

  • 2900XL (2900XL-HS-M) Cisco IOS Software Release 11.2(8.6)SA6, внутреннее программное обеспечение сопровождения

Версии оборудования

  • Процессор Cisco WS-C3524XL (PowerPC403) (Revision 0x01) с 8192 КБ KB/1024 памяти

  • Процессор Cisco WS-C3512XL (PowerPC403) (Revision 0x01) с 8192 КБ KB/1024 памяти

  • Процессор Cisco WS-C2924MXL (PowerPC403GA) (Revision 0x11) с 8192 КБ KB/1024 памяти

  • Процессор Cisco WS-C2916MXL (PowerPC403GA) (Revision 0x11) с 4096 КБ KB/640 памяти

Сценарии проверки

Схема 1

/image/gif/paws/4085/61-b.gif

Схема 2

/image/gif/paws/4085/61-c.gif

Схема 3: Топология типа «звезда»

/image/gif/paws/4085/61-d.gif

Схема 4: гирляндная топология

61-e.gif

Создайте кластеры с пакетом управления кластером

В данном разделе описана пошаговая процедура создания простого кластера с использованием CMS. В примерах конфигурации и выходных результатах этих шагов используются коммутаторы серий 3500XL и 2900XL. Однако можно заменить другими коммутаторами с фиксированной конфигурацией то объединение в кластеры CMS поддержки. Кроме того, интерфейс пользователя некоторых коммутаторов может казаться другим, чем окна, которые вы видите в этом разделе. (См. рисунок 1 и образы, которые придерживаются рисунка 1.) Это различие зависит от версии кода, которую вы установили в коммутаторе.

Самый легкий способ настроить кластер через Веб-интерфейс. Однако необходимо знать то, что продолжается "негласно". Этот раздел предоставляет окна, которые показывают веб-конфигурацию кластера, а также изменения к конфигурациям на коммутаторах тот результат.

В данном разделе также использован пример для описания процедуры создания кластеров с использованием CMS. В примере вы соединили проводом вместе четыре коммутатора с использованием Гигабита и Портов Fast Ethernet. Первоначально, вы создаете кластер с одним командным коммутатором и двумя коммутаторами - участниками. Позже, вы добавляете другой коммутатор в кластере, который демонстрирует, как добавить нового участника.

Примечание: В этом документе нет описания настройки кластера с помощью интерфейса командной строки (CLI). Для получения дополнительной информации о CLI обратитесь к разделам конфигурации интерфейса командой строки Создания и Управления Кластерами.

Реализация конфигураций в этом документе произошла в изолированной лабораторной среде, как вы видите в Схеме 1 и Схеме 2. Убедитесь, что вы понимаете потенциальное воздействие любой конфигурации или команды в вашей сети перед использованием его. В результате выполнения команды write erase все конфигурации на всех устройствах будут удалены и заменены конфигурациями по умолчанию.

Примечание: В этом документе предполагается, что пользователь имеет доступ к CLI на коммутаторах с использованием порта консоли. Для получения дополнительной информации о том, как обратиться к Коммутатору XL с консольным портом, обратитесь к Доступу к Коммутатору Использование раздела Консольного порта Обновления программного обеспечения в Коммутаторах Catalyst 2900XL Использование Интерфейса командной строки.

  1. Проверьте, что все коммутаторы имеют версию или команды или кода коммутатора - участника, который имеет кластерную поддержку.

    Это всегда верно для коммутаторов серий 2940, 2950, 2970, 3550, 3560 и 3750, потому что все версии их ПО поддерживают кластеризацию.

    Для получения дополнительной информации на версиях программного обеспечения и коммутаторах, которые поддерживают объединение в кластеры, посмотрите Модели коммутатора Catalyst с разделом Возможностей кластера этого документа. Чтобы определить если ваши выполнения коммутатора 2900XL/3500XL с поддержкой кластеров программное обеспечение, выполните команду Show version пользовательского уровня на коммутаторе.

    Например, 2900XL или коммутатор серии 3500XL, который выполняет команду - и с поддержкой членов программное обеспечение предоставляет эти выходные данные команды Show version:

    Switch> show version
    Cisco Internetwork Operating System Software
    IOS (TM) C3500XL Software (C3500XL-C3H2S-M), Version 12.0(5.2)XU, 
    MAINTENANCE INTERIM SOFTWARE
    Copyright (c) 1986-2000 by cisco Systems, Inc.
    Compiled Mon 17-Jul-00 18:29 by ayounes
    Image text-base: 0x00003000, data-base: 0x00301F3C
    
    ROM: Bootstrap program is C3500XL boot loader
    
    Switch uptime is 3 days, 1 hour, 45 minutes
    System returned to ROM by reload
    System image file is "flash:c3500XL-c3h2s-mz-120.5.2-XU.bin"
    
    
    cisco WS-C3524-XL (PowerPC403) processor (revision 0x01) with 8192K/1024K 
    bytes of memory.
    Processor board ID , with hardware revision 0x00
    Last reset from warm-reset
    
    Processor is running Enterprise Edition Software
    Cluster command switch capable
    Cluster member switch capable
    24 FastEthernet/IEEE 802.3 interface(s)
    2 Gigabit Ethernet/IEEE 802.3 interface(s)
    
    32K bytes of flash-simulated non-volatile configuration memory.
    Base ethernet MAC Address: 00:D0:58:68:F1:80
    Configuration register is 0xF
    

    Примечание: В этих выходных данных Кластерный способный командный коммутатор и Член кластера коммутирует способный показ, что коммутатор в настоящее время выполняет программное обеспечение, которое является и командой - и с поддержкой членов. Если коммутатор только выполняет с поддержкой членов программное обеспечение, то только способный коммутатор Члена кластера появляется в выходных данных. Можно также настроить коммутатор, который выполняет способное к команде программное обеспечение как коммутатор - участника; однако, вы никогда не можете настраивать коммутатор, который выполняет только с поддержкой членов программное обеспечение как командный коммутатор.

  2. Если вы находите в Шаге 1, что коммутатор не выполняет с поддержкой кластеров программное обеспечение, обновите коммутатор к корректному программному обеспечению.

    Как только коммутатор выполняется с поддержкой кластеров образ, продолжитесь к Шагу 3.

  3. Телеграфируйте коммутаторы так, чтобы командный коммутатор был в состоянии обнаружить кандидатов в коммутаторы, которые способны к добавлению к кластеру.

    С использованием CDPv2 командный коммутатор может автоматически обнаружить коммутаторы в звезде или объединить в гирляндную цепь топологию, которая является до трех кластерно-поддерживающих устройств (три перехода) далеко от края кластера. При использовании Cisco IOS Software Release 12.0(5)XU или более позднего можно настроить управляющий коммутатор на обнаружение коммутаторов, находящихся не более чем в семи переходах (через семь устройств, поддерживающих кластеризацию).

    Выполните эту команду на командном коммутаторе, если вы хотите включить обнаружение кандидата в коммутаторы, который является до семи переходов далеко:

    Switch(config)# cluster discovery hop-count 7
    

    Если CDP поддержки коммутаторов, но не поддерживает объединение в кластеры, и это соединяется с командным коммутатором, кластер неспособен обнаружить кандидатов, которые подключают к нему. Например, Составитель кластера Cluster Builder не может создать кластер, который включает кандидатов, которые соединяются с Catalyst 5500/5000 или 6500/6000 коммутатором серии, который соединяется с командным коммутатором.

    Кроме того, убедитесь, что вы подключаете все коммутаторы с теми портами, которые находятся в той же VLAN управления. Доступ ко всем средствам управления кластером через IP-адрес командного коммутатора. IP-адрес управляющего коммутатора всегда принадлежит к VLAN управления (по умолчанию VLAN1). Все коммутаторы в кластере коммутаторов должны иметь ту же VLAN управления как командный коммутатор.

    Примечание: С программного обеспечения Cisco IOS версии 12.0(5)XP для 2900XL и 3500XL коммутаторы, можно изменить VLAN управления от по умолчанию (VLAN1). Кроме того, программное обеспечение Cisco IOS версии 12.0(5)XU или позже позволяет вам изменять VLAN управления для кластера целостного коммутатора. Изменение требует одной команды, которую необходимо выполнить через веб-интерфейс CMS. Для получения дополнительной информации о том, как изменить VLAN управления, обратитесь к этим документам:

    В этом примере центральный коммутатор (3524XL) настраивается как командный коммутатор. (См. схему 1.)

  4. После определения командного коммутатора назначьте IP-адрес.

    IP-адрес командного коммутатора в данном примере - 172.16.84.35. Используйте эти команды для выполнения начальной конфигурации на командном коммутаторе:

    Switch> enable
    Switch# configure terminal
    Enter configuration commands, one per line. End with CNTL/Z.
    Switch(config)# enable password mysecret
    Switch(config)# interface vlan1
    Switch(config-if)# ip address 172.16.84.35 255.255.255.0
    Switch(config-if)# exit
    Switch(config)# ip default-gateway 172.16.84.1
    Switch(config)# ip http server(Enabling web access to the switch)
    Switch(config)# end
    Switch#
    %SYS-5-CONFIG_I: Configured from console by console
    Switch# write memory
    Building configuration...
    [OK]
    

    Примечание: Это начальная конфигурация, которую нужно настроить на коммутаторе, чтобы с его помощью можно было получить доступ к Web-ресурсам. Конфигурация кластера не произошла на этом этапе. При запуске команды show running-config на коммутаторе вы не замечаете добавление никаких кластерных команд в файле конфигурации.

  5. Для начала Веб-интерфейса введите IP-адрес командного коммутатора в окно браузера.

    Используйте этот синтаксис для ввода IP-адреса:

    http://x.x.x.x
    
    

    Примечание: Переменная x.x.x.x является IP-адресом коммутатора команд.

    Может быть выведено приглашение для ввода имени пользователя и пароля. В качестве регистрационного имени и пароля используйте разрешающий пароль. В данном примере mysecret является enable password. После ввода входа в систему и пароля вы видите Страницу доступа Cisco, как вы видите на рисунке 1. Если вы испытываете затруднения из-за доступа коммутатора при использовании web-браузера обратитесь к Устранению проблем Cisco Visual Switch Manager или Доступа к набору управления кластерами на Catalyst 2900 XL/3500 XL/2950/3550 Коммутатор.

    Рисунок 1

    /image/gif/paws/4085/61-f.gif

    Примечание: Более поздние версии программного обеспечения используют Страницу доступа Cisco как этот:

    Рис. 2

    /image/gif/paws/4085/61-g.gif

  6. Нажмите Cluster Management Suite или Visual Switch Manager на Странице доступа Cisco.

    Будет открыт экран с эмблемой Visual Switch Manager, как показано на рис. 3. Домашняя страница Switch Manager, как видно на рис.4, загружается.

    Примечание: При выборе ссылки Cluster Management Suite или Visual Switch Manager на странице доступа Cisco сначала появляется экран с логотипом Visual Switch Manager. С разрешением объединения в кластеры вы видите экран Cluster Management Suite после экрана с эмблемой Visual Switch Manager (вместо рисунка 4).

    Рис. 3

    /image/gif/paws/4085/61-h.gif

    Рис. 4

    /image/gif/paws/4085/61-i.gif

    Примечание: Если вы испытываете трудности с доступом к домашней странице Коммутатора, которую вы видите на рисунке 4, обращаетесь к Устранению проблем Cisco Visual Switch Manager или Доступа к набору управления кластерами на Catalyst 2900 XL/3500 XL/2950/3550 Коммутатор устранять проблему.

    Конфигурация кластера до настоящего момента не выполнена. Поэтому в конфигурации любого коммутатора не произошло никаких изменений, связанных с кластеризацией. В шагах, которые придерживаются, вы добавляете кластерные команды в файлах конфигурации. Процедура обсуждает каждую команду.

  7. От строки меню выберите Cluster> Cluster Command Configuration.

    Это открывает окно Cluster Configuration, как показано на рисунке 5.

    Рис. 5

    /image/gif/paws/4085/61-j.gif

  8. В поле Command Switch Status, выберите Enable.

  9. Введите имя в поле Cluster Name.

    Для названия кластера можно использовать до 31 символа. В этом примере в качестве имени кластера используется “engineering”:

    Рис. 6

    /image/gif/paws/4085/61-k.gif

  10. Нажмите кнопку OK.

    Это позволяет использовать кластеризацию на центральном коммутаторе и делает этот коммутатор управляющим. При нажатии кнопки OK на экране отображается дополнительная информация о кластере (см. рис. 7).

    IP-адрес команды и имя кластера стали видимыми. Данный экран также называется Cluster Management Suite (Пакет управления кластерами).

    Рисунок 7

    /image/gif/paws/4085/61-l.gif

    На этом этапе обновление центрального коммутатора (3524XL) конфигурация произошла при командах, которые появляются полужирным:

    !
    hostname Switch
    !
    enable password mysecret
    !
    ip subnet-zero
    cluster enable engineering 0
    !
    !
    !
    interface VLAN1
    ip address 172.16.84.35 255.255.255.0
    no ip directed-broadcast
    ip nat outside
    !
    !
    ip default-gateway 172.16.84.1
    ip Nat inside source list 199 interface VLAN1 overload
    access-list 199 dynamic Cluster-NAT permit ip any any
    
    !--- Full configuration output is suppressed.
    
    
    

    При выполнении команды "cluster enable engineering" коммутатор берет на себя функции управляющего кластером под названием "engineering". Команды Технологии NAT имеют автоматическое добавление к файлу конфигурации командного коммутатора. Не удаляйте эти команды, потому что команды обращаются к коммутаторам - участникам. Когда командный коммутатор управляет коммутатором - участником через Веб-интерфейс, действия командного коммутатора как прокси и вперед HTTP и вызовы Java к коммутатору - участнику. Командный коммутатор использует действительный в адресах NAT (также известный как адреса CMP) для выполнения этого действия. Для получения дополнительной информации о том, как CMP работает, посмотрите Раздел протокола Управления кластером этого документа.

  11. Выберите Cluster> Cluster Management.

    Новое окно управления кластером открывается. Окно показывает Составитель кластера Cluster Builder (карта коммутаторов). В этом окне появляется окно Suggested Candidate, как вы видите на рисунке 8. Можно переместить или минимизировать окно Suggested Candidate для наблюдения окна Cluster Builder (карта) ясно. В карте показана команда и кандидат в коммутаторы.

    Составитель кластера Cluster Builder использует CDP для обнаружения кандидатов в коммутаторы, которые способны к добавлению к кластеру. С CDP командный коммутатор может автоматически обнаружить коммутаторы в звезде или объединить в гирляндную цепь топологию, которая является до трех кластерно-поддерживающих устройств (три перехода) далеко от края кластера. (См. Шаг 3 этого раздела. При использовании Cisco IOS Software Release 12.0(5)XU или более позднего можно настроить управляющий коммутатор на обнаружение коммутаторов, находящихся не более чем в семи переходах (через семь устройств, поддерживающих кластеризацию).

    Примечание: В окне Suggested Candidate Показ предложил кандидатов каждый раз, когда Составитель кластера Cluster Builder запускается, флажок проверен. В зависимости от этого выбора вы можете или не можете видеть окно Suggested Candidate, которое включено по умолчанию.

    Рис. 8

    /image/gif/paws/4085/61-m.gif

    Примечание: На схеме показан только один коммутатор-кандидат. Командный коммутатор появляется в зеленом, и кандидат в коммутаторы появляется в синем. В этом случае коммутаторы появляются, так как существует два коммутатора, обладающих именем хоста по умолчанию Switch. В это время ни один из кандидатов в коммутаторы, которые появляются в синем, не был добавлен в кластере. Диспетчер кластера отобразил только один коммутатор на схеме топологии на рис. 8, хотя в действительности их два.

    Правильное количество доступных коммутаторов отображается в окне Suggested Candidate, как показано на рис. 8. Вы можете также использовать CLI для проверки корректности числа коммутаторов-соискателей, имеющих потенциал для того, чтобы быть рядовым коммутатором. Пример:

    Switch# show cluster candidates
                                                                 |---Upstream---|
    MAC Address      Name    Device Type    PortIf  FEC  Hops  SN    PortIf   FEC
    00e0.1e9f.50c0   Switch  WS-C2916M-XL   Fa0/1          1    0     Fa0/2
    00d0.5868.eb80   Switch  WS-C3512-XL    Gi0/2          1    0     Gi0/1
    
    
  12. Нажмите OK в окне Suggested Candidate и ждите в течение приблизительно 30 секунд.

    Вы видите экран, на котором отображается правильное количество коммутаторов-участников и центральный коммутатор:

    Рис. 9

    /image/gif/paws/4085/61-n.gif

    В этой схеме Коммутатор центрального коммутатора является командным коммутатором. Коммутатор-2 и коммутатор-2 – это коммутаторы-участники. Теперь, все коммутаторы являются зелеными, который показывает, что они находятся в кластере с названием "разработка".

    Проверить кластер можно с помощью следующих команд на командном и рядовом коммутаторе:

    • Командный коммутатор (центральный коммутатор, 3524XL):

      Switch# show cluster
      Command switch for cluster "engineering"
           Total number of members:                3
           Status:                                 0 members are unreachable
           Time since last status change:          0 days, 0 hours, 7 minutes
           Redundancy:                             Disabled
           Heartbeat interval:                     8
           Heartbeat hold-time:                    80
           Extended discovery hop count:           3
      
      Switch# show cluster members
                                                               |---Upstream---|
      SN   MAC Address      Name      PortIf   FEC   Hops  SN  PortIf  FEC  State
      0    00d0.5868.f180   Switch                     0                    Up (Cmdr)
      1    00e0.1e9f.50c0   Switch-1   Fa0/1           1    0  Fa0/2        Up
      2    00d0.5868.eb80   Switch-2   Gi0/2           1    0  Gi0/1        Up
      
      Switch# show cluster view
                                                                 |---Upstream---|
      SN   MAC Address      Name       Device Type    PortIf FEC Hops  SN PortIf  FEC
      0    00d0.5868.f180   Switch     WS-C3524-XL                0
      1    00e0.1e9f.50c0   Switch-1   WS-C2916M-XL   Fa0/1       1     0   Fa0/2
      2    00d0.5868.eb80   Switch-2   WS-C3512-XL    Gi0/2       1     0   Gi0/1
      

      Изменения, которые имеют место в файле конфигурации командного коммутатора после выполнения Шага 12 появляются здесь полужирным:

      !
      ip subnet-zero
      cluster enable engineering 0
      cluster member 1 mac-address 00e0.1e9f.50c0
      cluster member 2 Mac-address 00d0.5868.eb80
      !
      !
      !
      
      !--- Full configuration output is suppressed.
      
      
      

      Примечание: Когда кандидат в коммутаторы становится членом, в перечень MAC адресов членов коммутаторов добавляется команда конфигурации коммутатора. Кроме того, конфигурация коммутатора-участника добавляет MAC-адрес командного коммутатора.

    • Задействованный Switch-1 (нижний коммутатор, 2916MXL)

      Switch-1# show cluster
      Cluster member 1
      Cluster name: engineering
      Management ip address: 172.16.84.35
      Command device Mac address: 00d0.5868.f180
      Switch-1#

      IP-адрес управления — это IP-адрес командного коммутатора. Это определяет концепцию кластеризации, которая является управлением группы коммутаторов с использованием единого IP-адреса.

      Кроме того, если у вас есть консольное соединение к задействованному Switch-1, это сообщение появляется на консоли коммутатора - участника, как только кластер добавляет коммутатор:

      Switch#
      %CMP-CLUSTER_MEMBER_1-5-ADD: The Device is added to the cluster
      (Cluster Name: engineering, CMDR IP Address 172.16.84.35)
      Switch-1#

      Изменения, которые имеют место в файле конфигурации командного коммутатора после выполнения Шага 12 появляются здесь полужирным:

      !
      hostname Switch-1
      !
      enable password mysecret
      !
      !
      no spanning-tree vlan 1
      no ip domain-lookup
      !
      cluster commander-address 00d0.5868.f180
      
      !--- You may also see the member number and cluster name in the
      !--- above line. This depends on the version of code that you use.
      
      !
      interface VLAN1
      no ip address
      no ip route-cache
      
      !--- Full configuration output is suppressed.
      
      
      
    • Задействованный Switch-2 (превышают коммутатор, 3512XL),

      Switch-2# show cluster
      Member switch for cluster "engineering"
             Member number:                                2
             Management IP address:                        172.16.84.35
             Command switch Mac address:                   00d0.5868.f180
             Heartbeat interval:                           8
             Heartbeat hold-time:                          80
      Switch-2#

      IP-адрес управления — это IP-адрес командного коммутатора.

      Кроме того, если у вас есть консольное соединение к задействованному Switch-2, это сообщение появляется на консоли коммутатора - участника, как только кластер добавляет коммутатор:

      Switch#
      %CMP-CLUSTER_MEMBER_2-5-ADD: The Device is added to the cluster
      (Cluster Name: engineering, CMDR IP Address 172.16.84.35)
      Switch-2#

      Изменения, которые имеют место в файле конфигурации командного коммутатора после выполнения Шага 12 появляются здесь полужирным:

      !
      hostname Switch-2
      !
      enable password mysecret
      !
      !
      ip subnet-zero
      !
      cluster commander-address 00d0.5868.f180 member 2 name engineering
      
      !--- If you run an older version of code, you may not see
      !--- the member number and cluster name in the above line.
      
      !
      interface VLAN1
      no ip address
      no ip directed-broadcast
      no ip route-cache
      
      !--- Full configuration output is suppressed.
      
      

      При просмотре выходных данных от задействованного Switch-1 и задействованных конфигураций Switch-2 вы замечаете наследование коммутаторами - участниками enable password и имени хоста, добавленного со многим командным коммутатором.

      Если имя хоста не было назначено ранее на коммутатор - участника (как в данном примере), командный коммутатор добавляет уникальный задействованный номер к имени хоста командного коммутатора; когда коммутатор присоединяется к кластеру, командный коммутатор тогда назначает номер последовательно на коммутатор. Число показывает порядок, в котором коммутатор подключил кластер. В данном примере командный коммутатор имеет Коммутатор имени хоста по умолчанию. Первый коммутатор - участник (WS-C2916MXL) берет Switch-1 имени хоста. Второй коммутатор - участник (WS-C3512XL) берет Switch-2 имени хоста.

      Примечание: Если коммутатор - участник уже имеет имя хоста, коммутатор сохраняет то имя хоста, когда это присоединяется к кластеру. Если коммутатор - участник оставляет кластер, имя хоста остается.

      При соединении рядового коммутатора с кластером коммутатор наследует команду enable secret или enable password управляющего коммутатора. Это сохраняет пароль, когда это оставляет кластер также. Если вы не настроили пароль командного коммутатора, коммутатор - участник наследовал пустой пароль.

  13. Выберите Views> метки Toggle для наблюдения более подробных сведений о кластере.

    В окне выводятся дополнительные сведения:

    • MAC-адрес коммутаторов - участников

    • IP-адрес командного коммутатора

    • Номера портов и тип каналов (каналы Fast Ethernet или Gigabit Ethernet)

    Рис. 10

    /image/gif/paws/4085/61-o.gif

  14. Для наблюдения образа всех коммутаторов в кластере выберите Cluster> Go to Cluster Manager.

    Менеджер кластера появляется. Это отображает представление коммутаторов в кластерной форме:

    Рис. 1-1

    /image/gif/paws/4085/61-p.gif

    Cluster Manager можно использовать для управления и настройки изменений в кластере. Его можно использовать для контроля и настройки портов, смены управляющей VLAN и имени узла. Управление кластером и как выполнить другие задачи конфигурации с Менеджером кластера, выходит за рамки этого документа, как бы то ни было. Для этих подробных данных обратитесь к документам:

Добавьте участника в существующем кластере

В этом разделе описывается добавить коммутатор - участника к кластеру, который уже существует. В примере коммутатор Catalyst 2924MXL добавляется в кластер, как показано на рис. 10.

Выполните эти шаги для добавления другого участника в кластере с CMS:

  1. Подключите коммутатор, который вы хотите добавить к одному из портов или на команде или на коммутаторе - участнике.

    В разделе Лабораторных сценариев этого документа новый коммутатор подключает с fastethernet 0/2 интерфейс командного коммутатора. Убедитесь, что порты, которые подключают два коммутатора, принадлежат той же VLAN управления или что порты являются магистральными портами. Также в Лабораторных сценариях, все порты принадлежат VLAN1, который является VLAN управления по умолчанию.

    Примечание: Доступ ко всем средствам управления кластером через IP-адрес командного коммутатора. IP-адрес управляющего коммутатора всегда принадлежит к VLAN управления (по умолчанию VLAN1). Все коммутаторы в кластере коммутаторов должны иметь ту же VLAN управления как командный коммутатор. С программного обеспечения Cisco IOS версии 12.0(5)XP для 2900XL и 3500XL коммутаторы, можно изменить VLAN управления от по умолчанию VLAN1. Кроме того, программное обеспечение Cisco IOS версии 12.0(5)XU или позже позволяет вам изменять VLAN управления для кластера целостного коммутатора. Изменение требует одной команды, которую необходимо выполнить через веб-интерфейс CMS. Для получения дополнительной информации о том, как изменить VLAN управления, обратитесь к этим документам:

  2. В вашем браузере выберите Cluster> Cluster Management.

    Это действие открывает Cluster Builder в новом окне браузера и выводит следующий экран:

    Рисунок 12

    61-q.gif

    Можно увидеть, что в окне uggested Candidate приведен новый коммутатор (2924MXL) в качестве кандидата. Рисунок 12 также показывает, что существует новый коммутатор в синем. Новый коммутатор подключается к центральному коммутатору (командному коммутатору). Если кандидат в коммутаторы становится членом кластера, цвет изменяется на зеленый и коммутатор указывается как Switch-3.

  3. Чтобы добавить кандидата в коммутаторы к кластеру и обновить карту сети, выполните один из этих шагов:

    Рисунок 13

    /image/gif/paws/4085/61-r.gif

    Рисунок 14

    /image/gif/paws/4085/61-s.gif

  4. Выберите Views> Toggle Labels для наблюдения большего количества подробных данных о карте сети.

    Рисунок 15

    /image/gif/paws/4085/61-t.gif

    Если вы хотите проверить этот кластер, выполните эти команды на командном коммутаторе и новом коммутаторе - участнике, Switch-3:

    • Командный коммутатор (центральный коммутатор, 3524XL)

      Switch# show cluster
      Command switch for cluster "engineering"
            Total number of members:            4   
            Status:                             0 members are unreachable
            Time since last status change:      0 days, 0 hours, 7 minutes
            Redundancy:                         Disabled
            Heartbeat interval:                 8
            Heartbeat hold-time:                80
            Extended discovery hop count:       3
      
      Switch# show cluster members
                                                        |---Upstream---|
      SN  MAC Address      Name     PortIf   FEC  Hops SN PortIf FEC  State
      0   00d0.5868.f180   Switch                   0                 Up (Cmdr)
      1   00e0.1e9f.50c0   Switch-1 Fa0/1           1   0  Fa0/2      Up
      2   00d0.5868.eb80   Switch-2 Gi0/2           1   0  Gi0/1      Up
      3   00ee.1e9f.50c0   Switch-3 Fa0/1           1   0  Fa0/3      Up
      
      Switch# show cluster view
                                                               |---Upstream---|
      SN  MAC Address       Name      Device Type   PortIf  FEC Hops SN  PortIf FEC
      0   00d0.5868.f180    Switch    WS-C3524-XL                0 
      1   00e0.1e9f.50c0    Switch-1  WS-C2916M-XL  Fa0/1        1   0    Fa0/2
      2   0d0.5868.eb80     Switch-2  WS-C3512-XL   Gi0/2        1   0    Gi0/1
      3   00ee.1e9f.50c0    Switch-3  WS-C2924M-XL  Fa0/1        1   0    Fa0/3
      

      Изменения файла конфигурации командного коммутатора после этапа 4 выделены жирным шрифтом:

      !
      ip subnet-zero
      cluster enable engineering 0
      cluster member 1 Mac-address 00e0.1e9f.50c0
      cluster member 2 Mac-address 00d0.5868.eb80
      cluster member 3 Mac-address 00ee.1e9f.50c0
      !
      !
      !
      
      !--- Full configuration output is suppressed.
      
      

      Примечание: Когда кандидат в коммутаторы становится членом, в перечень MAC адресов членов коммутаторов добавляется команда конфигурации коммутатора. Кроме того, конфигурация коммутатора-участника добавляет MAC-адрес командного коммутатора.

    • Задействованный Switch-3 (2924MXL)

      Switch-3# show cluster
      Member switch for cluster "engineering"
         Member number:     3
         Management IP address:     172.16.84.35
         Command switch Mac address:     00d0.5868.f180
         Heartbeat interval:     8
         Heartbeat hold-time:     80
      Switch-3#
      

      IP-адрес управления — это IP-адрес командного коммутатора.

      Изменения файла конфигурации командного коммутатора после этапа 4 выделены жирным шрифтом:

      !
      hostname Switch-3
      !
      enable password mysecret
      !
      !
      ip subnet-zero
      !
      cluster commander-address 00d0.5868.f180 member 3 name engineering
      !
      interface VLAN1
      no ip address
      no ip directed-broadcast
      no ip route-cache
      
      !--- Full configuration output is suppressed.
      
      
  5. Выберите Cluster> Go to Cluster Manager.

    Менеджер кластера появляется, как вы видите на рисунке 16. Это представление обновлено от рисунка 11 и показывает новый добавленный коммутатор (2924MXL) в списке:

    Рисунок 16

    61-u.gif

команды "debug" и "show"

Пример выходных данных команды show

show cluster и show cluster members

Чтобы проверить статус кластера и его членов, используйте команды show cluster и show cluster members.

  • Командный коммутатор (центральный коммутатор, 3524XL)

    Switch# show cluster
    Command switch for cluster "engineering"
            Total number of members:        4
            Status:                         0 members are unreachable
            Time since last status change:  0 days, 0 hours, 7 minutes
            Redundancy:                     Disabled
            Heartbeat interval:             8
            Heartbeat hold-time:            80
            Extended discovery hop count:   3
    
    
    Switch# show cluster members 
                                                    |---Upstream---|
    SN MAC Address    Name         PortIf FEC Hops   SN PortIf  FEC  State
    0  00d0.5868.f180 Switch                   0                    Up   (Cmdr)
    1  00e0.1e9f.50c0 Switch-1     Fa0/1       1     0  Fa0/2       Up  
    2  00d0.5868.eb80 Switch-2     Gi0/2       1     0  Gi0/1       Up
    3  00ee.1e9f.50c0 Switch-3     Fa0/1       1     0  Fa0/3       Up
    
    

    Если один из коммутаторов - участников теряет подключение командному коммутатору, выходные данные команд show cluster и show cluster members отражают потерю.

    Например, если задействованный Switch-2 теряет подключение командному коммутатору, выходные данные этих команд:

    Switch# show cluster       
    Command switch for cluster "engineering"
            Total number of members:        4
            Status:                         1 members are unreachable
            Time since last status change:  0 days, 0 hours, 0 minutes
            Redundancy:                     Disabled
            Heartbeat interval:             8
            Heartbeat hold-time:            80
            Extended discovery hop count:   3
    Switch#
    
    Switch# show cluster member
                                                    |---Upstream---|
    SN MAC Address    Name         PortIf FEC Hops   SN PortIf  FEC  State
    0  00d0.5868.f180 Switch                   0                    Up   (Cmdr)
    1  00e0.1e9f.50c0 Switch-1     Fa0/1       1     0  Fa0/2       Up  
    2  00d0.5868.eb80 Switch-2                 1                    Down
    3  00ee.1e9f.50c0 Switch-3     Fa0/1       1     0  Fa0/3       Up
    
    

    Примечание: Результаты изменений, выполненных с помощью данных команд, отображаются не сразу. Командный коммутатор должен ждать определенный интервал (Время удержания биения), прежде чем командный коммутатор объявит коммутатор - участника вниз. По умолчанию время удержания периодических контрольных сообщений составляет 80 секунд. Это - параметр с изменяемой конфигурацией. Можно изменить параметр, выполнив команду cluster holdtime 1-300 в режиме глобальной конфигурации.

  • Задействованный Switch-1 (2916MXL)

    Switch-1# show cluster
    Cluster member 1
    Cluster name: engineering
    Management ip address: 172.16.84.35
    Command device Mac address: 00d0.5868.f180
    Switch-1#
  • Задействованный Switch-2 (превышают коммутатор, 3512XL),

    Switch-2# show cluster 
    Member switch for cluster "engineering"
            Member number:                  2
            Management IP address:          172.16.84.35
            Command switch Mac address:     00d0.5868.f180
            Heartbeat interval:             8
            Heartbeat hold-time:            80
    Switch-2#
  • Задействованный Switch-3 (2924MXL)

    Switch-3# show cluster
    Member switch for cluster "engineering"
            Member number:                  3
            Management IP address:          172.16.84.35
            Command switch Mac address:     00d0.5868.f180
            Heartbeat interval:             8
            Heartbeat hold-time:            80
    Switch-3#

команды show cdp neighbors и show cdp neighbors

Как обсуждено в разделе Характеристик Кандидата в коммутаторы и Коммутатора - участника этого документа, все коммутаторы, включая командный коммутатор, используют CDPv2 для обнаружения соседей CDP. Коммутаторы хранят эти данные в соответствующем кэше окружения CDP. Когда командный коммутатор получает сведения, коммутатор фильтрует кэши соседей CDP и создает список кандидатов в коммутаторы.

При помощи команд show cdp neighbors и show cdp neighbors detail можно проверить, находятся ли коммутаторы в соседской кэш-памяти протокола CDP и что все коммутаторы используют протокол CDP версии 2.

  • Командный коммутатор (3524XL)

    Switch# show cdp neighbors
    Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
                      S - Switch, H - Host, I - IGMP, r - Repeater
    
    Device ID        Local Intrfce     Holdtme    Capability  Platform  Port ID
    Switch-3         Fas 0/3            162         T S       WS-C2924M-Fas 0/1
    Switch-2         Gig 0/1            121         T S       WS-C3512-XGig 0/2
    Switch-1         Fas 0/2            136          S        WS-C2916M-Fas 0/1
    
    
    Switch# show cdp neighbors detail
    -------------------------
    Device ID: Switch-3
    Entry address(es):
    Platform: cisco WS-C2924M-XL, Capabilities: Trans-Bridge Switch
    Interface: FastEthernet0/3, Port ID (outgoing port): FastEthernet0/1
    Holdtime : 132 sec
    
    !--- Output suppressed.
    
    
    advertisement version: 2
    Protocol Hello: OUI=0x00000C, Protocol ID=0x0112; payload len=25,
    value=0AA050C000000003010103FF00D05868F18000EE1E9F50C001
    VTP Management Domain: ''
    
    -------------------------
    Device ID: Switch-2
    Entry address(Es):
          IP address: 0.0.0.0
          IP address: 172.16.84.35
    Platform: cisco WS-C3512-XL, Capabilities: Trans-Bridge Switch
    Interface: GigabitEthernet0/1, Port ID (outgoing port): GigabitEthernet0/2
    Holdtime : 141 sec
    
    !--- Output suppressed.
    
    
    advertisement version: 2
    Protocol Hello: OUI=0x00000C, Protocol ID=0x0112; payload Len=27,
    value=0A68EB8000000002010123FF00D05868F18000D05868EB80010001
    VTP Management Domain: ''
    Duplex: full
    
    -------------------------
    Device ID: Switch-1
    Entry address(Es):
          IP address: 172.16.84.35
    Platform: cisco WS-C2916M-XL, Capabilities: Switch
    Interface: FastEthernet0/2, Port ID (outgoing port): FastEthernet0/1
    Holdtime : 140 sec
    
    !--- Output suppressed.
    
    
    advertisement version: 2
    Protocol Hello: OUI=0x00000C, Protocol ID=0x0112; payload Len=25,
    value=0A9F50C000000001010103FF00D05868F18000E01E9F50C001
    VTP Management Domain: ''
    
  • Задействованный Switch-1 (2916MXL)

    Switch-1# show cdp neighbors 
    Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
                      S - Switch, H - Host, I - IGMP, r - Repeater
    
    Device ID        Local Intrfce     Holdtme    Capability  Platform  Port ID
    Switch           Fas 0/1           139         T S       WS-C3524-XFas 0/2
    
    Switch-1# show cdp neighbors detail
    -------------------------
    Device ID: Switch
    Entry address(Es):
          IP address: 172.16.84.35
          IP address: 172.16.84.35
    Platform: cisco WS-C3524-XL, Capabilities: Trans-Bridge Switch
    Interface: FastEthernet0/1, Port ID (outgoing port): FastEthernet0/2
    Holdtime : 147 sec
    
    !--- Output suppressed.
    
    
    advertisement version: 2
    Protocol Hello:  OUI=0x00000C, Protocol ID=0x0112; payload Len=27,
    value=0A68F18000000000010123FF00D05868F18000D05868F180000001
    VTP Management Domain: ''
    
  • Задействованный Switch-2 (3512XL)

    Switch-2# show cdp neighbors 
    Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
                      S - Switch, H - Host, I - IGMP, r - Repeater
    
    Device ID        Local Intrfce     Holdtme    Capability  Platform  Port ID
    Switch           Gig 0/2            147         T S       WS-C3524-XGig 0/1
    
    
    Switch-2# show cdp neighbors detail
    -------------------------
    Device ID: Switch
    Entry address(Es):
          IP address: 172.16.84.35
          IP address: 172.16.84.35
    Platform: cisco WS-C3524-XL, Capabilities: Trans-Bridge Switch
    Interface: GigabitEthernet0/2, Port ID (outgoing port): GigabitEthernet0/1
    Holdtime : 141 sec
    
    
    !--- Output suppressed.
    
    advertisement version: 2 
    Protocol Hello: OUI=0x00000C, Protocol ID=0x0112; payload Len=27, 
    value=0A68F18000000000010123FF00D05868F18000D05868F180000001 
    VTP Management Domain: '' Duplex: full 
  • Задействованный Switch-3 (2924MXL)

    Switch-3# show cdp neighbors 
    Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
                      S - Switch, H - Host, I - IGMP, r - Repeater
    
    Device ID        Local Intrfce     Holdtme    Capability  Platform  Port ID
    Switch           Fas 0/1            125         T S       WS-C3524-XFas 0/3
    
    
    Switch-3# show cdp neighbors detail
    -------------------------
    Device ID: Switch
    Entry address(Es):
          IP address: 172.16.84.35
          IP address: 172.16.84.35
    Platform: cisco WS-C3524-XL, Capabilities: Trans-Bridge Switch
    Interface: FastEthernet0/1, Port ID (outgoing port): FastEthernet0/3
    Holdtime : 179 sec
    
    !--- Output suppressed.
    
    
    advertisement version: 2
    Protocol Hello: OUI=0x00000C, Protocol ID=0x0112; payload Len=27,
    value=0A68F18000000000010123FF00D05868F18000D05868F180000001
    VTP Management Domain: ''
    

Примечание: Если вы не видите версию объявления: 2 в выходных данных команды show cdp neighbors detail для коммутатора, тот коммутатор не может стать коммутатором - участником.

Пример выходных данных команды debug

Данный раздел описывает команды отладки, которые проверяют активность кластера. Здесь, команды проверяют активность кластера между командным коммутатором (3524XL) и задействованным Switch-2 (3512XL). Можно воспользоваться этими же командами отладки для проверки активности кластера между командным коммутатором и любыми другим коммутаторами-участниками.

Примечание: При добавлении или удалении члена кластера при помощи Web-интерфейса отображается следующая информация из системного журнала:

%CMP-CLUSTER_MEMBER_2-5-REMOVE:
The Device is removed from the cluster (Cluster Name: engineering)

%CMP-CLUSTER_MEMBER_2-5-ADD:
The Device is added to the cluster(Cluster Name: engineering, 
CMDR IP Address 172.16.84.35)

"debug cluster member", "debug cluster neighbors" и "debug cluster events"

Первые две отладочные команды в этих примерах, debug cluster member и debug cluster neighbors, показывают обновления для соседей кластера, исходящие от управляющего коммутатора или рядового коммутатора. Третья команда отладки, debug cluster events, показывает входящий соседний hellos. Между командами комментарии синего цвета улучшают видимость определенных выходных данных. Кроме того, этот показ подавляет ненужную информацию от завершенных выходных данных отладки.

  • Командный коммутатор (3524XL)

    Switch# debug cluster members 
    Cluster members debugging is on
    Switch#
    23:21:47: Sending neighbor update...
    23:21:47: 
    Cluster Member: 00, active.
    
    !--- Member 00 means commander switch.
    
    23:21:47:       Unanswered heartbeats: 1
    23:21:47:       Hops to commander:     0
    23:21:47:       Assigned CMP address:  10.104.241.128
    
    !--- This is the commander CMP address.
    
    23:21:47:       Cmdr IP address:       172.16.84.35   
    23:21:47:       Cmdr CMP address:      10.104.241.128
    
    !--- This is the commander CMP address.
    
    23:21:47:       Auto update counter:   0
    23:21:47:       Cmdr MAC address:      00d0.5868.f180
    23:21:47:       Mbr  MAC address:      00d0.5868.f180
    23:21:47:       Command Port ID:       
    23:21:47:       Platform Name:         cisco WS-C3524-XL
    23:21:47:       Host Name:             Switch
    
    Switch# debug cluster neighbors
    Cluster neighbors debugging is on
    Switch#
    23:51:50:           Neighbor update from member 0
    
    !--- This is an update from the commander.
    
    23:51:50:           3 Cluster neighbors:
    
    !--- Information about member Switch-2 starts here.
    
    23:51:50:           00d0.5868.eb80 connected to Member 0 
                        on port GigabitEthernet0/2
    23:51:50:           Port Macaddr: 00d0.5868.eb8e
    23:51:50:           Hostname: Switch-2
    23:51:50:           Port ID: GigabitEthernet0/2
    23:51:50:           Neighbor FEC: 255
    23:51:50:           Member FEC: 255
    23:51:50:           Capabilities: 0A
    23:51:50:           Link Qualification: 0
    23:51:50:           Qualification Note: 21
    23:51:50:           Member 2 of stack with commander 0.104.187.140
    23:51:50:           CMP address: 10.104.235.128
    23:51:50:           Hops to Commander: 1
    23:51:50:           Management vlan: 1
    
    !--- Information about member Switch-2 ends here.
    
    
    
    !--- Information about member Switch-1 starts here.
    
    23:51:50:      00e0.1e9f.50c0 connected to Member 0 on port FastEthernet0/2
    23:51:50:      Port Macaddr: 00e0.1e9f.50c1
    23:51:50:      Hostname: Switch-1
    23:51:50:      Port ID: FastEthernet0/1
    23:51:50:      Neighbor FEC: 255
    23:51:50:      Member FEC: 255
    23:51:50:      Capabilities: 08
    23:51:50:      Link Qualification: 3
    23:51:50:      Qualification Note: 01
    23:51:50:      Member 1 of stack with commander 0.77.44.124
    23:51:50:      CMP address: 10.159.80.192
    23:51:50:      Hops to Commander: 1
    23:51:50:      Management vlan: 0
    
    !--- Information about member Switch-1 ends here.
    
    
    
    !--- Information about member Switch-3 starts here.
    
    23:51:50:       00ee.1e9f.50c0 connected to Member 0 on port FastEthernet0/3
    23:51:50:       Port Macaddr: 00ee.1e9f.50c1
    23:51:50:       Hostname: Switch-3
    23:51:50:       Port ID: FastEthernet0/1
    23:51:50:       Neighbor FEC: 255
    23:51:50:       Member FEC: 255
    23:51:50:       Capabilities: 0A
    23:51:50:       Link Qualification: 3
    23:51:50:       Qualification Note: 00
    23:51:50:       Member 3 of stack with commander 0.77.184.56
    23:51:50:       CMP address: 10.160.80.192
    23:51:50:       Hops to Commander: 1
    23:51:50:       Management vlan: 1
    
    !--- Information about member Switch-3 ends here.
    
    
    !--- The information that follows is from Switch-2, as seen on 
    !--- the command switch.
    !--- You can see the same information if you issue the
    !--- debug cluster events command on certain versions 
    !--- of codes.
    
    Cluster neighbor's Protocol Hello payload:
    23:52:00:           Sender Version: 1, Works with version 1 and later
    23:52:00:           Flags: 23, Number of hops to the commander: 1
    23:52:00:           Cluster member number: 2
    23:52:00:           Cluster Cmdr Mac Address: 00d0.5868.f180
    23:52:00:           Sender Mac address: 00d0.5868.eb80
    
    !--- This is the Switch-2 MAC address.
    
    
    23:52:00:           Sender CMP address: 10.104.235.128
    
    !--- This is the Switch-2 CMP address.
    
    23:52:00:           Upstream switch No: 0.0.0.0
    23:52:00:           FEC Number: 255
    23:52:00:           Management vlan: 1
    
    !--- Output suppressed.
    
    
  • Задействованный Switch-2 (3512XL)

    Switch-2# debug cluster member
    Cluster members debugging is on
    Switch-2#
    23:22:51:     Sending neighbor update...
    23:22:51:     Switch 00d0.5868.f180 connected on port GigabitEthernet0/2
    
    !--- This is the command switch MAC address local port.
    
    23:22:51:     Port ID: GigabitEthernet0/2
    23:22:51:     Capabilities: 0A
    23:22:51:     Link Qualification: 5
    23:22:51:     Qualification Note: 20
    23:22:51:     Member 0 of stack with commander 00d0.5868.f180
    23:22:51:     CMP address: 10.104.241.128
    
    !--- This is the commander CMP address.
    
    23:22:51:     Hops to Commander: 0
    23:22:51:     Management vlan: 1*
    23:22:51:
    
    !--- Up to this point, the information is about the command switch.
    !--- The output that follows is the local switch information that goes to the 
    !--- neighbor (command) switch.
    
    Cluster Member: 02, active.
    23:22:51:    Unanswered heartbeats: 1
    23:22:51:    Hops to commander: 1
    23:22:51:    Assigned CMP address: 10.104.235.128
    23:22:51:    Cmdr IP address: 172.16.84.35
    23:22:51:    Cmdr CMP address: 10.104.241.128
    23:22:51:    Auto update counter: 0
    23:22:51:    Cmdr MAC address: 00d0.5868.f180
    23:22:51:    Mbr MAC address: 00d0.5868.eb80
    23:22:51:    Command Port ID: GigabitEthernet0/2
    
    !--- This is the port that connects to the commander.
    
    23:22:51:    Platform Name: cisco WS-C3512-XL
    23:22:51:    Host Name: Switch-2
    Switch-2#
    
    Switch-2# debug cluster neighbors
    Cluster neighbors debugging is on
    Switch-2#
    23:59:32: cmi_setCommandPort: setting ups mbr num to 0
    23:59:32: cmp_sendNeighborsToCmdr: skip neighbor 00d0.5868.f180
    Switch-2#
    23:59:42:
    
    !--- Information that follows is from the command switch.
    !--- You can see the same information if you issue the
    !--- debug cluster events command on certain versions 
    !--- of codes.
    
    Cluster neighbor's Protocol Hello payload:
    23:59:42:    Sender Version: 1, Works with version 1 and later
    23:59:42:    Flags: 23, Number of hops to the commander: 0
    23:59:42:    Cluster member number: 0
    23:59:42:    Cluster Cmdr Mac Address: 00d0.5868.f180
    23:59:42:    Sender Mac address: 00d0.5868.f180
    
    !--- This is the commander MAC address.
    
    23:59:42:    Sender CMP Address: 10.104.241.128
    
    !--- This is the commander CMP address.
    
    23:59:42:    Upstream switch No: 0.0.0.0
    23:59:42:    FEC Number: 255
    23:59:42:    Management vlan: 1

отладка кластера ip

Поле CMP Address появляется в результатах выполнения команды debug. Как Раздел протокола Управления кластером объясняет, командующий и коммутаторы - участники связываются с использованием этих адресов CMP.

При просмотре выходных данных в участнике debug cluster, соседних узлах debug cluster и разделе debug cluster events, вы видите, что адреса CMP коммутаторов в данном примере:

  • Адрес CMP командующего: 10.104.241.128

  • Задействованный адрес CMP Switch-1: 10.159.80.192

  • Задействованный адрес CMP Switch-2: 10.104.235.128

  • Задействованный адрес CMP Switch-3: 10.160.80.192

Как Раздел протокола Управления кластером обсуждает, CMP состоит из трех ключевых частей технологии. Один из них является механизмом CMP/RARP. CMP/RARP также добавляет и удаляет коммутаторы из кластера. Описанные ниже выходные данные отладки отображают журнал сообщений CMP/RARP по добавлению участника к кластеру.

Примечание:  Для согласованности с командами члена кластера отладки, соседей кластера отладки и раздела событий кластера отладки выполните команду debug cluster ip на главном коммутаторе (3524XL) и добавьте к нему второй (Switch-2, 3512XL).

  • Командующий Свич (3524XL) (Switch-2 добавления члена)

    Switch# debug cluster ip
    Cluster IP/transport debugging is on
    Switch#
    
    
    !--- The command switch generates the new CMP address.
    
    1d08h: cmdr_generate_cluster_ip_address: generated cluster,
    ip addr 10.104.235.128 for Mac 00d0.5868.eb80
    
    
    !--- The commander allocates the CMP address to member Switch-2.
    
    1d08h: cmdr_generate_and_assign_ip_address:
    setting addr for member 2 addr 10.104.235.128
    
    1d08h: cmdr_generate_and_assign_ip_address:
    adding static ARP for 10.104.235.128
    1d08h: cluster_send_rarp_reply:
    Sending reply out on Virtual1 to member 2
    1d08h: cmdr_process_rarp_request: received RARP req :
    1d08h: proto type : 0000
    1d08h: source Mac : 00d0.5868.eb80
    
    !--- This is the member MAC Address.
    
    1d08h: source ip : 10.104.235.128
    
    !--- This is the member CMP Address.
    
    1d08h: target Mac : 00d0.5868.f180
    
    !--- This is the commander MAC Address.
    
    1d08h: target ip : 10.104.241.128
    
    !--- This is the commander CMP Address.
    
    1d08h: cmdr_process_rarp_request: rcvd ACK for the bootstrap req
    
  • Задействованный Switch-2 (3512XL) (который командующий добавляет),

    Switch# debug cluster ip
    Cluster IP/transport debugging is on
    Switch#
    
    
    !--- The member switch receives information from the command switch.
    
    00:01:24: cluster_process_rarp_reply: received RARP reply :
    00:01:24: source Mac : 00d0.5868.f180
    
    !--- This is the commander MAC Address.
    
    00:01:24: source ip : 10.104.241.128
    
    !--- This is the commander CMP Address.
    
    00:01:24: target Mac : 00d0.5868.eb80
    
    !--- This is the member MAC Address.
    
    00:01:24: target ip : 10.104.235.128
    
    !--- This is the member CMP Address.
    !--- The member switch extracts and implements the cluster information.
    
    00:01:24: cluster_process_rarp_reply:
    setting commander's MAC address: 00d0.5868.f180
    00:01:24: create_cluster_idb: creating HWIDB(0x0) for the cluster
    00:01:24: cluster_create_member_idb:
    creating cluster-idb 4D4378, cmp-addr: 10.104.235.128
    00:01:24: Authorizing the password string:
    00:01:24: cluster_send_rarp_request: Sending request out to cmdr
    00:01:24: cluster_process_rarp_reply:
    created hwidb and set IP address (10.104.235.128)
    00:01:24: cluster_process_rarp_reply:
    setting commander's addr (10.104.241.128) info
    00:01:24: cluster_process_rarp_reply:
    setting static ARP for cmdr addr 10.104.241.128
    00:01:24: cluster_set_default_gateway:
    setting default gw to cmdr's addr (10.104.241.128)
    00:01:24: setting hostname to Switch-2
    00:01:24: setting password to enable password 0 mysecret
    00:01:24: cluster_pick_defaultidb: picking cluster IDB to be default IDB
    00:01:24: This switch is added to the cluster
    00:01:24: Cluster Name : engineering ; Cmdr IP address: 172.16.84.35
    00:01:24: CMP address: 10.104.235.128 ; Cmdr CMP address: 10.104.241.128
    
    !--- At this point, the switch has been added to the cluster.
    
    00:01:24: %CMP-CLUSTER_MEMBER_2-5-ADD: The Device is added to the cluster
    (Cluster Name: engineering, CMDR IP Address 172.16.84.35)
    00:01:24: cluster_process_rarp_reply: bootstrap for the firsttime, start member
    00:01:24: cluster_process_rarp_reply: setting netsareup to TRUE
    

Использование rcommand для удаленного администрирования CLI

Эта последняя часть анализа отладки объясняет, как работает CMP/IP. Как Раздел протокола Управления кластером этого документа обсуждает, CMP/IP является механизмом переноса для обмена используемыми для управления пакет между командным коммутатором и коммутаторами - участниками.

Одним примером является использование rcommand, который является фактически сеансом Telnet от командного коммутатора до коммутатора - участника. Это использует те же действительные адреса CMP.

  1. Установите сеанс Telnet к командному коммутатору.

  2. От CLI на командном коммутаторе выполните rcommand для получения до CLI любого из коммутаторов - участников.

    Rcommand применяется в тех случаях, когда нужно устранить неполадки или внести изменения в конфигурацию на коммутаторе-участнике с использованием CLI.

    Данный пример демонстрирует использование:

    Switch# rcommand 2
    
    !--- This accesses member Switch-2.
    
    Trying ... Open
    
    Switch-2#
    
    !--- Here, you establish a Telnet session with member Switch-2.
    
    Switch-2# exit
    
    !--- Use this command to end the Telnet session.
    
    
    [Connection closed by foreign host]
    Switch#
    

Если команда debug ip packet поддерживается на рядовом коммутаторе, при подаче этой команды с управляющего коммутатора на рядовой коммутатор на консоли рядового коммутатора будут отображаться следующие сообщения:

01:13:06: IP: s=10.104.241.128 (Virtual1), d=10.104.235.128, Len 44, rcvd 1

!--- This is a received request from the command switch.


01:13:06: IP: s=10.104.235.128 (local), d=10.104.241.128 (Virtual1), Len 44, sending

!--- A reply returns to the command switch.


Примечание: Чтобы отобразить эти выходные данные на коммутаторе-участнике, необходимо сначала установить прямое подключение консоли к этому коммутатору. После того, как вы устанавливаете соединение, выполняете команду debug ip packet и затем открываете сеанс rcommand от командного коммутатора.

Приложение

Типовые конфигурации кластеров

Этот раздел перечисляет конфигурации полной выборки всех коммутаторов, которые использовали Лабораторные сценарии. Подробное описание процесса конфигурации представлено в разделах Кластеры создания и набор программ управления кластером и Добавление элемента в существующий кластер.

Командный маршрутизатор

Switch# show running-config
Building configuration...
Current configuration:
!
version 12.0
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Switch
!
enable password mysecret
!
!
!
!
!
!
ip subnet-zero
cluster enable engineering 0
cluster member 1 Mac-address 00e0.1e9f.50c0
cluster member 2 Mac-address 00d0.5868.eb80
cluster member 3 Mac-address 00ee.1e9f.50c0
!
!
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface VLAN1
ip address 172.16.84.35 255.255.255.0
no ip directed-broadcast
ip Nat outside
!
ip default-gateway 172.16.84.1
ip Nat inside source list 199 interface VLAN1 overload
access-list 199 dynamic Cluster-NAT permit ip any any
!
line con 0
transport input none
stopbits 1
line vty 0 4
login
line vty 5 15
login
!
end

Задействованный Switch-1

Switch-1# show running-config
Building configuration...
Current configuration:
!
version 11.2
no service pad
no service udp-small-servers
no service tcp-small-servers
!
hostname Switch-1
!
enable password mysecret
!
!
no spanning-tree vlan 1
no ip domain-lookup
!
cluster commander-address 00d0.5868.f180
!
interface VLAN1
no ip address
no ip route-cache
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
!
line con 0
stopbits 1
line vty 0 4
login
line vty 5 15
login
!
end

Задействованный Switch-2

Switch-2# show running-config
Building configuration...
Current configuration:
!
version 12.0
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Switch-2
!
enable password mysecret
!
!
!
!
!
!
ip subnet-zero
!
cluster commander-address 00d0.5868.f180 member 2 name engineering
!
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface VLAN1
no ip address
no ip directed-broadcast
no ip route-cache
!
!
line con 0
transport input none
stopbits 1
line vty 0 4
login
line vty 5 15
login
!
end

Задействованный Switch-3

Switch-3# show running-config
Building configuration...
Current configuration:
!
version 12.0
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Switch-3
!
enable password mysecret
!
!
!
!
!
!
ip subnet-zero
!
cluster commander-address 00d0.5868.f180 member 3 name engineering
!
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet1/1
!
interface VLAN1
no ip directed-broadcast
no ip route-cache
!
!
!
line con 0
transport input none
stopbits 1
line vty 5 15
!
end

Дополнительные сведения

Для получения информации о том, как использовать CMS после начальной конфигурации, обратитесь к руководству по конфигурации программного обеспечения для вашего коммутатора:


Дополнительные сведения


Document ID: 4085