Голосовая связь : H.323

Проектирование и внедрение VoIP через ISDN

20 октября 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (19 декабря 2015) | Отзыв


Содержание


Введение

Передача голоса по IP (VoIP) по Цифровой сети связи с комплексными услугами (ISDN) (ISDN) иногда является предпочтительной комбинацией, особенно в корпоративных сетях с помощью IP-телефонии. Функции, требуемые предоставить необходимое качество обслуживания (QoS) для VoIP, Организации очереди с малой задержкой (LLQ), Взвешенной организации очереди на основе классов (CBWFQ), и Фрагментации и чередования данных в канале (LFI), поддерживаются для ISDN, и комбинация работает. Однако существуют значительные вопросы проектирования для принятия во внимание. Этот документ обсуждает предупреждения и ограничения, вовлеченные в использование их, VoIP отнесся Характеристики QoS с ISDN и предоставляет некоторые протестированные примеры конфигурации.

Предварительные условия

Требования

Компания Cisco рекомендует предварительно ознакомиться со следующими предметами:

  • ISDN

  • Point-to-Point Protocol (PPP)

  • Multilink PPP (MLPPP)

  • LFI

  • LLQ

  • CBWFQ

  • Сжатый протокол реального времени RTP

Этот документ не предоставляет обучение технологии на этих предметах, а скорее пояснении того, как эти технологии сотрудничают в Сети VoIP. Посмотрите раздел "Дополнительных сведений" для получения дополнительной информации об этих предметах.

Используемые компоненты

Сведения, содержащиеся в данном документе, касаются следующих версий программного обеспечения и оборудования:

  • Cisco выпуск ПО IOS� 12.2

  • Программное обеспечение Cisco IOS версии 12.2(2)T к 12.2 (10) T

  • Программное обеспечение Cisco IOS версии 12.2 (12) T и позже

Эти проектные решения представлены в этом документе и были протестированы с Cisco IOS Software Release, на которые обращают внимание:

Тестирование было выполнено с помощью следующего оборудования. Эти маршрутизаторы были связаны непосредственно через ISDN. Pagent использовался, чтобы моделировать трафик RTP и превысить намеченную сумму соединения.

  • Маршрутизатор Cisco 7200 с интерфейсом PRI

  • Маршрутизатор Cisco 2600 с интерфейсом BRI

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в этом документе, были запущены с чистой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд до их использования.

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Условные обозначения технических терминов Cisco.

Проблемы проектирования

Существует три проблемы, которые требуют специальных вопросов, когда вы разрабатываете VoIP по сетям ISDN. Они описаны кратко в этой таблице и затем подробно остановлены.

Проблема Описание
Переменная пропускная способность Пропускная способность соединения ISDN варьируется, поскольку B-каналы добавлены или отброшены.
Пакетное переупорядочение вызвано LFI Когда пакеты RTP чередованы, они могут поступить не в порядке, когда передано через множественные B-каналы.
Ограничения управления контролем доступа (CAC) Сisco CallManager Сisco CallManager основанный на местоположении CAC в настоящее время не является знающей топологией.

Переменная пропускная способность

ISDN позволяет B-каналам быть добавленными или отброшенными в ответ на спрос на пропускную способность. Факт, что пропускная способность ссылки варьируется в течение долгого времени, представляет собой специальную проблему к CBWFQ и механизмам организации очередей LLQ Cisco IOS. До программного обеспечения Cisco IOS версии 12.2(2)T policy-map, который внедрил LLQ или CBWFQ, можно было только назначить фиксированный размер пропускной способности. По умолчанию назначенная пропускная способность может только использовать 75% доступной пропускной способности. На интерфейсе ISDN, CBWFQ и LLQ предполагает, что только 64 кбит/с доступны, даже при том, что интерфейс имеет потенциал для обеспечения 1.544 или 2.408 Мбит/с пропускной способности. Поэтому только 75% 64 кбит/с или 48 кбит/с, могут быть выделены policy-map на любом интерфейсе ISDN. Это ограничивает количество вызовов VoIP, которые можно нести. Если больше пропускной способности выделено, то сообщение об ошибках генерируется, когда policy-map применен к интерфейсу ISDN.

Рассмотрите это использование policy-map как пример:

Команда policy-map
policy-map isdn-qos
  class VoIP-RTP
  priority 64
  class VoIP-Sig
  bandwidth 10

Когда это применено к интерфейсу BRI, команда policy-map отклонена, потому что зарезервированы больше чем 75% одного B-канала (48 кбит/с):

Команда service-policy output

!--- Note the highlighted error message when the policy 
!--- is applied to the dialer interface
.

router(config)# interface dialer 0
  router(config-if)# service-policy output isdn-qos
  I/f Dialer0 class VoIP-RTP requested bandwidth 64 (kbps) Available only 47 (kbps)

Решение этой проблемы было представлено в программном обеспечении Cisco IOS версии 12.2(2)T. С этого выпуска возможно резервировать процент полосы пропускания, доступный вместо абсолютной ширины полосы пропускания. Для резервирования 64 кбит/с для RTP и 8 кбит/с для сигнализации на интерфейсе BRI с двумя B-каналами, что общие 128 кбит/с и один Канал D 8 кбит/с, стратегия обслуживания:

Команда policy-map
policy-map isdn-qos
  class VoIP-RTP
  priority percent 50
  class VoIP-SIG
  bandwidth 8

В результате существует 32 кбит/с, доступные для RTP, когда первый B-канал подходит, и 64 кбит/с, доступные, когда подходит второй канал. Кроме того, Cisco IOS никогда не удаляет стратегию обслуживания из интерфейса из-за превышения подписки, так как никогда не может происходить превышение подписки.

Пакетное переупорядочение, вызванное LFI

При выполнении VoIP по ISDN MLPPP используется для LFI. LFI делит большие пакеты данных на меньшие фрагменты и передает их параллельно через все B-каналы в связке (bundle). В то же время голосовые пакеты чередованы промежуточные, фрагменты и их задержка уменьшены. Чередующиеся пакеты не подвергаются инкапсуляции MLPPP, они инкапсулируются как стандартные пакеты PPP. Поэтому они не имеют никаких порядковых номеров MLPPP и не могут быть переупорядочены, должен они поступать не в порядке. Возможность для переупорядочения является real. Глубина различных очередей ссылки в связке (bundle) может отличаться, который заставляет пакеты RTP настигать друг друга в результате различия в задержке в очереди. Различные B-каналы могут также взять другие пути через сеть ISDN и закончиться с другими задержками передачи.

Обычно это переупорядочение пакетов не является проблемой пакетов RTP. Минимизирующие изменении задержки прихода пакетов буфер на VoIP - устройствах получения переупорядочивают пакеты на основе порядковых номеров RTP. Если cRTP используется, Однако переупорядочение действительно становится проблемой. Алгоритм cRTP предполагает, что пакеты RTP сжаты и распакованы в том же заказе. Если они переупорядочены, то распаковка не происходит правильно. Если существует несколько B-каналов в связке (bundle) MLPPP, не в настоящее время безопасно использовать cRTP. То же ограничение просит MLPPP OVER ATM или Frame Relay. В этом случае, если существует несколько виртуальных каналов (VC) в связке (bundle), cRTP не возможен.

Решение проблемы переупорядочения предлагается протоколом PPP мультикласса (MCMP). MCMP дает чередующимся пакетам маленький заголовок с порядковым номером. Это позволяет чередующимся пакетам быть переупорядоченными дальним концом связки (bundle), прежде чем распаковка данных cRTP будет иметь место. Поддержка MCMP ожидается в программном обеспечении Cisco IOS версии 12.2 (12) T. См. RFC 2686 и идентификатор ошибки Cisco CSCdv46666 (только зарегистрированные клиенты) для получения дополнительной информации.

Ограничения CAC Сisco CallManager

Корпоративные клиенты с branch network часто используют ISDN для резервного копирования данных. Когда IP-телефония развернута, клиентам нравится использовать ссылку резервного ISDN для голоса, а также данные. Эта конфигурация возможна, но существуют некоторые предупреждения наблюдать.

IP-телефония в branch network, как правило, основана на модели централизованной обработки вызовов и использует основанный на местоположении CAC для ограничения количества вызовов через глобальную сеть (WAN). Основанный на местоположении CAC в настоящее время не имеет никакого механизма для отслеживания изменений топологии в сети. Сisco CallManager не знает, если основное соединение к ответвлению выключается, и резервный ISDN активирует. Поэтому важно, что ссылка резервного ISDN поддерживает то же количество вызовов VoIP как основное соединение. В противном случае CAC мог превысить намеченную сумму резервного соединения.

Реальная пропускная способность основного соединения и резервного соединения не должна быть идентичной. Ссылки просто должны быть в состоянии нести то же количество вызовов VoIP. Например, в то время как основное соединение не делает, резервное соединение может использовать cRTP. В этом случае меньше пропускной способности требуется на резервном соединении нести то же количество вызовов как основное соединение.

Проектные решения

Существуют разнообразные широкие возможности проектирования, доступные проектировщику сети на основе используемого Cisco IOS Software Release. Эти параметры следующие:

Обсуждение каждой опции придерживается включая примеры конфигурации, перечисленные здесь.

Речь и данные, Сосуществующая на Одиночном B-канале С или Без cRTP

В программном обеспечении Cisco IOS версии 12.2 пропускная способность в policy-map может только быть задана как фиксированный размер максимум по умолчанию до 75% пропускной способности соединения. Кроме того, ISDN, как всегда предполагается, предоставляет 64 кбит/с пропускной способности независимо от количества B-каналов, используемых на интерфейсе PRI или BRI. Поэтому 48 кбит/с являются пропускной способностью максимума по умолчанию, которая может быть зарезервирована в policy-map для ISDN.

Эти ограничения означают, что это только целесообразно использовать один B-канал для переноса пакетов RTP. На основе требований можно принять решение нести данные и голос на том же B-канале. Также можно использовать второй B-канал BRI для данных только. В обоих из этих проектных решений это безопасно использовать cRTP в качестве всего перемещения пакетов RTP вниз одиночный B-канал и не может поступить не в порядке.

Это проектное решение передает всему трафику речевых пакетов и пакетов данных вниз одиночный B-канал. Начиная с речи и данных конкурируют за ту же ссылку, вам нужны LFI, LLQ и CBWFQ. Можно также безопасно использовать cRTP, так как нет никакой возможности для пакетов RTP для становления переупорядоченной.

По умолчанию стратегия обслуживания не может резервировать больше чем 48 кбит/с (75% 64 кбит/с) для RTP и VoIP передача сигналов. Минимальное количество, которое можно назначить на класс VoIP передача сигналов, составляет 8 кбит/с. С остающимися 40 кбит/с, доступными для использования RTP, можно произвести эту таблицу, которая показывает максимальное число вызовов, которые может нести одиночный BRI.

Размер замера (байт) PPS cRTP Длина пакета (байты) Bandwidth {Кбит/с} Вызовы на BRI
20 50 Нет 66 26.4 1
20 50 Да 28 11.2 3
30 33 Нет 76 20.1 1
30 33 Да 38 10.0 3
40 25 Нет 86 17.2 2
40 25 Да 48 9.6 4

Эти выходные данные показывают пример конфигурации для речи и данных на том же B-канале.

Конфигурация для речи и данных на одиночном B-канале с cRTP

!--- This section shows only relevant parts of the configuration.


class-map match-all VoIP-RTP
 match ip dscp ef
 
!--- RTP packets.

class-map match-all VoIP-SIG
 match ip dscp af31
 
!--- VoIP signaling packets.


policy-map voice-and-data
 class VoIP-RTP
  priority 40
 
!--- 40 Kbps available for voice.

 class VoIP-SIG
  bandwidth 8
  
!--- 8 Kbps is the minimum value allowed by Cisco IOS.


interface BRI0/0
 encapsulation ppp
 dialer pool-member 1
 ppp authentication chap

interface Dialer1
 encapsulation ppp
 bandwidth 64
 
!--- Increase the bandwidth from 56 to 64 Kbps
. 
 dialer pool 1
 dialer remote-name routerB-dialer1
 dialer-group 1
 dialer string 12345678
 service-policy output voice-and-data
 
!--- The service policy.

 ppp authentication chap
 ppp chap hostname routerA-dialer1
 ppp chap password cisco
 ppp multilink
 ppp multilink fragment-delay 10
 
!--- THe LFI delay equals 10 msec.

 ppp multilink interleave
 
!--- Enable LFI.

 ip rtp header-compression
 
!--- RTP header compression is OK.

Речь и данные на Отдельных B-каналах С или Без cRTP

Этот дизайн также возможен при помощи программного обеспечения Cisco IOS версии 12.2. Однако для лучше использования доступные Каналы B ISDN, речь и данные разделены. Выбранный пример подходит для конфигурации базовой скорости, где пакеты RTP используют один B-канал, и данные и голосовая сигнализация используют второй B-канал. Подобные понятия просят конфигурацию основной скорости, где больше каналов может использоваться для данных.

Поскольку пакеты RTP не конкурируют ни с какими данными, LFI и LLQ на голосовом канале не должны требоваться. Однако это - полезный прием для включения его так или иначе. Протокол CDP и обновления маршрута могут быть включены по ошибке, или атака типа отказ в обслуживании (DOS) может лавинно рассылать голосовой канал. На канале данных не требуется никакой LFI. Но CBWFQ требуется, чтобы защищать VoIP передача сигналов от общих данных. Обновления маршрута на голосовом канале должны быть подавлены для предотвращения трафика, который маршрутизируется через этот интерфейс. В ее месте используйте маршрутизацию на основе политик для принуждения пакетов RTP через голосовой канал. Можно безопасно использовать cRTP, так как нет никакой возможности для пакетов RTP для становления переупорядоченной.

По умолчанию стратегия обслуживания не может резервировать больше чем 48 кбит/с (75% 64 кбит/с) для RTP и VoIP передача сигналов. Однако безопасно увеличить процент до 90% с этим дизайном, поскольку нет никакого другого трафика на голосовом канале. Этот увеличенный максимум может быть задан с командой max-reserved-bandwidth.

На основе 57 кбит/с для RTP можно произвести эту таблицу, которая показывает максимальное число вызовов, что одиночный BRI может нести.

Размер замера (байт) PPS cRTP Длина пакета (байты) Bandwidth {Кбит/с} Вызовы на BRI
20 50 Нет 66 26.4 2
20 50 Да 28 11.2 5
30 33 Нет 76 20.1 2
30 33 Да 38 10.0 5
40 25 Нет 86 17.2 3
40 25 Да 48 9.6 5

Эта таблица показывает пример конфигурации для речи и данных на отдельных B-каналах.

Конфигурация для Речи и данных на Разделяет B-каналы cRTP

!--- This section shows only relevant parts of the configuration.



Class-map match-all VoIP-RTP
 match ip dscp ef
class-map match-all VoIP-SIG
 match ip dscp af31 

policy-map voice-only
 class VoIP-RTP
  priority 57

policy-map data-and-signaling
 class VoIP-SIG
  bandwidth 8

interface BRI0/0
 encapsulation ppp
 dialer pool-member 1
 ppp authentication chap

interface Dialer1
 encapsulation ppp
 bandwidth 64
 
!--- Increase the bandwidth from 56 to 64 Kbps.

 dialer pool 1
 dialer remote-name routerB-dialer1
 max-reserved-bandwidth 90
 
!--- Allow 90% of the bandwidth to be reserved.

 dialer-group 1
 dialer string 12345678
 service-policy output voice-only
 
!--- RTP packets only.

 ppp authentication chap
 ppp chap hostname routerA-dialer1
 ppp chap password cisco
 ppp multilink
 ppp multilink fragment-delay 10
 ppp multilink interleave 
 ip rtp header-compression

interface Dialer2
 encapsulation ppp
 dialer pool 1
 dialer remote-name routerB-dialer2
 dialer-group 1
 dialer string 12345678
 service-policy output data-and-signaling
 
!--- Data and VoIP signaling.

 ppp authentication chap
 ppp chap hostname routerA-dialer2
 ppp chap password cisco

router eigrp 1
 passive-interface dialer 1
 
!--- Suppress routing on the voice channel.


interface fastethernet 0/1
 ip policy route-map ip-rtp
 
!--- Policy route RTP packets.


route-map ip-rtp permit 10
 match ip address 100
 set interface dialer 1
 
!--- Route RTP packets out dialer 1.


access-list 100 permit udp any range 16384 32768
  any range 16384 32768 dscp ef

Речь и данные, Сосуществующая на Множественных B-каналах Без cRTP

Этот дизайн использует преимущества факта, что с программного обеспечения Cisco IOS версии 12.2(2)T, можно задать пропускную способность в policy-map как процент вместо абсолютного номера. Эта возможность позволяет вам применять политику обслуживания к связке (bundle) со множественными B-каналами. В результате пакеты RTP можно нести через множественные B-каналы. Компромисс - то, что реализация разнообразных путей означает, что cRTP не безопасно использовать из-за возможного изменения порядка пакетов RTP.

Cisco IOS предоставляет два механизма для вас, чтобы управлять, как дополнительные B-каналы принесены в ответ на требование. Первый механизм обычно упоминается как Технология DDR. DDR требует, чтобы порог нагрузки был задан как часть доступной пропускной способности. Когда трафик превышает эту величину порога, дополнительный канал добавлен к связке (bundle). Порог вычислен как рабочее среднее число, и существует определенная задержка внедрения дополнительных B-каналов, когда увеличивается загрузка. Эта задержка не является проблемой с данными. Однако с голосом, не приемлемо, если пользователь делает телефонный звонок, и требуются минуты для внедрения необходимой пропускной способности для поддержки QoS для вызова.

Можно уменьшить задержку для внедрения дополнительных каналов приблизительно к 30 секундам с командой load-interval на физическом интерфейсе ISDN. Однако даже 30 секунд являются слишком длинными для вызова обойтись без помощи требуемого QoS. Решение состоит в том, чтобы иметь набор команд порога загрузки номеронабирателя к значению, которое гарантирует достаточную пропускную способность в резерве для поддержки по крайней мере одного дополнительного вызова VoIP с соответствующим QoS.

Так как проблема все еще существует, если два вызова переведены в рабочее состояние в 30-секундном интервале, секунда и более надежное решение предпочтены. Решение состоит в том, чтобы сразу перевести все B-каналы в рабочее состояние и продолжить их, пока требуется Сервис ISDN. Можно использовать команду ppp multilink links minimum для определения этого действия.

С двумя доступными B-каналами стратегия обслуживания может теперь резервировать 96 кбит/с (75% 128 кбит/с) для RTP и VoIP передача сигналов. Вам нужны 8 кбит/с для VoIP передача сигналов, таким образом, это оставляет 88 кбит/с для RTP. На основе использования двух B-каналов эта таблица показывает максимальное число вызовов, которые можно нести на BRI.

Размер замера (байт) PPS cRTP Длина пакета (байты) Bandwidth {Кбит/с} Вызовы на BRI
20 50 Нет 66 26.4 3
20 50 Да 28 11.2
30 33 Нет 76 20.1 4
30 33 Да 38 10.0
40 25 Нет 86 17.2 5
40 25 Да 48 9.6

Эти выходные данные показывают пример конфигурации для речи и данных, которая сосуществует на множественных B-каналах без cRTP.

Конфигурация для Речи и данных, Сосуществующей на Множественных B-каналах без cRTP

!--- This section shows only relevant parts of the configuration.



Class-map match-all VoIP-RTP
 match ip dscp ef
class-map match-all VoIP-SIG
 match ip dscp af31 

policy-map voice-and-data
 class VoIP-RTP
  priority percent 65
  
!--- This is 65% of 64/128K for RTP.

 class VoIP-SIG
  bandwidth percent 10
  
!--- This is 10% of 64/128K for VoIP signaling.


interface BRI0/0
 encapsulation ppp
 dialer pool-member 1
 ppp authentication chap

interface Dialer1
 encapsulation ppp
 dialer pool 1
 dialer remote-name routerB-dialer1
 dialer-group 1
 dialer string 12345678
 service-policy output voice-and-data
 ppp authentication chap
 ppp chap hostname routerA-dialer1
 ppp chap password cisco
 ppp multilink
 ppp multilink fragment-delay 10
 ppp multilink interleave 
 ppp multilink links minimum 2
 
!--- Bring up two B-channels immediately.

 no ip rtp header-compression
 
!--- cRTP is not safe

Речь и данные, Сосуществующая на Множественных B-каналах С cRTP

С введением MCMP в программном обеспечении Cisco IOS версии 12.2 (12) T, решена проблема переупорядочения cRTP, и возможно иметь голос, используют множественные B-каналы и все еще делают cRTP. Принципы проектирования для этого идентичны обсужденному в Речи и данных, Сосуществующей на Множественных B-каналах Без раздела cRTP, с единственной разницей, являющейся этим, можно теперь включить cRTP. Эта таблица добавляет максимальное число вызовов, которые можно нести на BRI, на основе использования cRTP на двух B-каналах.

Размер замера (байт) PPS cRTP Длина пакета (байты) Bandwidth {Кбит/с} Вызовы на BRI
20 50 Нет 66 26.4 3
20 50 Да 28 11.2 7
30 33 Нет 76 20.1 4
30 33 Да 38 10.0 8
40 25 Нет 86 17.2 5
40 25 Да 48 9.6 9

Для этого сценария применяется Конфигурация для Речи и данных, Сосуществующей на Множественных B-каналах Без cRTP. Исключение - то, что теперь MCMP включен, и cRTP идет, когда вы добавляете эти выходные данные к интерфейсу номеронабирателя.

Типовая мультинастройка класса ppp multilink

!--- This command is available with Cisco IOS Software Release 12.2(12)T.
 
interface Dialer1 ppp multilink multiclass
	  
!--- Enable MCMP.

 ip rtp header-compression
    
!--- Support cRTP on the bundle


Дополнительные сведения


Document ID: 25610