Интерфейсы и модули Cisco : Сервисные модули Cisco

Устранение неисправностей и настройка начального модуля беспроводных служб (WiSM) серии Cisco Catalyst 6500

8 августа 2008 - Перевод, выполненный профессиональным переводчиком
Другие версии: PDF-версия:pdf | Машинный перевод (1 августа 2013) | Английский (4 августа 2008) | Отзыв

Содержание

Введение
Предварительные условия
     Требования
     Используемые компоненты
     Условные обозначения
Общие сведения
Настройка взаимодействия между модулем управления Supervisor 720 и Cisco WiSM
Этапы проверки
Связанные обсуждения сообщества поддержки Cisco
Дополнительные сведения

Введение

В данном документе рассматриваются команды, используемые для проверки и устранения неисправностей устройства WiSM. Также описываются основные этапы настройки взаимодействия модуля управления Supervisor Engine 720 (Sup720) с установленным в нем модулем WiSM.

Предварительные условия

Требования

Желательны знания основ работы с контроллерами беспроводных LAN и их настройки, а также основные сведения о коммутаторах Cisco Catalyst 6500, использующих модуль Supervisor 720 и такие технологии как EtherChannel Link Aggregation (LAG). Каких-либо еще специфических требований этот документ не предъявляет.

Используемые компоненты

Текст данного документа основан на модуле Cisco WiSM, установленном в модуле управления Supervisor Engine 720 в Catalyst 6500, использующем встроенный IOS® версии 12.2(18)SXF2, но команды применимы ко всем версиям IOS, поддерживающим Supervisor 720 и плату WiSM.

Данные для документа были получены в специально созданных лабораторных условиях. Все устройства, используемые в этом документе, были запущены в исходной (заданной по умолчанию) конфигурации. Если ваша сеть работает в реальных условиях, убедитесь, что вы понимаете потенциальное воздействие каждой команды.

Условные обозначения

Дополнительную информацию об используемых в документе обозначениях см. в разделе Условные обозначения, используемые в технической документации Cisco.

Общие сведения

Cisco WiSM входит в семейство контроллеров беспроводных сетей Cisco. Он работает совместно с "облегченными" точками доступа (LAP) серии Cisco Aironet, с Cisco WCS и системой определения местоположения устройств Cisco Wireless Location Appliance, образуя безопасное и унифицированное беспроводное решение, поддерживающее беспроводную передачу данных, голоса и видео.

Cisco WiSM беспрепятственно интегрируется в коммутатор Cisco Catalyst серии 6500 и модуль управления Supervisor Engine 720 Cisco Catalyst 6500. Поддерживаются все версии модуля управления Supervisor Engine 720. Модуль WiSM также поддерживается маршрутизаторами Cisco 7600, работающими только на программном обеспечении Cisco IOS® версии 12.2(18)SXF5.

Модуль Cisco WiSM состоит из двух контроллеров Cisco 4404, IT персонал должен быть осведомлен о наличии в одном модуле двух независимых контроллеров. Первый контроллер считается платой WiSM-A, второй – платой WiSM-B. Интерфейсы и IP-адресацию обеих плат следует рассматривать по отдельности. WiSM-A управляет 150-ю точками доступа, WiSM-B – другими 150-ю точками доступа. Эти контроллеры могут быть объединены в мобильную группу, которая формирует кластер.

На каждом контроллере Cisco WiSM есть интерфейсы различных типов; из них три - предустановленного типа, они должны присутствовать и быть настроены в процессе установки:

  • Управляющий интерфейс (предустановленный и обязательный)

  • Интерфейс менеджера точки доступа (предустановленный и обязательный)

  • Виртуальный интерфейс (предустановленный и обязательный)

  • Определяемый оператором интерфейс (устанавливается пользователем)

  • Интерфейс сервисного порта (предустановленный и обязательный)

Дополнительную информацию о каждом типе интерфейсов см. в разделе Настройка модуля беспроводных служб WiSM и беспроводной системы управления.

В модуле WiSM для согласования с модулем управления используется сервисный порт.

Примечание. Шасси серии Catalyst 6500 способно поддерживать до пяти модулей Cisco WiSM в отсутствие других сервисных модулей. Если установлен один или более сервисных модулей, шасси сможет поддерживать максимум четыре сервисных модуля, включая модули WiSM.

Настройка взаимодействия между модулем управления Supervisor 720 и Cisco WiSM

После установки контроллера Cisco WiSM в определенный слот и обнаружения его модулем управления, эти настройки выполняются в модуле управления для обеспечения его взаимодействия с WiSM.

  1. Создайте область DHCP для сервисного порта модуля Catalyst WiSM.

    ip dhcp excluded-address 192.168.10.1 192.168.10.2
    
    !
    ip dhcp pool wism-service-port
     
    network 192.168.10.0 255.255.255.0
    
    default-router 192.168.10.1
    
    

    Также возможно открыть сеанс: (session slot X proc 1 or 2) или зайти в WiSM напрямую с консоли и установить статические IP-адреса (config Interface Address Service-Port).

    Убедитесь, что IP-адрес сервисного порта в вашей сети не является маршрутизируемым, т. к. он используется исключительно для связи между Sup 720 и WiSM.

    Сервисный порт не поддерживает функцию формирования подсетей VLSM, следовательно, адрес сервисного порта не должен перекрываться с другими адресами вашей сети. Другими словами, интерфейс сервисного порта необходимо создавать в сети, в которой первый октет не соответствует никаким другим интерфейсам.

    Например, не используйте следующее:

    • Management: 10.1.1.1/24

    • AP-Manager: 10.1.2.1/24

    • Service-Port: 10.10.10.1/24

    В данном случае сервисный порт может быть расположен в любом другом диапазоне частной сети (192.x, 172.x).

    Дополнительную информацию о настройке сервисного порта см. в разделе Вопросы и ответы по устранению неполадок WiSM.

  2. Создайте шлюз сервисного порта модуля WiSM и назначьте IP-адрес.

    Создайте сеть VLAN в Supervisor 720. Данная сеть VLAN является локальной для шасси и используется для связи между модулем Cisco WiSM и Catalyst Supervisor 720 через Gigabit Interface на Supervisor и сервисный порт в модуле Cisco WiSM.

    interface Vlan192
    
    Description WiSM Service Port Gateway or Management Interface on CAT6K
    ip address 192.168.10.1 255.255.255.0
    
    

    Примечание. Для доступа к Cat6k необходимо наличие интерфейса VLAN управления сетью.

  3. Назначьте сервисные порты модуля WiSM для VLAN.

    Настройте данную команду, чтобы использовать VLAN 192 для связи с сервисным портом.

    wism service-vlan 192
    
    
  4. На Cat6k создайте интерфейс управления WiSM/шлюза менеджера точки доступа.

    Ниже приведен пример:

    interface vlan40
    
    Description WiSM Management/AP-Manager Interface Gateway
    ip address 40.1.1.1
    
    

    Примечание. Программное обеспечение версии 12.2(18)SXF5 представило новые команды модуля WiSM для использования совместно с портами auto-LAG (при высоком значении диапазона, равном 200). Данные команды могут быть использованы вместо шагов 5 и 6. Повторите данные две команды для контроллера 1 и контроллера 2 в модуле WiSM.

    wism module <модуль/номер слота>controller 1 native-vlan 40

    wism module <модуль/номер слота> controller 1 allowed-vlan native vlan id(40), vlan id1, vlan2, etc...

  5. На Cat6k создайте два интерфейса порт-канал с помощью магистрального соединения dot1q trunking, trust dscp и собственной VLAN, что позволит получать немаркированные пакеты с порта управления.

    Создайте два интерфейса порт-канал для двух независимых контроллеров в модуле Cisco WiSM и назначьте VLAN 40 в качестве собственного интерфейса.

    interface Port-channel X
    
    switchport trunk encapsulation dot1q
    switchport trunk native vlan 40
    
    switchport mode trunk
    mls qos trust dscp
    spanning-tree portfast trunk
    

    Подобным образом создайте другой интерфейс порт-канал для другого контроллера модуля WiSM.

  6. Настройте интерфейсы контроллеров 1 и 2 модуля WiSM.

    Как только контроллер модуля Cisco WiSM будет обнаружен модулем управления, будут созданы восемь интерфейсов Gigabit, в диапазоне от Gig<номер слота, в который установлен модуль>/1 до Gig<номер слота>/8.

    Настройте эти интерфейсы Gigabit в качестве транковых портов с сетью VLAN 40 в качестве собственной VLAN. Во время выполнения настроек модуля Cisco WiSM собственная VLAN не должна быть тегирована. Ниже приведен пример конфигурации:

    router(config)# interface range gigabitEthernet
    <slot>/1 - 4 
    or 
    router(config)# interface range gigabitEthernet 
    <slot>/5 - 8
    
    switchport trunk encapsulation dot1q
    switchport trunk native vlan 40
     
    switchport mode trunk
    mls qos trust dscp
    spanning-tree portfast trunk
    channel-group <порт-номер канала> mode on
    

Этапы проверки

В данном документе рассматриваются команды, используемые для проверки настройки WiSM.

  1. Чтобы проверить, какая версия CAT IOS работает в настоящий момент, используйте команду

    show version.

    Router#show version
    Cisco Internetwork Operating System Software 
    IOS (tm) s72033_rp Software (s72033_rp-ADVENTERPRISEK9_WAN-M), Version 12.2(18)SXF5, RELEASE SOFTWARE (fc3)
    Technical Support: http://www.cisco.com/techsupport
    Copyright (c) 1986-2006 by cisco Systems, Inc.
    Compiled Sat 08-Jul-06 02:54 by kellythw
    Image text-base: 0x40101040, data-base: 0x42D88000
    
    ROM: System Bootstrap, Version 12.2(14r)S1, RELEASE SOFTWARE (fc1)
    BOOTLDR: s72033_rp Software (s72033_rp-ADVENTERPRISEK9_WAN-M), Version 12.2(18)SXF5, RELEASE SOFTWARE (fc3)
    
    ... skip ...
    
    cisco WS-C6503-E (R7000) processor (revision 1.1) with 458720K/65536K bytes of memory.
    Processor board ID FOX0920047A
    SR71000 CPU at 600Mhz, Implementation 0x504, Rev 1.2, 512KB L2 Cache
    Last reset from power-on
    SuperLAT software (copyright 1990 by Meridian Technology Corp).
    X.25 software, Version 3.0.0.
    Bridging software.
    TN3270 Emulation software.
    3 Virtual Ethernet/IEEE 802.3 interfaces
    20 Gigabit Ethernet/IEEE 802.3 interfaces
    1917K bytes of non-volatile configuration memory.
    8192K bytes of packet buffer memory.
    
    65536K bytes of Flash internal SIMM (Sector size 512K).
    Configuration register is 0x2102

    Примечание. Для модуля WiSM необходим Supervisor 720, использующий собственную IOS версии 12.2(18)SXF2 или более позднюю.

  2. Чтобы проверить, что в Cat6k есть Supervisor 720 и плата WiSM, используйте команду show module

    Router#show module
    Mod Ports Card Type                              Model              Serial No.
    --- ----- -------------------------------------- ------------------ -----------
      1    2  Supervisor Engine 720 (Active)         WS-SUP720-BASE     SAD0717003H
      3   10  WiSM WLAN Service Module               WS-SVC-WISM-1-K9   SAD09280AZU
    
    
    Mod MAC addresses                       Hw    Fw           Sw           Status
    --- ---------------------------------- ------ ------------ ------------ -------
      1  000c.ce63.eb0c to 000c.ce63.eb0f   2.1   7.7(1)       12.2(18)SXF5 Ok
      3  0030.f274.ae36 to 0030.f274.ae45   0.3   12.2(14r)S5  12.2(18)SXF5 Ok
    
    
    Mod  Sub-Module                  Model              Serial       Hw     Status 
    ---- --------------------------- ------------------ ----------- ------- -------
      1  Policy Feature Card 3       WS-F6K-PFC3A       SAD071902DP  1.1    Ok
      1  MSFC3 Daughterboard         WS-SUP720          SAD071700L3  1.2    Ok
      3  Centralized Forwarding Card FARFEL             SAD0929038U  0.3    Ok
    
    Mod  Online Diag Status 
    ---- -------------------
      1  Pass
      3  Pass

    Примечание. Выходные данные команды show module, переданной от коммутатора, показывают модуль WISM с 10 портами. Но только 8 портов используются для конфигурации порт-канал, порт-канал1 и порт-канал2. Оставшиеся два используются в качестве сервисных портов.

  3. Чтобы проверить, в какой слот установлен модуль WiSM, используйте команду

    show wism status.

    Ниже приведен пример выходных данных этой команды:

    Router#sh wism status
    Service Vlan : 158, Service IP Subnet : 172.16.158.131/255.255.255.128
    WLAN
    Slot Controller Service IP Management IP SW Version Status
    ----+-----------+----------------+----------------+-----------+---------
    3 1 172.16.158.142 140.1.3.10 3.2.116.21 Oper-Up
    3 2 172.16.158.143 140.1.3.11 3.2.116.21 Oper-Up
    

    Для 6503-E подходят только слоты 1 – 3. Для 6504 – 6506 подходят только слоты 1 – 4. Для 6509 подходят только слоты 1 – 9. Для 6913, которая отличается от остальных версий, подходят только слоты 9 – 13. Дополнительную информацию см. в разделе Вопросы и ответы по устранению неполадок WiSM

  4. Чтобы проверить состояние модуля WiSM со стороны Cat6k, используйте команду

    show wism module X controller Y status

    и найдите Oper-Up and the LAG port in use (Verify LAG port).

    Чтобы проверить отсутствие сервисного IP-адреса, проверьте настройки DHCP для сервисной VLAN. Кроме того, также можно открыть сеанс с модулем (session slot x proc 1 or 2) или задать статический IP-адрес прямой командой с консоли WiSM.

    Router#show wism module 3 controller 1 status 
    
    WiSM Controller 1 in Slot 3
    Operational Status of the Controller : Oper-Up
    Service VLAN                         : 250
    Service Port                         : 9
    Service Port Mac Address             : 0014.a9bd.d9a2
    Service IP Address                   : 172.16.158.142
    Management IP Address                : 140.1.3.10
    Software Version                     : 3.2.116.21
    Port Channel Number                  : 285
    Allowed vlan list                    : 5,10,15,25,35,45,55
    Native VLAN ID                       : 5
    WCP Keep Alive Missed                : 0
    
  5. Чтобы проверить, установлен ли режим магистрального соединения с модулем WiSM и сетями VLAN, используйте команду

    show interface trunk.

    Ниже приведен пример выходных данных этой команды:

    Router#show interface trunk
             Port  Mode   Encapsulation Status Native vlan
             Po1   on     802.1q trunking 140
             Po2   on     802.1q trunking 140
  6. Чтобы проверить правильность алгоритма балансировки нагрузки (config #port-channel load-balance src-dst-ip), используйте команду

    show etherchannel load-balance.

    Ниже приведен пример выходных данных этой команды:

    Router# show etherchannel load balance
    EtherChannel Load-Balancing Configuration:
                       src-dst-ip
    

    Чтобы проверить правильность выбора портов на EthernChannel, используйте команду

    show etherchannel load-balance.

    Пример выходных данных:

    Router#show etherchannel summary
    Group Port-channel Protocol Ports
    ------+-------------+-----------+-----------------------------------------
    1     Po1(SU)        -      Gi3/1(P) Gi3/2(P) Gi3/3(P) Gi3/4(P)
    2     Po2(SU)        -      Gi3/5(P) Gi3/6(P) Gi3/7(P) Gi3/8(P)
  7. Чтобы проверить состояние со стороны WiSM, откройте сессию (session slot x proc 1 or 2) или зайдите в WiSM с консоли и проверьте состояние LAG с помощью show interface summary (или Controller -> Interfaces - > edit (интерфейс управления). В области Physical Information указано, что интерфейс привязан к LAG.

    Ниже представлен пример:

    (WiSM-slot3-1) >show interface
    		  summary
    Interface Name     Port  Vlan Id   IP Address   Type   Ap Mgr
    --------------------------------   ----      -------   -------- ------- 
             ap-manager         LAG  untagged   192.168.3.9   Static   Yes
             management         LAG  untagged   192.168.3.10  Static    No

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения


Document ID: 91473