Беспроводные сети / Мобильные решения : "Беспроводные сети, LAN (WLAN)"

Пример конфигурации QoS в контроллерах беспроводной LAN и облегченных точках доступа

8 августа 2008 - Перевод, выполненный профессиональным переводчиком
Другие версии: PDF-версия:pdf | Машинный перевод (28 июля 2013) | Английский (27 июня 2008) | Отзыв

Содержание

Введение
Предварительные условия
     Требования
     Используемые компоненты
     Условные обозначения
Базовые сведения
     Усовершенствования маркировки пакетов QoS уровня 3
     Параметры сети
Настройка
     Настройка беспроводной сети для QoS
     Настройка проводной сети для QoS
Проверка и устранение неполадок
     Команды устранения неполадок
Связанные обсуждения сообщества поддержки Cisco
Дополнительные сведения

Введение

В этом документы содержится пример конфигурации, показывающий настройку качества обслуживания (QoS) в единой беспроводной сети Cisco (UWN) с помощью контроллеров беспроводной локальной сети Cisco (WLC) и облегченных точек доступа (LAP).

Предварительные условия

Требования

Убедитесь, что вы обеспечили выполнение следующих требований, прежде чем попробовать эту конфигурацию:

  • Базовые знания о настройке облегченных точек доступа и WLC компании Cisco.

  • Знание настройки базовой маршрутизации и QoS в проводной сети.

Используемые компоненты

Сведения, содержащиеся в данном документе, касаются следующих версий программного и аппаратного обеспечения.

  • 2006 WLC Cisco с микропрограммой версии 4.0.

  • Облегченные точки доступа Cisco 1000 Series.

  • Адаптер беспроводного клиента (WCA) 802.11a/b/g Cisco с микропрограммой версии 2.6.

  • Маршрутизатор Cisco 3725, использующий программное обеспечение Cisco IOS® версии 12.3(4)T1.

  • Маршрутизатор Cisco 3640, использующий программное обеспечение Cisco IOS® версии 12.2(26).

  • Два коммутатора Cisco 3500 XL Series, использующие программное обеспечение Cisco IOS версии 12.0(5)WC3b.

Сведения, содержащиеся в этом документе, были получены в специально созданных лабораторных условиях. Все устройства, используемые в этом документе, запускались с чистой (заданной по умолчанию) конфигурацией. Если сеть работает в реальных условиях, убедитесь, что вы понимаете потенциальное воздействие каждой команды.

Условные обозначения

Дополнительную информацию о применяемых в документе обозначениях см. в разделе Условные обозначения, используемые в технической документации Cisco.

Базовые сведения

Качество обслуживания (QoS) относится к способности сети предоставить улучшенное или особое обслуживание набору пользователей или приложений за счет других пользователей или приложений.

При использовании QoS можно более эффективно управлять пропускной способностью в локальных сетях. Это относится также к беспроводным локальным сетям и глобальным сетям. Служба QoS обеспечивает улучшенное и надежное использование сети благодаря следующим функциям.

  • Поддержка выделенной полосы пропускания для важнейших пользователей и приложений.

  • Контроль дрожания и задержки (требуется для трафика реального времени).

  • Управление и минимизация перегрузки сети.

  • Формирование сетевого трафика для сглаживания его потока.

  • Установка приоритетов сетевого трафика.

В прошлом WLAN в основном использовались для передачи трафика, связанного с данными приложений и требующего невысокой пропускной способности. Теперь, с распространением WLAN в вертикальных (торговых, финансовых, образовательных и пр.) и корпоративных средах, они используются для передачи данных приложений, требующих высокой пропускной способности в сочетании с данными чувствительных ко времени передачи мультимедийных приложений. Это привело к тому, что появилась необходимость в службе QoS для беспроводных сетей.

Рабочая группа IEEE 802.11e в составе комитета по стандартам IEEE 802.11 составила определение стандарта. Тем не менее, внедрение стандарта 802.11e все еще находится на ранней стадии и, как это бывает со многими стандартами, существует много дополнительных компонентов. Как и в случае с безопасностью стандарта 802.11, определенной в 802.11i, группы разработчиков, среди которых Wi-Fi Alliance, и лидеры отрасли, в том числе компания Cisco, определяют ключевые требования службы QoS для WLAN в рамках программ Wi-Fi MultiMedia (WMM) и Cisco Compatible Extensions (CCX). Наличие важнейших функций продуктов и возможность их взаимодействия обеспечивается с помощью программ сертификации.

Унифицированные беспроводные продукты Cisco поддерживают WMM, систему QoS, основанную на черновике стандарта IEEE 802.11e, опубликованном группой Wi-Fi Alliance.

Дополнительные сведения о том, как работает QoS в единой беспроводной сети Cisco см. в разделе Служба QoS в единой беспроводной сети Cisco документа Руководство по планированию корпоративной мобильности.

В данном документе приведен пример конфигурации, показывающий, каким образом можно настроить QoS на контроллерах и обмениваться данными с проводной сетью, в которой также настроено QoS.

Усовершенствования маркировки пакетов QoS уровня 3

Единая беспроводная сеть Cisco поддерживает IP-маркировку уровня 3 для пакетов, отправляемых устройствами WLC и LAP, которая называется Differentiated Services Code Point (DSCP). Эта функция улучшает то, каким образом точки доступа используют информацию сетевого уровня 3 для обеспечения правильной беспроводной приоритизации пакетов, отправляемых с точки доступа беспроводному клиенту.

В централизованной архитектуре WLAN данные сети туннелируются между точкой доступа и контроллером WLAN по протоколу облегченных точек доступа (LWAPP). Чтобы сохранить исходную классификацию QoS при использовании этого туннеля, параметры QoS инкапсулированного пакета данных должны быть правильно сопоставлены полям уровня 2 (802.1p) и уровня 3 (IP DSCP) пакета внешнего туннеля.

Пакетам между контроллером и облегченной точкой доступа нельзя назначить метку DSCP, если значение DSCP или 802.1P отсутствует в исходном пакете.

Контроллер не использует собственные настройки QoS. Поддержка QoS на контроллере WLC дает последнему возможность применять к пакетам приоритет, установленный в сети (или в приложении).

Поэтому единственное действие, доступное устройствам WLC и AP — копирование значения из исходного пакета во внешний заголовок пакета LWAPP. Единственная цель параметров "gold", "silver" и "bronze" QoS на контроллере WLC — выполнение правильного преобразования QoS из значений 802.11e/802.1p UP в значения IP DSCP и обратно (значения IP DSCP зависят от используемого приложения или стандарта). Служба QoS на контроллере WLC обеспечивает правильную обработку QoS пакетов от начала до конца. Контроллер не работает с QoS самостоятельно. Если QoS уже существует и требуется осуществлять приоритизацию пакетов беспроводного соединения, то контроллер может поддерживать передачу этих данных. Но служба QoS не может существовать только на контроллере.

Приведем пример работы контроллеров WLC с QoS. Приложение (например, CallManager), может установить значение параметра качества обслуживания равным Высокое. Поэтому исходный пакет данных, поступающий от приложения, будет снабжен IP-заголовком, котором параметр DCSP принимает значение Высокое. Затем пакет достигает контроллера. После этого пакет проходит тест SSID. Но если тест SSID на контроллере настроен на профиль QoS Bronze, то IP-заголовок пакета, в который инкапсулирован пакет LWAPP от контроллера для точки доступа, будет иметь значение Bronze, хотя IP-заголовок исходного пакета от приложения будет иметь высокий приоритет. В данном документе предполагается, что значение DCSP, устанавливаемое в приложении, и профиль QoS для данного SSID на контроллере совпадают. Но так бывает не всегда.

qos-wlc-lap1.gif

Например, если клиентом беспроводной сети отправляется трафик 802.11e, в кадре трафика содержится класс UP (пользовательского приоритета). Точке доступа необходимо сопоставить этот класс 802.11e значению DSCP для пакета LWAPP, в котором содержится этот кадр. Это обеспечит назначение пакету соответствующего приоритета на его пути к контроллеру WLC. Примерно те же действия должны выполняться на контроллере WLC для пакетов LWAPP, направляющихся к точке доступа. Также на точке доступа и контроллере WLC необходим механизм классификации трафика для клиентов, не использующих 802.11e, чтобы пакетам также назначался соответствующий им приоритет. В следующей таблице описывается обработка пакетов на каждом устройстве.

#

Откуда

Куда

UP (802.1p/802.11e)

IP DSCP

1

Контроллер

Точка доступа

Значение DSCP входящего пакета НЕ преобразуется в значение AVVID 802.1p UP. Если для помеченных пакетов на контроллере включен доступ 802.1p, выполняется сравнение потолка входящего значения 802.1p и установленного на контроллере значения. Затем меньшее из этих двух значений копируется в исходящий пакет. Значение DSCP, если оно присутствует, переходит в пакет напрямую. Для непомеченных пакетов сопоставление DSCP и 802.1p не выполняется, даже если протокол 802.1p включен на контроллере.

Значение DSCP копируется из входящего пакета.

2

Точка доступа

Беспроводный клиент

Клиент WMM: Значение DSCP из входящего пакета LWAPP преобразуется в значение UP для 802.11e. Настройте значение так, чтобы оно не превышало максимально допустимого для данного клиента значения QoS беспроводной сети, заданного политикой. Пакет помещается в очередь 802.11 Tx, в соответствии со значением UP.

Обычный клиент: Пакет помещается в очередь 802.11 Tx по умолчанию для политики QoS беспроводной сети, назначенной этому клиенту.

Отсутствует (сохраняется исходное значение DSCP).

3

Точка доступа

Контроллер

Отсутствует (точки доступа не поддерживают метки 802.1Q/802.1p).

Клиент WMM: Политика для значения UP 802.11e настраивается так, чтобы оно не превышало максимума, определенного политикой QoS для данного клиента. Значение преобразуется в значение DSCP.

Обычный клиент: Используется значение UP 802.11e для политики QoS, назначенной данному клиенту. Значение преобразуется в значение DSCP.

4

Контроллер

Коммутатор Ethernet

Значение DSCP из входящих пакетов LWAPP преобразуется в значение UP для 802.11p.

Отсутствует (сохраняется исходное значение DSCP).

В следующей таблице описаны преобразования значений из UP (802.11e/802.1p) в DSCP (IP) и обратно. Так как архитектура Cisco для передачи голоса, видео и интегрированных данных (AVVID) определяет преобразование из UP (802.1) в DSCP (IP), а IEEE определяет преобразование из DSCP (IP) в UP (802.1e), необходимо два различных набора преобразований.

Тип трафика Cisco AVVID 802.1p UP

Cisco AVVID IP DSCP

Cisco AVVID 802.1p UP

IEEE 802.11e UP

Примечания

Управление сетью

-

7

-

Зарезервировано для управления сетью.

Межсетевое управление

48

6

7 (AC_VO)

Управление LWAPP.

Голос

46 (EF)

5

6 (AC_VO)

Контроллер: Профиль QoS "Platinum"

Видео

34 (AF41)

4

5 (AC_VI)

Контроллер: Профиль QoS "Gold"

Голосовое управление

26 (AF31)

3

4 (AC_VI)

-

Оптимальный уровень

0 (BE)

0

3 (AC_BE)

0 (AC_BE)

Контроллер: Профиль QoS "Silver"

-

Фоновый процесс (фоновый процесс Cisco AVVID Gold)

18 (AF21)

2

2 (AC_BK)

-

Фоновый процесс (фоновый процесс Cisco AVVID Silver)

10 (AF11)

1

1 (AC_BK)

Контроллер: Профиль QoS "Bronze"

Параметры сети

В данном документе используется следующая схема сети:

  • Проводная сеть состоит из двух маршрутизаторов (Router1 и Router2), соединенных по протоколу OSPF. Хосты проводной сети следующие: FTP-сервер (F1), голосовой клиент (V1) и клиент видео (Vi1). Хосты проводной сети подсоединены к сети через коммутатор уровня 2, который подсоединяется к интерфейсу Fast Ethernet маршрутизатора Router1.

  • Беспроводная сеть подключается к сети через маршрутизатор Router2, как это показано на схеме. Хосты беспроводный сети следующие: FTP-клиент (без WMM), голосовой клиент V1 (7920 Phone) и клиент видео Vi1 (с WMM).

  • Голосовым пакетам должен назначаться самый высокий приоритет, вторые по значимости - пакеты видеоданных. Пакетам FTP назначается наименьший приоритет.

  • В проводной сети для реализации QoS используется взвешенный алгоритм произвольного раннего обнаружения (Weighted Random Early Detection, WRED). Классификация и приоритизация различных типов трафика выполняется с помощью значений DSCP. Для приоритизированных пакетов используется алгоритм WRED.

  • В беспроводной сети необходимо создать три WLAN для каждого типа трафика и включить соответствующие профили QoS.

    • WLAN 1—FTP Clients: Профиль QoS "Bronze"

    • WLAN 2—Video Clients: Профиль QoS "Gold"

    • WLAN 3—Voice Clients: Профиль QoS "Platinum"

Устройства для обеспечения базовой поддержки IP-соединений и качества обслуживания необходимо настроить как в проводной, так и в беспроводной сети.

qos-wlc-lap4.gif

Настройка

В этом разделе содержатся сведения по настройке функций, описанных в данном документе.

Примечание. Чтобы получить дополнительную информацию о применяемых в данном документе командах, воспользуйтесь Средством поиска команд (только для зарегистрированных клиентов).

Чтобы настроить устройства для этой конфигурации, необходимо выполнить следующее.

Настройка беспроводной сети для QoS

Перед настройкой качества обслуживания QoS на контроллерах WLC, необходимо провести первичную настройку контроллера WLC и зарегистрировать облегченные точки доступа на контроллере. В данном документе предполагается, что первичная настройка контроллера WLC проведена и облегченные точки доступа уже зарегистрированы на контроллере. Если вы являетесь начинающим пользователем, то обратитесь за информацией о первичной настройке контроллера WLC для работы с облегченными точками доступа к странице Регистрация облегченных точек доступа на контроллере WLC.

После регистрации облегченных точек доступа на контроллере WLC выполните следующие шаги, чтобы настроить облегченные точки доступа и контроллер WLC для данной конфигурации.

  1. Настройте сети WLAN для различных типов трафика.

  2. Включите профили QoS для WLAN.

Чтобы создать WLAN для голосовых клиентов на контроллере WLC, выполните следующие действия.

  1. Нажмите WLANs в графическом интерфейсе контроллера, чтобы создать WLAN.

  2. Нажмите New для настройки новой беспроводной сети.

    В данном примере имя сети — VoiceClients, а WLAN ID — 1.

  3. Нажмите кнопку Apply.

    qos-wlc-lap5.gif

  4. В окне WLANs > Edit определите параметры для WLAN VoiceClients.

    1. Выберите соответствующий интерфейс для WLAN в поле «Interface Name».

      В данном примере WLAN VoiceClients сопоставлен интерфейс Voice.

    2. В раскрывающемся меню «Quality of Service (QoS)» выберите соответствующий профиль QoS для этой WLAN.

      В данном примере выбран профиль QoS Platinum. Таким образом, для голосовой WLAN будет установлен наивысший приоритет.

    3. Для параметра «7920 Phone Support» выберите тип контроля приема вызов (CAC).

      В данном примере используется значение AP CAC Limit (Предел CAC точки доступа).

    4. Выберите другие параметры согласно схеме сети.

      В данном примере используются значения по умолчанию.

    5. Нажмите кнопку Apply.

      qos-wlc-lap6.gif

      Примечание. Не включайте режим WMM, если в сети используются телефоны Cisco 7920 Phone. Нельзя одновременно включить режим WMM и режим управляемого клиентом CAC в одной беспроводной сети. Если включен режим управляемого точкой доступа CAC, точка доступа посылает собственный информационный элемент (IE) Cisco CAC, но не посылает стандартный элемент IE QBSS.

Установка инфраструктуры для передачи голоса по WLAN включает не только настройку качества обслуживания в WLAN. В голосовой WLAN должны учитываться требуемая зона покрытия, поведение пользователей, требования роуминга и контроль приема. Все это описывается в документе Руководство по планированию и развертыванию сетей беспроводной IP-телефонии Cisco 7920.

Подобным образом создайте WLAN для клиентов видео и FTP. Клиенты видео сопоставляются динамическому интерфейсу Video, а клиенты FTP сопоставляются динамическому интерфейсу FTP. Ниже приведены снимки экрана.

Примечание. В данном документе не описывается создание VLAN в контроллерах WLC. Сведения о настройке динамических интерфейсов в контроллерах WLC см. на странице Пример конфигурации сетей VLAN на WLC.

qos-wlc-lap7.gif

qos-wlc-lap8.gif

Примечание. Поддержка клиентов WLAN для WMM не означает, что трафик клиентов автоматически получает возможность использовать преимущества WMM. Приложения, которым требуется использовать WMM назначают приоритеты собственному трафику, а операционной системе необходимо передать эту классификацию на интерфейс WLAN. В специально предназначенных устройствах (например в гарнитурах VoWLAN) это часть конструкции. Но при внедрении на платформе общего назначения, например, на компьютере, необходимо установить классификацию трафика приложениями и поддержку функций WMM операционной системой.

Для клиентов видео выбирается профиль QoS «Gold» и включается WMM. Для клиентов FTP выбирается профиль QoS «Bronze» и WMM отключается, так как клиенты FTP не поддерживают WMM.

qos-wlc-lap9.gif

qos-wlc-lap10.gif

Примечание. Если контроллер находится в режиме уровня 2, режим WMM включен, необходимо поместить точки доступа на магистральный порт, чтобы они могли присоединяться к контроллеру.

Для настройки WLAN и качества обслуживания на контроллерах WLC в окне командной строки введите следующие команды:

  • config wlan create <wlan-id> <wlan-name>, чтобы создать новую WLAN. Вместо wlan-id укажите значение от 1 до 16. Вместо имя-wlan введите сетевое имя SSID (до 31 алфавитно-цифрового символа).

  • config wlan enable <wlan-id>, чтобы включить WLAN.

  • config wlan qos wlan-id {bronze | silver | gold | platinum}, чтобы назначить уровень качества обслуживания WLAN.

  • config wlan wmm {disabled | allowed | required} wlan-id, чтобы включить режим WMM.

  • config wlan 7920-support client-cac-limit {enabled | disabled} wlan-id для телефонов, требующих контролируемого клиентом приема вызовов (CAC).

  • config wlan 7920-support ap-cac-limit {enabled | disabled} wlan-id для телефонов, требующих контролируемого клиентом приема вызовов (CAC).

Настройка проводной сети для QoS

Чтобы настроить проводную сеть для данной конфигурации, необходимо провести первичную настройку маршрутизаторов и включить QoS в проводной сети. В качестве протокола одноадресной маршрутизации используется OSPF.

Для установки качества обслуживания в проводной сети используется алгоритм WRED. Функция DiffServ Compliant WRED (WRED, совместимый с DiffServ) включает WRED, чтобы использовать значение DSCP при расчете вероятности сброса для пакета.

Далее приведены конфигурации для маршрутизаторов R1 и R2:

Router1

Router1#show run
Building configuration...

Current configuration : 2321 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Router1
!
!
ip subnet-zero
!
!
!
call rsvp-sync
!

!
class-map match-all FTP
!--- Классификация FTP-пакетов в соответствии со списком доступа 103.

  match access-group 103
class-map match-all Video
!--- Классификация пакетов видеоданных в соответствии со списком доступа 102.

  match access-group 102
class-map match-all Voice
!--- Классификация пакетов речевых сигналов в соответствии со списком доступа 101.

  match access-group 101
!
!
policy-map Marking-For-FTP
!--- Установка для DSCP значения af11 для FTP-пакетов.

  class FTP
   set ip dscp af11
policy-map Marking-For-Voice
!--- Установка для DSCP значения ef для пакетов речевых сигналов.

  class Voice
   set ip dscp ef
policy-map Marking-For-Video
!--- Установка для DSCP значения af41 для пакетов видеоданных.

  class Video
   set ip dscp af41
!
!
!
interface Serial2/0
 description Connected to Router2
 ip address 10.2.3.2 255.255.255.0
 random-detect dscp-based 
!--- Активация WRED на основе значения DSCP пакета.

 random-detect dscp 10 30 40
!--- Установка минимального и максимального пороговых значений количества пакетов 
!--- в размере 30 и 40 пакетов для значения 10 DSCP.

 random-detect dscp 34 40 50
!--- Установка минимального и максимального пороговых значений количества пакетов 
!--- в размере 40 и 50 пакетов для значения 34 DSCP.

 random-detect dscp 46 50 60
!--- Установка минимального и максимального пороговых значений количества пакетов 
!--- в размере 50 и 60 пакетов для значения 46 DSCP.

 clockrate 56000
!
interface Serial2/1
 no ip address
 shutdown
!
interface Serial2/2
 no ip address
 shutdown
!
interface Serial2/3
 no ip address
 shutdown
!
interface Serial2/4
 no ip address
 shutdown
!
interface Serial2/5
 no ip address
 shutdown
!
interface Serial2/6
 no ip address
 shutdown
!
interface Serial2/7
 no ip address
 shutdown
!
interface FastEthernet3/0
 no ip address
 duplex auto
 speed auto
!
interface FastEthernet3/0.1
 description Connected to Voice Clients
 encapsulation dot1Q 10
 ip address 192.168.0.1 255.255.0.0
 service-policy output Marking-For-Voice
!--- Применение к интерфейсу политики маркировки для речевых сигналов.

!
interface FastEthernet3/0.2
 description Connected to Video Clients
 encapsulation dot1Q 20
 ip address 172.16.0.1 255.255.0.0
 service-policy output Marking-For-Video
!--- Применение к интерфейсу политики маркировки для видеоданных.

!
interface FastEthernet3/0.3
 description Connected to FTP Server
 encapsulation dot1Q 30
 ip address 30.0.0.1 255.0.0.0
 service-policy output Marking-For-FTP
!--- Применение к интерфейсу политики маркировки для FTP.

!
interface FastEthernet3/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
router ospf 1
!--- Настройка OSPF в качестве протокола маршрутизации.

 log-adjacency-changes
 network 10.0.0.0 0.255.255.255 area 0
 network 30.0.0.0 0.0.0.255 area 0
 network 172.16.0.0 0.0.255.255 area 0
 network 192.168.0.0 0.0.255.255 area 0
!
ip classless
ip http server
!
access-list 101 permit ip 192.168.0.0 0.0.255.255 any
!--- Список доступа, используемый для пакетов речевых сигналов.

access-list 102 permit ip 172.16.0.0 0.0.255.255 any
!--- Список доступа, используемый для пакетов видеоданных.

access-list 103 permit ip 30.0.0.0 0.0.0.255 any
!--- Список доступа, используемый для FTP-пакетов.

!
voice-port 1/0/0
!
voice-port 1/0/1
!
voice-port 1/1/0
!
voice-port 1/1/1
!
dial-peer cor custom
!
!
!
dial-peer voice 1 pots
 destination-pattern 4085551234
 port 1/0/0
!
!
line con 0
line aux 0
line vty 0 4
!
end

Router2

Router2#show run
Building configuration...

Current configuration : 1551 bytes
!
version 12.3
service config
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
ip subnet-zero
!

!
interface FastEthernet0/0
 ip address dhcp
 duplex auto
 speed auto
!
interface FastEthernet0/0.1
 description Connected to Voice Clients
 encapsulation dot1Q 40
 ip address 20.0.0.1 255.0.0.0
!
interface FastEthernet0/0.2
 description Connected to Video Clients
 encapsulation dot1Q 50
 ip address 40.0.0.1 255.0.0.0
!
interface FastEthernet0/0.3
 description Connected to FTP Clients
 encapsulation dot1Q 60
 ip address 50.0.0.1 255.0.0.0
!
interface Serial0/0
 description Connected to Router1
 ip address 10.2.3.1 255.255.255.0
 random-detect dscp-based
!--- Активация WRED на основе значения DSCP пакета.

 random-detect dscp 10 30 40
!--- Установка минимального и максимального пороговых значений количества пакетов 
!--- в размере 30 и 40 пакетов для значения 10 DSCP.

 random-detect dscp 34 40 50
!--- Установка минимального и максимального пороговых значений количества пакетов 
!--- в размере 40 и 50 пакетов для значения 34 DSCP.

 random-detect dscp 46 50 60
!--- Установка минимального и максимального пороговых значений количества пакетов 
!--- в размере 50 и 60 пакетов для значения 46 DSCP.

!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Service-Engine2/0
 no ip address
 shutdown
 hold-queue 60 out
!
router ospf 1
!--- Настройка OSPF в качестве протокола маршрутизации.

 log-adjacency-changes
 network 10.0.0.0 0.255.255.255 area 0
 network 20.0.0.0 0.255.255.255 area 0
 network 40.0.0.0 0.255.255.255 area 0
 network 50.0.0.0 0.255.255.255 area 0
!
ip http server
ip classless
!
!
control-plane
!
!
voice-port 1/0/0
!
voice-port 1/0/1
!
gatekeeper
 shutdown
!
!
line con 0
line 65
 no activation-character
 no exec
 transport preferred none
 transport input all
 transport output all
line aux 0
line vty 0 4
!
!
end

Проверка и устранение неполадок

После первичной настройки подключения для проводной и беспроводной сетей и установки QoS пакеты классифицируются, помечаются и отправляются на основе политик, настроенных для каждого типа трафика.

В слабо загруженной сети заметить использование QoS может быть непросто. Функции QoS начинают воздействовать на производительность приложений по мере увеличения нагрузки сети. Качество обслуживания (QoS) сохраняет задержку, дрожание и потери для выбранных типов трафика в приемлемых пределах.

Клиент видео с включенным WMM

Когда клиент видео на стороне проводной сети отправляет данные на клиент видео на стороне беспроводной сети, происходит следующее.

  1. На интерфейсе FastEthernet маршрутизатора Router1 к пакетам видео применяется политика Marking-For-Video и пакетам назначается значение DSCP AF41.

  2. Помеченные пакеты видео проходят последовательные интерфейсы S3/0 на маршрутизаторе Router1 и S0/0 на маршрутизаторе Router2. Здесь вероятность сброса пакета сравнивается с пределом, установленным для алгоритма WRED. Когда средняя длина очереди достигает минимального предела (в данном случае это 40 пакетов видео), алгоритм WRED случайным образом сбрасывает некоторые пакеты со значением DSCP AF41. Также, когда средняя длина очереди превышает максимальный предел (в данном случае это 50 пакетов видео), алгоритм WRED случайным образом сбрасывает все пакеты со значением DSCP AF41.

  3. Как только пакеты видео достигают контроллера WLC по интерфейсу fastethernet на маршрутизаторе Router2, контроллер WLC преобразует значение DSCP входящего пакета в значение AVVID 802.1p UP и копирует значение DSCP из входящего пакета в пакет LWAPP, как показано ниже. В данном примере значение DSCP, равное AF41, преобразуется в соответствующее значение 802.1p, равное 4.

    qos-wlc-lap11.gif

  4. Когда пакет достигает облегченной точки доступа, точка доступа преобразует DSCP-значение входящего пакета LWAPP в значение 802.1p UP и определяет политику для значения, чтобы оно не превышало максимальное значение для политики QoS WLAN, назначенной данному клиенту. Затем облегченная точка доступа помещает пакет в очередь 802.11 Tx, в соответствии со значением UP. В данном примере значение DSCP, равное AF41, преобразуется в соответствующее значение 802.1p, равное 5.

    qos-wlc-lap12.gif

Когда клиент видео на стороне беспроводной сети отправляет данные на клиент видео на стороне проводной сети, происходит следующее.

  1. Когда клиент с включенным WMM отправляет пакет на облегченную точку доступа, точка доступа определяет политику для значения значение 802.1p UP, чтобы оно не превышало максимальное значение для политики QoS, назначенной данному клиенту. Затем это значение преобразуется в значение DSCP. В данном примере WLAN для видео настроена с профилем QoS «Gold», которому соответствует значение 802.11e UP 4. Это значение преобразуется в соответствующее DSCP-значение AF41 и отправляется на контроллер.

    qos-wlc-lap13.gif

  2. Контроллер преобразует DSCP-значение входящего пакета LWAPP в значение 802.1p UP, как показано ниже. Кроме того, также отправляется исходное значение DSCP без изменений.

    qos-wlc-lap14.gif

  3. Пакеты со DSCP-значением af41 на интерфейсе fastethernet маршрутизатора Router2 проходят последовательные интерфейсы маршрутизаторов Router2 и Router1 и достигают клиентов видео на стороне проводной сети. Когда пакет проходит последовательные интерфейсы, вероятность сброса пакета сравнивается с пределом, установленным для алгоритма WRED.

Клиент FTP с выключенным WMM

Когда клиент FTP на стороне проводной сети отправляет данные на клиент FTP на стороне беспроводной сети, происходит следующее.

  1. На интерфейсе FastEthernet маршрутизатора Router1 к пакетам FTP применяется политика Marking-For-FTP и пакетам присваивается значение DSCP, равное AF11.

  2. Помеченные пакеты FTP проходят последовательные интерфейсы s3/0 на маршрутизаторе Router1 и S0/0 на маршрутизаторе Router2. Здесь вероятность сброса пакета сравнивается с пределом, установленным для алгоритма WRED. Когда средняя длина очереди достигает минимального предела (в данном случае это 30 пакетов FTP), алгоритм WRED случайным образом сбрасывает некоторые пакеты со значением DSCP AF11. Также, когда средняя длина очереди превышает максимальный предел (в данном случае это 40 пакетов FTP), алгоритм WRED случайным образом сбрасывает все пакеты со значением DSCP, равным AF11.

  3. Как только пакеты FTP достигают контроллера WLC по интерфейсу fastethernet на маршрутизаторе Router2, контроллер WLC преобразует значение DSCP входящего пакета в значение AVVID 802.1p UP и копирует значение DSCP из входящего пакета в пакет LWAPP, как показано ниже. В данном примере значение DSCP, равное AF11, преобразуется в соответствующее значение 802.1p, равное 1.

  4. Когда пакет достигает облегченной точки доступа, она помещает пакет в очередь 802.11 Tx по умолчанию для политики QoS WLAN, назначенной этому клиенту. В данном примере пакет помещается в очередь для профиля QoS «Bronze».

Когда клиент FTP на стороне беспроводной сети отправляет данные на клиент FTP на стороне проводной сети, происходит следующее.

  1. Когда клиент FTP отправляет пакет в беспроводной сети на облегченную точку доступа, она использует значение 802.11e UP для политики QoS, назначенной для этого клиента. Затем облегченная точка доступа преобразует это значение в значение DHCP и отправляет пакет на контроллер. Так как клиент FTP относится к профилю QoS «Bronze» значение IEEE 802.11e UP 1 преобразуется в DSCP-значение AF11.

  2. Контроллер преобразует DSCP-значение входящего пакета LWAPP в значение 802.1p UP, как показано ниже. Кроме того, также отправляется исходное значение DSCP без изменений. Затем пакет пересылается на маршрутизатор Router2 через коммутатор уровня 2.

  3. Пакеты со DSCP-значением AF11 на интерфейсе fastethernet маршрутизатора Router2 проходят последовательные интерфейсы маршрутизаторов Router2 и Router1 и достигают клиентов видео на стороне проводной сети. Когда пакет проходит последовательные интерфейсы, вероятность сброса пакета сравнивается с пределом, установленным для алгоритма WRED.

Приблизительно то же самое происходит, когда голосовой пакет проходит из проводной сети в беспроводную, и наоборот.

Команды устранения неполадок

Средство Интерпретатор выходных данных (только для зарегистрированных клиентов) (OIT) поддерживает некоторые команды show. Используйте это средство для просмотра результатов анализа выходных данных команды show.

Примечание. Перед использованием команд debug обратитесь к документу Важные сведения о командах debug.

Для устранения неполадок и проверки конфигурации QoS на маршрутизаторах можно выполнить следующие команды Cisco IOS.

  • show queue {имя-интерфейса номер-интерфейса} — вывод информации о пакетах в очереди интерфейса.

  • show queueing random-detect interface {имя-интерфейса номер-интерфейса} — вывод конфигурации и статистики средства обработки очереди интерфейса.

  • show policy-map interface {имя-интерфейса номер-интерфейса} — вывод статистики и конфигураций политик ввода и вывода, связанных с интерфейсом. Эта команда должна использоваться в соответствующем режиме EXEC.

    Router1#show policy-map interface F3/0.1
     FastEthernet3/0.1
    
      Service-policy output: Marking-For-Voice
    
        Class-map: Voice (match-all)
          18 packets, 1224 bytes
          5 minute offered rate 0 bps, drop rate 0 bps
          Match: access-group 101
          QoS Set
            dscp ef
              Packets marked 18
    
        Class-map: class-default (match-any)
          2 packets, 128 bytes
          5 minute offered rate 0 bps, drop rate 0 bps
          Match: any
  • debug qos set — вывод информации о QoS метках пакетов.

На контроллере WLC выполните следующую команду для просмотра настроек профиля QoS.

  • show qos {bronze/silver/gold/platinum} — вывод информации о профиле QoS, настроенном для WLAN.

    Ниже приведен пример выходных данных команды show qos.

    (Cisco Controller) >show qos Platinum
    
    Description...................................... For Voice Applications
    Average Data Rate................................   0
    Burst Data Rate..................................   0
    Average Realtime Data Rate.......................   0
    Realtime Burst Data Rate.........................   0
    Maximum RF usage per AP (%)...................... 100
    Queue Length..................................... 100
    protocol......................................... none
    
    (Cisco Controller) >show qos Gold
    
    Description...................................... For Video Applications
    Average Data Rate................................   0
    Burst Data Rate..................................   0
    Average Realtime Data Rate.......................   0
    Realtime Burst Data Rate.........................   0
    Maximum RF usage per AP (%)...................... 100
    Queue Length.....................................  75
    protocol......................................... none
    
    (Cisco Controller) >show qos Bronze
    
    Description...................................... For Background
    Average Data Rate................................   0
    Burst Data Rate..................................   0
    Average Realtime Data Rate.......................   0
    Realtime Burst Data Rate.........................   0
    Maximum RF usage per AP (%)...................... 100
    Queue Length.....................................  25
    protocol......................................... none
  • show wlan <WLAN-ID> — вывод информации о WLAN. Ниже приведен пример выходных данных:

    (Cisco Controller) >show wlan 1
    
    WLAN Identifier.................................. 1
    Network Name (SSID).............................. VoiceClients
    Status........................................... Enabled
    MAC Filtering.................................... Disabled
    Broadcast SSID................................... Enabled
    AAA Policy Override.............................. Disabled
    Number of Active Clients......................... 0
    Exclusionlist Timeout............................ 60 seconds
    Session Timeout.................................. 1800 seconds
    Interface........................................ management
    WLAN ACL......................................... unconfigured
    DHCP Server...................................... Default
    DHCP Address Assignment Required................. Disabled
    Quality of Service............................... Platinum (voice)
    WMM.............................................. Disabled
    CCX - AironetIe Support.......................... Enabled
    CCX - Gratuitous ProbeResponse (GPR)............. Disabled
    Dot11-Phone Mode (7920).......................... Disabled
    Wired Protocol................................... None
    IPv6 Support..................................... Disabled
    Radio Policy..................................... All
    Security
    
       802.11 Authentication:........................ Open System
       Static WEP Keys............................... Disabled
       802.1X........................................ Enabled
       Encryption:..................................... 104-bit WEP
       Wi-Fi Protected Access (WPA/WPA2)............. Disabled
       CKIP ......................................... Disabled
       IP Security Passthru.......................... Disabled
       Web Based Authentication...................... Disabled
       Web-Passthrough............................... Disabled
       Auto Anchor................................... Disabled
       H-REAP Local Switching........................ Disabled
       Management Frame Protection................... Enabled (Global MFP Disabled)

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения


Document ID: 81831