Беспроводные сети / Мобильные решения : "Беспроводные сети, LAN (WLAN)"

Пример настройки модуля контроллера беспроводной LAN

11 августа 2008 - Перевод, выполненный профессиональным переводчиком
Другие версии: PDF-версия:pdf | Машинный перевод (28 июля 2013) | Английский (19 февраля 2007) | Отзыв

Содержание

Введение
Предварительные условия
     Требования
     Используемые компоненты
     Условные обозначения
Базовая настройка
Пример 1 Базовая настройка с точкой доступа, подключенной к маршрутизатору на плате Fast Ethernet/Gigabit Ethernet
     Настройка контроллера
     Настройка маршрутизатора
Пример 2 – Настройки VLAN с точками доступа, подключенными к внешнему коммутатору
     Настройка контроллера
     Настройка коммутатора
     Настройка маршрутизатора
Пример 3 – Настройки с точками доступа, подключенными к коммутатору Ethernet на маршрутизаторе, и объединение соответствующих VLAN из проводных и беспроводных LAN
Пример 4 – Настройки с проводными VLAN в NME-ESW, объединенными с беспроводными VLAN в NM-WLC
     Настройки маршрутизатора
     Настройки коммутатора
Связанные обсуждения сообщества поддержки Cisco
Дополнительные сведения

Введение

Модуль контроллера WLAN (WLC) Cisco (WLCM) позволяет Cisco ISR и маршрутизаторам Cisco серии 3700 управлять шестью точками доступа (AP) беспроводной LAN (WLAN) и упрощает развертывание и управление WLAN. Он эквивалентен Cisco WLC 2006, помещенному в конструктив NM. Единственное различие заключается в том, что NM-WLC (модуль WLCM) обладает только одним портом Fast Ethernet, внутренне подключенным к главному маршрутизатору, а внешний порт Fast Ethernet на передней панели NM отключен и не используется. В данном документе объясняется настройка WLCM по разным сценариям.

Предварительные условия

Требования

Убедитесь, что вы обеспечили выполнение следующих требований, прежде чем попробовать эту конфигурацию.

  • Основные сведения об протоколе упрощенных точек доступа (LWAPP; Lightweight Access Point Protocol)

  • Основные сведения о WLC и упрощенных точках доступа (LAP; Lightweight AP)

Используемые компоненты

Настоящий документ не имеет жесткой привязки к устройству или какой-либо версии ПО.

Условные обозначения

Дополнительную информацию об используемых в документе обозначениях см. в разделе Условные обозначения, используемые в технической документации Cisco.

Базовая конфигурация

Можно представить себе NM-WLC как внешний WLC (2006) только с одним интерфейсом Fast Ethernet (FE) (известным, как порт 1), внутренне подключенным к интерфейсу Fast Ethernet маршрутизатора, известного как интерфейс контроллера WLAN. Данный пример представлен на рисунке.

Примечание. Внешний порт FastEthernet на передней панели модуля Cisco WLC не поддерживается.

nm-wlc-config-guide-1.gif

Обычный способ подключения модуля – это внутренне подключить его в маршрутизаторе с помощью команды service-module session.

  1. Вставьте модуль NM-WLC в маршрутизатор и загрузите его нужным ПО.

    Любое ПО (от ipbase до adventerprisek9) поддерживает модуль NM-WLC. Данная функция была представлена в ПО Cisco IOS версии 12.4(2)XA1 (ПО маршрутизатора). Минимальная версия микропрограммного обеспечения контроллера должна быть 3.2.78.0 (ПО контроллера).

  2. Настройте IP-адрес через interface wlan-controller 1/0, при условии, что модуль подключен к слоту 1 маршрутизатора. Выполните no shut, если он выключен.

    c2811#configure terminal
    Enter configuration commands, one per line.  End with CNTL/Z.
    c2811(config)#
    c2811(config)#interface wlan-controller 1/0
    c2811(config-if)#ip address 192.168.99.254 255.255.255.0
    c2811(config-if)#no shut
    c2811(config-if)#end
    c2811#
  3. В привилегированном режиме "exec", откройте сеанс для контроллера, используя команду service-module session.

    c2811#service-module wlan-controller 1/0 session 
    Trying 192.168.99.254, 2066 ... Open

Если контроллер подключается впервые и не имеет никакой предварительной конфигурации, он автоматически входит в мастер настройки CLI, который запрашивает некоторые сведения о конфигурации. Данного мастера настройки невозможно обойти. Необходимо ввести все запрашиваемые сведения. Понимание того, как должна выглядеть конфигурация по завершению, помогает дать ответы на все поставленные вопросы. Некоторые сведения не являются важными и не используются немедленно, но все же необходимо предоставить их, так как недопустимый ввод не принимается, и обойти это невозможно. Отображаются выходные данные идентичные выходным данным, указанным в данной таблице:

Контроллер Cisco

Welcome to the Cisco Wizard Configuration Tool
Use the '-' character to backup
System Name [Cisco_ff:f6:a0]: NMWLC
Enter Administrative User Name (24 characters max): admin
Enter Administrative Password (24 characters max): *****
 
Management Interface IP Address: 192.168.99.24
Management Interface Netmask: 255.255.255.0
Management Interface Default Router: 192.168.99.254 
Management Interface VLAN Identifier (0 = untagged): 0
Management Interface Port Num [1]: 1
Management Interface DHCP Server IP Address: 192.168.99.24
 
AP Manager Interface IP Address: 192.168.99.25
 
AP-Manager is on Management subnet, using same values
AP Manager Interface DHCP Server (192.168.99.24): 192.168.99.24
 
Virtual Gateway IP Address: 1.1.1.1
 
Mobility/RF Group Name: mg1
 
Network Name (SSID): wl15
Allow Static IP Addresses [YES][no]: no
 
Configure a RADIUS Server now? [YES][no]: no
Warning! The default WLAN security policy requires a RADIUS server.
Please see documentation for more details.
 
Enter Country Code (enter 'help' for a list of countries) [US]: US
 
Enable 802.11b Network [YES][no]: YES
Enable 802.11a Network [YES][no]: YES
Enable 802.11g Network [YES][no]: YES
Enable Auto-RF [YES][no]: no
Configuration saved!
Resetting system with new configuration...

По завершению конфигурации происходит автоматическая перезагрузка с использованием новой конфигурации, и останавливается на приглашении User:, где необходимо указать имя пользователя и пароль. Затем отображается приглашение (Cisco Controller) >.

User:admin
Password:*****
(Cisco Controller) >

Как только отобразилось приглашение контроллера, можно продолжить дальнейшую настройку или внести изменения того, что было сделано через мастер настройки CLI. Чтобы получить справку используйте команду ?.

Чтобы перейти обратно к маршрутизатору, нажмите сочетание клавиш ctrl+shift+6, отпустите их, затем нажмите клавишу x. В результате этого выполняется переход к командной строке маршрутизатора. Данное действие не закрывает сеанс, при нажатии клавиши "Enter", произойдет переход обратно к контроллеру. Если необходимо полностью закрыть сеанс, в командной строке маршрутизатора введите disconnect.

Хотя контроллер обладает только одним физическим портом (известным как порт 1), на нем можно создать любое количество логических интерфейсов, статических или динамических. Данные интерфейсы могут иметь или не иметь теги VLAN. По умолчанию контроллер имеет два статических и не отмеченных тегами интерфейса:

  • Управляющий интерфейс

  • Интерфейс менеджера точек доступа

Управляющий интерфейс используется в целях управления. Если для управления WLCM будет выбран веб-интерфейс GUI, на управляющем интерфейсе необходимо настроить IP-адрес и сделать его доступным с тех рабочих станций, с которых планируется управление.

Примечание. По умолчанию сервер HTTP контроллера отключен, но включен защищенный HTTP. Таким образом, URL для IP-адреса управления контроллером должен быть https://ip-адрес для управления.

Интерфейс менеджера точек доступа используется контроллером для взаимодействия с LAP. Так как оба интерфейса (менеджер точек доступа и управляющий) не отмечены тегами, они должны находиться в той же подсети IP, что и интерфейс WLC маршрутизатора.

(Cisco Controller) >config
(Cisco Controller) config>interface address management 192.168.99.24 255.255.255.0 192.168.99.254
(Cisco Controller) config>interface address ap-manager 192.168.99.25 255.255.255.0 192.168.99.254

CLI можно настроить двумя способами. Первый - из обычной командной строки набрать config и потом CLI. Другой способ - это перейти к командной строке конфигурации с помощью команды config, а затем ввести CLI без использования слова "config". Пример:

 (Cisco Controller) >config
(Cisco Controller) config>interface address management 192.168.99.24 255.255.255.0 192.168.99.254

или

(Cisco Controller)>config interface address management 192.168.99.24 255.255.255.0 192.168.99.254

В данном примере показаны настройка управляющего интерфейса с IP-адресом 192.168.99.24/24 и определение шлюза по умолчанию: 192.168.99.254.

Примечание. Шлюз по умолчанию интерфейса точек доступа и управляющего интерфейса должен указывать на IP-адрес Ethernet порта WLCM.

Примечание. После настройки данных IP-адресов с помощью мастера настройки, эти команды не нужны. Они приведены только для того, чтобы показать, что эти IP-адреса принадлежат к одной подсети и, что их можно настроить с помощью командной строки.

В обоих случаях, последний IP-адрес (192.168.99.254) является IP-адресом шлюза по умолчанию. Поскольку единственный способ выйти из контроллера – это через основной маршрутизатор, шлюз по умолчанию должен иметь IP-адрес интерфейса wlan-controller1/0 маршрутизатора. С данной конфигурацией можно выполнить запрос "ICMP-эхо" с маршрутизатора на IP-адрес управляющего интерфейса контроллера.

c2811#ping 192.168.99.24
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.99.24, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
c2811# 

Пример 1 – Базовая настройка с точкой доступа, подключенной к маршрутизатору на плате Fast Ethernet/Gigabit Ethernet

Когда LAP подключенная к встроенному интерфейсу Gigabit Ethernet (g0/0) маршрутизатора, включена, она посылает DHCP-запрос об IP-адресе. В данном примере маршрутизатор настроен в качестве DHCP-сервера с пулом IP-адресов сети 192.168.100.0/24. Поэтому LAP получает IP-адрес 192.168.100.101. Предложение DHCP так же сообщает LAP (через опцию 43), что IP-адресом контролера является 192.168.99.24 (управляющий IP-адрес контроллера). Теперь LAP отсылает одноадресное сообщение поиска контроллера на 192.168.99.24. Контроллер предлагает регистрацию и в результате LAP регистрируется в контроллере.

Чтобы увидеть, какие LAP зарегистрированы в WLCM, используйте команду show ap summary.

(Cisco Controller) >show ap summary

AP Name             Slots  AP Type    MAC Addr           Location          Port
------------------  -----  ---------  -----------------  ---------------- 	----
AP11                 2     Cisco      00:0b:85:01:03:30                   		 1

В данном примере контроллер настроен c двумя WLAN (wl15 и wl16), как описано дальше в данном документе.

Клиент C1 отсылает запрос связи, содержащий SSID wl15. Происходит связь, и с DHCP-сервера, сконфигурированного на маршрутизаторе, он получает IP-адрес 192.168.15.101 и шлюз по умолчанию 192.168.15.1.

Клиент C2 также посылает запрос связи с SSID wl16. Происходит связь, и он получает IP-адрес 192.168.16.101 и шлюз по умолчанию 192.168.15.1. Теперь в двух разных подсетях существует два клиента. Связь между ними возможна с помощью маршрутизатора, который выполняет маршрутирование между двумя субинтерфейсами (wlc1/0.15 и wlc1/0.16), как показано на рисунке:

Настройка устройств, необходимая для данной схемы, рассматривается в разделе Настройка контроллера данного документа.

nm-wlc-config-guide-2.gif

Настройка контроллера

В данном разделе описывается настройка, необходимая для модуля контроллера.

  1. Создайте два динамических интерфейса с именем vl15 для VLAN 15 и vl16 для VLAN 16.

    (Cisco Controller) >config interface create vl15 15
    (Cisco Controller) >config interface create vl16 16
    
  2. Для данных VLAN интерфейсов назначьте IP-адрес, маску подсети и шлюз по умолчанию.

    (Cisco Controller) >config interface address vl15 
    192.168.15.254 255.255.255.0 192.168.15.1
    
    (Cisco Controller) >config interface address vl16 
    192.168.16.254 255.255.255.0 192.168.16.1
    

    Примечание. Шлюз по умолчанию для динамических интерфейсов должен являться IP-адресом субинтерфейса маршрутизатора для соответствующих VLAN.

  3. Создайте две WLAN 15 и 16 с соответствующими SSID wl15 и wl16.

    (Cisco Controller) >wlan create 15 wl15
    (Cisco Controller) >wlan create 16 wl16
    
  4. Свяжите эти WLAN с созданными соответствующими интерфейсами VLAN (на стороне проводной сети).

    (Cisco Controller) >wlan interface 15 vl15
    (Cisco Controller) >wlan interface 16 vl16
    
  5. Настройте созданные вами динамические интерфейсы на пересылку клиентских DHCP-запросов с IP-адресом DHCP-сервера.

    Так как DHCP-сервер сконфигурирован на маршрутизаторе, он должен указывать на соответствующие IP-адреса субинтерфейсов маршрутизатора. При внешнем DHCP-сервере, на этот IP-адрес должен указывать он.

    (Cisco Controller) >interface dhcp vl15 192.168.15.1
    (Cisco Controller) >interface dhcp vl16 192.168.16.1
    
  6. Способ аутентификации по умолчанию – dot1X. Он активизирован. Чтобы работать с открытой аутентификацией, отключите его с помощью данной команды для обеих WLAN:

    (Cisco Controller) >wlan security 802.1X disable 15
    (Cisco Controller) >wlan security 802.1X disable 16
    

Данная конфигурация может быть расширена в соответствии с потребностями, например больше VLAN/WLAN, аутентификации (упрощенный расширяемый протокол аутентификации [LEAP], EAP), QoS и т.д.

Примечание. При наличии WLCM, для LAP становится труднее обнаружить WLCM через широковещательный IP-адрес подсети. Это происходит из-за способа интегрирования WLCM в объединительную плату, и LAP и интерфейс Gigabit маршрутизатора 2800, который напрямую подключен к LAP, должен быть одной и той же подсетью. Если необходимо успешно выполнить широковещательное обнаружение IP-подсети, используйте команды ip helper-address/ip forward-protocol udp 12223. Общее назначение данных команд - пересылать или ретранслировать потенциально любой широковещательный IP-кадр. Простое подключение и направление его на управляющий интерфейс WLC должно быть достаточным, чтобы WLC отправлял ответ обратно к LAP.

Примечание. Все конфигурации контроллера, указанные в данном разделе, можно с легкостью выполнить через GUI посредством веб-обозревателя, сразу после того, как управляющий интерфейс получит IP-адрес, маски подсети и шлюз. Так же необходима маршрутизация на сети для доступа к контроллеру со станций с браузером. URL для открытия страницы GUI – https://192.168.99.24.

Настройка маршрутизатора

Чтобы настроить маршрутизатор, выполните следующие действия, указанные в данном разделе.

  1. Настройте интерфейс G0/0 на маршрутизаторе, который подключен к LAP.

  2. Назначьте интерфейсу wlan-controller 1/0 IP-адрес сети 192.168.99.0/24, а субинтерфейсам w1/0.15 для VLAN 15 и w1/0.16 для VLAN 16 - IP-адреса сетей 192.168.15.0/24 и 192.168.16.0/24.

  3. Настройте DHCP-сервер в маршрутизаторе с указанием нескольких пулов.

    • Пул lwapp-ap назначает IP-адреса точкам доступа из сети 192.168.100.0/24, которая также включает в себя DHCP параметр 43, который информирует AP об IP-адресе контроллера, необходимого для установления соединения.

    • Пул client-15 назначает IP-адреса клиентам (проводным/беспроводным) для VLAN 15 из сети 192.168.15.0/24.

    • Пул client-16 назначает IP-адреса клиентам (проводным/беспроводным) для VLAN 16 из сети 192.168.16.0/24.

В приведенных ниже выходных данных представлена конфигурация маршрутизатора:

Маршрутизатор

!		
interface GigabitEthernet0/0								
Description: Connected to AP							
 ip address 192.168.100.1 255.255.255.0						
 load-interval 30									
 duplex auto									
 speed auto
									
!										
ip dhcp excluded-address 192.168.100.1 192.168.100.100
!
ip dhcp pool lwapp-ap
!--- Создает пул DHCP для LAP.

network 192.168.100.0 255.255.255.0
default-router 192.168.100.1 
option 43 ascii "192.168.99.24"
!
ip dhcp pool vlan-15
!--- Создает пул DHCP для пользователей, которые подключаются к WLAN wl15.

network 192.168.15.0 255.255.255.0
default-router 192.168.15.1 
!
ip dhcp pool vlan-16
!--- Создает пул DHCP для пользователей, которые подключаются к WLAN wl16.

network 192.168.16.0 255.255.255.0
default-router 192.168.16.1 
!										
interface wlan-controller1/0								
 ip address 192.168.99.254 255.255.255.0							
!										
interface wlan-controller1/0.15
!--- Создает субинтерфейс для VLAN 15.
						
encapsulation Dot1q 15								
ip address 192.168.15.1 255.255.255.0							
!										
interface wlan-controller 1/0.16
!--- Создает субинтерфейс для VLAN 16.
					
encapsulation Dot1q 16								
ip address 192.168.16.1 255.255.255.0							
!

Пример 2 – Настройка виртуальной VLAN с точками доступа, подключенными к внешнему коммутатору

WLCM, подключенный к маршрутизатору, может считаться логически эквивалентным внешнему WLC, подключенному к маршрутизатору посредством интерфейса Ethernet, как показано на приведенной ниже схеме. С учетом предположения, что сетевой модуль установлен в слот 1 маршрутизатора, типичное соединение состоит из:

  • WLCM, подключенного к маршрутизатору через интерфейс wlan-controller 1/0;

  • коммутатора уровня 2, подключенного к маршрутизаторам на Gigabit Ethernet G0/0;

  • точки доступа протокола LWAPP, подключенной к коммутатору;

  • беспроводных клиентов C1 и C2, связанных с AP: одного во WLAN 15, а другого во WLAN 16.

В данном примере показано создание двух беспроводных VLAN или WLAN (wl15 и wl16) на контроллере, сопоставленных VLAN 15 и VLAN 16 на соответствующей проводной стороне, и процесс выполнения маршрутизатором маршрутизации между VLAN 15 и VLAN 16 через субинтерфейсы dot1Q.

На маршрутизаторе для каждой VLAN создайте один субинтерфейс в интерфейсе WLC (в режиме конфигурации интерфейса), назначьте его соответствующей VLAN и настройте IP-адрес из соответствующих подсетей.

Дополнительные сведения о конфигурации устройств, необходимой для данной настройки см.в разделе Настройка контроллера данного документа.

nm-wlc-config-guide-3.gif

Настройка контроллера

Для данной настройки модуля контроллера выполните следующие действия.

  1. На контроллере для каждой VLAN создайте один динамический интерфейс в соответствующей VLAN, и назначьте IP-адрес, маску подсети и шлюзы по умолчанию.

    (Cisco Controller)#configure interface create vl15 15
    (Cisco Controller)#configure interface create vl16 16
    
    (Cisco Controller)#configure interface address Vl15 192.168.15.254 255.255.255.0 192.168.15.1
    (Cisco Controller)#configure interface address Vl16 192.168.16.254 255.255.255.0 192.168.16.1
    
  2. Создайте две WLAN 15 и 16 с соответствующими SSID wl15 и wl16.

    (Cisco Controller)#configure wlan create 15 wl15
    (Cisco Controller)#configure wlan create 16 wl16
    
  3. Свяжите эти WLAN с созданными соответствующими интерфейсами VLAN (на стороне проводной сети).

    (Cisco Controller)#configure wlan interface 15 Vl15
    (Cisco Controller)#configure wlan interface 16 Vl16
    
  4. Настройте данные для DHCP-сервера на интерфейсах контроллеров (для беспроводных клиентов), которые указывали бы на соответствующие IP-адреса субинтерфейсов на маршрутизаторе.

    (Cisco Controller)#configure interface dhcp vl15 192.168.15.1
    (Cisco Controller)#configure interface dhcp Vl16 192.168.16.1
    

С данной конфигурацией, два беспроводных клиента в двух WLAN должны функционировать нормально, с учетом предположения, что выполнена надлежащая настройка безопасности. Трафик клиента WLAN 15, предназначенный для WLAN 16, маршрутируется между субинтерфейсами w1/0.15 и w1/0.16 маршрутизатора. Такая же конфигурация может быть расширена для любого количества VLAN, поддерживаемых контроллером (до 16).

Настройка коммутатора

С предположением того, что все проводные клиенты подключены к коммутатору (например cat3750), который магистрально соединен с маршрутизатором через интерфейс Gig 1/0/1 для маршрутизации между LAN, подключите точки доступа LWAPP к интерфейсу F1/0/1 коммутатора и настройте его для VLAN 100.

Interface Fastethernet 1/0/1
Description: Connected to LWAPP AP
Switchport access vlan 100
Switchport mode access
!
Interface Gigabitethernet 1/0/1
Description: Connected to Router
Switchport trunk encapsulation dot1Q
Switchport mode trunk

Настройка маршрутизатора

На маршрутизаторе выполните следующие действия.

  1. Настройте интерфейс G0/0, который подключен к коммутатору, а также необходимые субинтерфейсы для маршрутизации между VLAN для проводных LAN.

  2. Назначьте интерфейсу wlan-controller 1/0 IP-адрес сети 192.168.99.0/24, а субинтерфейсам w1/0.15 для VLAN 15 и w1/0.16 для VLAN 16 - IP-адреса сетей 192.168.15.0/24 и 192.168.16.0/24.

  3. Настройте DHCP-сервер в маршрутизаторе с указанием нескольких пулов.

    • Пул lwapp-ap назначает IP-адреса точкам доступа из сети 192.168.100.0/24, которая также включает в себя DHCP параметр 43, который информирует AP об IP-адресе контроллера, необходимого для установления соединения.

    • Пул client-15 назначает IP-адреса клиентам (проводным/беспроводным) для VLAN 15 из сети 192.168.15.0/24.

    • Пул client-16 назначает IP-адреса клиентам (проводным/беспроводным) для VLAN 16 из сети 192.168.16.0/24.

    Примечание. Для AP и клиентов необходимы отдельные пулы.

Маршрутизатор

ip dhcp excluded-address 192.168.100.1 192.168.100.100
ip dhcp pool lwapp-ap
network 192.168.100.0 255.255.255.0
default-router 192.168.100.1 
option 43 ascii "192.168.99.24"
								
ip dhcp pool client-15
network 192.168.15.0 255.255.255.0
default-router 192.168.15.1 

ip dhcp pool client-16
network 192.168.16.0 255.255.255.0
default-router 192.168.16.1 
!
interface GigabitEthernet0/0
Description: Connected to AP
No ip address							
 load-interval 30									
 duplex auto									
 speed auto
!
interface GigabitEthernet0/0.100
encapsulation dot1Q 100
ip address 192.168.100.1 255.255.255.0	
interface wlan-controller1/0								
 ip address 192.168.99.254 255.255.255.0							
!										
interface wlan-controller1/0.15								
encapsulation Dot1q 15								
ip address 192.168.15.1 255.255.255.0							
!										
interface wlan-controller 1/0.16							
encapsulation Dot1q 16								
ip address 192.168.16.1 255.255.255.0

Примечание. Службы DHCP для клиентов можно запустить и на контроллере. Но рекомендуется запускать их на маршрутизаторе, так как контроллер не является полноценным DHCP-сервером и не может передавать параметры как, например, TFTP-сервер, необходимый для таких приложений, как Cisco CallManager Express.

С данной конфигурацией, AP может получить IP-адрес, найти контроллер и зарегистрироваться в нем. Два беспроводных клиента C1 и C2 должны быть способны связываться с AP и получить IP-адрес в соответствующих подсетях.

Пример 3 – Настройки с точками доступа, подключенными к коммутатору Ethernet на маршрутизаторе, и объединение соответствующих VLAN из проводных и беспроводных LAN

В данном сценарии HWIC коммутатора Ethernet подключен к слоту 0 HWIC ISR, а NM-WLC подключен к слоту 1 NM. Проводной клиент C3 подключен к интерфейсу F0/0/1 во VLAN 15 с IP-адресом 192.168.15.102 и проводной клиент C4, подключен к F0/0/2 во VLAN 16 с IP-адресом 192.168.16.102.

LWAPP AP подключены к интерфейсу F0/0/0 во VLAN 100 с IP-адресом 192.168.100.1. Маршрутизатор настроен в качестве DHCP-сервера для обслуживания IP-адреса AP. Например, AP получает IP-адрес 192.168.100.101, шлюз по умолчанию 192.168.100.1 и IP-адрес контроллера 192.168.99.24 посредством опции 43.

Примечание. Необходимая конфигурация контроллера похожа на конфигурацию, описанную в предыдущем примере, и поэтому не приведена в данном разделе. В оставшихся разделах описывается необходимая конфигурация маршрутизатора.

nm-wlc-config-guide-4.gif

Беспроводные клиенты C1 и C2 связываются с LAP в wl15 и wl16 соответственно. Беспроводные клиенты C1 и C2 также получают IP-адрес 192.168.15.101 и 192.168.16.101, назначенный DHCP-сервером, настроенном на маршрутизаторе, или внешним DHCP-сервером с IP-пулами данных подсетей. Если DHCP-сервер внешний, на соответствующих VLAN и субинтерфейсах необходимо настроить вспомогательный IP-адрес. С позиции маршрутизатора, у него есть две проводные VLAN, представленные интерфейсами VLAN 15 и VLAN 16, и две беспроводные VLAN, представленные субинтерфейсами dot1Q w1/0.15 и w1/0.16 в WLC-интерфейсе маршрутизатора.

Чтобы объединить проводную VLAN 15 и беспроводную WLAN 15, определите интерфейс VLAN 15 и интерфейс w1/0.15 в общей группе мостов, например, группе мостов 15. Подобно этому, чтобы объединить проводную VLAN 16 и беспроводную WLAN 16, определите интерфейс VLAN 16 и интерфейс w1/0.16 в общую группу мостов, например, группу мостов 16. С данной конфигурацией, соответствующие проводные и беспроводные VLAN принадлежат одним и тем же IP подсетям 192.168.15.0/24 и 192.168.16.0/24 и могут взаимодействовать друг с другом внутри группы моста. Но чтобы клиенты двух разных групп моста взаимодействовали друг с другом, необходимо включить на маршрутизаторе интегрированную маршрутизацию и соединение с помощью мостов (IRB; Integrated Routing and Bridging), чтобы процесс взаимодействия происходил посредством интерфейсов BVI в соответствующих группах моста.

Примечание. Данная конфигурация основана на предположении, что на маршрутизаторе проводной LAN стоит EtherSwitch HWIC или NM-ESW. Если вместо NM/HWIC стоит сервисный модуль EtherSwitch (NME-ESW), интерфейсы VLAN замещаются соответствующими субинтерфейсами dot1Q в интерфейсе Gigabit Ethernet маршрутизатора, а оставшаяся конфигурация остается такой же.

Настройка маршрутизатора

!

ip dhcp excluded-address 192.168.100.1 192.168.100.100
ip dhcp excluded-address 192.168.15.1 192.168.15.100
ip dhcp excluded-address 192.168.16.1 192.168.16.100
!
ip dhcp pool lwapp-ap
network 192.168.100.0 255.255.255.0
default-router 192.168.100.1 
option 43 ascii "192.168.99.24"
!
ip dhcp pool vlan-15
network 192.168.15.0 255.255.255.0
default-router 192.168.15.1 
!
ip dhcp pool vlan-16
network 192.168.16.0 255.255.255.0
default-router 192.168.16.1 


interface FastEthernet0/0/0								
Description: Connected to AP
Switchport mode access
Switchport access vlan 100
!
interface FastEthernet0/0/1								
Description: Connected to C3
Switchport mode access
Switchport access vlan 15
!
interface FastEthernet0/0/2								
Description: Connected to C4
Switchport mode access
Switchport access vlan 16
!
Interface vlan 15
Bridge-group 15
!
Interface vlan 16
Bridge-group 16

Interface vlan 100							
 ip address 192.168.100.1 255.255.255.0						
 load-interval 30									
 !
interface wlan-controller1/0								
 ip address 192.168.99.254 255.255.255.0							
!										
interface wlan-controller1/0.15								
encapsulation Dot1q 15								
bridge-group 15							
!										
interface wlan-controller 1/0.16							
encapsulation Dot1q 16								
bridge-group 16									
!										
Bridge irb
Bridge 15 route ip
Bridge 16 route ip

Interface bvi 15
Ip address 192.168.15.1 255.255.255.0
!
Interface bvi 16
Ip address 192.168.16.1 255.255.255.0

Пример 4 – Настройки с проводными VLAN в NME-ESW, объединенными с беспроводными VLAN в NM-WLC

Рассмотрим следующий сценарий, где сервисный модуль EtherSwitch (NME-ESW) установлен в слот 2 ISR NM, а NM-WLC установлен в слот 1 NM. NME-ESW можно считать эквивалентным внешнему коммутатору, подключенному к маршрутизатору через канал Gigabit Ethernet. Проводной клиент C3 подключен к интерфейсу F0/0/1 во VLAN 15 с IP-адресом 192.168.15.102, а проводной клиент C4 к F0/0/2 - во VLAN 16 с IP-адресом 192.168.16.102.

AP LWAPP подключена к интерфейсу F0/0/3 во VLAN 100. Внутренний интерфейс EtherSwitch (G1/0/2) внутренне подключен к основному маршрутизатору через интерфейс Gigabit Ethernet 2/0. Так в коммутаторе больше чем одна VLAN, внутренний канал между коммутатором и маршрутизатором необходимо настроить в качестве магистрального канала. Чтобы предоставлять IP-адреса для точек доступа и клиентов (проводных и беспроводных), маршрутизатор настроен в качестве DHCP-сервера с несколькими пулами.

AP получает IP-адрес 192.168.100.101, шлюз по умолчанию 192.168.100.1 и IP-адрес контроллера 192.168.99.24 посредством опции 43, а также определяется контроллером и регистрируется в нем. Беспроводные клиенты C1 и C2 взаимодействуют с LAP во WLAN 15 и 16, и получают IP-адреса 192.168.15.101 и 192.168.16.101 соответственно. Проводные клиенты C3 и C4 во VLAN 15 и 16 получают IP-адреса 192.168.15.102 и 192.168.16.102 от DHCP-сервера.

Чтобы осуществить объединение проводной VLAN 15 с беспроводной WLAN 15, определите интерфейсы G2/0.15 и интерфейс w1/0.15 в общей группе мостов 15. Подобным образом объедините группу 16 в интерфейсах G2/0.16 и W1/0.16. Две группы мостов взаимодействуют друг с другом через их интерфейсы BVI BVI15 и BVI16.

Конфигурация контроллера остается такой же, как было указано в сценариях, приведенных выше.

nm-wlc-config-guide-5.gif

Настройка маршрутизатора

Настройка маршрутизатора

!

ip dhcp excluded-address 192.168.100.1 192.168.100.100
ip dhcp excluded-address 192.168.15.1 192.168.15.100
ip dhcp excluded-address 192.168.16.1 192.168.16.100
!
ip dhcp pool lwapp-ap
network 192.168.100.0 255.255.255.0
default-router 192.168.100.1 
option 43 ascii "192.168.99.24"
!
ip dhcp pool vlan-15
network 192.168.15.0 255.255.255.0
default-router 192.168.15.1 
!
ip dhcp pool vlan-16
network 192.168.16.0 255.255.255.0
default-router 192.168.16.1 
!
interface GigabitEthernet2/0								
Description: Internally connected to Etherswitch
IP address 20.0.0.1 255.255.255.0
load-interval 30
!
Interface GigabitEthernet2/0.100
Encapsulation dot1Q 100							
 ip address 192.168.100.1 255.255.255.0						

Interface GigabitEthernet2/0.15
Encapsulation dot1Q 15							
 Bridge-group 15
!
Interface GigabitEthernet2/0.16
Encapsulation dot1Q 16							
Bridge-group 16									
 !
interface wlan-controller1/0								
 ip address 192.168.99.254 255.255.255.0							
!										
interface wlan-controller1/0.15								
encapsulation Dot1q 15								
bridge-group 15							
!										
interface wlan-controller 1/0.16							
encapsulation Dot1q 16								
bridge-group 16									
!										
Bridge irb
Bridge 15 route ip
Bridge 16 route ip

Interface bvi 15
Ip address 192.168.15.1 255.255.255.0
!
Interface bvi 16
Ip address 192.168.16.1 255.255.255.0

Настройка коммутатора

Откройте сеанс из маршрутизатора к сервисному модулю EtherSwitch, используя команду service-module session. Войдя в коммутатор, настройте его, как показано в приведенных ниже выходных данных:

!
Interface GigabitEthernet 1/0/2
Description: Internally connected to router G2/0 interface.
Switchport trunk encapsulation dot1Q
Switchport mode trunk

!
Interface Fastethernet 0/0/1
Description: Connected to Client C3 in vlan 15
Switchport access vlan 15
Switchport mode access
!
Interface Fastethernet 0/0/2
Description: Connected to Client C4 in vlan 16
Switchport access vlan 16
Switchport mode access
!
Interface Fastethernet 0/0/3
Description: Connected to Client LWAPP AP in vlan 100
Switchport access vlan 100
Switchport mode access

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения


Document ID: 70530