Коммутация LAN : Виртуальные локальные сети / Протокол VTP

Установление магистрального соединения 802.1Q между коммутаторами Catalyst, работающими под управлением системного ПО CatOS и Cisco IOS

8 августа 2008 - Перевод, выполненный профессиональным переводчиком
Другие версии: PDF-версия:pdf | Машинный перевод (28 июля 2013) | Английский (17 ноября 2007) | Отзыв

Содержание

Введение
Предварительные условия
     Требования
     Используемые компоненты
     Условные обозначения
     Базовые сведения
Настройка
     Схема сети
     Конфигурации
Проверка
     Команды show
     Пример выходных данных команды show
Поиск и устранение неполадок
Связанные обсуждения сообщества поддержки Cisco
Дополнительные сведения

Введение

В этом документе содержатся образцы конфигураций для установления магистрального соединения IEEE 802.1Q между коммутаторами Catalyst, работающими под управлением системного ПО Catalyst OS (CatOS), и модульными коммутаторами третьего уровня (L3), работающими под управлением системного ПО Cisco IOS®. К коммутаторам, работающим под управлением CatOS, относятся коммутаторы Catalyst серий 4500/4000, 5500/5000 и 6500/6000. К модульным коммутаторам 3-го уровня, работающим под управлением программного обеспечения Cisco IOS, относятся коммутаторы Catalyst серий 4500/4000 и 6500/6000. В примерах конфигураций используются коммутаторы Catalyst 4000 (CatOS) и Catalyst 6500 (ПО Cisco IOS), но для получения тех же результатов могут использоваться любые из вышеупомянутых коммутаторов.

С помощью установления магистрального соединения передается трафик из нескольких виртуальных локальных сетей через двухточечное соединение между двумя данными устройствами. Существует два способа реализации магистрального соединения Ethernet:

  • Протокол ISL (Протокол передачи данных между коммутаторами, это проприетарный протокол Cisco);

  • 802.1Q (стандарт IEEE).

Предварительные условия

Требования

Системные требования, нормы и ограничения стандартов 802.1Q и ISL для коммутаторов Catalyst см. в документе Системные требования к реализации магистрального соединения.

Используемые компоненты

Для подготовки примеров в данном документе было использовано следующее оборудование:

  • коммутатор Catalyst 4000 с управляющим модулем Supervisor Engine II (WS-X4013) под управлением ПО CatOS версии 8.1.3;

  • коммутатор Catalyst 6509 с управляющим модулем Supervisor Engine 2 или платой многоуровневой коммутации MSFC2 (Multilayer Switch Feature Card 2) под управлением ПО Cisco IOS версии 12.1(20)E2 на модуле Supervisor Engine и плате MSFC2.

Данные для этого документа были получены при тестировании указанных устройств в специально созданных лабораторных условиях. Все устройства, используемые в этом документе, запускались с чистой (заданной по умолчанию) конфигурацией. Если сеть работает в реальных условиях, при использовании каждой команды следует адекватно оценивать ее потенциальное воздействие.

Условные обозначения

Дополнительные сведения о применяемых в документе обозначениях см. в разделе Условные обозначения, используемые в технической документации Cisco.

Базовые сведения

В данном документе рассматриваются только примеры файлов конфигурации для коммутаторов, а также выходные данных соответствующих команд show. Дополнительные сведения о настройке магистрального соединения 802.1Q между коммутаторами Catalyst см. в документе Страницы поддержки продуктов для локальных сетей.

В магистральном соединении 802.1Q все пакеты виртуальных локальных сетей (VLAN) помечаются на магистральном канале, за исключением собственной сети. Пакеты собственной виртуальной сети отправляются по магистральному каналу без разметки. Поэтому собственная сеть VLAN должна быть одинаковой на обоих коммутаторах, настроенных на магистральное соединение. Таким образом, можно выяснить, к какой сети VLAN относится кадр, полученный без метки. По умолчанию VLAN 1 является собственной сетью VLAN для всех коммутаторов.

  • В CatOS собственную сеть VLAN можно переопределить, задав команду set vlan vlan-id mod/port, где mod/port – магистральный порт.

  • В ПО Cisco IOS собственную виртуальную сеть можно переопределить, задав команду switchport trunk native vlan vlan-id interface, которая настраивается в магистральном порту.

Настройка

В этом разделе приводится информация по настройке функций, описанных в данном документе.

Конфигурации, рассматриваемые в этом документе, были реализованы в изолированной среде. Перед использованием любой конфигурации или команды необходимо оценить ее потенциальное воздействие на сеть. Конфигурации всех устройств были очищены командами clear config all и write erase для того, чтобы обеспечить конфигурации по умолчанию для данных устройств.

Примечание. Чтобы найти дополнительные сведения о командах, применяемых в этом документе, используйте Средство поиска команд leavingcisco.com (только для зарегистрированных клиентов).

Схема сети

В данном документе используется следующая настройка сети.

67-a.gif

Конфигурации

В данном документе используются следующие конфигурации:

Примечание. Замечания и пояснения выделены синим курсивом.

Коммутатор Catalyst 4000

#version 8.1(3)
!
!
#system web interface version(s)
!
#system
set system name  cat4000
!
#frame distribution method
set port channel all distribution mac both
!
#vtp
set vtp domain cisco
!--- В этом примере доменное имя по протоколу VTP (VLAN Trunk Protocol) является одинаковым
!--- на обеих сторонах. Это требуется для автосогласования магистрали
!--- протоколом DTP (Dynamic Trunking Protocol).


set vtp mode client vlan
!--- В этом примере режим VTP установлен в client.
!--- Установите режим VTP согласно требованиям сети.

!--- Дополнительные сведения см. в документе
!--- Описание и настройка магистрального протокола (VTP).


!
#ip
set interface sc0 1 10.10.10.2/255.255.255.0 10.10.10.255
!--- Это IP-адрес используется для управления.

!--- Выходные данные обрезаны.

!
#module 1 : 2-port 1000BaseX Supervisor
!
#module 2 empty
!
#module 3 empty
!
#module 4 empty
!
#module 5 : 48-port Inline Power Module
set vlan 2    5/13-24
!--- Порты 5/13-24 были назначены сети VLAN 2.



set trunk 5/1  desirable dot1q 1-1005,1025-4094
!--- Магистральный режим установлен в режим desirable, это означает, что
!--- порт автоматически пытается установить магистральное соединение с
!--- соседним портом, установленным в режим desirable, auto или on.

!--- Дополнительные сведения о настройках магистрального режима см. в
!--- разделе "Динамический магистральный протокол" документа
!--- Рекомендации по настройке и управлению для коммутаторов 
Catalyst серий 4500/4000, 5500/5000 и 6500/6000 под управлением системы CatOS.

!--- Выходные данные обрезаны.


set spantree portfast    5/2-24 enable
set port channel 5/2-24 mode off
!--- Макрокоманда set port host 5/2-24 использована для выполнения трех операций:
!--- отключить магистральное соединение, отключить передачу по каналу порта и включить режим быстрого порта с покрывающим деревом (spantree portfast).

!--- Дополнительные сведения о команде set port host см. в документе
!--- Использование команды Portfast и др. для устранения задержек подключения при запуске рабочей станции.

!
#module 6 empty
end

Коммутатор Catalyst 6500

Current configuration : 4408 bytes
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname cat6500
!
boot system flash sup-bootflash:c6sup22-jsv-mz.121-20.E2
enable password mysecret
!--- Это используемый в данном примере пароль для привилегированного режима.


!
ip subnet-zero
!
!
!
mls flow ip destination
mls flow ipx destination
!
redundancy
 mode rpr-plus
 main-cpu
  auto-sync running-config
  auto-sync standard
!
!
!
interface GigabitEthernet2/1
 no ip address
 shutdown
!
interface GigabitEthernet2/2
 no ip address
 shutdown
!
interface fastethernet3/1
 switchport
!--- Команду switchport следует вводить один раз,  
!--- без ключевых слов, чтобы настроить интерфейс в качестве порта второго уровня.
!--- Теперь интерфейс автоматически настраивается с помощью команды по умолчанию
!--- switchport mode dynamic desirable.

!--- Это означает, что интерфейс готов автоматически согласовать инкапсуляцию магистрального соединения
!--- и сформировать магистральный канал (используя протокол DTP) с соседним портом
!--- в режиме desirable, auto или on.

!--- Дополнительные сведения о настройках магистрального режима см. в
!--- разделе "Динамический магистральный протокол" документа
!--- Рекомендации для коммутаторов Catalyst серий 6500/6000 и 4500/4000 
под управлением ПО Cisco IOS.



!
interface FastEthernet3/2
 switchport
 switchport mode access
 spanning-tree portfast

!--- Команда interface range fastethernet mod/beginport - endport 
!--- используется для одновременной настройки интерфейсов 3/2 - 24.

!--- Далее задается команда switchport (если это уже не было сделано).


switchport mode access
 spanning-tree portfast
!--- Затем задайте макрокоманду switchport host 3/2 - 24, чтобы автоматически настроить
!--- эти порты в качестве портов доступа и включить режим spantree portfast.

!--- Дополнительные сведения о команде set port host см. в документе
!--- Использование команды Portfast и др. для устранения задержек подключения при запуске рабочей станции.


!
interface FastEthernet3/13
 switchport
 switchport access vlan 2
!--- Интерфейсы 3/13 - 24 определяются в сети VLAN 2
!--- с помощью команды switchport access vlan 2.


 switchport mode access
 spanning-tree portfast

!--- Выходные данные команды обрезаны.


!
interface FastEthernet3/24
 shutdown
 switchport
 switchport access vlan 2
 switchport mode access
 spanning-tree portfast

!--- Выходные данные команды обрезаны.

!
interface FastEthernet3/48
 no ip address
 shutdown
!
interface vlan 1
 ip address 10.10.10.3 255.255.255.0
!--- Это IP-адрес используется для управления.

!
ip classless
no ip http server
!
!
!
line con 0
line vty 0 4
 password mysecret

!--- Это используемый в данном примере пароль Telnet.


 login
 transport input lat pad mop telnet rlogin udptn nasi
!
!
end

cat6500#

Проверка

В данном разделе содержатся сведения о проверке работы конфигурации.

Команды show

Некоторые команды show поддерживаются средством Интерпретатор выходных данных leavingcisco.com (только для зарегистрированных клиентов), который позволяет выполнять анализ выходных данных команды show.

На коммутаторах Catalyst под управлением системы CatOS используются следующие команды:

  • show port capabilities module/port;

  • show port module/port;

  • show trunk module/port;

  • show vtp domain.

На коммутаторах Catalyst 6000 под управлением ПО Cisco IOS используются следующие команды:

  • show interfaces interface-type module/port trunk;

  • show vlan.

Пример выходных данных команды show

Коммутатор Catalyst 4000

Команда show port capabilities module/port служит для проверки возможности данного порта установить магистральное соединение.

cat4000> (enable) show port capabilities 5/1
Model                    WS-X4148-RJ45V
Port                     5/1
Type                     10/100BaseTX
Speed                    auto,10,100
Duplex                   half,full
Trunk encap type         802.1Q
Trunk mode               on,off,desirable,auto,nonegotiate
Channel                  5/1-48
Flow control             no
Security                 yes
Dot1x                    yes
Membership               static,dynamic
Fast start               yes
QOS scheduling           rx-(none),tx-(2q1t)
CoS rewrite              no
ToS rewrite              no
Rewrite                  no
UDLD                     yes
Inline power             auto,off,static
AuxiliaryVlan            1..1000,1025..4094,untagged,none
SPAN                     source,destination,reflector
Link debounce timer      yes
IGMPFilter               yes
Dot1q-all-tagged         no
cat4000> (enable)

Команда show port module/port показывает статус отдельного порта и сведения о том, участвует ли он в магистральном соединении.

cat4000> (enable) show port status 5/1
Port  Name               Status     Vlan       Level  Duplex Speed Type
----- ------------------ ---------- ---------- ------ ------ ----- ------------
 5/1                     connected  trunk      normal a-full a-100 10/100BaseTX
cat4000> (enable)

Команда show trunk используется для проверки состояния и конфигурации магистрального соединения.

cat4000> (enable) show trunk
* - indicates vtp domain mismatch
# - indicates dot1q-all-tagged enabled on the port
Port      Mode         Encapsulation  Status        Native vlan
--------  -----------  -------------  ------------  -----------
 5/1      desirable    dot1q          trunking      1

Port      Vlans allowed on trunk
--------  ---------------------------------------------------------------------
 5/1      1-1005,1025-4094

Port      Vlans allowed and active in management domain
--------  ---------------------------------------------------------------------
 5/1      1-2

Port      Vlans in spanning tree forwarding state and not pruned
--------  ---------------------------------------------------------------------
 5/1      1-2
cat4000> (enable)

Команда show vtp domain используется для проверки данных протокола VTP.

cat4000> (enable) show vtp domain 
Version      : running VTP1 (VTP3 capable)
Domain Name  : cisco                            Password  : not configured
Notifications: disabled                         Updater ID: 10.10.10.3

Feature        Mode           Revision
-------------- -------------- -----------
VLAN           Client         21

Pruning             : disabled
VLANs prune eligible: 2-1000

Коммутатор Catalyst 6500

Команда show interfaces interface-type module/port trunk сообщает, участвует ли данный порт в магистральном соединении.

cat6500# show interfaces fastethernet 3/1 trunk

Port      Mode         Encapsulation  Status        Native vlan
Fa3/1     desirable    n-802.1q       trunking      1

Port      Vlans allowed on trunk
Fa3/1     1-4094

Port      Vlans allowed and active in management domain
Fa3/1     1-2

Port      Vlans in spanning tree forwarding state and not pruned
Fa3/1     1-2
cat6500#

Команда show vlan дает информацию о сетях VLAN и портах, принадлежащих определенной сети VLAN.

cat6500# show vlan

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa3/2, Fa3/3, Fa3/4, Fa3/5
                                                Fa3/6, Fa3/7, Fa3/8, Fa3/9
                                                Fa3/10, Fa3/11, Fa3/12
2    VLAN0002                         active    Fa3/13, Fa3/14, Fa3/15, Fa3/16
                                                Fa3/17, Fa3/18, Fa3/19, Fa3/20
                                                Fa3/21, Fa3/22, Fa3/23, Fa3/24
1002 fddi-default                     act/unsup
1003 token-ring-default               act/unsup
1004 fddinet-default                  act/unsup
1005 trnet-default                    act/unsup

!--- Выходные данные команды обрезаны.
    
cat6500#

Примечание. Отображаются только порты, настроенные как немагистральные порты 2-ого уровня.

Поиск и устранение неполадок

Для этой конфигурации отсутствуют сведения об устранении неполадок.


Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения


Document ID: 8760