Интерфейсы и модули Cisco : Сетевые модули Cisco

Пример конфигурации сетевого модуля (ESW) EtherSwitch

31 июля 2008 - Перевод, выполненный профессиональным переводчиком
Другие версии: PDF-версия:pdf | Машинный перевод (28 июля 2013) | Английский (19 марта 2007) | Отзыв

Содержание

Введение
Предварительные условия
     Требования
     Используемые компоненты
     Соответствующие продукты
     Условные обозначения
Модули EtherSwitch – Принципы
Настройка
     Схема сети
     Конфигурации
     Конфигурация интерфейсов VLAN
     Конфигурация VTP, магистрали, канала порта и связующего дерева
     Конфигурация портов доступа
     Конфигурация голосового порта
     Конфигурация качества обслуживания (QoS)
Проверка
Поиск и устранение неполадок
Связанные обсуждения сообщества поддержки Cisco
Дополнительные сведения

Введение

Этот документ предоставляет пример конфигурации для сетевого модуля EtherSwitch, установленного на маршрутизаторе с интеграцией сервисов (ISR). В данном документе не описан пример конфигурации обслуживающего модуля EtherSwitch.

Предварительные условия

Требования

Для данного документа нет особых требований.

Используемые компоненты

Сведения, содержащиеся в данном документе, касаются следующих версий программного и аппаратного обеспечения:

  • Маршрутизатор Cisco версии 2800 в ПО Cisco IOS® версии 12.4 или более поздних

  • NM-16ESW-PWR = Сервисный модуль (NM) 10/100 EtherSwitch с портом 16

Данные для документа были получены в специально созданных лабораторных условиях. Все устройства, используемые в этом документе, были запущены с чистой (заданной по умолчанию) конфигурацией. Если ваша сеть работает в реальных условиях, убедитесь, что вы понимаете потенциальное воздействие каждой команды.

Соответствующие продукты

Эта конфигурация может также использоваться со следующими версиями программного/аппаратного обеспечения:

Условные обозначения

Подробные сведения о применяемых в документе обозначениях см. в статье Условные обозначения, используемые в технической документации Cisco.

Модули EtherSwitch – Принципы

Существует два типа модулей EtherSwitch, доступных для маршрутизаторов с интеграцией сервисов Cisco. Они выглядят следующим образом.

  • Сетевой модуль EtherSwitch (ESW)

  • Обслуживающий модуль EtherSwitch (ES)

Модули ESW, настроенные с помощью маршрутизатора IOS. Данные модули не используют отдельное ПО. ПО интегрировано в маршрутизатор хоста IOS. Можно создавать сети VLAN, настраивать сети VLAN, связующее дерево, магистральный протокол VLAN (VTP) и другие элементы в маршрутизаторе хоста. Данный маршрутизатор также хранит файл базы данных VLAN (vlan.dat) на флэш-памяти. В данном документе описан пример конфигурации для модуля ESW.

У модулей ES есть собственные процессоры, коммутирующие устройства и флэш-память, которые используют независимые ресурсы маршрутизатора хоста. После установки модуля ES в маршрутизаторе можно попасть в модуль ES с помощью консоли маршрутизатора хоста. Можно создавать сети VLAN, настраивать сети VLAN, связующее дерево, VTP и другие элементы в модуле ES. Модули ES основаны на платформе Catalyst 3750.

Настройка

В этом разделе приводится информация по настройке функций, описанных в данном документе.

Примечание. Для получения дополнительных сведений о командах, используемых в данном разделе, используйте Средство поиска команд (только для зарегистрированных клиентов).

Схема сети

В данном документе используется следующая схема сети.

ether-switch-nm-config-1.gif

Конфигурации

В данном документе используются следующие конфигурации.

Конфигурация интерфейсов VLAN

По умолчанию все порты принадлежат VLAN1. Можно создавать сети VLAN только в режиме базы данных VLAN. После создания сетей VLAN в режиме базы данных VLAN создается файл vlan.dat; он хранится в файловой системе флэш-памяти маршрутизатора. Можно просматривать сети VLAN с помощью команды show vlan-switch. В данном примере сервер протокола динамической конфигурации хоста (DHCP) (172.16.10.20) расположен в VLAN 10. Команда ip helper-address настроена во всех сетях VLAN кроме VLAN 10, чтобы получить IP-адрес с сервера DHCP для устройств, расположенных в данных сетях VLAN.

Router1


Создание виртуальных LAN


Router1#vlan database
Router1(vlan)#vlan 10
VLAN 10 added:
    Name: VLAN0010
Router1(vlan)#vlan 51
VLAN 51 added:
    Name: VLAN0051
Router1(vlan)#vlan 50
VLAN 50 added:
    Name: VLAN0050
Router1(vlan)#vlan 100
VLAN 100 added:
    Name: VLAN0100
Router1(vlan)#vlan 200
VLAN 200 added:
    Name: VLAN0200
Router1(vlan)#exit
APPLY completed.
Exiting....
Router1#



Конфигурация виртуальных LAN


Router1(config)#interface vlan 10
Router1(config-if)#ip address 172.16.10.1 255.255.255.0

Router1(config-if)#interface vlan 50
Router1(config-if)#ip address 172.16.50.1 255.255.255.0
Router1(config-if)#ip helper-address 172.16.10.20

Router1(config-if)#interface vlan 51
Router1(config-if)#ip address 172.16.51.1 255.255.255.0
Router1(config-if)#ip helper-address 172.16.10.20

Router1(config-if)#interface vlan 100
Router1(config-if)#ip address 172.16.100.1 255.255.255.0
Router1(config-if)#ip helper-address 172.16.10.20

Router1(config-if)#interface vlan 200
Router1(config-if)#ip address 172.16.200.1 255.255.255.0
Router1(config-if)#ip helper-address 172.16.10.20

Router1#show vlan-switch

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa1/0, Fa1/2, Fa1/3, Fa1/4, 
                                                Fa1/5, Fa1/6, Fa1/7, Fa1/8,
                                                Fa1/9, Fa1/10, Fa1/11, Fa1/12
                                                Fa1/13, Fa1/14, Fa1/15
10   VLAN0010                         active    
50   VLAN0050                         active    
51   VLAN0051                         active    
100  VLAN0100                         active    
200  VLAN0200                         active    
1002 fddi-default                     active    
1003 token-ring-default               active    
1004 fddinet-default                  active    
1005 trnet-default                    active    

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1    enet  100001     1500  -      -      -        -    -        1002   1003
10   enet  100010     1500  -      -      -        -    -        0      0   
50   enet  100050     1500  -      -      -        -    -        0      0   
51   enet  100051     1500  -      -      -        -    -        0      0   
100  enet  100100     1500  -      -      -        -    -        0      0   

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
200  enet  100200     1500  -      -      -        -    -        0      0   
1002 fddi  101002     1500  -      -      -        -    -        1      1003
1003 tr    101003     1500  1005   0      -        -    srb      1      1002
1004 fdnet 101004     1500  -      -      1        ibm  -        0      0   
1005 trnet 101005     1500  -      -      1        ibm  -        0      0   

Конфигурация VTP, магистрали, канала порта и связующего дерева

Режим VTP является сервером по умолчанию, а имя домена пустое. VTP можно настраивать только в режиме базы данных VLAN. Только поддерживаемый режим связующего дерева является PVST+. По умолчанию инкапсуляция магистрали – dot1q. Если настроить порт магистрали для разрешения только указанных VLAN, вы получите сообщение об ошибке Bad VLAN allowed list. В данном случае необходимо разрешить сети VLAN 1-2, 1002-1005 по умолчанию вместе с пользовательским списком VLAN. В связи с этим также необходимо разрешить сети VLAN по умолчанию и пользовательские VLAN на соседнем коммутаторе, который подключен к порту магистрали, чтобы избежать несоответствий магистрали.

Router1


Конфигурация VTP


Router1#vlan database
Router1(vlan)#vtp transparent
Setting device to VTP TRANSPARENT mode.
Router1(vlan)#vtp domain LAB
Changing VTP domain name from NULL to LAB
Router1(vlan)#exit
APPLY completed.
Exiting....



Конфигурация связующего дерева


Router1(config)#spanning-tree vlan 1 root primary
Router1(config)#spanning-tree vlan 10 root primary
Router1(config)#spanning-tree vlan 50 root primary
Router1(config)#spanning-tree vlan 51 root primary
Router1(config)#spanning-tree vlan 100 root primary
Router1(config)#spanning-tree vlan 200 root primary



Конфигурация магистрали и канала порта


Router1(config)#interface port-channel 1
Router1(config-if)#switchport mode trunk
!--- dot1q – это инкапсуляция по умолчанию.

Router1(config-if)#switchport trunk allowed vlan 100,200
Command rejected: Bad VLAN allowed list. You have to include all default vlans,
e.g. 1-2,1002-1005.
Command rejected: Bad VLAN allowed list. You have to include all default vlans,
e.g. 1-2,1002-1005.
Router1(config-if)#switchport trunk allowed vlan 1,1002-1005,100,200
Router1(config-if)#exit

Router1(config)#interface range fastEthernet 1/0 - 1
Router1(config-if-range)#switchport mode trunk
!--- dot1q – это инкапсуляция по умолчанию.

Router1(config-if-range)#switchport trunk allowed vlan 1,1002-1005,100,200
Router1(config-if-range)#channel-group 1 mode on
Router1(config-if-range)#exit

Access1


Конфигурация коммутатора Access1


Access1(config)#vlan 100,200
Access1(config-vlan)#exit

Access1(config)#vtp mode transparent
Setting device to VTP TRANSPARENT mode.

Access1(config)#vtp domain LAB
Changing VTP domain name from NULL to LAB

Access1(config)#interface port-channel 1
Access1(config-if)#switchport trunk encapsulation dot1q
Access1(config-if)#switchport mode trunk
Access1(config-if)#switchport trunk allowed vlan 1,1002-1005,100,200
Access1(config-if)#exit

Access1(config)#interface range FastEthernet 0/1 - 2
Access1(config-if-range)#switchport trunk encapsulation dot1q
Access1(config-if-range)#switchport mode trunk
Access1(config-if-range)#switchport trunk allowed vlan 1,1002-1005,100,200
Access1(config-if-range)#channel-group 1 mode on
Access1(config-if-range)#exit

Router1#show vtp status
VTP Version                     : 2
Configuration Revision          : 0
Maximum VLANs supported locally : 52
Number of existing VLANs        : 10
VTP Operating Mode              : Transparent
VTP Domain Name                 : LAB
VTP Pruning Mode                : Disabled
VTP V2 Mode                     : Disabled
VTP Traps Generation            : Disabled
MD5 digest                      : 0x8D 0x71 0x37 0x29 0x6C 0xB0 0xF2 0x0E
Configuration last modified by 172.22.1.197 at 2-20-07 22:31:06
Router1#
Router1#show interface fastethernet 1/0 trunk

Port      Mode         Encapsulation  Status        Native vlan
Fa1/0     on           802.1q         trunk-inbndl  1
                                      (Po1)

Port      Vlans allowed on trunk
Fa1/0     1,100,200,1002-1005

Port      Vlans allowed and active in management domain
Fa1/0     1,100,200

Port      Vlans in spanning tree forwarding state and not pruned
Fa1/0     1,100,200
Router1#show spanning-tree summary
Root bridge for: VLAN1, VLAN10, VLAN50, VLAN51, VLAN100, VLAN200.
PortFast BPDU Guard is disabled
UplinkFast is disabled
BackboneFast is disabled

Name                 Blocking Listening Learning Forwarding STP Active
-------------------- -------- --------- -------- ---------- ----------
VLAN1                0        0         0        1          1
VLAN10               0        0         0        1          1
VLAN50               0        0         0        1          1
VLAN51               0        0         0        1          1
VLAN100              0        0         0        1          1
VLAN200              0        0         0        1          1
-------------------- -------- --------- -------- ---------- ----------
             6 VLANs 0        0         0        6          6

Конфигурация портов доступа

Конфигурация портов доступа соответствует стандартной конфигурации коммутатора LAN.

Router1


Конфигурация порта для сервера


Router1(config)#interface fastEthernet 1/2
Router1(config-if)#switchport mode access
Router1(config-if)#switchport access vlan 10
Router1(config-if)#spanning-tree portfast
Router1(config-if)#speed 100
Router1(config-if)#duplex full
Router1(config-if)#exit



Конфигурация порта для принтера


Router1(config)#interface fastethernet 1/3
Router1(config-if)#switchport mode access
Router1(config-if)#switchport access vlan 51
Router1(config-if)#spanning-tree portfast
Router1(config-if)#exit

Конфигурация голосового порта

Конфигурация голосового порта соответствует стандартной конфигурации коммутатора LAN.

Router1


Конфигурация порта для передачи голосовых данных

Router1(config)#interface fastethernet 1/4
Router1(config-if)#switchport mode access
Router1(config-if)#switchport access vlan 51
Router1(config-if)#switchport voice vlan 50
Router1(config-if)#spanning-tree portfast
Router1(config-if)#mls qos trust cos

Конфигурация качества обслуживания (QoS)

Конфигурация QoS по умолчанию на модуле ESW.

Router1#show wrr-queue bandwidth
WRR Queue  :   1   2   3   4

Bandwidth  :   1   2   4   8
wrr-queue bandwidth is disabled

Router1#show wrr-queue cos-map
CoS Value      :  0  1  2  3  4  5  6  7

Priority Queue :  1  1  2  2  3  3  4  4
wrr-queue cos map is disabled

Router1#show mls qos maps cos-dscp
   Cos-dscp map:
        cos:   0  1  2  3  4  5  6  7
     --------------------------------
       dscp:   0  8 16 26 32 46 48 56

Router1#show mls qos maps dscp-cos

   Dscp-cos map:
       dscp:   0  8 10 16 18 24 26 32 34 40 46 48 56
     -----------------------------------------------
        cos:   0  1  1  2  2  3  3  4  4  5  5  6  7

В данном разделе описаны следующие конфигурации:

Конфигурация очередей wrr

Невозможно настроить QoS, основанный на порте, на портах коммутаторов уровня 2. Очереди можно настроить только в глобальной конфигурации. Пример конфигурации совпадает со значениями CoS для четырех различных очередей. Если пакет переходит в модуль уровня 2 прямо из порта коммутатора, он помещается в одну из четырех очередей в динамическом буфере с общим объемом памяти 32 Мб. Пакеты голосового однонаправленного канала, которые входят в IP-телефоны Cisco в голосовых VLAN автоматически помещаются в самый высокий приоритет (Очередь 4) на основе значения 802.1p (CoS 5), сгенерированного с помощью IP-телефона. Очереди обслуживаются на основе взвешенного циклического алгоритма (WRR). Управляющий трафик, который использует CoS или тип обслуживания (ToS) 3 помещается в Очередь 3.

Router1

Router1(config)#wrr-queue cos-map 1 0 1
Router1(config)#wrr-queue cos-map 2 2
Router1(config)#wrr-queue cos-map 3 3 4
Router1(config)#wrr-queue cos-map 4 5 6 7
!--- wrr-queue cos-map <номер очереди> <значения cos, разделенные пробелом>

Router(config)#wrr-queue bandwidth 1 16 64 255
!--- wrr-queue bandwidth <Вес Queue1> <Вес Queue2> 
!--- <Вес Queue3> <Вес Queue4>

Проверка параметров очередей.

Router1#show wrr-queue bandwidth
WRR Queue  :   1   2   3   4

Bandwidth  :   1   2   4   8 
!--- Значения по умолчанию


WRR Queue  :   1   2   3   4

Bandwidth  :   1  16  64 255 
!--- Сконфигурированные значения


Router1#show wrr-queue cos-map
CoS Value      :  0  1  2  3  4  5  6  7

Priority Queue :  1  1  2  2  3  3  4  4  
!--- Значения по умолчанию

CoS Value      :  0  1  2  3  4  5  6  7

Priority Queue :  1  1  2  3  3  4  4  4  
!--- Сконфигурированные значения

В следующей таблице отображен номер очереди, значение CoS и вес каждой очереди после конфигурации.

Номер очереди

Значение CoS

Вес

1

0 1

1

2

2

16

3

3 4

64

4

5 6 7

255

Конфигурация порта для CoS магистрали

Router1

Router1(config)#interface fastethernet1/4
Router1(config-if)#mls qos trust cos
!--- Установите значение CoS кадров в IP-телефоне.

Router1(config-if)#mls qos cos override
!--- Сбросьте значение CoS кадров в PC до 0.

Router1(config-if)#exit

Router1(config)#interface range fastEthernet 1/0 - 1
Router1(config-if-range)#mls qos trust cos
!--- Установите значение CoS кадров в данном магистральном канале.

Router1(config-if-range)#exit

Конфигурация ограничителя

В данном разделе описана конфигурация ограничителя на интерфейсе fa1/2, чтобы ограничить трафик FTP до 5 Mbps.

Router1

Router1(config)#ip access-list extended ACTIVE-FTP
Router1(config-ext-nacl)#permit tcp any any eq ftp
Router1(config-ext-nacl)#permit tcp any any eq ftp-data
Router1(config-ext-nacl)#exit
Router1(config)#class-map ACTIVE-FTP-CLASS
Router1(config-cmap)#match class ACTIVE-FTP
Router1(config-cmap)#exit
Router1(config)#policy-map ACTIVE-FTP-POLICY
Router1(config-pmap)#class ACTIVE-FTP-CLASS
Router1(config-pmap-c)#police 5000000 conform-action transmit exceed-action drop
Router1(config-pmap-c)#exit
Router1(config-pmap)#exit
Router1(config)#interface fastethernet1/2
Router1(config-if)#service-policy input ACTIVE-FTP-POLICY
Router1(config-if)#exit

Существует несколько ограничений в конфигурации ограничителя в модулях ESW. Они перечислены ниже.

  • Карты политик с классификацией ACL в исходящем направлении не поддерживаются и не подключаются к интерфейсу с помощью команды конфигурации service-policy input policy-map-name interface.

  • В карте политики класс по умолчанию не поддерживается. Коммутатор не фильтрует трафик на основе карты политики, определенной с помощью команды конфигурации class class-default policy-map.

  • Можно создавать карту политики и применять только ко входным интерфейсам ESW. В карте политики поддерживается только ограничитель.

    Router1#show policy-map
      Policy Map FINANCE-POLICY
        Class FINANCE-CLASS
          set cos 4
    Router1(config)#interface fastethernet1/4
    Router1(config-if)#service-policy input FINANCE-POLICY
    %Error: FastEthernet1/4 Service Policy Configuration Failed.Only Police Action S
    upported
  • Не существует поддержки для политик на уровне VLAN или коммутируемого виртуального интерфейса (SVI).

Проверка

В настоящее время для этой конфигурации нет процедуры проверки.

Поиск и устранение неполадок

Для этой конфигурации отсутствуют сведения об устранении неполадок.


Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения


Document ID: 82156