Интерфейсы и модули Cisco : Сетевые модули Cisco

Пример конфигурации обслуживающего модуля EtherSwitch (ES)

29 июля 2008 - Перевод, выполненный профессиональным переводчиком
Другие версии: PDF-версия:pdf | Машинный перевод (13 сентября 2013) | Английский (24 июня 2008) | Отзыв

Содержание

Введение
Предварительные условия
     Требования
     Используемые компоненты
     Соответствующие продукты
     Условные обозначения
Модули EtherSwitch основные понятия
Настройка
     Схема сети
     Конфигурации
     Начальная конфигурация модуля EtherSwitch
     Настройка VTP и VLAN
     Настройка связывающего дерева, магистрали и канала порта
     Конфигурация порта доступа
     Конфигурация голосового порта
     Настройка маршрутизации
     Настройка механизма обеспечения качества обслуживания
Проверка
Поиск и устранение неполадок
Связанные обсуждения сообщества поддержки Cisco
Дополнительные сведения

Введение

В данном документе приведен пример конфигурации обслуживающего модуля EtherSwitch, установленного на маршрутизаторе с интеграцией сервисов (ISR). В данном документе не рассматривается пример конфигурации для сетевого модуля EtherSwitch.

Предварительные условия

Требования

Для данного документа отсутствуют особые требования.

Используемые компоненты

Сведения, содержащиеся в данном документе, касаются следующих версий программного и аппаратного обеспечения:

  • Маршрутизатор Cisco серии 2800 на основе ПО Cisco IOS® версии 12.4(10)

  • NME-16ES-1G-P – 16-портовый 10/100 обслуживающий модуль EtherSwitch Cisco

Данные для документа были получены в специально созданных лабораторных условиях. Все устройства, используемые в этом документе, были запущены с чистой (заданной по умолчанию) конфигурацией. Если ваша сеть работает в реальных условиях, убедитесь, что вы понимаете потенциальное воздействие каждой команды.

Соответствующие продукты

Данную конфигурацию можно использовать с маршрутизаторами Cisco серий 2600/3600/3700/3800.

Дополнительные сведения см. в таблице 6 документа Обслуживающие модули Cisco EtherSwitch лист данных.

Условные обозначения

Дополнительную информацию о применяемых в документе обозначениях см. в документе Условные обозначения, используемые в технической документации Cisco.

Модули EtherSwitch – основные понятия

Для маршрутизаторов с интеграцией сервисов Cisco ISR доступно два типа модулей EtherSwitch.

  • Обслуживающий модуль EtherSwitch (ES)ES модули обладают собственным процессором, коммутирующими устройствами и флэш-памятью, которые используют независимые ресурсы маршрутизатора хоста. После установки модуля ES в маршрутизаторе можно попасть в модуль ES с помощью консоли маршрутизатора хоста. Можно создавать сети VLAN, настраивать сети VLAN, связывающее дерево, протокол VTP и другие элементы в модуле ES. Модули ES основаны на платформе Catalyst 3750. В данном документе описан пример конфигурации только для модуля ES.

  • Сетевой модуль EtherSwitch (ESW) – модули ESW настроены с помощью маршрутизатора IOS. Данные модули не используют отдельное ПО. Оно интегрировано в маршрутизатор хоста IOS. Можно создать и настроить сети VLAN, связывающее дерево, магистральный протокол VLAN (VTP) и другие элементы на маршрутизаторе хоста. Данный маршрутизатор хранит файл базы данных VLAN (vlan.dat) на флэш-памяти.

Настройка

В этом разделе предоставляются сведения по конфигурации функций, описанных в данном документе.

Примечание. Для получения дополнительных сведений о командах, используемых в данном разделе, см. Средство поиска команд (только для зарегистрированных клиентов).

Схема сети

В данном документе используется следующая схема сети.

es-mod-config1.gif

Конфигурации

В данном документе используются следующие конфигурации:

Начальная конфигурация модуля EtherSwitch

После установки модуля ES на маршрутизаторе, отображается новый интерфейс GigabitEthernet x/0 (где "x" является номером слота), распознанный IOS. Следующие выходные данные получены после установки модуля ES на маршрутизатор:

Router1#show ip interface brief
Interface                  IP-Address      OK? Method Status                Protocol

GigabitEthernet0/0         1.1.1.3         YES NVRAM  up                    down

GigabitEthernet0/1         unassigned      YES NVRAM  administratively down down

GigabitEthernet1/0         unassigned      YES unset  administratively down down

Vlan1                      unassigned      YES NVRAM  up                    up

Команда service-module gigabitEthernet x/0 session является привилегированной командой режима EXEC, которая используется для консольного соединения в модуле ES из маршрутизатора хоста. Чтобы настроить его, необходимо использовать консольное соединение модуля ES. Чтобы получить консольное соединение с модулем ES, необходимо настроить IP-адрес для интерфейса GigabitEthernet x/0. Если будет осуществлена попытка консольного соединения без назначения IP-адреса, отобразится следующее сообщение об ошибке:

Router1#service-module gigabitEthernet 1/0 session
IP address needs to be configured on interface GigabitEthernet1/0

Router1


Настройка маршрутизатора хоста для управления модулем ES


Router1#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router1(config)#interface gigabitethernet 1/0

Router1(config-if)#ip address 172.16.1.1 255.255.255.0
Router1(config-if)#no shutdown
Router1(config-if)#exit
Router1(config)#exit


Консольное соединение модуля ES


Router1#service-module gigabitEthernet 1/0 session
Trying 172.16.1.1, 2066 ... Open

         --- System Configuration Dialog ---

Would you like to enter the initial configuration dialog? [yes/no]: no

Would you like to terminate autoinstall? [yes]:
Switch>enable
Switch#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Switch(config)#hostname Switch-ES
Switch-ES(config)#interface gigabitethernet 1/0/2

Switch-ES(config-if)#no switchport
Switch-ES(config-if)#ip address 172.16.1.2 255.255.255.0
Switch-ES(config-if)#exit
!--- С помощью GigabitEthernet 1/0/2 модуль ES подключается к маршрутизатору.


Switch-ES(config)#line console 0
Switch-ES(config-line)#password a99l3
Switch-ES(config-line)#exec-timeout 30
Switch-ES(config-line)#exit
Switch-ES(config)#line vty 0 4
Switch-ES(config-line)#password a99l3
Switch-ES(config-line)#login
Switch-ES(config-line)#exec-timeout 30
Switch-ES(config-line)#exit

Данные сведения содержат выходные данные команды show ip interface brief, выполненной на модуле ES. Интерфейс GigabitEthernet1/0/2 подключает модуль ES к интерфейсу GigabitEthernet1/0 маршрутизатора хоста.

Switch-ES#show ip int brief
Interface              IP-Address      OK? Method Status                Protocol
Vlan1                  unassigned      YES unset  administratively down down
FastEthernet1/0/1      unassigned      YES unset  down                  down
FastEthernet1/0/2      unassigned      YES unset  down                  down
FastEthernet1/0/3      unassigned      YES unset  down                  down
FastEthernet1/0/4      unassigned      YES unset  down                  down
FastEthernet1/0/5      unassigned      YES unset  down                  down
FastEthernet1/0/6      unassigned      YES unset  down                  down
FastEthernet1/0/7      unassigned      YES unset  down                  down
FastEthernet1/0/8      unassigned      YES unset  down                  down
FastEthernet1/0/9      unassigned      YES unset  down                  down
FastEthernet1/0/10     unassigned      YES unset  down                  down
FastEthernet1/0/11     unassigned      YES unset  down                  down
FastEthernet1/0/12     unassigned      YES unset  down                  down
FastEthernet1/0/13     unassigned      YES unset  down                  down
FastEthernet1/0/14     unassigned      YES unset  down                  down
FastEthernet1/0/15     unassigned      YES unset  down                  down
FastEthernet1/0/16     unassigned      YES unset  down                  down
GigabitEthernet1/0/1   unassigned      YES unset  down                  down
GigabitEthernet1/0/2   172.16.1.2      YES manual  up                    up

Если модулю ES или устройству, подключенному к модулю ES, необходимо взаимодействовать с внешней сетью с помощью маршрутизатора хоста, данному порту (GigabitEthernet1/0/2) необходимо иметь значение порта уровня 3 или являться членом VLAN уровня 3. См. раздел Настройка маршрутизации данного документа, чтобы получить понятия о настройке маршрутизации модуля ES.

В данной диаграмме объясняется логическое соединение маршрутизатора хоста и модуля ES:

es-mod-config2.gif

Чтобы вернуться к маршрутизатору хоста, необходимо нажать сочетание клавиш Ctrl+Shift+6, затем X.

Если необходимо очистить сеанс из маршрутизатора, подайте команду service-module gigabitEthernet x/0 session clear из привилегированного режима EXEC маршрутизатора.

Настройка VTP и VLAN

По умолчанию на модуле ES, режим VTP является сервером, а имя домена VTP – пустым. По умолчанию, все порты принадлежат vlan1. В данном примере, DHCP-сервер (172.16.10.20) находится в vlan 10. Команда ip helper-address 172.16.10.20 настроена на всех VLAN, за исключением vlan 10, чтобы получить IP-адрес с DHCP-сервера для устройств, расположенных в данных сетях VLAN.

Коммутатор-ES


Настройка VTP

Switch-ES(config)#vtp mode transparent
Setting device to VTP TRANSPARENT mode.
Switch-ES(config)#vtp domain LAB
Changing VTP domain name from NULL to LAB
Switch-ES(config)#


Создание виртуальных LAN (VLAN)


Switch-ES(config)#vlan 10,50,51,100,200
Switch-ES(config-vlan)#exit
Switch-ES(config)#



Настройка сетей VLAN


Switch-ES(config)#interface vlan 10
Switch-ES(config-if)#ip address 172.16.10.1 255.255.255.0
Switch-ES(config-if)#no shutdown

Switch-ES(config-if)#interface vlan 50
Switch-ES(config-if)#ip address 172.16.50.1 255.255.255.0
Switch-ES(config-if)#ip helper-address 172.16.10.20
Switch-ES(config-if)#no shutdown

Switch-ES(config-if)#interface vlan 51
Switch-ES(config-if)#ip address 172.16.51.1 255.255.255.0
Switch-ES(config-if)#ip helper-address 172.16.10.20
Switch-ES(config-if)#no shutdown

Switch-ES(config-if)#interface vlan 100
Switch-ES(config-if)#ip address 172.16.100.1 255.255.255.0
Switch-ES(config-if)#ip helper-address 172.16.10.20
Switch-ES(config-if)#no shutdown

Switch-ES(config-if)#interface vlan 200
Switch-ES(config-if)#ip address 172.16.200.1 255.255.255.0
Switch-ES(config-if)#ip helper-address 172.16.10.20
Switch-ES(config-if)#no shutdown

Switch-ES#show vlan

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa1/0/1, Fa1/0/2, Fa1/0/3
                                                Fa1/0/4, Fa1/0/7, Fa1/0/8
                                                Fa1/0/9, Fa1/0/10, Fa1/0/11
                                                Fa1/0/12, Fa1/0/13, Fa1/0/14
                                                Fa1/0/15, Fa1/0/16, Gi1/0/1
                                                Gi1/0/2
10   VLAN0010                         active
50   VLAN0050                         active
51   VLAN0051                         active
100  VLAN0100                         active

200  VLAN0200                         active
1002 fddi-default                     act/unsup
1003 token-ring-default               act/unsup
1004 fddinet-default                  act/unsup
1005 trnet-default                    act/unsup

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1    enet  100001     1500  -      -      -        -    -        0      0

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
10   enet  100010     1500  -      -      -        -    -        0      0
50   enet  100050     1500  -      -      -        -    -        0      0
51   enet  100051     1500  -      -      -        -    -        0      0
100  enet  100100     1500  -      -      -        -    -        0      0

200  enet  100200     1500  -      -      -        -    -        0      0
1002 fddi  101002     1500  -      -      -        -    -        0      0
1003 tr    101003     1500  -      -      -        -    -        0      0
1004 fdnet 101004     1500  -      -      -        ieee -        0      0
1005 trnet 101005     1500  -      -      -        ibm  -        0      0

Remote SPAN VLANs
------------------------------------------------------------------------------


Primary Secondary Type              Ports
------- --------- ----------------- ------------------------------------------
Switch-ES#show vtp status
VTP Version                     : 2
Configuration Revision          : 0
Maximum VLANs supported locally : 1005
Number of existing VLANs        : 10
VTP Operating Mode              : Transparent
VTP Domain Name                 : LAB
VTP Pruning Mode                : Disabled
VTP V2 Mode                     : Disabled
VTP Traps Generation            : Disabled
MD5 digest                      : 0x21 0x51 0xD5 0x4E 0x30 0xA5 0x46 0x3C
Configuration last modified by 0.0.0.0 at 10-27-06 18:28:10

Настройка связывающего дерева, магистрали и канала порта

В данном разделе показана конфигурация связывающего дерева на модуле ES и коммутаторе Access1. Также здесь показана конфигурация канала порта и магистрали между модулем ES и коммутатором Access1. В данном примере приведены настройки быстрого связующего дерева на всех коммутаторах. Модуль ES настроен в качестве корня связующего дерева для всех VLAN.

Коммутатор-ES


Настройка Spanning-Tree

Switch-ES(config)#spanning-tree mode rapid-pvst
Switch-ES(config)#spanning-tree vlan 10,50,51,100,200 root primary


Настройка магистрали и канала портов

Switch-ES(config)#interface port-channel 1
Switch-ES(config-if)#switchport trunk encapsulation dot1q
Switch-ES(config-if)#switchport mode trunk
Switch-ES(config-if)#switchport trunk allowed vlan 100,200
Switch-ES(config-if)#exit

Switch-ES(config)#interface range fastethernet 1/0/5-6
Switch-ES(config-if-range)#switchport trunk encapsulation dot1q
Switch-ES(config-if-range)#switchport mode trunk
Switch-ES(config-if-range)#switchport trunk allowed vlan 100,200
Switch-ES(config-if-range)#channel-group 1 mode on
Switch-ES(config-if-range)#exit

Access1


Настройка коммутатора Access1



Access1(config)#vtp mode transparent
Setting device to VTP TRANSPARENT mode.

Access1(config)#vtp domain LAB
Changing VTP domain name from NULL to LAB

Access1(config)#vlan 100,200
Access1(config-vlan)#exit

Access1(config)#spanning-tree mode rapid-pvst

Access1(config)#interface port-channel 1
Access1(config-if)#switchport trunk encapsulation dot1q
Access1(config-if)#switchport mode trunk
Access1(config-if)#switchport trunk allowed vlan 100,200
Access1(config-if)#exit

Access1(config)#interface range FastEthernet 0/1 - 2
Access1(config-if-range)#switchport trunk encapsulation dot1q
Access1(config-if-range)#switchport mode trunk
Access1(config-if-range)#switchport trunk allowed vlan 100,200
Access1(config-if-range)#channel-group 1 mode on
Access1(config-if-range)#exit

Switch-ES#show spanning-tree summary
Switch is in rapid-pvst mode
Root bridge for: VLAN0001, VLAN0100, VLAN0200
Extended system ID           is enabled
Portfast Default             is disabled
PortFast BPDU Guard Default  is disabled
Portfast BPDU Filter Default is disabled
Loopguard Default            is disabled
EtherChannel misconfig guard is enabled
UplinkFast                   is disabled
BackboneFast                 is disabled
Configured Pathcost method used is short

Name                   Blocking Listening Learning Forwarding STP Active
---------------------- -------- --------- -------- ---------- ----------
VLAN0001                     0         0        0          1          1
VLAN0100                     0         0        0          1          1
VLAN0200                     0         0        0          1          1
---------------------- -------- --------- -------- ---------- ----------
3 vlans                      0         0        0          3          3
Switch-ES#show interface port-channel 1 trunk

Port        Mode         Encapsulation  Status        Native vlan
Po1         on           802.1q         trunking      1

Port      Vlans allowed on trunk
Po1         100,200

Port        Vlans allowed and active in management domain
Po1         100,200

Port        Vlans in spanning tree forwarding state and not pruned
Po1         100,200

Настройка порта доступа

Конфигурация порта доступа соответствует стандартной конфигурации коммутатора LAN.

Коммутатор-ES


Настройка порта для сервера

Switch-ES(config)#interface fastEthernet 1/0/7
Switch-ES(config-if)#switchport mode access
Switch-ES(config-if)#switchport access vlan 10
Switch-ES(config-if)#spanning-tree portfast
Switch-ES(config-if)#speed 100
Switch-ES(config-if)#duplex full
Switch-ES(config-if)#exit


Настройка порта для принтера

Switch-ES(config)#interface fastethernet 1/0/8
Switch-ES(config-if)#switchport mode access
Switch-ES(config-if)#switchport access vlan 51
Switch-ES(config-if)#spanning-tree portfast
Switch-ES(config-if)#exit

Настройка голосового порта

Конфигурация голосового порта соответствует стандартной конфигурации коммутатора LAN.

Коммутатор-ES


Настройка порта для сервера

Switch-ES(config)#interface fastethernet 1/0/9
Switch-ES(config-if)#switchport mode access
Switch-ES(config-if)#switchport access vlan 51
Switch-ES(config-if)#switchport voice vlan 50
Switch-ES(config-if)#spanning-tree portfast

Настройка маршрутизации

В данном примере используются статические маршруты для настройки маршрутизации.

Коммутатор-ES


Настройка маршрута, используемого по умолчанию

Switch-ES(config)#ip routing
Switch-ES(config)#ip route 0.0.0.0 0.0.0.0 172.16.1.1

Router1


Настройка маршрута к LAN

Router1(config)#ip route 172.16.0.0 255.255.0.0 172.16.1.2

Настройка механизма обеспечения качества обслуживания

В данном разделе приведено использование автоматического механизма обеспечения качества обслуживания (AutoQoS) для настройки механизма обеспечения качества обслуживания (QoS). Дополнительные сведения об автоматическом механизме обеспечения качества обслуживания см. раздел Описание Cisco AutoQoS.

Коммутатор-ES


Настройка параметров QoS на порте, к которому подключен IP-телефон

Switch-ES(config)#interface fastethernet 1/0/9
Switch-ES(config-if)#auto qos voip cisco-phone
Switch-ES(config-if)#exit


Настройка параметров QoS на порте восходящего канала для связи с маршрутизатором хоста.

Switch-ES(config)#interface gigabitEthernet 1/0/2
Switch-ES(config-if)#auto qos voip trust

Router1


Создание карты классов

Router1(config)#class-map match-any VoIP-Control
Router1(config-cmap)#match ip dscp AF31
Router1(config-cmap)#exit

Router1(config)#class-map match-any VoIP-RTP
Router1(config-cmap)#match ip dscp EF
Router1(config-cmap)#exit


Создание карты политик

Router1(config)#policy-map Policy-VoIP
Router1(config-pmap)#class VoIP-RTP
Router1(config-pmap-c)#priority percent 70
Router1(config-pmap-c)#class VoIP-Control
Router1(config-pmap-c)#bandwidth percent 5
Router1(config-pmap-c)#class class-default
Router1(config-pmap-c)#fair-queue
Router1(config-pmap-c)#exit
Router1(config-pmap)#exit


Применение политики на интерфейсе, подключенном к модулю ES

Router1(config)#interface gigabitEthernet 1/0
Router1(config-if)#service-policy output Policy-VoIP
Router1(config-if)#exit

Проверка

В настоящее время для этой конфигурации нет процедуры проверки.

Устранение неполадок

Для этой конфигурации отсутствуют сведения об устранении неполадок.

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения


Document ID: 82288