Коммутация LAN : EtherChannel

Настройка канала Ethernet 2 уровня и магистрального соединения между коммутаторами 2900XL/3500XL/2950 и коммутаторами Catalyst под управлением ПО Cisco IOS

29 июля 2008 - Перевод, выполненный профессиональным переводчиком
Другие версии: PDF-версия:pdf | Машинный перевод (28 июля 2013) | Английский (26 февраля 2006) | Отзыв

Содержание

Введение
Предварительные условия
     Требования
     Используемые компоненты
     Условные обозначения
     Протокол DTP
     Рассмотрение 802.1Q стандартной VLAN
     Протокол PAgP
Конфигурация 1: магистральное соединение ISL и EtherChannel между Catalyst 3500 XL и Catalyst 6500 под управлением ПО Cisco IOS
     Схема сети
Конфигурация 2: магистральное соединение ISL и EtherChannel между коммутаторами Catalyst 2950 XL и Catalyst 6500 под управлением ПО Cisco IOS
     Схема сети
Конфигурация 2: магистральное соединение ISL
     Catalyst 3500 XL
     Catalyst 6500 (ПО Cisco IOS)
Проверка: магистральное соединение 802.1Q
     Catalyst 2950
     Catalyst 6500 ПО Cisco IOS
Устранение неполадок
     Отсутствует передача трафика на магистрали 802.1Q
Связанные обсуждения сообщества поддержки Cisco
Дополнительные сведения

Введение

В данном документе приведены примерные конфигурации магистрального соединения IEEE 802.1Q/ISL и EtherChannel уровня 2 (L2) между коммутаторами Cisco Catalyst 2900 XL/3500 XL или Catalyst 2950 и коммутатором Catalyst 6500/6000 под управлением ПО Cisco IOS®. В данном примере также можно использовать коммутатор Catalyst 4500/4000 под управлением ПО Cisco IOS вместо Catalyst 6500/6000. В данном документе рассмотрены наиболее важные аспекты настройки магистрального соединения и передачи данных по каналу между коммутаторами. В документе также приведены примеры конфигураций.

В данном примере четыре порта Fast Ethernet каждого коммутатора соединены с помощью магистрального соединения и сгруппированы в каналы Fast EtherChannel (FEC). Для 3500 XL ISL использовался протокол магистрального соединения, а для примера 2950 использовался 802.1Q.

Примечание. Catalyst 2950 не поддерживает магистральное соединение ISL. Вместо этого используется магистральное соединение 802.1Q.

Предварительные условия

Требования

Для данного документа отсутствуют особые требования.

Используемые компоненты

Для создания данных примеров в лабораторной среде использовались данные коммутаторы с ненастроенной конфигурацией:

  • Коммутатор Catalyst 3548 XL под управлением ПО Cisco IOS 12.0(5)WC2

  • Коммутатор Catalyst 2950-24 под управлением ПО Cisco IOS 12.1(6)EA2c

  • Коммутатор Catalyst 6509 с модулем Supervisor Engine II под управлением ПО Cisco IOS 12.1(11b)E

Данные для документа были получены в специально созданных лабораторных условиях. Все устройства, используемые в этом документе, были запущены с чистой (заданной по умолчанию) конфигурацией. Если ваша сеть работает в реальных условиях, убедитесь, что вы понимаете потенциальное воздействие каждой команды.

Условные обозначения

Дополнительную информацию о применяемых в документе обозначениях см. в документе Условные обозначения, используемые в технической документации Cisco.

Протокол DTP

Магистральное соединение между устройствами может быть настроено статически или с помощью протокола DTP. Протокол DTP обеспечивает подключение обоих устройств с согласованием параметров магистрального соединения перед фактической установкой магистрального соединения. Конфигурируемые режимы ПО Cisco IOS коммутируемых портов (магистральных соединений) включают в себя: динамический (порт работает в режиме доступа или в режиме магистрального соединения), магистральное соединение (только магистральное соединение) и режим доступа (порт доступа без поддержки магистрального соединения). Наиболее часто используются параметры комбинированного режима на обоих концах статической (без согласования по DTP) магистрали – "trunk-trunk". Для динамических магистральных соединений (с согласованием DTP) обычной настройкой является "dynamic-dynamic". Допустимы также другие комбинации, но они не рассматриваются в данном документе. При использовании магистрального соединения между коммутатором, поддерживающим протокол агрегации портов (PAgP), и устройством, не поддерживающим протокол PagP, режим магистрального соединения должен быть включен.

Примечание. Большинство маршрутизаторов Cisco и некоторые коммутаторы Catalyst не поддерживают протокол DTP, в таких случаях необходима настройка статического магистрального соединения. Например, маршрутизаторы Cisco Catalyst XL, Catalyst 2948G-L3, Catalyst 4908G-L3, Catalyst 8500, серии 2/3/4/7xxx и другие не поддерживают протокол DTP, и в таких случаях необходима настройка статического магистрального соединения.

Рассмотрение стандартной VLAN 802.1Q

При использовании магистрального соединения 802.1Q применяется вставка 4-байтовое поле тега 802.1Q в рассылаемые по магистрали кадры, содержащие информацию о VLAN. Тег 802.1Q вставляется в каждый кадр, передаваемый по магистрали, за исключением кадров в стандартной VLAN, которые передаются без тегов. В большинстве случаев необходимо совпадение стандартной VLAN на обоих концах магистрали, за исключением редких случаев специальных требования к конфигурации, но они не рассматриваются в данном документе. Если стандартные сети VLAN не соответствуют друг другу, коммутатор заносит в журнал сообщения протокола CDP с указанием несоответствия. Хотя это исправимо, такая настройка приводит к тому, что две разные стандартные VLAN объединяются в один большой домен широковещательной рассылки L2 (VLAN). Эти две VLAN пытаются рассчитать одну общую топологию STP для стандартных виртуальных локальных сетей с мостовым соединением, что в итоге может привести к превышению максимального поддерживаемого диаметра STP.

Примечание. Существуют определенные ситуации, когда для соседнего или стороннего устройства необходимо тегирование всех сетей VLAN. В таком случае можно применить обходной прием для создания фиктивной VLAN и настроить ее как стандартную VLAN. Все необходимые сети VLAN будут помечены, а данные через них будут пересылаться по магистрали соседним или сторонним устройствам. Catalyst 6500 под управлением ПО Cisco IOS версии 12.1.11bEX, 12.1.13E и более поздних версий поддерживает возможность магистрального соединения 802.1Q, которое позволяет помечать весь трафик VLAN (в том числе и стандартной VLAN). В режиме глобального конфигурирования необходимо ввести команду vlan dot1q tag native. На коммутаторах Catalyst 4500/4000 под управлением ПО Cisco IOS команда vlan dot1q tag native изначально поддерживалась ПО Cisco IOS версии 12.2(18)EW.

PAgP

Гигабитные каналы EtherChannels (GECs) и FECs между коммутаторами могут быть настроены статически или динамически с помощью PAgP. Протокол PAgP обеспечивает подключение обоих устройств с согласованием параметров перед фактическим формированием канала. Режим настройки PAgP включает в себя: desirable (порт инициирует согласование каналов), auto (по умолчанию, порт не инициирует согласование, но реагирует на согласование с другого конца) и on (устанавливает порт на канал в безусловном режиме, обмен кадрами PAgP не поддерживается). Для соединения между коммутатором, поддерживающим PagP, и устройством, не поддерживающим PagP, для создания канала необходим режим on.

on-on – наиболее часто используемый комбинированный режим для двух концов статического (без согласования PAgP) канала. Для динамических каналов (согласованных с PAgP) стандартными настройками являются desirable-desirable или desirable-auto. Подключенные порты, настроенные в режиме desirable, обеспечивают согласование каналов и проверку перед началом передачи данных по каналу, а также и проверку, не занят ли канал. Ввиду дополнительных мер безопасности, предоставляемых PAgP, рекомендуется настраивать поддержку обоих PAgP для подключенных коммутаторов.

Примечание. В конфигурацию PAgP намеренно внесены некоторые ограничения. Для согласования портов каналы должны иметь одинаковую скорость, дуплексный режим, инкапсуляцию магистрального соединения и настройки VLAN. Также алгоритм балансировки нагрузки каналов в соединениях может быть перенастроен на определенных платформах.

Примечание. EtherChannel сразу после включения становится уникальным портом STP. Поэтому, чтобы избежать несогласованности протокола STP при настройке несогласованного канала, рекомендуется выполнить следующие действия:

  1. Отключите все порты канала для настройки на обоих концах.

  2. Выполните настройку на обоих концах.

  3. Снова включите все порты.

Попытка настроить этот канал при активированных портах может привести к временной несогласованности STP и (или) появлению петель. Описанные выше шаги можно выполнить, только если не используется PAgP.

Catalyst 2900 XL / 3500 XL

Коммутаторы серии Catalyst 2900 XL/ 3500 XL не поддерживают DTP и PagP, поэтому требуют статической настройки магистрали и канала. Дополнительные сведения см. в примечании выше. Коммутаторы Catalyst 2900 XL/ 3500 XL поддерживают инкапсуляцию для магистральных соединений ISL и 802.1Q. Дополнительные сведения см. в документе:

ISL поддерживается ПО Cisco IOS версии 11.2(8)SA4 и более поздних версий. 802.1Q поддерживается ПО Cisco IOS версии 11.2(8)SA5 и более поздних версий.

На Catalyst 2900XL под управлением ПО Cisco IOS Software 11.2(8)SA1 или 11.2(8)SA2 разрешено использовать четыре канала EtherChannel (групп портов) для одного коммутатора и неограниченное количество портов в одной группе. Балансировка нагрузки трафика по соединениям в канале всегда основана на адресе назначения. Анализатор коммутируемых портов (SPAN) и функции защиты портов не поддерживаются.

В коммутаторах Catalyst 2900 XL под управлением Cisco IOS 11.2(8)SA3 или более поздних версий, Catalyst 3500 XL под управлением Cisco IOS 11.2(8)SA6 или более поздних версий, а также в Catalyst 2950 балансировка нагрузки по соединениям в канале основана на MAC-адресе источника или назначения. Источник задан по умолчанию. Перенаправление на основе источника позволяет подключать до девяти портов в FEC (группе портов). Перенаправление на основе назначения позволяет подключать неограниченное количество портов в группе портов. Можно настроить до 12 групп портов на одном коммутаторе, причем это могут быть группы как портов-источников, так и портов назначения. Анализатор коммутируемых портов и защита порта не поддерживаются.

Catalyst 2950

Коммутаторы Catalyst 2950 поддерживают только магистральное соединение 802.1Q, но не поддерживают ISL. Коммутаторы Catalyst 2950 поддерживают протокол DTP, динамическое магистральное соединение PAgP, согласование каналов в Cisco IOS 12.1 и статические режимы только в Cisco IOS 12.0. Для балансировки нагрузки EtherChannel можно использовать пересылку на MAC-адрес источника или назначения. Для настройки способа балансировки нагрузки выполните команду глобальной настройки port-channel load-balance. Данные коммутаторы поддерживают до восьми портов на канал.

Коммутаторы Catalyst 6500 под управлением ПО Cisco IOS

Коммутаторы Catalyst 6500 под управлением ПО Cisco IOS поддерживают конфигурации канала EtherChannel уровня 2 (L2) (порт коммутации) и уровня 3 (L3) (маршрутизируемый порт). Коммутатор Catalyst 6500/6000 поддерживает максимум 64 канала EtherChannel (256 с ПО Cisco IOS версии 12.1(2)E и более ранних версий). Для любого модуля коммутатора Catalyst 6000 можно организовывать канал EtherChannel с максимум восемью портами LAN с совместимой конфигурацией. Исключением являются модули, оснащенные платой DFC (Плата цифровых функций), например, WS-X6816 и др., которые в настоящее время поддерживают использование каналом уровня 2 только портов этой же DFC-платы. Таким образом, канал L3 может быть настроен на любых модулях, оснащенных DFC. На коммутаторы Catalyst 6500/6000 под управлением ПО Cisco IOS 12.1(11b)EX и более поздних версий данное ограничение не распространяется. В данном документе рассматривается настройка канала L2 EtherChannel.

Коммутатор Catalyst 6500/6000 под управлением Cisco IOS позволяет настраивать балансировку нагрузки EtherChannel для использования MAC-адресов, IP-адресов и информации о порте уровня 4 (L4) любого отправителя, адресата или комбинации отправитель-адресат с помощью команды глобальной конфигурации port-channel load-balance. Значение по умолчанию установлено для использования функции хеширования между IP-адресами источника и назначения.

Коммутаторы Catalyst 6500/6000 поддерживают инкапсуляцию для группирования магистральных соединений в ISL и 802.1Q, а также DTP-протокол. Для получения подробных сведений о возможностях порта введите команду show interface interface_id capabilities.

Коммутаторы Catalyst 4000 под управлением ПО Cisco IOS

Коммутаторы Catalyst 4000 под управлением ПО Cisco IOS (с модулями управления Supervisor Engine III и IV) поддерживают конфигурации канала EtherChannel уровня (L2) (порт коммутации) и 3 уровня (L3) (маршрутизируемый порт). Коммутаторы серии Catalyst 4000 поддерживают максимум 64 канала EtherChannels. Для любого модуля и между модулями коммутатора Catalyst 4000 можно организовать Ethernet-канал с максимум восемью Ethernet-интерфейсами с совместимой конфигурацией. На всех каналах EtherChannel должны быть настроены интерфейсы L2 или L3, причем с одинаковой скоростью.

Коммутатор Catalyst 4000 под управлением Cisco IOS позволяет настраивать балансировку нагрузки EtherChannel для использования MAC-адресов, IP-адресов и информации о порте уровня 4 (L4) любого отправителя, адресата или комбинации отправитель-адресат с помощью команды глобальной конфигурации port-channel load-balance. Значение по умолчанию установлено для использования функции хеширования между IP-адресами источника и назначения.

Коммутаторы Catalyst 4000 под управлением ПО Cisco IOS поддерживают инкапсуляцию магистральных соединений ISL и 802.1Q, а также DTP-протокол. На определенных модулях межкоммутаторное соединение (ISL) недоступно. Полный список модулей см. в подразделе Общие сведения о магистральных соединениях VLAN раздела Настройка интерфейсов Ethernet второго уровня. Для получения подробных сведений о возможностях порта новых версий ПО необходимо ввести команду show interface capabilities. В настоящий момент данная команда недоступна.

Конфигурация 1: магистральное соединение ISL и EtherChannel между коммутаторами Catalyst 3500 XL и Catalyst 6500 под управлением ПО Cisco IOS

В этом разделе предоставляются сведения по конфигурации функций, описанных в данном документе.

Примечание. Для поиска дополнительной информации о командах в данном документе используйте Средство поиска команд (только для зарегистрированных клиентов).

Схема сети

В данной конфигурации используется следующая настройка сети:

144-a.gif

Catalyst 3524 XL

!--- Catalyst 3500 XL не поддерживает DTP/PAgP.
!--- Вначале отключите вторичные порты, задействованные в канале, 
!--- а затем снова активируйте их по окончании настройки на обоих коммутаторах.



Cat3500XL#show run
Building configuration...
Current configuration:
!

version 12.0
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Cat3500XL
ip subnet-zero
!
interface FastEthernet0/1
!
!--- Выходные данные команды подавляются.


!
interface FastEthernet0/17
port group 1
!--- Порт, назначенный каналу портов 1.


switchport trunk encapsulation isl
!--- Настройка порта с целью использования ISL инкапсуляции для магистральных соединений.


switchport mode trunk
!--- Настраиваемый порт должен находиться в режиме магистрального соединения.


!
interface FastEthernet0/18
!--- Повторная настройка магистрали и канала.


port group 1
switchport trunk encapsulation isl
switchport mode trunk
!
interface FastEthernet0/19
!--- Повторная настройка магистрали и канала.


Port group 1
switchport trunk encapsulation isl
switchport mode trunk
!
interface FastEthernet0/20
!--- Повторная настройка магистрали и канала.


Port group 1
switchport trunk encapsulation isl
switchport mode trunk
!
interface FastEthernet0/21
!
!--- Выходные данные команды подавляются.


!
interface FastEthernet0/48
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!

interface VLAN1
ip address 10.10.10.1 255.255.255.0
no ip directed-broadcast
no ip route-cache
!
line con 0
transport input none
stopbits 1
line vty 0 4
login

Catalyst 6500 (ПО Cisco IOS)

!--- Catalyst 3500 XL не поддерживает DTP/PAgP.
!--- Вначале отключите вторичные порты, задействованные в канале, 
!--- а затем снова активируйте их по окончании настройки на обоих коммутаторах.



Cat6500#show run
Building configuration...
Current configuration : 3999 bytes
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Cat6500
!
boot bootldr bootflash:c6msfc2-boot-mz.121-8b.E9
!
redundancy 
main-cpu  
auto-sync standard
ip subnet-zero
!
!
no mls ip multicast aggregate
no mls ip multicast non-rpf cef
mls qos statistics-export interval 300
mls qos statistics-export delimiter |
!
interface Port-channel1

!--- Этот интерфейс создается и конфигурируется автоматически. 
!--- Вводить данные на этом этапе настройки не требуется.


switchport 
switchport trunk encapsulation isl 
switchport mode trunk 
no ip address
!
interface GigabitEthernet1/1 
no ip address 
shutdown
!
!--- Выходные данные команды подавляются.


!
interface FastEthernet4/2 
switchport
!--- Установка интерфейса в качестве L2-порта, поскольку по умолчанию порт является маршрутизируемым портом.


!--- Примечание. Catalyst 4500/4000, работающий под управлением ПО Cisco IOS, по умолчанию использует L2-порт.


switchport trunk encapsulation dot1q
!--- Установка dot1q для инкапсуляции магистрали.


switchport mode trunk
!--- Настраиваемый порт должен находиться в режиме магистрального соединения. 


no ip address 
channel-group 1 mode on
!--- Настройка порта для работы в канале портов 1 при активированном режиме канала.


! 
Interface FastEthernet4/3
!--- Повторная настройка магистрали и канала. 


switchport 
switchport trunk encapsulation isl 
switchport mode trunk 
no ip address 
channel-group 1 mode on
! 
interface FastEthernet4/4
!--- Повторная настройка магистрали и канала.


switchport 
switchport trunk encapsulation isl 
switchport mode trunk 
no ip address 
channel-group 1 mode on
! 
interface FastEthernet4/5
!--- Повторная настройка магистрали и канала. 


switchport 
switchport trunk encapsulation isl 
switchport mode trunk 
no ip address 
channel-group 1 mode on
!
interface FastEthernet4/6 
no ip address 
shutdown
!
!
interface VLAN 1 
ip address 10.10.10.2  255.255.255.0
!
ip classless
no ip http server
!
line con 0
line vty 0 4
!
end
Cat6500# 

Конфигурация 2: магистральное соединение 802.1Q и EtherChannel с использованием протоколов DTP и PAgP между коммутаторами Catalyst 2950 и Catalyst 6500 под управлением ПО Cisco IOS

В этом разделе предоставляются сведения по конфигурации функций, описанных в данном документе.

Примечание. Для поиска дополнительной информации о командах в данном документе используйте Средство поиска команд (только для зарегистрированных клиентов).

Схема сети

В данной конфигурации используется следующая настройка сети:

144-b.gif

Catalyst 2950

!--- Catalyst 2950 с ПО Cisco IOS версии 12.1 поддерживает PAgP. 
!--- Порты отключать не требуется, поскольку коммутаторы Catalyst 2950 и 6500 могут выполнять согласование 
!--- для передачи по каналу в требуемом режиме.



Cat2950#show run
Building configuration...
Current configuration : 1380 bytes
!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Cat2950
!
ip subnet-zero
no ip finger
!
interface Port-channel1 
switchport mode trunk
!
interface FastEthernet0/1
!         
interface FastEthernet0/2 
switchport mode trunk
!--- Настраиваемый порт должен находиться в режиме магистрального соединения.


channel-group 1 mode desirable
!--- Настройка порта для работы в канале портов 1 в режиме согласования PAgP.


!
interface FastEthernet0/3
!--- Повторная настройка магистрали и канала.
 

switchport mode trunk 
channel-group 1 mode desirable
!
interface FastEthernet0/4
!--- Повторная настройка магистрали и канала. 


switchport mode trunk 
channel-group 1 mode desirable
!
interface FastEthernet0/5
!--- Повторная настройка магистрали и канала. 


switchport mode trunk 
channel-group 1 mode desirable
!
interface FastEthernet0/6
!
!--- Выходные данные команды подавляются.


!
interface FastEthernet0/25
!
interface FastEthernet0/26
!
interface VLAN1 
ip address 10.10.10.1 255.255.255.0 
no ip route-cache
!
ip http server
!
line con 0 
transport input none
line vty 5 15
!
end 
Cat2950#

Catalyst 6500 (ПО Cisco IOS)

!--- Catalyst 2950 с ПО Cisco IOS версии 12.1 поддерживает PAgP. 
!--- Порты отключать не требуется, поскольку коммутаторы Catalyst 2950 и 6500 могут выполнять согласование 
!--- для передачи по каналу в требуемом режиме.


Cat6500#show run
Building configuration...
Current configuration : 3999 bytes
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Cat6500
!
boot bootldr bootflash:c6msfc2-boot-mz.121-8b.E9
!
redundancy 
main-CPU  
auto-sync standard
ip subnet-zero
!
!
no mls ip multicast aggregate
no mls ip multicast non-rpf cef
mls qos statistics-export interval 300
mls qos statistics-export delimiter |
!
interface Port-channel1

!--- Этот интерфейс создается и конфигурируется автоматически. 
!--- Вводить данные на этом этапе настройки не требуется.


switchport 
switchport trunk encapsulation dot1q 
switchport mode trunk 
no ip address
!
interface GigabitEthernet1/1 
no ip address 
shutdown
!
!--- Выходные данные команды подавляются.


!
interface FastEthernet4/2 
switchport
!--- Установка интерфейса в качестве L2-порта, поскольку по умолчанию порт является маршрутизируемым портом.


!--- Примечание. Catalyst 4500/4000, работающий под управлением ПО Cisco IOS, по умолчанию использует L2-порт.


switchport trunk encapsulation dot1q

!--- Установка dot1q для инкапсуляции магистрали.


switchport mode trunk
!--- Настраиваемый порт должен находиться в режиме магистрального соединения. 


No ip address 
channel-group 1 mode desirable
!--- Настройка порта для работы в канале портов 1 в требуемом режиме канала.


! 
Interface FastEthernet4/3
!--- Повторная настройка магистрали и канала. 


switchport 
switchport trunk encapsulation dot1q 
switchport mode trunk 
no ip address 
channel-group 1 mode desirable 
!
interface FastEthernet4/4
!--- Повторная настройка магистрали и канала.
  

switchport 
switchport trunk encapsulation dot1q 
switchport mode trunk 
no ip address 
channel-group 1 mode desirable 
!
interface FastEthernet4/5
!--- Повторная настройка магистрали и канала. 


switchport
switchport trunk encapsulation dot1q
switchport mode trunk 
no ip address 
channel-group 1 mode desirable 
!
interface FastEthernet4/6 
no ip address 
shutdown
!
!
interface VLAN 1 
ip address 10.10.10.2  255.255.255.0
!
ip classless
no ip http server
!
!
line con 0
line vty 0 4
!
end
Cat6500# 

Проверка: магистральное соединение ISL

Используйте этот раздел для того, чтобы подтвердить, что ваша конфигурация работает правильно.

Средство Интерпретатор выходных данных (OIT) (только для зарегистрированных клиентов) поддерживает некоторые команды show. Используйте OIT для просмотра аналитики выходных данных команды show.

Catalyst 3500 XL

Cat3500XL#show cdp neighbor  
Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
                  S - Switch, H - Host, I - IGMP, r - Repeater

Device ID        Local Intrfce     Holdtme    Capability  Platform  Port ID
Cat3500XL        Fas 0/20           136        R S I      Catalyst 6Fas 4/5
Cat3500XL        Fas 0/19           136        R S I      Catalyst 6Fas 4/4
Cat3500XL        Fas 0/18           136        R S I      Catalyst 6Fas 4/3
Cat3500XL        Fas 0/17           136        R S I      Catalyst 6Fas 4/2
Cat3500XL#



Cat3500XL#show port group 
Group  Interface              Transmit Distribution
-----  ---------------------  ---------------------
1  FastEthernet0/18       source address
1  FastEthernet0/17       source address
1  FastEthernet0/20       source address
1  FastEthernet0/19       source address
Cat3500XL#


Cat3500XL#show etherchannel summary
Flags:  d - default     D - down
I - in use

Group Ports
----- -----
1     Fa0/18(I) Fa0/17(Id) Fa0/20(I) Fa0/19(I)
Cat3500XL#

Примечание. Выполнение команды show etherchannel summary на восьмипортовом EtherChannel может привести к аварийному отказу коммутатора под управлением версий ПО более ранних, чем ПО Cisco IOS версии 12.0(5)WC5.

Cat3500XL#show interfaces fastethernet0/17 switchport 
Name: Fa0/17
Switchport: Enabled
Administrative mode: trunk
Operational Mode: trunk
Administrative Trunking Encapsulation: isl
Operational Trunking Encapsulation: isl
Negotiation of Trunking: Disabled
Access Mode VLAN: 0 ((Inactive))
Trunking Native Mode VLAN: 1 (default)
Trunking VLANs Enabled: ALL
Trunking VLANs Active: 1,2
Pruning VLANs Enabled: 2-1001

Priority for untagged frames: 0
Override vlan tag priority: FALSE
Voice VLAN: none
Appliance trust: none
Cat3500XL#

Catalyst 6500 (ПО Cisco IOS)

Cat6500#show interfaces fastethernet 4/2 capabilities 
FastEthernet4/2
Model:                 WS-X6248-RJ-45
Type:                  10/100BaseTX
Speed:                 10,100,auto
Duplex:                half,full
Trunk encap. type:     802.1Q,ISL
Trunk mode:            on,off,desirable,nonegotiate
Channel:               yes
Broadcast suppression: percentage(0-100)
Flowcontrol:           rx-(off,on),tx-(none)
Fast Start:            yes
QOS scheduling:        rx-(1q4t), TX(2q2t)
CoS rewrite:           yes
ToS rewrite:           yes
Inline power:          no
SPAN:                  source/destination

Cat6500#

Cat6500#show cdp neighbors
Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
                  S - Switch, H - Host, I - IGMP, r - Repeater

Device ID        Local Intrfce     Holdtme    Capability  Platform  Port ID
Cat6500          Fas 4/5            135         T S       WS-C3548-XFas 0/20
Cat6500          Fas 4/4            135         T S       WS-C3548-XFas 0/19
Cat6500          Fas 4/3            134         T S       WS-C3548-XFas 0/18
Cat6500          Fas 4/2            134         T S       WS-C3548-XFas 0/17
Cat6500#


Cat6500#show interfaces port-channel 1 etherchannel 
Age of the Port-channel   = 01d:07h:30m:43s
Logical slot/port   = 14/1           Number of ports = 4
GC                  = 0x00010001      HotStandBy port = null
Port state          = Port-channel Ag-Inuse 

Ports in the Port-channel: 

Index   Load   Port    EC state
------+------+------+------------
0     11     Fa4/2    on         
1     22     Fa4/3    on         
2     44     Fa4/4    on         
3     88     Fa4/5    on         

Time since last port bundled:    01d:06h:51m:22s    Fa4/5
Time since last port Un-bundled: 01d:06h:52m:30s    Fa4/5

Cat6500#


Cat6500#show etherchannel ?
<1-269>       Channel group number
brief         Brief information
detail        Detail information
load-balance  Load-balance/frame-distribution scheme among ports in
port-channel
port          Port information
port-channel  Port-channel information
summary       One-line summary per channel-group


Cat6500#show etherchannel summary 
Flags:  D - down        P - in port-channel
I - stand-alone s - suspended
R - Layer3      S - Layer2
U - port-channel in use
Group Port-channel  Ports
-----+------------+-----------------------------------------------------------
1     Po1(SU)     Fa4/2(P)   Fa4/3(P)   Fa4/4(P)   Fa4/5(P)   

Cat6500#


Cat6500#show etherchannel port-channel 
Channel-group listing: 
-----------------------

Group: 1 
----------
Port-channels in the group: 
----------------------

Port-channel: Po1
------------

Age of the Port-channel   = 01d:07h:35m:28s
Logical slot/port   = 14/1           Number of ports = 4
GC                  = 0x00010001      HotStandBy port = null
Port state          = Port-channel Ag-Inuse 

Ports in the Port-channel: 

Index   Load   Port    EC state
------+------+------+------------
0     11     Fa4/2    on         
1     22     Fa4/3    on         
2     44     Fa4/4    on         
3     88     Fa4/5    on         

Time since last port bundled:    01d:06h:56m:08s    Fa4/5
Time since last port UN-bundled: 01d:06h:57m:15s    Fa4/5


Cat6500#show interfaces port-channel 1 switchport
Name: Po1
Switchport: Enabled
Administrative Mode: trunk
Operational Mode: trunk
Administrative Trunking Encapsulation: isl
Operational Trunking Encapsulation: isl
Negotiation of Trunking: On
Access Mode VLAN: 1 (default)
Trunking Native Mode VLAN: 1 (default)
Administrative private-vlan host-association: none 
Administrative private-vlan mapping: none 
Operational private-vlan: none 
Trunking VLANs Enabled: ALL
Pruning VLANs Enabled: 2-1001

Cat6500#

Проверка: магистральное соединение 802.1Q

Используйте этот раздел для того, чтобы подтвердить, что ваша конфигурация работает правильно.

Средство Интерпретатор выходных данных (OIT) (только для зарегистрированных клиентов) поддерживает некоторые команды show. Используйте OIT для просмотра аналитики выходных данных команды show.

Catalyst 2950

Cat2950#show cdp neighbors 
Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
                  S - Switch, H - Host, I - IGMP, r - Repeater

Device ID        Local Intrfce     Holdtme    Capability  Platform  Port ID
Cat2950          Fas 0/4            120        R S I      Catalyst 6Fas 4/4
Cat2950          Fas 0/5            120        R S I      Catalyst 6Fas 4/5
Cat2950          Fas 0/3            120        R S I      Catalyst 6Fas 4/3
Cat2950          Fas 0/2            120        R S I      Catalyst 6Fas 4/2
Cat2950#



Cat2950#show etherchannel port-channel
Channel-group listing: 
-----------------------

Group: 1 
----------
Port-channels in the group: 
----------------------

Port-channel: Po1
------------

Age of the Port-channel   = 01d:08h:27m:08s
Logical slot/port   = 1/0           Number of ports = 4
GC                  = 0x00010001      HotStandBy port = null
Port state          = Port-channel Ag-Inuse 

Ports in the Port-channel: 

Index   Load   Port    EC state
------+------+------+------------
0     00     Fa0/2    desirable-SL  
0     00     Fa0/3    desirable-SL  
0     00     Fa0/4    desirable-SL  
0     00     Fa0/5    desirable-SL  

Time since last port bundled:    00d:00h:07m:17s    Fa0/5
Time since last port UN-bundled: 01d:08h:10m:06s    Fa0/5

Cat2950#



Cat2950#show etherchannel load-balance 
Source MAC address
Cat2950#


Cat2950#show interfaces port-channel 1 switchport 
Name: Po1
Switchport: Enabled
Administrative Mode: trunk
Operational Mode: trunk
Administrative Trunking Encapsulation: dot1q
Operational Trunking Encapsulation: dot1q
Negotiation of Trunking: On
Access Mode VLAN: 1 (default)
Trunking Native Mode VLAN: 1 (default)
Trunking VLANs Enabled: ALL
Pruning VLANs Enabled: 2-1001

Protected: false

Voice VLAN: none (Inactive)
Appliance trust: none
Cat2950#

Catalyst 6500 по управлением Cisco IOS

Cat6500#show etherchannel port-channel 
Channel-group listing: 
-----------------------

Group: 1 
----------
Port-channels in the group: 
----------------------

Port-channel: Po1
------------

Age of the Port-channel   = 01d:08h:25m:07s
Logical slot/port   = 14/1           Number of ports = 4
GC                  = 0x00010001      HotStandBy port = null
Port state          = Port-channel Ag-Inuse 

Ports in the Port-channel: 

Index   Load   Port    EC state
------+------+------+------------
1     11     Fa4/2    desirable-SL  
3     22     Fa4/3    desirable-SL  
0     44     Fa4/4    desirable-SL  
2     88     Fa4/5    desirable-SL  

Time since last port bundled:    00d:00h:09m:53s    Fa4/3
Time since last port UN-bundled: 00d:00h:09m:56s    Fa4/5

Cat6500#

Устранение неполадок

Данный раздел предназначен для устранения неполадок конфигурации.

Отсутствует передача трафика на магистрали 802.1Q

Возможная причина проблемы:

  • Несовпадение конфигурации стандартной VLAN на портах, подключенных между двумя коммутаторами.

    Необходимо проверить конфигурацию VLAN на обоих коммутаторах. С помощью команды show trunk на коммутаторе CatOS можно просмотреть настройки стандартной VLAN. С помощью команды show interface interface_id switchport на коммутаторе XL можно просмотреть настройки стандартной VLAN. При несовпадении стандартной VLAN между двумя коммутаторами их необходимо настроить на одну стандартную VLAN. С помощью команды настройки интерфейса switchport trunk native vlan на коммутаторе XL можно изменить стандартную VLAN. С помощью команды set vlan на коммутаторе CatOS можно изменить стандартную VLAN.

  • Коммутаторы XL не поддерживают кадры протокола DTP.

    Коммутаторы CatOS отправляют кадры протокола DTP по магистральному каналу, а коммутаторы XL не поддерживают кадры протокола DTP. Протокол DTP не поддерживается на коммутаторах XL. Чтобы устранить эту проблему, необходимо настроить состояние порта коммутатора CatOS на несогласование. С помощью команды set trunk mod/port nonegotiate dot1q можно настроить несогласование режима магистрального соединения для магистрали dot1q.

  • Несовпадение инкапсуляции на коммутаторе XL.

    На коммутаторе XL необходимо проверить, настроена ли инкапсуляция магистрали на dot1q. С помощью команды show interface interface_id switchport можно просмотреть текущую настройку. С помощью команды настройки интерфейса switchport trunk encapsulation dot1q можно установить инкапсуляцию dot1q.

  • Более ранние версии CatOS не поддерживают магистральное соединение dot1q.

    Более ранние версии CatOS, используемые на коммутаторах, не поддерживают магистральное соединение dot1q. Обновите текущую версию CatOS коммутатора на более позднюю, поддерживающую магистральное соединение dot1q и ISL.

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения


Document ID: 22422