Голосовая связь и система унифицированных коммуникаций : Cisco Unity Express

Пример совместимости конфигураций основного автоматического распределения вызовов Cisco CME и Cisco Unity Express услугой автоответчика

29 июля 2008 - Перевод, выполненный профессиональным переводчиком
Другие версии: PDF-версия:pdf | Машинный перевод (28 июля 2013) | Английский (4 мая 2007) | Отзыв

Содержание

Введение
Предварительные условия
     Требования
     Используемые компоненты
     Родственные продукты
     Условные обозначения
Общие сведения
Настройки
     Схема сети
     Конфигурации
     Примечания к конфигурациям основного исполнения
Сценарий 1 – использование Cisco CME Basic ACD совместно с голосовой почтой Cisco Unity Express
     Маршрут вызова
     Примечания к конфигурациям сценария 1
     Настройка Cisco CME для сценария 1
     Настройка Cisco Unity Express для сценария 1
Сценарий 2 – использование автоответчика Cisco Unity Express в качестве основного меню, а Basic ACD – в качестве второстепенного меню
     Маршрут вызова сценария 2
     Примечания к конфигурациям сценария 2
     Настройка Cisco CME для сценария 2
     Настройка Cisco Unity Express для сценария 2
     Сценарий 2 Изменение конфигураций 1 – персональные GDM для каждой поисковой группы
     Сценарий 2 Изменение конфигурации 2 – персональные GDM для каждой группы ACD
     Сценарий 2 Изменение конфигураций 3 – использование функции Drop (удаление) с помощью функциональных возможностей CD
Сценарий 3 – использование Basic ACD в качестве основного меню, а автоответчика Cisco Unity Express – в качестве второстепенного меню
     Маршрут вызова сценария 3
     Примечания к конфигурациям сценария 3
     Настройка Cisco CME для сценария 3
     Настройка Cisco Unity Express для сценария 3
Проверка
Устранение неполадок
Связанные обсуждения сообщества поддержки Cisco
Дополнительные сведения

Введение

В данном документе приведены примеры конфигураций для использования Cisco CallManager Express (CME) основного автоматического распределения вызовов (ACD) и Cisco Unity Express с услугой автоответчика (AA).

Предварительные условия

Требования

Необходимы базовые знания о конфигурации Cisco CME и Cisco Unity Express. Главной темой данного документа является совместимость конфигураций Cisco CME Basic ACD и Cisco Unity Express AA.

Минимальные версии для функциональных возможностей, описанных в этом примере конфигураций:

  • Cisco CME 3.3

  • Cisco IOS® Software Release 12.4.3

  • Cisco Unity Express 2.1.3

Используемые компоненты

Сведения, содержащиеся в данном документе, касаются следующих версий программного и аппаратного обеспечения:

  • Маршрутизатор Cisco 2821 для запуска Cisco CME и Cisco Unity Express

  • ПО Cisco IOS версии 12.4.3

  • Cisco CME 3.3

  • Сценарий основного ACD версии 2.1.0.0

  • Cisco Unity Express 2.1.3

  • Установленная функция IP Voice Cisco IOS

Данные для документа были получены в специально созданных лабораторных условиях. Все устройства, используемые в данном документе, были запущены с чистой (заданной по умолчанию) конфигурацией. Если сеть работает в реальных условиях, убедитесь, что вы понимаете потенциальное воздействие каждой команды.

Родственные продукты

Данная конфигурация также может применяться для маршрутизаторов серий Cisco 2600XM, Cisco 3700, Cisco 2800 или Cisco 3800 с программным обеспечением Cisco IOS версии 12.4.1 или более поздней.

Условные обозначения

Дополнительную информацию о применяемых в документе обозначениях см. в документе Условные обозначения, используемые в технической документации Cisco.

Общие сведения

В этом документе рассмотрены следующие три сценария:

  • Сценарий 1 – использование групп Cisco CME AA и ACD совместно с Cisco Unity Express только в качестве голосовой почты

  • Сценарий 2 – использование Cisco Unity Express в качестве точки входа основного автоответчика и автоответчик Cisco CME AA в качестве "подменю" в пределах этого автоответчика

  • Сценарий 3 – использование Cisco CME AA в качестве точки входа основного автоответчика, а также Cisco Unity Express AA для получения универсальных "сообщений", как элемента услуги автоответчика

Сценарий 1 является наиболее приемлемым в случае, когда автоответчик Cisco CME ограничен в обеспечении меню прямыми вызовами в группы ACD. В данном сценарии Cisco CME используется в качестве автоответчика для входящих вызовов, а Cisco Unity Express – только как сервер голосовой почты, когда агенты ACD не имеют возможности ответить на вызовы в определенный период времени. Автоответчик Cisco Unity Express не используется в данном сценарии.

Сценарий 2 является наиболее универсальные конфигурации для объединения Cisco CME основного ACD и автоответчика Cisco Unity Express. Устройство, применяемое в сценарии 2, отличает автоответчик Cisco Unity Express автоматизацией основного управления вызовов и передачей вызовов агентам ACD. В этом сценарии Cisco Unity Express используется в качестве автоответчика для входящих вызовов, Cisco Unity Express также предоставляет различные параметры меню для звонящего (набор по имени, набор с помощью добавочного номера, а также сегменты зарегистрированной информации). Один из выбора меню направляет некоторые вызовы в группы Cisco CME ACD. Голосовая почта Cisco Unity Express применяется так же, как и сценарий 1.

Сценарий 3 является одной из разновидностей сценария 1, в котором Cisco CME АА используется в качестве автоответчика для входящих вызовов, а ACD является основной функцией, требуемой для автоответчика. Однако, автоответчик Cisco Unity Express используется в качестве "сервера сообщений" совместно с автоответчиком Cisco CME. Это дает возможность добавить несколько сообщений (таких как часы работы или расположение), что недоступно при использовании единственного автоответчика Cisco CME.

Примечание. Описанные в данном издании процедуры конфигураций, основанные на системе GUI, применяются для иллюстрации реализации процесса, связанного с этим примером конфигураций, а также для суммирования этапов, необходимых для выполнения функций, описанных в документе. Однако, полные пошаговые операции не предусмотрены. Данный документ предполагает наличие знаний о Cisco CME и Cisco Unity Express GUIs, а также рабочие навыки с Cisco IOS CLI. Для получения более подробной информации о применении процедур и команд см. соответствующее руководство администратора Cisco CME и Cisco Unity Express, руководство по настройке, а также справочное руководство.

Настройка

В этом разделе приводится информация по настройке функций, описанных в данном документе.

Примечание. Для получения дополнительных сведений о командах, используемых в данном разделе, см. Средство поиска команд (только для зарегистрированных клиентов).

Схема сети

В данном документе используется следующая настройка сети:

Рисунок 1 Схема сети для Cisco CME Basic ACD и Cisco Unity Express AA

135345.jpg

Конфигурации

Все сценарии конфигураций имеют следующие основные характеристики:

  • Сосредоточенная система Cisco CME

  • Каналы связи PSTN, объединенные на маршрутизаторе Cisco CME

  • Конфигурации задают 4-значную схему набора номера с использованием IP-телефона с добавочным номером в диапазоне от 2000 до 2010, без использования телефона (например, поисковая группа портов) – добавочный номер в диапазоне от 2020 до 2099, а также точки входа Cisco Unity Express с добавочным номером 21 xx.

  • Определены девять IP-телефонов, добавочный номер от 2000 до 2009.

  • Устройство ACD использует три поисковые группы с тремя IP-телефонами в каждой.

  • Заданы два секретаря, которые также являются элементами девяти IP-телефонов в группах ACD.

Настройки сети используют маршрутизатор Cisco 2821 со следующими характеристиками:

  • Доступ к IP-сети через IP-адрес b .168.1.1

  • Конфигурации Cisco CME с девятью IP-телефонами, каждый с 4-значным добавочным номером (от 2001 до 2010)

  • NM-CUE

  • IP-адрес Cisco Unity Express a .1.11.2

В данном примере используются следующие конфигурации:

Примечания к конфигурациям основного исполнения

Возможность соединения PSTN, используемого в этих конфигурациях, доступна лишь благодаря каналам связи телефонной станции с международным коммутатором (FXO). При наличии канала связи PRI конфигурации имеют те же настройки, что и в примере, представленном в данном издании, с добавлением данных записей конфигураций:

controller T1 2/1
 framing esf
 linecode b8zs
 pri-group timeslots 1-24
!
interface Serial2/1:23
 no ip address
 isdn switch-type primary-ni
 isdn incoming-voice voice
 no cdp enable
!
voice-port 2/1:23
!
dial-peer voice 777 pots
 incoming called-number .
 direct-inward-dial
 port 2/1:23

Сценарии автоответчика Cisco Unity Express, используемые в примерах, которые представлены в данном документе, очень просты и для удобства содержат минимальное количество функций для получения функциональных возможностей, описанных в данном документе. Сценарии Cisco Unity Express, разворачиваемые в реальной сети должны иметь значительно больше возможностей для обработки телефонных вызовов по сравнению с сетями, тестируемыми в лаборатории. Дополнительный "этап" обработки телефонных вызовов может включать следующие элементы:

  • Уточненная обработка ошибок (например, когда пользователь нажимает на кнопки, которых нет в меню)

  • Обработка времени ожидания (например, повтор меню фиксированное число раз)

  • Возможность блокировать внешнюю передачу вызовов на внешнее устройство PSTN (во избежание проблем, связанных с налоговым мошенничеством).

Сценарий 1 – использование Cisco CME Basic ACD совместно с голосовой почтой Cisco Unity Express

В сценарии 1 входящие вызовы направляются на автоответчик Cisco CME (добавочный 2040), который обеспечивает приятное приветствие и предлагает звонящему меню с тремя функциями. В зависимости от выбора звонящего вызов пересылается в одну из трех поисковых групп ACD. Если вызов остался неотвеченным и в группе ACD, он перенаправляется в общий почтовый ящик (GDM) для того, чтобы звонящий мог оставить сообщение.

Примечание. GDM не может быть скопирован в почтовый ящик каждого пользователя (также, как и список абонентов).

В этом сценарии, описанном в этом разделе, используется один GDM, таким образом все девять агентов ACD в группе ACD могут быть занесены в журнал и выполнять поиск сообщений. В других случаях, представленных в качестве элемента сценария 2, рассматривается возможность каждой группы ACD иметь отдельный GDM.

Маршрут вызова

Маршрут вызова конфигураций в этом разделе изображен на рисунке 2.

Рисунок 2 Автоответчик Cisco Unity Express с маршрутом вызова сценария 1 Cisco CME Basic ACD

135346.jpg

Примечания к конфигурациям сценария 1

Вызовы PSTN, поступающие из порта FXO (0/3/0), автоматически завершаются (с помощью команды connection plar-opx 2040) в телефонный номер доступа автоответчика Cisco CME (2040). Автоответчик Cisco CME предлагает приветствие и меню с тремя функциями – голосовое содержание подсказок представлено на схеме маршрута вызова на рисунке 2 . Записанные фразы приветствия хранятся на флэш-файле en_bacd_welcome.au, а записанные фразы меню – на file en_bacd_options_menu.au.

Сообщения приветствия GDM для добавочного номера 2070: "Спасибо, что обратились в отдел работы с клиентами; в данный момент никого нет на месте. Пожалуйста, оставьте сообщение и мы ответим на ваш звонок по мере возможности."

Индикатор "сообщение" (MWI) для сообщений в GDM появляется при прохождении автоответчика Cisco CME (команда param voice-mail 2070) в промежуточный добавочный номер (2070), который является CFA (переадресация вызовов) в телефонный номер доступа голосовой почты (2105). Пересылка выполняется вместо прямого направления автоответчика Cisco CME на телефонный номер доступа голосовой почты; это было бы выполнено с помощью команды param voice-mail 2105. Для добавочного номера 2070 используется кнопка 2 на телефоне агента, и эта кнопка отображает MWI для GDM, связанный с добавочным номером 2070, в отличие от добавочных номеров поисковых групп ACD (2020, 2021 или 2022). "Конечные" номера не настроены в поисковых группах, так как логика ACD обходит конечные номера для получения номера автоответчика (команда param voice-mail).

Примечание. При любом изменении сценария необходимо загрузить приложение.

Сценарий автоответчика Cisco CME связан со шлейфовым IP-адресом (a .1.1.1) для проверки того, что сценарий инструментального командного языка (TCL) будет всегда выше, независимо от состояния интерфейсов LAN (команда dial-peer voice 2040 voip). Последовательный набор при одноранговом узле связи используется для выполнения прямых звонков в точку входа автоответчика Cisco CME (2040) для предоставления звонящим PSTN (также, как и местным IP-телефонам) возможности совершать звонки на автоответчик (команда dial-peer voice 2041 voip).

Настройка Cisco CME для сценария 1

Эти этапы объединяют конфигурации для Cisco CME для сценария 1:

  1. Выберите Configure > System Parameters для настройки трех поисковых групп ACD 2020, 2021 и 2022, связанных с тремя параметрами меню автоответчика Cisco CME. См. рисунок 3.

    Рисунок 3 Определение поисковых групп Cisco Unity Express ACD

    135352.jpg

  2. Выберите Configure > System Parameters для настройки элементов для поисковых групп 2020 с агентами 2001, 2002 и 2003. См. рисунок 4.

    Рисунок 4 Настройка элементов поисковой группы 2020

    135353.jpg

  3. Выберите Configure > Phones и отметьте MAC-адрес того телефона, который нужно изменить. Появится окно изменения телефона (см. рисунок 5).

  4. Введите добавочный номер 2070 в телефон агента ACD для получения MWI для сообщений в GDM.

    Рисунок 5 Связывание добавочных номеров с определенными кнопками

    135354.jpg

Ниже представлены завершенные (и аннотированные) конфигурации маршрутизатора CLI Cisco CME для сценария 1, являющийся результатом специальных изменений базовых конфигураций.

CME-2821#show running-config
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname CME-2821
!
boot-start-marker
boot system flash:
boot-end-marker
!
no aaa new-model
!
resource policy
!
ip subnet-zero
!
!
ip cef
no ip dhcp use vrf connected
ip dhcp excluded-address b.168.1.1 b.168.1.10
!
ip dhcp pool ITS
   network b.168.1.0 255.255.255.0
   option 150 ip a.1.11.1 
   default-router b.168.1.1 
!
no ip domain lookup
!
voice-card 0
 no dspfarm
!
voice service voip 
 allow-connections h323 to h323
 allow-connections h323 to sip
 supplementary-service h450.12 advertise-only
!
!--- Задайте параметры сценария Cisco CME ACD TCL. 
!--- Поисковыми группами для ACD
!--- являются 2020, 2021 и 2022.

!
application
 service acd flash:app-b-acd-2.1.0.0.tcl
  param queue-cme-debugs 1
  param aa-hunt1 2020
  param aa-hunt2 2021
  param number-of-hunt-grps 3
  param aa-hunt3 2022
  param queue-len 30
 !
!--- Определите параметры сценария Cisco CME AA TCL. 
!--- Телефонный номер доступа – 2040.
!--- Абонентским номером голосовой почты является добавочный номер 2070, который
!--- является отсортированным по маршруту CFA, т.е. производит переадресацию вызовов на голосовую почту (2105).

!
 service cme-aa flash:app-b-acd-aa-2.1.0.0.tcl
  param max-time-call-retry 60
  param voice-mail 2070
  paramspace english index 0
  param service-name acd
  param number-of-hunt-grps 3
  param handoff-string cme-aa
  paramspace english language en
  param max-time-vm-retry 1
  paramspace english location flash:
  param aa-pilot 2040
  param second-greeting-time 30
  paramspace english prefix en
  param call-retry-timer 20
!
!--- Задайте шлейфовый адрес, к которому привязан сценарий TCL.

!
interface Loopback0
 ip address a.1.11.1 255.255.255.252
!
interface GigabitEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet0/1/0
 switchport access vlan 10
!
interface FastEthernet0/1/1
 switchport access vlan 10
!
interface FastEthernet0/1/2
 switchport access vlan 10
!
interface FastEthernet0/1/3
 switchport access vlan 10
!
interface FastEthernet0/1/4
 switchport access vlan 10
!
interface FastEthernet0/1/5
 switchport access vlan 10
!
interface FastEthernet0/1/6
 switchport access vlan 10
!
interface FastEthernet0/1/7
 switchport access vlan 10
!
interface FastEthernet0/1/8
 switchport access vlan 10
!
interface Service-Engine1/0
 ip unnumbered Loopback0
 service-module ip address a.1.11.2 255.255.255.252
 service-module ip default-gateway a.1.11.1
!
interface Vlan1
 no ip address
!
interface Vlan10
 ip address b.168.1.1 255.255.255.0
!
ip classless
ip route a.1.11.2 255.255.255.255 Service-Engine1/0
!
ip http server
ip http path flash:
!
tftp-server flash:P00305000600.bin
tftp-server flash:P00305000600.sbn
!
control-plane
!
!--- Вызовы PSTN автоматически прекращаются при телефонном номере доступа автоответчика Cisco CME 2040.

!
voice-port 0/3/0
 connection plar opx 2040
!
voice-port 0/3/1
 connection plar opx 2040
!
voice-port 0/3/2
!
voice-port 0/3/3
!
!--- Вызовы, поступающие на телефонный номер доступа автоответчика Cisco CME
!--- связаны со шлейфовым адресом a.1.11.1 для того, чтобы сценарий TCL был всегда выше.

!
dial-peer voice 2040 voip
 destination-pattern 2040
 session target ipv4:a.1.11.1
 dtmf-relay h245-alphanumeric
 codec g711ulaw
 no vad
!
!--- Последовательный набор при одноранговом узле связи 
!--- для телефонного номера доступа автоответчика Cisco CME
!--- указывает на сценарий TCL 
!--- автоответчика для того, чтобы как PSTN, так и внутренние вызовы имели бы доступ к автоответчику.

!
dial-peer voice 2041 voip
 service cme-aa
 incoming called-number 2040
 dtmf-relay h245-alphanumeric
 codec g711ulaw
 no vad
!
!--- Все вызовы в диапазоне 21xx направляются в Cisco Unity Express.

!
dial-peer voice 2105 voip
 destination-pattern 21..
 session protocol sipv2
 session target ipv4:a.1.11.2
 dtmf-relay sip-notify
 codec g711ulaw
 no vad
!
telephony-service
 load 7960-7940 P00305000300
 max-ephones 48
 max-dn 192
 ip source-address a.1.11.1 port 2000
 max-redirect 20
 auto assign 1 to 10
 system message CISCO SYSTEMS
 create cnf-files version-stamp 7960 Aug 05 2005 00:00:32
 voicemail 2105
 max-conferences 8 gain -6
 moh music-on-hold.au
 dn-webedit 
 time-webedit 
 transfer-system full-consult
 transfer-pattern 210. blind
 transfer-pattern 2040 blind
!
!--- Данный раздел предлагает девять добавочных номеров агентов АCD.

!
ephone-dn  1  dual-line
 number 2001
 name User21
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  2  dual-line
 number 2002
 name User22
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  3  dual-line
 number 2003
 name User23
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  4  dual-line
 number 2004
 name User24
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  5  dual-line
 number 2005
 name User25
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  6  dual-line
 number 2006
 name User26
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  7  dual-line
 number 2007
 name User27
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  8  dual-line
 number 2008
 name User28
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  9  dual-line
 number 2009
 name User29
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
!--- Добавочный номер 2070 связан с GDM. 
!--- Этот добавочный номер используется
!--- для получения MWI на номер агента ACD.

!
ephone-dn  11
 number 2070
 description GDM
 name Cust Svc GDM
 call-forward all 2105
!
ephone-dn  100
 number 8000....
 mwi on
!
ephone-dn  101
 number 8001....
 mwi off
!
!--- Данный раздел иллюстрирует определение номеров для агентов ACD.
!--- Телефон – набираемый номер 11 (2070),
!--- кнопка 2 на каждом телефоне, поэтому каждый агент может получить MWI для GDM).

!
ephone  1
 username "user21" password null
 mac-address 0012.0034.81B7
 type 7960
 button  1:1 2:11
!
ephone  2
 username "user22" password null
 mac-address 0011.2032.C876
 type 7960
 button  1:2 2:11
!
ephone  3
 username "user23" password null
 mac-address 0012.01E8.875F
 type 7960
 button  1:3 2:11
!
ephone  4
 username "user24"
 mac-address 0003.AAAA.0004
 type 7960
 button 1:4 2:11
!
ephone 5
 username "user25"
 mac-address 0003.AAAA.0005
 type 7960
 no auto-line
 button 1:5 2:11
!
ephone 6
 username "user26"
 mac-address 0003.AAAA.0006
 type 7960
 button 1:6 2:11
!
ephone 7
 username "user27"
 mac-address 0003.AAAA.0007
 type 7960
 button 1:7 2:11
!
ephone 8
 username "user28"
 mac-address 0003.AAAA.0008
 type 7960
 button 1:8 2:11
!
ephone  9
 username "user29"
 mac-address 0003.AAAA.0009
 type 7960
 button 1:9 2:11
!
!--- Для сценариев ACD предназначены три поисковые группы. 
!--- Каждая группа имеет три агента.

!
ephone-hunt 1 longest-idle
 pilot 2020
 list 2001, 2002, 2003
 timeout 5
!
ephone-hunt 2 longest-idle
 pilot 2021
 list 2004, 2005, 2006
 timeout 5
!
ephone-hunt 3 longest-idle
 pilot 2022
 list 2007, 2008, 2009
 timeout 5
!
line con 0
 logging synchronous
line aux 0
line 66
 no activation-character
 no exec
 transport preferred none
 transport input all
 transport output all
line vty 0 4
 login
!
scheduler allocate 20000 1000
ntp master
!
end

Настройка Cisco Unity Express для сценария 1

Эти этапы объединяют конфигурации для Cisco Unity Express для сценария 1:

  1. Выберите Configure > Groups. Затем отметьте группу (обслуживание клиентов), которую необходимо редактировать. Появится окно "Group Profile" (см. рисунок 6).

  2. Вкладка "Profile" настроена по умолчанию. Настройте группу обслуживания клиентов в соответствии с добавочным номером 2070.

    Рисунок 6 Настройка профиля группы

    142424.jpg

  3. Нажмите вкладку "Owners/Members" (см. рисунок 7).

  4. Настройте все элементы (все девять пользователей агента ACD) группы обслуживания клиентов.

    Рисунок 7 Настройка элементов группы

    135356.jpg

Ниже представлены завершенные (и аннотированные) конфигурации Cisco Unity Express CLI для сценария 1, являющийся результатом специальных изменений базовых конфигураций.

cue#show running-config
Generating configuration:
clock timezone America/Los_Angeles
hostname cue
ip domain-name cisco.com
ntp server a.1.11.1
groupname Administrators create
groupname Broadcasters create
!
!--- Группа обслуживания клиентов 
!---объединяет в себе всех пользователей, имеющих доступ к GDM.

!
groupname custservice create
!
!--- Девять агентов ACD определены, как пользователи.

!
username admin create
username user21 create
username user22 create
username user23 create
username user24 create
username user25 create
username user26 create
username user27 create
username user28 create
username user29 create
!
!--- Группа обслуживания клиентов (а, следовательно, и GDM) 
!--- связана с добавочным номером 2070.

!
groupname custservice phonenumber "2070"
username user21 phonenumber "2001"
username user22 phonenumber "2002"
username user23 phonenumber "2003"
username user24 phonenumber "2004"
username user25 phonenumber "2005"
username user26 phonenumber "2006"
username user27 phonenumber "2007"
username user28 phonenumber "2008"
username user29 phonenumber "2009"
groupname Administrators member admin
!
!--- Девять пользователей агента ACD являются элементами 
!--- группы обслуживания клиентов,
!--- таким образом у них есть доступ к ACD для поиска сообщений.

!
groupname custservice member user21
groupname custservice member user22
groupname custservice member user23
groupname custservice member user24
groupname custservice member user25
groupname custservice member user26
groupname custservice member user27
groupname custservice member user28
groupname custservice member user29
groupname Administrators privilege superuser
groupname Administrators privilege ManagePrompts
groupname Administrators privilege ManagePublicList
groupname Administrators privilege ViewPrivateList
groupname Broadcasters privilege broadcast
calendar biz-schedule systemschedule
 closed day 1 from 00:00 to 24:00
 open day 2 from 09:00 to 17:00
 open day 3 from 09:00 to 17:00
 open day 4 from 09:00 to 17:00
 open day 5 from 09:00 to 17:00
 open day 6 from 09:00 to 17:00
 closed day 7 from 00:00 to 24:00
end schedule
!
!--- Система автоответчика Cisco Unity Express 
!--- определена в системе по умолчанию, но
!--- не используется в сценарии.

!
ccn application autoattendant
 description "autoattendant"
 enabled
 maxsessions 8
 script "aa.aef"
 parameter "busOpenPrompt" "AABusinessOpen.wav"
 parameter "holidayPrompt" "AAHolidayPrompt.wav"
 parameter "busClosedPrompt" "AABusinessClosed.wav"
 parameter "allowExternalTransfers" "false"
 parameter "MaxRetry" "3"
 parameter "operExtn" "2001"
 parameter "welcomePrompt" "AAWelcome.wav"
 parameter "businessSchedule" "systemschedule"
 end application
ccn application ciscomwiapplication
 description "ciscomwiapplication"
 enabled
 maxsessions 8
 script "setmwi.aef"
 parameter "strMWI_OFF_DN" "8001"
 parameter "strMWI_ON_DN" "8000"
 parameter "CallControlGroupID" "0"
 end application
ccn application promptmgmt
 description "promptmgmt"
 enabled
 maxsessions 1
 script "promptmgmt.aef"
 end application
ccn application voicemail
 description "voicemail"
 enabled
 maxsessions 8
 script "voicebrowser.aef"
 parameter "logoutUri" "http://localhost/voicemail/vxmlscripts/mbxLogout.jsp"
 parameter "uri" "http://localhost/voicemail/vxmlscripts/login.vxml"
 end application
ccn engine
 end engine
ccn subsystem jtapi
 ccm-manager address 0.0.0.0 
 end subsystem
ccn subsystem sip
 gateway address "a.1.11.1"
 end subsystem
ccn trigger sip phonenumber 2102
 application "autoattendant"
 enabled
 maxsessions 8
 end trigger
ccn trigger sip phonenumber 2105
 application "voicemail"
 enabled
 maxsessions 8
 end trigger
ccn trigger sip phonenumber 2106
 application "promptmgmt"
 enabled
 maxsessions 1
 end trigger
voicemail default language en_US
voicemail default mailboxsize 3000
voicemail broadcast recording time 300
voicemail operator telephone 2001
!
!--- Определите GDM, 
!--- связанный с номером 2070, который в свою очередь связан с группой обслуживания клиентов.

!
voicemail mailbox owner "custservice" size 3000
 description "custservice mailbox"
 end mailbox
!
!--- Задайте личные почтовые ящики для девяти агентов ACD.

!
voicemail mailbox owner "user21" size 3000
 end mailbox
voicemail mailbox owner "user22" size 3000
 end mailbox
voicemail mailbox owner "user23" size 3000
 end mailbox
voicemail mailbox owner "user24" size 3000
description "user24 mailbox"
end mailbox
voicemail mailbox owner "user25" size 3000
description "user25 mailbox"
end mailbox
voicemail mailbox owner "user26" size 3000
description "user26 mailbox"
end mailbox
voicemail mailbox owner "user27" size 3000
description "user27 mailbox"
end mailbox
voicemail mailbox owner "user28" size 3000
description "user28 mailbox"
end mailbox
voicemail mailbox owner "user29" size 3000
description "user29 mailbox"
end mailbox
end

Сценарий 2 – использование автоответчика Cisco Unity Express в качестве основного меню, а Basic ACD – в качестве второстепенного меню

В сценарии 2 входящие вызовы направляются на специальный автоответчик Cisco Unity Express (добавочный 2100), с приветственным сообщением, после чего предлагает звонящему меню с четырьмя функциями. В зависимости от запроса звонящего, вызов направляется Cisco CME ACD (параметр 1), одному из двух сообщений (параметры 2 и 3) или на главный почтовый ящик (GDM for extension 2080), связанными с секретарями (параметр 4).

Если звонящий выбирает первую функцию, вызов передается в Cisco CME ACD, где автоответчик Cisco CME имеет второстепенное меню, аналогичное сценарию 1.

Маршрут вызова сценария 2

Маршрут вызова конфигураций в этом разделе изображен на рисунке 8.

Рисунок 8 Маршрут вызова сценария 2

135360.jpg

Примечания к конфигурациям сценария 2

Вызовы PSTN, поступающие из порта FXO (0/3/0), автоматически завершаются в автоответчик Cisco Unity Express (2100).

Это основное меню ("Спасибо, что обратились в систему деталей; нажмите 1 для связи с отделом по работе с клиентами; нажмите 2 для получения информации о расположении учреждения; нажмите 3 для получения информации о часах работы; нажмите 4, чтобы оставить голосовое сообщение.") является элементом специального автоответчика Cisco Unity Express (файл S10_Main_Menu.wav).

Второстепенное меню("Предназначено для помощи пользователям переадресовывать свои вызовы. Нажмите 1, чтобы задать вопросы об аппаратном обеспечении; нажмите 2, чтобы задать вопросы о программном обеспечении; нажмите 3, чтобы задать основные вопросы.") обеспечивается текстовыми файлами автоответчика Cisco CME. Первый этап ("Помощь при переадресации вызововa") расположен на флэш-файле en_bacd_welcome.au, в то время как оставшиеся указания остались неизменными конфигурациями сценария 1 и содержатся на флэш-файле en_bacd_options_menu.au.

Можно не использовать приветственное сообщение в Cisco CME, для этого нужно записать небольшой пустой файл или удалить файл с флэш-маршрутизатора (это приведет к тому, что программное обеспечение Сisco CME не будет использовать приветствие). В образце сценария 2, изображенном в данном разделе, элементы меню, связанные с текстовыми файлами Cisco Unity Express и Cisco CME, были структурированы в виде потока, как единичный автоответчик звонящего. Вы также можете не использовать сообщения приветствия и выбора функций автоответчика Cisco CME с помощью команды param drop-through-option number, которая позволяет переадресовывать вызов непосредственно в Cisco CME ACD без использования автоответчика Cisco CME.

Добавочный номер 2080 и соответствующий GDM внесены в конфигурации для того, чтобы секретарь имел доступ к главному почтовому ящику. Чтобы войти в почтовый ящик, необходимо выбрать функцию 4 из основного меню. Почтовый ящик полностью управляется внутри Cisco Unity Express. Добавочный номер 2080 был добавлен в IP-телефоны 2001 and 2004, которые связаны с двумя секретарями (так же, как и агенты ACD).

Если звонящий в основном меню выбрал 1, и его вызов направили в группу ACD, но звонок остается неотвеченным, вызов переадресуется на добавочный номер 2070, который является GDM для агентов ACD.

Настройка Cisco CME для сценария 2

Эти этапы объединяют конфигурации для Cisco CME для сценария 2:

  1. Выберите Configure > Phones. Затем отметьте MAC-адрес того телефона, который необходимо изменить. Отобразится окно "Change Phone" (см. рисунок 9).

  2. Введите добавочный номер 2080 напротив кнопки 3 телефона секретаря, при этом ACD GDM остается на кнопке 2. Благодаря такой настройке сотрудник получает MWI для почтового ящика как секретаря, так и ACD GDM.

    Рисунок 9 Добавление кнопки добавочного номера для телефона секретаря

    135361.jpg

Ниже представлены завершенные (и аннотированные) конфигурации маршрутизатора CLI Cisco CME для сценария 1, являющегося результатом специальных изменений базовых конфигураций.

CME-2821#show running-config
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname CME-2821
!
boot-start-marker
boot system flash:
boot-end-marker
!
no aaa new-model
!
resource policy
!
ip subnet-zero
!
ip cef
no ip dhcp use vrf connected
ip dhcp excluded-address b.168.1.1 b.168.1.10
!
ip dhcp pool ITS
   network b.168.1.0 255.255.255.0
   option 150 ip a.1.11.1 
   default-router b.168.1.1 
!
no ip domain lookup
!
voice-card 0
 no dspfarm
!
voice service voip 
 allow-connections h323 to h323
 allow-connections h323 to sip
 supplementary-service h450.12 advertise-only
!
application
 service acd flash:app-b-acd-2.1.0.0.tcl
  param queue-cme-debugs 1
  param aa-hunt1 2020
  param aa-hunt2 2021
  param number-of-hunt-grps 3
  param aa-hunt3 2022
  param queue-len 30
 !
 service cme-aa flash:app-b-acd-aa-2.1.0.0.tcl
  param max-time-call-retry 60
  param voice-mail 2070
  paramspace english index 0
  param service-name acd
  param number-of-hunt-grps 3
  param handoff-string cme-aa
  paramspace english language en
  param max-time-vm-retry 1
  paramspace english location flash:
  param aa-pilot 2040
  param second-greeting-time 30
  paramspace english prefix en
  param call-retry-timer 20
!
interface Loopback0
 ip address a.1.11.1 255.255.255.252
!
interface GigabitEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet0/1/0
 switchport access vlan 10
!
interface FastEthernet0/1/1
 switchport access vlan 10
!
interface FastEthernet0/1/2
 switchport access vlan 10
!
interface FastEthernet0/1/3
 switchport access vlan 10
!
interface FastEthernet0/1/4
 switchport access vlan 10
!
interface FastEthernet0/1/5
 switchport access vlan 10
!
interface FastEthernet0/1/6
 switchport access vlan 10
!
interface FastEthernet0/1/7
 switchport access vlan 10
!
interface FastEthernet0/1/8
 switchport access vlan 10
!
interface Service-Engine1/0
 ip unnumbered Loopback0
 service-module ip address a.1.11.2 255.255.255.252
 service-module ip default-gateway a.1.11.1
!
interface Vlan1
 no ip address
!
interface Vlan10
 ip address b.168.1.1 255.255.255.0
!
ip classless
ip route a.1.11.2 255.255.255.255 Service-Engine1/0
!
ip http server
ip http path flash:
!
tftp-server flash:P00305000600.bin
tftp-server flash:P00305000600.sbn
!
control-plane
!
!--- Вызовы PSTN автоматически прекращаются при телефонном номере доступа автоответчика Cisco CME 2100.

!
voice-port 0/3/0
 connection plar opx 2100
!
voice-port 0/3/1
 connection plar opx 2100
!
voice-port 0/3/2
!
voice-port 0/3/3
!
dial-peer voice 2040 voip
 destination-pattern 2040
 session target ipv4:a.1.11.1
 dtmf-relay h245-alphanumeric
 codec g711ulaw
 no vad
!
dial-peer voice 2041 voip
 service cme-aa
 incoming called-number 2040
 dtmf-relay h245-alphanumeric
 codec g711ulaw
 no vad
!
dial-peer voice 2105 voip
 destination-pattern 21..
 session protocol sipv2
 session target ipv4:a.1.11.2
 dtmf-relay sip-notify
 codec g711ulaw
 no vad
!
telephony-service
 load 7960-7940 P00305000300
 max-ephones 48
 max-dn 192
 ip source-address a.1.11.1 port 2000
 max-redirect 20
 auto assign 1 to 10
 system message CISCO SYSTEMS
 create cnf-files version-stamp 7960 Aug 05 2005 00:00:32
 voicemail 2105
 max-conferences 8 gain -6
 moh music-on-hold.au
 dn-webedit 
 time-webedit 
 transfer-system full-consult
 transfer-pattern 210. blind
 transfer-pattern 2040 blind
!
ephone-dn  1  dual-line
 number 2001
 name User21
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  2  dual-line
 number 2002
 name User22
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  3  dual-line
 number 2003
 name User23
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  4  dual-line
 number 2004
 name User24
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  5  dual-line
 number 2005
 name User25
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  6  dual-line
 number 2006
 name User26
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  7  dual-line
 number 2007
 name User27
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  8  dual-line
 number 2008
 name User28
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  9  dual-line
 number 2009
 name User29
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
!--- Добавочный номер 2080 связан с GDM секретарей. 
!--- Этот добавочный номер необходим для получения MWI на телефоны секретарей.

!
ephone-dn  10
 number 2080
 description Reception GDM
 name Reception GDM
 call-forward all 2105
!
ephone-dn  11
 number 2070
 description GDM
 name Cust Svc GDM
 call-forward all 2105
!
ephone-dn  100
 number 8000....
 mwi on
!
ephone-dn  101
 number 8001....
 mwi off
!
!--- Телефон – набираемый номер 10 (2080), предназначенная кнопка – 3  
!--- на телефонах 2001 и 2004, 
!--- таким образом все секретари (телефоны 1 и 4) получают MWI для GDM.

!
ephone  1
 username "user21" password null
 mac-address 0012.0034.81B7
 type 7960
 button  1:1 2:11 3:10
!
ephone  2
 username "user22" password null
 mac-address 0011.2032.C876
 type 7960
 button  1:2 2:11
!
ephone  3
 username "user23" password null
 mac-address 0012.01E8.875F
 type 7960
 button  1:3 2:11
!
ephone  4
 username "user24"
 mac-address 0003.AAAA.0004
 type 7960
 button 1:4 2:11 3:10
!
ephone 5
 username "user25"
 mac-address 0003.AAAA.0005
 type 7960
 no auto-line
 button 1:5 2:11
!
ephone 6
 username "user26"
 mac-address 0003.AAAA.0006
 type 7960
 button 1:6 2:11
!
ephone 7
 username "user27"
 mac-address 0003.AAAA.0007
 type 7960
 button 1:7 2:11
!
ephone 8
 username "user28"
 mac-address 0003.AAAA.0008
 type 7960
 button 1:8 2:11
!
ephone  9
 username "user29"
 mac-address 0003.AAAA.0009
 type 7960
 button 1:9 2:11
!
ephone-hunt 1 longest-idle
 pilot 2020
 list 2001, 2002, 2003
 timeout 5
!
ephone-hunt 2 longest-idle
 pilot 2021
 list 2004, 2005, 2006
 timeout 5
!
ephone-hunt 3 longest-idle
 pilot 2022
 list 2007, 2008, 2009
 timeout 5
!
line con 0
 logging synchronous
line aux 0
line 66
 no activation-character
 no exec
 transport preferred none
 transport input all
 transport output all
line vty 0 4
 login
!
scheduler allocate 20000 1000
ntp master
!
end

Настройка Cisco Unity Express для сценария 2

Эти этапы объединяют конфигурации для Cisco Unity Express для сценария 2:

  1. Откройте утилиту редактора сценария Cisco Unity Express и создайте пользовательский сценарий Cisco Unity Express. См. рисунок 10.

    Рисунок 10 Настройка сценария автоответчика Cisco Unity Express для основного меню верхнего уровня

    135362.jpg

  2. Выберите Voice Mail > Auto Attendant и свяжите сценарий (S10_CUE-AA-BACD-script.aef) с телефонным номером доступа 2100. См. рисунок 11.

    Рисунок 11 Связывание сценария с телефонным номером доступа

    135363.jpg

  3. Запишите все подсказки для сценария автоответчика. Их можно записать либо в отключенном состоянии и загрузить .wav-файлы в Cisco Unity Express, используя соответствующее имя файла или записать их через систему управления с помощью телефонии (AVT).

  4. (Дополнительно) При использовании AVT, Cisco Unity Express назначает общее имя файла, которое позднее может быть изменено на любое другое имя файла. Выберите Voice Mail > Prompts и отметьте имя системного файла.

  5. (Дополнительно) Отредактируйте имя (имена) файла, как это требуется в диалоговом окне и нажмите . В окне "Voice Mail > Prompts" теперь отображен соответствующий список имен файла (см. рисунок 12).

    Рисунок 12 Список подсказок сценария автоответчика

    135364.jpg

  6. Выберите Voice Mail > Auto Attendant и откройте автоответчик, являющийся элементом этапа 1. Выберите Script Parameters и свяжите имена файла сценария с соответствующими параметрами в сценарии.

  7. Выберите Configure > Groups и отметьте группу ( reception ), которую необходимо редактировать. Появится окно "Group Profile" (см. окно частичной прозрачности в верхней части рисунка 13). Вкладка "Profile" настроена по умолчанию.

  8. Выберите вкладку "Owners/Members" для настройки элементов.

    Рисунок 13 Определение группы секретаря

    142217.jpg

Ниже представлены завершенные (и аннотированные) конфигурации Cisco Unity Express CLI для сценария 2, являющийся результатом специальных изменений базовых конфигураций.

cue#show running-config
Generating configuration:
clock timezone America/Los_Angeles
hostname cue
ip domain-name cisco.com
ntp server a.1.11.1
!--- Добавьте группу секретаря.

!
groupname Administrators create
groupname Broadcasters create
groupname custservice create
groupname reception create
username admin create

username user21 create
username user22 create
username user23 create
username user24 create
username user25 create
username user26 create
username user27 create
username user28 create
username user29 create
!
!--- Группа секретаря (а следовательно и GDM) связана с добавочным номером 2080.

!
groupname custservice phonenumber "2070"
groupname reception phonenumber "2080"
username user21 phonenumber "2001"
username user22 phonenumber "2002"
username user23 phonenumber "2003"
username user24 phonenumber "2004"
username user25 phonenumber "2005"
username user26 phonenumber "2006"
username user27 phonenumber "2007"
username user28 phonenumber "2008"
username user29 phonenumber "2009"
!
!--- Определите состав группы "reception".

!
groupname Administrators member admin
groupname custservice member user21
groupname custservice member user22
groupname custservice member user23
groupname custservice member user24
groupname custservice member user25
groupname custservice member user26
groupname custservice member user27
groupname custservice member user28
groupname custservice member user29
groupname reception member user21
groupname reception member user24
groupname Administrators privilege superuser
groupname Administrators privilege ManagePrompts
groupname Administrators privilege ManagePublicList
groupname Administrators privilege ViewPrivateList
groupname Broadcasters privilege broadcast
!--- Настройте расписание автоответчика на понедельник – пятницу с 09:00 до 17:00.

!
calendar biz-schedule systemschedule
 closed day 1 from 00:00 to 24:00
 open day 2 from 09:00 to 17:00
 open day 3 from 09:00 to 17:00
 open day 4 from 09:00 to 17:00
 open day 5 from 09:00 to 17:00
 open day 6 from 09:00 to 17:00
 closed day 7 from 00:00 to 24:00
end schedule
ccn application autoattendant
 description "autoattendant"
 enabled
 maxsessions 8
 script "aa.aef"
 parameter "busOpenPrompt" "AABusinessOpen.wav"
 parameter "holidayPrompt" "AAHolidayPrompt.wav"
 parameter "busClosedPrompt" "AABusinessClosed.wav"
 parameter "allowExternalTransfers" "true"
 parameter "MaxRetry" "3"
 parameter "operExtn" "2001"
 parameter "welcomePrompt" "AAWelcome.wav"
 parameter "businessSchedule" "systemschedule"
 end application
ccn application ciscomwiapplication
 description "ciscomwiapplication"
 enabled
 maxsessions 8
 script "setmwi.aef"
 parameter "strMWI_OFF_DN" "8001"
 parameter "strMWI_ON_DN" "8000"
 parameter "CallControlGroupID" "0"
 end application
ccn application promptmgmt
 description "promptmgmt"
 enabled
 maxsessions 1
 script "promptmgmt.aef"
 end application
!
!--- Добавьте сценарий пользовательского автоответчика для главного меню.

!
ccn application s10-cue-aa-bacd
 description "s10-cue-aa-bacd"
 enabled
 maxsessions 8
 script "s10-cue-aa-bacd-script.aef"
 parameter "S10_StoreHours" "S10_StoreHours.wav"
 parameter "S10_CustomerService" "2040"
 parameter "S10_GDM" "2080"
 parameter "S10_StoreLocation" "S10_StoreLocation.wav"
 end application
ccn application voicemail
 description "voicemail"
 enabled
 maxsessions 8
 script "voicebrowser.aef"
 parameter "logoutUri" "http://localhost/voicemail/vxmlscripts/mbxLogout.jsp"
 parameter "uri" "http://localhost/voicemail/vxmlscripts/login.vxml"
 end application
ccn engine
 end engine
ccn subsystem jtapi
 ccm-manager address 0.0.0.0 
 end subsystem
ccn subsystem sip
 gateway address "a.1.11.1"
 end subsystem
!
!--- Свяжите сценарий пользовательского автоответчика с телефонным номером доступа 2100.

!
ccn trigger sip phonenumber 2100
 application "s10-cue-aa-bacd"
 enabled
 maxsessions 8
 end trigger
ccn trigger sip phonenumber 2102
 application "autoattendant"
 enabled
 maxsessions 8
 end trigger
ccn trigger sip phonenumber 2105
 application "voicemail"
 enabled
 maxsessions 8
 end trigger
ccn trigger sip phonenumber 2106
 application "promptmgmt"
 enabled
 maxsessions 1
 end trigger
voicemail default language en_US
voicemail default mailboxsize 3000
voicemail broadcast recording time 300
voicemail operator telephone 2001
!
!--- Добавьте GDM для "reception"

!
voicemail mailbox owner "reception" size 3000
 description "Receptionists mailbox"
 end mailbox
voicemail mailbox owner "custservice" size 3000
 description "custservice mailbox"
 end mailbox
voicemail mailbox owner "user21" size 3000
 end mailbox
voicemail mailbox owner "user22" size 3000
 end mailbox
voicemail mailbox owner "user23" size 3000
 end mailbox
voicemail mailbox owner "user24" size 3000
description "user24 mailbox"
end mailbox
voicemail mailbox owner "user25" size 3000
description "user25 mailbox"
end mailbox
voicemail mailbox owner "user26" size 3000
description "user26 mailbox"
end mailbox
voicemail mailbox owner "user27" size 3000
description "user27 mailbox"
end mailbox
voicemail mailbox owner "user28" size 3000
description "user28 mailbox"
end mailbox
voicemail mailbox owner "user29" size 3000
description "user29 mailbox"
end mailbox
end

Сценарий 2. Изменение конфигураций 1 – персональные GDM для каждой поисковой группы

Конфигурация основного сценария, описанного в предыдущем разделе, задает определенный GDM для всех сообщений, которые оставляют пользователи в три группы ACD (общие вопросы, а также вопросы об аппаратном и программном обеспечении). Такой уровень модульности в некоторых случаях может быть не вполне достаточным, так как агенты одной группы (такой как программное обеспечение) не будут рассматривать сообщения, оставленные для групп аппаратного обеспечения и общих вопросов перед тем, как осуществить поиск сообщений, относящихся к программному обеспечению. При наличии большого объема сообщений можно использовать отдельный почтовый ящик для каждой группы ACD.

При наличии стандартных поисковых групп Cisco CME (без применения ACD), можно использовать отдельный почтовый ящик для каждой поисковой группы, связывая персональные GDM с номерами поисковых групп (2020, 2021, 2022) и указывая "конечное" назначение поисковых групп на голосовую почту, как это показано в примерах конфигураций.

Настройка Cisco CME для изменения 1 сценария 2

Изменения конфигурации Cisco CME персональных GDM:

ephone-hunt 1 sequential
 pilot 2020
 list 2001, 2002, 2003
 final 2105
 timeout 10
!
!
ephone-hunt 2 sequential
 pilot 2021
 list 2004, 2005, 2006
 final 2105
 timeout 10
!
!
ephone-hunt 3 sequential
 pilot 2022
 list 2007, 2008, 2009
 final 2105
 timeout 10

Настройка Cisco Unity Express для изменения 1 сценария 2

Эти этапы объединяют конфигурации групп и GDM в Cisco Unity Express для изменения 1 сценария 2:

  1. Персональные группы заданы в Cisco Unity Express для каждой из трех поисковых групп. Выберите Configure > Groups для определения группы. См. рисунок 14.

    Рисунок 14 Определение персональных групп

    135357.jpg

  2. Из Configure > Groups, выберите группу (аппаратное обеспечение), которую необходимо редактировать. Появится вкладка "Profile", настроенная по умолчанию (см. верхнюю часть рисунка 15).

    Рисунок 15 Настройка специальных групп

    135358.jpg

  3. Выберите вкладку "Owners/Members" (см. нижнюю часть рисунка 15) и поставьте галочку в окошке слева для выбора владельцев и элементов.

    Изменения конфигурации Cisco Unity Express персональных GDM:

    groupname hardware create
    groupname software create
    groupname general create
    groupname hardware phonenumber "2020"
    groupname software phonenumber "2021"
    groupname general phonenumber "2022"
    groupname hardware member user21
    groupname hardware member user22
    groupname hardware member user23
    groupname software member user24
    groupname software member user25
    groupname software member user26
    groupname general member user27
    groupname general member user28
    groupname general member user29
    voicemail mailbox owner "general" size 5520
     description "general mailbox"
     end mailbox
    voicemail mailbox owner "hardware" size 5520
     description "Hardware mailbox"
     end mailbox
    voicemail mailbox owner "software" size 5520
     description "software mailbox"
     end mailbox

Сценарий 2. Изменение конфигурации 2 – персональные GDM для каждой группы ACD

Конфигурации, описанные в разделе "Сценарий 2 Изменение конфигурации 1 – Персональные GDM для каждой поисковой группы", имеют два недостатка.

  • Это работает только при прямом вызове поисковых групп (добавочный номер 2020, 2021 и 2022), и не работает, когда поисковая группа используется в качестве ACD при вызове на телефонный номер доступа АCD (2040)

  • Это не предоставляет никаких средств обеспечения MWI для агентов, так как номера поисковых групп не могут быть набраны на телефоне.

Чтобы определить конфигурации, которые помогут решить эти проблемы, в Cisco Unity Express можно использовать сценарий системы передачи данных почтового ящика. Задайте три группы в Cisco Unity Express (для аппаратного и программного обеспечения, а также общую группу) и свяжите каждую из них с предварительным добавочным номером (таким, как 2030, 2031 и 2032), которые могут быть заменены кнопками, появляющимися на телефоне агента (в результате чего, предоставляя MWI). Конфигурации групп, добавочные номера и телефоны сведены в таблицу 2.

Агент

Добавочный номер

Номер поисковой группы

Группа ACD

Почтовый ящик группы

user21 (пользователь21)

2001

2020

Аппаратное обеспечение

2030

user22 (пользователь22)

2002

2020

Аппаратное обеспечение

2030

user23 (пользователь23)

2003

2020

Аппаратное обеспечение

2030

user24 (пользователь24)

2004

2021

Программное обеспечение

2031

user25 (пользователь25)

2005

2021

Программное обеспечение

2031

user26 (пользователь26)

2006

2021

Программное обеспечение

2031

user27 (пользователь27)

2007

2022

Общие сведения

2032

user28 (пользователь28)

2008

2022

Общие сведения

2032

user29 (пользователь29)

2009

2022

Общие сведения

2032

Заданный маршрут вызова модифицированной настройки изображен на рисунке 16.

Рисунок 16 Заданный маршрут вызова для изменения сценария системы передачи данных почтового ящика Variation

135359.jpg

Для направления вызовов в персональные GDM в Cisco Unity Express необходим пользовательский сценарий, вызывающий сценарий системы передачи данных почтового ящика. Вызовы в Cisco CME ACD могут быть переадресованы в Cisco Unity Express с использованием однопозиционной команды param voice-mail number (персональное конечное назначение поисковой группы не может быть использовано для маршрутов вызова ACD). Эта команда представляет отдельный добавочный номер Cisco Unity Express для входа в почтовый ящик (добавочный номер 2070 в предыдущих конфигурациях). Cisco Unity Express не может определить, какая из поисковых групп является намеченным адресатом и в какую из трех групп GDM нужно войти.

Вместо этого, направьте конечное назначение голосовой почты Сisco CME ACD на телефонный номер доступа Cisco Unity Express (2110), который открывает доступ в пользовательский сценарий ( s12-xfer-to-mbox.aef ). Этот телефонный номер доступа предлагает пользователю меню с выбором групп, в которые может быть оставлено сообщение (аппаратное и программное обеспечение или общая группа). Содержание меню изображено в нижней части маршрута вызова на рисунке 16. В зависимости от запроса звонящегоr изменение почтового ящика устанавливается в соответствии с добавочным номером (2030, 2031 или 2032), а вызов передается (через сценарий системы передачи данных почтового ящика) в одну из трех групп GDM.

Этапы, связанные с изменением конфигурации сценария 2 и предназначенные для управления этими изменениями, занесенными в таблицу 2 и изображенными на рисунке 16, описаны следующим образом:

  1. Откройте утилиту редактора сценария Cisco Unity Express и запишите пользовательский сценарий Cisco Unity Express, который называется s12-xfer-to-mbox.aef. См. рисунок 17.

    Рисунок 17 Стандартное окно создания сценария Cisco Unity Express

    135347.jpg

  2. Выберите Voice Mail > Auto Attendant. См. рисунок 18. Добавьте новый автоответчик и свяжите его со сценарием, который является элементом этапа 1.

  3. Свяжите пользовательский сценарий s12-xfer-to-mbox.aef Cisco Unity Express с телефонным номером доступа 2110. См. рисунок 18.

    Рисунок 18 Связывание пользовательского сценария Cisco Unity Express с телефонным номером доступа

    135348.jpg

  4. Запишите подсказки (в данном случае они называются S12_Main_Menu.wav) для нового сценария автоответчика. Их можно записать либо в отключенном состоянии и загрузить .wav-файлы в Cisco Unity Express, используя соответствующее имя файла или записать их через систему управления с помощью телефонии (AVT).

  5. (Дополнительно) При использовании AVT, Cisco Unity Express назначает общее имя файла, которое позднее может быть изменено на любое другое имя файла. Выберите Voice Mail > Prompts и отметьте имя системного файла.

  6. (Дополнительно) Отредактируйте имя файла, как это требуется в диалоговом окне и нажмите OK. В окне "Voice Mail > Prompts" теперь отображен соответствующий список имен файла (см. рисунок 19).

  7. Выберите Voice Mail > Auto Attendant и откройте автоответчик, созданный на этапе 2. Выберите Script Parameters и свяжите имя файла подсказки с соответствующим параметром сценария.

    Рисунок 19 Список записанных подсказок

    135349.jpg

  8. Выберите Configure > Extension для определения добавочных номеров 2030, 2031 и 2032 для их связывания с каждой из групп GDM. См. рисунок 20.

    Рисунок 20 Определение добавочных номеров для связывания групп GDM с поисковыми группами ACD

    135350.jpg

  9. Выберите Configure > Phones и отметьте MAC-адрес того телефона, который нужно изменить. Появится окно изменения телефона (см. рисунок 21).

  10. Добавьте кнопки для номеров 2030, 2031 или 2032 на телефонных агентах ACD для получения MWI.

    Рисунок 21 Окно добавления кнопок

    135351.jpg

Аннотированные конфигурации маршрутизатора CLI Cisco CME для изменений и добавлений конфигураций Cisco CME в конфигурацию базового сценария, связанную с разделом "Настройка Cisco CME для сценария 2".

!--- Установите назначение голосовой почты автоответчика 
!--- на номер 2110, точка входа сценария Cisco Unity Express
!--- для функционирования системы передачи данных почтового ящика.

!
 service cme-aa flash:app-b-acd-aa-2.1.0.0.tcl
  param max-time-call-retry 60
  param voice-mail 2110
  paramspace english index 0
  param service-name acd
  param number-of-hunt-grps 3
  param handoff-string cme-aa
  paramspace english language en
  param max-time-vm-retry 1
  paramspace english location flash:
  param aa-pilot 2040
  param second-greeting-time 30
  paramspace english prefix en
  param call-retry-timer 20
!
!--- Определите действующий добавочный номер 
!--- (2030, 2031 и 2032) по мере появления кнопок
!--- на телефонах агента таким образом, что они смогут получить MWI для GDM. 
!--- Поместите эти добавочные номера в CFA,
!--- после чего телефон не будет звонить, отвлекая агентов.

!
ephone-dn  12
 number 2030
 description HW Cust Svc Mbox
 name HW Cust Svc Mbox
 call-forward all 2110
!
ephone-dn  13
 number 2031
 description SW Cust Svc Mbox
 name SW Cust Svc Mbox
 call-forward all 2110
!
ephone-dn  14
 number 2032
 description Gen Cust Svc Mbox
 name Gen Cust Svc Mbox
 call-forward all 2110
!
!--- Добавьте кнопки соответствующего 
!--- добавочного номера группы каждого
!--- из телефонов агента ACD.

!
ephone  1
 username "user21" password null
 mac-address 0012.0034.81B7
 type 7960
 button  1:1 2:12 3:10
!
ephone  2
 username "user22" password null
 mac-address 0011.2032.C876
 type 7960
 button  1:2 2:12
!
ephone  3
 username "user23" password null
 mac-address 0012.01E8.875F
 type 7960
 button  1:3 2:12
!
ephone  4
 username "user24"
 mac-address 0003.AAAA.0004
 type 7960
 button 1:4 2:13 3:10
!
ephone 5
 username "user25"
 mac-address 0003.AAAA.0005
 type 7960
 no auto-line
 button 1:5 2:13
!
ephone 6
 username "user26"
 mac-address 0003.AAAA.0006
 type 7960
 button 1:6 2:13
!
ephone 7
 username "user27"
 mac-address 0003.AAAA.0007
 type 7960
 button 1:7 2:14
!
ephone 8
 username "user28"
 mac-address 0003.AAAA.0008
 type 7960
 button 1:8 2:14
!
ephone  9
 username "user29"
 mac-address 0003.AAAA.0009
 type 7960
 button 1:9 2:14

Аннотированные конфигурации Cisco Unity Express CLI для изменений и добавлений конфигураций в конфигурацию базового сценария, связанную с разделом "Настройка Cisco Unity Express для сценария 2" и предыдущими изменениями GUI:

!--- Задайте три новые группы – аппаратное обеспечение, программное обеспечение и общая.

!
groupname hardware create
groupname software create
groupname general create
!
!--- Определите новые группы (а следовательно и GDM), 
!--- связанные с добавочными номерами 2030, 2031 и 2032).

!
groupname hardware phonenumber "2030"
groupname software phonenumber "2031"
groupname general phonenumber "2032"
!
!--- Определите состав групп аппаратного и программного обеспечения, а также общей группы.

!
groupname hardware member user21
groupname hardware member user22
groupname hardware member user23
groupname software member user24
groupname software member user25
groupname software member user26
groupname general member user27
groupname general member user28
groupname general member user29
!
!--- Определите сценарий пользовательского автоответчика, 
!--- который во время выбора звонящим соответствующего GMD
!--- из меню автоматически перейдет к сценарию системы передачи данных почтового ящика.

!
ccn application s12-xfer-to-mbox
 description "s12-xfer-to-mbox"
 enabled
 maxsessions 8
 script "s12_cue-aa-bacd-script.aef"
 end application
!
!--- Задайте телефонный номер доступа 2110 для пользовательского сценария.

!
ccn trigger sip phonenumber 2110
 application "s12-xfer-to-mbox"
 enabled
 maxsessions 8
 end trigger
!
!--- Задайте GDM для каждой группы.

!
voicemail mailbox owner "hardware" size 3000
 description "hardware mailbox"
 end mailbox
voicemail mailbox owner "software" size 3000
 description "software mailbox"
 end mailbox
voicemail mailbox owner "general" size 3000
 description "general mailbox"
 end mailbox

Сценарий 2 Изменение конфигураций 3 – Использование функции Drop (удаление) с помощью функциональных возможностей CD

Функция "drop" (удаление) с помощью возможностей Cisco CME ACD может быть использована для того, чтобы обойти меню автоответчика Cisco CME и передать вызов непосредственно в ACD. Благодаря этому свойству все меню автоответчика может быть полностью объединено в сценарий автоответчика Cisco Unity Express. Для использования этого свойства необходимы дополнительные конфигурации маршрутизатора Cisco CME, что упрощает обслуживание сценария (меню) автоответчика, по сравнению с разветвлением меню и записью сообщений между автоответчиками Cisco Unity Express (основное мню 1) и Cisco CME (основное меню 2).

В конфигурации сценария 2 (вариант 3) оба основных меню автоответчика входят в сценарий автоответчика Cisco Unity Express:

  • Спасибо, что обратились в систему деталей

    • Нажмите 1 для связи с отделом по работе с клиентами

      • Нажмите 1, чтобы задать вопросы о программном обеспечении

      • Нажмите 2, чтобы задать вопросы о программном обеспечении

      • Нажмите 3, чтобы задать основные вопросы

    • Нажмите 2 для получения информации о расположении учреждения

    • Нажмите 3 для получения информации о часах работы

    • Нажмите 4, чтобы оставить голосовое сообщение

Опции основного меню являются результатом того, что вызовы передаются из Cisco Unity Express на персональный телефонный номер доступа Cisco CME ACD для каждой из этих групп:

  • Телефонный номер доступа для группы аппаратного обеспечения—Cisco CME ACD – 2040

  • Телефонный номер доступа для группы программного обеспечения—Cisco CME ACD – 2041

  • Телефонный номер доступа для общей группы—Cisco CME ACD – 2042

Конфигурации, описанные в данном документе ранее, определяли единый телефонный номер доступа ACD (2040). В данном изменении конфигурации определены три различных телефонных номера доступа Cisco CME ACD (2040, 2041 и 2042). Это изменение показывает, как можно запустить функцию drop (удаление), используя набор функциональных возможностей. Использование функции "drop" (удаление) с помощью функциональных возможностей позволяет обойти меню автоответчика Cisco CME и выбрать конкретный параметр для изучения (указанный в соответствующей команде CLI) Система функционирует так, как если бы пользователь указал параметр, статически расположенный в CLI. В этом сценарии конфигурации автоответчика Cisco CME включают в себя следующие приспособления:

  • Настройка телефонного номера доступа ACD (2040) включает в себя команду param drop-through-option 1

  • Настройка телефонного номера доступа ACD (2041) включает в себя команду param drop-through-option 2

  • Настройка телефонного номера доступа ACD (2042) включает в себя команду param drop-through-option 3

Настройка Cisco CME для изменения 3 сценария 2

Эти этапы объединяют конфигурации для Cisco CME изменения 3 сценария 2:

  1. Введите дополнительную конфигурацию Cisco CME AA и ACD TCL для номеров доступа 2040, 2041 and 2042 с помощью "drop-through" CLI.

  2. Добавьте точки вызова для осуществления набора новых телефонных номеров доступа 2040, 204,1 и 2042.

    Аннотированные конфигурации маршрутизатора CLI Cisco CME для изменений и добавлений в конфигурацию Cisco CME базового сценария, связанного с разделом "Настройка Cisco CME для сценария 2".

    application
     service acd flash:app-b-acd-2.1.0.0.tcl
      param queue-cme-debugs 1
      param aa-hunt1 2020
      param aa-hunt2 2021
      param number-of-hunt-grps 3
      param aa-hunt3 2022
      param queue-len 30
    !
    !--- Задайте конфигурации TCL для группы аппаратного обеспечения, используя телефонный номер доступа 2040 
    !--- и функцию "drop-through-option 1". Добавочный номер 2030 связан с GMD
    !--- группы аппаратного обеспечения таким образом, что является назначением голосовой почты.
    
    !
     service hardware-aa flash:app-b-acd-aa-2.1.0.0.tcl
      param max-time-vm-retry 1
      paramspace english index 0
      param max-time-call-retry 60
      param voice-mail 2030
      param aa-pilot 2040
      param number-of-hunt-grps 1
      paramspace english language en
      param handoff-string hardware-aa
      param call-retry-timer 20
      paramspace english location flash:
      param service-name acd
      param drop-through-option 1
      param second-greeting-time 30
      paramspace english prefix en
    !
    !--- Задайте конфигурацию TCL для группы "Программное обеспечение" 
    !--- с помощью номера доступа 2041 
    !--- и функцию "drop-through-option 2". Добавочный номер 2031 связан с GMD
    !--- аппаратного обеспечения таким образом, что является назначением голосовой почты.
    
    !
     service software-aa flash:app-b-acd-aa-2.1.0.0.tcl
      param number-of-hunt-grps 1
      paramspace english index 0
      param handoff-string software-aa
      paramspace english language en
      param call-retry-timer 20
      param service-name acd
      paramspace english location flash:
      param drop-through-option 2
      param second-greeting-time 30
      param max-time-vm-retry 1
      param voice-mail 2031
      paramspace english prefix en
      param max-time-call-retry 60
      param aa-pilot 2041
    !
    !--- Задайте конфигурации TCL для общей группы, используя телефонный номер доступа 2042 
    !--- и функцию "drop-through-option 3". Добавочный номер 2032 связан с GMD
    !--- для общей группы таким образом, что является назначением голосовой почты.
    
    !
     service general-aa flash:app-b-acd-aa-2.1.0.0.tcl
      param call-retry-timer 20
      paramspace english index 0
      param max-time-call-retry 60
      param voice-mail 2032
      param service-name acd
      param number-of-hunt-grps 1
      param drop-through-option 3
      paramspace english language en
      param handoff-string general-aa
      param max-time-vm-retry 1
      paramspace english location flash:
      param aa-pilot 2042
      param second-greeting-time 30
      paramspace english prefix en
    !
    !--- Определите точки вызова для телефонного номера доступа 2042 и свяжите его со
    !--- доступа 2042 и свяжите его со сценарием общей группы TCL.
    
    !
    dial-peer voice 2040 voip
     destination-pattern 2040
     session target ipv4:a.1.11.1
     dtmf-relay h245-alphanumeric
     codec g711ulaw
     no vad
    !
    dial-peer voice 20400 voip
     service hardware-aa
     incoming called-number 2040
     dtmf-relay h245-alphanumeric
     codec g711ulaw
     no vad
    !
    !--- Определите точки вызова для телефонного номера
    !--- доступа 2042 и свяжите его со сценарием общей группы TCL.
    
    !
    dial-peer voice 2041 voip
     destination-pattern 2041
     session target ipv4:a.1.11.1
     dtmf-relay h245-alphanumeric
     codec g711ulaw
     no vad
    !
    dial-peer voice 20410 voip
     service software-aa
     incoming called-number 2041
     dtmf-relay h245-alphanumeric
     codec g711ulaw
     no vad
    A?
    !--- Определите точки вызова для телефонного номера
    !--- доступа 2042 и свяжите его со сценарием общей группы TCL.
    
    !
    dial-peer voice 2042 voip
     destination-pattern 2042
     session target ipv4:a.1.11.1
     dtmf-relay h245-alphanumeric
     codec g711ulaw
     no vad
    !
    dial-peer voice 20420 voip
     service general-aa
     incoming called-number 2042
     dtmf-relay h245-alphanumeric
     codec g711ulaw
     no vad

Настройка Cisco Unity Express для изменения 3 сценария 2

Эти этапы объединяют конфигурации для Cisco Unity Express изменения 3 сценария 2:

  1. Откройте утилиту редактора сценария Cisco Unity Express и настройте сценарий s10-cue-aa-bacd.aef таким образом, чтобы он содержал оба основных меню автоответчика. См. рисунок 22.

    Рисунок 22 Настройка сценария автоответчика Cisco Unity Express для двух основных меню

    142220.jpg

  2. Выберите Voice Mail > Auto Attendant и свяжите новый сценарий (S10A_CUE-AA-BACD-script.aef) с телефонным номером доступа 2100. См. рисунок 23.

    Рисунок 23 Связывание сценария с телефонным номером доступа

    142221.jpg

  3. Запишите все подсказки, необходимые для сценария автоответчика. Их можно записать либо в отключенном состоянии и загрузить .wav-файлы в Cisco Unity Express, используя соответствующие имена файла или записать их через систему управления с помощью телефонии (AVT).

  4. (Дополнительно) При использовании AVT, Cisco Unity Express назначает общие имена файлов, которые позднее могут быть изменены на любое другое имя файла. Выберите Voice Mail > Prompts и отметьте имя системного файла.

  5. (Дополнительно) Отредактируйте имя (имена) файла в диалоговом окне и нажмите OK. В окне "Voice Mail > Prompts" теперь отображен соответствующий список имен файла.

Аннотированные конфигурации Cisco Unity Express CLI для изменений и добавлений конфигураций в конфигурацию базового сценария, связанного с разделом настройки Cisco Unity Express для сценария 2.

!--- Задайте новый автоответчик с помощью сценария s10a-cue-aa-bacd.aef.

!
ccn application s10a-cue-aa-bacd
 description "s10a-cue-aa-bacd"
 enabled
 maxsessions 8
 script "s10a_cue-aa-bacd-script.aef"
 parameter "S10_Hardware" "2040"
 parameter "S10_StoreHours" "S10_StoreHours.wav"
 parameter "S10_Software" "2041"
 parameter "S10_General" "2042"
 parameter "S10_GDM" "2080"
 parameter "S10_StoreLocation" "S10_StoreLocation.wav"
 end application
!
!--- Свяжите телефонный номер доступа 2100 автоответчика с новым сценарием.

!
ccn trigger sip phonenumber 2100
 application "s10a-cue-aa-bacd"
 enabled
 maxsessions 8
 end trigger

Сценарий 3 – Использование Basic ACD в качестве основного меню, а автоответчика Cisco Unity Express – в качестве второстепенного меню

В третьем сценарии, представленном в этом документе, входящие вызовы, также как и в сценарии 1, направляются на автоответчик Cisco CME (телефонный номер доступа 2040). Единственным отличием является наличие всего двух групп ACD (аппаратное и программное обеспечение), при этом третий параметр Главного меню необходим для доступа к сообщениям о расположении предприятий и режиме работы.

Примечание. Невозможно включить в автоответчик Cisco CME сообщения свободного формата. Вместо этого необходим пользовательский сценарий Cisco Unity Express.

Такой же результат можно получить (с точки зрения звонящего) и с помощью изменения сценария 2. Образец сценария 3 демонстрирует еще один способ структурирования приложения путем передачи вызова из обработки ACD Cisco CME на автоответчик Cisco Unity Express. Изменение сценария 2 – один из самых обычных способов разработки данного приложения.

Маршрут вызова сценария 3

Маршрут вызова конфигураций в этом разделе изображен на рисунке 24.

Рисунок 24 Маршрут вызова сценария 3

135510.jpg

Примечания к конфигурациям сценария 3

Вызовы PSTN, поступающие из порта FXO (0/3/0), автоматически завершаются на автоответчике Cisco CME (2040).

Cisco CME ACD имеет только две группы агентов (2020 и 2021). Третий параметр меню используется для передачи вызова на автоответчик сообщений Cisco Unity Express. Вместо отображения номеров поисковых групп, при выборе звонящим параметра 3, система направляет вызовы звонящих на телефонный номер доступа автоответчика Cisco Unity Express (2100) – результат использования команды param aa-hunt3 2100.

Настройка Cisco CME для сценария 3

На примере представлена конфигурация CLI для маршрутизатора Cisco CME:

CME-2821#show running-config
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname CME-2821
!
boot-start-marker
boot system flash:
boot-end-marker
!
no aaa new-model
!
resource policy
!
ip subnet-zero
!
ip cef
no ip dhcp use vrf connected
ip dhcp excluded-address b.168.1.1 b.168.1.10
!
ip dhcp pool ITS
   network b.168.1.0 255.255.255.0
   option 150 ip a.1.11.1 
   default-router b.168.1.1 
!
no ip domain lookup
!
voice-card 0
 no dspfarm
!
voice service voip 
 allow-connections h323 to h323
 allow-connections h323 to sip
 supplementary-service h450.12 advertise-only
!
!--- Укажите третий параметр меню (aa-hunt3) 
!--- для автоответчика Cisco Unity Express (2100)).

!
application
 service acd flash:app-b-acd-2.1.0.0.tcl
  param queue-cme-debugs 1
  param aa-hunt1 2020
  param aa-hunt2 2021
  param number-of-hunt-grps 3
  param aa-hunt3 2100
  param queue-len 30
 !
 service cme-aa flash:app-b-acd-aa-2.1.0.0.tcl
  param max-time-call-retry 60
  param voice-mail 2070
  paramspace english index 0
  param service-name acd
  param number-of-hunt-grps 3
  param handoff-string cme-aa
  paramspace english language en
  param max-time-vm-retry 1
  paramspace english location flash:
  param aa-pilot 2040
  param second-greeting-time 30
  paramspace english prefix en
  param call-retry-timer 20
!
interface Loopback0
 ip address a.1.11.1 255.255.255.252
!
interface GigabitEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet0/1/0
 switchport access vlan 10
!
interface FastEthernet0/1/1
 switchport access vlan 10
!
interface FastEthernet0/1/2
 switchport access vlan 10
!
interface FastEthernet0/1/3
 switchport access vlan 10
!
interface FastEthernet0/1/4
 switchport access vlan 10
!
interface FastEthernet0/1/5
 switchport access vlan 10
!
interface FastEthernet0/1/6
 switchport access vlan 10
!
interface FastEthernet0/1/7
 switchport access vlan 10
!
interface FastEthernet0/1/8
 switchport access vlan 10
!
interface Service-Engine1/0
 ip unnumbered Loopback0
 service-module ip address a.1.11.2 255.255.255.252
 service-module ip default-gateway a.1.11.1
!
interface Vlan1
 no ip address
!
interface Vlan10
 ip address b.168.1.1 255.255.255.0
!
ip classless
ip route a.1.11.2 255.255.255.255 Service-Engine1/0
!
ip http server
ip http path flash:
!
tftp-server flash:P00305000600.bin
tftp-server flash:P00305000600.sbn
!
control-plane
!
voice-port 0/3/0
 connection plar opx 2040
!
voice-port 0/3/1
 connection plar opx 2040
!
voice-port 0/3/2
!
voice-port 0/3/3
!
dial-peer voice 2040 voip
 destination-pattern 2040
 session target ipv4:a.1.11.1
 dtmf-relay h245-alphanumeric
 codec g711ulaw
 no vad
!
dial-peer voice 2041 voip
 service cme-aa
 incoming called-number 2040
 dtmf-relay h245-alphanumeric
 codec g711ulaw
 no vad
!
dial-peer voice 2105 voip
 destination-pattern 21..
 session protocol sipv2
 session target ipv4:a.1.11.2
 dtmf-relay sip-notify
 codec g711ulaw
 no vad
!
telephony-service
 load 7960-7940 P00305000300
 max-ephones 48
 max-dn 192
 ip source-address a.1.11.1 port 2000
 max-redirect 20
 auto assign 1 to 10
 system message CISCO SYSTEMS
 create cnf-files version-stamp 7960 Aug 05 2005 00:00:32
 voicemail 2105
 max-conferences 8 gain -6
 moh music-on-hold.au
 dn-webedit 
 time-webedit 
 transfer-system full-consult
 transfer-pattern 210. blind
 transfer-pattern 2040 blind
!
ephone-dn  1  dual-line
 number 2001
 name User21
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  2  dual-line
 number 2002
 name User22
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  3  dual-line
 number 2003
 name User23
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  4  dual-line
 number 2004
 name User24
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  5  dual-line
 number 2005
 name User25
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  6  dual-line
 number 2006
 name User26
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  11
 number 2070
 description GDM
 name Cust Svc GDM
 call-forward all 2105
!
ephone-dn  100
 number 8000....
 mwi on
!
ephone-dn  101
 number 8001....
 mwi off
!
ephone  1
 username "user21" password null
 mac-address 0012.0034.81B7
 type 7960
 button  1:1 2:11
!
ephone  2
 username "user22" password null
 mac-address 0011.2032.C876
 type 7960
 button  1:2 2:11
!
ephone  3
 username "user23" password null
 mac-address 0012.01E8.875F
 type 7960
 button  1:3 2:11
!
ephone  4
 username "user24"
 mac-address 0003.AAAA.0004
 type 7960
 button 1:4 2:11
!
ephone 5
 username "user25"
 mac-address 0003.AAAA.0005
 type 7960
 no auto-line
 button 1:5 2:11
!
ephone 6
 username "user26"
 mac-address 0003.AAAA.0006
 type 7960
 button 1:6 2:11
!
ephone-hunt 1 longest-idle
 pilot 2020
 list 2001, 2002, 2003
 timeout 5
!
ephone-hunt 2 longest-idle
 pilot 2021
 list 2004, 2005, 2006
 timeout 5
!
line con 0
 logging synchronous
line aux 0
line 66
 no activation-character
 no exec
 transport preferred none
 transport input all
 transport output all
line vty 0 4
 login
!
scheduler allocate 20000 1000
ntp master
!
end

Настройка Cisco Unity Express для сценария 3

Эти этапы объединяют конфигурации для Cisco Unity Express для сценария 3:

  1. Откройте утилиту редактора сценария Cisco Unity Express и создайте пользовательский сценарий Cisco Unity Express. См. рисунок 25.

    Рисунок 25 Часы работы магазина и локальный сценарий

    135367.jpg

  2. Запишите подсказку (в данном случае она называется S11_Announcement.wav) для сценария автоответчика (S11_CUE-AA-BACD-script.aef). Их можно записать либо в отключенном состоянии и загрузить .wav-файлы в Cisco Unity Express, используя соответствующее имя файла или записать их через систему управления с помощью телефонии (AVT).

  3. (Дополнительно) При использовании AVT, Cisco Unity Express назначает общее имя файла, которое позднее может быть изменено на любое другое имя файла. Выберите Voice Mail > Prompts и отметьте имя системного файла.

  4. (Дополнительно) Отредактируйте имя файла в диалоговом окне и нажмите OK. В окне "Voice Mail > Prompts" теперь отображен соответствующий список имен файла (см. рисунок 26).

  5. Выберите Voice Mail > Auto Attendant и откройте автоответчик, созданный на этапе 2. Выберите Script Parameters и свяжите имя файла подсказки с соответствующим параметром сценария.

    Рисунок 26 Окно параметров подсказок

    135368.jpg

  6. Выберите Voice Mail > Auto Attendant и свяжите сценарий с телефонным номером доступа 2100 автоответчика. См. рисунок 27.

    Рисунок 27 Окно связывания сценария с телефонным номером доступа автоответчика

    135369.jpg

На примере представлена конфигурация CLI для системы Cisco Unity Express:

cue# 
show running-config
Generating configuration:
clock timezone America/Los_Angeles
hostname cue
ip domain-name cisco.com
ntp server a.1.11.1
groupname Administrators create
groupname Broadcasters create
groupname custservice create
username admin create
username user21 create
username user22 create
username user23 create
username user24 create
username user25 create
username user26 create
groupname custservice phonenumber "2070"
username user21 phonenumber "2001"
username user22 phonenumber "2002"
username user23 phonenumber "2003"
username user24 phonenumber "2004"
username user25 phonenumber "2005"
username user26 phonenumber "2006"
groupname Administrators member admin
groupname custservice member user21
groupname custservice member user22
groupname custservice member user23
groupname custservice member user24
groupname custservice member user25
groupname custservice member user26
groupname Administrators privilege superuser
groupname Administrators privilege ManagePrompts
groupname Administrators privilege ManagePublicList
groupname Administrators privilege ViewPrivateList
groupname Broadcasters privilege broadcast
calendar biz-schedule systemschedule
 closed day 1 from 00:00 to 24:00
 open day 2 from 09:00 to 17:00
 open day 3 from 09:00 to 17:00
 open day 4 from 09:00 to 17:00
 open day 5 from 09:00 to 17:00
 open day 6 from 09:00 to 17:00
 closed day 7 from 00:00 to 24:00
end schedule
ccn application autoattendant
 description "autoattendant"
 enabled
 maxsessions 8
 script "aa.aef"
 parameter "busOpenPrompt" "AABusinessOpen.wav"
 parameter "holidayPrompt" "AAHolidayPrompt.wav"
 parameter "busClosedPrompt" "AABusinessClosed.wav"
 parameter "allowExternalTransfers" "true"
 parameter "MaxRetry" "3"
 parameter "operExtn" "2001"
 parameter "welcomePrompt" "AAWelcome.wav"
 parameter "businessSchedule" "systemschedule"
 end application
ccn application ciscomwiapplication
 description "ciscomwiapplication"
 enabled
 maxsessions 8
 script "setmwi.aef"
 parameter "strMWI_OFF_DN" "8001"
 parameter "strMWI_ON_DN" "8000"
 parameter "CallControlGroupID" "0"
 end application
ccn application promptmgmt
 description "promptmgmt"
 enabled
 maxsessions 1
 script "promptmgmt.aef"
 end application
!
!--- Укажите сценарий, необходимый для передачи сообщения.

!
ccn application s11-cue-aa-bacd
 description "s11-cue-aa-bacd"
 enabled
 maxsessions 8
 script "s11_cue-aa-bacd-script.aef"
 end application
ccn application voicemail
 description "voicemail"
 enabled
 maxsessions 8
 script "voicebrowser.aef"
 parameter "logoutUri" "http://localhost/voicemail/vxmlscripts/mbxLogout.jsp"
 parameter "uri" "http://localhost/voicemail/vxmlscripts/login.vxml"
 end application
ccn engine
 end engine
ccn subsystem jtapi
 ccm-manager address 0.0.0.0 
 end subsystem
ccn subsystem sip
 gateway address "a.1.11.1"
 end subsystem
!
!--- Свяжите этот сценарий с телефонным номером доступа 2100 автоответчика.

!
ccn trigger sip phonenumber 2100
 application "s11-cue-aa-bacd"
 enabled
 maxsessions 8
 end trigger
ccn trigger sip phonenumber 2102
 application "autoattendant"
 enabled
 maxsessions 8
 end trigger
ccn trigger sip phonenumber 2105
 application "voicemail"
 enabled
 maxsessions 8
 end trigger
ccn trigger sip phonenumber 2106
 application "promptmgmt"
 enabled
 maxsessions 1
 end trigger
voicemail default language en_US
voicemail default mailboxsize 3000
voicemail broadcast recording time 300
voicemail operator telephone 2001
voicemail mailbox owner "custservice" size 3000
 description "custservice mailbox"
 end mailbox
voicemail mailbox owner "user21" size 3000
 end mailbox
voicemail mailbox owner "user22" size 3000
 end mailbox
voicemail mailbox owner "user23" size 3000
 end mailbox
voicemail mailbox owner "user24" size 3000
description "user24 mailbox"
end mailbox
voicemail mailbox owner "user25" size 3000
description "user25 mailbox"
end mailbox
voicemail mailbox owner "user26" size 3000

description "user26 mailbox"
end mailbox
end

Проверка

В настоящее время для этой конфигурации нет процедуры проверки.

Поиск и устранение неполадок

Для этой конфигурации отсутствуют сведения об устранении неполадок.


Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения


Document ID: 67907