Протокол IP : Протоколы IP-маршрутизации

Пример конфигурации маршрутизации на основе политик с функцией отслеживания по нескольким параметрам

29 июля 2008 - Перевод, выполненный профессиональным переводчиком
Другие версии: PDF-версия:pdf | Машинный перевод (28 июля 2013) | Английский (10 августа 2005) | Отзыв

Содержание

Введение
Предварительные условия
     Требования
     Используемые компоненты
     Условные обозначения
Настройка
     Схема сети
     Конфигурация
Проверка
Устранение неполадок
Связанные обсуждения сообщества поддержки Cisco
Дополнительные сведения

Введение

В этом документе приводится пример конфигурации для маршрутизации на основе политик (PBR, policy based routing) с помощью функции отслеживания по нескольким параметрам. Эта функция была представлена в Cisco IOS® версии 12.3(4)T. Дополнительные сведения см. в документе Поддержка технологии PBR для функции отслеживания по нескольким параметрам.

Данная функция расширяет возможности отслеживания цели, проверяя IP-адрес следующего сетевого сегмента до переадресации на него трафика. Метод верификации может быть запросом "ICMP-эхо" (межсетевой протокол контрольных сообщений) или UDP (протокол пользовательских датаграмм) либо запросом GET по протоколу HTTP (протокол передачи гипертекста). Протокол ICMP - это наиболее общий метод верификации, используемый в Интернете. Функция отслеживания по нескольким параметрам больше всего подходит для маршрутизаторов, имеющих множественные Ethernet-подключения в качестве следующего сетевого сегмента. Обычно интерфейсы Ethernet подключаются к цифровой абонентской линии (DSL) или кабельным модемам. В настоящее время не существует метода для обнаружения ошибок восходящего потока в широкополосной сети поставщика Интернет-услуг (ISP). Интерфейс Ethernet остается в рабочем состоянии, а любая форма статической маршрутизации указывает на него. Преимущество этой функции заключается в том, что она позволяет резервировать два интерфейса Ethernet, выбирать тот интерфейс, который является доступным, отправляя запросы "ICMP-эхо" для проверки достижимости, и затем направлять на него трафик.

Предварительные условия

Требования

Прежде чем приступить к данной конфигурации, необходимо убедиться в выполнении следующего требования:

  • Загрузите набор функций Enterprise Base IOS на маршрутизаторы, если это уже не было сделано ранее. Если данный набор функций был оплачен, его можно загрузить в разделе сайта Область загрузки ПО (только для зарегистрированных пользователей).

Используемые компоненты

Сведения в данном документе не ограничиваются определенными версиями ПО или устройств.

Условные обозначения

Дополнительные сведения о применяемых в документе обозначениях см. в документе Условные обозначения, используемые в технической документации Cisco.

Настройка

В этом разделе представлены сведения по настройке функций, описанных в данном документе.

Примечание. Для поиска дополнительных сведений о командах, используемых в этом документе, используйте Средство поиска команд (только для зарегистрированных пользователей).

Схема сети

В этом документе использованы параметры данной сети. В этом сценарии маршрутизатор R1 подключен к двум различным ISP (ISP-1 и ISP-2). R1 отслеживает достижимость обоих маршрутизаторов ISP.

pbrtracking_01.gif

Конфигурация

В данном документе используется следующая конфигурация.

R1

R1# show running-config 
Building configuration...

Current configuration : 1203 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
clock timezone EST 0
no aaa new-model
ip subnet-zero
no ip domain lookup
!
!
!
!
track 123 rtr 1 reachability
!--- Отслеживание достижимости 1-ого маршрутизатора.

!         
track 124 rtr 2 reachability
!--- Отслеживание достижимости 2-ого маршрутизатора.

!
!
interface Loopback0
 ip address 1.1.1.1 255.255.255.255
!
interface Ethernet0/0
 ip address 192.168.0.1 255.255.255.0
!
interface Ethernet1/0
 ip address 192.168.1.1 255.255.255.0
!
interface Ethernet2/0
 ip address 10.10.10.1 255.255.255.0
 ip policy route-map alpha
!--- Включение маршрутизации на основе политики на исходящем интерфейсе.

!
ip classless
no ip http server
!
!
!
!
route-map alpha permit 10
!--- Определение маршрутной карты для задания следующего перехода  
!--- в зависимости от состояния отслеживаемых маршрутизаторов.

 set ip next-hop verify-availability 192.168.0.10 10 track 123
 set ip next-hop verify-availability 192.168.1.20 20 track 124
!
!
control-plane
!
rtr 1
!--- Определение и запуск 1-ого маршрутизатора.

 type echo protocol ipIcmpEcho 192.168.0.10
rtr schedule 1 life forever start-time now
rtr 2
!--- Определение и запуск 2-ого маршрутизатора.


 type echo protocol ipIcmpEcho 192.168.1.20
rtr schedule 2 life forever start-time now
!
line con 0
 transport preferred all
 transport output all
line aux 0
 transport preferred all
 transport output all
line vty 0 4
 login
 transport preferred all
 transport input all
 transport output all
!
!
end

Проверка

В данном разделе содержатся сведения о проверке работы конфигурации.

Некоторые команды show поддерживаются с помощью Интерпретатора выходных данных (только для зарегистрированных пользователей); это позволяет выполнять анализ выходных данных команды show.

  • show track - выводит данные отслеживания.

  • show track brief - выводит ограниченные данные отслеживания.

R1# show track           
Track 123
  Response Time Reporter 1 reachability
  Reachability is Up
    3 changes, last change 00:06:43
  Latest operation return code: OK
  Latest RTT (millisecs) 8
  Tracked by:
    ROUTE-MAP  0
Track 124
  Response Time Reporter 2 reachability
  Reachability is Up
    3 changes, last change 00:06:43
  Latest operation return code: OK
  Latest RTT (millisecs) 12
  Tracked by:
    ROUTE-MAP  0

R1# show track brief
Track   Object                         Parameter        Value
123     rtr       1                    reachability     Up
124     rtr       2                    reachability     Up

Из выходных данных команды show track brief видно, что оба ISP являются достижимыми. Если отключить интерфейс, который подключен к ISP-1, при отслеживании он будет показан как отключенный.

R1# conf t
R1(config)# int ethernet 0/0
R1(config-if)# shutdown
R1(config-if)# end
R1#

*Jan 21 06:06:50.167: %SYS-5-CONFIG_I: Configured from console by console
*Jan 21 06:06:50.807: %LINK-5-CHANGED: Interface Ethernet0/0, changed state to administratively down
*Jan 21 06:06:51.827: %LINEPROTO-5-UPDOWN: Line protocol on Interface Ethernet0/0, changed state to down

R1# show track brief
Track   Object                         Parameter        Value
123     rtr       1                    reachability     Up
124     rtr       2                    reachability     Up

R1# show track brief
Track   Object                         Parameter        Value
123     rtr       1                    reachability     Down
124     rtr       2                    reachability     Up
R1#

Устранение неполадок

Для этой конфигурации отсутствуют сведения об устранении неполадок.

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения


Document ID: 48003