Качество обслуживания (QoS) : Политики QoS

Параметры качества обслуживания (QoS) на туннельных интерфейсах GRE

29 июля 2008 - Перевод, выполненный профессиональным переводчиком
Другие версии: PDF-версия:pdf | Машинный перевод (28 июля 2013) | Английский (24 января 2006) | Отзыв

Содержание

Введение
Предварительные условия
     Требования
     Используемые компоненты
     Условные обозначения
Обзор протокола GRE
Система Cisco качества обслуживания (QoS) для туннелей GRE
     Формирование трафика
     Назначение политик
     Предотвращение перегрузок
     Команда qos pre-classify
Задание характеристик трафика для политик QoS
Где применяются политики безопасности?
Многоточечные туннельные интерфейсы
Типичные ошибки
Связанные обсуждения сообщества поддержки Cisco
Дополнительные сведения

Введение

В этом документе приводится обзор функций качества обслуживания (Quality of Service, QoS), которые можно настраивать на туннельных интерфейсах с использованием протокола GRE (общая инкапсуляция маршрутов). Туннели, настраиваемые по протоколу IPsec (межсетевой протокол безопасности), находятся за пределами рассмотрения данного документа.

Предварительные условия

Требования

Для данного документа отсутствуют особые требования.

Используемые компоненты

Сведения в данном документе не ограничиваются определенными версиями ПО или устройств.

Данные для этого документа были получены при тестировании указанных устройств в специально созданных лабораторных условиях. Все устройства, описанные в данном документе, обладают ненастроенной (заданной по умолчанию) конфигурацией. При работе в действующей сети необходимо изучить все возможные последствия каждой команды.

Условные обозначения

Дополнительную информацию о применяемых в документе обозначениях см. в документе Условные обозначения, используемые в технической документации Cisco.

Обзор протокола GRE

Прежде чем рассматривать систему QoS на туннелях GRE, в первую очередь необходимо ознакомиться с форматом туннелируемого пакета.

Туннельный интерфейс - это виртуальный или логический интерфейс на маршрутизаторе под управлением системы Cisco IOS ®. Он создает виртуальное соединение "точка-точка" между двумя маршрутизаторами Cisco на удаленных пунктах объединенной IP-сети.

GRE - это протокол инкапсуляции, поддерживаемый системой IOS и определенный в стандарте RFC 1702 leavingcisco.com. Протоколы туннелирования инкапсулируют пакеты в пределах протокола транспортного уровня.

Туннельный интерфейс поддерживает заголовок для каждого из следующих протоколов:

  • протокол переноса или инкапсулируемый протокол, например IP, AppleTalk, DECnet (Digital Equipment Corporation Network, сеть корпорации цифрового оборудования) и IPX (Internetwork Packet eXchange, межсетевой пакетный обмен);

  • протокол носителя (GRE в данном случае);

  • транспортный протокол (только IP в данном случае).

Формат туннельного пакета проиллюстрирован ниже:

qostunnel_01.gif

Дополнительные сведения о настройке туннелей GRE см. в документе Настройка логических интерфейсов.

Система Cisco качества обслуживания (QoS) для туннелей GRE

Туннельный интерфейс поддерживает большинство тех же функций QoS, что и физический интерфейс. В следующих разделах описываются поддерживаемые функции QoS.

Формирование трафика

В системе Cisco IOS версии 12.0(7)T предоставляется поддержка для применения протокола GTS (Формирование общего трафика) непосредственно на туннельном интерфейсе. В следующем примере конфигурации формируется туннельный интерфейс с общей скоростью исходящего трафика 500 Кбит/с. Дополнительные сведения см. в документе Настройка формирования общего трафика.

interface Tunnel0 
  ip address 130.1.2.1 255.255.255.0 
  traffic-shape rate 500000 125000 125000 1000 
  tunnel source 10.1.1.1 
  tunnel destination 10.2.2.2

В системе Cisco IOS версии 12.1(2)T появилась поддержка формирования трафика на основе классов с использованием MQC (modular QoS command-line interface, модульный интерфейс командной строки качества обслуживания). Следующий пример конфигурации показывает, как применять ту же политику формирования трафика к туннельному интерфейсу с помощью команд MQC. Дополнительные сведения см. в документе Настройка формирования трафика на основе классов.

policy-map tunnel 
  class class-default 
    shape average 500000 125000 125000 
interface Tunnel0 
  ip address 130.1.2.1 255.255.255.0 
  service-policy output tunnel 
  tunnel source 130.1.35.1 
  tunnel destination 130.1.35.2

Назначение политик

Когда интерфейсы перегружены и пакеты начинают скапливаться в очередь, к пакетам, ожидающим передачи, можно применить метод организации очереди. Логические интерфейсы Cisco IOS по своей сути не поддерживают состояние перегруженности и непосредственное применение политики обслуживания, применяющей метод организации очереди. Вместо этого необходимо применить иерархическую политику следующим образом:

  1. Создайте "дочернюю" политику или политику нижнего уровня, которая настраивает механизм организации очереди: построение очереди с низкой задержкой с помощью команды priority или объективную организацию очереди с весовыми коэффициентами на основе классов (CBWFQ, class-based weighted fair queueing) с помощью команды bandwidth. Дополнительные сведения см. в документе Управление перегрузкой.

    policy-map child 
     class voice 
      priority 512
  2. Создайте "родительскую" политику (верхнего уровня), которая применяет формирование трафика на основе классов. Примените дочернюю политику как команду родительской политики, так как контроль на входе дочернего класса основан на скорости формирования трафика родительского класса.

    policy-map tunnel 
     class class-default 
      shape average 2000000 
      service-policy child 
  3. Примените родительскую политику к туннельному интерфейсу.

    interface tunnel0 
       service-policy tunnel

Когда туннельный интерфейс настраивается с помощью политики обслуживания, которая применяет организацию очереди, не используя формирование, маршрутизатор печатает следующее сообщение журнала событий.

router(config)# interface tunnel1
router(config-if)# service-policy output child
 Class Based Weighted Fair Queueing not supported on this interface

Туннельные интерфейсы также поддерживают назначение политик на основе классов, но не предусматривают фиксированную скорость доступа (committed access rate, CAR).

Примечание. На туннельных интерфейсах устройств серии 7500 политики обслуживания не поддерживаются.

Предотвращение перегрузок

В системе Cisco IOS версии 11.3T введен приоритет IP для туннелей GRE, согласно которому маршрутизатор настраивается на копирование значений битов приоритета IP из байта ToS (Type of Service, тип обслуживания) в IP-заголовок туннеля или протокола GRE, инкапсулирующий внутренний пакет. Ранее для этих битов было установлено значение, равное нулю. На промежуточных маршрутизаторах между конечными точками туннеля могут использоваться значения IP-приоритета, чтобы классифицировать пакеты для таких функций QoS, как маршрутизация на основе политик, объективная организация очереди с весовыми коэффициентами (WFQ, weighted fair queueing) и случайное взвешенное предварительное обнаружение (WRED, Weighted Random Early Detection).

Команда qos pre-classify

Если пакеты инкапсулируются заголовками туннелей или шифровок, средствам QoS не удается проверить исходные заголовки пакетов и правильно их классифицировать. Пакеты, перемещающиеся по одному туннелю, имеют идентичные заголовки туннеля, поэтому пакеты обрабатываются одинаковым образом в том случае, если физический интерфейс перегружен. С введением функции качества обслуживания для виртуальных частных сетей (VPN) пакеты можно классифицировать перед выполнением туннелирования и шифрования.

В следующем примере tunnel0 - это название туннеля. Команда qos pre-classify включает систему QoS для функции VPN на tunnel0:

Router(config)# interface tunnel0
Router(config-if)# qos pre-classify

Задание характеристик трафика для политик QoS

При настройке политики обслуживания сначала может возникнуть необходимость описать характеристики трафика, проходящего по туннелю. Система Cisco IOS поддерживает Netflow и IP-учет по методу коммутации CEF (Cisco Express Forwarding, технология Cisco скоростной переадресации) на логических интерфейсах, подобным туннелям. Дополнительные сведения см. в документе Руководство по решениям и службам NetFlow.

Где применяются политики обслуживания?

Политику обслуживания можно применить либо к туннельному интерфейсу, либо к основному физическому интерфейсу. Выбор интерфейса, где следует применить политику, зависит от целей качества обслуживания. Это также зависит от того, какой заголовок нужен для классификации.

  • Когда нужно классифицировать пакеты на основе заголовка перед туннелем, применяйте политику к туннельному интерфейсу, не используя qos-preclassify.

  • Если же необходимо классифицировать пакеты на основе заголовка после туннеля, следует применять политику к физическому интерфейсу, не используя qos-preclassify. Кроме того, при формировании всего трафика туннеля или назначении для него политики следует применять политику к физическому интерфейсу. Физический интерфейс поддерживает несколько туннелей.

  • При необходимости выполнить классификацию пакетов на основе заголовка перед туннелем применяется политика к физическому интерфейсу и включается qos-preclassify.

Многоточечные туннельные интерфейсы

На многоточечном интерфейсе технология CBWFQ в пределах формирования трафика на основе классов не поддерживается. Если использовать исправление ошибки Cisco с идентификатором CSCds87191, то при отклонении политики маршрутизатор будет выдавать сообщение об ошибке.

Типичные ошибки

В редких случаях применение политики обслуживания, настроенной с помощью команды shape, приводит к высокой загрузке процессора и ошибкам выравнивания. Перегрузка процессора происходит вследствие регистрации ошибок выравнивания, которые, в свою очередь, вызываются методом CEF, неверно устанавливающим выходной интерфейс, и данными о перезаписи смежности. Эта проблема касается только платформ начального уровня, имеющих тип, отличный от RSP, и платформ, использующих метод коммутации CEF на основе частиц, и решается с помощью исправлений ошибок Cisco с идентификаторами CSCdu45504 и CSCuk30302. Кроме того, можно использовать следующие приемы:

  • замену инкапсуляции GRE на tunnel mode ipip;

  • замену команды shape на police;

  • настройку формирования трафика на физическом интерфейсе, который поддерживает туннель.


Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения


Document ID: 10106