Коммутация LAN : EtherChannel

Пример конфигурации: EtherChannel между коммутаторами Catalyst, работающими под управлением ПО CatOS и Cisco IOS

28 июля 2008 - Перевод, выполненный профессиональным переводчиком
Другие версии: PDF-версия:pdf | Машинный перевод (28 июля 2013) | Английский (25 октября 2006) | Отзыв

Содержание

Введение
Предварительные условия
     Требования
     Используемые документы
     Условные обозначения
     Общие сведения
Конфигурация
     Схема сети
     Рекомендации
     Конфигурации
Проверка
Пример выходных данных команды show
     Коммутатор Catalyst 5500
     Коммутатор Catalyst 6500
     Специальные рекомендации по использованию безусловного режима канала
Устранение неполадок
     Проблемы производительности каналов EtherChannel
Связанные обсуждения сообщества поддержки Cisco
Дополнительная информация

Введение

В этом документе рассматривается настройка EtherChannel между коммутатором Catalyst 5500/5000 с ПО Catalyst OS (CatOS) и коммутатором Catalyst 6500/6000 или Catalyst 4500/4000 с ПО Cisco IOS®. EtherChannel связывает отдельные соединения в одно логическое соединение, которое обеспечивает более высокую пропускную способность и избыточность между коммутаторами или другими устройствами. EtherChannel может называться Fast EtherChannel (FEC) или Gigabit EtherChannel (GEC); термин зависит от скорости интерфейсов или портов, которые используются для формирования EtherChannel. Эта конфигурация также применима к коммутатору серии Catalyst 4500/4000 или 6500/6000 с ПО CatOS, который соединен с коммутатором серии Catalyst 4500/4000 или 6500/6000 с системным ПО Cisco IOS.

Эта конфигурация связывает два порта Fast Ethernet (FE) от каждого коммутатора и преобразовывает их в канал FEC. Для обозначения GEC, FEC, канала порта, канала и группы каналов в этом документе используется термин "EtherChannel".

В этом документе показаны только файлы конфигурации для коммутаторов, а также примеры выходных данных команды show. Более подробные сведения о настройке EtherChannel см. в следующих документах:

Предварительные условия

Требования

Прежде чем воспользоваться этой конфигурацией, убедитесь, что вы владеете базовым уровнем знаний по следующим разделам:

  • Настройка EtherChannel

  • Настройка коммутаторов серии Catalyst 6500/6000 и 5500/5000 с использованием интерфейса командной строки.

Используемые компоненты

Сведения, содержащиеся в данном документе, касаются следующих версий программного и аппаратного обеспечения:

  • Коммутатор Catalyst 5505 с ПО CatOS версии 6.4(8)

  • Коммутатор Cisco Catalyst 6509 с ПО Cisco IOS версии 12.1(20)E

Примечание. Системные требования для реализации EtherChannel на коммутаторах Catalyst см. в статье Системные требования для реализации EtherChannel на коммутаторах Catalyst

Данные для этого документа были получены при тестировании указанных устройств в специально созданных лабораторных условиях. Все устройства начинали работу с чистой конфигурацией (конфигурацией по умолчанию). При работе в действующей сети необходимо изучить все возможные последствия каждой команды.

Условные обозначения

Дополнительные сведения о применяемых в документе обозначениях см. в Условные обозначения, используемые в технической документации Cisco.

Теоретические сведения

Настройка EtherChannel производится безусловно при помощи команды channel mode on или путем автоматического согласования. Если настройка производится посредством автоматического согласования, коммутатор выполняет согласование параметров канала с дальним концом. Для выполнения данного действия коммутатор использует частный протокол объединения портов (PAgP) Cisco (при помощи команды channel mode desirable) или управления объединением каналов IEEE 802.3ad (LACP) (при помощи команды channel mode active или channel mode passive) В данном документе при настройке EtherChannel для автоматического согласования используется PAgP.

Все коммутаторы Catalyst с системным ПО CatOS поддерживают протокол PAgP. Коммутаторы серии Catalyst 6500/6000 и 4500/4000 с системным ПО Cisco IOS также поддерживают протокол PAgP. Для установления EtherChannel между устройствами с поддержкой протокола PAgP рекомендуется работать в режиме "desirable". PAgP защищает от любых недействительных конфигураций между двумя устройствами. Если соединяющее устройство не поддерживает протокол PAgP и необходимо настроить канал, используйте команду channel mode on. Ключевые слова режима молчания (silent) или немолчания (non-silent) доступны в режимах канала "auto" и "desirable". В коммутаторах серии Catalyst 6500/6000 или 4500/4000 ключевое слово режима молчания по умолчанию включено на всех портах. В коммутаторах серии Catalyst 5500/5000 ключевое слово молчания включено по умолчанию на медных портах. Ключевое слово немолчания включено по умолчанию на всех волоконных портах (FE и Gigabit Ethernet [GE]) для коммутаторов серии Catalyst 5500/5000. Используйте ключевое слово молчания или немолчания при соединении коммутаторов Cisco.

Примечание. Дополнительные сведения о режиме настройки PAgP и режимах молчания и немолчания см. в разделах Использование PAgP для настройки EtherChannel (рекомендуется) и Режим молчания и немолчания документа Настройка канала EtherChannel между коммутаторами Catalyst 4500/4000, 5500/5000 и 6500/6000, работающими под управлением ПО CatOS.

Настройка

В этом разделе представлены сведения по настройке функций, описанных в данном документе.

Схема сети

В данном документе используется следующая настройка сети:

71a.gif

Рекомендации

Если активные соединения объединяются в EtherChannel, порты мгновенно прекращают функционировать по протоколу STP и возвращаются в режим отдельного логического порта. Сетевой трафик будет прерываться до тех пор, пока происходит обновление протокола STP.

Если по каким-либо причинам при настройке EtherChannel не используются протоколы PAgP или LACP, убедитесь, что рекомендуемые параметры одинаковы на обоих концах. Если они отличаются, то один конец канала переключится в режим "err-disable". Чтобы вывести порты из режима "err-disable", см. следующее:

Конфигурации

Этот документ использует следующие конфигурации:

Примечание Для проверки возможностей настраиваемого модуля или порта коммутатора служит команда show port capabilities module (для коммутаторов, работающих под управлением CatOS). Для коммутаторов, работающих под управлением ПО Cisco IOS, используется команда "show interfaces capabilities".

Примечание. В настройках примечания к выходным данным выделены синим курсивом.

Catalyst 5500

cat5500 (enable) show config
This command shows non-default configurations only.
Use 'show config all' to show both default and non-default configurations.
......
................
................
..

begin
!
# ***** NON-DEFAULT CONFIGURATION *****
!
!
# time: Wed Jan 28 2004, 09:39:55
!

# version 6.4(2) 
!
# errordetection
set errordetection portcounter enable
!
# frame distribution method
set port channel all distribution mac both
!
# vtp
set vtp domain cisco
set vlan 1 name default type ethernet mtu 1500 said 100001 state active
set vlan 1002 name fddi-default type fddi mtu 1500 said 101002 state active
set vlan 1004 name fddinet-default type fddinet mtu 1500 said 101004 state
active stp ieee
set vlan 1005 name trnet-default type trbrf mtu 1500 said 101005 state
active stp ibm
set vlan 1003 name token-ring-default type trcrf mtu 1500 said 101003 state
active mode srb aremaxhop 7 stemaxhop 7 backupcrf off
!
# ip
!--- Данный IP-адрес для управления.

set interface sc0 1 10.10.10.2/255.255.255.0 10.10.10.255

!
# set boot command
set boot config-register 0x2102
set boot system flash bootflash:cat5000-supg.6-4-8.bin
!
# mls
set mls nde disable
!
# port channel

!--- Порты назначены группе администратора 200. Административные группы 
!--- определяют, какие порты могут образовывать EtherChannel. Административная группа 
!--- может содержать не более 8 портов. Назначение данной административной группы происходит
!--- автоматически при настройке канала порта. Также можно
!--- назничить ее вручную, как показано в данном примере. Однако нет необходимости назначать 
!--- административную группу вручную. Коммутатор автоматически создаст
!--- административную группу. 
!--- Примечание: Данная конфигурация устанавливает порты 4/1 — 4/4
!--- для канала порта, но настраивает только порты 4/1-2. Это
!--- нормальное поведение. Можно использовать порты 4/3 и 4/4 для других целей.

set port channel 4/1-4 200
!
# default port status is enable
!
!
#module 1 : 0-port Supervisor III
!
#module 2 : 2-port MM MIC FDDI
!
#module 3 : 24-port 10/100BaseTX Ethernet
!
#module 4 : 12-port 10/100BaseTX Ethernet
!--- Это позволяет передать по каналу с помощью PAgP и настроить необходимый режим молчания.

set port channel 4/1-2 mode desirable silent
!
#module 5 : 2-port MM OC-3 Dual-Phy ATM
!--- Выходные данные команды подавлены.

end

Для получения дополнительной информации о командах см. Справочное руководство по командам семейства коммутаторов Catalyst 5000 (6.3 и 6.4).

Catalyst 6500

Cat6509# show running-config
Building configuration...

Current configuration : 3852 bytes
!
version 12.1
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Cat6509
!
!
redundancy
 main-cpu
  auto-sync standard
ip subnet-zero
!
!
interface port-channel1
 no ip address

!--- В данном примере настроен EtherChannel уровня 2 (L2).
!--- Можно настроить EtherChannel уровня 3 (L3) на коммутаторах Catalyst
!--- 6500/6000, работающих под управлением ПО Cisco IOS, однако 
!--- в этом документе основное внимание уделено другим вопросам. Дополнительные сведения о настройке EtherChannel уровня 3 (L3)
!--- см.в документе Настройка каналов EtherChannel.


 switchport

!--- Данная команда размещает интерфейс в VLAN1 по умолчанию.

switchport mode access
!
interface FastEthernet6/1
no ip address
!--- На коммутаторе Catalyst 6500/6000 можно выполнить команду switchport один раз
!--- без каких либо ключевых слов, чтобы настроить интерфейс в качестве порта L2.
!--- По умолчанию все порты являются портами маршрутизатора (порты уровня 3).
!--- Все порты коммутаторов Catalyst 4500/4000 являются портами L2 по умолчанию.
!--- Использование дополнительной команды не требуется.

switchport

!--- Данная команда размещает интерфейс в VLAN1 по умолчанию.

 switchport mode access

!--- Порт существует в первой группе каналов автосогласования,
!--- в которой используется PAgP и режим молчания.

 channel-group 1 mode desirable
!
interface FastEthernet6/2
 no ip address

!--- На коммутаторе Catalyst 6500/6000 можно выполнить команду switchport один раз
!--- без каких либо ключевых слов, чтобы настроить интерфейс в качестве порта L2.
!--- По умолчанию все порты являются портами маршрутизатора (порты уровня 3).
!--- Все порты коммутаторов Catalyst 4500/4000 являются портами L2 по умолчанию.
!--- Использование дополнительной команды не требуется.

 switchport

!--- Данная команда размещает интерфейс в VLAN1 по умолчанию.

 switchport mode access

!--- Порт существует в первой группе каналов автосогласования,
!--- в которой используется PAgP и режим молчания.

 channel-group 1 mode desirable
!
interface FastEthernet6/3
 no ip address
!
interface FastEthernet6/4
 no ip address
!
!--- Выходные данные команды подавлены.

interface FastEthernet6/45
 no ip address
 shutdown
!
interface FastEthernet6/46
 no ip address
 shutdown
!
interface FastEthernet6/47
 no ip address
 shutdown
!
interface FastEthernet6/48
 no ip address
 shutdown
!

!--- IP-адрес для управления.

 ip address 10.10.10.3 255.255.255.0


!
ip classless
no ip http server
!
!
!
line con 0
line vty 0 4
!
end
Cat6509#

Для получения дополнительной информации о командах см. Справочное руководство по командам семейства коммутаторов Catalyst 5000 (6.3 и 6.4).

Примечание. Невозможно создать интерфейс в несуществующей сети VLAN до тех пор, пока не будет создана ее база данных. Дополнительные сведения см. в документе Настройка сетей VLAN, раздел Создание и изменение Ethernet VLAN.

Проверка

В данном разделе содержатся сведения для проверки работы текущей конфигурации.

Некоторые команды show поддерживаются Интерпретатором выходных данных (только для зарегистрированных клиентов), которое позволяет выполнять анализ выходных данных команды show.

Чтобы проверить канал порта в коммутаторах CatOS, выполните следующие команды:

Чтобы проверить статус протокола STP в коммутаторах CatOS, выполните следующие команды:

Чтобы проверить канал порта в коммутаторах серии Catalyst 6500/6000 или Catalyst 4500/4000 с ПО Cisco IOS, выполните следующие команды:

Чтобы проверить статус протокола STP в коммутаторах серии Catalyst 6500/6000 или Catalyst 4500/4000 с ПО Cisco IOS, выполните следующие команды:

Пример выходных данных команды "show"

Коммутатор Catalyst 5500

Эта команда проверяет, поддерживает ли данный модуль уплотнение канала. Данная команда также позволяет узнать, какую группу портов можно объединить для формирования EtherChannel. В данном примере показано, что для формирования канала необходимо объединить два порта 4/1-2 или четыре порта 4/1-4.

cat5500 (enable) show port capabilities 4
Model                    WS-X5203
Port                     4/1
Type                     10/100BaseTX
Speed                    auto,10,100
Duplex                   half,full
Trunk encap type         ISL
Trunk mode               on,off,desirable,auto,nonegotiate
Channel                  4/1-2,4/1-4
Broadcast suppression    pps(0-150000),percentage(0-100)
Flow control             no
Security                 yes
Membership               static,dynamic
Fast start               yes
QOS scheduling           rx-(none),tx-(none)
CoS rewrite              no
ToS rewrite              no
Rewrite                  no
UDLD                     yes
AuxiliaryVlan            no
SPAN                     source,destination
!--- Выходные данные команды подавлены.

Данная команда наряду с командой show port проверяет статус канала порта.

cat5500 (enable) show port channel
Port  Status     Channel              Admin Ch                 
                 Mode                 Group Id
----- ---------- -------------------- ----- -----
4/1  connected  desirable silent       200   865 
4/2  connected  desirable silent       200   865
----- ---------- -------------------- ----- -----

Port  Device-ID                       Port-ID                   Platform
----- ------------------------------- ------------------------- ---------------- 
4/1  Switch                          Fa6/1                     cisco Catalyst 6000 
4/2  Switch                          Fa6/2                     cisco Catalyst 6000
----- ------------------------------- ------------------------- ----------------
cat5500 (enable)
cat5500 (enable) show port 4/1
Port  Name               Status     Vlan       Level  Duplex Speed Type
----- ------------------ ---------- ---------- ------ ------ ----- ------------ 
4/1                     connected  1          normal a-full a-100 10/100BaseTX
!--- Выходные данные команды подавлены.

 
Port  Status     Channel              Admin Ch                 
                 Mode                 Group Id
----- ---------- -------------------- ----- ----- 
4/1  connected  desirable silent       200   865 
4/2  connected  desirable silent       200   865
----- ---------- -------------------- ----- -----

!--- Выходные данные команды подавлены.


cat5500 (enable) show port 4/2
Port  Name               Status     Vlan       Level  Duplex Speed Type
----- ------------------ ---------- ---------- ------ ------ ----- ------------ 
4/2                     connected  1          normal a-full a-100 10/100BaseTX

!--- Выходные данные команды подавлены.


Port  Status     Channel              Admin Ch                 
                 Mode                 Group Id
----- ---------- -------------------- ----- ----- 
4/1  connected  desirable silent       200   865 
4/2  connected  desirable silent       200   865
----- ---------- -------------------- ----- -----

!--- Выходные данные команды подавлены.

cat5500 (enable) show port channel info
Switch Frame Distribution Method: Mac both

Port  Status     Channel              Admin Channel Speed Duplex Vlan
                 mode                 group id
----- ---------- -------------------- ----- ------- ----- ------ ---- 
4/1  connected  desirable silent       200     865 a-100 a-full    1 
4/2  connected  desirable silent       200     865 a-100 a-full    1
----- ---------- -------------------- ----- ------- ----- ------ ----
 
Port  ifIndex Oper-group Neighbor   Oper-Distribution PortSecurity/
                         Oper-group Method            Dynamic port
----- ------- ---------- ---------- ----------------- ------------- 
4/1  334              1 65537      Mac both 
4/2  334              1 65537      Mac both
----- ------- ---------- ---------- ----------------- -------------
 
Port  Device-ID                       Port-ID                   Platform
----- ------------------------------- ------------------------- ---------------- 
4/1  Switch                          Fa6/1                     cisco Catalyst 6000 
4/2  Switch                          Fa6/2                     cisco Catalyst 6000
----- ------------------------------- ------------------------- ----------------

!--- Выходные данные команды подавлены.

Команды STP проверяют, все ли порты внутри канала объединены и находятся в состоянии пересылки.

cat5500 (enable) show spantree 1
VLAN 1
Spanning tree enabled
Spanning tree type          IEEE

Designated Root             00-30-40-a7-a4-00
Designated Root Priority    32768
Designated Root Cost        0
Designated Root Port        1/0
Root Max Age   20 sec    Hello Time 2  sec   Forward Delay 15 sec 

Bridge ID MAC ADDR          00-30-40-a7-a4-00
Bridge ID Priority          32768
Bridge Max Age 20 sec    Hello Time 2  sec   Forward Delay 15 sec
 
Port                     Vlan Port-State    Cost  Priority Portfast   Channel_id
------------------------ ---- ------------- ----- -------- ---------- ---------- 
2/1-2                   1    not-connected    19       32 disabled   0 
3/1                     1    not-connected   100       32 disabled   0 
3/2                     1    not-connected   100       32 disabled   0 
3/3                     1    not-connected   100       32 disabled   0 
3/4                     1    not-connected   100       32 disabled   0 
3/5                     1    not-connected   100       32 disabled   0 
3/6                     1    not-connected   100       32 disabled   0 
3/7                     1    not-connected   100       32 disabled   0 
3/8                     1    not-connected   100       32 disabled   0 
3/9                     1    not-connected   100       32 disabled   0 
3/10                    1    not-connected   100       32 disabled   0 
3/11                    1    not-connected   100       32 disabled   0 
3/12                    1    not-connected   100       32 disabled   0 
3/13                    1    not-connected   100       32 disabled   0 
3/14                    1    not-connected   100       32 disabled   0 
3/15                    1    not-connected   100       32 disabled   0 
3/16                    1    not-connected   100       32 disabled   0 
3/17                    1    not-connected   100       32 disabled   0 
3/18                    1    not-connected   100       32 disabled   0 
3/19                    1    not-connected   100       32 disabled   0 
3/20                    1    not-connected   100       32 disabled   0 
3/21                    1    not-connected   100       32 disabled   0 
3/22                    1    not-connected   100       32 disabled   0 
3/23                    1    not-connected   100       32 disabled   0 
3/24                    1    not-connected   100       32 disabled   0
4/1-2                   1    forwarding       12       32 disabled   865 
4/3                     1    forwarding       19       32 disabled   0 
4/4                     1    forwarding       19       32 disabled   0 
4/5                     1    not-connected   100       32 disabled   0 
4/6                     1    not-connected   100       32 disabled   0 
4/7                     1    not-connected   100       32 disabled   0 
4/8                     1    not-connected   100       32 disabled   0 
4/9                     1    not-connected   100       32 disabled   0 
4/10                    1    not-connected   100       32 disabled   0 
4/11                    1    not-connected   100       32 disabled   0 
4/12                    1    not-connected   100       32 disabled   0
cat5500 (enable)  
cat5500 (enable) show spantree 4/1
Port                     Vlan Port-State    Cost  Priority Portfast   Channel_id
------------------------ ---- ------------- ----- -------- ---------- ----------
4/1-2                    1    forwarding       12       32 disabled   865
cat5500 (enable) show spantree 4/2
Port                     Vlan Port-State    Cost  Priority Portfast   Channel_id
------------------------ ---- ------------- ----- -------- ---------- ----------
4/1-2                    1    forwarding       12       32 disabled   865
cat5500 (enable) 

Примечание. Выходные данные show spantree модуль/порт для портов 4/1 и 4/2 отображают одинаковые результаты. Это происходит потому, что они объединены в один канал, имеющий идентификатор (ID) 865.

Коммутатор Catalyst 6500

Эта команда проверяет, поддерживает ли данный модуль уплотнение канала.

Cat6509# show interfaces capabilities module 6  
FastEthernet6/1
  Model:                 WS-X6348-RJ-45
  Type:                  10/100BaseTX
  Speed:                 10,100,auto
  Duplex:                half,full
  Trunk encap. type:     802.1Q,ISL
  Trunk mode:            on,off,desirable,nonegotiate
  Channel:               yes
  Broadcast suppression: percentage(0-100)
  Flowcontrol:           rx-(off,on),tx-(none)
  Membership:            static
  Fast Start:            yes
  QOS scheduling:        rx-(1q4t), tx-(2q2t)
  CoS rewrite:           yes
  ToS rewrite:           yes
  Inline power:          yes
  SPAN:                  source/destination
  UDLD                   yes
  Link Debounce:         yes
  Link Debounce Time:    no
FastEthernet6/2
  Model:                 WS-X6348-RJ-45
  Type:                  10/100BaseTX
  Speed:                 10,100,auto
  Duplex:                half,full
  Trunk encap. type:     802.1Q,ISL
  Trunk mode:            on,off,desirable,nonegotiate
  Channel:               yes
  Broadcast suppression: percentage(0-100)
  Flowcontrol:           rx-(off,on),tx-(none)
  Membership:            static
  Fast Start:            yes
  QOS scheduling:        rx-(1q4t), tx-(2q2t)
  CoS rewrite:           yes
  ToS rewrite:           yes
  Inline power:          yes
  SPAN:                  source/destination
  UDLD                   yes
  Link Debounce:         yes
  Link Debounce Time:    no
  • show interfaces port-channel номер интерфейса порта-канала

Данная команда проверяет статус канала порта. Также эта команда сообщает, какие порты принадлежат данному каналу.

Cat6509# show interfaces port-channel 1
Port-channel1 is up, line protocol is up
  Hardware is EtherChannel, address is 0009.1267.27d9 (bia 0009.1267.27d9)
  MTU 1500 bytes, BW 200000 Kbit, DLY 100 usec,
     reliability 255/255, txload 1/255, rxload 1/255  
Encapsulation ARPA, loopback not set  
Full-duplex, 100Mb/s  
input flow-control is off, output flow-control is off  
Members in this channel: Fa6/1 Fa6/2  
ARP type: ARPA, ARP Timeout 04:00:00  
Last input never, output never, output hang never  
Last clearing of "show interface" counters never  
Input queue: 0/2000/0/0 (size/max/drops/flushes); Total output drops: 0  
Queueing strategy: fifo  
Output queue :0/40 (size/max)  
5 minute input rate 0 bits/sec, 0 packets/sec  
5 minute output rate 0 bits/sec, 0 packets/sec
     126880 packets input, 10173099 bytes, 0 no buffer
     Received 126758 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 input packets with dribble condition detected
     6101 packets output, 1175124 bytes, 0 underruns
     0 output errors, 0 collisions, 2 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier
     0 output buffer failures, 0 output buffers swapped out
Cat6509#

Данная команда отображает однострочную сводку по каждой группе каналов. В этом примере выходных данных показан флаг P для портов Fa6/1 и Fa6/2. Это означает, что данные порты находятся в канале порта.

Cat6509# show etherchannel summary
Flags: D - down P - in port-channel
I - stand-alone s - suspended
H - Hot-standby (LACP only)
R - Layer3 S - Layer2
U - in use f - failed to allocate aggregator

u - unsuitable for bundling
Number of channel-groups in use: 1
Number of aggregators: 1

Group Port-channel Protocol Ports
--------- +-----------------------+ ----------------+ ---------------
1 Po1(SU) PAgP Fa6/1(P) Fa6/2(P)

Эта команда отображает данные канала порта.

Cat6509# show etherchannel port-channel


Channel-group listing:
-----------------------

Group: 1
----------
Port-channels in the group:
----------------------

Port-channel: Po1
------------

Age of the Port-channel = 00d:00h:02m:25s
Logical slot/port = 14/1 Number of ports = 2
GC = 0x00010001 HotStandBy port = null
Port state = Port-channel Ag-Inuse
Protocol = PAgP

Ports in the Port-channel:

Index Load Port EC state No of bits
------+------+------+------------------+-----------
1 55 Fa6/1 Desirable-Sl 4
0 AA Fa6/2 Desirable-Sl 4

Time since last port bundled: 00d:00h:01m:03s Fa6/1
Time since last port Un-bundled: 00d:00h:01m:05s Fa6/1

Данная команда проверяет, находится ли канал в состоянии пересылки для отдельной сети VLAN.

Cat6509# show spanning-tree detail

VLAN1 is executing the IEEE compatible Spanning Tree protocol
  Bridge Identifier has priority 32768, address 00d0.029a.8001
  Configured hello time 2, max age 20, forward delay 15
  Current root has priority 32768, address 0030.40a7.a400
  Root port is 833 (Port-channel1), cost of root path is 12
  Topology change flag not set, detected flag not set
  Number of topology changes 0 last change occurred 00:23:59 ago
  Times:  hold 1, topology change 35, notification 2
          hello 2, max age 20, forward delay 15
  Timers: hello 0, topology change 0, notification 0, aging 300

Port 833 (Port-channel1) of VLAN1 is forwarding
   Port path cost 12, Port priority 128, Port Identifier 131.65.
   Designated root has priority 32768, address 0030.40a7.a400
   Designated bridge has priority 32768, address 0030.40a7.a400
   Designated port id is 131.97, designated path cost 0
   Timers: message age 2, forward delay 0, hold 0
   Number of transitions to forwarding state: 1
   BPDU: sent 1, received 718 

Данная команда отображает сведения STP для сети VLAN1.

Cat6509# show spanning-tree vlan 1

VLAN0001
Spanning tree enabled protocol ieee
Root ID Priority 32768
Address 0030.40a7.a400
Cost 12
Port 833 (Port-channel1)
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

Bridge ID Priority 32768
Address 00d0.029a.8001
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Aging Time 300

Interface Role Sts Cost Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Po1 Root FWD 12 128.833 P2p

Специальные рекомендации по использованию безусловного режима канала.

Для настройки канала порта Cisco рекомендует использовать протокол PAgP, так как описано в данном документе. Если по каким-либо причинам настройка канала EtherChannel производится безусловно (при помощи команды channel mode on), необходимо создать канал порта. В данном разделе приведена процедура создания. Создание канала порта позволит избежать возможных проблем с STP в течение процесса настройки. Обнаружение петель STP может отключить порты, если настроить одну сторону как канал прежде, чем другая сторона станет каналом.

  1. Настройка портов на уплотнение канала порта для отключения режима на коммутаторе CatOS производится с помощью команды set port disable модуль/порт.

  2. Создайте канал порта (группу портов) на коммутаторе Cisco IOS и установите режим канала в значение "on".

  3. Создайте канал порта на коммутаторе CatOS и установите режим канала в значение "on".

  4. Для включения портов на первом коммутаторе CatOS, которые ранее были выключены, выполните команду set port enable модуль/порт

Поиск и устранение неполадок

Проблемы производительности каналов EtherChannel

Проблемы, связанные с производительностью каналов EtherChannel, вызваны несколькими факторами. Самые распространенные причины – это неправильный механизм балансирования нагрузки и неисправность портов на физическом уровне.

Чтобы лучше понять и настроить механизм балансирования нагрузки, см. следующие документы:

Дополнительные сведения об устранении неполадок, связанных с портами на физическом уровне, см. в документе Устранение неисправностей портов и интерфейсов коммутатора.

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения


Document ID: 12029