Программное обеспечение Cisco IOS и NX-OS : программное обеспечение Cisco IOS версии 12.0 - специальные и тестовые развёртывания

Настройка однопортовых и двухпортовых плат интерфейса T1/E1 Multiflex Voice/WAN на маршрутизаторах Cisco 2600 Series Routers и Cisco 3600 Series Routers

7 апреля 2008 - Перевод, выполненный профессиональным переводчиком
Другие версии: PDF-версия:pdf | Английский (17 ноября 1999) | Отзыв

Содержание

Настройка однопортовых и двухпортовых плат интерфейса T1/E1 Multiflex Voice/WAN на маршрутизаторах Cisco 2600 Series Routers и Cisco 3600 Series Routers

Обзор функций

Поддерживаемые платформы

Поддерживаемые стандарты, MIB и RFC

Предварительные условия

Задачи настройки

Настройка голосовой платы и настройки контроллера
Проверка голосовой платы и настройки контроллера
Настройка последовательных интерфейсов
Проверка конфигурации последовательных интерфейсов
Настройка голосовых портов
Проверка голосовых портов
Настройка голосовых одноранговых телефонных соединений
Проверка голосовых одноранговых телефонных соединений

Примеры конфигураций

Справочник по командам

Глоссарий

Настройка однопортовых и двухпортовых плат интерфейса T1/E1 Multiflex Voice/WAN на маршрутизаторах Cisco 2600 Series Routers и Cisco 3600 Series Routers

В этом документе описана настройка однопортовых и двухпортовых плат интерфейса T1/E1 Multiflex Voice/WAN на маршрутизаторах Cisco 2600 Series Routers и Cisco 3600 Series Routers; он содержит следующие разделы:

Обзор функций

Платы интерфейса Cisco T1/E1 Multiflex Voice/WAN (VWIC) поддерживают голосовые приложения и приложения передачи данных в маршрутизаторах Cisco 2600 Series Routers и Cisco 3600 Series Routers. Платы VWIC обеспечивают функциональность платы интерфейса WAN (WIC) и платы голосового интерфейса (VIC) в различных приложениях для предприятий и для поставщиков услуг, которые поставляют абонентское оконечное оборудование.


Рис. 1. Приложения T1/E1 Multiflex VWIC, порты VWIC, назначенные офисным АТС и центральным телефонным узлам (без подключения к WAN).


Платы Multiflex VWIC поддерживают следующие приложения.

  • Передача данных. Как и WIC для приложений T1/E1, включая использование дробных каналов, в версии T1 интегрирован полностью управляемый модуль обработки данных/модуль обслуживания канала (DSU/CSU), а версия E1 включает полностью управляемый модуль DSU.

  • Передача речевых пакетов. Поскольку в состав модуля Digital T1 Packet Voice Trunk Network Module для обеспечения подключений по линии T1 к офисным АТС и центральным телефонным узлам входят платы VIC, платы T1 VWIC позволяют использовать приложения передачи речевых пакетов по протоколу IP (VoIP).

  • Мультиплексирование потоков голоса и данных. Двухпортовые платы T1/E1 VWICs могут обеспечивать мультиплексирование удаления и вставки благодаря наличию интегрированных модулей DSU/CSU. Например, при использовании модуля Digital T1 Packet Voice Trunk Network Module удаление и вставка позволяют получить каналы DS0 (64 Кб) из одного канала T1 и осуществить их цифровую кросс-коммутацию с каналами DS0 (64 Кб) другого канала T1. Удаление и вставка, иногда называемая кросс-коммутацией с мультиплексированием с разделением по времени (TDM), использует коммутацию каналов и не использует цифровые процессоры сигналов (DSP), которые применяются в технологии VoIP.

Доступны следующие платы Multiflex VWIC:

  • 1-портовая плата T1 Multiflex Trunk Interface (VWIC-1MFT-T1)

  • 1-портовая плата E1 Multiflex Trunk Interface (VWIC-1MFT-E1)

  • 2-портовая плата T1 Multiflex Trunk Interface (VWIC-2MFT-T1)

  • 2-портовая плата E1 Multiflex Trunk Interface (VWIC-2MFT-E1)

  • 2-портовая плата T1 Multiflex Trunk Interface с удалением и вставкой (VWIC-2MFT-T1-DI)

  • 2-портовая плата E1 Multiflex Trunk Interface с удалением и вставкой (VWIC-2MFT-E1-DI)

В число функций Multiflex VWIC входят:

  • Возможности удаления и вставки, которые позволяют использовать отдельные каналы DS0 (64 Кб) для прозрачной передачи информации без сжатия между двумя портами одной платы Multiflex VWIC, не используя процессор цифровых сигналов (DSP):

    • При использовании этого метода трафик канала идет между офисной АТС и центральной станцией (CO) или другим телефонным оборудованием.

    • Кроме того, удаление и вставка делают возможной кросс-коммутацию телефонного коммутатора (от СО или PSTN) с банком каналов, позволяя создать внешнее аналоговое подключение.


Примечание. Каналы T1/E1 можно использовать или для удаления и вставки, или для VoIP, но не для обоих режимов.
  • Функция пересылки аварийных сигналов физического уровня между двумя портами двухпортовых карт

  • Сетевые интерфейсы T1/E1 или дробные T1/E1

  • Скорости передачи данных 64 Кбит/с или 56 Кбит/с на канал T1/E1 для служб WAN (Frame Relay или выделенная линия)

В таблице 1 представлены возможные конфигурации аппаратных средств для Multiflex VWIC.


Таблица 1. Поддержка Multiflex VWIC.
VWIC и приложение Маршрутизаторы Cisco 2600 Series Routers Платформы Cisco 3620 и 3640 Cisco 3660

с 1 портом

Только данные

T1 или E1 VWIC в гнезде шасси

T1 или E1 VWIC в 1- или 2-портовом сетевом модуле (NM-1E2W, NM-2E2W, NM-1E1R2W)

Планируется выпуск

с 2 портами

Только данные

T1 или E1 VWIC в гнезде шасси. Не обеспечивает пакетную передачу голосовых данных. Может обеспечивать два физических WAN-подключений с участием обоих портов и поддержкой полной и дробной скорости T1/E1.

Планируется выпуск

Планируется выпуск

с 2 портами

Удаление и вставка

T1 или E1 D&I VWIC в гнезде шасси. Не обеспечивает пакетную передачу голосовых данных. Обеспечивает WAN-подключения и цифровую кросс-коммутацию.

T1 D&I VWIC в сетевом модуле Digital T1 Packet Voice Trunk Network Module. Обеспечивает голосовые соединения и цифровую кросс-коммутацию. Не обеспечивает WAN-подключения.

T1 или E1 D&I VWIC в 1- или 2-портовом сетевом модуле (NM-1E2W, NM-2E2W, NM-1E1R2W). Обеспечивает WAN-подключения и цифровую кросс-коммутацию.

T1 D&I VWIC в сетевом модуле Digital T1 Packet Voice Trunk Network Module. Обеспечивает голосовые соединения и цифровую кросс-коммутацию. Не обеспечивает WAN-подключения.

с 1 или 2 портами

Только голос, без WAN-подключений

T1 VWIC в сетевом модуле Digital T1 Packet Voice Trunk Network Module

T1 VWIC в сетевом модуле Digital T1 Packet Voice Trunk Network Module

T1 VWIC в сетевом модуле Digital T1 Packet Voice Trunk Network Module



Преимущества

Использование плат T1/E1 Multiflex VWIC снижает стоимость жизненного цикла сетевого оборудования следующими методами.

  • Обеспечивается эффективный переход от приложений только для передачи данных к мультиплексным приложениям работы с данными, голосом и голосовыми пакетами.

  • Упрощается развертывание и управление по сравнению со специализированными интерфейсами.

Платы T1/E1 Multiflex VWIC обеспечивают следующие преимущества мультфункциональной поддержки для маршрутизации между сетями LAN-to-LAN, мультиплексирования потоков голоса и данных и передачи голосовых данных:

  • исключается использование дорогостоящих модулей CSU или DSU;

  • исключается необходимость в мультиплексорах удаления и вставки;

  • упрощается удаленное управление сетью благодаря использованию одного средства управления, например CiscoView или CiscoWorks, для поддержки маршрутизатора, обеспечения функций CSU/DSU и мультиплексора удаления и вставки;

  • увеличивается плотность портов T1/E1, поддерживаемая на маршрутизаторах Cisco 2600 Series Routers, разрешается два подключения T1/E1 на одно гнездо WIC.

Ограничения

К конфигурациям T1/E1 Multiflex VWIC применяются следующие ограничения.

  • На платформах Cisco 3660 платы Multiflex VWICs поддерживаются, только тогда, когда они установлены в сетевой модуль Digital T1 Packet Voice Trunk Network Module.

  • На всех платформах Cisco 2600 и 3600 сетевые модули Digital T1 Packet Voice Trunk Network Modules поддерживают только платы T1 Multiflex VWIC.

  • Платы E1 VWICs не поддерживаются на платформах Cisco 3660.

  • Комбинация сетевых модулей Cisco 3620 и 3640 допускает установку 1-портовой VWIC или 2-портовой Drop-and-Insert VWIC.

  • Возможность удаления и вставки поддерживается только между двумя портами одной платы.

  • При установке в гнездо шасси Cisco 2600 ресурсы DSP для пакетной передачи голосовых данных для плат Multiflex VWIC с удалением и вставкой недоступны.

Сводную информацию см. в таблице 1.

Связанные функции и технологии

Для работы сетевых модулей Digital T1 Packet Voice Trunk Network Modules требуется 2-портовая плата T1 Multiflex VWIC. Дополнительные сведения об этих модулях см. в разделе Настройка сетевых модулей Digital T1 Packet Voice Trunk Network на маршрутизаторах Cisco 2600 Series Routers и Cisco 3600 Series Routers.

Сопутствующая документация

Дополнительную информацию по установке и настройке плат T1/E1 Multiflex VWIC см. в следующих документах:

Следующие документы для ПО Cisco IOS выпуск 12.0 содержат сведения, которые могут помочь при использовании плат T1/E1 Multiflex VWIC:

  • Руководство по конфигурации голосовых, видео и домашних приложений

  • Справочник по командам голосовых, видео и домашних приложений

  • Руководство по конфигурации сетевых протоколов, часть 1

  • Руководство по конфигурации интерфейса Cisco IOS

  • Справочник по командам интерфейса Cisco IOS

  • Руководство по конфигурации решений для коммутируемых линий связи

Поддерживаемые платформы

Данная функция поддерживается на следующих платформах:

  • Cisco 2610

  • Cisco 2611

  • Cisco 2612

  • Cisco 2613

  • Cisco 2620

  • Cisco 2621

  • Cisco 3620

  • Cisco 3640

  • Cisco 3661

  • Cisco 3662

Поддерживаемые стандарты, MIB и RFC

T1/E1 Multiflex VWIC поддерживают стандарты, MIB и RFC, перечисленные в данном разделе.

Соответствие T1 (неполный перечень)
  • ANSI T1.403

  • США (UL 1950, T1)

  • FCC, часть 68

  • CS-03

  • Канада (CSA 950, T1)

  • США (FCC часть 15 класс B, T1)

  • Великобритания (BS6301, EN60950, EN41003)

  • Канада (CSA C108.8 класс A, T1)

  • Bellcore---AT&T Accunet (62411)

  • ATT 54016

  • Япония (VCCI класс 2, VCCI:V-3/97.04, T1, JATE Green Book, IEC950)

Соответствие Е1 (неполный перечень)
  • Австралия (TS 016, AS/NZS 3548:1995)

  • Германия (TUV GS, EN60950)

  • Германия (VDE 0878 часть 3 и 30)

  • Франция (NFC98020, EN60950, EN41003)

  • Швеция (SS447-2-22, SS636334, EN60950)

  • Великобритания (NTR4)

  • Европа (EN55022 класс B, EN55102-1, EN55102-2, CTR12, EN60950, EN50082-1:1992, EN55022:1994)

  • CCITT/ITU G.704, I.431

  • ETSI NET5, ETS300156

  • TBR4

  • CTR-13

  • ETS 300011

  • ITU I.431

RFC

RFC 1406

MIB
  • T1 CSU MIB

Другие стандарты
  • ANSI T1.40

  • AT&T публикация 62411

Предварительные условия

Платы T1/E1 Multiflex VWIC требуют особых услуг, программного и аппаратного обеспечения:


Примечание. В маршрутизатор Cisco 2600 Series Routers и Cisco 3600 Series Routers может быть установлен один сетевой модуль Digital T1 Packet Voice Trunk Network Module. Маршрутизатор Cisco 3640 может поддерживать три модуля, а в маршрутизатор Cisco 3660 можно установить шесть модулей.
  • Установите платы Multiflex VWIC T1 или E1 в соответствии с инструкциями, содержащимися в Руководстве по установке плат интерфейса глобальной сети (WIC) Cisco 2600 Series Routers и Cisco 3600 Series Routers.

  • Если с сетевым модулем Digital T1 Packet Voice Trunk Network Module используется режим удаления и вставки, установите хотя бы один другой сетевой модуль или плату интерфейса WAN, чтобы обеспечить подключение к IP LAN или WAN.

  • Установите рабочую IP-сеть. Дополнительные сведения о настройке IP см. в главах "Обзор технологии IP," "Настройка адресации IP" и "Настройка служб IP" в Руководстве по настройке сетевых протоколов, часть 1, ПО Cisco IOS выпуск 12.0.

  • Выполните план телефонных соединений компании.

  • Установите работающую телефонную сеть на основе плана телефонных соединений компании.

Руководство по конфигурации голосовых, видео и домашних приложений и Справочник по командам голосовых, видео и домашних приложений для ПО Cisco IOS выпуск 12.0 содержат сведения о настройке сетей передачи голосовых данных.

Задачи настройки

Настройка T1/E1 Multiflex VWIC предполагает выполнение следующих задач.

  • Настройка плат обработки голосовых данных (только голос) и контроллеров T1/E1.

  • Настройка последовательных интерфейсов и интерфейсов LAN.

  • Настройка голосовых портов (голосовые услуги применимы только к платам T1 Multiflex VWIC, установленным в сетевой модуль Digital T1 Packet Voice Trunk Network Module).

  • Настройка одноранговых телефонных соединений (голосовые услуги применимы только к платам T1 Multiflex VWIC, установленным в сетевые модули Digital T1 Packet Voice Trunk Network Module).

Подробные сведения о настройке T1 Multiflex VWIC, установленной в сетевой модуль Digital T1 Packet Voice Trunk Network Module, см. в разделе Настройка сетевых модулей Digital T1 Packet Voice Trunk Network Modules на маршрутизаторах Cisco 2600 Series Routers и Cisco 3600 Series Routers.

Настройка голосовой платы и настройки контроллера

Данный раздел включает следующие темы:

  • Настройка голосовых плат и групп DS0, только для плат T1 Multiflex VWIC, установленных в сетевые модули Digital T1 Packet Voice Trunk Network Modules, когда требуются голосовые сервисы

  • Настройка контроллеров T1 или E1

  • Настройка удаления и вставки для T1 или E1

Настройка голосовых плат и групп DS0

Для настройки плат T1 Multiflex VWIC, установленных в сетевые модули Digital T1 Packet Voice Trunk Network Modules, для обработки голосовых данных выполните перечисленные ниже шаги. Повторите шаги 2 и 3 для каждой голосовой платы.

Шаг Команда Назначение
1 .  


Router# configure terminal

Войдите в режим глобальных настроек.

2 .


Router(config)# voice-card slot

Войдите в режим настройки интерфейса голосовой платы и укажите расположение гнезда, используя значение от 0 до 5, в зависимости от маршрутизатора.

3 .


Router(config-voice-ca)# codec complexity {high |
medium}

Укажите сложность кодека, учитывая используемый стандарт кодеков. Кодеки высокой сложности поддерживают меньшую частоту вызовов, чем кодеки средней сложности. Поддерживаемое количество каналов зависит от числа установленных модулей пакетной передачи голосовых данных (PVDM) и сложности кодека. Воспользуйтесь следующими указанием.

  • В режиме кодека высокой сложности можно выполнить до шести голосовых или факсовых вызовов на PVDM-12 с использованием следующих кодеков: G.711, G.726, G.729, G.729 Annex B, G.723.1, G.723.1 Annex A, G.728 и ретрансляции факсимильных данных (fax relay).

  • В режиме кодека средней сложности можно выполнить до двенадцати голосовых или факсовых вызовов на PVDM-12 с использованием следующих кодеков: G.711, G.726, G.729 Annex A, G.729 Annex B with Annex A и ретрансляции факсимильных данных (fax relay)

Для всех голосовых плат в маршрутизаторе следует использовать одинаковую настройку сложности кодеков.

Ключевое слово, указанное для команды codec complexity влияет на имеющиеся кодеки при использовании команды голосовой конфигурации codec наборного узла с равными правами. См. шаг 7 в разделе "Настройка голосовых одноранговых телефонных соединений".

Пока определены группы DS0, изменить сложность кодека нельзя. Если они уже настроены, используйте команду no ds0-group, прежде чем переустанавливать сложность кодеков. Для получения дополнительных сведений о команде ds0-group см. шаг 5.

4 .  


Router(config)# controller T1 slot/port

Войдите в режим конфигурации контроллера для платы VWIC. Ключевое слово slot может принимать значения от 0 до 5, ключевое слово port - 0 и 1.

5 .


Router(config-controller)# ds0-group ds0-group-no
timeslots timeslot-list type {e&m-immediate |
e&m-delay |e&m-wink | fxs-ground-start |
fxs-loop-start | fxo-ground-start | fxo-loop-start}

(Только для голоса.) Эта команда определяет каналы T1 для использования сжатыми голосовыми вызовами, а также определение метода сигнализации, используемого маршрутизатором для подключения к офисной АТС или центральной станции. Установите группы DS0 после указания сложности кодека в конфигурации голосовой платы в соответствии с шагом 3. Если изменяются параметры команды codec complexity, следует сначала удалить все имеющиеся группы DS0, а затем восстановить их после изменения сложности кодеков.

ds0-group-no - значение от 0 до 23, определяющее группу DS0.

Примечание. Команда ds0-group автоматически создает логический голосовой порт, пронумерованный следующим образом: slot/port:ds0-group-no. Хотя создается только один голосовой порт, соответствующие вызовы маршрутизируются в любой канал в группе.

Аргумент timeslot-list - простое число, несколько чисел, разделенных запятыми, или пара чисел, разделенных дефисом, которые определяют диапазон временных интервалов. Для T1 разрешены значения от 1 до 24. Для отображения отдельных временных интервалов DS0 определите дополнительные группы. Система отображает дополнительные голосовые порты для каждой определенной группы. См. шаг 2 в разделе "Настройка голосовых портов".

Выбор метода сигнализации для ключевого слова type зависит от выполняемого соединения.

  • Интерфейс E&M позволяет подключать магистральные (соединительные) линии офисной АТС и телефонное оборудование. Настройки мигания и задержки определяют подтверждающие сигналы между передающим и принимающими концами, тогда как настройка немедленной сигнализации не предусматривает специальных сигналов занятой/мвободной линии.

  • Интерфейс FXO предназначен для подключения центральной станции к интерфейсу стандартной офисной АТС, если это разрешено местными правилами; он часто используется для дистанционных расширений.

  • Интерфейс FXS позволяет подключать основное телефонное оборудование и офисные АТС.



Настройка контроллеров T1 и E1

Для настройки контроллеров T1 и E1 выполните следующую процедуру. Пропустите шаги 1 и 2, если уже включен режим настройки контроллера.

Повторите шаги, следующие за шагом 2, для каждого контроллера.

1 .  


Router# configure terminal

Пропустите этот шаг, если уже включен режим настройки контроллера.

Войдите в режим глобальных настроек.

2 .


Router(config)# controller {T1 | E1}slot/port
 

Пропустите этот шаг, если уже включен режим настройки контроллера.

Войдите в режим настройки контроллера T1 или E1 для указанного местоположения slot/port.

3 .  


Router(config-controller)# loopback {diagnostic |
local {payload | line}|remote {iboc |esf {payload | line}}

(Необязательно, только для T1, проверка) Эта команда выполняет локальную кольцевую проверку линии или на уровне полезной нагрузки, или дистанционно по шлейфу. Подробнее см. Настройка сетевых модулей Digital T1 Packet Voice Trunk Network Modules на маршрутизаторах Cisco 2600 Series Routers и Cisco 3600 Series Routers.

4 .


Router(config-controller)# clock source {line
[primary] | internal}

Укажите источник синхронизации. Ключевое слово line указывает, что источником синхронизации служит активная линия, а не независимый генератор синхронизирующих импульсов. Эта настройка используется по умолчанию, обычно она более надежна. К выбору источника синхронизации применимы следующие правила.

  • При установке линейной сигнализации обоих портов без указания первичного источника порт 0 выступает в роли первичного, а порт 1 - в роли вторичного источника синхронизации по умолчанию.

  • Если же установлена линейная синхронизация обоих портов и один порт определен в качестве первичного источника синхронизации, другой порт по умолчанию является резервным или вторичным источником и синхронизируется по замкнутой системе.

  • Если один порт установлен как clock source line (линейный источник синхронизации) или clock source line primary (первичный линейный источник синхронизации), а другой - как clock source internal, (внутренний источник синхронизации), то внутренний порт восстанавливает часы по линейному порту, если последний включен. Если же этот порт не включен, внутренний порт генерирует свои собственные часы.

  • Если оба порта установлены как clock source internal, то имеется только один источник синхронизации - внутренний.

5 .  


Router(config-controller)# framing {sf | esf}

или

Router(config-controller)# framing {crc4 | no-crc4}
[australia]

Установите обычный (SuperFrame, SF) или расширенный (Extended SuperFrame, ESF) формат кадрирования, в соответствии с требованиями поставщика услуг.

Установите для кадрирования контроль с использованием циклического избыточного кода 4 (CRC4) или не-CRC4, в соответствии с требованиями поставщика услуг. Необязательное ключевое слово australia определяет австралийскую сертификацию уровня 1 (Australian Layer 1 Homologation) для кадрирования E1.

6 .  


Router(config-controller)# linecode {b8zs | ami | hdb3}
 

Установите линейное шифрование в соответствии с инструкциями поставщика услуг. Метод Bipolar-8 zero substitution (B8ZS), доступный только для линий T1, кодирует последовательность из восьми нулей в уникальную бинарную последовательность для выявления нарушений линейного кодирования.

Кодирование с чередованием полярности битовых элементов (Alternate mark inversion, AMI), доступный для линий T1 или E1, представляет нули, используя 01 в каждой битовой ячейке, а единицы - используя, наоборот, 11 или 00, в каждом однобитовом элементе. Для метода AMI требуется, чтобы передающее устройство поддерживало плотность единиц. Плотность единиц не поддерживается независимо от потока данных.

Для E1 установите линейное кодирование AMI или высокоплотное биполярное кодирование третьего порядка (HDB3), используемое по умолчанию.

7 .  


Router(config-controller)# line-termination {75-ohm |
120-ohm}

(Только для E1) Введите значение для конечное устройство линии. Эта команда указывает импеданс для оконечного устройства Е1. Уровни импеданса поддерживаются, чтобы исключить повреждение данных в каналах дальней связи.

Укажите 120-ohm для соответствия сбалансированному 120-омному интерфейсу. Это значение используется по умолчанию.

Значение 75-ohm используется для несбалансированного 75-омного интерфейса BNC.

8 .  


Router(config-if)# fdl {att | ansi | both}

(Только интерфейсы T1) Эта команда задает стандарт канала обмена данными Facility Data Link (FDL) для контроллеров CSU. FDL - это канал с пропускной способностью 4 Кбит/с, который используется с расширенным форматом кодирования (ESF) в целях внеполосного обмена сообщениями для проверки ошибок на канале T1.

Обычно рекомендуется оставлять значение по умолчанию (ansi), которое соответствует стандарту ANSI T1.403 для поддержки каналов обмена данными с расширенным кодированием. Изменение этого значения в некоторых случаях делает возможным улучшение управления, но может вызвать проблемы, если настройки несовместимы с настройками поставщика услуг.

Значение att выбирает стандарт AT&T TR54016 для поддержки каналов обмена данными с расширенным кодированием.

Значение both разрешает оба указанных стандарта.

9 .  


Router(config-controller)# cablelength long {gain26 |
gain36} {-15db | -22.5db | -7.5db | 0db}

или

cablelength short {133 | 266 | 399 | 533 | 655}

(Только интерфейсы T1) Настройка длины кабеля должна соответствовать фактической длине используемого кабеля. Например, при попытке ввести команду cablelength short для канала T1 дальней связи эта команда будет отклонена.

Чтобы задать длину кабеля больше 200 метров (655 футов) для канала T1 введите команду cablelength long.

  • gain26 указывает усиление импульсов 26 децибел. Это значение усиления импульсов используется по умолчанию.

  • gain36 указывает усиление импульсов 36 децибел.

  • -15db указывает коэффициент для импульсов -15 децибел.

  • -22,5db указывает коэффициент для импульсов -22,5 децибел.

  • -7,5db указывает коэффициент для импульсов -7,5 децибел.

  • 0db указывает коэффициент для импульсов 0 децибел. Это значение коэффициента импульсов используется по умолчанию.

Чтобы задать длину кабеля 200 метров (655 футов) и менее для канала T1 введите команду cablelength short. Для cablelength short нет значения по умолчанию:

  • 133 определяет длину кабеля 0-133 футов (0-45 м).

  • 266 определяет длину кабеля 134-266 футов (40,8-81 м).

  • 399 определяет длину кабеля 267-399 футов (81,4-121,6 м).

  • 533 определяет длину кабеля 400-533 футов (121,9-162,5 м).

  • 655 определяет длину кабеля 534-655 футов (162,7-200 м).

Если длина кабеля пользователем не задана, система по умолчанию использует настройку cablelength long gain26 0db.



Настройка удаления и вставки

Если производится настройка удаления и вставки, выполните описанные в этом разделе действия. Если настройка не производится, перейдите к разделу "Настройка последовательных интерфейсов".

1 .


Router(config-controller)# tdm-group tdm-group-no
timeslots timeslot-list type [e&m | fxs [loop-start |
ground-start] fxo [loop-start | ground-start]

Введите эту команду для настройки групп каналов TDM для функции удаления и вставки для 2-портовой платы Multiflex VWIC.

tdm-group-no - это значение от 0 до 23 для T1 и от 0 до 30 для E1; оно определяет группу.

Аргумент timeslot-list - простое число, несколько чисел, разделенных запятыми, или пара чисел, разделенных дефисом, которые определяют диапазон временных интервалов. Допустимый диапазон от 1 до 24 для T1. Для E1 этот диапазон от 1 до 31.

Выбор метода сигнализации для ключевого слова type зависит от выполняемого соединения. Параметры fxs и fxo позволяют указать линии с сигнализацией с заземлением и с сигнализацией по шлейфу. Справочник команд Cisco IOS выпуск 12.0 Справочник по командам голоса, видео и факса содержит дополнительные сведения об этих параметрах.

Примечание. Номера групп контроллера должны быть уникальными. Например, группа TDM не должна иметь тот же идентификационный номер, что и группа DS0 или группа каналов.
2 .  


Router(config-controller)# channel-group
channel-group-no timeslots timeslot-list [speed
[48|56|64]]

(Необязательно) Введите эту команду, чтобы настроить группы каналов для служб передачи данных WAN для 2-портовой платы Multiflex Drop-and-Insert VWIC.

channel-group-no - это значение от 0 до 23 для T1 и от 0 до 30 для E1; поскольку на 1- или 2-портовой плате Multiflex VWIC может быть только одна группа каналов, это значение всегда 0.

timeslot-list - простое число, несколько чисел, разделенных запятыми, или пара чисел, разделенных дефисом, которые определяют диапазон временных интервалов. Допустимый диапазон от 1 до 24 для T1. Для E1 этот диапазон от 1 до 31.

В качестве необязательного параметра настройки speed по умолчанию используется 56 Кбит/с для Т1 и 64 Кбит/с для Е1.

Примечание. Хотя в интерфейсе командной строки отображается значение 48, как параметр скорости, это значение не поддерживается.
3 .


Router(config-controller)# no shutdown

Активируйте контроллер.

4 .


Router(config-controller)# exit

Выйдите из режима настройки контроллера. Если удаление и вставка не настраивается, пропустите следующий шаг.

5 .


Router(config)# connect id {T1 | E1} slot/port-1
tdm-group-no-1
{T1 | E1} slot/port-2 tdm-group-no-2

Эта команда глобальной настройки задает соединение между группами TDM временных интервалов T1 или E1 на плате WVIC---для удаления и вставки.

id - это имя соединения.

Идентифицируйте каждый контроллер по расположению slot/port.

tdm-group-no-1 иtdm-group-no-2 определяют номера групп TDM (от 0 до 23 или 30) на указанном контроллере. Эти группы были настроены в шаге 1.

Пример конфигураций удаления и вставки см. в разделе "Примеры конфигураций".



Проверка настроек голосовой платы и контроллера

Шаг 1 Введите команду show running-config, чтобы просмотреть текущую настройку голосовой платы. Если сложность кодека не отображается, по умолчанию настроена средняя сложность. В следующем примере показана часть выходных данных команды:

Router# show running-config
.
.
hostname router-alpha 
 
voice-card 1
 codec complexity high 
.
.
.

Шаг 2 Команда привилегированного выполнения show controllers t1/e1 выводит статус контроллеров T1 или E1 и сведения об источниках синхронизации и других настройках портов.

Router# show controller T1 1/0
 
T1 1/0 is up.
  Applique type is Channelized T1
  Cablelength is short 133
  Description: T1 WIC card Alpha
  No alarms detected.
  Framing is ESF, Line Code is B8ZS, Clock Source is Line Primary.
  Data in current interval (1 seconds elapsed):
     0 Line Code Violations, 0 Path Code Violations
     0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins
     0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs  
 

Шаг 3 Команда привилегированного выполнения show connection all command выводит статус групп TDM контроллеров T1 или E1 и их настройку.

Router# show connection all
 
ID   Name               Segment 1            Segment 2           State
========================================================================
1    Test              -T1 1/0 01           -T1 1/1 02           ADMIN UP

Настройка последовательных интерфейсов

Способ настройки последовательных и LAN-интерфейсов зависит от приложения. В данном документе не рассматриваются все возможные параметры настройки последовательных интерфейсов и не описана настройка LAN-интерфейсов. Полностью эту информацию см. в Руководстве по настройке интерфейса Cisco IOS и в Справочнике по командам интерфейса Cisco IOS для ПО Cisco IOS выпуск 12.0.

Если планируется поддержка голоса, перейдите к разделу "Примеры конфигураций".

Для конфигурации VoIP следует как минимум настроить IP-адреса для последовательных интерфейсов. Когда пользователь наберет достаточно цифр, чтобы они совпали с настроенным шаблоном назначения, номер телефона сопоставляется IP-хосту программой сопоставления плана соединений. IP-хост имеет прямое подключение или к набираемому номеру телефона, или к офисной АТС, которая выполняет вызов настроенного шаблона назначения.


Примечание. Сведения о контроле последовательных интерфейсов для переключения состояния занятости голосового порта при отключенном интерфейсе см. в разделе "Настройка голосовых портов".
Шаг Команда Назначение
1 .  


Router# configure terminal

Войдите в режим глобальных настроек.

2 .


Router(config)# interface serial
slot/port:channel-group

Войдите в режим настройки последовательного интерфейса, который указан по гнезду и порту. Часть команды :channel-group требуется только для интерфейсов Т1 или Е1 с разделением каналов; она всегда имеет значение 0 для поддержки Multiflex VWIC. (Сведения о настройке интерфейсов с разделением каналов см. в Руководстве по конфигурации решений для коммутируемых линий связи для ПО Cisco IOS выпуск 12.0.)

3 .  


Router(config-if)# ip address ip-address mask

Назначьте интерфейсу IP-адрес и маску подсети.


Проверка конфигурации последовательных интерфейсов

Чтобы проверить конфигурации последовательных интерфейсов, введите команду привилегированного выполнения show interfaces serial, которая показывает статус всех последовательных интерфейсов или конкретного последовательного интерфейса, как в следующем примере. Эту команду можно использовать для проверки инкапсуляции, IP-адресации и других настроек:

Router #show interface serial0/0:0
Serial0/0:0 is up, line protocol is up 
  Hardware is QUICC Serial
  Internet address is 1.156.1.1/24
  MTU 1500 bytes, BW 1536 Kbit, DLY 20000 usec, 
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation HDLC, loopback not set
  Keepalive not set
  Last input 00:00:00, output 00:00:00, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0 (size/max/drops); Total output drops: 0
  Queueing strategy: weighted fair
  Output queue: 0/1000/64/0 (size/max total/threshold/drops) 
     Conversations  0/1/256 (active/max active/max total)
     Reserved Conversations 0/0 (allocated/max allocated)
  5 minute input rate 1000 bits/sec, 1 packets/sec
  5 minute output rate 1000 bits/sec, 1 packets/sec
     637 packets input, 64736 bytes, 0 no buffer
     Received 181 broadcasts, 0 runts, 5 giants, 0 throttles
     3617 input errors, 1506 CRC, 1646 frame, 0 overrun, 0 ignored, 0 abort
     682 packets output, 67213 bytes, 0 underruns
     0 output errors, 0 collisions, 1070 interface resets
     0 output buffer failures, 0 output buffers swapped out
     13 carrier transitions
     Timeslot(s) Used:1-24, Transmitter delay is 0 flags

Настройка голосовых портов

Чтобы настроить голосовые порты для поддержки местных и удаленных станций, выполните следующие действия. Эта процедура применима только к платам T1 Multiflex VWIC, установленным в сетевые модули Digital T1 Packet Voice Trunk Network Modules, когда требуются голосовые сервисы.

В этом разделе рассматриваются не все команды, которые можно использовать. Дополнительные сведения см. в документах Руководство по конфигурации голосовых, видео и домашних приложений и Справочник по командам голосовых, видео и домашних приложений для ПО Cisco IOS выпуск 12.0.

Шаг Команда Назначение
1 .  


Router# configure terminal

Войдите в режим глобальных настроек.

2 .


Router(config)# voice-port slot/port:ds0-group-no

Войдите в режим настройки голосового порта.

slot - это гнездо в маршрутизаторе, в которое установлен голосовой модуль. Допускаются значения от 0 до 3.

port указывает местонахождение платы Multiflex VWIC. Допускаются значения 0 и 1.

Каждый определенный номер группы DS0 представлен представлен на отдельном голосовом порту. Это позволяет определять отдельные DS0 на цифровой плате T1. Для получения дополнительных сведений о группах DS0 см. шаг 5 в разделе "Настройка голосовой платы и настройки контроллера".

Примечание. Синтаксис команды voice-port неприменим к аналоговым голосовым модулям и платам голосового интерфейса. Укажите платы голосового интерфейса, используя slot/subunit/port, назначающий гнездо маршрутизатора сетевому модулю передачи голоса, расположение платы голосового интерфейса в сетевом модуле и порт установки платы голосового интерфейса.
3 .  


Router(config-voice-port)# busyout monitor interface
interface number

(Необязательно) Эта команда позволяет указать интерфейс LAN или WAN, который будет контролироваться, и, в случае неполадок, инициировать состояние занятости на голосовом порте. Это позволяет перенаправлять вызовы. Например, если указать в качестве интерфейса и номера Serial 1/0 (Последовательный 1/10), голосовой порт посылает сигнал занятости, когда интерфейс отключен. Эту команду можно выполнять несколько раз, чтобы указать требуемое число интерфейсов, виртуальных интерфейсов и субинтерфейсов для голосового порта.

Например, если подать эту команду три раза, чтобы контролировались три интерфейса, голосовой порт перейдет в состояние занятости, только когда будут отключены все три интерфейса. Когда любой из этих интерфейсов находится в рабочем состоянии, состояние занятости удаляется.

4 .  


Router(config-voice-port)# comfort-noise

(Необязательно) Этот параметр включен по умолчанию. Он создает слабый фоновый шум для заполнения зон молчания во время вызова, когда включена функция VAD для голосовых одноранговых телефонных соединений. Если не создавать комфортный шум, тишина может быть неприятна для звонящих.

5 .  


Router(config-voice-port)# echo-cancel enable

(Необязательно) Эта настройка включена по умолчанию. Эхоподавление повышает качество передачи голоса благодаря корректировке эха, возникающего в интерфейсе вследствие рассогласований импеданса. Небольшое эхо действует успокаивающе, эхо свыше 25 миллисекунд может вызвать проблемы.

6 .  


Router(config-voice-port)# echo-cancel coverage {16 |
24 |32 | 8}

(Необязательно) Эта команда корректирует эхоподавление на указанное количество миллисекунд, по умолчанию установлено 16.

7 .  


Router(config-voice-port)# connection {plar |trunk}
string

(Необязательно) Эта команда служит для настройки режима подключения для голосового порта.

plar определяет автоматический прямой вызов частной линии (private line automatic ring down, PLAR), который вызывает удаленный телефон, когда одноранговое соединение находится в состоянии "занято".

trunk определяет соединение по межсистемной линии связи с офисной АТС.

string определяет номер удаленного телефона или значимые начальные цифры этого номера.

Пример конфигураций подключений PLAR и магистрального подключения см. в разделе "Примеры конфигураций".

8 .  


Router(config-voice-port)# timeouts interdigit seconds

(Необязательно) Эта команда задает число секунд, в течение которого система после ввода абонентом начальной цифры ожидает следующей цифры набираемого номера. Если по истечении этого времени номер назначения не определяется, звучит сигнал и вызов завершается. По умолчанию это 10 секунд, можно установить время от 0 до 120 секунд.

Примечание.  Обычно изменение значения по умолчанию не требуется. Могут потребоваться другие настройки времени. Для получения дополнительных сведений см. Руководство по конфигурации голосовых, видео и домашних приложений для ПО Cisco IOS выпуск 12.0.
9 .


Router(config-voice-port)# exit

Выйдите из режима настройки голосового порта.

Повторите шаги 2 - 9 для каждой создаваемой группы DS0.



Проверка голосовых портов

Для проверки настройки голосовых портов выполните следующую процедуру. Для получения дополнительных сведений см. Руководство по конфигурации голосовых, видео и домашних приложений для ПО Cisco IOS выпуск 12.0.

Важные выходные данные команды выделены полужирным шрифтом.

Чтобы проверить правильность настройки голосовых портов введите команду привилегированного выполнения show voice port slot/port:ds0-group. В следующем примере выходных данных команды объяснения приводятся после символов <<

cisco-router# show voice port 1/0:1
 
receEive and transMit Slot is 1, Sub-unit is 0, Port is 1  << voice-port 1/0:1
 Type of VoicePort is E&M
 Operation State is DORMANT
 Administrative State is UP
 No Interface Down Failure
 Description is not set
 Noise Regeneration is enabled
 Non Linear Processing is enabled
 Music On Hold Threshold is Set to -38 dBm
 In Gain is Set to 0 dB
 Out Attenuation is Set to 0 dB
 Echo Cancellation is enabled
 Echo Cancel Coverage is set to 8 ms
 Connection Mode is normal
 Connection Number is not set
 Initial Time Out is set to 10 s
 Interdigit Time Out is set to 10 s
 Region Tone is set for US

Настройка голосовых одноранговых телефонных соединений

Чтобы настроить голосовые одноранговые телефонные соединения для поддержки местных и удаленных станций, выполните следующие действия. Эта процедура применима только к платам T1 Multiflex VWIC, установленным в сетевые модули Digital T1 Packet Voice Trunk Network Modules, когда требуются голосовые сервисы.

В этом разделе рассматриваются не все команды, которые может потребоваться ввести. Дополнительные сведения см. в документах Руководство по конфигурации голосовых, видео и домашних приложений и Справочник по командам голосовых, видео и домашних приложений для ПО Cisco IOS выпуск 12.0.

Шаг Команда Назначение
1 .  


Router# configure terminal

Войдите в режим глобальных настроек.

2 .  


Router(config)# dial-peer voice number pots

Войдите в режим настройки одноранговых телефонных соединений и определите локальную адресуемую точку вызова, которая будет подключаться к обычной телефонной сети (POTS).

number - это одна или несколько цифр, определяющих адресуемую точку вызова. Допускаются значения от 1 до 2147483647.

pots указывает узел с равными правами, использующий основное телефонное оборудование.

3 .


Router(config-dialpeer)# destination-patternstring
[T]

Настройте шаблон назначения однорангового телефонного соединения, чтобы система могла сопоставить набранные цифры с номером телефона.

string - это набор цифр, который определяет номер телефона E.164 или плана вызова частной линии. Допустимые значения - цифры от 0 до 9 и буквы A - D. Использование знака "плюс" (+) не допускается. Можно ввести следующие специальные символы.

  • Символ звездочки (*), который имеется на стандартных клавиатурах кнопочного набора и может быть любой цифровой строкой, но не начальным символом (например, *650).

  • Точка (.) служит символом подстановки.

  • Запятая (,) может использоваться только в префиксах и служит для вставки паузы длительностью одна секунда.

Когда в конце шаблона назначения стоит символ таймера (T), система запоминает набранные цифры по мере их набора, пока не будет превышено время ожидания между цифрами (по умолчанию 10 секунд) или пользователь не нажмет клавишу окончания набора (по умолчанию это #).

Примечание.  В качестве символа таймера используется прописная T.
4 .  


Router(config-dialpeer)# prefix string

(Необязательно) введите набираемый префикс, который автоматически вводит система, а не пользователь.

string - это значение от 0 до 9, можно использовать запятую (,) для указания паузы.

Примечание.  Имеются другие команды управления цифрами для использования, например, в качестве префиксов для специальных служб, пропуска отдельных цифр и набора на удаленных офисных АТС, как если бы они были местными.
5 .  


Router(config-dialpeer)# port slot/port:ds0-group-no

Эта команда связывает адресуемую точку вызова с конкретным логическим интерфейсом.

slot - это положение в маршрутизаторе, где установлен голосовой модуль. Допускаются значения от 0 до 3.

port - указывает местонахождение платы голосового интерфейса. Допускаются значения 0 и 1.

Каждый определенный номер группы DS0 представлен на отдельном голосовом порту. Это позволяет определять отдельные DS0 на цифровой плате T1.

6 .  


Router(config)# dial-peer voice number voip

Войдите в режим настройки однорангового телефонного соединения и определите удаленную VoIP-адресуемую точку вызова.

number - это одна или несколько цифр, определяющих адресуемую точку вызова. Допускаются значения от 1 до 2147483647.

voip определяет VoIP-адресуемую точку вызова, использующую инкапсуляцию в IP-сети.

7 .


Router(config-dialpeer)# codec {g711alaw | g711ulaw |
g723ar53 | g723ar63 | g723r53 | g723r63 | g726r16 |
g726r24 | g726r32 | g728 | g729r8 [pre-ietf] | g729br8}
[bytes]

Команда настройки голосовой платы codec complexity задает параметры кодека, которые доступны при вводе этой команды (см. шаг 3 в разделе "Настройка голосовой платы и настройки контроллера").

Если сложность кодека не задана, используется g729r8 с упорядочиванием битов IETF.

Если установить высокую сложность кодека (high), доступны следующие варианты:

  • g711alaw---G.711 A Law 64 Кбит/с

  • g711ulaw---G.711 u Law 64 Кбит/с

  • g723ar53---G.723.1 Annex A 5,3 Кбит/с

  • g723ar63---G.723.1 Annex A 6,3 Кбит/с

  • g723r53---G.723.1 5,3 Кбит/с

  • g723r63---G.723.1 6,3 Кбит/с

  • g726r16---G.726 16 Кбит/с

  • g726r24---G.726 24 Кбит/с

  • g726r32---G.726 32 Кбит/с

  • g728---G.728 16 Кбит/с

  • g729r8---G.729 8 Кбит/с (по умолчанию)

  • g729br8---G.729 Annex B 8 Кбит/с

Если установить среднюю сложность кодека, доступны следующие варианты:

  • g711alaw---G.711 A Law 64 Кбит/с

  • g711ulaw---G.711 u Law 64 Кбит/с

  • g726r16---G.726 16 Кбит/с

  • g726r24---G.726 24 Кбит/с

  • g726r32---G.726 32 Кбит/с

  • g729r8---G.729 Annex А 8 Кбит/с

  • g729br8---G.729 Annex B with Annex A 8 Кбит/с

Необязательный параметр bytes задает число байт голосовых данных на кадр. Допустимы значения от 10 до 240 с шагом 10 (например, 10, 20, 30 и т.д.). Любые другие значения округляются вниз (например, 236 до 230).

Если указано g729r8, то используется упорядочивание битов Internet Engineering Task Force (IETF). Для совместимости с маршрутизаторами Cisco 2600, 3600 или AS5300 под управлением ПО Cisco IOS более раннего выпуска, чем 12.0(5)T или 12.0(4)XH, необходимо ввести дополнительное ключевое слово pre-ietf после g729r8.

8 .  


Router(config-dialpeer)# vad

(Необязательно) Эта настройка включена по умолчанию и активирует функцию опознавания активности речи (VAD). VAD позволяет системе уменьшить ненужные передачи голосовых данных, обусловленных неотфильтрованным фоновым шумом.

9 .  


Router(config-dialpeer)# dtmf-relay [cisco-rtp]
[h245-signal] [h245-alphanumeric]

(Необязательно) Двухтональные многочастотные сигналы (DTMF) соответствуют тональному сигналу, который звучит в ответ на нажатие клавиш клавиатуры телефона. Тональные сигналы DTMF сжимаются на одном конце вызова и извлекаются на другом конце.

Если используется кодек с узкой полосой пропускания, например G.729 или G.723, тональные сигналы могут звучать искаженно. Команда dtmf-relay передает тональные сигналы DTMF, генерируемые после установления внеполосного соединения с помощью метода, который передает сигналы с большей точностью, чем это возможно для внутриполосного соединения для большинства кодеков с узкой полосой пропускания. Без DTMF RELAY для вызовов, установленных с использованием кодеков с узкой полосой пропускания, могут наблюдаться проблемы с доступом к автоматизированным системам телефонных меню, например к голосовой почте и системам интерактивного речевого ответа (IVR).

Метод сигнализации поддерживается, только если его поддерживает удаленный конец, возможные варианты: собственный метод Cisco (cisco-rtp), стандарт H.323 (h245-alphanumeric) и стандарт H.323 с длительностью сигнала (h245-signal).

10 .  


Router(config-dialpeer)# fax-rate {2400 | 4800 | 7200
| 9600 | 12000 | 14400 | disable | voice}

(Необязательно) Укажите скорость передачи, с которой в эту адресуемую точку вызова может быть отправлен факс. Значение disable отключает возможность передачи факса, а voice определяет максимально возможную скорость передачи факса, поддерживаемую частотой голосового сигнала.

11 .  


Router(config-dialpeer)# destination-patternstring
[T]

См. шаг 3 в этой процедуре.

12 .  


Router(config-dialpeer)# session target
{ipv4:destination-address | dns:[$s$. | $d$. | $e$. |
$u$.] host-name}

Настройте назначение сеанса IP для адресуемой точки вызова.

ipv4:destination-address определяет IP-адрес для адресуемой точки вызова.

dns:host-name указывает, что сервер доменных имен будет разрешать имя IP-адреса. Допустимыми значениями для этого параметра являются символы, представляющие имя хост-устройства.

Также можно использовать подстановочные символы для определения доменных имен с помощью ключевого слова с использованием в имени хоста сведений об источнике, назначении и соединении.

Полностью сведения о синтаксисе команды см. в документе Справочник по командам голосовых, видео и домашних приложений для ПО Cisco IOS выпуск 12.0.



Проверка голосовых одноранговых телефонных соединений

Для проверки настройки голосовых одноранговых телефонных соединений выполните следующую процедуру. Дополнительные сведения об этих командах см. в документе Справочник по командам голосовых, видео и домашних приложений для ПО Cisco IOS выпуск 12.0.

Важные выходные данные команды выделены полужирным шрифтом.

Введите команду привилегированного выполнения show dial-peer voice. Ниже приведен текст примера выходных данных команды для однорангового соединения обычной телефонной сети.

router# show dial-peer voice 1
VoiceEncapPeer1
        tag = 1, dest-pat = \Q+14085551000',
        answer-address = \Q',
        group = 0, Admin state is up, Operation state is down
        Permission is Both,
        type = pots, prefix = \Q',
        session-target = \Q', voice-port =
        Connect Time = 0, Charged Units = 0
        Successful Calls = 0, Failed Calls = 0
        Accepted Calls = 0, Refused Calls = 0
        Last Disconnect Cause is "10"
        Last Disconnect Text is ""
        Last Setup Time = 0 
 

Ниже приведен текст примера выходных данных команды show dial-peer voice для однорангового VoIP-узла.

Router# show dial-peer voice 10
VoiceOverIpPeer10
        tag = 10, dest-pat = \Q',
        incall-number = \Q+14087',
        group = 0, Admin state is up, Operation state is down
        Permission is Answer, 
        type = voip, session-target = \Q',
        sess-proto = cisco, req-qos = bestEffort, 
        acc-qos = bestEffort, 
        fax-rate = voice, codec = g729r8,
        Expect factor = 10,Icpif = 30, VAD = disabled, Poor QOV Trap = disabled, 
        Connect Time = 0, Charged Units = 0
        Successful Calls = 0, Failed Calls = 0
        Accepted Calls = 0, Refused Calls = 0
        Last Disconnect Cause is "10"
        Last Disconnect Text is ""
        Last Setup Time = 0

Примеры конфигураций

В этом разделе представлены три примера конфигурации, иллюстрирующие различные сценарии.

  • Удаление и вставка, когда услуги PSTN и VoIP предоставляются по одной линии поставщика услуг.

  • Удаление и вставка, когда услуги PSTN и передачи данных предоставляются по одной линии поставщика услуг.

  • Удаление и вставка, когда услуги PSTN, передачи данных и VoIP предоставляются по одной линии поставщика услуг.


Примечание. Другие примеры см. в документах Настройка сетевых модулей Digital T1 Packet Voice Trunk Network Modules на маршрутизаторах Cisco 2600 Series Routers и Cisco 3600 Series Routers.

Технология удаления и вставки - это один из способов интеграции старых технологий PBX с VoIP. Она позволяет получать каналы DS0 64 Kб с одного канала T1 или E1 и осуществлять их цифровую коммутацию с каналами DS0 64 Kб другого канала T1 или E1.

Технология удаления и вставки позволяет использовать каналы DS0 для прозрачной передачи информации без сжатия между портами T1/E1, не используя обработку процессором цифровых сигналов (DSP). Трафик через канал идет между офисной АТС и центральной станцией (CO) или другим телефонным оборудованием, что позволяет, например, использовать некоторые каналы офисной АТС для междугородней связи через PSTN, в то время как маршрутизатор сжимает другие для межофисных соединений VoIP. Кроме того, удаление и вставка делает возможной кросс-коммутацию телефонного коммутатора (от СО или PSTN) с банком каналов для внешнего аналогового подключения.

Необходимо учитывать следующие спекты.

  • Удаление и вставка работает только между портами одной платы Multiflex VWIC.

  • Плата VWIC может быть установлена или в отдельное гнездо WIC маршрутизатора Cisco 2600 Series Routers, интегрированном в гнездо VWIC сетевого модуля Digital T1 Packet Voice Trunk Network Module, или в 2-портовый сетевой модуль (NM-1E2W, NM-2E2W, NM-1E1R2W) маршрутизатора Cisco 3600 Series Routers.

  • Когда модуль VWIC установлен в гнездо VWIC сетевого модуля Digital T1 Packet Voice Trunk Network Module, порты Т1 не обеспечивают подключение к WAN (например, Frame-Relay, PPP и т.д.) в дополнение к голосовому подключению и удалению и вставке.

  • Возможности подключения к WAN и удаления и вставки поддерживаются, когда плата VWIC устанавливается в гнездо WIC шасси маршрутизатора Cisco 2600 Series Routers.

Удаление и вставка с помощью служб VoIP и PSTN


Рис. 2. Удаление и вставка с помощью служб VoIP и PSTN.

В этом примере показана настройка удаления и вставки, когда 2-портовая плата Multiflex VWIC установлена в гнездо VWIC сетевого модуля Digital T1 Packet Voice Trunk Network Module и настроено соединение VoIP. Подключения к WAN должны предоставляться отдельными каналами.

hostname RTR-A
 
!
voice-card 1
  codec complexity high
!
controller T1 1/0
framing esf
linecoding b8zs
ds0-group 1 timeslots 1-12 type e&m-wink
tdm-group 2 timeslots 13-24 type e&m
!
controller T1 1/1
framing esf
linecoding b8zs
clock source line primary
tdm-group 3 timeslots 13-24 type e&m
!
voice-port 1/0:1
!
dial-peer voice 1 voip
destination-pattern 4...
codec g723r63
dtmf-relay h245-alpha
session target ipv4:209.165.200.253
session target ipv4:209.165.200.252
!
dial-peer voice 2 pots
destination-pattern 5...
prefix 5 
port 1/0:1
!
interface serial 0/0
encapsulation ppp
ip address 209.165.200.252 255.255.255.224
!
connect tdm1 T1 1/0 2 T1 1/1 3
hostname RTR-B
!
voice-card 1
  codec complexity high
!
controller T1 1/0
framing esf
linecoding b8zs
ds0-group 1 timeslots 1-12 type e&m-wink
tdm-group 2 timeslots 13-24 type e&m
!
controller T1 1/1
framing esf
linecoding b8zs
clock source line primary
tdm-group 3 timeslots 13-24 type e&m
!
voice-port 1/0:1
!
dial-peer voice 1 voip
destination-pattern 5.
codec g723r63
dtmf-relay h245-alpha
!
!
!
dial-peer voice 2 pots
destination-pattern 4.
prefix 4
port 1/0:1
!
interface serial 0/0
encapsulation ppp
ip address 209.165.200.253 255.255.255.224
!
connect tdm1 T1 1/0 2 T1 1/1 3 

Источники синхронизации

В этом примере для каждого порта Multiflex VWIC маршрутизатора доступны два источника синхронизации: один из офисной АТС и один из центрального узла PSTN. Однако источник синхронизации должен быть одним и тем же, поэтому система настраивается в соответствии с этим требованием.

Ключевое слово primary команды clock source, примененной к T1 1/1, означает, что источник синхронизации предоставляется PSTN. Порт T1 1/0, соединенный с офисной АТС, автоматически переводится в режим looped-time, что означает, что порт получает сигнал синхронизации на свою пару Rx (прием) и посылает его назад на пару Tx (передача). Во время приема сигнала синхронизации он не включает встроенный источник синхронизации. Он "обманывает" порт, так что соединенный с офисной АТС порт не определяет несинхронизированный сигнал, на что указывают ошибки. Маршрутизатор определяет ошибки как контролируемые, и не переводит порт в состояние сбоя.

Дополнительные замечания

Рекомендуется учесть следующие ключевые моменты.

  • Команда tdm-group 2 timeslots 13-24 type e&amp;m определяет удаление и вставку путем настройки временных интервалов с каждого канала Т1, которые будут использоваться в цифровой кросс-коммутации. Ключевое слово type не является обязательным, но его использование характерно для функции удаления и вставки.

    • Если включить ключевое слово type в тип сигнала, кросс-коммутация удаления и вставки обеспечивает прохождение указанного сигнала ("свободно" и "занято") между каналами DS0. Здесь также используются сигнальные биты для передачи сигнала "занято", если не работает один из каналов Т1.

    • Если ключевое слово type не используется, кросс-коммутация удаления и вставки является чистым каналом и не интерпретирует никакую сигнализацию.

  • Команда connect tdm1 T1 1/0 2 T1 1/1 3 активирует кросс-коммутацию удаления и вставки между каналами Т1. Часть команды tdm1 является просто именем кросс-коммутации, этим именем может быть слово, число или последовательность букв.

  • Для проверки соединений удаления и вставки можно воспользоваться командой show connection.

Удаление и вставка с помощью служб передачи данных и PSTN


Рис. 3. Удаление и вставка с помощью служб передачи данных и PSTN.


В этом примере показана настройка удаления и вставки, когда 2-портовая плата Multiflex VWIC установлена в гнездо шасси маршрутизатора VWIC Cisco 2600 или гнездо WIC сетевого модуля маршрутизатора Cisco 3600 Series Routers. Данные Frame Relay и голосовые вызовы PSTN передаются между офисными АТС, но информация VoIP или VoIP через Frame Relay не передается.

Источники синхронизации

Как и в предыдущем примере для каждого порта Multiflex VWIC маршрутизатора доступны два источника синхронизации: один из офисной АТС и один из центрального узла PSTN. Однако источник синхронизации должен быть одним и тем же, поэтому система настраивается в соответствии с этим требованием.

Первичным источником синхронизации является канал T1 или E1 1/0, подключенный к PSTN, и его сигнал является опорным для канала T1 или E1 1/1. В случае отказа T1 1/0 источник синхронизации для T1 или E1 1/1 генерируется с линии на офисную АТС.

Дополнительные замечания

Команда channel-group 0 настроена таким образом, чтобы поставщик услуг мог отправить сведения об управлении каналом (LMI) Frame-Relay на каналы T1 13 - 24 (17 - 31 на E1) для служб передачи данных Frame-Relay. Эта команда автоматически создает последовательный интерфейс 1/0:0.

Последовательный интерфейс 1/0:0 - это то, где настраиваются все данные WAN и протокола 3 уровня, например инкапсуляция Frame Relay или IP-адреса.

Конфигурация T1

hostname RTR-A
 
!
controller T1 1/0
framing esf
linecoding b8zs
clock source line primary
tdm-group 1 timeslots 1-12 
channel-group 0 timeslots 13-24
!
controller T1 1/1
framing esf
linecoding b8zs
clock source line
tdm-group 2 timeslots 1-12
!
interface serial 1/0:0
encapsulation frame-relay
!
interface serial 1/0:1.1
ip address 209.165.200.252 255.255.255.224
frame-relay interface-dlci 100 br
!
interface ethernet 0
ip address 209.165.200.250 255.255.255.224
!
router eigrp 1
network 209.165.200.224
!
connect tdm1 T1 1/0 1 T1 1/1 2
hostname RTR-B
!
controller T1 1/0
framing esf
linecoding b8zs
clock source line primary
tdm-group 1 timeslots 1-12
channel-group 0 timeslots 13-24
!
controller T1 1/1
framing esf
linecoding b8zs
clock source line
tdm-group 2 timeslots 1-12
!
interface serial 1/0:0
encapsulation frame-relay
!
interface serial 1/0:1.1
ip address 209.165.200.253 255.255.255.224
frame-relay interface-dlci 100 br
!
interface ethernet 0
ip address 209.165.201.1 255.255.255.224
!
router eigrp 1
network 209.165.200.224
network 209.165.201.0
!
connect tdm1 T1 1/0 1 T1 1/1 2

Конфигурация E1

hostname RTR-A
 
!
controller E1 1/0
framing crc4
linecoding hdb3
clock source line primary
tdm-group 1 timeslots 1-15 
channel-group 0 timeslots 17-31
!
controller E1 1/1
framing crc4
linecoding hdb3
clock source line
tdm-group 2 timeslots 1-15
!
interface serial 1/0:0
encapsulation frame-relay
!
interface serial 1/0:1.1
ip address 209.165.200.252 255.255.255.224
frame-relay interface-dlci 100 br
!
interface ethernet 0
ip address 209.165.200.250 255.255.255.224
!
router eigrp 1
network 209.165.200.224
!
connect tdm1 T1 1/0 1 T1 1/1 2
 
hostname RTR-B
!
controller E1 1/0
framing crc4
linecoding hdb3
clock source line primary
tdm-group 1 timeslots 1-15
channel-group 0 timeslots 17-31
!
controller E1 1/1
framing crc4
linecoding hdb3
clock source line
tdm-group 2 timeslots 1-15
!
interface serial 1/0:0
encapsulation frame-relay
!
interface serial 1/0:1.1
ip address 209.165.200.253 255.255.255.224
frame-relay interface-dlci 100 br
!
interface ethernet 0
ip address 209.165.201.1 255.255.255.224
!
router eigrp 1
network 209.165.200.224
network 209.165.201.0
!
connect tdm1 T1 1/0 1 T1 1/1 2

Удаление и вставка с помощью служб PSTN, передачи данных и VoIP


Рис. 4. Пример конфигурации. Удаление и вставка с помощью служб PSTN, передачи данных и VoIP.


Эта конфигурация иллюстрирует использование некоторых каналов T1 для передачи голоса из PSTN в офисную АТС и некоторых каналов служб передачи данных, которые также пропускают трафик VoIP. Для этой настройки требуется сетевой модуль Digital T1 Packet Voice Trunk Network Module с установленной платой Multiflex VWIC и отдельной Multiflex VWIC.

Источники синхронизации

Первичным источником синхронизации является канал T1, и его сигнал является опорным для канала T1 1/1. При сбое T1 1/0 источник синхронизирующих импульсов для T1 1/1 генерируется внутренне.

hostname RTR-A
 
!
controller T1 1/0
description - NM-HDV connected to PBX
framing esf
linecoding b8zs
clock source internal 
tdm-group 1 timeslots 1-12 
ds0-group 2 timeslots 13-24 type e&m-wink
!
controller T1 1/1
description - xconnect to VWIC T1
framing esf
linecoding b8zs
clock source line
tdm-group 2 timeslots 1-12
!
controller T1 2/0
description - connected to TELCO WAN
framing esf
linecoding b8zs
channel-group 0 timeslots 13-24 
tdm-group 3 timeslots 1-12
clock source line
!
controller T1 2/1
description - xconnect to NM-HDV
framing esf
linecoding b8zs
clock source internal
tdm-group 4 timeslots 1-12
!
voice-port 1/0:2
!
interface serial 2/0:0
encapsulation frame-relay
!
interface serial 1/0:0.1
ip address 209.165.200.252 255.255.255.224
frame-relay interface-dlci 100 br
!
interface ethernet 0
ip address 209.165.200.250 255.255.255.224
!
router eigrp 1
network 209.165.200.224
!
dial-peer voice 1 voip
destination-pattern 5...
session target ipv4:209.165.200.253
!
dial-peer voice 2 pots
destination-pattern 4...
prefix 4
prefix 5
port 1/0:2
port 1/0:2
!
connect tdm1 T1 1/0 1 T1 1/1 2
connect tdm2 T1 2/0 3 T1 2/1 4
hostname RTR-B
!
controller T1 1/0
description -  NM-HDV connected to PBX
framing esf
linecoding b8zs
clock source internal
tdm-group 1 timeslots 1-12
!
controller T1 1/1
description - xconnect to VWIC T1
framing esf
linecoding b8zs
clock source line
tdm-group 2 timeslots 1-12
!
!
controller T1 2/0
description - connected to TELCO WAN
framing esf
linecoding b8zs
channel-group 0 timeslots 13-24
tdm-group 3 timeslots 1-12
clock source line
!
controller T1 2/1
description - xconnect NM-HDV
framing esf
linecoding b8zs
clock source internal
tdm-group 4 timeslots 1-12
!
voice-port 1/0:2
!
interface serial 2/0:0
encapsulation frame-relay
!
interface serial 1/0:0.1
ip address 209.165.200.253 255.255.255.0
frame-relay interface-dlci 100 br
!
interface ethernet 0
ip address 209.165.201.1 255.255.255.224
!
router eigrp 1
network 209.165.200.224
network 209.165.201.0
!
dial-peer voice 1 voip
destination-pattern 4...
session target ipv4:209.165.200.252
!
dial-peer voice 2 pots
destination-pattern 5...
!
connect tdm1 T1 1/0 1 T1 1/1 2
connect tdm2 T1 2/0 3 T1 2/1 4
 


Дополнительные замечания

Следующие подключения выполняются с использованием каналов 1-12 поставщика услуг:

  • Каналы подключаются к плате Multiflex VWIC, которая не установлена в сетевой модуль Digital T1 Packet Voice Trunk Network Module.

  • Эти 12 каналов кросс-коммутируются с другим портом Multiflex VWIC.

  • Оттуда внешний кабель с перекрестными проводниками T1 кросс-коммутирует каналы с первым портом T1 сетевого модуля Digital T1 Packet Voice Trunk Network Module.

  • 12 каналов кросс-коммутируют с другим портом T1 сетевого модуля Digital T1 Packet Voice Trunk Network Module и с подключенной офисной АТС.

Каналы 13 - 24 передают Frame-Relay LMI от поставщика услуг для служб передачи данных, и каналы оканчиваются на группе каналов Multiflex VWIC. Этот последовательный интерфейс используется для передачи данных из сети Ethernet, а также трафика VoIP, берущего свое начало на каналах 13 - 24 от офисной АТС, соединенной с сетевым модулем Digital T1 Packet Voice Trunk Network Module.

Справочник по командам

Новые или измененные команды содержатся в разделе справочника по командам Настройка сетевых модулей Digital T1 Packet Voice Trunk Network Modules на маршрутизаторах Cisco 2600 Series Routers и Cisco 3600 Series Routers. Все другие команды, используемые с этой функцией, задокументированы в справочниках по командам ПО Cisco IOS выпуск 12.0.

Глоссарий

AMI - кодирование с чередованием полярности битовых элементов (alternate mark inversion). Тип линейного кодирования, используемый в каналах T1 и E1. В AMI нули представляются значением 01 в каждой битовой ячейке, единицы представляются, наоборот, значениями 11 или 00 в каждой битовой ячейке. Для метода AMI требуется, чтобы передающее устройство поддерживало плотность единиц, которая не поддерживается независимо от потока данных. Иногда называется бинарным кодированием с чередованием полярности битовых элементов.

ATM - режим асинхронной передачи (Asynchronous Transfer Mode). Международным стандартом для сотовой ретрансляциис несколькими типами служб (голос, видео и данные) закреплен фиксированный (53 байта) размер ячеек, что позволяет оборудованию проводить обработку сотовыъ элементов, таким образом уменьшая задержки при передаче. Режим ATM предназначен для получения преимуществ высокоскоростной среды передачи данных, такой как E3, SONET и T3.

B8ZS - линейное кодирование с бинарной перестановкой 8 нулей (binary 8-zero substitution). Тип линейного кодирования, используемый в каналах T1 и E1, в котором при отправке по каналу последовательности из 8 нулей подставляется особый код. Затем этот код интерпретируется на удаленном конце соединения. Этот метод гарантирует, что плотность единиц не будет зависеть от потока данных.

CAS - передача сигналов, связанная с каналом. Магистральная сигнализация (например, на линии T1), в которой контрольные сигналы, например синхронизирующие и связывающие кадры, переносятся по одному каналу вместе с голосовыми сигналами и сигналами данных.

CCS - сигнализация по общему каналу (common channel signaling). Магистральная сигнализация (например, с использованием интерфейса основной скорости), в которой контрольный канал передает сигналы отдельно для голосового канала и канала данных.

CO - центральный узел (central office). Офис местной телефонной компании, в котором подключаются все абонентские шлейфы в данной области, и происходит коммутация абонентских линий.

codec - кодировщик-декодировщик (Coder-decoder). Устройство, которое обычно использует импульсно-кодовую модуляцию для преобразования аналоговых сигналов в цифровые, а цифровых сигналов – обратно в аналоговые.

DTMF - двухтональные многочастотные сигналы (Dual-tone multifrequency). Использование одновременно двух тональных сигналов голосовой частоты для набора номера (например, при кнопочном наборе).

Удаление и вставка - (также называется кросс-коммутация TDM) делает возможной цифровую кросс-коммутацию каналов DS0 от одного канала T1 или E1 с каналами DS0 другого канала T1 или E1. При использовании этого метода трафик идет между офисной АТС и коммутатором центральной станции PSTN, что позволяет, например, использовать некоторые каналы офисной АТС для междугородней связи через PSTN, в то время как маршрутизатор сжимает другие для межофисных соединений VoIP. Кроме того, удаление и вставка делает возможной кросс-коммутацию телефонного коммутатора (от СО или PSTN) с банком каналов для внешнего аналогового подключения.

DSP - процессор цифровых сигналов (digital signal processor).

E1 - используемая в Европе цифровая сеть, применяемая для передачи данных через усовершенсвованную телефонную иерархию. Скорость передачи в E1 равна 2,048 Мбит/с.

E&amp;M - rEceive and transMit или Ear and Mouth ("Прием и передача", или "Ухо и рот"). Тип передачи сигналом, изначально разработанный для аналоговой телефонии с использованием проводников для микрофона и наушника; в цифровой телефонии используется два бита.

ESF - расширенный суперкадр (Extended Superframe). Тип кадрирования, используемый в сетях T1, который состоит из 24 кадров по 192 бита каждый, 193-й бит отвечает за тайминг и другие функции. ESF является усовершенствованной версией формата SF.

FDL - канал обмена данными (Facility Data Link). Канал 4 Кбит/с, предоставляемый форматом кадрирования Т 1 Extended SuperFrame (ESF). FDL реализует внешнюю полезную нагрузку и позволяет поставщику услуг проверять статистику ошибок на оконечном оборудовании без вмешательства в его эксплуатацию.

FXO - служба междугородной телефонной связи (Foreign Exchange Office). Голосовой интерфейс, эмулирующий магистральную линию PSTN до коммутирующего или телефонного оборудования до интерфейса расширения офисной АТС.

FXS - станция междугородной телефонной связи (Foreign Exchange Station). Голосовой интерфейс для подключения телефонного оборудования; он эмулирует интерфейс расширения офисной АТС или интерфейс абонента для коммутатора.

HBD3 - высокоплотное биполярное кодирование третьего порядка (High-Density Bipolar 3). Тип линейного кодирования, используемый в каналах E1.

IETF - протокол Internet Engineering Task Force.

ISDN - цифровая сеть интегрированных служб (Integrated Services Digital Network). Предложенный телефонными компаниями коммуникационный протокол. ISDN позволяет передавать через телефонные сети данные, голос и другой исходный трафик.

пакет - логическая группа информации, которая содержит заголовок с контрольной информацией и (обычно) пользовательские данные. Пакеты чаще всего используются как название единиц данных сетевого уровня.

POTS - традиционная служба телефонной связи

PDVM - модуль пакета голосовых данных.

PSTN - телефонная сеть общего пользования (Public Switched Telephone Network). Общий термин, относящийся к различным телефонным сетям и услугам, используемым во всем мире.

QoS - качество обслуживания (quality of service). Мера производительности системы передачи, которая отражает качество передачи и доступность услуги.

SF - Super Frame. Обычный тип кадрирования, используемый в каналах E1. SF состоит из 12 кадров по 192 бита каждый, 193-й бит отвечает за проверку ошибок и другие функции. SF вытесняется ESF, но все еще широко используется. Также называется кадрированием D4.

SNMP – простой протокол управления сетью (Simple Network Management Protocol). Протокол управления сетью, используется почти исключительно в сетях TCP/IP. SNMP является средством контроля и управления сетевыми устройствами, управления конфигурациями, сбора статистики, управления производительностью и безопасностью.

T1 - цифровая сеть WAN (Digital WAN carrier facility). T1 передает данные в формате DS 1 со скоростью 1,544 Мбит/с через телефонные коммутируемые сети, используя кодирование с чередованием полярности битовых элементов или кодирование B8ZS.

Магистраль T1 - цифровая сеть WAN (Digital WAN carrier facility). См. T1.

TDM - мультиплексирование с разделением времени (time-division multiplexing).

Магистраль - физическое и логическое соединение между двумя коммутаторами, через которое проходит сетевой трафик. Опорная сеть состоит из ряда магистралей.

UNI - интерфейс пользователь-сеть (User-Network Interface). Спецификация ATM Forum, которая определяет стандарт совместимости интерфейса между продуктами на основе ATM (маршрутизатор или коммутатор ATM), расположенными в частной сети, и коммутаторами ATM, расположенными в общедоступных сетях. Также используется для описания аналогичных подключений в сетях Frame Relay.

VAD - функция определения активности речи (voice activity detection).