Коммутаторы : Коммутаторы Cisco Catalyst серии 6500

Пример конфигурации: изменение режима STP с PVST+ на Rapid-PVST

7 апреля 2008 - Перевод, выполненный профессиональным переводчиком
Другие версии: PDF-версия:pdf | Машинный перевод (28 июля 2013) | Английский (12 января 2007) | Отзыв

Содержание

Введение
Предварительные условия
     Требования
     Используемые компоненты
     Условные обозначения
Общие сведения
Настройка
     Схема сети
     Конфигурации
     Конфигурация PVST+
     UplinkFast и BackboneFast
     Миграция на Rapid-PVST+
     Выходные данные отладки — смешанный режим
     Выходные данные отладки — режим Rapid-PVST+
Проверка
Поиск и устранение неполадок
Связанные обсуждения сообщества поддержки Cisco
Дополнительные сведения

Введение

В этом документе представлен пример конфигурации для перевода режима STP с PVST+ на Rapid-PVST+ внутри кампусной сети. Кроме того, приводятся описания конфигурации PVST+, согласования нагрузки по протоколу STP и функций UplinkFast и BackboneFast.

Предварительные условия

Требования

Перед настройкой Rapid-PVST+ рекомендуется прочитать статью Общие сведения о протоколе RSTP (802.1w) .

В таблице приводятся сведения о поддержке протокола RSTP в коммутаторах Catalyst и минимальные версии ПО, необходимые для этой поддержки.

Платформа Catalyst

Rapid-PVST+

Catalyst 2900 XL / 3500 XL

Недоступно.

Catalyst 2940

12.1(20)EA2

Catalyst 2950/2955/3550

12.1(13)EA1

Catalyst 2970/3750

12.1(14)EA1

Catalyst 3560

12.1(19)EA1

Catalyst 3750 Metro

12.1(14)AX

Catalyst 2948G-L3/4908G-L3

Недоступно.

Catalyst 4000/2948G/2980G (CatOS)

7.5

Catalyst 4000/4500 (IOS)

12.1(19)EW

Catalyst 5000/5500

Недоступно.

Catalyst 6000/6500

7.5

Catalyst 6000/6500 (IOS)

12.1(13)E

Catalyst 8500

Недоступно.

Используемые компоненты

В этом документе приводятся сведения для ПО Cisco IOS® Release12.2(25) и CatOS 8.5(8). Однако конфигурацию можно использовать в минимальных версиях Cisco IOS, перечисленных в таблице.

Данные для документа были получены в специально созданных лабораторных условиях. Все устройства, используемые в этом документе, были запущены с чистой конфигурацией (конфигурацией по умолчанию). В рабочей сети необходимо изучить потенциальное воздействие всех команд.

Условные обозначения

Более подробную информацию о применяемых в документе обозначениях см. в документе Cisco Technical Tips Conventions (Условные обозначения, используемые в технической документации Cisco).

Общие сведения

Медленная конвергенция — серьезный недостаток протокола STP на базе 802.1D. Коммутаторы Cisco Catalyst поддерживают три типа протокола STP — PVST+, Rapid-PVST+ и MST. Протокол PVST+ основывается на стандарте IEEE802.1D и включает проприетарные расширения Cisco, такие как BackboneFast, UplinkFast и PortFast. Протокол Rapid-PVST+ основывается на стандарте IEEE 802.1w и обеспечивает более быструю конвергенцию, чем протоколы на базе 802.1D. RSTP (IEEE 802.1w) изначально включает большинство проприетарных усовершенствований Cisco для протокола STP на базе 802.1D, таких как BackboneFast и UplinkFast. Rapid-PVST+ поддерживает следующие уникальные функции:

  • Использует блок данных протокола моста (BPDU) версии 2, обратно совместимый с протоколом 802.1D STP, который использует BPDU 0.

  • Все коммутаторы генерируют BPDU и передают их из всех портов каждые 2 секунды, тогда как при использовании 802.1D STP конфигурационные блоки BPDU рассылаются только корневым мостом.

  • Роли портов — корневой порт, назначенный порт, альтернативный порт и резервный порт.

  • Состояния портов — отбрасывание, самообучение и пересылка.

  • Типы портов — пограничный порт (PortFast), "точка-точка" и общий порт.

Rapid-PVST использует протокол RSTP для быстрой конвергенции. Когда любой из портов RSTP получает старый блок BPDU протокола 802.1D, он переключается на старый протокол STP. При взаимодействии со старыми мостами преимущества быстрой конвергенции протокола 802.1w теряются.

Настройка

Этот пример состоит из двух разделов. В первом разделе приводится текущая конфигурация PVST+. Во втором разделе приводится конфигурация для миграции с PVST+ на Rapid-PVST+.

Примечание: Используйте инструмент CommandLookup Tool (registered customers only) для получения информации о командах, используемых в этом разделе.

Схема сети

В этом документе используется следующая конфигурация сети:

Схема включает коммутаторы:

  • Коммутаторы Distribution1 и Distribution2 на уровне распределения

  • Два коммутатора уровня доступа с именами Access1 (IOS) и Access2 (CatOS)

  • Два коммутатора для объединения потоков серверов Services1 и Services2

Сети VLAN 10, 30 и 100 для передачи трафика данных. Сети VLAN 20, 40 и 200 для передачи голосового трафика

rapidpvst-mig-config1.gif

Конфигурации

В этом документе используются следующие конфигурации:

Конфигурация PVST+

Коммутаторы настраиваются в PVST+ для переноса голоса и данных в соответствии со схемой сети. Ниже приводится краткая сводка конфигурации:

  • Коммутатор Distribution1 настроен в качестве основного корневого моста для сетей VLAN передачи данных 10, 30 и 100 с помощью команды Distribution1(config)# spanning-tree vlan 10,30,100 root primary и в качестве вспомогательного корневого моста для голосовых сетей VLAN 20, 40 и 200 с помощью команды Distribution1(config)# spanning-treevlan 20,40,200 root secondary .

  • Коммутатор Distribution2 настроен в качестве основного корневого моста для голосовых сетей VLAN 20, 40 и 200 с помощью команды Distribution2(config)# spanning-tree vlan 20,40,200 rootprimary и в качестве вспомогательного корневого моста для сетей VLAN передачи данных 10, 30 и 100 с помощью команды Distribution2(config)# spanning-tree vlan10,30,100 root secondary .

  • Команда spanning-tree backbonefast сконфигурирована на всех коммутаторах для ускоренной конвергенции STP в случае отказа обходного канала.

  • Команда spanning-tree uplinkfast сконфигурирована на коммутаторах уровня доступа для ускоренной конвергенции STP в случае отказа прямого канала.

Distribution1

Distribution1#show running-config 
 Building configuration...
spanning-tree mode pvst
spanning-tree extend system-id
spanning-tree backbonefast
spanning-tree vlan 10,30,100 priority 24576
spanning-tree vlan 20,40,200 priority 28672
!
vlan 10,20,30,40,100,200
!
interface FastEthernet1/0/1
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 10,20
!
interface FastEthernet1/0/3
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 30,40
!
interface FastEthernet1/0/5
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 100,200
!
interface FastEthernet1/0/23
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 10,20,30,40,100,200
!
interface FastEthernet1/0/24
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 10,20,30,40,100,200
!
 !
 end

Вы можете видеть, что порт Fa1/0/24 настроен с помощью команды spanning-tree vlan 20,40,200 port-priority 64 . Коммутатор Distribution2 настроен как корневой мост для сетей VLAN 20, 40 и 200. Коммутатор Distribution2 поддерживает два соединения с коммутатором Distribution1: Fa1/0/23 и Fa1/0/24. Оба порта являются назначенными для VLAN 20, 40 и 200, так как коммутатор Distribution2 является корневым для этих сетей VLAN. Оба порта имеют одинаковый приоритет 128 (по умолчанию). Кроме того, два соединения с коммутатором Distribution1 имеют одинаковую стоимость с точки зрения портов fa1/0/23 и fa1/0/24. Коммутатор Distribution1 выбирает порт с наименьшим номером и переводит его в состоянии пересылки. Наименьший номер — Fa1/0/23. Однако в соответствии со схемой сети трафик голосовых сетей VLAN 20 и 40, 200 должен проходить через Fa1/0/24. Этого можно добиться следующими способами:

  1. Уменьшить стоимость порта Fa1/0/24 на коммутаторе Distribution1

  2. Снизить приоритетность порта Fa1/0/24 на коммутаторе Distribution2

В примере для пересылки трафика сетей VLAN 20, 40 и 200 через fa1/0/24 снижена приоритетность этого порта.

Distribution2

Distribution2#show running-config 
 Building configuration...
!
spanning-tree mode pvst
spanning-tree extend system-id
spanning-tree backbonefast
spanning-tree vlan 10,30,100 priority 28672
spanning-tree vlan 20,40,200 priority 24576
!
vlan 10,20,30,40,100,200
!
interface FastEthernet1/0/2
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 10,20
!
interface FastEthernet1/0/4
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 30,40
!
interface FastEthernet1/0/6
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 100,200
!
interface FastEthernet1/0/23
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 10,20,30,40,100,200
!
interface FastEthernet1/0/24
 switchport trunk encapsulation dot1q
 switchport mode trunk
 spanning-tree vlan 20,40,200 port-priority 64
 switchport trunk allowed vlan 10,20,30,40,100,200

end

Можно видеть, что на порте Fa0/5 коммутатора Services1 и портах Fa0/6 и Fa0/48 коммутатора Services2 настроена стоимость и приоритетность порта по протоколу STP. В данном случае протокол STP настроен так, что трафик сетей VLAN 100 и 200 коммутаторов Services1 и Services2 может передаваться через магистральные каналы между ними. Если не применить эту конфигурацию, коммутаторы Services1 и Services2 не будут передавать трафик через соединяющие их магистральные каналы. Вместо этого будет выбран путь между коммутаторами Distribution1 и Distribution2.

Коммутатор Services2 видит два пути с равной стоимостью к корневому мосту сети VLAN 100 (Distribution1). Один через Services1, другой через Distribution2. Протокол STP выбирает лучший путь (корневой порт) в следующем порядке:

  1. Стоимость пути

  2. Идентификатор моста пересылающего коммутатора

  3. Порт с низшим приоритетом

  4. Внутренний порт с наименьшим номером

В этом примере два пути имеют одинаковую стоимость. Однако приоритет коммутатора Distribution2 (24576) ниже, чем приоритет коммутатора Services1 (32768) для данной сети VLAN. Поэтому коммутатор Services2 выбирает коммутатор Distribution2. В этом примере для стоимости порта fa0/5 коммутатора Services1 задано более низкое значение, чтобы позволить коммутатору Services2 выбрать коммутатор Services1. Стоимость пути переопределяет значение приоритета пересылающего коммутатора.

Services1

Services1#show running-config 
 Building configuration...
spanning-tree mode pvst
spanning-tree portfast bpduguard default
spanning-tree extend system-id
spanning-tree backbonefast
!
vlan 100,200
!
interface FastEthernet0/5
 switchport trunk encapsulation dot1q
 switchport mode trunk
 spanning-tree vlan 100 cost 18
 switchport trunk allowed vlan 100,200
!
interface FastEthernet0/47
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 100,200
!
interface FastEthernet0/48
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 100,200
!
!
 end

Аналогичный метод используется, чтобы позволить коммутатору Services1 выбрать коммутатор Services2 для пересылки трафика сети VLAN 200. После уменьшения стоимости сети VLAN 200 на интерфейсе fa0/6 коммутатора Services2 коммутатор Services1 выберет интерфейс fa0/47 для пересылки трафика сети VLAN 200. Однако в этом случае необходимо пересылать трафик сети VLAN200 через fa0/48. Этого можно добиться следующими способами:

  1. Уменьшить стоимость порта Fa0/48 на коммутаторе Services1

  2. Снизить приоритетность порта Fa0/48 на коммутаторе Services2

В примере для пересылки трафика сети VLAN 200 через fa0/48 снижена приоритетность этого порта.

Services2

Services2#show running-config 
 Building configuration...
spanning-tree mode pvst
spanning-tree portfast bpduguard default
spanning-tree extend system-id
spanning-tree backbonefast
!
vlan 100,200
!
interface FastEthernet0/6
 switchport trunk encapsulation dot1q
 switchport mode trunk
 spanning-tree vlan 200 cost 18
 switchport trunk allowed vlan 100,200
!
interface FastEthernet0/47
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 100,200
!
interface FastEthernet0/48
 switchport trunk encapsulation dot1q
 switchport mode trunk
 spanning-tree vlan 200 port-priority 64
 switchport trunk allowed vlan 100,200
!
 !
 end

Access1

Access1#show running-config 
 Building configuration...
!
spanning-tree mode pvst
spanning-tree portfast bpduguard default
spanning-tree extend system-id
spanning-tree uplinkfast
spanning-tree backbonefast
!
vlan 10,20
!
interface FastEthernet0/1
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 10,20
!
interface FastEthernet0/2
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 10,20
!
 end

Access2

Access2> (enable)show config all 

#mac address reduction
set spantree macreduction enable
!
#stp mode
set spantree mode pvst+
!
#uplinkfast groups
set spantree uplinkfast enable rate 15 all-protocols off
!
#backbonefast
set spantree backbonefast enable
!
#vlan parameters
set spantree priority 49152  1
set spantree priority 49152  30
set spantree priority 49152  40
!
#vlan(defaults)
set spantree enable  1,30,40
set spantree fwddelay 15     1,30,40
set spantree hello    2      1,30,40
set spantree maxage   20     1,30,40
!
#vtp
set vlan 1,30,40
!
#module 3 : 48-port 10/100BaseTX Ethernet
set trunk 3/3  on dot1q 30,40
set trunk 3/4  on dot1q 30,40
!
 end

UplinkFast и BackboneFast

Мы рекомендуем разобраться в принципе работы функций UplinkFast и BackboneFast перед началом миграции. На схеме сети коммутатор Access1 работает под управлением Cisco IOS. Эти выходные данные получены перед переходом на режим Rapid-PVST+:

Access1#show spanning-tree vlan 10

VLAN0010
  Spanning tree enabled protocol ieee
  Root ID    Priority    24586
             Address     0015.63f6.b700
             Cost        3019
             Port        107 (FastEthernet3/0/1)
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    49162  (priority 49152 sys-id-ext 10)
             Address     000f.f794.3d00
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time 300
  Uplinkfast enabled

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Fa3/0/1          Root FWD 3019      128.107  P2p
Fa3/0/2          Altn BLK 3019      128.108  P2p


Access1#show spanning-tree summary
Switch is in pvst mode
Root bridge for: none
Extended system ID           is enabled
Portfast Default             is disabled
PortFast BPDU Guard Default  is enabled
Portfast BPDU Filter Default is disabled
Loopguard Default            is disabled
EtherChannel misconfig guard is enabled
UplinkFast                   is enabled
BackboneFast                 is enabled
Configured Pathcost method used is short

Name                   Blocking Listening Learning Forwarding STP Active
---------------------- -------- --------- -------- ---------- ----------

VLAN0010                     1         0        0          1          2
VLAN0020                     1         0        0          1          2
---------------------- -------- --------- -------- ---------- ----------
2 vlans                      2         0        0          2          4

Эти выходные данные получены после перехода на режим Rapid-PVST+:

Access1#show spanning-tree vlan 10

VLAN0010
  Spanning tree enabled protocol rstp
  Root ID    Priority    24586
             Address     0015.63f6.b700
             Cost        3019
             Port        107 (FastEthernet3/0/1)
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    49162  (priority 49152 sys-id-ext 10)
             Address     000f.f794.3d00
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time 300
  UplinkFast enabled but inactive in rapid-pvst mode

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Fa3/0/1          Root FWD 3019      128.107  P2p
Fa3/0/2          Altn BLK 3019      128.108  P2p

Access1#show spanning-tree summary
Switch is in rapid-pvst mode
Root bridge for: none
Extended system ID           is enabled
Portfast Default             is disabled
PortFast BPDU Guard Default  is enabled
Portfast BPDU Filter Default is disabled
Loopguard Default            is disabled
EtherChannel misconfig guard is enabled
UplinkFast                   is enabled but inactive in rapid-pvst mode
BackboneFast                 is enabled but inactive in rapid-pvst mode
Configured Pathcost method used is short

Name                   Blocking Listening Learning Forwarding STP Active
---------------------- -------- --------- -------- ---------- ----------

VLAN0010                     1         0        0          1          2
VLAN0020                     1         0        0          1          2
---------------------- -------- --------- -------- ---------- ----------
2 vlans                      2         0        0          2          4

В выходных данных команды show spanning-tree summary вы можете видеть, что функции UplinkFast и BackboneFast включены, но неактивны в режиме Rapid-PVST. Вы можете удалить обе команды. Однако если команды останутся в конфигурации, это не повлияет на работу Rapid-PVST. Если вы отключите функцию UplinkFast с помощью команды режима конфигурации no spanning-tree uplinkfast , приоритет моста и стоимость порта вернутся к значениям по умолчанию. Рекомендуется назначать некорневым коммутаторам более высокое значение приоритета моста. Выходные данные ниже отображаются после отключения функции UplinkFast в режиме Rapid-PVST:

Access1#show spanning-tree vlan 10

VLAN0010
  Spanning tree enabled protocol rstp
  Root ID    Priority    24586
             Address     0015.63f6.b700
             Cost        19
             Port        107 (FastEthernet3/0/1)
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32778  (priority 32768 sys-id-ext 10)
             Address     000f.f794.3d00
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time 300

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Fa3/0/1          Root FWD 19        128.107  P2p
Fa3/0/2          Altn BLK 19        128.108  P2p

Access1#show spanning-tree summary
Switch is in rapid-pvst mode
Root bridge for: none
Extended system ID           is enabled
Portfast Default             is disabled
PortFast BPDU Guard Default  is enabled
Portfast BPDU Filter Default is disabled
Loopguard Default            is disabled
EtherChannel misconfig guard is enabled
UplinkFast                   is disabled
BackboneFast                 is enabled but inactive in rapid-pvst mode
Configured Pathcost method used is short

Name                   Blocking Listening Learning Forwarding STP Active
---------------------- -------- --------- -------- ---------- ----------

VLAN0010                     1         0        0          1          2
VLAN0020                     1         0        0          1          2
---------------------- -------- --------- -------- ---------- ----------
2 vlans                      2         0        0          2          4

CatOS не позволяет переходить в режим Rapid-PVST, если функция BackboneFast включена. Перед изменением режима необходимо отключить функцию BackboneFast. Функция UplinkFast работает так же, как в IOS.

Access2> (enable) set spantree mode rapid-pvst+
Cannot change the spantree mode to RAPID-PVST+ when backbonefast is enabled.

Миграция на Rapid-PVST+

Rapid-PVST+ использует тот же формат BPDU, что 802.1D и предлагает обратную совместимость. Одновременный перевод всех коммутаторов в корпоративной сети в режим Rapid-PVST+ — сложная задача. Обратная совместимость позволяет перевести их поэтапно. Рекомендуется вносить изменения во время запланированных окон обслуживания, так как изменение конфигурации протокола STP прерывает потоки трафика. Функции UplinkFast и BackboneFast протокола STP входят в состав PVST+. Они отключаются при активации режима Rapid-PVST+, так как являются встроенными функциями Rapid-PVST+. Поэтому вы можете отключить эти команды при изменении режима. Конфигурации таких функций, как PortFast, BPDUguard, BPDUfilter, Root guard и Loopguard, также применяются в режиме Rapid-PVST+. Использование этих функций будет таким же, как в режиме PVST+. Если вы уже включили эти функции в режиме PVST+, они останутся активными при переходе на режим Rapid-PVST+. В этом примере изменение режима выполняется в следующем порядке:

  1. Access1

  2. Access2

  3. Services1 и Services2

  4. Distribution1 и Distribution2

  1. Изменение режима Access1:

    Access1(config)#spanning-tree mode rapid-pvst
    Access1(config)#no spanning-tree uplinkfast
    Access1(config)#no spanning-tree backbonefast
    
    
    Access1#show spanning-tree vlan 10
    
    VLAN0010
      Spanning tree enabled protocol rstp
      Root ID    Priority    24586
                 Address     0015.63f6.b700
                 Cost        19
                 Port        107 (FastEthernet3/0/1)
                 Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
    
      Bridge ID  Priority    32778  (priority 32768 sys-id-ext 10)
                 Address     000f.f794.3d00
                 Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
                 Aging Time 300
    
    Interface        Role Sts Cost      Prio.Nbr Type
    ---------------- ---- --- --------- -------- --------------------------------
    Fa3/0/1          Root FWD 19        128.107  P2p Peer(STP)
    Fa3/0/2          Altn BLK 19        128.108  P2p Peer(STP)
    
    !--- Type P2p Peer(STP) represents that the neighbor switch runs PVST.
    
    
  2. Изменение режима Access2:

    Access2> (enable) set spantree backbonefast disable
    Backbonefast disabled for all VLANs.
    
    Access2> (enable) set spantree mode rapid-pvst+
    PVST+ database cleaned up.
    Spantree mode set to RAPID-PVST+.
    
    
    Access2> (enable) clear spantree uplinkfast
    This command will cause all portcosts, portvlancosts, and the
    bridge priority on all vlans to be set to default.
    Do you want to continue (y/n) [n]? y
    VLANs 1-4094 bridge priority set to 32768.
    The port cost of all bridge ports set to default value.
    The portvlancost of all bridge ports set to default value.
    uplinkfast all-protocols field set to off.
    uplinkfast disabled for bridge.
  3. Изменение режима Services1 и Services2:

    Services1(config)#spanning-tree mode rapid-pvst
    Services1(config)#no spanning-tree backbonefast
    
    Services2(config)#spanning-tree mode rapid-pvst
    Services2(config)#no spanning-tree backbonefast
    
  4. Изменение режима Distribution1 и Distribution2:

    Distribution1(config)#spanning-tree mode rapid-pvst
    2d02h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan10, changed state to
    up
    2d02h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan20, changed state to
    up
    2d02h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan30, changed state to
    up
    2d02h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan40, changed state to
    up
    2d02h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan100, changed state to
     up
    2d02h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan200, changed state to
     up
    2d02h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan40, changed state to
    down
    2d02h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan30, changed state to
    down
    2d02h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan40, changed state to
    up
    2d02h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan30, changed state to
    up
    !--- Distribution1 switch has Layer3 VLAN interfaces and it goes 
    !--- down and up during the conversion.
    
    
    Distribution1(config)#no spanning-tree backbonefast 
    
    Distribution2(config)#spanning-tree mode rapid-pvst
    
    2d02h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan1, changed state to
    own
    2d02h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan1, changed state to
    p
    2d02h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan10, changed state to
    up
    2d02h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan20, changed state to
    up
    2d02h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan30, changed state to
    up
    2d02h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan40, changed state to
    up
    2d02h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan100, changed state t
     up
    2d02h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan200, changed state t
     up
    2d02h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan30, changed state to
    down
    2d02h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan30, changed state to
    up
    !--- Distribution2 switch has Layer3 VLAN interfaces and it goes 
    !--- down and up during the conversion.
    
    
    Distribution2(config)#no spanning-tree backbonefast
    

Выходные данные отладки — смешанный режим

В крупных корпоративных сетях процесс перехода может занять несколько дней. Во время этого процесса можно использовать сеть VLAN в смешанном режиме, т. е. часть коммутаторов будут работать в режиме PVST+, а другая часть — в режиме rapid-PVST+. В смешанном режиме нельзя реализовать все преимущества Rapid-PVST+. Общее время конвергенции будет таким же, как в режиме PVST+. Чтобы воспользоваться всеми преимуществами Rapid-PVST+, необходимо перевести все коммутаторы в топологии STP на Rapid-PVST+ . В таблице ниже приводится пример выходных данных команды debug , демонстрирующий работу протокола STP в смешанном режиме. Коммутаторы Distribution1 и Distribution2 находятся в режиме PVST+, а коммутаторы Access1 — в режиме Rapid-PVST+.

Выходные данные команды debug spanning-tree демонстрируют работу протокола STP при отказе соединения между коммутаторами Access1 и Distribution1.

Access1

00:55:13: RSTP(10): updt roles, root port Fa0/1 going down
00:55:13: RSTP(10): Fa0/2 is now root port
00:55:13: RSTP(10): Fa0/2 received a tc ack
00:55:15: %LINK-5-CHANGED: Interface FastEthernet0/1, changed state to adminis
tratively down
00:55:16: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, cha
nged state to down

Distribution1

00:55:20: STP: VLAN0010 Topology Change rcvd on Fa1/0/23
00:55:20: STP: VLAN0020 sent Topology Change Notice on Fa1/0/24
00:55:21: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet1/0/1,
changed state to down
00:55:22: %LINK-3-UPDOWN: Interface FastEthernet1/0/1, changed state to down

Distribution2

00:55:06: STP: VLAN0010 Topology Change rcvd on Fa1/0/2
00:55:06: STP: VLAN0010 sent Topology Change Notice on Fa1/0/23

Выходные данные команды debug spanning-tree демонстрируют работу протокола STP в ситуации, когда соединение между коммутаторами Access1 и Distribution1 активно.

Access1

00:55:40: %LINK-3-UPDOWN: Interface FastEthernet0/1, changed state to up
00:55:43:  STP: PVST vlan 10 port Fa0/1 created, ext id 2E42430, vp 3389640
00:55:43: RSTP(10): initializing port Fa0/1
00:55:43: RSTP(10): Fa3/0/1 is now designated
00:55:43:  STP: PVST vlan 20 port Fa0/1 created, ext id 2E42430, vp 300EC20
00:55:43: RSTP(20): initializing port Fa0/1
00:55:43: RSTP(20): Fa0/1 is now designated
00:55:43: RSTP(10): transmitting a proposal on Fa0/1
00:55:43: RSTP(20): transmitting a proposal on Fa0/1
00:55:43: RSTP(10): transmitting a proposal on Fa0/1
00:55:43: RSTP(20): transmitting a proposal on Fa0/1
00:55:43: RSTP(10): updt roles, received superior bpdu on Fa0/1
00:55:43: RSTP(10): Fa0/1 is now root port
00:55:43: RSTP(10): Fa0/2 blocked by re-root
00:55:43: RSTP(10): Fa0/2 is now alternate
00:55:44: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, cha
nged state to up
00:55:44: RSTP(20): updt roles, received superior bpdu on Fa0/1
00:55:44: RSTP(20): Fa0/1 is now alternate

Distribution1

00:55:49: %LINK-3-UPDOWN: Interface FastEthernet1/0/1, changed state to up
00:55:50: set portid: VLAN0010 Fa1/0/1: new port id 8001
00:55:50:  STP: PVST vlan 10 port Fa1/0/1 created, ext id 2DA13A8, vp 3BDB708
00:55:50: STP: VLAN0010 Fa1/0/1 -> listening
00:55:50: set portid: VLAN0020 Fa1/0/1: new port id 8001
00:55:50:  STP: PVST vlan 20 port Fa1/0/1 created, ext id 2DA13A8, vp 3C06F20
00:55:50: STP: VLAN0020 Fa1/0/1 -> listening
00:55:51: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet1/0/1,
changed state to up
00:56:05: STP: VLAN0010 Fa1/0/1 -> learning
00:56:05: STP: VLAN0020 Fa1/0/1 -> learning
00:56:20: STP: VLAN0010 Fa1/0/1 -> forwarding
00:56:20: STP: VLAN0020 sent Topology Change Notice on Fa1/0/24
00:56:20: STP: VLAN0020 Fa1/0/1 -> forwarding

!--- This output is evident that the Access1 switch waits for the 
!--- standard 802.1D Spanning Tree process of listening, learning and forwarding
!--- to complete in Distribution1.




Distribution2

00:55:06: STP: VLAN0020 Topology Change rcvd on Fa1/0/24
00:56:06: STP: VLAN0020 Topology Change rcvd on Fa1/0/24

!--- This output shows that Distribution2 is notified
!--- about the indirect link outage by TCN BPDUs.

Выходные данные отладки — режим Rapid-PVST+

Коммутаторы Distribution1, Distribution2 и Access1 находятся в режиме Rapid-PVST+. Выходные данные команды debug spanning-tree демонстрируют работу протокола STP при отказе соединения между коммутаторами Access1 и Distribution1.

Access1

01:31:04: RSTP(10): updt roles, root port Fa0/1 going down
01:31:04: RSTP(10): Fa0/2 is now root port
01:31:06: %LINK-5-CHANGED: Interface FastEthernet0/1, changed state to adminis
tratively down
01:31:07: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, cha
nged state to down

Distribution1

01:31:13: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet1/0/1,
changed state to down
01:31:14: %LINK-3-UPDOWN: Interface FastEthernet1/0/1, changed state to down

Выходные данные команды debug spanning-tree демонстрируют работу протокола STP в ситуации, когда соединение между коммутаторами Access1 и Distribution1 активно.

Access1

01:35:46: %LINK-3-UPDOWN: Interface FastEthernet0/1, changed state to up
01:35:48:  STP: PVST vlan 10 port Fa3/0/1 created, ext id 2E42430, vp 3C8E360
01:35:48: RSTP(10): initializing port Fa3/0/1
01:35:48: RSTP(10): Fa3/0/1 is now designated
01:35:48:  STP: PVST vlan 20 port Fa3/0/1 created, ext id 2E42430, vp 3C8E3E0
01:35:48: RSTP(20): initializing port Fa3/0/1
01:35:48: RSTP(20): Fa3/0/1 is now designated
01:35:48: RSTP(10): updt roles, received superior bpdu on Fa3/0/1
01:35:48: RSTP(10): Fa3/0/1 is now root port
01:35:48: RSTP(10): Fa3/0/2 blocked by re-root
01:35:48: RSTP(10): synced Fa3/0/1
01:35:48: RSTP(10): Fa3/0/2 is now alternate
01:35:48: RSTP(20): updt roles, received superior bpdu on Fa3/0/1
01:35:48: RSTP(20): Fa3/0/1 is now alternate
01:35:48: RSTP(10): transmitting an agreement on Fa3/0/1 as a response to a prop
osal

Distribution1

01:35:55: %LINK-3-UPDOWN: Interface FastEthernet1/0/1, changed state to up
01:35:56:  STP: PVST vlan 10 port Fa1/0/1 created, ext id 2DA13A8, vp 3BDCCD8
01:35:56: RSTP(10): initializing port Fa1/0/1
01:35:56: RSTP(10): Fa1/0/1 is now designated
01:35:56:  STP: PVST vlan 20 port Fa1/0/1 created, ext id 2DA13A8, vp 2D21C60
01:35:56: RSTP(20): initializing port Fa1/0/1
01:35:56: RSTP(20): Fa1/0/1 is now designated
01:35:56: RSTP(10): transmitting a proposal on Fa1/0/1
01:35:56: RSTP(20): transmitting a proposal on Fa1/0/1
01:35:56: RSTP(10): received an agreement on Fa1/0/1
01:35:57: RSTP(20): transmitting a proposal on Fa1/0/1
01:35:59: RSTP(20): transmitting a proposal on Fa1/0/1
01:36:01: RSTP(20): transmitting a proposal on Fa1/0/1
01:36:03: RSTP(20): transmitting a proposal on Fa1/0/1
01:36:06: RSTP(20): transmitting a proposal on Fa1/0/1
01:36:08: RSTP(20): transmitting a proposal on Fa1/0/1
01:36:10: RSTP(20): transmitting a proposal on Fa1/0/1
01:36:11: RSTP(20): Fa1/0/1 fdwhile Expired
01:36:12: RSTP(20): transmitting a proposal on Fa1/0/1
01:36:14: RSTP(20): transmitting a proposal on Fa1/0/1
01:36:16: RSTP(20): transmitting a proposal on Fa1/0/1
01:36:18: RSTP(20): transmitting a proposal on Fa1/0/1
01:36:20: RSTP(20): transmitting a proposal on Fa1/0/1
01:36:22: RSTP(20): transmitting a proposal on Fa1/0/1
01:36:24: RSTP(20): transmitting a proposal on Fa1/0/1
01:36:26: RSTP(20): transmitting a proposal on Fa1/0/1
01:36:26: RSTP(20): Fa1/0/1 fdwhile Expired

!--- Distribution1 puts the port Fa1/0/1 as designated for VLANs 10 and 20.
!--- It also proposes that Fa1/0/1 is designated for VLANs 10, 20. Access1 agrees with the 
!--- proposal for VLAN10. However, it does not agree with the proposal for VLAN20 because it  
!--- has the superior BPDU for VLAN20 from Distribution2.

Проверка

Используйте этот раздел для проверки правильности работы конфигурации.

Инструмент Output Interpreter Tool (registered customers only) (OIT) поддерживает некоторые команды выходных данных show. Используйте OIT для просмотра и анализа выходных данных команд show.

Рекомендуется проверять топологию STP при каждом изменении конфигурации.

Убедитесь, что коммутатор Distribution1 является корневым мостом для сети VLAN передачи данных. Кроме того, убедитесь, что путь пересылки STP соответствует пути на схеме сети.

Distribution1#show spanning-tree vlan 10

VLAN0010
  Spanning tree enabled protocol rstp
  Root ID    Priority    24586
             Address     0015.63f6.b700
             This bridge is the root
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    24586  (priority 24576 sys-id-ext 10)
             Address     0015.63f6.b700
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time 300

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Fa1/0/1          Desg FWD 19        128.1    P2p
Fa1/0/3          Desg FWD 19        128.3    P2p
Fa1/0/5          Desg FWD 19        128.5    P2p
Fa1/0/23         Desg FWD 19        128.23   P2p
Fa1/0/24         Desg FWD 19        128.24   P2p


Access1#show spanning-tree summary
Switch is in rapid-pvst mode
Root bridge for: none
Extended system ID           is enabled
Portfast Default             is disabled
PortFast BPDU Guard Default  is enabled
Portfast BPDU Filter Default is disabled
Loopguard Default            is disabled
EtherChannel misconfig guard is enabled
UplinkFast                   is disabled
BackboneFast                 is disabled
Configured Pathcost method used is short

Name                   Blocking Listening Learning Forwarding STP Active
---------------------- -------- --------- -------- ---------- ----------

VLAN0010                     1         0        0          1          2
VLAN0020                     1         0        0          1          2
---------------------- -------- --------- -------- ---------- ----------
2 vlans                      2         0        0          2          4

Access2> (enable) show spantree 30
VLAN 30
Spanning tree mode          RAPID-PVST+
Spanning tree type          ieee
Spanning tree enabled

Designated Root             00-15-63-f6-b7-00
Designated Root Priority    24606
Designated Root Cost        19
Designated Root Port        3/3
Root Max Age   20 sec   Hello Time 2  sec   Forward Delay 15 sec

Bridge ID MAC ADDR          00-d0-00-50-30-1d
Bridge ID Priority          32768
Bridge Max Age 20 sec   Hello Time 2  sec   Forward Delay 15 sec

Port                     State         Role Cost      Prio Type
------------------------ ------------- ---- --------- ---- --------------------
 3/3                     forwarding    ROOT        19   32 P2P
 3/4                     blocking      ALTR        19   32 P2P

Access2> (enable) show spantree 40
VLAN 40
Spanning tree mode          RAPID-PVST+
Spanning tree type          ieee
Spanning tree enabled

Designated Root             00-15-c6-c1-30-00
Designated Root Priority    24616
Designated Root Cost        19
Designated Root Port        3/4
Root Max Age   20 sec   Hello Time 2  sec   Forward Delay 15 sec

Bridge ID MAC ADDR          00-d0-00-50-30-27
Bridge ID Priority          32768
Bridge Max Age 20 sec   Hello Time 2  sec   Forward Delay 15 sec

Port                     State         Role Cost      Prio Type
------------------------ ------------- ---- --------- ---- --------------------
 3/3                     blocking      ALTR        19   32 P2P
 3/4                     forwarding    ROOT        19   32 P2P


Services1#show spanning-tree vlan 100

VLAN0100
  Spanning tree enabled protocol rstp
  Root ID    Priority    24676
             Address     0015.63f6.b700
             Cost        18
             Port        7 (FastEthernet0/5)
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32868  (priority 32768 sys-id-ext 100)
             Address     0003.fd63.bb80
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time 300

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Fa0/5            Root FWD 18        128.7    P2p
Fa0/46           Desg FWD 19        128.50   P2p
Fa0/47           Desg FWD 19        128.51   P2p

Services1#show spanning-tree vlan 200

VLAN0200
  Spanning tree enabled protocol rstp
  Root ID    Priority    24776
             Address     0015.c6c1.3000
             Cost        37
             Port        51 (FastEthernet0/47)
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32968  (priority 32768 sys-id-ext 200)
             Address     0003.fd63.bb80
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time 300

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Fa0/5            Altn BLK 19        128.7    P2p
Fa0/46           Altn BLK 19        128.50   P2p
Fa0/47           Root FWD 19        128.51   P2p

Services2#show spanning-tree vlan 100

VLAN0100
  Spanning tree enabled protocol rstp
  Root ID    Priority    24676
             Address     0015.63f6.b700
             Cost        37
             Port        42 (GigabitEthernet0/42)
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32868  (priority 32768 sys-id-ext 100)
             Address     00d0.2bfc.7d80
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time 300

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Fa0/6            Altn BLK 19        128.6    P2p
Fa0/42           Root FWD 19        128.42   P2p
Fa0/43           Altn BLK 19        128.43   P2p

Services2#show spanning-tree vlan 200

VLAN0200
  Spanning tree enabled protocol rstp
  Root ID    Priority    24776
             Address     0015.c6c1.3000
             Cost        18
             Port        6 (GigabitEthernet0/6)
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32968  (priority 32768 sys-id-ext 200)
             Address     00d0.2bfc.7d80
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time 300

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Fa0/6            Root FWD 18        128.6    P2p
Fa0/42           Desg FWD 19        128.42   P2p
Fa0/43           Desg FWD 19         64.43   P2p

Поиск и устранение неполадок

Для этой конфигурации нет сведений об устранении неполадок.

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения


Document ID: 72836