Коммутаторы : Коммутаторы Cisco Catalyst серии 6500

Пример конфигурации для миграции STP с PVST+ на MST

7 апреля 2008 - Перевод, выполненный профессиональным переводчиком
Другие версии: PDF-версия:pdf | Машинный перевод (28 июля 2013) | Английский (13 декабря 2006) | Отзыв

Содержание

Введение
Предварительные условия
     Требования
     Используемые компоненты
     Условные обозначения
Общие сведения
Настройка
     Схема сети
     Конфигурации
     Конфигурация PVST+
     Изменение режима на MST
Проверка
Поиск и устранение неполадок
Связанные обсуждения сообщества поддержки Cisco
Дополнительные сведения

Введение

В документе представлен пример конфигурации для миграции STP с PVST+ на MST внутри кампусной сети.

Предварительные условия

Требования

Перед настройкой MST ознакомьтесь со статьей Общие сведения о протоколе MSTP (802.1s).

В таблице приведены сведения о поддержке MST в коммутаторах Catalyst и минимальные требования к ПО, необходимому для такой поддержки.

Платформа Catalyst

MST с RSTP

Catalyst 2900 XL и 3500 XL

Недоступна

Catalyst 2950 и 3550

Cisco IOS® 12.1(9)EA1

Catalyst 3560

Cisco IOS 12.1(9)EA1

Catalyst 3750

Cisco IOS 12.1(14)EA1

Catalyst 2955

Все версии Cisco IOS

Catalyst 2948G-L3 и 4908G-L3

Недоступно.

Catalyst 4000, 2948G и 2980G (Catalyst OS (CatOS))

7.1

Catalyst 4000 и 4500 (Cisco IOS)

12.1(12c)EW

Catalyst 5000 и 5500

Недоступна

Catalyst 6000 и 6500 (CatOS)

7.1

Catalyst 6000 и 6500 (Cisco IOS)

12.1(11b)EX, 12.1(13)E, 12.2(14)SX

Catalyst 8500

Недоступна

  • Catalyst 3550/3560/3750: реализация MST в версии Cisco IOS Release 12.2(25)SEC основывается на использовании спецификаций стандарта IEEE 802.1s. Реализации MST в более ранних версиях Cisco IOS являются достандартными.

  • Catalyst 6500 (IOS): реализация MST в версии Cisco IOS Release 12.2(18)SXF основывается на стандарте IEEE 802.1s. Реализации MST в более ранних версиях Cisco IOS являются достандартными.

Используемые компоненты

Этот документ разработан с использованием версий IOS 12.2(25) и CatOS 8.5(8), но конфигурация применима к минимальным версиями IOS, перечисленным в таблице.

Данные для документа были получены в специально созданных лабораторных условиях. Все устройства, используемые в этом документе, были запущены с чистой конфигурацией (конфигурацией по умолчанию). В рабочей сети необходимо изучить потенциальное воздействие всех команд.

Условные обозначения

Более подробную информацию о применяемых в документе обозначениях см. в статье Cisco Technical Tips Conventions (Условные обозначения, используемые в технической документации Cisco).

Общие сведения

Функция MST соответствует спецификациям стандарта IEEE 802.1s, являющегося расширением стандарта 802.1Q. MST распространяет алгоритм RST, описанный в стандарте 802.1w, на несколько экземпляров дерева STP. Это обеспечивает быструю конвергенцию и выравнивание нагрузки в среде VLAN. Протоколы PVST+ и Rapid-PVST+ используют отдельные экземпляры дерева STP для каждой сети VLAN. Среды MST позволяют объединять несколько сетей VLAN в один экземпляр. MST использует блоки BPDU 3, обратно совместимые с протоколом STP на базе IEEE 802.1D, в котором используются блоки BPDU 0.

Конфигурация протокола MSTP: конфигурация включает имя региона, номер версии и MST-таблицу назначения экземпляров сетей VLAN. Коммутатор для региона настраивается с помощью команды глобальной конфигурации spanning-tree mst configuration .

Регион MST: Регион MST состоит из связанных мостов с одинаковой конфигурацией MST. Число регионов MST в сети не ограниченно.

Экземпляры STP в регионе MST: экземпляр — это группа сетей VLAN, связанных командой spanning-tree mst configuration. По умолчанию все сети VLAN группируются в экземпляр IST0, который называется внутренним экземпляром дерева STP (IST). Вы можете вручную настроить экземпляры с номерами от 1 до 4094 и метками MSTn (n =1–4094), но регион поддерживает максимум 65 экземпляров. Некоторые версии поддерживают только 16 экземпляров. См. руководство по конфигурации ПО для своей платформы коммутатора.

IST/CST/CIST: IST — единственный экземпляр, который может получать и отправлять блоки BPDU в сети MST. Экземпляр MSTn является локальным для региона. IST разных регионов соединены через общий экземпляр дерева STP (CST). Совокупность IST в каждом регионе MST и объединяющего их экземпляра CST называются общим и внутренними экземплярами деревьев STP (CIST).

Обратная совместимость: протокол MST обратно совместим с протоколами PVST+, Rapid-PVST+ и достандартной версией MST (MISTP). Коммутатор MST соединяется с коммутаторами под управлением других протоколов STP (PVST+ и Rapid-PVST+) через общий экземпляр дерева STP (CST). Другие коммутаторы STP (PVST+ и Rapid-PVST+) видят весь регион MST как один коммутатор. При подключении коммутатора с достандартной версией MST к коммутатору со стандартной версией MST необходимо задать команду spanning-tree mst pre-standard для интерфейса коммутатора со стандартной версией MST .

Настройка

Этот пример состоит из двух разделов. В первом разделе приводится текущая конфигурация PVST+. Во втором разделе приводится конфигурация для перехода с PVST+ на MST.

Примечание: Используйте инструмент CommandLookup Tool (registered customers only) для получения информации о командах, используемых в этом разделе.

Схема сети

В этом документе используется следующая конфигурация сети:

Схема включает следующие коммутаторы:

  • Коммутаторы Distribution1 и Distribution2 на уровне распределения

  • Два коммутатора уровня доступа с именами Access1 (IOS) и Access2(CatOS)

  • Два коммутатора для объединения потоков серверов Services1 и Services2

Сети VLAN 10, 30 и 100 для передачи трафика данных. Сети VLAN 20, 40 и 200 для передачи голосового трафика

MST-1.gif

Конфигурации

В этом документе используются следующие конфигурации:

Конфигурация PVST+

Коммутаторы настраиваются в PVST+ для переноса голоса и данных в соответствии со схемой сети. Ниже приводится краткая сводка конфигурации:

  • Коммутатор Distribution1 настроен в качестве основного корневого моста для сетей VLAN передачи данных 10, 30 и 100 с помощью команды Distribution1(config)# spanning-tree vlan 10,30,100 root primary и в качестве вспомогательного корневого моста для голосовых сетей VLAN 20, 40 и 200 с помощью команды Distribution1(config)#spanning-tree vlan 20,40,200 root secondary .

  • Коммутатор Distribution2 настроен в качестве основного корневого моста для голосовых сетей VLAN 20, 40 и 200 с помощью команды Distribution2(config)# spanning-tree vlan 20,40,200 rootprimary и в качестве вспомогательного корневого моста для сетей VLAN передачи данных 10, 30 и 100 с помощью команды Distribution2(config)# spanning-tree vlan10,30,100 root secondary .

  • Команда spanning-tree backbonefast задана на всех коммутаторах для ускоренной конвергенции STP в случае отказа обходного канала.

  • Команда spanning-tree uplinkfast сконфигурирована на коммутаторах уровня доступа для ускоренной конвергенции STP в случае отказа прямого канала.

Distribution1

Distribution1#show running-config 
 Building configuration...
spanning-tree mode pvst
spanning-tree extend system-id
spanning-tree backbonefast
spanning-tree vlan 10,30,100 priority 24576
spanning-tree vlan 20,40,200 priority 28672
!
vlan 10,20,30,40,100,200
!
interface FastEthernet1/0/1
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 10,20
!
interface FastEthernet1/0/3
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 30,40
!
interface FastEthernet1/0/5
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 100,200
!
interface FastEthernet1/0/23
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 10,20,30,40,100,200
!
interface FastEthernet1/0/24
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 10,20,30,40,100,200
!
 !
 end

Вы можете видеть, что порт Fa1/0/24 настроен с помощью команды spanning-tree vlan 20,40,200 port-priority 64 . Коммутатор Distribution2 настроен как корневой мост для сетей VLAN 20, 40 и 200. Коммутатор Distribution2 поддерживает два соединения с коммутатором Distribution1: Fa1/0/23 и Fa1/0/24. Оба порта являются назначенными для сетей VLAN 20, 40 и 200, так как коммутатор Distribution2 — корневой мост этих сетей VLAN. Оба порта имеют одинаковый приоритет 128 (по умолчанию). Кроме того, два соединения с коммутатором Distribution1 имеют одинаковую стоимость с точки зрения портов fa1/0/23 и fa1/0/24. Коммутатор Distribution1 выбирает порт с наименьшим номером и переводит его в состоянии пересылки. Наименьший номер порта — Fa1/0/23, но в соответствии со схемой сети трафик голосовых сетей VLAN 20 и 40, 200 должен проходить через Fa1/0/24. Этого можно добиться следующими способами:

  1. Уменьшить стоимость порта Fa1/0/24 на коммутаторе Distribution1.

  2. Снизить приоритетность порта Fa1/0/24 на коммутаторе Distribution2.

В примере для пересылки трафика сетей VLAN 20, 40 и 200 через fa1/0/24 снижена приоритетность этого порта.

Distribution2

Distribution2#show running-config 
 Building configuration...
!
spanning-tree mode pvst
spanning-tree extend system-id
spanning-tree backbonefast
spanning-tree vlan 10,30,100 priority 28672
spanning-tree vlan 20,40,200 priority 24576
!
vlan 10,20,30,40,100,200
!
interface FastEthernet1/0/2
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 10,20
!
interface FastEthernet1/0/4
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 30,40
!
interface FastEthernet1/0/6
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 100,200
!
interface FastEthernet1/0/23
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 10,20,30,40,100,200
!
interface FastEthernet1/0/24
 switchport trunk encapsulation dot1q
 switchport mode trunk
 spanning-tree vlan 20,40,200 port-priority 64
 switchport trunk allowed vlan 10,20,30,40,100,200

end

Вы можете видеть, что на порте Fa0/5 коммутатора Services1 и портах Fa0/6 и Fa0/48 коммутатора Services2 настроена стоимость и приоритетность порта по протоколу STP. В данном случае протокол STP настроен так, что трафик сетей VLAN 100 и 200 коммутаторов Services1 и Services2 может передаваться через магистральные каналы между ними. Если не применить эту конфигурацию, коммутаторы Services1 и Services2 не будут передавать трафик через соединяющие их магистральные каналы. Вместо этого будет выбран путь между коммутаторами Distribution1 и Distribution2.

Коммутатор Services2 видит два пути с равной стоимостью к корневому мосту сети VLAN 100 (Distribution1): один через коммутатор Services1, другой через коммутатор Distribution2. Протокол STP выбирает лучший путь (корневой порт) в следующем порядке:

  1. Стоимость пути

  2. Идентификатор моста пересылающего коммутатора

  3. Порт с низшим приоритетом

  4. Внутренний порт с наименьшим номером

В этом примере два пути имеют одинаковую стоимость, но коммутатор Distribution2 (24576) имеет более низкий приоритет, чем Services1 (32768) для сети VLAN 100, поэтому коммутатор Services2 выбирает Distribution2. В этом примере для стоимости порта fa0/5 коммутатора Services1 задано более низкое значение, чтобы позволить коммутатору Services2 выбрать коммутатор Services1. Стоимость пути переопределяет значение приоритета пересылающего коммутатора.

Services1

Services1#show running-config 
 Building configuration...
spanning-tree mode pvst
spanning-tree portfast bpduguard default
spanning-tree extend system-id
spanning-tree backbonefast
!
vlan 100,200
!
interface FastEthernet0/5
 switchport trunk encapsulation dot1q
 switchport mode trunk
 spanning-tree vlan 100 cost 18
 switchport trunk allowed vlan 100,200
!
interface FastEthernet0/47
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 100,200
!
interface FastEthernet0/48
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 100,200
!
!
 end

Аналогичный метод используется, чтобы позволить коммутатору Services1 выбрать коммутатор Services2 для пересылки трафика сети VLAN 200. После уменьшения стоимости сети VLAN 200 на интерфейсе fa0/6 коммутатора Services2 коммутатор Services1 выберет интерфейс fa0/47 для пересылки трафика сети VLAN 200. Однако в этом случае необходимо пересылать трафик сети VLAN 200 через fa0/48. Этого можно добиться следующими способами:

  1. Уменьшить стоимость порта Fa0/48 на коммутаторе Services1.

  2. Снизить приоритетность порта Fa0/48 на коммутаторе Services2.

В примере для пересылки трафика сети VLAN 200 через fa0/48 снижена приоритетность этого порта.

Services2

Services2#show running-config 
 Building configuration...
spanning-tree mode pvst
spanning-tree portfast bpduguard default
spanning-tree extend system-id
spanning-tree backbonefast
!
vlan 100,200
!
interface FastEthernet0/6
 switchport trunk encapsulation dot1q
 switchport mode trunk
 spanning-tree vlan 200 cost 18
 switchport trunk allowed vlan 100,200
!
interface FastEthernet0/47
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 100,200
!
interface FastEthernet0/48
 switchport trunk encapsulation dot1q
 switchport mode trunk
 spanning-tree vlan 200 port-priority 64
 switchport trunk allowed vlan 100,200
!
 !
 end

Access1

Access1#show running-config 
 Building configuration...
!
spanning-tree mode pvst
spanning-tree portfast bpduguard default
spanning-tree extend system-id
spanning-tree uplinkfast
spanning-tree backbonefast
!
vlan 10,20
!
interface FastEthernet0/1
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 10,20
!
interface FastEthernet0/2
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 10,20
!
 end

Access2

Access2> (enable)show config all 

#mac address reduction
set spantree macreduction enable
!
#stp mode
set spantree mode pvst+
!
#uplinkfast groups
set spantree uplinkfast enable rate 15 all-protocols off
!
#backbonefast
set spantree backbonefast enable
!
#vlan parameters
set spantree priority 49152  1
set spantree priority 49152  30
set spantree priority 49152  40
!
#vlan(defaults)
set spantree enable  1,30,40
set spantree fwddelay 15     1,30,40
set spantree hello    2      1,30,40
set spantree maxage   20     1,30,40
!
#vtp
set vlan 1,30,40
!
#module 3 : 48-port 10/100BaseTX Ethernet
set trunk 3/3  on dot1q 30,40
set trunk 3/4  on dot1q 30,40
!
 end

Изменение режима на MST

Одновременный перевод всех коммутаторов корпоративной сети в режим MST — сложная задача. Обратная совместимость позволяет выполнить поэтапный перевод. Рекомендуется вносить изменения во время запланированных окон обслуживания, так как изменение конфигурации протокола STP прерывает потоки трафика. При включении MST также активируется протокол RSTP. Uplinkfast и Backbonefast — это функции PVST+. Они отключаются при включении MST, так как являются встроенными функциями PVST+, в то время как MST основывается на RSTP. Во время перехода можно удалить соответствующие команды из IOS. В catOS команды backbonefast и uplinkfast автоматически удаляются из конфигурации, но конфигурации таких функций, как PortFast, bpduguard, bpdufilter, root guard и loopguard применимы и в режиме MST. Использование этих функций будет таким же, как в режиме PVST+. Если вы уже включили эти функции в режиме PVST+, они останутся активными при миграции на режим Rapid-PVST+. При настройке MST следуйте правилам и ограничениям, перечисленным ниже:

  • Первый этап перехода на стандарт IEEE 802.1s/w состоит в правильном определении пограничных портов и портов "точка-точка". Убедитесь, что все каналы между коммутаторами, для которых необходимо быстрое изменение режима, являются полнодуплексными. Пограничные порты задаются с помощью функции PortFast.

  • Выберите имя конфигурации и номер версии, общие для всех коммутаторов в сети. Cisco рекомендует разместить максимально возможное число коммутаторов в одном регионе. Разбиение сети на регионы неэффективно.

  • Будьте внимательны при выборе числа экземпляров в коммутируемой сети, учтите что экземпляр преобразуется в логическую топологию. Не следует назначать сеть VLAN нулевому экземпляру. Выберите, какие сети VLAN назначить этим экземплярам, а затем задайте корневой мост и резервный корневой мост для каждого экземпляра.

  • Убедитесь, что магистральные каналы переносят трафик всех сетей VLAN, назначенных экземпляру, либо вообще не переносят трафик сетей VLAN для данного экземпляра.

  • MST может взаимодействовать со старыми мостами, которые работают под управлением PVST+ на уровне портов. Поэтому одновременное использование мостов обоих типов не является проблемой при ясном понимании принципов взаимодействия между ними. Старайтесь использовать экземпляры CST и IST внутри региона. При взаимодействии с мостом PVST+ через магистральный канал убедитесь, что мост MST является корневым для всех сетей VLAN, которые могут использовать данный магистральный канал. Не используйте мосты PVST в качестве корневых мостов CST.

  • Убедитесь, что все корневые мосты PVST имеют более низкий приоритет, чем корневой мост CST (соответствует более высокому численному значению).

  • Не отключайте протокол STP на любых сетей VLAN мостов PVST.

  • Не подключайте коммутаторы с каналами доступа, так как каналы доступа могут разделить сеть VLAN.

  • Любая операция настройки MST, охватывающая значительное количество существующих или новых логических портов сети VLAN, должна выполняться во время окна обслуживания, поскольку при каждом частичном изменении, таком как добавление новых сетей VLAN к экземплярам или перемещение сетей VLAN между экземплярами, производится переинициализация всей базы данных MST.

В этом примере кампусная сеть включает в себя один регион MST (region1) и два экземпляра MST: MST1 (сети VLAN передачи данных с номерами 10, 30 и 100) и MST2 (голосовые сети VLAN с номерами 20, 40 и 200). Вы можете видеть, что протокол MST выполняет только два экземпляра, а PVST+ — шесть экземпляров. Коммутатор Distribution1 выбран региональным корневым мостом CIST. Это значит, что коммутатор Distribution1 является корневым мостом IST0. Для распределения сетевого трафика в соответствии со схемой сети коммутатор Distribution1 настраивается как корневой мост для MST1 (экземпляр для сети VLAN передачи данных) и MST2 настраивается как корневой мост для MST2 (экземпляр для голосовых сетей VLAN).

Сначала необходимо изменить режим центральной сети, затем перейти к коммутаторам доступа. Перед изменением режима STP задайте конфигурацию MST на коммутаторах. Затем переведите тип STP на MST. В этом примере изменение режима выполняется в следующем порядке:

  1. Distribution1 и Distribution2

  2. Services1 и Services2

  3. Access1

  4. Access2

  1. Изменение режима Distribution1 и Distribution2:

    
    Distribution1 Configuration
    
    Distribution1(config)# spanning-tree mst configuration
    Distribution1(config-mst)# name region1
    Distribution1(config-mst)# revision 10
    Distribution1(config-mst)# instance 1 vlan 10, 30, 100
    Distribution1(config-mst)# instance 2 vlan 20, 40, 200
    Distribution1(config-mst)# exit
    Distribution1(config)# spanning-tree mst 0-1 root primary
    Distribution1(config)# spanning-tree mst 2 root secondary
    
    
    Distribution2 Configuration
    
    Distribution2(config)# spanning-tree mst configuration
    Distribution2(config-mst)# name region1
    Distribution2(config-mst)# revision 10
    Distribution2(config-mst)# instance 1 vlan 10, 30, 100
    Distribution2(config-mst)# instance 2 vlan 20, 40, 200
    Distribution2(config-mst)# exit
    Distribution2(config)# spanning-tree mst 2 root primary
    Distribution2(config)# spanning-tree mst 0-1 root secondary
    
    
    Ensure that trunks carry all the VLANs that are mapped to an instance
    
    
    Distribution1(config)# interface FastEthernet1/0/1
    Distribution1(config-if)#switchport trunk allowed vlan 10,20,30,40,100,200
    !
    Distribution1(config)#interface FastEthernet1/0/3
    Distribution1(config-if)# switchport trunk allowed vlan 10,20,30,40,100,200
    !
    Distribution1(config)#interface FastEthernet1/0/5
    Distribution1(config-if)# switchport trunk allowed vlan 10,20,30,40,100,200
    !
    Distribution1(config)#interface FastEthernet1/0/23
    Distribution1(config-if)# switchport trunk allowed vlan 10,20,30,40,100,200
    !
    Distribution1(config)#interface FastEthernet1/0/24
    Distribution1(config-if)# switchport trunk allowed vlan 10,20,30,40,100,200
    
    Distribution2(config)# interface FastEthernet1/0/2
    Distribution2(config-if)#switchport trunk allowed vlan 10,20,30,40,100,200
    !
    Distribution2(config)#interface FastEthernet1/0/4
    Distribution2(config-if)# switchport trunk allowed vlan 10,20,30,40,100,200
    !
    Distribution2(config)#interface FastEthernet1/0/6
    Distribution2(config-if)# switchport trunk allowed vlan 10,20,30,40,100,200
    !
    Distribution2(config)#interface FastEthernet1/0/23
    Distribution2(config-if)# switchport trunk allowed vlan 10,20,30,40,100,200
    !
    Distribution2(config)#interface FastEthernet1/0/24
    Distribution2(config-if)# switchport trunk allowed vlan 10,20,30,40,100,200
    
    
    STP Mode conversion
    
    Distribution1(config)# spanning-tree mode mst
    Distribution2(config)# spanning-tree mode mst
    
    
    MST tuning - to load balance data and voice vlan traffic
    
    Distribution2(config)# interface FastEthernet1/0/24
    Distribution2(config-if)# spanning-tree mst 2 port-priority 64
    
    
    PVST+ cleanup
    
    Distribution1(config)# no spanning-tree backbonefast
    Distribution2(config)# no spanning-tree backbonefast
    Distribution2(config)# interface FastEthernet1/0/24
    Distribution2(config-if)# no spanning-tree vlan 20,40,200 port-priority 64

    Примечание: Рекомендуется задать корневой мост MST0 вручную. В этом примере коммутатор Distribution1 выбран корневым мостом MST0 и, следовательно, является корневым мостом CIST.

    Теперь сеть имеет смешанную конфигурацию. Ее можно представить следующей схемой:

    MST-2.gif

    Коммутаторы Distribution1 и Distribution2 находятся в регионе MST с именем region1, и коммутаторы PVST+ видят регион region1 как один мост. Потоки трафика после повторной конвергенции показаны на схеме 2. Вы все еще можете настроить коммутаторы PVST+ (spanning-tree VLAN X cost) на распределение голосового трафика и трафика данных в соответствии со схемой 1. После изменения режима других коммутаторов (действия 2–4) вы получите окончательную топологию STP, соответствующую схеме 1.

  2. Изменение режима Services1 и Services2:

    
    Services1 Configuration
    
    Services1(config)#spanning-tree mst configuration
    Services1(config-mst)# name region1
    Services1(config-mst)# revision 10
    Services1(config-mst)# instance 1 vlan 10, 30, 100
    Services1(config-mst)# instance 2 vlan 20, 40, 200
    Services1(config-mst)#exit
    
    
    Services2 Configuration
    
    Services2(config)#spanning-tree mst configuration
    Services2(config-mst)# name region1
    Services2(config-mst)# revision 10
    Services2(config-mst)# instance 1 vlan 10, 30, 100
    Services2(config-mst)# instance 2 vlan 20, 40, 200
    Services2(config-mst)#exit
    
    
    Ensure that trunks carry all the VLANs that are mapped to an instance
    
    Services1(config)# interface FastEthernet0/5
    Services1(config-if)# switchport trunk allowed vlan 10,20,30,40,100,200
    !
    Services1(config)#interface FastEthernet0/47
    Services1(config-if)# switchport trunk allowed vlan 10,20,30,40,100,200
    !
    Services1(config)#interface FastEthernet0/48
    Services1(config-if)# switchport trunk allowed vlan 10,20,30,40,100,200
    !
    Services2(config)# interface FastEthernet0/6
    Services2(config-if)# switchport trunk allowed vlan 10,20,30,40,100,200
    !
    Services2(config)#interface FastEthernet0/47
    Services2(config-if)# switchport trunk allowed vlan 10,20,30,40,100,200
    !
    Services2(config)#interface FastEthernet0/48
    Services2(config-if)# switchport trunk allowed vlan 10,20,30,40,100,200
    
    
    
    STP Mode conversion
    
    Services1(config)#spanning-tree mode mst
    Services2(config)#spanning-tree mode mst
    
    
    MST tuning - to load balance data and voice vlan traffic
    
    Services1(config)# interface fastEthernet 0/46
    Services1(config-if)# spanning-tree mst 2 cost 200000
    Services1(config-if)# exit
    Services1(config)# interface fastEthernet 0/47
    Services1(config-if)# spanning-tree mst 2 cost 100000
    Services1(config-if)# exit
    
    Services2(config)#interface FastEthernet 0/6
    Services2(config-if)#spanning-tree mst 1 cost 500000
    Services2(config-if)# exit
    
    
    PVST+ cleanup
    
    Services1(config)# no spanning-tree uplinkfast
    Services1(config)# no spanning-tree backbonefast
    Services1(config)# interface FastEthernet0/5
    Services1(config-if)# no spanning-tree vlan 100 cost 18
    Services1(config-if)# exit
    
    Services2(config)# no spanning-tree uplinkfast
    Services2(config)# no spanning-tree backbonefast
    Services2(config)# interface FastEthernet0/6
    Services2(config-if)# no spanning-tree vlan 200 cost 18
    Services2(config-if)# exit
    Services2(config)# interface FastEthernet0/48
    Services2(config-if)# no spanning-tree vlan 200 port-priority 64
    Services2(config-if)# exit
  3. Изменение режима Access1:

    
    Access1 Configuration
    
    Access1(config)# spanning-tree mst configuration
    Access1(config-mst)# name region1
    Access1(config-mst)# revision 10
    Access1(config-mst)# instance 1 vlan 10, 30, 100
    Access1(config-mst)# instance 2 vlan 20, 40, 200
    Access1(config-mst)#exit
    
    
    Ensure that trunks carry all the VLANs that are mapped to an instance
    
    Access1(config)#interface FastEthernet0/1
    Access1(config-if)# switchport trunk allowed vlan 10,20,30,40,100,200
    !
    Access1(config)#interface FastEthernet0/2
    Access1(config-if)# switchport trunk allowed vlan 10,20,30,40,100,200
    
    STP mode conversion
    
    Access1(config)# spanning-tree mode mst
    
    
    PVST+ cleanup
    
    Access1(config)# no spanning-tree uplinkfast
    Access1(config)# no spanning-tree backbonefast
  4. Изменение режима Access2:

    
    Access2 Configuration
    
    Access2> (enable) set spantree mst config name region1 revision 10
    Edit Buffer modified.
    Use 'set spantree mst config commit' to apply the changes
    
    Access2> (enable) set spantree mst 1 vlan 10,30,100
    Edit Buffer modified.
    Use 'set spantree mst config commit' to apply the changes
    
    Access2> (enable) set spantree mst 2 vlan 20,40,200
    Edit Buffer modified.
    Use 'set spantree mst config commit' to apply the changes
    
    Access2> (enable) set spantree mst config commit
    
    
    Ensure that trunks carry all the VLANs that are mapped to an instance
    
    Access2> (enable)set trunk 3/3  on dot1q 10,20,30,40,100,200
    Access2> (enable)set trunk 3/4  on dot1q 10,20,30,40,100,200
    
    
    STP mode conversion
    
    Access2> (enable) set spantree mode mst
    PVST+ database cleaned up.
    Spantree mode set to MST.
    
    !--- Backbonefast and uplinkfast configurations will be cleaned up automatically
    
    
    

Проверка

Рекомендуется проверять топологию STP при каждом изменении конфигурации.

Убедитесь, что коммутатор Distribution1 является корневым мостом для сети VLAN передачи данных с номерами 10, 30 и 100 и что путь пересылки STP соответствует пути на схеме.

 Distribution1# show spanning-tree mst 0

##### MST0    vlans mapped:   1-9,11-19,21-29,31-39,41-99,101-199,201-4094
Bridge        address 0015.63f6.b700  priority      24576 (24576 sysid 0)
Root          this switch for the CIST
Operational   hello time 2 , forward delay 15, max age 20, txholdcount 6
Configured    hello time 2 , forward delay 15, max age 20, max hops    20

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Fa1/0/1          Desg FWD 200000    128.1    P2p
Fa1/0/3          Desg FWD 200000    128.3    P2p
Fa1/0/5          Desg FWD 200000    128.5    P2p 
Fa1/0/23         Desg FWD 200000    128.23   P2p
Fa1/0/24         Desg FWD 200000    128.24   P2p


Distribution1# show spanning-tree mst 1

##### MST1    vlans mapped:   10,30,100
Bridge        address 0015.63f6.b700  priority      24577 (24576 sysid 1)
Root          this switch for MST1

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Fa1/0/1          Desg FWD 200000    128.1    P2p
Fa1/0/3          Desg FWD 200000    128.3    P2p
Fa1/0/5          Desg FWD 200000    128.5    P2p 
Fa1/0/23         Desg FWD 200000    128.23   P2p
Fa1/0/24         Desg FWD 200000    128.24   P2p

Distribution1# show spanning-tree mst 2

##### MST2    vlans mapped:   20,40,200
Bridge        address 0015.63f6.b700  priority      28674 (28672 sysid 2)
Root          address 0015.c6c1.3000  priority      24578 (24576 sysid 2)
              port    Gi1/0/24        cost          200000    rem hops 4

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Gi1/0/1          Desg FWD 200000    128.1    P2p
Gi1/0/3          Desg FWD 200000    128.3    P2p
Gi1/0/23         Altn BLK 200000    128.23   P2p
Gi1/0/24         Root FWD 200000    128.24   P2p

Distribution2# show spanning-tree mst 0

##### MST0    vlans mapped:   1-9,11-19,21-29,31-39,41-99,101-199,201-4094
Bridge        address 0015.c6c1.3000  priority      28672 (28672 sysid 0)
Root          address 0015.63f6.b700  priority      24576 (24576 sysid 0)
              port    Fa1/0/23        path cost     0
Regional Root address 0015.63f6.b700  priority      24576 (24576 sysid 0)
                                      internal cost 200000    rem hops 19
Operational   hello time 2 , forward delay 15, max age 20, txholdcount 6
Configured    hello time 2 , forward delay 15, max age 20, max hops    20

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Fa1/0/2          Desg FWD 200000    128.54   P2p
Fa1/0/4          Desg FWD 200000    128.56   P2p
Fa1/0/6          Desg FWD 200000    128.58   P2p
Fa1/0/23         Root FWD 200000    128.75   P2p
Fa1/0/24         Altn BLK 200000    128.76   P2p

!--- CIST root is Distribution1. All the switches are in the same region "region1".
Hence in all the switches in the region1 you can see the path cost as 0.


Distribution2# show spanning-tree mst 1

##### MST1    vlans mapped:   10,30,100
Bridge        address 0015.c6c1.3000  priority      28673 (28672 sysid 1)
Root          address 0015.63f6.b700  priority      24577 (24576 sysid 1)
              port    Gi2/0/23        cost          200000    rem hops 1

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Gi2/0/2          Desg FWD 200000    128.54   P2p
Gi2/0/4          Desg FWD 200000    128.56   P2p
Gi2/0/23         Root FWD 200000    128.75   P2p
Gi2/0/24         Altn BLK 200000    128.76   P2p

Distribution2# show spanning-tree mst 2

##### MST2    vlans mapped:   20,40,200
Bridge        address 0015.c6c1.3000  priority      24578 (24576 sysid 2)
Root          this switch for MST2

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Gi2/0/2          Desg FWD 200000    128.54   P2p
Gi2/0/4          Desg FWD 200000    128.56   P2p
Gi2/0/6          Desg FWD 200000    128.58   P2p
Gi2/0/23         Desg FWD 200000    128.75   P2p
Gi2/0/24         Desg FWD 200000     64.76   P2p

Access2> (enable) show spantree mst 1
Spanning tree mode          MST
Instance                    1
VLANs Mapped:               10,30,100

Designated Root             00-15-63-f6-b7-00
Designated Root Priority    24577  (root priority: 24576, sys ID ext: 1)
Designated Root Cost        200000     Remaining Hops 19
Designated Root Port        3/3

Bridge ID MAC ADDR          00-d0-00-50-30-00
Bridge ID Priority          32769  (bridge priority: 32768, sys ID ext: 1)

Port                     State         Role Cost      Prio Type
------------------------ ------------- ---- --------- ---- --------------------
 3/3                     forwarding    ROOT    200000   32 P2P
 3/4                     blocking      ALTR    200000   32 P2P

Access2> (enable) show spantree mst 2
Spanning tree mode          MST
Instance                    2
VLANs Mapped:               20,40,200

Designated Root             00-15-c6-c1-30-00
Designated Root Priority    24578  (root priority: 24576, sys ID ext: 2)
Designated Root Cost        200000     Remaining Hops 19
Designated Root Port        3/4

Bridge ID MAC ADDR          00-d0-00-50-30-00
Bridge ID Priority          32770  (bridge priority: 32768, sys ID ext: 2)

Port                     State         Role Cost      Prio Type
------------------------ ------------- ---- --------- ---- --------------------
 3/3                     blocking      ALTR    200000   32 P2P
 3/4                     forwarding    ROOT    200000   32 P2P

Поиск и устранение неполадок

Для этой конфигурации нет сведений об устранении неполадок.

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения


Document ID: 72844