Módulos e interfaces de Cisco : Módulos de red de Cisco

Ejemplo de configuración de módulo de servicio EtherSwitch (ES)

17 Abril 2008 - Traducción manual
Otras Versiones: PDFpdf | Traducción Automática (13 Septiembre 2013) | Inglés (24 Junio 2008) | Comentarios

Contenido

Introducción
Requisitos previos
      Requerimientos
      Componentes utilizados
      Productos relacionados
      Convenciones
Módulos EtherSwitch: conceptos
Configuración
      Diagrama de la red
      Configuraciones
      Configuración inicial del módulo EtherSwitch
      Configuración de VTP y VLAN
      Configuración de árbol de expansión, tronco y canal de puerto
      Configuración de puertos de acceso
      Configuración de puerto de voz
      Configuración de enrutamiento
      Configuración de QoS
Verificación
Resolución de problemas
Discusiones relacionadas de la comunidad de soporte de Cisco

Introducción

Este documento proporciona un ejemplo de configuración para el módulo de servicio EtherSwitch instalado en el router de servicios integrados (ISR). Este documento no trata el ejemplo de configuración del módulo de red EtherSwitch.

Requisitos previos

Requerimientos

No hay requerimientos específicos para este documento.

Componentes utilizados

La información que contiene este documento se basa en las siguientes versiones de software y hardware:

  • Router de la serie 2800 de Cisco en software Cisco IOS® versión 12.4(10)

  • NME-16ES-1G-P: módulo de servicio EtherSwitch 10/100 de 16 puertos de Cisco

La información que contiene este documento se creó a partir de los dispositivos en un entorno de laboratorio específico. Todos los dispositivos que se utilizan en este documento se iniciaron con una configuración sin definir (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener cualquier comando.

Productos relacionados

Esta configuración se puede utilizar también con los routers de las series 2600/3600/3700/3800 de Cisco.

Consulte la tabla 6 de Módulos de servicio EtherSwitch de Cisco: hoja de datos (en inglés) para obtener más información.

Convenciones

Consulte Convenciones sobre consejos técnicos de Cisco para obtener más información sobre las convenciones del documento.

Módulos EtherSwitch: conceptos

Éstos son los dos tipos de módulos EtherSwitch disponibles para los ISR de Cisco:

  • Módulo de servicio EtherSwitch (ES): los módulos ES tienen sus propios procesadores, motores de conmutación, software y memoria Flash que se ejecutan independientemente de los recursos del router del host. Después de instalar el módulo ES en el router, puede conectar la consola al módulo ES en el router del host. A continuación, puede crear las VLAN, configurar VLAN, árbol de expansión y Protocolo de Terminal Virtual (VTP) desde el módulo ES. Los módulos ES se basan en la plataforma Catalyst 3750. Este documento muestra un ejemplo de configuración solamente para el módulo ES.

  • Módulo de red EtherSwitch (ESW): los módulos ESW se configuran mediante IOS de router. Estos módulos no ejecutan software independiente. Están integrados en IOS del router de host. Puede crear las VLAN, configurar VLAN, árbol de expansión y VTP desde el router del host. El router almacena el archivo de base de datos de VLAN (vlan.dat) en la memoria Flash.

Configuración

En esta sección encontrará la información para configurar las funciones descritas en este documento.

Nota: Utilice Command Lookup Tool (sólo para clientes registrados) para obtener más información acerca de los comandos utilizados en esta sección.

Diagrama de la red

En este documento se utiliza la siguiente configuración de red:

es-mod-config1.gif

Configuraciones

En este documento se utilizan las siguientes configuraciones:

Configuración inicial del módulo EtherSwitch

Después de la instalación del módulo ES en el router, podrá ver un nuevo valor de interfaz GigabitEthernet x/0 (donde x es el número de la ranura) reconocida por IOS. Este resultado se obtiene después de instalar el módulo ES en el router:

Router1#show ip interface brief
Interface                  IP-Address      OK? Method Status                Protocol

GigabitEthernet0/0         1.1.1.3         YES NVRAM  up                    down

GigabitEthernet0/1         unassigned      YES NVRAM  administratively down down

GigabitEthernet1/0         unassigned      YES unset  administratively down down

Vlan1                      unassigned      YES NVRAM  up                    up

El comando service-module gigabitEthernet x/0 session es el comando de modo EXEC con privilegios utilizado para conectar la consola al módulo ES desde el router del host. Debe conectar la consola al módulo ES para poder configurarlo. Para conectar la consola al módulo ES, es necesario configurar la dirección IP de la interfaz GigabitEthernet x/0. Si intenta conectar la consola al módulo sin asignarle una dirección IP, recibirá el siguiente mensaje de error:

Router1#service-module gigabitEthernet 1/0 session
IP address needs to be configured on interface GigabitEthernet1/0

Router1


Configure the host router to manage the ES module


Router1#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router1(config)#interface gigabitethernet 1/0

Router1(config-if)#ip address 172.16.1.1 255.255.255.0
Router1(config-if)#no shutdown
Router1(config-if)#exit
Router1(config)#exit


Console into the ES Module


Router1#service-module gigabitEthernet 1/0 session
Trying 172.16.1.1, 2066 ... Open

         --- System Configuration Dialog ---

Would you like to enter the initial configuration dialog? [yes/no]: no

Would you like to terminate autoinstall? [yes]:
Switch>enable
Switch#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Switch(config)#hostname Switch-ES
Switch-ES(config)#interface gigabitethernet 1/0/2

Switch-ES(config-if)#no switchport
Switch-ES(config-if)#ip address 172.16.1.2 255.255.255.0
Switch-ES(config-if)#exit

!--- GigabitEthernet 1/0/2 connects the ES module to the router.


Switch-ES(config)#line console 0
Switch-ES(config-line)#password a99l3
Switch-ES(config-line)#exec-timeout 30
Switch-ES(config-line)#exit
Switch-ES(config)#line vty 0 4
Switch-ES(config-line)#password a99l3
Switch-ES(config-line)#login
Switch-ES(config-line)#exec-timeout 30
Switch-ES(config-line)#exit

Este resultado muestra el comando show ip interface brief del módulo ES. La interfaz GigabitEthernet1/0/2 conecta el módulo ES a la interfaz GigabitEthernet1/0 del router del host.

Switch-ES#show ip int brief
Interface              IP-Address      OK? Method Status                Protocol
Vlan1                  unassigned      YES unset  administratively down down
FastEthernet1/0/1      unassigned      YES unset  down                  down
FastEthernet1/0/2      unassigned      YES unset  down                  down
FastEthernet1/0/3      unassigned      YES unset  down                  down
FastEthernet1/0/4      unassigned      YES unset  down                  down
FastEthernet1/0/5      unassigned      YES unset  down                  down
FastEthernet1/0/6      unassigned      YES unset  down                  down
FastEthernet1/0/7      unassigned      YES unset  down                  down
FastEthernet1/0/8      unassigned      YES unset  down                  down
FastEthernet1/0/9      unassigned      YES unset  down                  down
FastEthernet1/0/10     unassigned      YES unset  down                  down
FastEthernet1/0/11     unassigned      YES unset  down                  down
FastEthernet1/0/12     unassigned      YES unset  down                  down
FastEthernet1/0/13     unassigned      YES unset  down                  down
FastEthernet1/0/14     unassigned      YES unset  down                  down
FastEthernet1/0/15     unassigned      YES unset  down                  down
FastEthernet1/0/16     unassigned      YES unset  down                  down
GigabitEthernet1/0/1   unassigned      YES unset  down                  down
GigabitEthernet1/0/2   172.16.1.2      YES manual  up                    up

Si el módulo ES o los dispositivos conectados al módulo ES necesitan comunicarse con una red externa a través del router del host, este puerto (GigabitEthernet1/0/2) necesita ser el puerto de la capa 3 o necesita ser un miembro de la VLAN de la capa 3. Consulte la sección Configuración de enrutamiento de este documento para aprender a configurar el enrutamiento en el módulo ES.

Este diagrama explica la conectividad lógica del router del host y el módulo ES:

es-mod-config2.gif

Presione Ctrl+Shift+6 (Ctrl+Mayús+6) y luego X para volver al router del host.

Si necesita eliminar la sesión del router, ejecute el comando service-module gigabitEthernet x/0 session clear desde el modo EXEC con privilegios del router.

Configuración de VTP y VLAN

De forma predeterminada, el modo VTP es el servidor y el nombre de dominio VTP es nulo en el módulo ES. De forma predeterminada, todos los puertos pertenecen a VLAN1. En este ejemplo, hay un servidor DHCP (172.16.10.20) en vlan 10. El comando ip helper-address 172.16.10.20 se configura en todas las VLAN, excepto en la VLAN 10, para obtener las direcciones IP desde el servidor DHCP para los dispositivos localizados en esas VLAN.

Switch-ES


VTP Configuration

Switch-ES(config)#vtp mode transparent
Setting device to VTP TRANSPARENT mode.
Switch-ES(config)#vtp domain LAB
Changing VTP domain name from NULL to LAB
Switch-ES(config)#


Create VLANs


Switch-ES(config)#vlan 10,50,51,100,200
Switch-ES(config-vlan)#exit
Switch-ES(config)#



Configure VLANs


Switch-ES(config)#interface vlan 10
Switch-ES(config-if)#ip address 172.16.10.1 255.255.255.0
Switch-ES(config-if)#no shutdown

Switch-ES(config-if)#interface vlan 50
Switch-ES(config-if)#ip address 172.16.50.1 255.255.255.0
Switch-ES(config-if)#ip helper-address 172.16.10.20
Switch-ES(config-if)#no shutdown

Switch-ES(config-if)#interface vlan 51
Switch-ES(config-if)#ip address 172.16.51.1 255.255.255.0
Switch-ES(config-if)#ip helper-address 172.16.10.20
Switch-ES(config-if)#no shutdown

Switch-ES(config-if)#interface vlan 100
Switch-ES(config-if)#ip address 172.16.100.1 255.255.255.0
Switch-ES(config-if)#ip helper-address 172.16.10.20
Switch-ES(config-if)#no shutdown

Switch-ES(config-if)#interface vlan 200
Switch-ES(config-if)#ip address 172.16.200.1 255.255.255.0
Switch-ES(config-if)#ip helper-address 172.16.10.20
Switch-ES(config-if)#no shutdown

Switch-ES#show vlan

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa1/0/1, Fa1/0/2, Fa1/0/3
                                                Fa1/0/4, Fa1/0/7, Fa1/0/8
                                                Fa1/0/9, Fa1/0/10, Fa1/0/11
                                                Fa1/0/12, Fa1/0/13, Fa1/0/14
                                                Fa1/0/15, Fa1/0/16, Gi1/0/1
                                                Gi1/0/2
10   VLAN0010                         active
50   VLAN0050                         active
51   VLAN0051                         active
100  VLAN0100                         active

200  VLAN0200                         active
1002 fddi-default                     act/unsup
1003 token-ring-default               act/unsup
1004 fddinet-default                  act/unsup
1005 trnet-default                    act/unsup

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1    enet  100001     1500  -      -      -        -    -        0      0

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
10   enet  100010     1500  -      -      -        -    -        0      0
50   enet  100050     1500  -      -      -        -    -        0      0
51   enet  100051     1500  -      -      -        -    -        0      0
100  enet  100100     1500  -      -      -        -    -        0      0

200  enet  100200     1500  -      -      -        -    -        0      0
1002 fddi  101002     1500  -      -      -        -    -        0      0
1003 tr    101003     1500  -      -      -        -    -        0      0
1004 fdnet 101004     1500  -      -      -        ieee -        0      0
1005 trnet 101005     1500  -      -      -        ibm  -        0      0

Remote SPAN VLANs
------------------------------------------------------------------------------


Primary Secondary Type              Ports
------- --------- ----------------- ------------------------------------------
Switch-ES#show vtp status
VTP Version                     : 2
Configuration Revision          : 0
Maximum VLANs supported locally : 1005
Number of existing VLANs        : 10
VTP Operating Mode              : Transparent
VTP Domain Name                 : LAB
VTP Pruning Mode                : Disabled
VTP V2 Mode                     : Disabled
VTP Traps Generation            : Disabled
MD5 digest                      : 0x21 0x51 0xD5 0x4E 0x30 0xA5 0x46 0x3C
Configuration last modified by 0.0.0.0 at 10-27-06 18:28:10

Configuración de árbol de expansión, tronco y canal de puerto

Esta sección muestra la configuración de árbol de expansión del módulo ES y el switch Access1. Esta sección también muestra la configuración de canal de puerto y de tronco entre el módulo ES y el switch Access1. En este ejemplo, se configura el árbol de expansión rápida en todos los switches. El módulo ES está configurado como la raíz de árbol de expansión para todas las VLAN.

Switch-ES


Spanning-Tree Configuration

Switch-ES(config)#spanning-tree mode rapid-pvst
Switch-ES(config)#spanning-tree vlan 10,50,51,100,200 root primary


Trunk & Port Channel Configuration

Switch-ES(config)#interface port-channel 1
Switch-ES(config-if)#switchport trunk encapsulation dot1q
Switch-ES(config-if)#switchport mode trunk
Switch-ES(config-if)#switchport trunk allowed vlan 100,200
Switch-ES(config-if)#exit

Switch-ES(config)#interface range fastethernet 1/0/5-6
Switch-ES(config-if-range)#switchport trunk encapsulation dot1q
Switch-ES(config-if-range)#switchport mode trunk
Switch-ES(config-if-range)#switchport trunk allowed vlan 100,200
Switch-ES(config-if-range)#channel-group 1 mode on
Switch-ES(config-if-range)#exit

Access1


Access1 switch configuration



Access1(config)#vtp mode transparent
Setting device to VTP TRANSPARENT mode.

Access1(config)#vtp domain LAB
Changing VTP domain name from NULL to LAB

Access1(config)#vlan 100,200
Access1(config-vlan)#exit

Access1(config)#spanning-tree mode rapid-pvst

Access1(config)#interface port-channel 1
Access1(config-if)#switchport trunk encapsulation dot1q
Access1(config-if)#switchport mode trunk
Access1(config-if)#switchport trunk allowed vlan 100,200
Access1(config-if)#exit

Access1(config)#interface range FastEthernet 0/1 - 2
Access1(config-if-range)#switchport trunk encapsulation dot1q
Access1(config-if-range)#switchport mode trunk
Access1(config-if-range)#switchport trunk allowed vlan 100,200
Access1(config-if-range)#channel-group 1 mode on
Access1(config-if-range)#exit

Switch-ES#show spanning-tree summary
Switch is in rapid-pvst mode
Root bridge for: VLAN0001, VLAN0100, VLAN0200
Extended system ID           is enabled
Portfast Default             is disabled
PortFast BPDU Guard Default  is disabled
Portfast BPDU Filter Default is disabled
Loopguard Default            is disabled
EtherChannel misconfig guard is enabled
UplinkFast                   is disabled
BackboneFast                 is disabled
Configured Pathcost method used is short

Name                   Blocking Listening Learning Forwarding STP Active
---------------------- -------- --------- -------- ---------- ----------
VLAN0001                     0         0        0          1          1
VLAN0100                     0         0        0          1          1
VLAN0200                     0         0        0          1          1
---------------------- -------- --------- -------- ---------- ----------
3 vlans                      0         0        0          3          3
Switch-ES#show interface port-channel 1 trunk

Port        Mode         Encapsulation  Status        Native vlan
Po1         on           802.1q         trunking      1

Port      Vlans allowed on trunk
Po1         100,200

Port        Vlans allowed and active in management domain
Po1         100,200

Port        Vlans in spanning tree forwarding state and not pruned
Po1         100,200

Configuración de puertos de acceso

La configuración de puertos de acceso es similar a la configuración del switch LAN estándar.

Switch-ES


Configure the port for server

Switch-ES(config)#interface fastEthernet 1/0/7
Switch-ES(config-if)#switchport mode access
Switch-ES(config-if)#switchport access vlan 10
Switch-ES(config-if)#spanning-tree portfast
Switch-ES(config-if)#speed 100
Switch-ES(config-if)#duplex full
Switch-ES(config-if)#exit


Configure Port for Printer

Switch-ES(config)#interface fastethernet 1/0/8
Switch-ES(config-if)#switchport mode access
Switch-ES(config-if)#switchport access vlan 51
Switch-ES(config-if)#spanning-tree portfast
Switch-ES(config-if)#exit

Configuración de puerto de voz

La configuración de puerto de voz es similar a la configuración del switch LAN estándar.

Switch-ES


Configure the port for Voice

Switch-ES(config)#interface fastethernet 1/0/9
Switch-ES(config-if)#switchport mode access
Switch-ES(config-if)#switchport access vlan 51
Switch-ES(config-if)#switchport voice vlan 50
Switch-ES(config-if)#spanning-tree portfast

Configuración de enrutamiento

En este ejemplo se utilizan rutas estáticas para configurar el enrutamiento.

Switch-ES


Configure the default route

Switch-ES(config)#ip routing
Switch-ES(config)#ip route 0.0.0.0 0.0.0.0 172.16.1.1

Router1


Configure the route to LAN

Router1(config)#ip route 172.16.0.0 255.255.0.0 172.16.1.2

Configuración de QoS

En esta sección se utiliza la QoS automática para configurar la QoS. Consulte Informe oficial sobre AutoQoS de Cisco (en inglés) para obtener más información acerca de la QoS automática.

Switch-ES


Configure QoS on the port where IP phone is connected

Switch-ES(config)#interface fastethernet 1/0/9
Switch-ES(config-if)#auto qos voip cisco-phone
Switch-ES(config-if)#exit


Configure QoS on the uplink port to the host router.

Switch-ES(config)#interface gigabitEthernet 1/0/2
Switch-ES(config-if)#auto qos voip trust

Router1


Create Class map

Router1(config)#class-map match-any VoIP-Control
Router1(config-cmap)#match ip dscp AF31
Router1(config-cmap)#exit

Router1(config)#class-map match-any VoIP-RTP
Router1(config-cmap)#match ip dscp EF
Router1(config-cmap)#exit


Create Policy map

Router1(config)#policy-map Policy-VoIP
Router1(config-pmap)#class VoIP-RTP
Router1(config-pmap-c)#priority percent 70
Router1(config-pmap-c)#class VoIP-Control
Router1(config-pmap-c)#bandwidth percent 5
Router1(config-pmap-c)#class class-default
Router1(config-pmap-c)#fair-queue
Router1(config-pmap-c)#exit
Router1(config-pmap)#exit


Apply the policy on the interface connects to the ES Module

Router1(config)#interface gigabitEthernet 1/0
Router1(config-if)#service-policy output Policy-VoIP
Router1(config-if)#exit

Verificación

Actualmente, no hay ningún procedimiento de verificación disponible para esta configuración.

Resolución de problemas

Actualmente, no hay información específica disponible sobre resolución de problemas para esta configuración.


Discusiones relacionadas de la comunidad de soporte de Cisco

La Comunidad de Soporte de Cisco es un foro donde usted puede preguntar y responder, ofrecer sugerencias y colaborar con colegas.


Document ID: 82288